BabyLIN Library: BabyLINDLL Documentation

BabyLIN Library
  • Main Page
  • Chapters
  • Globals
BabyLINDLL Documentation

Table of Contents

  • General Information
  • BabyLIN DLL - New And Old API
    • Comparison Of Basic API Flow

These documents describe the BabyLIN-DLL C Interface of BabyLIN devices with CAN support and therefore mainly address developers not using the LinWorks SimpleMenu application to run simulations. Nevertheless, the General Information chapters might be interesting for all BabyLIN users as they describe the essential changes in the BabyLIN infrastructure.

The Return Values are the first chapter and can help with some of the issues.

Information about the BLC_sendCommand s command parameter can be found in the Commands chapter.

An Introduction to the Unified Access will help getting an over view over the internal data structures.

General Information

With the introduction of CAN support in BabyLIN devices, the changes in hardware cause basic changes in the LinWorks software as well as the BabyLIN-DLL structure. Previous BabyLIN devices were restricted to one LIN bus. This setup made it possible to use the USB connection to the device for handling the LIN bus ( refer picture Old BabyLIN structure ).

Old BabyLIN structure

The CAN support introduces devices with multiple bus interfaces (LIN and CAN). To distinguish between the bus interfaces, the BabyLIN structure represents each bus interface using a channel ( i.e. LIN-channel and CAN-channel ). Furthermore, the BabyLIN device itself provides a DEVICE-channel for configuration and status purposes. Picture New BabyLIN structure shows a USB connection with a LIN, two CAN and one DEVICE channel. These devices are called multi-channel-devices.

New BabyLIN structure

The channel-based design of the BabyLIN structure allows the user to use each channel in a similar way as in the old structure.

The introduction of channels leads to new specifications for all software components in the BabyLIN portfolio. First of all, the Session Description File (SDF) format has to provide configurations for different types of channels. This issue is addressed by introducing SDF-sections. A section within an SDF stores the configuration of exactly one channel. A SDF can store multiple sections. The sections will be mapped to a matching channel in the device upon download. The BabyLIN-DLL API has to provide an interface to the new structure and SDF format, as does the LinWorks software.

BabyLIN DLL - New And Old API

In order to provide a convenient way to use multi-channel-devices and reduce the overhead in application development, the API is designed to support both, new and old (legacy) API calls. All legacy API calls startet with the prefix BL_. These calls are deprecated but still work. The naming convention for new API calls provides the prefix BLC_ ( Baby-Lin-Can ). The following table shows how the devices and APIs may be combined:

API | Old BabyLIN Device | Multi-Channel-Device
Legacy | X | X
New | X | X
Note
It is possible to use legacy API-calls on multi-channel-devices, but in order to make use if the multi-channel-functionality, the new API functions have to be used.

This philosophy of API-calls allows the usage of multi-channel-devices with existing applications using the legacy API. In this case, the device will be used as an old, single-channel-device with only one LIN channel. On the other hand, when using an old, single-channel-device with the new API, the device will be handled as a device with a virtual DEVICE- and LIN-channel. Working on a channel representing a LIN- or CAN-BUS ( i.e. a BUS-channel ), is very similar to working with an old (single-channel) device connection. The main difference between legacy- and new API usage is the setup of the device connection with and without channel awareness.

Comparison Of Basic API Flow

The following pictures show an example flow of how the legacy- and new API work

Old BabyLIN Device | Multi-Channel-Device
Old BabyLIN API flow | New BabyLIN API flow
Generated on Fri May 30 2025 17:16:14 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: Chapters

  • Globals
Chapters
Here is a list of all modules:
[detail level 123456]
o Limitations | Lists all known limitations of DLL features
o Return Values | List of possible return values of BabyLINDLL functions
o Commands | Additional documentation for the command parameter of the BL_sendCommand and BLC_sendCommand functions
o SDF based logging | API to create log files from within a SDF
o Unified Access | In the Unified Access interface the available features and values are structured in a tree of objects
| o DLL Handle | The properties of the DLL Handle
| | o Log file | The properties of a log file
| | \ Date and time format | The format specifiers for string supporting date and time
| o SDF | The properties of a SDF Handle
| | \ Section | The properties of a Section Handle
| | o Signal | The properties of a Signal Handle
| | | \ Encoding Type | The property of an Encoding Type Handle
| | | \ Encoding Value | The properties of an Encoding Value Handle
| | o Frame | The properties of a Frame Handle
| | o Mapping | The properties of a Mapping Handle
| | o Node | The properties of a Node Handle
| | \ Macro | The properties of a Macro Handle
| | \ Macro Parameter | The properties of a Macro Parameter Handle
| \ Device | The properties of a Device Handle
| \ Channel | The properties of a Channel Handle
| \ Protocol ISO-TP | The properties of a Protocol ISO-TP Handle
| o First Frame Callback Object | The properties of the Temporary Object obtained in the Protocol ISO-TP 's 'ff_callback'
| o Service ISO-TP | The properties of a Service ISO-TP Handle
| o UDS Service ECUReset | The properties of a UDS ECUReset Handle. Also include all properties of Service ISO-TP Handles
| o UDS Service InputOutputControlByIdentifier | The properties of a UDS InputOutputControlByIdentifier Handle. Also include all properties of Service ISO-TP Handles
| o UDS Service ReadDataByIdentifier | The properties of a UDS ReadDataByIdentifier Handle. Also include all properties of Service ISO-TP Handles
| o UDS Service WriteDataByIdentifier | The properties of a UDS WriteDataByIdentifier Handle. Also include all properties of Service ISO-TP Handles
| o UDS Service AccessTimingParameter | The properties of a UDS AccessTimingParameter Handle. Also include all properties of Service ISO-TP Handles
| o UDS Service ClearDiagnosticInformation | The properties of a UDS ClearDiagnosticInformation Handle. Also include all properties of Service ISO-TP Handles
| o UDS Service CommunicationControl | The properties of a UDS CommunicationControl Handle. Also include all properties of Service ISO-TP Handles
| o UDS Service ControlDTCSetting | The properties of a UDS ControlDTCSetting Handle. Also include all properties of Service ISO-TP Handles
| o UDS Service DiagnosticSessionControl | The properties of a UDS DiagnosticSessionControl Handle. Also include all properties of Service ISO-TP Handles
| o UDS Service DynamicallyDefineDataIdentifier | The properties of a UDS DynamicallyDefineDataIdentifier Handle. Also include all properties of Service ISO-TP Handles
| o UDS Service LinkControl | The properties of a UDS LinkControl Handle. Also include all properties of Service ISO-TP Handles
| o UDS Service ReadDataByPeriodicIdentifier | The properties of a UDS ReadDataByPeriodicIdentifier Handle. Also include all properties of Service ISO-TP Handles
| o UDS Service ReadDTCInformation | The properties of a UDS ReadDTCInformation Handle. Also include all properties of Service ISO-TP Handles
| | o ReportNumberOfDTCByStatusMask | The specialized Prooperties of reportNumberOfDTCByStatusMask Subfuction ID 0x01
| | o ReportDTCByStatusMask | The specialized Prooperties of reportDTCByStatusMask Subfuction ID 0x02
| | o ReportDTCSnapshotIdentification | The specialized Prooperties of reportDTCSnapshotIdentification Subfuction ID 0x03
| | o ReportDTCSnapshotRecordByDTCNumber | The specialized Prooperties of reportDTCSnapshotRecordByDTCNumber Subfuction ID 0x04
| | o ReportDTCStoredDataByRecordNumber | The specialized Prooperties of reportDTCStoredDataByRecordNumber Subfuction ID 0x05
| | o ReportDTCExtDataRecordByDTCNumber | The specialized Prooperties of reportDTCExtDataRecordByDTCNumber Subfuction ID 0x06
| | o ReportNumberOfDTCBySeverityMaskRecord | The specialized Prooperties of reportNumberOfDTCBySeverityMaskRecord Subfuction ID 0x07
| | o ReportDTCBySeverityMaskRecord | The specialized Prooperties of reportDTCBySeverityMaskRecord Subfuction ID 0x08
| | o ReportSeverityInformationOfDTC | The specialized Prooperties of reportSeverityInformationOfDTC Subfuction ID 0x09
| | o ReportSupportedDTC | The specialized Prooperties of reportSupportedDTC Subfuction ID 0x0A
| | o ReportFirstTestFailedDTC | The specialized Prooperties of reportFirstTestFailedDTC Subfuction ID 0x0B
| | o ReportFirstConfirmedDTC | The specialized Prooperties of reportFirstConfirmedDTC Subfuction ID 0x0C
| | o ReportMostRecentTestFailedDTC | The specialized Prooperties of reportMostRecentTestFailedDTC Subfuction ID 0x0D
| | o ReportMostRecentConfirmedDTC | The specialized Prooperties of reportMostRecentConfirmedDTC Subfuction ID 0x0E
| | o ReportMirrorMemoryDTCByStatusMask | The specialized Prooperties of reportMirrorMemoryDTCByStatusMask Subfuction ID 0x0F
| | o ReportMirrorMemoryDTCExtDataRecordByDTCNumber | The specialized Prooperties of reportMirrorMemoryDTCExtDataRecordByDTCNumber Subfuction ID 0x10
| | o ReportNumberOfMirrorMemoryDTCByStatusMask | The specialized Prooperties of reportNumberOfMirrorMemoryDTCByStatusMask Subfuction ID 0x11
| | o ReportNumberOfEmissionsOBDDTCByStatusMask | The specialized Prooperties of reportNumberOfEmissionsOBDDTCByStatusMask Subfuction ID 0x12
| | o ReportEmissionsOBDDTCByStatusMask | The specialized Prooperties of reportEmissionsOBDDTCByStatusMask Subfuction ID 0x13
| | o ReportDTCFaultDetectionCounter | The specialized Prooperties of reportDTCFaultDetectionCounter Subfuction ID 0x14
| | o ReportDTCWithPermanentStatus | The specialized Prooperties of reportDTCWithPermanentStatus Subfuction ID 0x15
| | o ReportDTCExtDataRecordByRecordNumber | The specialized Prooperties of reportDTCExtDataRecordByRecordNumber Subfuction ID 0x16
| | o ReportUserDefMemoryDTCByStatusMask | The specialized Prooperties of reportUserDefMemoryDTCByStatusMask Subfuction ID 0x17
| | o ReportUserDefMemoryDTCSnapshotRecordByDTCNumber | The specialized Prooperties of reportUserDefMemoryDTCSnapshotRecordByDTCNumber Subfuction ID 0x18
| | o ReportUserDefMemoryDTCExtDataRecordByDTCNumber | The specialized Prooperties of reportUserDefMemoryDTCExtDataRecordByDTCNumber Subfuction ID 0x19
| | o ReportWWHOBDDTCByMaskRecord | The specialized Prooperties of reportWWHOBDDTCByMaskRecord Subfuction ID 0x42
| | \ ReportWWHOBDDTCWithPermanentStatus | The specialized Prooperties of reportWWHOBDDTCWithPermanentStatus Subfuction ID 0x55
| o UDS Service ReadMemoryByAddress | The properties of a UDS ReadMemoryByAddress Handle. Also include all properties of Service ISO-TP Handles
| o UDS Service ReadScalingDataByIdentifier | The properties of a UDS ReadScalingDataByIdentifier Handle. Also include all properties of Service ISO-TP Handles
| o UDS Service RequestDownload | The properties of a UDS RequestDownload Handle. Also include all properties of Service ISO-TP Handles
| o UDS Service RequestFileTransfer | The properties of a UDS RequestFileTransfer Handle. Also include all properties of Service ISO-TP Handles
| o UDS Service RequestTransferExit | The properties of a UDS RequestTransferExit Handle. Also include all properties of Service ISO-TP Handles
| o UDS Service RequestUpload | The properties of a UDS RequestUpload Handle. Also include all properties of Service ISO-TP Handles
| o UDS Service ResponseOnEvent | The properties of a UDS ResponseOnEvent Handle. Also include all properties of Service ISO-TP Handles
| o UDS Service RoutineControl | The properties of a UDS RoutineControl Handle. Also include all properties of Service ISO-TP Handles
| o UDS Service SecuredDataTransmission | The properties of a UDS SecuredDataTransmission Handle. Also include all properties of Service ISO-TP Handles
| o UDS Service SecurityAccess | The properties of a UDS SecurityAccess Handle. Also include all properties of Service ISO-TP Handles
| o UDS Service TesterPresent | The properties of a UDS TesterPresent Handle. Also include all properties of Service ISO-TP Handles
| o UDS Service TransferData | The properties of a UDS TransferData Handle. Also include all properties of Service ISO-TP Handles
| \ UDS Service WriteMemoryByAddress | The properties of a UDS WriteMemoryByAddress Handle. Also include all properties of Service ISO-TP Handles
o AdHoc Protocols | SDF like protocol handling from the API
o Connection Handling | List of BabyLIN connection handling and device information functions
o Command Functions | List of functions to send commands to a BabyLIN device
o Data Structures | List of BabyLIN structures
o Callback Handling | List of functions to manage callback functions
o Pull Functions | List of functions to pull retrieved data from a connection
o SDF Handling | List of functions to get information about the loaded SDF
o SDF functions | List of SDF functions
o Direct Mode operation | List of functions to access the LIN-BUS directly
o SDF scripting | Scripting language based on LUA for BabyLIN devices
| o Global scope | Functions and variables available in the global scope
| \ Function scope | Functions and variables available in the function scope
| o Print | Prints a given string
| o Sleep | Sleeps for a given time
| o Channel | Object representing a channel on the device
| \ Table | Object representing a table in the SDF
\ Legacy Parts | Backward compatibility functions
o Legacy Connection Handling | List of legacy BabyLIN connection handling function
o Legacy Command Functions | List of legacy functions to send commands to a BabyLIN device
o Legacy Data Structures | List of legacy BabyLIN structures
o Legacy Callback Handling | List of legacy functions to manage callback functions
o Legacy Pull Functions | List of legacy functions to pull retrieved data from a connection
o Legacy SDF Handling | List of legacy functions to get information about the loaded SDF
\ Legacy SDF Functions | List of legacy SDF functions
Generated on Fri May 30 2025 17:16:14 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: Limitations

Limitations

Limitations

In this chapter all known limitations of the BabyLIN library are listed.

Protocol Service Data Mapping

The services configurable via the Unified Access interface can not map more then 268435455 Bytes (~256 MB) in a single binary mapping.

UDS Services

The following UDS Services do not yet have named properties for data mappings: UDS Service ResponseOnEvent, UDS Service ReadDataByPeriodicIdentifier and UDS Service DynamicallyDefineDataIdentifier. Mapping data from and to those services requires you to use free mappings as described in Service ISO-TP
Generated on Fri May 30 2025 17:16:13 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: Return Values

Macros
Return Values

Detailed Description

The following values may be returned by BL_ and BLC_ functions to indicate the success or failure of an operation. Mostly, the functions will return BL_OK as an indicator for success. However, some functions use positive values to return the result of the function on success ( for example BL_getFrameCount will return the number of frames ).

Macros

#define | BL_OK 0
#define | SDF_OK 0
#define | BL_PC_SIDE_ERRORS -100000
#define | BL_RESOURCE_ERROR -100001
#define | BL_HANDLE_INVALID -100002
#define | BL_NO_CONNECTION -100003
#define | BL_SERIAL_PORT_ERROR -100004
#define | BL_CMD_SYNTAX_ERROR -100005
#define | BL_NO_ANSWER -100006
#define | BL_FILE_ERROR -100007
#define | BL_WRONG_PARAMETER -100008
#define | BL_NO_DATA -100009
#define | BL_NO_SDF -100010
#define | BL_DP_MSG_ERROR -100011
#define | BL_SIGNAL_NOT_EXISTENT -100012
#define | BL_SIGNAL_IS_SCALAR -100013
#define | BL_SIGNAL_IS_ARRAY -100014
#define | BL_SDF_INSUFFICIENT_FIRMWARE -100015
#define | BL_ENCODING_NOT_EXISTENT -100016
#define | BL_BUFFER_TOO_SMALL -100017
#define | BL_NO_ANSWER_DATA -100018
#define | BL_ANSWER_DATA_NOT_EXISTENT -100019
#define | BL_NO_CHANNELS_AVAILABLE -100020
#define | BL_UNKNOWN_COMMAND -100021
#define | BL_TIMEOUT -100022
#define | BL_SDF_INCOMPATIBLE -100023
#define | SDF_HANDLE_INVALID -100024
#define | SDF_IN_USE -100025
#define | BL_DOWNLOAD_IN_PROGRESS -100026
#define | BL_INVALID_MODE -100027
#define | BLC_UA_EXECUTION_FAILED -100093
#define | BLC_UA_INVALID_PARAMETER_COUNT -100094
#define | BLC_UA_GET_VALUE_REJECTED -100095
#define | BLC_UA_INVALID_PARAMETER -100096
#define | BLC_UA_NO_GETTER_DEFINED -100097
#define | BLC_UA_NO_SETTER_DEFINED -100098
#define | BLC_UA_SET_VALUE_REJECTED -100099
#define | BLC_UA_NOT_RESOLVABLE_TAG_FIRST -100100
#define | BLC_UA_NOT_RESOLVABLE_TAG_MAX -100200
#define | BLC_UA_NO_REQUEST_DATA -100201
#define | BLC_UA_SERVICE_FRAME_ORDER -100202
#define | BLC_UA_SERVICE_TIMEOUT_SEND -100203
#define | BLC_UA_SERVICE_TIMEOUT_RESPONSE -100204
#define | BLC_UA_SERVICE_TIMEOUT_FLOWCONTROL_SEND -100205
#define | BLC_UA_SERVICE_FLOWCONTROL_INVALIDSTATE -100206
#define | BLC_UA_SERVICE_FLOWCONTROL_WAITSTATES -100207
#define | BLC_UA_SERVICE_FLOWCONTROL_OVERFLOW -100208
#define | BLC_UA_SERVICE_TIMEOUT_FLOWCONTROL_RECEIVE -100209
#define | BLC_UA_SERVICE_FRAME_PACKAGING_ERROR -100210
#define | BLC_UA_REQUESTED_OBJECT_NOT_FOUND_FIRST -101100
#define | BLC_UA_REQUESTED_OBJECT_NOT_FOUND_MAX -101200
#define | BLC_ADHOC_INVALID_HANDLE -1
#define | BLC_ADHOC_EXECUTE_RUNNING -102000
#define | BLC_ADHOC_MCR_OFFSET 71000
#define | BLC_LUA_RUNTIME_ERROR -103000
#define | BL_ERR_SDF_HEADER 98
#define | BL_ERR_DP_CORRUPT 101
#define | BL_ERR_DP_SEQUENCE 102
#define | BL_ERR_DP_MAPPING 103
#define | BL_ERR_CHANNEL 104
#define | BL_ERR_SECTION_TYPE 105
#define | BL_ERR_NULLPOINTER 106
#define | BL_ERR_SECTION_MAPPING 107
#define | BL_ERR_DATAFLASH_INIT 108
#define | BL_ERR_DATAFLASH_INDEX 109
#define | BL_ERR_DATAFLASH_NOSPACE 110
#define | BL_ERR_DATAFLASH 111
#define | BL_ERR_LICENCE 112
#define | BL_ERR_HEAP_EXHAUSTED 113
#define | BL_ERR_SIG_REFERENCE 114
#define | BL_ERR_FRAME_REFERENCE 115
#define | BL_ERR_CFG_REFERENCE 116
#define | BL_ERR_MACROSEL_REFERENCE 117
#define | BL_ERR_EVENT_REFERENCE 118
#define | BL_ERR_SIGFUNC_REFERENCE 119
#define | BL_ERR_CRC 120
#define | BL_ERR_NOT_INITIALIZED 121
#define | BL_ERR_FRAMEID_LOOKUP_FAILED 122
#define | BL_ERR_MACRO_REFERENCE 130
#define | BL_ERR_PARAMVALUE 200
#define | BL_ERR_CONDITION 210
#define | BL_ERR_PARAMCOUNT 211
#define | BL_ERR_SERVICEQUEUE_EXHAUSTED 300
#define | BL_ERR_DP_PARSE 900
#define | BL_ERR_DP_PARSE_TOP 980
#define | BL_ERR_DP_ARRAY_SIZE 989
#define | BL_ERR_DP_NONAME 990
#define | BL_ERR_DP_NAME_TO_SHORT 991
#define | BL_ERR_DP_NAME_TO_LONG 992
#define | BL_CMD_NOT_SUPPORTED 997
#define | BL_ERR_UNDEF 998
#define | BL_ERR_UNKNOWN_CMD 999
#define | BL_OPERATION_PENDING -1
#define | BL_MACRO_STILL_RUNNING 150
#define | BL_MACRO_SAME_RUNNING 151
#define | BL_MACRO_OTHER_RUNNING 152
#define | BL_MACRO_START_FAIL 153
#define | BL_MACRO_NEVER_EXECUTED 154
#define | BL_MACRO_ERRCODE_IN_RESULT 155
#define | BL_MACRO_EXCEPTIONCODE_IN_RESULT 156

Macro Definition Documentation

#define BL_ANSWER_DATA_NOT_EXISTENT -100019

Additional data with given index/name not present

Definition at line 89 of file BabyLINReturncodes.h.

#define BL_BUFFER_TOO_SMALL -100017

The given buffer is too small

Definition at line 85 of file BabyLINReturncodes.h.

#define BL_CMD_NOT_SUPPORTED 997

Macro Command/Event Action is not known.

Definition at line 253 of file BabyLINReturncodes.h.

#define BL_CMD_SYNTAX_ERROR -100005

BabyLIN command syntax error.

Definition at line 61 of file BabyLINReturncodes.h.

#define BL_DOWNLOAD_IN_PROGRESS -100026

can not execute command because SDF download is in progress

Definition at line 104 of file BabyLINReturncodes.h.

#define BL_DP_MSG_ERROR -100011

Internal message format error

Definition at line 73 of file BabyLINReturncodes.h.

#define BL_ENCODING_NOT_EXISTENT -100016

The given signal has no encoding

Definition at line 83 of file BabyLINReturncodes.h.

#define BL_ERR_CFG_REFERENCE 116

Same as ERR_NULLPOINTER but Objects are restricted to Configurations.

Definition at line 215 of file BabyLINReturncodes.h.

#define BL_ERR_CHANNEL 104

The requested Action can not be carried out on the selected channel.

Definition at line 191 of file BabyLINReturncodes.h.

#define BL_ERR_CONDITION 210

Condition not be applied or is not full filled.

Definition at line 233 of file BabyLINReturncodes.h.

#define BL_ERR_CRC 120

The Loaded SDF is discarded because the checksum is wrong.

Definition at line 223 of file BabyLINReturncodes.h.

#define BL_ERR_DATAFLASH 111

Dataflash/persistent memory read or write error.

Definition at line 205 of file BabyLINReturncodes.h.

#define BL_ERR_DATAFLASH_INDEX 109

Dataflash/persistent memory does not keep requested SDF index.

Definition at line 201 of file BabyLINReturncodes.h.

#define BL_ERR_DATAFLASH_INIT 108

Dataflash/persistent memory could not be initialized.

Definition at line 199 of file BabyLINReturncodes.h.

#define BL_ERR_DATAFLASH_NOSPACE 110

Dataflash/persistent memory is to small to hold the SDF.

Definition at line 203 of file BabyLINReturncodes.h.

#define BL_ERR_DP_ARRAY_SIZE 989

Same as ERR_PARAMVALUE+x but only for Array Size.

Definition at line 244 of file BabyLINReturncodes.h.

#define BL_ERR_DP_CORRUPT 101

A corrupted DPMSG was received. This happens when a DPMessage contains an invalid identifier.

Definition at line 185 of file BabyLINReturncodes.h.

#define BL_ERR_DP_MAPPING 103

The SDF Section Type does not match the Channel Type it is loaded on to.

Definition at line 189 of file BabyLINReturncodes.h.

#define BL_ERR_DP_NAME_TO_LONG 992

Same as ERR_DP_CORRUPT. Happens when the message name field is longer then the entire message.

Definition at line 251 of file BabyLINReturncodes.h.

#define BL_ERR_DP_NAME_TO_SHORT 991

The DPMSG name is empty.

Definition at line 248 of file BabyLINReturncodes.h.

#define BL_ERR_DP_NONAME 990

The DPMSG does not start with a message name.

Definition at line 246 of file BabyLINReturncodes.h.

#define BL_ERR_DP_PARSE 900

Error Parsing a parameter of a DPMSG. The parameter index will be added onto resulting in the final Error code.

Definition at line 240 of file BabyLINReturncodes.h.

#define BL_ERR_DP_PARSE_TOP 980

Upper limit of the reserved ERR_DP_PARSE indices.

Definition at line 242 of file BabyLINReturncodes.h.

#define BL_ERR_DP_SEQUENCE 102

An unexpected DPMSG was received.

Definition at line 187 of file BabyLINReturncodes.h.

#define BL_ERR_EVENT_REFERENCE 118

Same as ERR_NULLPOINTER but Objects are restricted to Events.

Definition at line 219 of file BabyLINReturncodes.h.

#define BL_ERR_FRAME_REFERENCE 115

Same as ERR_NULLPOINTER but Objects are restricted to Frames.

Definition at line 213 of file BabyLINReturncodes.h.

#define BL_ERR_FRAMEID_LOOKUP_FAILED 122

Same as ERR_FRAME_REFERENCE.

Definition at line 227 of file BabyLINReturncodes.h.

#define BL_ERR_HEAP_EXHAUSTED 113

Not sufficient Heap Space to perform the requested action.

Definition at line 209 of file BabyLINReturncodes.h.

#define BL_ERR_LICENCE 112

Licence for the requested feature is not installed.

Definition at line 207 of file BabyLINReturncodes.h.

#define BL_ERR_MACRO_REFERENCE 130

Same as ERR_NULLPOINTER but Objects are restricted to Macros.

Definition at line 229 of file BabyLINReturncodes.h.

#define BL_ERR_MACROSEL_REFERENCE 117

Same as ERR_NULLPOINTER but Objects are restricted to MacroSelections.

Definition at line 217 of file BabyLINReturncodes.h.

#define BL_ERR_NOT_INITIALIZED 121

Same as ERR_SEQUENCE The requested Component is not yet initialized.

Definition at line 225 of file BabyLINReturncodes.h.

#define BL_ERR_NULLPOINTER 106

The Object you are trying to manipulate was never created.

Definition at line 195 of file BabyLINReturncodes.h.

#define BL_ERR_PARAMCOUNT 211

Invalid number of Parameters.

Definition at line 235 of file BabyLINReturncodes.h.

#define BL_ERR_PARAMVALUE 200

A parameter had an invalid value.

Definition at line 231 of file BabyLINReturncodes.h.

#define BL_ERR_SDF_HEADER 98

Missing or unknown SDF header. This Error occurs when a File is read that is not a SDF File.

Definition at line 183 of file BabyLINReturncodes.h.

#define BL_ERR_SECTION_MAPPING 107

The Section Type does not Match the Channel Type.

Definition at line 197 of file BabyLINReturncodes.h.

#define BL_ERR_SECTION_TYPE 105

The Section Type does not Match the Channel Type.

Definition at line 193 of file BabyLINReturncodes.h.

#define BL_ERR_SERVICEQUEUE_EXHAUSTED 300

No more Services can be enqueued because the Service queue is full.

Definition at line 237 of file BabyLINReturncodes.h.

#define BL_ERR_SIG_REFERENCE 114

Same as ERR_NULLPOINTER but Objects are restricted to Signals.

Definition at line 211 of file BabyLINReturncodes.h.

#define BL_ERR_SIGFUNC_REFERENCE 119

Same as ERR_NULLPOINTER but Objects are restricted to SignalFunctions.

Definition at line 221 of file BabyLINReturncodes.h.

#define BL_ERR_UNDEF 998

A not further specified Error.

Definition at line 255 of file BabyLINReturncodes.h.

#define BL_ERR_UNKNOWN_CMD 999

An unknown Command was received.

Definition at line 257 of file BabyLINReturncodes.h.

#define BL_FILE_ERROR -100007

Unable to open a file.

Definition at line 65 of file BabyLINReturncodes.h.

#define BL_HANDLE_INVALID -100002

Specified handle invalid.

Definition at line 55 of file BabyLINReturncodes.h.

#define BL_INVALID_MODE -100027

function can not be executed due to wrong mode or configuration

Definition at line 106 of file BabyLINReturncodes.h.

#define BL_MACRO_ERRCODE_IN_RESULT 155

Macro Result actually contains the error value.

Definition at line 271 of file BabyLINReturncodes.h.

#define BL_MACRO_EXCEPTIONCODE_IN_RESULT 156

Macro Result actually contains the exception value.

Definition at line 273 of file BabyLINReturncodes.h.

#define BL_MACRO_NEVER_EXECUTED 154

The initial Macro error value.

Definition at line 269 of file BabyLINReturncodes.h.

#define BL_MACRO_OTHER_RUNNING 152

No more parallel Macros are allowed.

Definition at line 265 of file BabyLINReturncodes.h.

#define BL_MACRO_SAME_RUNNING 151

The Macro can not be started, because the macro is still running.

Definition at line 263 of file BabyLINReturncodes.h.

#define BL_MACRO_START_FAIL 153

The Macro could not be started.

Definition at line 267 of file BabyLINReturncodes.h.

#define BL_MACRO_STILL_RUNNING 150

The Macro result can not be read, because the macro is still running.

Definition at line 261 of file BabyLINReturncodes.h.

#define BL_NO_ANSWER -100006

BabyLIN doesn't answer within timeout.

Definition at line 63 of file BabyLINReturncodes.h.

#define BL_NO_ANSWER_DATA -100018

There is no additional answer data present from last sendCommand-call

Definition at line 87 of file BabyLINReturncodes.h.

#define BL_NO_CHANNELS_AVAILABLE -100020

Device Supported no Channels

Definition at line 91 of file BabyLINReturncodes.h.

#define BL_NO_CONNECTION -100003

There is no connection open.

Definition at line 57 of file BabyLINReturncodes.h.

#define BL_NO_DATA -100009

No data available upon request.

Definition at line 69 of file BabyLINReturncodes.h.

#define BL_NO_SDF -100010

No SDF was loaded previously

Definition at line 71 of file BabyLINReturncodes.h.

#define BL_OK 0

Function successfully completed.

Definition at line 48 of file BabyLINReturncodes.h.

#define BL_OPERATION_PENDING -1

A not further specified Error.

Definition at line 259 of file BabyLINReturncodes.h.

#define BL_PC_SIDE_ERRORS -100000

Limit for separating BabyLIN- and PC-side errors; below there are all PC-side ones.

Definition at line 51 of file BabyLINReturncodes.h.

#define BL_RESOURCE_ERROR -100001

Internal resource allocation problem. Maybe out of memory/handles/etc.

Definition at line 53 of file BabyLINReturncodes.h.

#define BL_SDF_INCOMPATIBLE -100023

SDF can not be loaded to a the device due to incompatibility ( incompatible SDFV3 to SDFV2 device )

Definition at line 98 of file BabyLINReturncodes.h.

#define BL_SDF_INSUFFICIENT_FIRMWARE -100015

The SDF is unsupported by connected Baby-LIN due to insufficient firmware version

Definition at line 81 of file BabyLINReturncodes.h.

#define BL_SERIAL_PORT_ERROR -100004

Serial port couldn't be opened or closed.

Definition at line 59 of file BabyLINReturncodes.h.

#define BL_SIGNAL_IS_ARRAY -100014

The signal chosen is an array, but an scalar function was called

Definition at line 79 of file BabyLINReturncodes.h.

#define BL_SIGNAL_IS_SCALAR -100013

The signal chosen is a scalar, but an array function was called

Definition at line 77 of file BabyLINReturncodes.h.

#define BL_SIGNAL_NOT_EXISTENT -100012

The given signal_nr or name does not exist in loaded SDF

Definition at line 75 of file BabyLINReturncodes.h.

#define BL_TIMEOUT -100022

a sendCommand message timed out

Definition at line 95 of file BabyLINReturncodes.h.

#define BL_UNKNOWN_COMMAND -100021

Unknown command passed to sendCommand

Definition at line 93 of file BabyLINReturncodes.h.

#define BL_WRONG_PARAMETER -100008

Wrong parameter given to function.

Definition at line 67 of file BabyLINReturncodes.h.

#define BLC_ADHOC_EXECUTE_RUNNING -102000

Definition at line 168 of file BabyLINReturncodes.h.

#define BLC_ADHOC_INVALID_HANDLE -1

Definition at line 167 of file BabyLINReturncodes.h.

#define BLC_ADHOC_MCR_OFFSET 71000

Definition at line 169 of file BabyLINReturncodes.h.

#define BLC_LUA_RUNTIME_ERROR -103000

Definition at line 174 of file BabyLINReturncodes.h.

#define BLC_UA_EXECUTION_FAILED -100093

The number of parameters is not valid for this method.

Definition at line 109 of file BabyLINReturncodes.h.

#define BLC_UA_GET_VALUE_REJECTED -100095

the value could not be read. the reason should be documented in the help file.

Definition at line 113 of file BabyLINReturncodes.h.

#define BLC_UA_INVALID_PARAMETER -100096

One of the parameters is invalid. Like a null pointer in a BLC_getUnsignedNumber or a value, that is outside of the permitted range, like setting 256 on a 8bit Number property.

Definition at line 116 of file BabyLINReturncodes.h.

#define BLC_UA_INVALID_PARAMETER_COUNT -100094

The number of parameters is not valid for this method.

Definition at line 111 of file BabyLINReturncodes.h.

#define BLC_UA_NO_GETTER_DEFINED -100097

the property has no getter for that type e.g. a unsigned number can not be read from a Binary property.

Definition at line 119 of file BabyLINReturncodes.h.

#define BLC_UA_NO_REQUEST_DATA -100201

The Service ISO-TP, is supposed to send a request but has no request data.

Definition at line 133 of file BabyLINReturncodes.h.

#define BLC_UA_NO_SETTER_DEFINED -100098

the property has no setter for that type e.g. a callback can not be stored into Binary property.

Definition at line 122 of file BabyLINReturncodes.h.

#define BLC_UA_NOT_RESOLVABLE_TAG_FIRST -100100

A return value between BLC_UA_NOT_RESOLVABLE_TAG_FIRST and BLC_UA_NOT_RESOLVABLE_TAG_MAX indicates that the path parameter given to one of the BLC_UnifiedAccess functions could not be found. The index of that key is the return value - BLC_UA_NOT_RESOLVABLE_TAG_FIRST (this index is 0 based).

Definition at line 129 of file BabyLINReturncodes.h.

#define BLC_UA_NOT_RESOLVABLE_TAG_MAX -100200

The given Path should not have more then 100 tags

Definition at line 131 of file BabyLINReturncodes.h.

#define BLC_UA_REQUESTED_OBJECT_NOT_FOUND_FIRST -101100

A return value between BLC_UA_REQUESTED_OBJECT_NOT_FOUND_FIRST and BLC_UA_REQUESTED_OBJECT_NOT_FOUND_MAX indicates that the path parameter given to one of the BLC_UnifiedAccess functions could not be resolved. The index of the object, that could not be found is the return value - BLC_UA_REQUESTED_OBJECT_NOT_FOUND_FIRST (this index is 0 based).

Definition at line 160 of file BabyLINReturncodes.h.

#define BLC_UA_REQUESTED_OBJECT_NOT_FOUND_MAX -101200

The given Path should not have more then 100 objects

Definition at line 162 of file BabyLINReturncodes.h.

#define BLC_UA_SERVICE_FLOWCONTROL_INVALIDSTATE -100206

The flow-control state reported by the target is not one of the known states.

Definition at line 146 of file BabyLINReturncodes.h.

#define BLC_UA_SERVICE_FLOWCONTROL_OVERFLOW -100208

The flow-control state was "overflow"(0x2).

Definition at line 150 of file BabyLINReturncodes.h.

#define BLC_UA_SERVICE_FLOWCONTROL_WAITSTATES -100207

The flow-control state was "wait"(0x1) in more then max_flow_wait flow-control frames.

Definition at line 148 of file BabyLINReturncodes.h.

#define BLC_UA_SERVICE_FRAME_ORDER -100202

During the reception of the Response or the Request a frame timeout occurred.

Definition at line 135 of file BabyLINReturncodes.h.

#define BLC_UA_SERVICE_FRAME_PACKAGING_ERROR -100210

The data for a frame to send can not be put into a frame with the specified frame length.

Definition at line 154 of file BabyLINReturncodes.h.

#define BLC_UA_SERVICE_TIMEOUT_FLOWCONTROL_RECEIVE -100209

The flow-control was not issued by the other node.

Definition at line 152 of file BabyLINReturncodes.h.

#define BLC_UA_SERVICE_TIMEOUT_FLOWCONTROL_SEND -100205

A flow-control Frame send by the DLL was not echoed by the BabyLIN within timeout_frame milliseconds. You might have to do a disframe/mon_on with that FrameID.

Definition at line 144 of file BabyLINReturncodes.h.

#define BLC_UA_SERVICE_TIMEOUT_RESPONSE -100204

The Response was not received within timeout_response milliseconds. Maybe the Request is malformed?

Definition at line 141 of file BabyLINReturncodes.h.

#define BLC_UA_SERVICE_TIMEOUT_SEND -100203

A Frame send by the DLL was not echoed by the BabyLIN within timeout_frame milliseconds. You might have to do a disframe/mon_on with that FrameID.

Definition at line 138 of file BabyLINReturncodes.h.

#define BLC_UA_SET_VALUE_REJECTED -100099

the value given was not set. the reason should be documented in the help file.

Definition at line 124 of file BabyLINReturncodes.h.

#define SDF_HANDLE_INVALID -100024

value passed as a SDF handle is not valid

Definition at line 100 of file BabyLINReturncodes.h.

#define SDF_IN_USE -100025

SDF can not be unloaded as the SDF is in use on a device

Definition at line 102 of file BabyLINReturncodes.h.

#define SDF_OK 0

Definition at line 49 of file BabyLINReturncodes.h.

Generated on Fri May 30 2025 17:16:13 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: Commands

Commands

Available commands

BabyLIN commands to use in BL_- and BLC_sendCommand Functions

This chapter gives a brief overview of the available BabyLIN commands to use in the sendCommand functions of the BabyLIN API. The table uses statements in the following syntax:

Symbol | Description
[ ... ] | Optional parameter
<[type:]name> | Parameter "name" of type "type". If omitted, type defaults to an integer value
| | Exclusive "or" of parameters. The user may specify one parameter out of the list.
bold text | Reserved keyword. In the Response, these texts can be used as name parameter in calls to BLC_getAnswerByName and BLC_getAnswerTypeByName
(...) | A group of parameters, used together with the exclusive "or" for more complex message definitions.
{[min],[max]} | This indicates the repetition of the previous parameter or parameter group. min/max stands for the minimal/maximal amount of repetitions. If only one number is given it specified min and max value, thus the number of repetitions must match exactly.

The first response parameter will be returned by BLC_sendCommand or BL_sendCommand.
If in the column response is given OK/Err, this mean the first return value will indicates the operation result 0 = OK anything != 0 will typically be an error. To access the remaining response parameters use the functions BLC_getAnswerByIndex, BLC_getAnswerTypeByIndex, BLC_getAnswerByName or BLC_getAnswerTypeByName.

Generic Commands

Command | Response | Description | Supported Channel
version <version> Reads firmware version of Baby-LIN.
example of interpretation of "version":
decimal value 311 = V.3.11 		DEVICE
reset OK | Error
  • LIN: All loaded configurations are deleted, LIN bus operation stops immediately.
  • CAN: All loaded configurations are deleted, CAN controller is switched off.
DEVICE
reboot | OK | Error | Target will execute same operations as on Power-On Reset. Commands following this command might timeout until the Device is ready for communication again. The Devices internal states are changed and thus new devices might be in state in which they are emulating an old device for some time. | DEVICE
silence [<time>] OK | Err Set BabyLIN to silence mode for specified time [ms]
  • no time BabyLIN will stop sending frame-/signal- reports
  • time = 0: BabyLIN will send frame-/signal- reports
  • time = 1...n: BabyLIN will stop sending for n milliseconds
DEVICE
targetcfg_wr <idx> <value> | OK | Err | Writes the target configuration variable with index idx with the given value. idx may range in [0;63] | DEVICE
targetcfg_rd <idx> | <value> | Reads target configuration variable with index idx idx may range in [0;63] The available target configuration variables are listed in appendix 12.4. | DEVICE
targetid OK | Error
  • hwtype <hwtype>
  • version <version>
  • build <build>
  • flags <flags>
  • snum <snum>
  • heap <heap>
  • spare <channelCount>
  • name <name>
Request info about the BabyLIN device (target). Use the bold key words in calls to BLC_getAnswerByName and BLC_getAnswerTypeByName, or use BLC_getTargetID function to read this information.
The hwtype is the hardwaretype of the BabyLIN device. Might differ from the result of the hwtype command while a new device simulates an old one.
The version is the firmware version of the BabyLIN device.
The build is the firmware build number of the BabyLIN device.
The flags is a bit map currently only consisting of bit 0, which when set indicates, that the loaded firmware is a test version.
The snum is the serial number of the BabyLIN device.
The heap is the maximum heap size of the BabyLIN device.
The channelCount the number of channels available on the BabyLIN device.
The name is the name of the BabyLIN device.
DEVICE
hwtype | <hwtype> | Request the hardwaretype of the BabyLIN device. The hwtype is the true Hardwaretype of the BabyLIN device. This command is wrapped in BLC_getHWType. | DEVICE
licrd OK | Err
  • <optioncount>
  • (<optionnum> <flags>){0, optioncount}
Read status of activated BabyLIN options. Use BLC_getAnswerByIndex to read through the response parameters.
Response will carry <optioncount> pairs of option number and option flags.
flags & 0x80 = 0x80 => option is disabled. 		DEVICE
licwr <string: code> | OK | Err | Send an activation code for an option to the BabyLIN device. | DEVICE
licoffon <number> <offon> Ok | Err Enable or disable the installed licence with number <number>.
If <offon> is 0, the licence will be disabled.
If <offon> is 1, the licence will be enabled. 		DEVICE
tstampzero OK | Err This command will reset the targets absolute 32 bit us timestamp to zero.
Older target firmware version might not support this command. 		DEVICE
persistent_rd <number> OK | Error
  • <value of variable>
Read the value of device global accessible and persistent variable <number>. Use BLC_getAnswerByIndex to read through the response parameters. DEVICE
persistent_wr <number> [<value>] | Ok | Err | set the value of device global accessible and persistent variable <number> to value <value>. If <value> is omitted, the variable will be unset. | DEVICE
output <number> <onoff> OK|Err Set digital output state of ouptut <number> to
  • onoff = 1 output state "on"
  • onoff = 0 output state "off"
DEVICE
factoryreset | Ok | Err | Reset the device to it's factory state (i.e. remove all installed licences). This might also involve a Reset of the device. | DEVICE
ascii <timeout> | no response ! | Switches Baby-LIN to ASCII command API. See chapter ASCII command mode. The optional parameter timeout will cause the Baby-LIN unit to switch back to the DPMSG based API after the given timeout period elapsed without any character reception from the PC. The timeout is given in msec. | DEVICE
readspeed | <speed> | Read the actual used BUS speed. If this command is issued after a mon_init 0 command, return speed=0 until Baby-LIN managed to detect the actual bus speed. | LIN/CAN
writespeed <speed> | OK | Err | Sets bus speed to given value (bits/second), the value is not checked! On LIN buses The new speed is only applied after the next bus start command, and thus can only be used in SDF mode. | LIN/CAN
inject <flags> <frameid> [<datasize>] <bytearray:data> <delay> <count> [fill <fillbyte>] OK | Err

Inject a frame into the currently running schedule or CAN-simulation.

  • flags: Bitmask
    • LIN:
      • Bits[0,1] 0x3: Lin Checksum Version:
        • 1 : Classic Checksum
        • 2 : Extended Checksum
        • 3 : Undefined Checksum
      • Bit2 0x4: Read frame (Send only the header)
      • Bit3 0x8: Isolated Frame does not change data of SDF-Frames
    • CAN:
      • Bit0 0x1: Use a 29Bit frame Id
      • Bit1 0x2: CAN-FD frame format
      • Bit3 0x8: Isolated Frame does not change data of SDF-Frames
      • Bit4 0x10: Enable baudrate-switching, only apply together with CAN-FD frame format
  • frameid = Identifier of the frame
  • datasize = size of the frame to send, only required for read frames or if the frame length should diverge from the length of the length of the given <data> array. Readframes with empty datasize are not supported by CAN
  • data = Bytearray ( if LIN-Readframe leave empty and specify <datasize> )
  • delay = Slottime for injected frame in milliseconds [ms]. A slottime of 0 will automatically cumpute the minimal slottime.
  • count specifies the number of injected frames which have to be issued to the Baby-LIN, before the first injection will start. This parameter allows to issue multiple inject commands and to make sure that all frames will be injected consecutive. In such a case the first inject command might have a count value of 8, the other will have a count value of 0. The amount of Injects bufferable Is dependant on the device.
  • fillbyte is the padding byte value, that will be used if <datasize> is bigger then the length of <data>.

Readframe-example: "inject 0x05 20 6 [] 1000 0;" - Inject frame with ID 20 as Readframe. Use slottime 1000ms and send immediately. Expect 6 bytes as frame data with classic checksum.

SDFV2 devices do not support read frames

LIN/CAN
pullup <master | slave | auto > OK | Err Configures the LIN bus pull-up resistor of the Baby-LIN device:
  • master => pull-up set to 1.12kOhm
  • slave => pull-up set to 30kOhm
  • auto => pull-up automatically set by BabyLIN
If a SDF configuration is used, the pull-up selection will happen automatically, depending on the emulation data setup. In case of such an automatic configuration the command pull-up will override the automatic selection. When loading a SDF, or entering monitor mode using "mon_init", the BabyLIN will be reset to "pullup auto". 		LIN
forcechecksum <mode> OK | Err forces the LIN checksum generator to use a specific model independant from SDF information.
  • mode = 0: use SDF information
  • mode = 1: use classic checksum
  • mode = 2: use enhanced checksum
LIN
hwstate <status> Returns state of LIN Bus Voltage
  • status = 0: Bus supply is off
  • status = 1: Bus supply is present
LIN
status <status> Read status of referred channel, actually supported for LIN channels only, other channels always return 0.
  • 0 disconnected from bus
  • 1 sleep mode
  • 2 waking up
  • 3 detecting bus speed
  • 4 connecting to bus
  • 5 connected to bus
  • 6 disconnecting from bus
  • 7 entering sleep mode
LIN
wakeup [<duration>] OK | Err Manually wake up BabyLIN from sleep.
  • duration => The duration of the wakeup pulse in us. If <duration> is omitted, the value will be 500us.

LIN

rtcget OK | Err
  • Year
  • Month
  • Day of month
  • Hour
  • Minute
  • Second
  • Day of week
Return the RTC time of the device. Use BLC_getAnswerByIndex to read through the response parameters.

DEVICE

rtcset <year> <month> <dayOfMonth> <hour> <minute> <second> OK | Err Set the RTC time of the device.

DEVICE

tagwrite <tag_id> <tag_value> [<write_secret>] [<read_secret>] <value> | Err Writes the specified value into a custom tag in the device.
When the "read_secret" parameter is set, you need to set this secret every time you want to read the value using "tagread", or you will get an error.
When you set the "write_secret" parameter, you can only overwrite the value by specifing this secret again in the next "tagwrite" command.
To overwrite the current "write_secret" you need the use the string "OverwritePasswordWr=\<current write secret\>" as the "value" parameter and put the new "write_secret" into the "write_secret" parameter.

ANY

tagread <tag_id> [<read_secret>] OK | Err Reads the value of a custom tag stored in the device.
You might need to set the "read_secret" parameter, if the tag was written with a "read_secret" set.

ANY

Monitor Commands

Command | Response | Description | Supported Channel
mon_init <baudrate> [<mastermode/sendack> [<data_baudrate>]] OK | Err This command enables the Baby-LIN for non-SDF based operation. Once given, the following monitor commands will be available.
A previous loaded SDF configuration on this channel will be destroyed, configurations on other channels remain.
  • The baudrate parameter supplied is the baud rate for the bus. If this parameter is set to 0, the Baby-LIN will enter a hardware synchronisation mode, where it tries to auto-detect the speed of the bus. This will require active communication on the bus to work properly.
  • LIN:
    • If the optional parameter <mastermode> on LIN is given with a value of 1, the device will allow sending data in monitor mode.
  • CAN:
    • For CAN, the optional <sendack> parameter set to 1 will send ACKs for every CAN-frame on the bus.
    • The optional <data_baudrate> is only valid for CAN channels which support CAN-FD communication. It can only be specified together with the <sendack> parameter. This baud rate will be used during the data phase of a frame with active "baudrate switch" flag.
See also the mon_frame and inject commands, how to define the data for the frames sent in this mode.

Note: Baby-LIN-3-ECO/KS1
When using the SDF-based operation mode, issuing a bus start command will automatically enable the generator if no external bus voltage has been detected.
For this monitor mode, this is not done automatically. If you do not supply the bus externally, you can enable the generator by sending the command 'sysvar_wr @SYSCFG17 1' to the LIN channel.
LIN/CAN
mon_on <frameid> <mode> OK | Err The parameter supplied specifies the frame ID of the frame which should be monitored by the Baby-LIN device.
  • If ALL DEFINED frameIds should be monitored, bit 30 of the frameId should be set to 1 (i.e. frameId = 0x40000000 )
  • If ALL UNDEFINED frameIds should be monitored, bit 31 of the frameId should be set to 1 (i.e. frameId = 0x80000000 )
  • If ALL frameIds (defined and undefined) should be monitored, bit 31 and 30 of the frameId should be set to 1 (i.e. frameId = 0xC0000000 )
  • To denote a 29bit CAN-Frame-Id, set bit 29 ( mask 0x20000000 ).
Note: If all frames are monitored, it is not possible to use mon_off on single frame-ids. There is no "blacklisting" in "all-frame"-mode. For LIN channels monitoring of all frames can also be activated by setting frameid to 255. The optional mode parameter can have the following values:
  • mode = 0: same as mon_off (stop reporting)
  • mode = 1: report on every occurrence, this is the default
  • mode = 3: report only on change
LIN/CAN
mon_off <frameid> OK | Err Removes the given frame ID from the list of monitored frames,
  • If ALL DEFINED frameIds shouldn't be monitored, bit 30 of the frameId should be set to 1 (i.e. frameId = 0x40000000 )
  • If ALL UNDEFINED frameIds shouldn't be monitored, bit 31 of the frameId should be set to 1 (i.e. frameId = 0x80000000 )
  • If ALL frameIds (defined and undefined) shouldn't be monitored, bit 30 and 31 of the frameId should be set to 1 (i.e. frameId = 0xC0000000 )
  • To denote a 29bit CAN-Frame-Id, set bit 29 ( mask 0x20000000 ).
For LIN channels monitoring of all frames can also be disabled by setting frameid to 255. 		LIN/CAN
mon_frame <frameid> <flags> <datalength> [<data> {<datalength>}] OK | Err This command is intended to replace the "mon_set" and the "mon_type" command by a single command.
Its a complete frame definition including <data> bytes and attributes(<flags>) (LIN: checksum type, CAN: 11/29 Bit identifier).
The <data> is the data of the frame, as a list of <datalength> bytes.
In case the Baby-LIN is in monitor mastermode, it will send the frame, when the mon_xmit command with the correspondng frameid is received.
  • LIN: Bit[0] flags & 0x01 == 0 Classic checksum
  • LIN: Bit[0] flags & 0x01 == 1 Extended checksum
  • CAN: Bit[0] flags & 0x01 == 0 11 bit identifier
  • CAN: Bit[0] flags & 0x01 == 1 29 bit identifier
  • CAN: Bit[1,2] flags & 0x06 == 0 Regular CAN frame
  • CAN: Bit[1,2] flags & 0x06 == 2 CAN-FD frame
  • CAN: Bit[1,2] flags & 0x06 == 4 CAN-FD frame with bitrate switching
LIN/CAN
mon_xmit <frameId> [<slottime>] OK | Err Trigger frame transmit of Frame with id frameId.
On LIN channels setting slottime has no effect.
On CAN channels, slottime = 0 equals a single transmit, slottime > 0 equals cyclic transmission of frame.
  • To denote a 29bit CAN-Frame-Id, set bit 31 ( mask 0x80000000 ).
  • If a 29bit frame id has been introduced using mon_frame, the flag 29bit flag is not needed to trasmit a frame (if there is no 11bit frame with the same id)
  • slottime sets the time of a CAN frame and is currently unsupported for LIN bus
  • If more than one LIN frame is emitted with this command, a delay must be inserted manually
Note: Baby-LIN-3-ECO/KS1
When using the SDF-based operation mode, issuing a bus start command will automatically enable the generator if no external bus voltage has been detected.
For this monitor mode, this is not done automatically. If you do not supply the bus externally, you can enable the generator by sending the command 'sysvar_wr @SYSCFG17 1' to the LIN channel.
LIN/CAN
mon_unset <id> | OK | Err | Stops responding for frame <id>. | LIN/CAN
mon_reset OK | Err Removes all objects defined by mon_on and mon_set commands.
Configurations made with mon_init are also deleted. The LIN bus speed setting remains valid. 		LIN/CAN
mon_set <id> [<data>{0,1024}] OK | Err Sets ID and data bytes for a frame, which will be responded by Baby-LIN.
  • Up to 1024 <data> values can be given.
Deprecated! use mon_frame instead 		LIN
mon_type <LINversion> OK | Err Set LIN version (checksum calculation method) for frames defined by mon_set
  • LINversion = 1 LIN version V.1.2/1.3
  • LINversion = 2 LIN version V.2.0
Deprecated! use mon_frame instead 		LIN

SDF Related Commands

Command | Response | Description | Supported Channel
start [schedule <schedule_nr>] OK | Err Start BUS simulation.
On LIN channels,
  • "start schedule <schedule_nr>" will start the schedule with number schedule_nr.
  • "start" equals "start schedule 0".
  • "start schedule -1" will start the currently selected schedule and the schedule queue.
All signal values will be reset to the initial values given in the LDF/DBC file. 		LIN/CAN
stop | OK | Err | Stop BUS simulation. | LIN/CAN
sleep | OK | Err | Issue special Master Request frame ( LIN only ) and stop simulations | LIN
schedule <schedule_number> [<int:mode>] OK | Err Switch to schedule table specified by schedule_number. (Detailed description is work in progress) If a schedule is running, switching will be scheduled after the current frame's delay.
The BabyLIN hast o be configured as master.
  • Mode = -1: Keep current mode
  • Mode = 0: Cyclic (Default)
    Schedule Table will be run continuously, switching to another table will happen immediately. (DefaultMode)
  • Mode = 1: SingleRun
    A table with this attribute will run one time after the "schdeule idx" command. Then the system will wait for another schedule command. Up to 12 schedule commands can be issued without delays, as they will be queued.
  • Mode = 2: ExitOnComplete
    The schedule table with this attribute will run continuously, but if a switch to another schedule is requested, the switch will always happens after processing the last entry of this table.
LIN
schedmode <schedule_number> <int:mode> OK | Err Sets the scheduling mode for the given schedule table, without selecting it.
  • Mode = 0: Cyclic (Default)
    Schedule Table will be run continuously, switching to another table will happen immediately. (DefaultMode)
  • Mode = 1: SingleRun
    A table with this attribute will run one time after the "schdeule idx" command. Then the system will wait for another schedule command. Up to 12 schedule commands can be issued without delays, as they will be queued.
  • Mode = 2: ExitOnComplete
    The schedule table with this attribute will run continuously, but if a switch to another schedule is requested, the switch will always happens after processing the last entry of this table.
LIN
schedmode <schedule_number> OK | Err
  • <mode>
Get the scheduling mode for the given schedulde table. Use BLC_getAnswerByIndex to read through the response parameters.
  • Mode = 0: Cyclic (Default)
    Schedule Table will be run continuously, switching to another table will happen immediately. (DefaultMode)
  • Mode = 1: SingleRun
    A table with this attribute will run one time after the "schdeule idx" command. Then the system will wait for another schedule command. Up to 12 schedule commands can be issued without delays, as they will be queued.
  • Mode = 2: ExitOnComplete
    The schedule table with this attribute will run continuously, but if a switch to another schedule is requested, the switch will always happens after processing the last entry of this table.
The mode is available using the BLC_getAnswer* functions 		LIN
schedstate >0 | Err
  • <running>
  • <selected>
  • <queued>{0, 13}
On SDFV3 devices this command returns the schedule execution state. The return value is either 0 for OK or !=0 for an error. Use BLC_getAnswerByIndex to read through the response parameters.
  • running = 0: no schedule running; running = 1: schedules are running
  • selected: the currently running (if running = 1) - or next to run (if running = 0) - schedule
  • queued: a list of up to 13 schedule numbers queued. Queued schedules will run in their delivered order
On SDFV2 devices, this command returns the last or current schedule running as the return value (>=0) or an error as a return value <0 		LIN
setnodesimu <node_nr> <onoff> OK | Err Switches node emulation on/off during run time
  • LIN: all frames published by the given node will be simulated or not
  • CAN: only frames with slottime != 0 will be simulated, if publishing node is turned on
The <node_nr> can be derived from the node definition in the LDF: Example LDF: Nodes { Master: MasterECU,1.0000 ms,0.1000 ms; Slaves: Slave1Motor, Slave2Sensor; } The master node always has the node number 0. The 1st slave node (here Slave1Motor) has the Node_nr 1
The 2nd slave node (here Slave2Sensor) has the node_nr 2
etc... 		LIN/CAN
getnodesimu <noder_nr> <emulationstate> returns emulationstate (0/1) for given node
  • emulationstate = 0 the requested node is not simulated by Baby-LIN, so it should be connected in real
  • emulationstate = 1 the requested node is simulated by Baby-LIN, so it should not be connected in real
LIN/CAN
setsig <signal_number> <int:value | bytearray:array> | OK | Err | Set a new signal value, the value can be an int (scalar signal) or a bytearray ( for byte array signal ). BLC_setsig is defined as a wrapper for this command. | LIN/CAN
getsig <signal_number> <mode> OK | Err | Pending (-1)
<int64 signalvalue> 		Allows direct access to current signal values as they are in the device.
The signal is referenced by the signal_number, which is the SDF index of the related signal.
There are some calling variants, which are controlled by option <mode> parameter.
If the parameter mode is not present, mode = 0 is used as default mode.
  • mode = 0: Returns the last value written to the signal.
  • mode = 1: Returns no value but resets fresh flag in device, which will be set on next appearance of the signal on bus.
  • mode = 2: Return signal value as result, if fresh flag was set since last call with mode = 1,
    otherwise returns RETCODE_OPERATION_PENDING (-1).
Mode 1 and 2 are used in combination and make sense for bus signals only. The BLC_sendCommand (handle, "getsig....") is an alternative method to access a signal value.
The other methods are BLC_getNextSignal (..) which fetches the signal value from a signal report queue and the BLC_getSignalValueX (...) variants, which return the latest signal value, which came into the signal report queue.
The methods using the signal report queue need to activate the appropriate signal reporting with dissignal before they will work! 		LIN/CAN
addsig <signal_number> <int32:value> [<int64/uint64:min_value>] [<int64/uint64:max_value>] [<wrap_around>] OK | Err Adds a signed value to the value of the given signal. min_value determines the lower limit for value. max_value determines the upper limit for value. wrap_around determine the overflow behaviour.
  • wrap_around = 0, disabled.
  • wrap_around = 1, enabled.
LIN/CAN
freezesig <mode> OK | Err
  • mode = 1: deactivates signal update on setsig commands.
  • mode = 0: re-enables signal update, all signal values defined by previous setsig commands will be updated at the same time
LIn/CAN
dissignal <signal_number> <mode> OK | Err Enable signal reporting for the given signal. The given signal number is the signal index within the section.
  • mode=0 Switch off reporting.
  • mode=1 Send value every time signal it occurs on bus.
  • mode=3 Send value, only if change occurs.
LIN/CAN
nodissignal <signal_number> | OK | Err | Disable signal reporting for the given signal. | LIN/CAN
disframe <scope> <mode> OK | Err Enable frame reporting for the frames selected by the given <scope> parameter.
The parameter <scope> selects specific frames defined in SDF bus description by SDF frame number, or by frame identifier
On LIN the frame identifier can be a 6 Bit value on CAN ist can be a 11 or 29 Bit identifier.
Additional there are some scope variants which allow to select all knownFrames or unknown frames.
Known frames are the frames given in the corresponding bus description(LDF, DBC or ARXML).
Unknown frames are not includes in bus description, this might be frames created by injects or protocol commands
or in case of CAN, unknown frames might be sent by nodes not included in bus description

Bits[31:30:29] define the meaning of Bits[28...0] of value <scope>.
  • Bits[31:30:29] = 0:0:0 scope defined by bits [28...0] only
    • Bits[28..0] = frame number (SDF index) of referenced frame
    • LIN special cases (legacy format)
      • Bits[28..0] = 255 (0xff) all known frames will be in scope
      • Bits[28..0] >= 256 (0x100) the known frame with frameId = scope - 0x100 will be in scope
  • Bits[31:30:29] = 1:0:0 scope will include all unknown frames
    • Bits[28..0] dont' care
  • Bits[31:30:29] = 0:1:0 scope will include all known frames
    • Bits[28..0] dont' care
  • Bits[31:30:29] = 1:1:0 scope will include all known and all unknown frames
    • Bits[28..0] dont' care
  • Bits[31:30:29] = 0:0:1 scope defined by bits [31,28...0]
    • Bits[31,28..0] = selects known frame with frameId = (scope & 0x9FFFFFFF)
    • Bits[31] is used for CAN only and defines whether a standard/11Bit Id (=0) or extended/29Bit ID CAN frame is selected.
The <mode> parameter defines the frame reporting options to be applied to all frames in the given <scope>.
  • mode=0: Switch off reporting for all frames in <scope>.
  • mode=1: report frames everytime when they occur on bus.
  • mode=3: report known frames on changes only. For unknown frames this will be converted mode = 1 automatically in device.
Examples:
  • disframe 15 1 selects frame with SDF index for reporting, every time it occurs on bus
  • disframe 0xC0000000 1 selects all known and unknown frames for reporting if they occur on bus
  • disframe 0x20000000 1 selects known frame with frame id 14 for reporting, every time it occurs on bus
  • disframe 255 1 On LIN bus, this is legacy version of disframe 0x4000000 1 and seletcs all known frames.
LIN/CAN
nodisframe <scope> OK | Err Disable frame reporting for the frames in given <scope>.
Regarding the <scope> parameter refer to disframe command to see all special cases. The disframe <scope> 0 variant will do the same as the nodisframe <scope> command.
So we recommend to use disframe in nre peroject as nodisframe is deprecated. 		LIN/CAN
macro_exec <macro_nr/macro_name> [<long:value> {0, 10}] OK | Err Start execution of macro with given number <macro_nr>.
<value> the parameters of the macro to call. 		LIN/CAN
macro_result <macro_nr> <state>
  • <macro_nr>
  • <high>
  • <low>
Requests the result of the last execution of the macro with the given number <macro_nr>.
The <high> and <low> values form one 64 bit number, with <high> containing the upper part of the value.
If the <state> is 0 the value of the "__Return" signal is returned in the <high> and <low> values.
If the <state> is 155 the value of the "__Failure" signal is returned in the <high> and <low> values.
If the <state> is 156 the value of the exception, that terminated the macro execution, is returned in the <high> and <low> values.
For other <state> values consult the BabyLINReturncodes.h. 		LIN/CAN
macro_rstr <macro_nr> OK | Err
  • <macro_result_string>
Requests the result string of the macro with the given number <macro_nr>.
Each macro can store one macro result string. It can be set using the print macro command.
The value of the macro result string will not be automatically reset, when a macro is started.
Therefor it may contain a value from a previous run. 		LIN/CAN
macro_abort [<macro_nr>] | OK | Err | Stop execution of an active macro given by macro_nr. If macro_nr is omitted, abort all running macros. | LIN/CAN
frameset <frame_number> <-1/0/1/2/n> OK | Err frame_number is the SDF-index of the requested frame.
On a LIN-Channel, the second parameter is used to suspend or resume the transmission of this frame, when Baby-Lin is used as LIN bus master.
  • Frameset 0 0 will suspend the sending of the frame 0, the frame slot time remains intact
  • Frameset 0 1 will resume the sending of this frame (if it is available form the active schedule table)
  • Frameset 0 2 will suspend the sending of the frame 0, including frame slot time
On a CAN-Channel, the second parameter is used to suspend, single send or resume the transmission of this frame with a specific timeout.
  • Frameset 0 -1 will suspend the sending of the frame 0
  • Frameset 0 0 will send the frame exactly one time
  • Frameset 0 n will start sending the frame with n-milliseconds timeout
LIN/CAN
sigfuncmodify <sigfuncidx><start><end><modify><flags> OK | Err This commands redefines the parameters of a signals function given in the SDF.
The command should only be used on signal functions of type counter.
The command is supported for LIN channels only.
  • <sigfuncidx> identifies which signals function to change
  • <start> counter start value
  • <end> counnting end value
  • <modify> increment of counter <modify> == 0 will stop counter
  • <flags> 0x01 swap Bytes
LIN/CAN
auxout <outchannel> <outstate> OK | Err Will set the given output of the device to given state, not supported on all devices.
Outchannels on Baby-LIN-RM/RM-II:
  • 0...3 OUT1...OUT4
  • 4 Led F1
  • 5 Led F2
Earlier target firmware version supported this command on LIN channel only later this command was moved to DEVCIE channel. 		LIN/DEVICE
dtlmode <mode> OK | Err Sets mode of diagnistic support.
  • 0 = no DTL
  • 1 = DTL-Raw Mode
  • 2 = DTL-Cooked Mode
See also additional manual Baby-LIN API for Diagnostic Modes (UM_BabyLIN_DIAG_E.pdf) 		LIN
varwr <mode> <signal index> [<length>] <value> OK | Err Writes <value> into the array, starting at <signal index>. <mode> defines, what kind of input for <value> is expected:
  • Mode 0: <value> has to be a list of number in the format: '[ value1 value2 valueN ]'. <length> can not be used in this mode.
    Example: 'varwr 0 23 [ 1 2 3 4]' would write "1..4" in the signals starting at index 23.
  • Mode 1: <value> has to be a string with escape sequences allowed. <length> can not be used in this mode.
    Example: 'varwr 1 23 "AB\03D"' would write the values 65, 66, 3, 67 (ASCII values of "AB[...]C" in the signals. "\03" is an escape sequence for the hex value 0x03.
  • Mode 2: requires the parameter <length>. <value> has to be a single number.
    Example: 'varwr 2 23 10 40' would write the value "40" in all 10 signals, starting at index 23.
In every <mode>, the array will be filled, beginning from <signal index>, until either no more values are to be written, or no more signals are found in the SDF. In <mode> = 2, the command is done, when <length> signals were written. 		LIN/CAN
varrd <mode> <signal index> <length> OK | Err
  • <array_data>
Reads <length> values from the array, starting at <signal index>. <mode> defines, how the values will be returned:
  • Mode 0: returns a list of decimal numbers
    Example: 'varrd 0 23 3' would read 3 signals, starting at index 23 and returns a list where each entry contains the corresponding signals value.
    Expected return code is 0.
  • Mode 1: returns a list of hexadecimal numbers. The numbers are encoded in a string for hexadecimal representation.
    Example: 'varrd 1 23 3' would read 3 signals, starting at index 23 and returns a list where each entry contains the corresponding signals valueas string of hexadecimal numbers (Format: "FF").
  • Mode 2: returns all read values as single concatenated string. The string may contain escaped sequences for non-printable characters.
    Example: 'varrd 2 23 3' would read 3 signals, starting at index 23 and returns a single answer as a string like "AB\03C".
  • Mode 3: returns all read values as single concatenated string. Non-printable characters are escaped as '.' .
    Example: 'varrd 3 23 3' would read 3 signals, starting at index 23 and returns a single answer as a string like "AB.C".
In every <mode>, <length> = 0 can be used to read the array until a signal with value 0x00 is encountered. 		LIN/CAN
sysvar_rd <name> OK | Err
  • <value>
Reads the system variable with the name <name> and return it's current value. DEVICE/LIN/CAN
sysvar_wr <name> <value> OK | Err Writes the system variable with the name <name> and sets it's new value to <value>.

DEVICE/LIN/CAN

Generated on Fri May 30 2025 17:16:13 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: SDF based logging

SDF based logging

SDF based logging

Introduction

A lot of application have the requirement for the creation of log files.Typical information included in these log files are:
  • Bus communication
  • Processed data, like e.g. serial numbers read using protocol services
  • Application status information
The content, that needs to be logged, may also vary depending on the application status and progress.Therefor the best way to create log files is by configuring and controlling them from within a SDF.

Availability

The SDF based logging is available in the following setups:
Baby-LIN device | Mode | Baby-LIN library application | Target folder for log files
Baby-LIN-II |  | SimpleMenu | My documents \Lipowsky Industrie-Elektronik GmbH\Logs\
Baby-LIN-RC-II
Baby-LIN-RM-II
HARP-4/5 | PC mode
Baby-LIN-MB-II | SimpleMenu mode
Baby-LIN-MB-II | Stand-Alone mode | The Baby-LIN-MB-II firmware | SD card

Control by print macro commands

To control the log mechanism, print macro commands are used.They allow to define a formatted string and use signals as replacement.All log commands must apply to these conditions:

  • "Debug report" must be chosen as target.
  • The print text must start with a "[LOG]" prefix.

Feedback from log commands

The print commands create reports, that are parsed and processed by the BabyLIN library.If a log command is not valid or can not be executed, an error report is created.Therefor it is not possible, to verify within the SDF, if the log command was executed successfully.If you want to implement the SDF based logging, please verify that no log commands triggers an error report by using the SimpleMenu for the development.

Log configuration

The SDF based logging uses internally the same mechanisms as the Log file available using the UniversalAccess API.All configuration properties available for the Log file, can also be used for the SDF based logging.

Log commands

The following commands are available to control the log file creation, configuration, writing and so on.
Command with parameter | Description | Parameter description
create *[handle]* | This command creates a new log file object. The new object has a default configuration. | handle (Optional parameter) The handle is an integer identifying a log file object. Default: The source channel of the log command.
assign *[mode]* *[channel]* *[handle]* | This command assigns a channel to or unassign a channel from the log file object. If assigned, the log file object will register all necessary channel callbacks. If unassigned, the log file object will unregister all registered channel callbacks. The assign method must be recalled, if a SDF file was loaded. | mode (Optional parameter) Possible values: 0: Unassign, 1: Assign Default: Assign channel (Optional parameter) The parameter identifies a channel using the channel index. Default: The source channel of the log command. handle (Optional parameter) The handle is an integer identifying a log file object. Default: The source channel of the log command.
config key value *[handle]* | This command sets a single configuration property. The configuration must be done, before a "start" or "write" command is send. | key (Mandatory parameter) The key name of the property, e.g. "log_format". value (Mandatory parameter) The new value of the property. handle (Optional parameter) The handle is an integer identifying a log file object. Default: The source channel of the log command.
start *[handle]* | This command starts the storing of the received reports in the memory. The stored reports are only written into a physical log file, if the write command is executed before the log file object is closed. | handle (Optional parameter) The handle is an integer identifying a log file object. Default: The source channel of the log command.
stop *[handle]* | This command stops the storing of the received reports in the memory. The stored reports are only written into a physical log file, if the write command is executed before the log file object is closed. | handle (Optional parameter) The handle is an integer identifying a log file object. Default: The source channel of the log command.
write *[filename]* *[handle]* | The write command triggers the creation of a physical log file. All stored reports in the memory will be written to the log file, even if the log file object is closed in the meantime. Without this command, no physical log file will be created. | filename (Optional parameter) The explicit filename used for the physical log file. Default: The filename will be created automatically based on the configuration properties. handle (Optional parameter) The handle is an integer identifying a log file object. Default: The source channel of the log command.
close *[handle]* | This command closes the log file object. If the writing has been triggered, all stored reports in memory will be written to the physical file. If no writing has been triggered, all stored reports will be discarded. No physical log file will be written. | handle (Optional parameter) The handle is an integer identifying a log file object. Default: The source channel of the log command.

Example

Print command content | Description
[LOG]create | This command creates a log file object. Since no handle is passed, it is implicitly created with a channel specific handle.
[LOG]assign 1 | This command assigns the the channel, which executes the section with this macro command to the log file. All reports, that are enabled, will be added to the log file, after the start command.
[LOG]config enable_frames 1 | Configure the log file object properties: Enable frame reports.
[LOG]config enable_errors 1 | Configure the log file object properties: Enable error reports.
[LOG]config enable_events 1 | Configure the log file object properties: Enable event reports.
[LOG]config enable_debug 1 | Configure the log file object properties: Enable debug reports.
[LOG]start | Start the saving of reports within the log file object. From now on, received reports will be saved, if the report type was enabled in the configuration.
[LOG]write | This commands triggers the writing of saved reports to a physical file. All reports saved until now will be written as well as all future reports. The name of the physical log file will be created using the configuration "file_prefix", "file_postfix" and "file_extension".
[LOG]stop | Stop the saving of reports within the log file. From now on, no received reports will be saved, until a "start" command is send again.
[LOG]close | The log file object is closed If a "write" command was sent, all saved reports will be written. If no "write" command was sent, the saved reports will be discarded.
Generated on Fri May 30 2025 17:16:13 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: Unified Access

Modules | Typedefs | Functions
Unified Access

Detailed Description

Every object may have children, properties and methods, that are accessible through the path parameter of the functions. The children, properties and methods are identified by tags. Those tags are handle specific and described in this document. Additionally they can be listed by calling BLC_discover with the handle you are interested in.

Creation of new Objects

To add a new Object into the tree use the BLC_createHandle function. To create a new object a using key value pairs ("<key>=<value>") is required. In a path each key value pair has to be separated by one space character. Tags valid for the creation keys can be taken from the "Creat tags" tables of the Objects documented in this document. The value is specifying the name property of the new child. Additionally key value pairs with property tags can be appended, to set properties during the object creation, so that less calls to the Setters are required afterwards. e.g. creating a Protocol ISO-TP in a Channel with the name "my_dtl" :

BL_HANDLE protocol_handle;
BLC_createHandle(channel_handle, "new_iso_tp_protocol=my_dtl",
&protocol_handle);

Handles of existing Objects

To find an existing Object in the tree use the BLC_createHandle function. Navigating the tree is done by constructing a path by using key value pairs ("<key>=<value>"). Tags valid for the keys can be taken from the "Child tags" tables of the Objects documented in this document. In a path each key value pair has to be separated by one space character. e.g. getting the handle to the previously created Protocol ISO-TP of that Channel :

BL_HANDLE protocol_handle;
BLC_createHandle(channel_handle, "protocol=my_dtl", &protocol_handle);

Getters

To read values of properties use BLC_getSignedNumber, BLC_getUnsignedNumber or BLC_getBinary functions. The path parameter has to end with the tag identifying the property to read. Valid tags can be taken from the "Property tags" tables of the Objects documented in this document. e.g. reading the requestFrameID from a Service ISO-TP :

uint64_t requestFrameID;
BLC_getUnsignedNumber(service_handle, "req_frame_id", &requestFrameID);

Setters

To store values of properties use BLC_setSignedNumber, BLC_setUnsignedNumber, BLC_setBinary or BLC_setCallback functions. The path parameter has to end with the tag identifying the property to store. Valid tags can be taken from the "Property tags" tables of the Objects documented in this document. e.g. setting the requestFrameID of a Service ISO-TP to 59 :

BLC_setUnsignedNumber(service_handle, "req_frame_id", 59);

Execution of Methods

To execute an object's method use BLC_execute or BLC_execute_async functions. In the path variable only the identifying tag is required. Valid tags can be taken from the "Method tags" tables of the Objects documented in this document. Functions might have parameters. Those can be specified by appending key value pairs to the path in the same manner as when creating new objects. The order of the parameters is not relevant. In some cases a synchronous call is not applicable, in these cases use BLC_execute_async to execute the method in a dedicated thread. e.g. executing a Service ISO-TP :

BLC_execute(service_handle, "execute");

Unified Access

The tree currently exposed by the Unified Access interface:

Object Tree Structure

To use spaces in the value part of a key value pair strings can be escaped by " or ' for example Tag="some text" or Tag='some text'. Also for escaped sequences the space between key value pairs is mandatory.

The Create Tags Table

Most Objects have to be created before they can be used. Exceptions such as Channels exist, they are created once the connection to the device is established. The permitted Tags are described for each Object in a table like this one:
Tag | Child Tag | Description
The exact tag for this child category | The child Tag the newly created Object will be available in. | A description, stating what exact Object will be created.

The Child Tags Table

For every existing Object, a handle can be retrieved by using the respective child Tag for the Objects type, on it's parent. The permitted Tags are described for each Object in a table like this one:
Tag | Type | Description
The exact tag for this child category | 32bit Number if the child can be selected by index String if the child can be selected by name | A description of the child category.

The Property Tags Table

Every Object does have properties, to read and write. They can be read or modified by using the respective Tag in a getter or setter. The permitted Tags are described for each Object in a table like this one:
Tag | Default Value | Type | Description
The exact tag for this child category | A Number (e.g. 1) A Boolean (e.g. false) A String (e.g. "example") A Binary (e.g. [1,2,3]) Uninitialized (<>) | <n>bit Number if it can be accessed as a number. Boolean is an alias for a 1bit Number, using 0 as false and 1 as true. String it can be accessed as a text. Binary if it can be accessed as an Array. Callback if a callback can be set. | A description of what the property does.

The Method Tags Table

More complex operations are performed by the BLC_execute function. The permitted Tags are described for each Object in a table like this one:
Tag | Parameters | Description
The exact tag for this child category | A tag for every parameter and its data type e.g. (timeout=64bit Number) | A description of what the method does. The returned values are also documented here. Returned values documented in the BabyLINReturncodes.h are not explicitly listed.

Modules

DLL Handle
The properties of the DLL Handle.
SDF
The properties of a SDF Handle.
Device
The properties of a Device Handle.

Typedefs

typedef void(* | BLC_unifiedaccess_callback_func_ptr )(BL_HANDLE handle, void *userdata)
The function prototype used for registering callbacks. More...
typedef void(* | BLC_unifiedaccess_async_callback_func_ptr )(int32_t result, BL_HANDLE handle, void *userdata)
The function prototype used for executing asynchron tasks. More...

Functions

int32_t BL_DLLIMPORT | BLC_createHandle (BL_HANDLE handle, const char *path, BL_HANDLE *result)
BLC_createHandle retrieves a handle to a loaded Object or creates a new Object. More...
int32_t BL_DLLIMPORT | BLC_destroy (BL_HANDLE handle)
BLC_destroy removes the handle from the currently opened Objects and removes the Object from its parent. More...
int32_t BL_DLLIMPORT | BLC_releaseHandle (BL_HANDLE handle)
BLC_releaseHandle removes the handle from the currently opened Objects. More...
int32_t BL_DLLIMPORT | BLC_discover (BL_HANDLE handle, const char *path, uint8_t *result, uint32_t *result_length)
BLC_discover fills the result array with space separated identifiers, that can be used in the path parameters. More...
int32_t BL_DLLIMPORT | BLC_getSignedNumber (BL_HANDLE handle, const char *path, int64_t *result)
BLC_getSignedNumber gets a signed value from the given handle. More...
int32_t BL_DLLIMPORT | BLC_getUnsignedNumber (BL_HANDLE handle, const char *path, uint64_t *result)
BLC_getUnsignedNumber gets a unsigned value from the given handle. More...
int32_t BL_DLLIMPORT | BLC_getBinary (BL_HANDLE handle, const char *path, uint8_t *result, uint32_t *result_length)
BLC_getBinary gets a binary value from the given handle. More...
int32_t BL_DLLIMPORT | BLC_setSignedNumber (BL_HANDLE handle, const char *path, int64_t value)
BLC_setSignedNumber sets a signed value of the given handle. More...
int32_t BL_DLLIMPORT | BLC_setUnsignedNumber (BL_HANDLE handle, const char *path, uint64_t value)
BLC_setUnsignedNumber sets an unsigned value of the given handle. More...
int32_t BL_DLLIMPORT | BLC_setBinary (BL_HANDLE handle, const char *path, const uint8_t *value, uint32_t value_length)
BLC_setBinary sets a binary value of the given handle. More...
int32_t BL_DLLIMPORT | BLC_setCallback (BL_HANDLE handle, const char *path, BLC_unifiedaccess_callback_func_ptr callback, void *userdata)
BLC_setCallback sets a callback function for an event of the given handle. More...
int32_t BL_DLLIMPORT | BLC_execute (BL_HANDLE handle, const char *path)
BLC_execute executes a method of the given handle. More...
int32_t BL_DLLIMPORT | BLC_execute_async (BL_HANDLE handle, const char *path, BLC_unifiedaccess_async_callback_func_ptr callback, void *userdata)
BLC_execute_async a method of the given handle. More...

Typedef Documentation

typedef void(* BLC_unifiedaccess_async_callback_func_ptr)(int32_t result, BL_HANDLE handle, void *userdata)

The result value is the value returned by the actual execute call.
The handle is the handle to the Object, that triggered the callback.
The userdata pointer is the userdata specified when registering the callback.

Definition at line 101 of file BabyLIN_UnifiedAccess.h.

typedef void(* BLC_unifiedaccess_callback_func_ptr)(BL_HANDLE handle, void *userdata)

The handle is the handle to the Object, that triggered the callback.
The userdata pointer is the userdata specified when registering the callback.

The device, that generated the callback must not be closed from within the callback.

Definition at line 93 of file BabyLIN_UnifiedAccess.h.

Function Documentation

int32_t BL_DLLIMPORT BLC_createHandle | ( | BL_HANDLE | handle,
 |  | const char * | path,
 |  | BL_HANDLE * | result
 | ) |  |

These Objects can range from Devices and SDFs down to Signals.
When retrieving a handle to an existing item the path has to end with a key value pair, where the key is a tag of the objects children list. When creating a new Object the "new_*=*" key value pair can be followed by key value pairs from the new objects property list, to initialize them.

Parameters
handle | The handle to start the query from.
path | The query, it is a cstring build from key value pairs, separated by spaces e.g. "protocol=1 service=2".
result | Value to store the new handle in.
Returns
BL_OK if no error occurred. If the returned value is between BLC_UA_NOT_RESOLVABLE_TAG_FIRST and BLC_UA_NOT_RESOLVABLE_TAG_MAX the corresponding key-value-pair in the path parameter could not be resolved correctly.
If the returned value is between BLC_UA_REQUESTED_OBJECT_NOT_FOUND_FIRST and BLC_UA_REQUESTED_OBJECT_NOT_FOUND_MAX the corresponding key-value-pair in the path parameter tries to access a non existing Object.
If BLC_UA_GET_VALUE_REJECTED is returned the requested Object was found but handles to this type of Object can not be created.
In case of Error refer to the BabyLINReturncodes.h file.
int32_t BL_DLLIMPORT BLC_destroy ( BL_HANDLE handle )

The given handle will be removed from the available handles and the Object behind it will be destroyed.

Parameters
handle The handle of the object to destroy.
Returns
BL_OK if no error occurred. In case of Error refer to the BabyLINReturncodes.h file.
int32_t BL_DLLIMPORT BLC_discover | ( | BL_HANDLE | handle,
 |  | const char * | path,
 |  | uint8_t * | result,
 |  | uint32_t * | result_length
 | ) |  |

Lists the available Tags of the object separated by spaces.

Parameters
handle | the handle to start the query from.
path the query, it is a cstring build from entries of tags ending with either "property","child", "create", "execute" or "all".
"property" will list all Tags usable in BLC_get...() and or BLC_set...().
"child" will list all Tags usable in BLC_createHandle for already existing objects.
"create" will list all Tags usable in BLC_createHandle for creating new objects.
"execute" will list all Tags usable in BLC_execute and BLC_execute_async.
"all" will list all Tags in the form of "property:=<tags >\nchild:=<tags >\ncreate:=<tags >\nexecute:=<tags>".
result | The buffer to fill, if a null pointer is provided here only the result_length will be filled.
result_length | Is a pointer to the length of the buffer, that will be set to the length of the result data.
Returns
BL_OK if no error occurred. If the returned value is between BLC_UA_NOT_RESOLVABLE_TAG_FIRST and BLC_UA_NOT_RESOLVABLE_TAG_MAX the corresponding key-value-pair in the path parameter could not be resolved correctly. In case of Error refer to the BabyLINReturncodes.h file.
int32_t BL_DLLIMPORT BLC_execute | ( | BL_HANDLE | handle,
 |  | const char * | path
 | ) |  |

The path will be followed and a Tag that identifies a Method property, followed by the Tags to set additional parameters of that method. The Method will be executed in a blocking manner.

Parameters
handle | the handle to start the query from.
path | the query, it is a cstring build from entries of tags.
Returns
BL_OK if no error occurred. If the returned value is between BLC_UA_NOT_RESOLVABLE_TAG_FIRST and BLC_UA_NOT_RESOLVABLE_TAG_MAX the corresponding key-value-pair in the path parameter could not be resolved correctly. In case of Error refer to the BabyLINReturncodes.h file.
int32_t BL_DLLIMPORT BLC_execute_async | ( | BL_HANDLE | handle,
 |  | const char * | path,
 |  | BLC_unifiedaccess_async_callback_func_ptr | callback,
 |  | void * | userdata
 | ) |  |

The path will be followed and a Tag that identifies a Method property, followed by the Tags to set additional parameters of that method. The Method will be executed in a non blocking manner, so the returned value does not state anything about whether the operation was successful, or not, but only if it was found or not. To get the result value you would get from BLC_execute use the first parameter of the BLC_unifiedaccess_async_callback_func_ptr.

Parameters
handle | The handle to start the query from.
path | The query, it is a cstring build from entries of tags.
callback | The callback to call once the operation is complete.
userdata | The additional parameter to call the callback with.
Returns
BL_OK if no error occurred. If the returned value is between BLC_UA_NOT_RESOLVABLE_TAG_FIRST and BLC_UA_NOT_RESOLVABLE_TAG_MAX the corresponding key-value-pair in the path parameter could not be resolved correctly. In case of Error refer to the BabyLINReturncodes.h file.
int32_t BL_DLLIMPORT BLC_getBinary | ( | BL_HANDLE | handle,
 |  | const char * | path,
 |  | uint8_t * | result,
 |  | uint32_t * | result_length
 | ) |  |

The path will be followed and the last Tag has to identify a property. A only Number or only Boolean property will be read as a string representation of it.

Parameters
handle | The handle to start the query from.
path | The query, it is a cstring build from entries of tags.
result | The buffer to fill, if a null pointer is provided here only the result_length will be filled.
result_length | Is a pointer to the length of the buffer, this parameter will be set to the length of the result data. If the result buffer is too small no data will be copied and only result_length will be updated.
Returns
BL_OK if no error occurred. If the returned value is between BLC_UA_NOT_RESOLVABLE_TAG_FIRST and BLC_UA_NOT_RESOLVABLE_TAG_MAX the corresponding key-value-pair in the path parameter could not be resolved correctly. In case of Error refer to the BabyLINReturncodes.h file.
int32_t BL_DLLIMPORT BLC_getSignedNumber | ( | BL_HANDLE | handle,
 |  | const char * | path,
 |  | int64_t * | result
 | ) |  |

The path will be followed and the last Tag has to identify a Number or Boolean property. If that property is signed and has less then 64 bits sign extension will be applied, so negative values stay negative.

Parameters
handle | The handle to start the query from.
path | The query, it is a cstring build from entries of tags.
result | The target value.
Returns
BL_OK if no error occurred. If the returned value is between BLC_UA_NOT_RESOLVABLE_TAG_FIRST and BLC_UA_NOT_RESOLVABLE_TAG_MAX the corresponding key-value-pair in the path parameter could not be resolved correctly. In case of Error refer to the BabyLINReturncodes.h file.
int32_t BL_DLLIMPORT BLC_getUnsignedNumber | ( | BL_HANDLE | handle,
 |  | const char * | path,
 |  | uint64_t * | result
 | ) |  |

The path will be followed and the last Tag has to identify a Number or Boolean property. If that property is signed no sign extension will be applied, so 8 bit -1 will be 255.

Parameters
handle | The handle to start the query from.
path | The query, it is a cstring build from entries of tags.
result | The target value.
Returns
BL_OK if no error occurred. If the returned value is between BLC_UA_NOT_RESOLVABLE_TAG_FIRST and BLC_UA_NOT_RESOLVABLE_TAG_MAX the corresponding key-value-pair in the path parameter could not be resolved correctly. In case of Error refer to the BabyLINReturncodes.h file.
int32_t BL_DLLIMPORT BLC_releaseHandle ( BL_HANDLE handle )

The given handle will be release, but a new handle to the underling object can be retrieved again.

Parameters
handle The handle to release.
Returns
BL_OK if no error occurred. In case of Error refer to the BabyLINReturncodes.h file.
int32_t BL_DLLIMPORT BLC_setBinary | ( | BL_HANDLE | handle,
 |  | const char * | path,
 |  | const uint8_t * | value,
 |  | uint32_t | value_length
 | ) |  |

The path will be followed and the last Tag has to identify a property. For a only Number or only Boolean property the given value will be parsed as a string, that is then handed to BLC_setUnsignedNumber or BLC_setSignedNumber.

Parameters
handle | The handle to start the query from.
path | The query, it is a cstring build from entries of tags.
value | The value to set.
value_length | The length of the value to set.
Returns
BL_OK if no error occurred. If the returned value is between BLC_UA_NOT_RESOLVABLE_TAG_FIRST and BLC_UA_NOT_RESOLVABLE_TAG_MAX the corresponding key-value-pair in the path parameter could not be resolved correctly. In case of Error refer to the BabyLINReturncodes.h file.
int32_t BL_DLLIMPORT BLC_setCallback | ( | BL_HANDLE | handle,
 |  | const char * | path,
 |  | BLC_unifiedaccess_callback_func_ptr | callback,
 |  | void * | userdata
 | ) |  |

The path will be followed and the last Tag has to identify a Callback property. Only one callback can be registered per event per object.

Parameters
handle | The handle to start the query from.
path | The query, it is a cstring build from entries of tags.
callback | The callback to set, use a null pointer to deactivate the callback.
userdata | The parameter to call the callback with.
Returns
BL_OK if no error occurred. If the returned value is between BLC_UA_NOT_RESOLVABLE_TAG_FIRST and BLC_UA_NOT_RESOLVABLE_TAG_MAX the corresponding key-value-pair in the path parameter could not be resolved correctly. In case of Error refer to the BabyLINReturncodes.h file.
int32_t BL_DLLIMPORT BLC_setSignedNumber | ( | BL_HANDLE | handle,
 |  | const char * | path,
 |  | int64_t | value
 | ) |  |

The path will be followed and the last Tag has to identify a Number or Boolean property. If that property is too small to represent the value the set is rejected.

Parameters
handle | The handle to start the query from.
path | The query, it is a cstring build from entries of tags.
value | The value to set.
Returns
BL_OK if no error occurred. If the returned value is between BLC_UA_NOT_RESOLVABLE_TAG_FIRST and BLC_UA_NOT_RESOLVABLE_TAG_MAX the corresponding key-value-pair in the path parameter could not be resolved correctly. In case of Error refer to the BabyLINReturncodes.h file.
int32_t BL_DLLIMPORT BLC_setUnsignedNumber | ( | BL_HANDLE | handle,
 |  | const char * | path,
 |  | uint64_t | value
 | ) |  |

The path will be followed and the last Tag has to identify a Number or Boolean property. If that property is too small to represent the value the set is rejected.

Parameters
handle | The handle to start the query from.
path | The query, it is a cstring build from entries of tags.
value | The value to set.
Returns
BL_OK if no error occurred. If the returned value is between BLC_UA_NOT_RESOLVABLE_TAG_FIRST and BLC_UA_NOT_RESOLVABLE_TAG_MAX the corresponding key-value-pair in the path parameter could not be resolved correctly. In case of Error refer to the BabyLINReturncodes.h file.
Generated on Fri May 30 2025 17:16:13 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: DLL Handle

Modules
DLL Handle
Unified Access

Detailed Description

The DLL Handle

You should first read through the Unified Access.
Here all available Tags of the DLL Handle can be looked up.
The DLL Handle is a unique Handle, that can be retrieved by calling BLC_createHandle with a handle value of 0 and an empty path.
BL_HANDLE dll_handle;
BLC_createHandle(0, "", &dll_handle);

Create Child Tags

Tag | Child Tag | Description
new_logfile | logfile | creates a new Log file

Property Tags

Tag | Default Value | Type | Description
version | <> | String | The Version of the library.
utf8path | false | Boolean | If set to 'true' the file paths will be interpreted as UTF-8 encoded Strings. Thus allowing to access SDF files with filenames/paths, that contain Characters, which can not be printed in the current locale.
global_sdf_log_enabled | true | Boolean | If true, logging from a SDF is enabled. The print commands are handled by the BabyLIN library and log files can be created.
global_max_log_memory | 100MB | 64Bit Nubmer | This is the maximum amount of RAM memory, that will be used by Log file.
global_fixed_log_path | "" | String | If set, all Log file will be redirected to this folder.

Modules

Log file
The properties of a log file.
Date and time format
The format specifiers for string supporting date and time.
Generated on Fri May 30 2025 17:16:13 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: Log file

Log file
DLL Handle

The log file

You should first read through the Unified Access.
The BabyLIN library allows to log data of a Baby-LIN device.
This log file can be configured in many ways, especially the data, that is logged, the file format and the mode, when data are written.
Here all available Tags of an log file can be looked up.

Property Tags

Tag | Default Value | Type | Description
config_name | "Log config" | String | The name of the config. This name is optional and can be used to identify the log config.
block_on_destruction false Boolean If true, the destruction of the log object blocks, until the writing of the file is finished.
If false, the file writing may be delayed until after the destruction.
This flag changes the behaviour of BLC_destroy().
Warning
This property can not be set from within a SDF.
flush_peridically false Boolean If true, the logfile will be flushed (written to disk) periodically.
If false, the file writing may be delayed until a close is called.
This flag may reduce the performance.
Warning
This property can not be set from within a SDF.
file_path Windows: C:\Users\<username>\Documents\Lipowsky Industrie-Elektronik GmbH\Logs\
Linux: /home/<username>/Documents/Lipowsky Industrie-Elektronik GmbH/Logs/ 		String This is the path, where the log files will be created.
file_prefix "Log_" String This is a fixed prefix for all log files.
The maximum log size will be evaluated depending on this filename prefix.
file_postfix "Y_m_d_H_M_S" String Adds a timestamp postfix to the filename.
The timestamp postfix is only added, if this format string is not empty.
See Date and time format for supported date and time format specifiers.
file_extension "log" String This is the extension of the log file.
A '.' will be added automatically between the filename and extension.
max_filesize 10 MB 64bit Number This is the maximum file size for a log file.
If this file size is exceeded:
- the current log file will be closed
- a new log file will be created
- the logging will continue in the new file
Warning
The final log size may be slightly larger than this value.
Please note, that the size of a report vary along different reports types and the memory size does not represent the final file size.
log_format 1
(3rd party compatible ASCII log) 		32bit Number This is the format of the log file:
0: Lipowsky binary log
1: 3rd party compatible ASCII log
4: CSV frame log
5: CSV signal log
6: Raw log
enable_frames | See table below. | Boolean | If true (1), frames will be logged.
enable_signals | See table below. | Boolean | If true (1), signals will be logged.
enable_macrostates | See table below. | Boolean | If true (1), macro state changes will be logged.
enable_errors | See table below. | Boolean | If true (1), errors will be logged.
enable_events | See table below. | Boolean | If true (1), events will be logged.
enable_debug | See table below. | Boolean | If true (1), debug messages will be logged.
enable_comments | See table below. | Boolean | If true (1), application comments will be logged.
date_line_format "%a %B %d %H:%M:%S %Y" String Adds a date line on top of the header.
The line starts with "date ".
The lines are only added, if this text property is not empty.
See Date and time format for supported date and time format specifiers.
internal_events_line_enabled true Boolean Adds a line with the fixed text:
"internal events logged"
format_version "8.0.0" String Adds a line with a version number.
Just add the version number, e.g. "11.0.0".
The line in the log file will then be: "version 11.0.0"
The lines are only added, if this text property is not empty.
additional_header_text <> String Adds a custom header text.
This custom header text will be added without the comment prefix.
You may use "\n" to add a new line.
The lines are only added, if this text property is not empty.
additional_header_comment <> String Adds a custom header comment.
This custom header comment will be added with the comment prefix.
You may use "\n" to add a new line.
The lines are only added, if this text property is not empty.
trigger_block_enabled true Boolean Marks the complete log as the trigger block.
Before the regular logging, this text is added with a timestamp: "Begin Triggerblock".
After the regular logging, this text is added: "End TriggerBlock".
start_entry "Start of measurement" String Adds this text, at the beginning of the regular logging.
The lines are only added, if this text property is not empty.
timestamp_decimal_places 6 32bit Number This is the number of decimal places used after the decimal point.
If the number of decimal places of the timestamp is lower, zeros will be added.
timestamp_integer_places 4 32bit Number This is the number of integer places used before the decimal point.
If the number of integer places of the timestamp is lower, space characters will be added.
align_timestamp_enabled false Boolean Check to align the timestamp of comments and reports with the frame reports.
3 space characters will be added before the tiemstamp of a frame report.
preceding_timestamp_format <> String Adds an absolute timestamp before each report.
The absolute timestamp is only added, if this format string is not empty.

See Date and time format for supported date and time format specifiers.
min_frame_id_chars 15 32bit Number This is the number of characters the frame ID will at least use.
If the number of characters for the frame ID is lower, space characters will be added. If the frame ID requires more characters, the lines may no longer be justified.
d_column_enabled | false | Boolean | Check to enable a column with 'd' characters before the data length of frame reports.
checksum_enabled | true | Boolean | Check to enable the Checksum entry as decimal number at the end.
frame_id_enabled | true | Boolean | Check to enable the frame ID as decimal number at the end.
channel_mapping "Li\nL2\nL3\nL4\nL5\nL6\nC1\nC2\nC3" String Choose the ID for a channel.
Each line represents a bus channel.
You can simply click the Baby-LIN device, that is used to record the log to get the default layout.
is_extended false
Simple format 		Boolean false: Simple format
The simple format only stores necessary information.
Use it, if you have never used the extended format before.

true: Extended format
It adds certain columns for compatibility reasons.
Use it only, if you have used it before.
integer_coding 1
Hexadecimal 		32bit Number 0: Decimal
Integer values are encoded as decimal values.

1: Hexadecimal
Integer values are encoded as hexadecimal values.

Method Tags

Tag | Parameters | Description
assign_channel | mode=32bit Number handle=BL_HANDLE | Use this method to assign a channel to the log file or deassign a channel from the log file. If assigned, the log files will register all necessary channel callbacks. If unassigned, the log files will unregister all registered channel callbacks. The assign method must be recalled, if a SDF file was loaded. The mode is optional and can have the follwoing values: 0: Unassign 1: Assign (Default)
write | filename=String (Optional) | Writes the log data from memory to a file. If no filename is passed, a log file name will be generated based on file_path, file_prefix, file_postfix and file_extension.
start |  | Start storing the received reports in the memory.
stop |  | Stop storing the received reports in the memory.
add | comment=String | Adds an application specific comment.
load | config=String | Loads a log configuration using the filename passed in config.
save | config=String overwrite=Boolean | Saves the current log configuration using the filename passed in config. If the file already exists, it will only overwritten, if overwrite is set.

Report type support of log file formats

 | Frames | Signals | Macro state | Errors | Events | Debug messages | Application comments | DTL requests | DTL responses
Lipowsky binary log | Supported Default: Enabled |  |  |  |  |  |  |  |
3rd party compatible ASCII log | Supported Default: Enabled | Supported Default: Disabled | Supported Default: Disabled | Supported Default: Enabled | Supported Default: Enabled | Supported Default: Enabled | Supported Default: Enabled | Supported Default: Disabled | Supported Default: Disabled
CSV frame log | Supported Default: Enabled |  |  |  |  |  |  |  |
CSV signal log |  | Supported Default: Enabled |  |  |  |  |  |  |
Warning
Signals are only reported, if the BabyLIN device is using a SDF.
All signals defined as GUI elements in the SDF will be logged.
If the BabyLIN device is monitoring without a SDF, no signals can be logged.

Ignored properties

Not all properties of the log configuration are always used. The following list shows an overview about the application and the ignored properties.
Devices | Application | Configuration source | Target | Ignored or special properties
All Baby-LIN devices | SimpleMenu | Log configuration dialog | Local PC storage |
All Baby-LIN devices | Custom application using the Baby-LIN library | Unified Access interface of the Baby-LIN library. | Local PC storage |
All Baby-LIN devices | SDF loaded by LINWorks or custom application using the Baby-LIN library | Print macro commands within a SDF. | Local PC storage | file_path: Should be empty to use default path, that is availbale on all machines
Baby-LIN-MB-II | SDF logging in PLC application or stand alone mode | Print macro commands within a SDF | Internal Baby-LIN-MB-II storage | file_path: Is a local path within the Baby-LIN-MB-II file_prefix: Should not be 'Log_' to not collide with the genral logging
Baby-LIN-MB-II | Background logging in PLC application or stand alone mode | Log configuration file uploaded via web interface | Internal Baby-LIN-MB-II storage | file_path: Is a local path within the Baby-LIN-MB-II file_prefix, file_postfix, file_extension: Uses a fixed algorithm max_logsize: Limited by the Baby-LIN-MB-II storage channel_mapping: Contains the Baby-LIN-MB-II channels additional_header_comment: Contains information about the Baby-LIN-MB-II
All Baby-LIN devices | External trigger | Log configuration dialog | Local PC storage | file_path: Should be empty to use default path, that is availbale on all machines
All Baby-LIN devices | Log file conversion in LogViewer export | Log configuration dialog | Local PC storage | file_path, file_prefix, file_postfix, file_extension: The target filename is selected max_filesize, max_logsize, max_storage_time: The target file size is not limited by the software
Generated on Fri May 30 2025 17:16:13 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: Date and time format

Date and time format
DLL Handle

Date and time format

Certain strings can use data and time format specifiers.
The following list shows all format specifiers.
Format specifier | Category | Description
%Y | Year | Writes year as a decimal number, e.g. 2017.
%Y | Year | Writes year as a decimal number, e.g. 2017.
%y | Year | Writes last 2 digits of year as a decimal number (range [00,99]).
%b | Month | Writes abbreviated month name, e.g. Oct (locale dependent).
%B | Month | Writes full month name, e.g. October (locale dependent).
%m | Month | Writes month as a decimal number (range [01,12]).
%U | Week | Writes week of the year as a decimal number (Sunday is the first day of the week) (range [00,53]).
%W | Week | Writes week of the year as a decimal number (Monday is the first day of the week) (range [00,53]).
%j | Day | Writes day of the year as a decimal number (range [001,366]).
%d | Day | Writes day of the month as a decimal number (range [01,31]).
%a | Day | Writes abbreviated weekday name, e.g. Fri (locale dependent).
%A | Day | Writes full weekday name, e.g. Friday (locale dependent).
%w | Day | Writes weekday as a decimal number, where Sunday is 0 (range [0-6]).
%H | Hour | Writes hour as a decimal number, 24 hour clock (range [00-23]).
%I | Hour | Writes hour as a decimal number, 12 hour clock (range [01,12]).
%M | Minute | Writes minute as a decimal number (range [00,59]).
%S | Second | Writes second as a decimal number (range [00,60]).
%%fm | Fractional | Writes milliseconds as a decimal number (range [000,999]).
%%fu | Fractional | Writes microseconds as a decimal number (range [000,999]).
%c | Other | Writes standard date and time string, e.g. Sun Oct 17 04:41:13 2010 (locale dependent).
%x | Other | Writes localized date representation (locale dependent).
%X | Other | Writes localized time representation, e.g. 18:40:20 or 6:40:20 PM (locale dependent).
%p | Other | Writes localized a.m. or p.m. (locale dependent).
%z | Other | Writes offset from UTC in the ISO 8601 format (e.g. -0430), or no characters if the time zone information is not available.
%Z | Other | Writes locale-dependent time zone name or abbreviation, or no characters if the time zone information is not available.
%% | Other | Writes literal %.
Generated on Fri May 30 2025 17:16:13 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: SDF

Modules
SDF
Unified Access

Detailed Description

The Session Description File

You should first read through the Unified Access.
Here all available Tags of a Session Description File can be looked up.

Child Tags

Tag | Type | Description
section | 32bit Number String | find a Section by index or name.

Property Tags

Tag | Default Value | Type | Description
name | <> | String | The name, of the SDF file.
sdf_version | <> | 32bit Number | The minimal SDF version, that is required by this SDF File.
section_count | <> | 32bit Number | The amount of available Sections in this Session Description File.

Modules

Section
The properties of a Section Handle.
Generated on Fri May 30 2025 17:16:13 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: Section

Modules
Section
SDF

Detailed Description

The Section

You should first read through the Unified Access.
Here all available Tags of a Section can be looked up.

Child Tags

Tag | Type | Description
signal | 32bit Number String | find a Signal by index or name.
frame | 32bit Number String | find a Frame by index or name.
node | 32bit Number String | find a Node by index or name.
macro | 32bit Number String | find a Macro by index or name.

Property Tags

Tag | Default Value | Type | Description
name | <> | String | The name, of the Section.
index | <> | 32bit Number | The Section's index in the SDF 's section list.
type | <> | 32bit Number | The Section type: 0 for LIN Sections 1 for CAN Sections 99 for Device Sections
speed | <> | 32bit Number | The bus speed configured in this Section.
sdf_version | <> | 32bit Number | The minimal SDF version, that is required by this section.
max_baudrate_required | <> | 32bit Number | The maximal baudrate a Channel has to support to load this section.
signal_count | <> | 32bit Number | The amount of available Signals in this Section.
frame_count | <> | 32bit Number | The amount of available Frames in this Section.
node_count | <> | 32bit Number | The amount of available Nodes in this Section.
macro_count | <> | 32bit Number | The amount of available Macros in this Section.

Modules

Signal
The properties of a Signal Handle.
Frame
The properties of a Frame Handle.
Mapping
The properties of a Mapping Handle.
Node
The properties of a Node Handle.
Macro
The properties of a Macro Handle.
Generated on Fri May 30 2025 17:16:13 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: Signal

Modules
Signal
Section

Detailed Description

The SDF Signal

You should first read through the Unified Access.
Here all available Tags of a Signal can be looked up.

Child Tags

Tag | Type | Description
encoding_type | void | return the associated Encoding Type.
mapping | 32bit Number | return the associated Mapping.

Property Tags

Tag | Default Value | Type | Description
name | <> | String | The name, of the Signal.
index | <> | 32bit Number | The signal's index in the Section 's signal list.
length | <> | 32bit Number | The signal's length in bits.
signed | <> | Boolean | True if the signal is handled as a signed Number.
initialvalue | <> | 64bit Number | The signal's initial value.
resetonbus | <> | Boolean | True if the signal is reset to the initialvalue when a "Bus Start" is executed.
emulated | <> | Boolean | True if the signal is emulated.
virtual | <> | Boolean | True if the signal is a virtual signal.
mapping_count | <> | 32bit Number | The amount of available Frame Mappings for this signal.

Modules

Encoding Type
The property of an Encoding Type Handle.
Generated on Fri May 30 2025 17:16:13 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: Encoding Type

Modules
Encoding Type
Signal

Detailed Description

The Encoding Type

You should first read through the Unified Access.
Here all available Tags of a Encoding Type can be looked up.

Child Tags

Tag | Type | Description
encoding_value | 32bit Number | find a Encoding Value by index.

Property Tags

Tag | Default Value | Type | Description
name | <> | String | The name, of the Encoding Type.
encoding_value_count | <> | 32bit Number | The amount of available Encoding Values for this Encoding Type.

Modules

Encoding Value
The properties of an Encoding Value Handle.
Generated on Fri May 30 2025 17:16:13 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: Encoding Value

Encoding Value
Encoding Type

The Encoding Value

You should first read through the Unified Access.
Here all available Tags of an Encoding Value can be looked up.Physical encodings are computed by multiplying the signal value with the scale followed by adding the offset.

Property Tags

Tag | Default Value | Type | Description
type | <> | 32bit Number | The Encoding Value value: Logical := 0 Physical := 1 BCD := 3 ASCII := 4
alias | <> | String | The Text that is used for this Encoding. Only valid for Logical encodings.
unit | <> | String | The Unit that is used for this Encoding. Only valid for Physical encodings.
raw_min | <> | 64bit Number | The minimal Signal Value, valid for this encoding.
raw_max | <> | 64bit Number | The maximal Signal Value, valid for this encoding.
scale | <> | String | The scale value for this encoding. Only valid for Physical encodings.
offset | <> | String | The offset value for this encoding. Only valid for Physical encodings.
Generated on Fri May 30 2025 17:16:13 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: Frame

Frame
Section

The SDF Frame

You should first read through the Unified Access.
Here all available Tags of a Frame can be looked up.

Child Tags

Tag | Type | Description
mapping | 32bit Number | return the associated Mapping.

Property Tags

Tag | Default Value | Type | Description
name | <> | String | The name, of the frame.
index | <> | 32bit Number | The frame's index in the Section 's frame list.
id | <> | 32bit Number | The frame's ID, that is used on the bus.
length | <> | 32bit Number | The frame's length in bytes.
emulated | <> | Boolean | True if the frame is emulated.
mapping_count | <> | 32bit Number | The amount of available Mappings in this frame.
Generated on Fri May 30 2025 17:16:13 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: Mapping

Mapping
Section
Generated on Fri May 30 2025 17:16:13 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: Node

Node
Section

The SDF Node

You should first read through the Unified Access.
Here all available Tags of a Node can be looked up.

Child Tags

Tag | Type | Description
frame | 32bit Number String | return the associated Frame.

Property Tags

Tag | Default Value | Type | Description
name | <> | String | The name, of the node.
index | <> | 32bit Number | The node's index in the Section 's node list.
emulated | <> | Boolean | True if the node is emulated.
frame_count | <> | 32bit Number | The amount of available Frames for this node.
Generated on Fri May 30 2025 17:16:13 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: Macro

Modules
Macro
Section

Detailed Description

The Macro

You should first read through the Unified Access.
Here all available Tags of a Macro can be looked up.

Child Tags

Tag | Type | Description
parameter | 32bit Number String | find a Macro Parameter by index or name.

Property Tags

Tag | Default Value | Type | Description
name | <> | String | The name, of the Macro.
index | <> | 32bit Number | The Macro's index in the Section 's macro list.
parameter_count | <> | 32bit Number | The number of Macro Parameter of this macro.

Modules

Macro Parameter
The properties of a Macro Parameter Handle.
Generated on Fri May 30 2025 17:16:13 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: Macro Parameter

Macro Parameter
Macro

The Macro Parameters

You should first read through the Unified Access.
Here all available Tags of a Macro Parameter can be looked up.

Property Tags

Tag | Default Value | Type | Description
name | <> | String | The name, of the Parameter.
index | <> | 32bit Number | The Parameter's index in the Macro 's parameter list.
Generated on Fri May 30 2025 17:16:13 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: Device

Modules
Device
Unified Access

Detailed Description

The Device

You should first read through the Unified Access.
Here all available Tags of a Device can be looked up. Also all Tags of the SDF loaded onto this device can be used.

Child Tags

Tag | Type | Description
sdf | Void | Gets the SDF loaded by this device.
channel | 32bit Number String | Find a Channel by index or name.
lin_channel | 32bit Number String | Find a LIN-Channel by index or name.
can_channel | 32bit Number String | Find a CAN-Channel by index or name.

Property Tags

Tag | Default Value | Type | Description
name | <> | String | The name, of the device.
supported_sdf_version | <> | 32bit Number | The maximal SDF version, that is supported by this device.
channel_count | <> | 32bit Number | The amount of available Channels in this device.
lin_channel_count | <> | 32bit Number | The amount of available LIN-Channels in this device.
can_channel_count | <> | 32bit Number | The amount of available CAN-Channels in this device.

Modules

Channel
The properties of a Channel Handle.
Generated on Fri May 30 2025 17:16:13 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: Channel

Modules
Channel
Device

Detailed Description

The Channel

You should first read through the Unified Access.
Here all available Tags of a Channel can be looked up. Also all Tags of the Section loaded onto this channel can be used.

Child Tags

Tag | Type | Description
section | Void | Gets the Section loaded by this channel.
protocol | 32bit Number String | Find a Protocol ISO-TP by index or name.

Create Child Tags

Tag | Child Tag | Description
new_iso_tp_protocol | protocol | creates a new Protocol ISO-TP

Property Tags

Tag | Default Value | Type | Description
name | <> | String | The name, by which this channel can be found.
index | <> | 32bit Number | The Channel's index in the Device 's channel list.
max_baudrate_supported | <> | 32bit Number | The maximal Baudrate this Channel supports.
protocol_count | <> | 32bit Number | the amount of available Protocols in this channel

Modules

Protocol ISO-TP
The properties of a Protocol ISO-TP Handle.
Generated on Fri May 30 2025 17:16:13 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: Protocol ISO-TP

Modules
Protocol ISO-TP
Channel

Detailed Description

The Base ISO-TP protocol

You should first read through the Unified Access.
Here all available Tags of an ISO-TP Protocol can be looked up.

Child Tags

Tag | Type | Description
service | 32bit Number String | Finds a Service ISO-TP by index or name.

Create Tags

Tag | Child Tag | Description
new_service | service | Creates a new Service ISO-TP of type Service ISO-TP
– | – | –
new_DiagnosticSessionControl | service | Creates a new Service ISO-TP of type UDS Service DiagnosticSessionControl
new_ECUReset | service | Creates a new Service ISO-TP of type UDS Service ECUReset
new_SecurityAccess | service | Creates a new Service ISO-TP of type UDS Service SecurityAccess
new_CommunicationControl | service | Creates a new Service ISO-TP of type UDS Service CommunicationControl
new_TesterPresent | service | Creates a new Service ISO-TP of type UDS Service TesterPresent
new_AccessTimingParameter | service | Creates a new Service ISO-TP of type UDS Service AccessTimingParameter
new_SecuredDataTransmission | service | Creates a new Service ISO-TP of type UDS Service SecuredDataTransmission
new_ControlDTCSetting | service | Creates a new Service ISO-TP of type UDS Service ControlDTCSetting
new_ResponseOnEvent | service | Creates a new Service ISO-TP of type UDS Service ResponseOnEvent
new_LinkControl | service | Creates a new Service ISO-TP of type UDS Service LinkControl
– | – | –
new_ReadDataByIdentifier | service | Creates a new Service ISO-TP of type UDS Service ReadDataByIdentifier
new_ReadMemoryByAddress | service | Creates a new Service ISO-TP of type UDS Service ReadMemoryByAddress
new_ReadScalingDataByIdentifier | service | Creates a new Service ISO-TP of type UDS Service ReadScalingDataByIdentifier
new_ReadDataByPeriodicIdentifier | service | Creates a new Service ISO-TP of type UDS Service ReadDataByPeriodicIdentifier
new_DynamicallyDefineDataIdentifier | service | Creates a new Service ISO-TP of type UDS Service DynamicallyDefineDataIdentifier
new_WriteDataByIdentifier | service | Creates a new Service ISO-TP of type UDS Service WriteDataByIdentifier
new_WriteMemoryByAddress | service | Creates a new Service ISO-TP of type UDS Service WriteMemoryByAddress
– | – | –
new_ClearDiagnosticInfromation | service | Creates a new Service ISO-TP of type UDS Service ClearDiagnosticInformation
new_ReadDTCInformation | service | Creates a new Service ISO-TP of type UDS Service ReadDTCInformation
– | – | –
new_InputOutputControlByIdentifier | service | Creates a new Service ISO-TP of type UDS Service InputOutputControlByIdentifier
– | – | –
new_RoutineControl | service | Creates a new Service ISO-TP of type UDS Service RoutineControl
– | – | –
new_RequestDownload | service | Creates a new Service ISO-TP of type UDS Service RequestDownload
new_RequestUpload | service | Creates a new Service ISO-TP of type UDS Service RequestUpload
new_TransferData | service | Creates a new Service ISO-TP of type UDS Service TransferData
new_RequestTransferExit | service | Creates a new Service ISO-TP of type UDS Service RequestTransferExit
new_RequestFileTransfer | service | Creates a new Service ISO-TP of type UDS Service RequestFileTransfer

Property Tags

Tag | Default Value | Type | Description
name | "" | String | The name, by which the Protocol ISO-TP can be found
index | <> | 32bit Number | The Protocol's index in the Channel 's protocol list.
service_count | <> | 32bit Number | The amount of Services in the protocol
ff_callback | <> | Callback | The Function to Call when a First Frame Candidate is detected. The obtained Handle will be a First Frame Callback Object. This function is also called for First Frame Candidates send by currently executed Services.
– | – | – | Default values for newly created Services
node_address | LIN: 0x7F CAN:-1 | 16bit Number | The default node address used for newly created Services. Set to -1 to deactivate NAD in the frames.
req_frame_id | LIN: 0x3C CAN:1 | 32bit Number | The default frame id of request frames used for newly created Services.
rsp_frame_id | LIN: 0x3D CAN:2 | 32bit Number | The default frame id of response frames used for newly created Services.
slave_only | LIN:0 (false) | Boolean | Indicates, that the device is configured as a LIN-Slave and can not actively schedule frames. It is required to set this value to true for protocol slave implementations. not applicable on CAN channels.
lin_version | LIN:1 | 2bit Number | The default checksum type (classic for 1, enhanced for 2, undefined otherwise) used for newly created Services.
extend_frameid | CAN:0 (false) | Boolean | The default frame id length (11 Bits in case of false, 29 Bits other wise) used for newly created Services.
req_slottime | 20 | 32bit Number | The default request frame slot time used for newly created Services. This value is also send in flow control frames when simulating the response.
rsp_slottime | 20 | 32bit Number | The default response frame slot time used for newly created Services. This value is also send in flow control frames when simulating the request.
timeout_frame | 50 | 32bit Number | The default timeout for send frames used for newly created Services.
timeout_response | 1000 | 32bit Number | The default timeout for the response frames used for newly created Services.
padding | LIN: 0xFF CAN: 0xCC | 8bit Number | The default padding used for newly created Services.
blocksize | CAN: 0 | 8bit Number | The default block size used in flow control frames for newly created Services.
optimize | false | Boolean | If this is set to true the last frame of the request and response will be transmitted with just the required frame length. e.g. a request with NAD and 3 bytes payload will have only 5 bytes instead of 8. This is the default value used for newly created Services.
max_continue_count | 10 | 32bit Number | For this may times the Response will be repeated when a negative response code of 0x78 (continue to send) is received. This is the default value used for newly created Services.
max_flow_wait | 10 | 32bit Number | For this may times the flow state is allowed to be 1, before aborting the service execution. This is the default value used for newly created Services.

Modules

First Frame Callback Object
The properties of the Temporary Object obtained in the Protocol ISO-TP 's 'ff_callback'.
Service ISO-TP
The properties of a Service ISO-TP Handle.
UDS Service ECUReset
The properties of a UDS ECUReset Handle. Also include all properties of Service ISO-TP Handles.
UDS Service InputOutputControlByIdentifier
The properties of a UDS InputOutputControlByIdentifier Handle. Also include all properties of Service ISO-TP Handles.
UDS Service ReadDataByIdentifier
The properties of a UDS ReadDataByIdentifier Handle. Also include all properties of Service ISO-TP Handles.
UDS Service WriteDataByIdentifier
The properties of a UDS WriteDataByIdentifier Handle. Also include all properties of Service ISO-TP Handles.
UDS Service AccessTimingParameter
The properties of a UDS AccessTimingParameter Handle. Also include all properties of Service ISO-TP Handles.
UDS Service ClearDiagnosticInformation
The properties of a UDS ClearDiagnosticInformation Handle. Also include all properties of Service ISO-TP Handles.
UDS Service CommunicationControl
The properties of a UDS CommunicationControl Handle. Also include all properties of Service ISO-TP Handles.
UDS Service ControlDTCSetting
The properties of a UDS ControlDTCSetting Handle. Also include all properties of Service ISO-TP Handles.
UDS Service DiagnosticSessionControl
The properties of a UDS DiagnosticSessionControl Handle. Also include all properties of Service ISO-TP Handles.
UDS Service DynamicallyDefineDataIdentifier
The properties of a UDS DynamicallyDefineDataIdentifier Handle. Also include all properties of Service ISO-TP Handles.
UDS Service LinkControl
The properties of a UDS LinkControl Handle. Also include all properties of Service ISO-TP Handles.
UDS Service ReadDataByPeriodicIdentifier
The properties of a UDS ReadDataByPeriodicIdentifier Handle. Also include all properties of Service ISO-TP Handles.
UDS Service ReadDTCInformation
The properties of a UDS ReadDTCInformation Handle. Also include all properties of Service ISO-TP Handles.
UDS Service ReadMemoryByAddress
The properties of a UDS ReadMemoryByAddress Handle. Also include all properties of Service ISO-TP Handles.
UDS Service ReadScalingDataByIdentifier
The properties of a UDS ReadScalingDataByIdentifier Handle. Also include all properties of Service ISO-TP Handles.
UDS Service RequestDownload
The properties of a UDS RequestDownload Handle. Also include all properties of Service ISO-TP Handles.
UDS Service RequestFileTransfer
The properties of a UDS RequestFileTransfer Handle. Also include all properties of Service ISO-TP Handles.
UDS Service RequestTransferExit
The properties of a UDS RequestTransferExit Handle. Also include all properties of Service ISO-TP Handles.
UDS Service RequestUpload
The properties of a UDS RequestUpload Handle. Also include all properties of Service ISO-TP Handles.
UDS Service ResponseOnEvent
The properties of a UDS ResponseOnEvent Handle. Also include all properties of Service ISO-TP Handles.
UDS Service RoutineControl
The properties of a UDS RoutineControl Handle. Also include all properties of Service ISO-TP Handles.
UDS Service SecuredDataTransmission
The properties of a UDS SecuredDataTransmission Handle. Also include all properties of Service ISO-TP Handles.
UDS Service SecurityAccess
The properties of a UDS SecurityAccess Handle. Also include all properties of Service ISO-TP Handles.
UDS Service TesterPresent
The properties of a UDS TesterPresent Handle. Also include all properties of Service ISO-TP Handles.
UDS Service TransferData
The properties of a UDS TransferData Handle. Also include all properties of Service ISO-TP Handles.
UDS Service WriteMemoryByAddress
The properties of a UDS WriteMemoryByAddress Handle. Also include all properties of Service ISO-TP Handles.
Generated on Fri May 30 2025 17:16:14 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: First Frame Callback Object

First Frame Callback Object
Protocol ISO-TP

The First Frame Callback Object

You should first read through the Unified Access.
Here all specific Tags of the temporary First Frame Callback Object can be looked up. The Tags from Protocol ISO-TP are also supported.
This Object is only extending the Protocol ISO-TP Object for its ff_callback context.

Property Tags

Tag | Default Value | Type | Description
frame_id | <> | 32bit Number | The frame ID of the First Frame Candidate.
frame_data | <> | Binary | The Frame Data as they were on the bus.
nad | <> | 8bit Number | The node address of the First Frame Candidate. If the Frame is definitely a ISO-TP frame without NAD, requesting this property will result in a BLC_UA_GET_VALUE_REJECTED.
payload_nad | <> | Binary | The Protocol payload of the First Frame Candidate. Interpreting Byte 1 as PCI.
payload_no_nad | <> | Binary | The Protocol payload of the First Frame Candidate. Interpreting Byte 0 as PCI.
Generated on Fri May 30 2025 17:16:14 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: Service ISO-TP

Service ISO-TP
Protocol ISO-TP

The Base ISO-TP protocol service

You should first read through the Unified Access.
Here all available Tags of an ISO-TP Service can be looked up.

Child Tags

Tag | Type | Description
mapping | Void | Free mappings can be realized by using this tag. e.g. storing the value 0x1337 with 16 bits into the request with an offset of 8 bits: BLC_setSignedNumber(service_handle, "mapping offset=8 length=16 request", 0x1337);

Property Tags

Tag | Default Value | Type | Description
name | "" | String | The name, by which the Service ISO-TP can be found.
index | <> | 32bit Number | The Service's index in the Protocol ISO-TP 's service list.
state | <> | 32bit Number | The Services current state of execution.
req_complete | <> | Callback | The function to call after the Request was completely send or received. The function is called by the thread that started the service execution.
rsp_complete | <> | Callback | The function to call after the Response was completely send or received, this will happen multiple times if the negative response code is 0x78 (continue to send) and max_continue_count is greater then 1. The function is called by the thread that started the service execution.
receive_flow | <> | Callback | The function to call after a flow control frame is received. The function is called by the thread that started the service execution.
send_flow | <> | Callback | The function to call before a flow control frame was send. The function is called by the thread that started the service execution.
– | – | – | –
req_node_address | from Protocol ISO-TP | 16bit Number | The NAD in the request frame(s).
rsp_node_address | from Protocol ISO-TP | 16bit Number | The NAD in the response frame(s).
req_frame_id | from Protocol ISO-TP | 32bit Number | The frame id of the request frame(s).
rsp_frame_id | from Protocol ISO-TP | 32bit Number | The frame id of the response frame(s).
req_slottime | from Protocol ISO-TP | 32bit Number | The slot time of the request frame(s). This value is also send in flow control frames when simulating the response.
rsp_slottime | from Protocol ISO-TP | 32bit Number | The slot time of the response frame(s). This value is also send in flow control frames when simulating the request.
timeout_frame | from Protocol ISO-TP | 32bit Number | If a send frame is not received within this time the service execution is aborted.
timeout_response | from Protocol ISO-TP | 32bit Number | If the response (or a flow control frame) is not received within this timeout the service execution is aborted.
slave_only | from Protocol ISO-TP | Boolean | Indicates, that the device is configured as a LIN-Slave and can not actively schedule frames. It is required to set this value to true for protocol slave implementations. not applicable on CAN channels.
lin_version | from Protocol ISO-TP | 2bit Number | The LIN version of the checksum. not applicable on CAN channels.
extend_frameid | from Protocol ISO-TP | Boolean | The frame id length (11 Bits in case of false, 29 Bits other wise) used for request and response frames. not applicable for LIN channels.
req_data | <> | Binary | The request payload.
rsp_data | <> | Binary | The response payload.
service_id | -1 | 16bit Number | The Service ID or sid of the request. If the value is between 0 and 255 the first byte of the simulated request will be set to this value when executing the service.
rsp_service_id | -1 | 16bit Number | The Response Service ID or rsid of the response. If the value is between 0 and 255 the first byte of the simulated response will be set to this value, after the request is completed in the service execution.
negative_response_code | 0 | 8bit Number | The negative response code or nrc from the last/current service execution.
req_simulate | true | Boolean | If true the request is send(simulated) by the application.
rsp_simulate | false | Boolean | If true the response is send(simulated) by the application.
req_flowstate | CAN:0 | 4bit Number | The status value of the last/next flow control frame received/send during the request.
rsp_flowstate | CAN:0 | 4bit Number | The status value of the last/next flow control frame received/send during the response.
req_blocksize | from Protocol ISO-TP | 8bit Number | The block size value of the last/next flow control frame received/send during the request.
rsp_blocksize | from Protocol ISO-TP | 8bit Number | The block size value of the last/next flow control frame received/send during the response.
max_flow_wait | from Protocol ISO-TP | 32bit Number | For this may times the flow state is allowed to be 1, before aborting the service execution.
max_continue_count | from Protocol ISO-TP | 32bit Number | For this may times the Response will be repeated when a negative response code of 0x78 (continue to send) is received.
padding | from Protocol ISO-TP | 8bit Number | The value to fill the last frame with if not optimized. This value is also the default value for not mapped parts of the request and response payload.
optimize | from Protocol ISO-TP | Boolean | If this is set to true the last frame of the request and response will be transmitted with just the required frame length. e.g. a request with NAD and 3 bytes payload will have only 5 bytes instead of 8.

Method Tags

Tag | Parameters | Description
execute | – | Executes the service. Return values in the range of: 0-255 = The negative_response_code (-255)-(-1) = The result of an intermediate command, send by the Device multiplied by '-1', to distinguish it from negative_response_code values.
wait_complete | timeout=64bit Number | Stalls until the service stops executing or the timeout is reached. The timeout is given in milliseconds, its default value is 5,8*10^8 years.
wait_start | timeout=64bit Number | Stalls until the service starts executing or the timeout is reached. The timeout is given in milliseconds, its default value is 5,8*10^8 years.

Free Mapping

Your are free to extract arbitrary data from the request and response. In opposition to other Objects in the tree, no handle can be generated for Free Mapping objects, so they can only be used in getters or setters. In the following examples a short is written into the request, so that the request data is {0x10, 0x01}:

// first the 0x10 is written to request byte 0 then 0x01 to request byte 1
BLC_setUnsignedNumber(service_handle, "mapping offset=0 length=16 request", 0x0110);

To achieve the same with motorola byte order (MSB first (0x01)):

// first the 0x01 is written to request byte 1 then 0x10 to request byte 0
BLC_setUnsignedNumber(service_handle, "mapping offset=8 length=16 type=motorolasawtooth request", 0x1001);

Child Tags

Tag | Default Value | Type | Description
offset | 0 | 32bit Number | The offset of the mapping in bits. the value always takes reference to bit0 of the value to map.
length | 0xFFFFFFFF | 32bit Number | The length of the mapping in bits. If the length is 0xFFFFFFFF the length is inferred from the specific getter or setter function. 64 for BLC_getSignedNumber, BLC_getUnsignedNumber, BLC_setSignedNumber and BLC_setUnsignedNumber, 64 bit length is also assumed if the length value was set to a value greater then 64. (8 * data length) for BLC_getBinary and BLC_setBinary.
extend | true | Boolean | If set to "true"(1) the request/response will be enlarged, so that the given data fits in. other wise the returned value might indicate, that no data was mapped.
type | 0/"intelsawtooth" | 2bit Number String | The bit and byte order to apply. 0=="intelsawtooth", 1=="intelsequential", 2=="motorolasawtooth", 3=="motorolasequential"

Property Tags

Tag | Type | Description
request | 64bit Number Binary | Apply the mapping to the request payload.
response | 64bit Number Binary | Apply the mapping to the response payload.
Generated on Fri May 30 2025 17:16:14 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: UDS Service ECUReset

UDS Service ECUReset
Protocol ISO-TP

The UDS ECUReset service

You should first read through the Unified Access.
Here all specific Tags of an UDS ECU reset service can be looked up. The Tags from Service ISO-TP are also supported.

Property Tags

Tag | Default Value | Type | Description
service_id | 0x11 | 16bit Number | The Service ID or sid of the request.
rsp_service_id | 0x51 | 16bit Number | The Response Service ID or rsid of the response.
req_subfunction | 1 | 8bit Number | the reset type of the request.
rsp_subfunction | <> | 8bit Number | the reset type of the response.
rsp_powerDownTime | <> | 8bit Number | the power down time of the response.
Generated on Fri May 30 2025 17:16:14 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: UDS Service InputOutputControlByIdentifier

UDS Service InputOutputControlByIdentifier
Protocol ISO-TP

The UDS InputOutputControlByIdentifier service

You should first read through the Unified Access.
Here all specific Tags of an UDS input output control by identifier service can be looked up. The Tags from Service ISO-TP are also supported.

Property Tags

Tag | Default Value | Type | Description
service_id | 0x2F | 16bit Number | The Service ID or sid of the request.
rsp_service_id | 0x6F | 16bit Number | The Response Service ID or rsid of the response.
req_dataIdentifier | <> | 16bit Number | the data identifier of the request.
req_controlOptionRecord | <> | Binary | the control option record of the request, might also contain the controlEnableMaskRecord.
rsp_dataIdentifier | <> | 16bit Number | the data identifier of the response.
rsp_controlStatusRecord | <> | Binary | the control status record of the response.
Generated on Fri May 30 2025 17:16:14 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: UDS Service ReadDataByIdentifier

UDS Service ReadDataByIdentifier
Protocol ISO-TP

The UDS ReadByDataIdentifier service

You should first read through the Unified Access.
Here all specific Tags of an UDS read data by identifier service can be looked up. The Tags from Service ISO-TP are also supported.

Property Tags

Tag | Default Value | Type | Description
service_id | 0x22 | 16bit Number | The Service ID or sid of the request.
rsp_service_id | 0x62 | 16bit Number | The Response Service ID or rsid of the response.
req_dataIdentifier | <> | 16bit Number | the data identifier from the request
rsp_dataIdentifier | <> | 16bit Number | the data identifier from the response
rsp_dataRecord | <> | Binary | the data record from the response
Generated on Fri May 30 2025 17:16:14 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: UDS Service WriteDataByIdentifier

UDS Service WriteDataByIdentifier
Protocol ISO-TP

The UDS WriteByDataIdentifier service

You should first read through the Unified Access.
Here all specific Tags of an UDS write data by identifier service can be looked up. The Tags from Service ISO-TP are also supported.

Property Tags

Tag | Default Value | Type | Description
service_id | 0x2E | 16bit Number | The Service ID or sid of the request.
rsp_service_id | 0x6E | 16bit Number | The Response Service ID or rsid of the response.
req_dataIdentifier | <> | 16bit Number | the data identifier of the request
req_dataRecord | <> | Binary | the data record of the request
rsp_dataIdentifier | <> | 16bit Number | the data identifier of the response
Generated on Fri May 30 2025 17:16:14 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: UDS Service AccessTimingParameter

UDS Service AccessTimingParameter
Protocol ISO-TP

The UDS AccessTimingParameter service

You should first read through the Unified Access.
Here all specific Tags of an UDS access timing parameter service can be looked up. The Tags from Service ISO-TP are also supported.

Property Tags

Tag | Default Value | Type | Description
service_id | 0x83 | 16bit Number | The Service ID or sid of the request.
rsp_service_id | 0xC3 | 16bit Number | The Response Service ID or rsid of the response.
req_subfunction | 3 | 8bit Number | The sub function or timing parameter access type of the request.
req_TimingParameterRequestRecord | <> | Binary | The timing parameter request record of the request.
rsp_subfunction | <> | 8bit Number | The sub function or timing parameter access type of the response.
rsp_TimingParameterResponseRecord | <> | Binary | The timing parameter response record of the response.
Generated on Fri May 30 2025 17:16:14 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: UDS Service ClearDiagnosticInformation

UDS Service ClearDiagnosticInformation
Protocol ISO-TP

The UDS ClearDiagnosticInformation service

You should first read through the Unified Access.
Here all specific Tags of an UDS clear diagnostic information service can be looked up. The Tags from Service ISO-TP are also supported.

Property Tags

Tag | Default Value | Type | Description
service_id | 0x14 | 16bit Number | The Service ID or sid of the request.
rsp_service_id | 0x54 | 16bit Number | The Response Service ID or rsid of the response.
req_groupOfDTC | <> | 24bit Number | The group of DTC of the request.
Generated on Fri May 30 2025 17:16:14 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: UDS Service CommunicationControl

UDS Service CommunicationControl
Protocol ISO-TP

The UDS CommunicationControl service

You should first read through the Unified Access.
Here all specific Tags of an UDS communication control service can be looked up. The Tags from Service ISO-TP are also supported.

Property Tags

Tag | Default Value | Type | Description
service_id | 0x28 | 16bit Number | The Service ID or sid of the request.
rsp_service_id | 0x68 | 16bit Number | The Response Service ID or rsid of the response.
req_subfunction | 0 | 8bit Number | The sub function or control type of the request.
req_communicationType | 1 | 8bit Number | The communication type of the request.
req_nodeIdentificationNumber | <> | 16bit Number | The node identification number of the request.
rsp_subfunction | <> | 8bit Number | The sub function or control type of the response.
Generated on Fri May 30 2025 17:16:14 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: UDS Service ControlDTCSetting

UDS Service ControlDTCSetting
Protocol ISO-TP

The UDS ControlDTCSetting service

You should first read through the Unified Access.
Here all specific Tags of an UDS control DTC setting service can be looked up. The Tags from Service ISO-TP are also supported.

Property Tags

Tag | Default Value | Type | Description
service_id | 0x85 | 16bit Number | The Service ID or sid of the request.
rsp_service_id | 0xC5 | 16bit Number | The Response Service ID or rsid of the response.
req_subfunction | 1 | 8bit Number | The sub function or DTC setting type of the request.
req_DTCSettingControlOptionRecord | <> | Binary | The DTC setting control option record of the request.
rsp_subfunction | <> | 8bit Number | The sub function or DTC setting type of the response.
Generated on Fri May 30 2025 17:16:14 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: UDS Service DiagnosticSessionControl

UDS Service DiagnosticSessionControl
Protocol ISO-TP

The UDS DiagnosticSessionControl service

You should first read through the Unified Access.
Here all specific Tags of an UDS diagnostic session control service can be looked up. The Tags from Service ISO-TP are also supported.

Property Tags

Tag | Default Value | Type | Description
service_id | 0x10 | 16bit Number | The Service ID or sid of the request.
rsp_service_id | 0x50 | 16bit Number | The Response Service ID or rsid of the response.
req_subfunction | 1 | 8bit Number | The sub function or diagnostic session type of the request.
rsp_subfunction | <> | 8bit Number | The sub function or diagnostic session type of the response.
rsp_sessionParameterRecord | <> | Binary | The session parameter record of the response.
rsp_P2 | <> | 16bit Number | The P2 server max timing value of the response.
rsp_P2* | <> | 16bit Number | The P2* server max enhanced timing value of the response.
Generated on Fri May 30 2025 17:16:14 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: UDS Service DynamicallyDefineDataIdentifier

UDS Service DynamicallyDefineDataIdentifier
Protocol ISO-TP

The UDS DynamicallyDefineDataIdentifier service

You should first read through the Unified Access.
Here all specific Tags of an UDS dynamically define data identifier service can be looked up. The Tags from Service ISO-TP are also supported.

Property Tags

Tag | Default Value | Type | Description
service_id | 0x2C | 16bit Number | The Service ID or sid of the request.
rsp_service_id | 0x6C | 16bit Number | The Response Service ID or rsid of the response.
Generated on Fri May 30 2025 17:16:14 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: UDS Service LinkControl

UDS Service LinkControl
Protocol ISO-TP

The UDS LinkCotntrol service

You should first read through the Unified Access.
Here all specific Tags of an UDS link control service can be looked up. The Tags from Service ISO-TP are also supported.

Property Tags

Tag | Default Value | Type | Description
service_id | 0x87 | 16bit Number | The Service ID or sid of the request.
rsp_service_id | 0xC7 | 16bit Number | The Response Service ID or rsid of the response.
req_subfunction | <> | 8bit Number | The sub function or link control type of the request. Setting this value will update the requests message length appropriately.
req_linkControlModeIdentifier | <> | 8bit Number | The link control mode identifier of the request.
req_linkRecord | <> | 24bit Number | The link record of the request.
rsp_subfunction | <> | 8bit Number | The sub function or link control type of the response.
Generated on Fri May 30 2025 17:16:14 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: UDS Service ReadDataByPeriodicIdentifier

UDS Service ReadDataByPeriodicIdentifier
Protocol ISO-TP

The UDS ReadDataByPeriodicIdentifier service

You should first read through the Unified Access.
Here all specific Tags of an UDS read data by periodic identifier service can be looked up. The Tags from Service ISO-TP are also supported.

Property Tags

Tag | Default Value | Type | Description
service_id | 0x2A | 16bit Number | The Service ID or sid of the request.
rsp_service_id | 0x6A | 16bit Number | The Response Service ID or rsid of the response.
Generated on Fri May 30 2025 17:16:14 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: UDS Service ReadDTCInformation

Modules
UDS Service ReadDTCInformation
Protocol ISO-TP

Detailed Description

The UDS ReadDTCInformation service

You should first read through the Unified Access.
Here all specific Tags of an UDS read DTC information service can be looked up.
The Tags from Service ISO-TP are also supported.

Property Tags

Tag | Default Value | Type | Description
service_id | 0x19 | 16bit Number | The Service ID or sid of the request.
rsp_service_id | 0x59 | 16bit Number | The Response Service ID or rsid of the response.
req_subfunction | <> | 8bit Number | The sub function or report type of the request. Setting this value will change the actual object type to that of the given sub function id.
rsp_subfunction | <> | 8bit Number | The sub function or report type of the response. Setting this value will change the actual object type to that of the given sub function id.

Modules

ReportNumberOfDTCByStatusMask
The specialized Prooperties of reportNumberOfDTCByStatusMask Subfuction ID 0x01.
ReportDTCByStatusMask
The specialized Prooperties of reportDTCByStatusMask Subfuction ID 0x02.
ReportDTCSnapshotIdentification
The specialized Prooperties of reportDTCSnapshotIdentification Subfuction ID 0x03.
ReportDTCSnapshotRecordByDTCNumber
The specialized Prooperties of reportDTCSnapshotRecordByDTCNumber Subfuction ID 0x04.
ReportDTCStoredDataByRecordNumber
The specialized Prooperties of reportDTCStoredDataByRecordNumber Subfuction ID 0x05.
ReportDTCExtDataRecordByDTCNumber
The specialized Prooperties of reportDTCExtDataRecordByDTCNumber Subfuction ID 0x06.
ReportNumberOfDTCBySeverityMaskRecord
The specialized Prooperties of reportNumberOfDTCBySeverityMaskRecord Subfuction ID 0x07.
ReportDTCBySeverityMaskRecord
The specialized Prooperties of reportDTCBySeverityMaskRecord Subfuction ID 0x08.
ReportSeverityInformationOfDTC
The specialized Prooperties of reportSeverityInformationOfDTC Subfuction ID 0x09.
ReportSupportedDTC
The specialized Prooperties of reportSupportedDTC Subfuction ID 0x0A.
ReportFirstTestFailedDTC
The specialized Prooperties of reportFirstTestFailedDTC Subfuction ID 0x0B.
ReportFirstConfirmedDTC
The specialized Prooperties of reportFirstConfirmedDTC Subfuction ID 0x0C.
ReportMostRecentTestFailedDTC
The specialized Prooperties of reportMostRecentTestFailedDTC Subfuction ID 0x0D.
ReportMostRecentConfirmedDTC
The specialized Prooperties of reportMostRecentConfirmedDTC Subfuction ID 0x0E.
ReportMirrorMemoryDTCByStatusMask
The specialized Prooperties of reportMirrorMemoryDTCByStatusMask Subfuction ID 0x0F.
ReportMirrorMemoryDTCExtDataRecordByDTCNumber
The specialized Prooperties of reportMirrorMemoryDTCExtDataRecordByDTCNumber Subfuction ID 0x10.
ReportNumberOfMirrorMemoryDTCByStatusMask
The specialized Prooperties of reportNumberOfMirrorMemoryDTCByStatusMask Subfuction ID 0x11.
ReportNumberOfEmissionsOBDDTCByStatusMask
The specialized Prooperties of reportNumberOfEmissionsOBDDTCByStatusMask Subfuction ID 0x12.
ReportEmissionsOBDDTCByStatusMask
The specialized Prooperties of reportEmissionsOBDDTCByStatusMask Subfuction ID 0x13.
ReportDTCFaultDetectionCounter
The specialized Prooperties of reportDTCFaultDetectionCounter Subfuction ID 0x14.
ReportDTCWithPermanentStatus
The specialized Prooperties of reportDTCWithPermanentStatus Subfuction ID 0x15.
ReportDTCExtDataRecordByRecordNumber
The specialized Prooperties of reportDTCExtDataRecordByRecordNumber Subfuction ID 0x16.
ReportUserDefMemoryDTCByStatusMask
The specialized Prooperties of reportUserDefMemoryDTCByStatusMask Subfuction ID 0x17.
ReportUserDefMemoryDTCSnapshotRecordByDTCNumber
The specialized Prooperties of reportUserDefMemoryDTCSnapshotRecordByDTCNumber Subfuction ID 0x18.
ReportUserDefMemoryDTCExtDataRecordByDTCNumber
The specialized Prooperties of reportUserDefMemoryDTCExtDataRecordByDTCNumber Subfuction ID 0x19.
ReportWWHOBDDTCByMaskRecord
The specialized Prooperties of reportWWHOBDDTCByMaskRecord Subfuction ID 0x42.
ReportWWHOBDDTCWithPermanentStatus
The specialized Prooperties of reportWWHOBDDTCWithPermanentStatus Subfuction ID 0x55.
Generated on Fri May 30 2025 17:16:14 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: ReportNumberOfDTCByStatusMask

ReportNumberOfDTCByStatusMask
UDS Service ReadDTCInformation

The UDS ReadDTCInformation ReportNumberOfDTCByStatusMask Subfuction ID 0x01.

You should first read through the Unified Access.
Here additional Tags of this ReadDTCInformation Subfunction can be looked up.
The Tags from UDS Service ReadDTCInformation and Service ISO-TP are also supported.

Property Tags

Tag | Default Value | Type | Description
req_subfunction | 1 | 8bit Number | The sub function or report type of the request. Setting this value will change the actual object type to that of the given sub function id.
rsp_subfunction | 1 | 8bit Number | The sub function or report type of the response. Setting this value will change the actual object type to that of the given sub function id.
req_dtcstatusmask | <> | 8bit Number | The DTC Status Mask of the Request.
rsp_dtcstatusavailabilitymask | <> | 8bit Number | The DTC Status Availability Mask of the Response.
rsp_dtcformatidentifier | <> | 8bit Number | The DTC Format Identifier of the Response.
rsp_dtccount | <> | 16bit Number | The DTC Count of the Response.
Generated on Fri May 30 2025 17:16:14 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: ReportDTCByStatusMask

ReportDTCByStatusMask
UDS Service ReadDTCInformation

The UDS ReadDTCInformation ReportDTCByStatusMask Subfuction ID 0x02.

You should first read through the Unified Access.
Here additional Tags of this ReadDTCInformation Subfunction can be looked up.
The Tags from UDS Service ReadDTCInformation and Service ISO-TP are also supported.

Property Tags

Tag | Default Value | Type | Description
req_subfunction | 2 | 8bit Number | The sub function or report type of the request. Setting this value will change the actual object type to that of the given sub function id.
rsp_subfunction | 2 | 8bit Number | The sub function or report type of the response. Setting this value will change the actual object type to that of the given sub function id.
req_dtcstatusmask | <> | 8bit Number | The DTC Status Mask of the Request.
rsp_dtcstatusavailabilitymask | <> | 8bit Number | The DTC Status Availability Mask of the Response.
rsp_dtcandstatusrecords | <> | Binary | The DTC And Status Records of the Response. This is a List of 4 byte blocks. The first, second and third byte are the DTC value(MSB first). The fourth byte is the statusOfDTC value.
Generated on Fri May 30 2025 17:16:14 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: ReportDTCSnapshotIdentification

ReportDTCSnapshotIdentification
UDS Service ReadDTCInformation

The UDS ReadDTCInformation ReportDTCSnapshotIdentification Subfuction ID 0x03.

You should first read through the Unified Access.
Here additional Tags of this ReadDTCInformation Subfunction can be looked up.
The Tags from UDS Service ReadDTCInformation and Service ISO-TP are also supported.

Property Tags

Tag | Default Value | Type | Description
req_subfunction | 3 | 8bit Number | The sub function or report type of the request. Setting this value will change the actual object type to that of the given sub function id.
rsp_subfunction | 3 | 8bit Number | The sub function or report type of the response. Setting this value will change the actual object type to that of the given sub function id.
req_dtcmaskrecord | <> | 24bit Number Binary | The DTC Mask Record of the Request.
req_dtcsnapshotrecordnumber | <> | 8bit Number | The DTC Snapshot Record Number of the Request.
rsp_dtcrecords | <> | Binary | The DTC Records of the Response. This is a list of 4 byte blocks, containing DTCRecord and DTCSnapshotRecordNumber. The first, second and third bytes are the DTC value(MSB first). The fourth byte is the DTCSnapshotRecordNumber.
Generated on Fri May 30 2025 17:16:14 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: ReportDTCSnapshotRecordByDTCNumber

ReportDTCSnapshotRecordByDTCNumber
UDS Service ReadDTCInformation

The UDS ReadDTCInformation ReportDTCSnapshotRecordByDTCNumber Subfuction ID 0x04.

You should first read through the Unified Access.
Here additional Tags of this ReadDTCInformation Subfunction can be looked up.
The Tags from UDS Service ReadDTCInformation and Service ISO-TP are also supported.

Property Tags

Tag | Default Value | Type | Description
req_subfunction | 4 | 8bit Number | The sub function or report type of the request. Setting this value will change the actual object type to that of the given sub function id.
rsp_subfunction | 4 | 8bit Number | The sub function or report type of the response. Setting this value will change the actual object type to that of the given sub function id.
req_dtcmaskrecord | <> | 24bit Number Binary | The DTC Mask Record of the Request.
req_dtcsnapshotrecordnumber | <> | 8bit Number | The DTC Snapshot Record Number of the Request.
rsp_dtcandstatusrecord | <> | 32bit Number Binary | The DTC And Status Record of the Response. The first, second and third byte are the DTC value(MSB first). The fourth byte is the statusOfDTC value. When accessed as Number the LSB ist the statusOfDTC.
rsp_dtcsnapshotrecords | <> | Binary | The DTC Snapshot Records of the Response. This is a list consisting of DTCSnapshotRecordNumber, DTCSnapshotRecordNumberOfIdentifiers and DTCSnapshotRecord. The first byte is the DTCSnapshotRecordNumber. The second byte is the DTCSnapshotRecordNumberOfIdentifiers, followed by the DTCSnapshotRecord. The DTCSnapshotRecord is a List of DataIdentifers and the corresponding snapshotData. The first and second bytes are the DataIdentifier value(MSB first), followed by the snapshotData. The size of the snapshotData has to be defined by the manufacturer and thus the position of the next DataIdentifier and DTCSnapshotRecordNumber.
Generated on Fri May 30 2025 17:16:14 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: ReportDTCStoredDataByRecordNumber

ReportDTCStoredDataByRecordNumber
UDS Service ReadDTCInformation

The UDS ReadDTCInformation ReportDTCStoredDataByRecordNumber Subfuction ID 0x05.

You should first read through the Unified Access.
Here additional Tags of this ReadDTCInformation Subfunction can be looked up.
The Tags from UDS Service ReadDTCInformation and Service ISO-TP are also supported.

Property Tags

Tag | Default Value | Type | Description
req_subfunction | 5 | 8bit Number | The sub function or report type of the request. Setting this value will change the actual object type to that of the given sub function id.
rsp_subfunction | 5 | 8bit Number | The sub function or report type of the response. Setting this value will change the actual object type to that of the given sub function id.
req_dtcstoreddatarecordnumber | <> | 8bit Number | The DTC Stored Data Record Number of the Request.
rsp_dtcstoreddatarecords | <> | Binary | The DTC Stored Data Records of the Response. This is a list consisting of DTCStoredDataRecordNumber, DTCAndStatusRecord, DTCStoredDataRecordNumberOfIdentifiers and DTCStoredDataRecord. The first byte is the DTCStoredDataRecordNumber. The second, third and fourth bytes are the DTC value(MSB first). The fifth byte id the statusOfDTC. The sixth byte is the DTCStoredDataRecordNumberOfIdentifiers, followed by the DTCStoredDataRecord. The DTCStoredDataRecord is a List of DataIdentifers and the corresponding DTCStoredData. The first and second bytes are the DataIdentifier value(MSB first), followed by the DTCStoredData. The size of the DTCStoredData has to be defined by the manufacturer and thus the position of the next DataIdentifier and DTCStoredDataRecordNumber.
Generated on Fri May 30 2025 17:16:14 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: ReportDTCExtDataRecordByDTCNumber

ReportDTCExtDataRecordByDTCNumber
UDS Service ReadDTCInformation

The UDS ReadDTCInformation ReportDTCExtDataRecordByDTCNumber Subfuction ID 0x06.

You should first read through the Unified Access.
Here additional Tags of this ReadDTCInformation Subfunction can be looked up.
The Tags from UDS Service ReadDTCInformation and Service ISO-TP are also supported.

Property Tags

Tag | Default Value | Type | Description
req_subfunction | 6 | 8bit Number | The sub function or report type of the request. Setting this value will change the actual object type to that of the given sub function id.
rsp_subfunction | 6 | 8bit Number | The sub function or report type of the response. Setting this value will change the actual object type to that of the given sub function id.
req_dtcmaskrecord | <> | 24bit Number Binary | The DTC Mask Record of the Request.
req_dtcextdatarecordnumber | <> | 8bit Number | The DTC Ext Data Record Number of the Request.
rsp_dtcandstatusrecord | <> | 32bit Number Binary | The DTC And Status Record of the Response. The first, second and third byte are the DTC value(MSB first). The fourth byte is the statusOfDTC value. When accessed as Number the LSB is the statusOfDTC.
rsp_dtcextdatarecords | <> | Binary | The DTC Extended Data Records of the Response. This is a List consisting of DTCExtDataRecordNumber and DTCExtDataRecord. The first byte is the DTCExtDataRecordNumber. The DTCExtDataRecord has to be defined by the manufacturer and thus the position of the next DTCExtDataRecordNumber.
Generated on Fri May 30 2025 17:16:14 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: ReportNumberOfDTCBySeverityMaskRecord

ReportNumberOfDTCBySeverityMaskRecord
UDS Service ReadDTCInformation

The UDS ReadDTCInformation ReportNumberOfDTCBySeverityMaskRecord Subfuction ID 0x07.

You should first read through the Unified Access.
Here additional Tags of this ReadDTCInformation Subfunction can be looked up.
The Tags from UDS Service ReadDTCInformation and Service ISO-TP are also supported.

Property Tags

Tag | Default Value | Type | Description
req_subfunction | 7 | 8bit Number | The sub function or report type of the request. Setting this value will change the actual object type to that of the given sub function id.
rsp_subfunction | 7 | 8bit Number | The sub function or report type of the response. Setting this value will change the actual object type to that of the given sub function id.
req_dtcseveritymaskrecord | <> | Binary | The DTC Severity Mask Record of the Request.
rsp_dtcstatusavailabilitymask | <> | 8bit Number | The DTC Status Availability Mask of the Response.
rsp_dtcformatidentifier | <> | 8bit Number | The DTC Format Identifier of the Response.
rsp_dtccount | <> | 16bit Number | The DTC Count of the Response.
Generated on Fri May 30 2025 17:16:14 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: ReportDTCBySeverityMaskRecord

ReportDTCBySeverityMaskRecord
UDS Service ReadDTCInformation

The UDS ReadDTCInformation ReportDTCBySeverityMaskRecord Subfuction ID 0x08.

You should first read through the Unified Access.
Here additional Tags of this ReadDTCInformation Subfunction can be looked up.
The Tags from UDS Service ReadDTCInformation and Service ISO-TP are also supported.

Property Tags

Tag | Default Value | Type | Description
req_subfunction | 8 | 8bit Number | The sub function or report type of the request. Setting this value will change the actual object type to that of the given sub function id.
rsp_subfunction | 8 | 8bit Number | The sub function or report type of the response. Setting this value will change the actual object type to that of the given sub function id.
req_dtcseveritymaskrecord | <> | Binary | The DTC Severity Mask Record of the Request.
rsp_dtcstatusavailabilitymask | <> | 8bit Number | The DTC Status Availability Mask of the Response.
rsp_dtcandseverityrecords | <> | Binary | The DTC And Severity Records of the Response. This is a List of 6 byte blocks. The first byte is the DTC Severity value. The second byte is the DTC Functional Unit. The third, fourth and fifth byte are the DTC value(MSB first). The sixth byte is the statusOfDTC value.
Generated on Fri May 30 2025 17:16:14 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: ReportSeverityInformationOfDTC

ReportSeverityInformationOfDTC
UDS Service ReadDTCInformation

The UDS ReadDTCInformation ReportDTCSeverityInformation Subfuction ID 0x09.

You should first read through the Unified Access.
Here additional Tags of this ReadDTCInformation Subfunction can be looked up.
The Tags from UDS Service ReadDTCInformation and Service ISO-TP are also supported.

Property Tags

Tag | Default Value | Type | Description
req_subfunction | 9 | 8bit Number | The sub function or report type of the request. Setting this value will change the actual object type to that of the given sub function id.
rsp_subfunction | 9 | 8bit Number | The sub function or report type of the response. Setting this value will change the actual object type to that of the given sub function id.
req_dtcmaskrecord | <> | 24bit Number Binary | The DTC Mask Record of the Request.
rsp_dtcstatusavailabilitymask | <> | 8bit Number | The DTC Status Availability Mask of the Response.
rsp_dtcandseverityrecords | <> | Binary | The DTC And Severity Records of the Response. This is a List of 6 byte blocks. The first byte is the DTC Severity value. The second byte is the DTC Functional Unit. The third, fourth and fifth byte are the DTC value(MSB first). The sixth byte is the statusOfDTC value.
Generated on Fri May 30 2025 17:16:14 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: ReportSupportedDTC

ReportSupportedDTC
UDS Service ReadDTCInformation

The UDS ReadDTCInformation ReportSupportedDTC Subfuction ID 0x0A.

You should first read through the Unified Access.
Here additional Tags of this ReadDTCInformation Subfunction can be looked up.
The Tags from UDS Service ReadDTCInformation and Service ISO-TP are also supported.

Property Tags

Tag | Default Value | Type | Description
req_subfunction | 0xA | 8bit Number | The sub function or report type of the request. Setting this value will change the actual object type to that of the given sub function id.
rsp_subfunction | 0xA | 8bit Number | The sub function or report type of the response. Setting this value will change the actual object type to that of the given sub function id.
rsp_dtcstatusavailabilitymask | <> | 8bit Number | The DTC Status Availability Mask of the Response.
rsp_dtcandstatusrecords | <> | Binary | The DTC And Status Records of the Response. This is a List of 4 byte blocks. The first, second and third byte are the DTC value(MSB first). The fourth byte is the statusOfDTC value.
Generated on Fri May 30 2025 17:16:14 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: ReportFirstTestFailedDTC

ReportFirstTestFailedDTC
UDS Service ReadDTCInformation

The UDS ReadDTCInformation ReportFirstTestFailedDTC Subfuction ID 0x0B.

You should first read through the Unified Access.
Here additional Tags of this ReadDTCInformation Subfunction can be looked up.
The Tags from UDS Service ReadDTCInformation and Service ISO-TP are also supported.

Property Tags

Tag | Default Value | Type | Description
req_subfunction | 0x0B | 8bit Number | The sub function or report type of the request. Setting this value will change the actual object type to that of the given sub function id.
rsp_subfunction | 0x0B | 8bit Number | The sub function or report type of the response. Setting this value will change the actual object type to that of the given sub function id.
rsp_dtcstatusavailabilitymask | <> | 8bit Number | The DTC Status Availability Mask of the Response.
rsp_dtcandstatusrecords | <> | Binary | The DTC And Status Records of the Response. This is a List of 4 byte blocks. The first, second and third byte are the DTC value(MSB first). The fourth byte is the statusOfDTC value.
Generated on Fri May 30 2025 17:16:14 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: ReportFirstConfirmedDTC

ReportFirstConfirmedDTC
UDS Service ReadDTCInformation

The UDS ReadDTCInformation ReportFirstConfirmedDTC Subfuction ID 0x0C.

You should first read through the Unified Access.
Here additional Tags of this ReadDTCInformation Subfunction can be looked up.
The Tags from UDS Service ReadDTCInformation and Service ISO-TP are also supported.

Property Tags

Tag | Default Value | Type | Description
req_subfunction | 0x0C | 8bit Number | The sub function or report type of the request. Setting this value will change the actual object type to that of the given sub function id.
rsp_subfunction | 0x0C | 8bit Number | The sub function or report type of the response. Setting this value will change the actual object type to that of the given sub function id.
rsp_dtcstatusavailabilitymask | <> | 8bit Number | The DTC Status Availability Mask of the Response.
rsp_dtcandstatusrecords | <> | Binary | The DTC And Status Records of the Response. This is a List of 4 byte blocks. The first, second and third byte are the DTC value(MSB first). The fourth byte is the statusOfDTC value.
Generated on Fri May 30 2025 17:16:14 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: ReportMostRecentTestFailedDTC

ReportMostRecentTestFailedDTC
UDS Service ReadDTCInformation

The UDS ReadDTCInformation ReportMostRecentTestFailedDTC Subfuction ID 0x0D.

You should first read through the Unified Access.
Here additional Tags of this ReadDTCInformation Subfunction can be looked up.
The Tags from UDS Service ReadDTCInformation and Service ISO-TP are also supported.

Property Tags

Tag | Default Value | Type | Description
req_subfunction | 0x0D | 8bit Number | The sub function or report type of the request. Setting this value will change the actual object type to that of the given sub function id.
rsp_subfunction | 0x0D | 8bit Number | The sub function or report type of the response. Setting this value will change the actual object type to that of the given sub function id.
rsp_dtcstatusavailabilitymask | <> | 8bit Number | The DTC Status Availability Mask of the Response.
rsp_dtcandstatusrecords | <> | Binary | The DTC And Status Records of the Response. This is a List of 4 byte blocks. The first, second and third byte are the DTC value(MSB first). The fourth byte is the statusOfDTC value.
Generated on Fri May 30 2025 17:16:14 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: ReportMostRecentConfirmedDTC

ReportMostRecentConfirmedDTC
UDS Service ReadDTCInformation

The UDS ReadDTCInformation ReportMostRecentConfirmedDTC Subfuction ID 0x0E.

You should first read through the Unified Access.
Here additional Tags of this ReadDTCInformation Subfunction can be looked up.
The Tags from UDS Service ReadDTCInformation and Service ISO-TP are also supported.

Property Tags

Tag | Default Value | Type | Description
req_subfunction | 0x0E | 8bit Number | The sub function or report type of the request. Setting this value will change the actual object type to that of the given sub function id.
rsp_subfunction | 0x0E | 8bit Number | The sub function or report type of the response. Setting this value will change the actual object type to that of the given sub function id.
rsp_dtcstatusavailabilitymask | <> | 8bit Number | The DTC Status Availability Mask of the Response.
rsp_dtcandstatusrecords | <> | Binary | The DTC And Status Records of the Response. This is a List of 4 byte blocks. The first, second and third byte are the DTC value(MSB first). The fourth byte is the statusOfDTC value.
Generated on Fri May 30 2025 17:16:14 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: ReportMirrorMemoryDTCByStatusMask

ReportMirrorMemoryDTCByStatusMask
UDS Service ReadDTCInformation

The UDS ReadDTCInformation ReportMirrorMemoryDTCByStatusMask Subfuction ID 0x0F.

You should first read through the Unified Access.
Here additional Tags of this ReadDTCInformation Subfunction can be looked up.
The Tags from UDS Service ReadDTCInformation and Service ISO-TP are also supported.

Property Tags

Tag | Default Value | Type | Description
req_subfunction | 0x0F | 8bit Number | The sub function or report type of the request. Setting this value will change the actual object type to that of the given sub function id.
rsp_subfunction | 0x0F | 8bit Number | The sub function or report type of the response. Setting this value will change the actual object type to that of the given sub function id.
req_dtcstatusmask | <> | 8bit Number | The DTC Status Mask of the Request.
rsp_dtcstatusavailabilitymask | <> | 8bit Number | The DTC Status Availability Mask of the Response.
rsp_dtcandstatusrecords | <> | Binary | The DTC And Status Records of the Response. This is a List of 4 byte blocks. The first, second and third byte are the DTC value(MSB first). The fourth byte is the statusOfDTC value.
Generated on Fri May 30 2025 17:16:14 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: ReportMirrorMemoryDTCExtDataRecordByDTCNumber

ReportMirrorMemoryDTCExtDataRecordByDTCNumber
UDS Service ReadDTCInformation

The UDS ReadDTCInformation ReportMirrorMemoryDTCExtDataRecordByDTCNumber Subfuction ID 0x10.

You should first read through the Unified Access.
Here additional Tags of this ReadDTCInformation Subfunction can be looked up.
The Tags from UDS Service ReadDTCInformation and Service ISO-TP are also supported.

Property Tags

Tag | Default Value | Type | Description
req_subfunction | 0x10 | 8bit Number | The sub function or report type of the request. Setting this value will change the actual object type to that of the given sub function id.
rsp_subfunction | 0x10 | 8bit Number | The sub function or report type of the response. Setting this value will change the actual object type to that of the given sub function id.
req_dtcmaskrecord | <> | 24bit Number Binary | The DTC Mask Record of the Request.
req_dtcextdatarecordnumber | <> | 8bit Number | The DTC Ext Data Record Number of the Request.
rsp_dtcandstatusrecord | <> | 32bit Number Binary | The DTC And Status Record of the Response. The first, second and third byte are the DTC value(MSB first). The fourth byte is the statusOfDTC value. When accessed as Number the LSB is the statusOfDTC.
rsp_dtcextdatarecords | <> | Binary | The DTC Extended Data Records of the Response. This is a List consisting of DTCExtDataRecordNumber and DTCExtDataRecord. The first byte is the DTCExtDataRecordNumber. The DTCExtDataRecord has to be defined by the manufacturer and thus the position of the next DTCExtDataRecordNumber.
Generated on Fri May 30 2025 17:16:14 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: ReportNumberOfMirrorMemoryDTCByStatusMask

ReportNumberOfMirrorMemoryDTCByStatusMask
UDS Service ReadDTCInformation

The UDS ReadDTCInformation ReportNumberOfMirrorMemoryDTCByStatusMask Subfuction ID 0x11.

You should first read through the Unified Access.
Here additional Tags of this ReadDTCInformation Subfunction can be looked up.
The Tags from UDS Service ReadDTCInformation and Service ISO-TP are also supported.

Property Tags

Tag | Default Value | Type | Description
req_subfunction | 0x11 | 8bit Number | The sub function or report type of the request. Setting this value will change the actual object type to that of the given sub function id.
rsp_subfunction | 0x11 | 8bit Number | The sub function or report type of the response. Setting this value will change the actual object type to that of the given sub function id.
req_dtcstatusmask | <> | 8bit Number | The DTC Status Mask of the Request.
rsp_dtcstatusavailabilitymask | <> | 8bit Number | The DTC Status Availability Mask of the Response.
rsp_dtcformatidentifier | <> | 8bit Number | The DTC Format Identifier of the Response.
rsp_dtccount | <> | 16bit Number | The DTC Count of the Response.
Generated on Fri May 30 2025 17:16:14 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: ReportNumberOfEmissionsOBDDTCByStatusMask

ReportNumberOfEmissionsOBDDTCByStatusMask
UDS Service ReadDTCInformation

The UDS ReadDTCInformation ReportNumberOfEmissionsOBDDTCByStatusMask Subfuction ID 0x12.

You should first read through the Unified Access.
Here additional Tags of this ReadDTCInformation Subfunction can be looked up.
The Tags from UDS Service ReadDTCInformation and Service ISO-TP are also supported.

Property Tags

Tag | Default Value | Type | Description
req_subfunction | 0x12 | 8bit Number | The sub function or report type of the request. Setting this value will change the actual object type to that of the given sub function id.
rsp_subfunction | 0x12 | 8bit Number | The sub function or report type of the response. Setting this value will change the actual object type to that of the given sub function id.
req_dtcstatusmask | <> | 8bit Number | The DTC Status Mask of the Request.
rsp_dtcstatusavailabilitymask | <> | 8bit Number | The DTC Status Availability Mask of the Response.
rsp_dtcformatidentifier | <> | 8bit Number | The DTC Format Identifier of the Response.
rsp_dtccount | <> | 16bit Number | The DTC Count of the Response.
Generated on Fri May 30 2025 17:16:14 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: ReportEmissionsOBDDTCByStatusMask

ReportEmissionsOBDDTCByStatusMask
UDS Service ReadDTCInformation

The UDS ReadDTCInformation ReportEmissionsOBDDTCByStatusMask Subfuction ID 0x13.

You should first read through the Unified Access.
Here additional Tags of this ReadDTCInformation Subfunction can be looked up.
The Tags from UDS Service ReadDTCInformation and Service ISO-TP are also supported.

Property Tags

Tag | Default Value | Type | Description
req_subfunction | 0x13 | 8bit Number | The sub function or report type of the request. Setting this value will change the actual object type to that of the given sub function id.
rsp_subfunction | 0x13 | 8bit Number | The sub function or report type of the response. Setting this value will change the actual object type to that of the given sub function id.
req_dtcstatusmask | <> | 8bit Number | The DTC Status Mask of the Request.
rsp_dtcstatusavailabilitymask | <> | 8bit Number | The DTC Status Availability Mask of the Response.
rsp_dtcandstatusrecords | <> | Binary | The DTC And Status Records of the Response. This is a List of 4 byte blocks. The first, second and third byte are the DTC value(MSB first). The fourth byte is the statusOfDTC value.
Generated on Fri May 30 2025 17:16:14 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: ReportDTCFaultDetectionCounter

ReportDTCFaultDetectionCounter
UDS Service ReadDTCInformation

The UDS ReadDTCInformation ReportDTCFaultDetectionCounter Subfuction ID 0x14.

You should first read through the Unified Access.
Here additional Tags of this ReadDTCInformation Subfunction can be looked up.
The Tags from UDS Service ReadDTCInformation and Service ISO-TP are also supported.

Property Tags

Tag | Default Value | Type | Description
req_subfunction | 0x14 | 8bit Number | The sub function or report type of the request. Setting this value will change the actual object type to that of the given sub function id.
rsp_subfunction | 0x14 | 8bit Number | The sub function or report type of the response. Setting this value will change the actual object type to that of the given sub function id.
rsp_dtcfaultdetectioncounterrecord | <> | Binary | The DTC Fault Detection Counter Record of the Response. This is a List of 4 byte blocks. The first, second and third byte are the DTC value(MSB first). The fourth byte is the DTC Fault Detection Counter value.
Generated on Fri May 30 2025 17:16:14 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: ReportDTCWithPermanentStatus

ReportDTCWithPermanentStatus
UDS Service ReadDTCInformation

The UDS ReadDTCInformation ReportDTCWithPermanentStatus Subfuction ID 0x15.

You should first read through the Unified Access.
Here additional Tags of this ReadDTCInformation Subfunction can be looked up.
The Tags from UDS Service ReadDTCInformation and Service ISO-TP are also supported.

Property Tags

Tag | Default Value | Type | Description
req_subfunction | 0x15 | 8bit Number | The sub function or report type of the request. Setting this value will change the actual object type to that of the given sub function id.
rsp_subfunction | 0x15 | 8bit Number | The sub function or report type of the response. Setting this value will change the actual object type to that of the given sub function id.
rsp_dtcstatusavailabilitymask | <> | 8bit Number | The DTC Status Availability Mask of the Response.
rsp_dtcandstatusrecords | <> | Binary | The DTC And Status Records of the Response. This is a List of 4 byte blocks. The first, second and third byte are the DTC value(MSB first). The fourth byte is the statusOfDTC value.
Generated on Fri May 30 2025 17:16:14 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: ReportDTCExtDataRecordByRecordNumber

ReportDTCExtDataRecordByRecordNumber
UDS Service ReadDTCInformation

The UDS ReadDTCInformation ReportDTCExtDataRecordByRecordNumber Subfuction ID 0x16.

You should first read through the Unified Access.
Here additional Tags of this ReadDTCInformation Subfunction can be looked up.
The Tags from UDS Service ReadDTCInformation and Service ISO-TP are also supported.

Property Tags

Tag | Default Value | Type | Description
req_subfunction | 0x16 | 8bit Number | The sub function or report type of the request. Setting this value will change the actual object type to that of the given sub function id.
rsp_subfunction | 0x16 | 8bit Number | The sub function or report type of the response. Setting this value will change the actual object type to that of the given sub function id.
req_dtcextdatarecordnumber | <> | 8bit Number | The DTC Extended Data Record Number of the Request.
rsp_dtcextdatarecordnumber | <> | 8bit Number | The DTC Extended Data Record Number of the Response.
rsp_dtcextdatarecords | <> | Binary | The DTC Extended Data Records of the Response. This is a List of DTCAndStatusRecord and DTCExtDataRecord fields. The first, second and third byte are the DTC value(MSB first). The fourth byte is the statusOfDTC value. The manufacturer has to document the amount and format of the following bytes forming the DTCExtDataRecord and thus where the next Record begins.
Generated on Fri May 30 2025 17:16:14 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: ReportUserDefMemoryDTCByStatusMask

ReportUserDefMemoryDTCByStatusMask
UDS Service ReadDTCInformation

The UDS ReadDTCInformation ReportUserDefMemoryDTCByStatusMask Subfuction ID 0x17.

You should first read through the Unified Access.
Here additional Tags of this ReadDTCInformation Subfunction can be looked up.
The Tags from UDS Service ReadDTCInformation and Service ISO-TP are also supported.

Property Tags

Tag | Default Value | Type | Description
req_subfunction | 0x17 | 8bit Number | The sub function or report type of the request. Setting this value will change the actual object type to that of the given sub function id.
rsp_subfunction | 0x17 | 8bit Number | The sub function or report type of the response. Setting this value will change the actual object type to that of the given sub function id.
req_dtcstatusmask | <> | 8bit Number | The DTC Status Mask of the Request.
req_memoryselection | <> | 8bit Number | The Memory Selection of the Request.
rsp_memoryselection | <> | 8bit Number | The Memory Selection of the Response.
rsp_dtcstatusavailabilitymask | <> | 8bit Number | The DTC Status Availability Mask of the Response.
rsp_dtcandstatusrecords | <> | Binary | The DTC And Status Records of the Response. This is a List of 4 byte blocks. The first, second and third byte are the DTC value(MSB first). The fourth byte is the statusOfDTC value.
Generated on Fri May 30 2025 17:16:14 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: ReportUserDefMemoryDTCSnapshotRecordByDTCNumber

ReportUserDefMemoryDTCSnapshotRecordByDTCNumber
UDS Service ReadDTCInformation

The UDS ReadDTCInformation ReportUserDefMemoryDTCSnapshotRecordByDTCNumber Subfuction ID 0x18.

You should first read through the Unified Access.
Here additional Tags of this ReadDTCInformation Subfunction can be looked up.
The Tags from UDS Service ReadDTCInformation and Service ISO-TP are also supported.

Property Tags

Tag | Default Value | Type | Description
req_subfunction | 0x18 | 8bit Number | The sub function or report type of the request. Setting this value will change the actual object type to that of the given sub function id.
rsp_subfunction | 0x18 | 8bit Number | The sub function or report type of the response. Setting this value will change the actual object type to that of the given sub function id.
req_dtcmaskrecord | <> | 24bit Number Binary | The DTC Mask Record of the Request.
req_dtcsnapshotrecordnumber | <> | 8bit Number | The DTC Snapshot Record Number of the Request.
req_memoryselection | <> | 8bit Number | The Memory Selection of the Request.
rsp_memoryselection | <> | 8bit Number | The Memory Selection of the Response.
rsp_dtcandstatusrecord | <> | 32bit Number Binary | The DTC And Status Record of the Response. The first, second and third byte are the DTC value(MSB first). The fourth byte is the statusOfDTC value. When accessed as Number the LSB is the statusOfDTC.
rsp_dtcsnapshotrecords | <> | Binary | The DTC Snapshot Records of the Response. The first byte of a DTC Snapshot Record is the record index. The second byte of a DTC Snapshot Record is the number of identifiers in the record. The actual record data starts with the third byte and is a list of 2 Bytes dataIdentfiers (MSB first) followed by the values associated with the dataIdentifier, the length of these values has to be documented in the by the manufacturer of the Device you are communicating with.
Generated on Fri May 30 2025 17:16:14 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: ReportUserDefMemoryDTCExtDataRecordByDTCNumber

ReportUserDefMemoryDTCExtDataRecordByDTCNumber
UDS Service ReadDTCInformation

The UDS ReadDTCInformation ReportUserDefMemoryDTCExtDataRecordByDTCNumber Subfuction ID 0x19.

You should first read through the Unified Access.
Here additional Tags of this ReadDTCInformation Subfunction can be looked up.
The Tags from UDS Service ReadDTCInformation and Service ISO-TP are also supported.

Property Tags

Tag | Default Value | Type | Description
req_subfunction | 0x19 | 8bit Number | The sub function or report type of the request. Setting this value will change the actual object type to that of the given sub function id.
rsp_subfunction | 0x19 | 8bit Number | The sub function or report type of the response. Setting this value will change the actual object type to that of the given sub function id.
req_dtcmaskrecord | <> | 24bit Number Binary | The DTC Mask Record of the Request.
req_dtcextdatarecordnumber | <> | 8bit Number | The DTC Ext Data Record Number of the Request.
req_memoryselection | <> | 8bit Number | The Memory Selection of the Request.
rsp_memoryselection | <> | 8bit Number | The Memory Selection of the Response.
rsp_dtcandstatusrecord | <> | 32bit Number Binary | The DTC And Status Record of the Response. The first, second and third byte are the DTC value(MSB first). The fourth byte is the statusOfDTC value. When accessed as Number the LSB is the statusOfDTC.
rsp_dtcextdatarecords | <> | Binary | The DTC Extended Data Records of the Response. This is a list of DataRecords. In each Record, the first byte is the DTCExtDataRecordNumber, followed by the DTCExtDataRecord data. The length of each record has to be documented by the manufacturer.
Generated on Fri May 30 2025 17:16:14 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: ReportWWHOBDDTCByMaskRecord

ReportWWHOBDDTCByMaskRecord
UDS Service ReadDTCInformation

The UDS ReadDTCInformation ReportWWHOBDDTCByMaskRecord Subfuction ID 0x42.

You should first read through the Unified Access.
Here additional Tags of this ReadDTCInformation Subfunction can be looked up.
The Tags from UDS Service ReadDTCInformation and Service ISO-TP are also supported.

Property Tags

Tag | Default Value | Type | Description
req_subfunction | 0x42 | 8bit Number | The sub function or report type of the request. Setting this value will change the actual object type to that of the given sub function id.
rsp_subfunction | 0x42 | 8bit Number | The sub function or report type of the response. Setting this value will change the actual object type to that of the given sub function id.
req_functionalgroupidentifier | <> | 8bit Number | The Functional Group Identifier of the Request.
req_dtcseveritymaskrecord | <> | Binary | The DTC Severity Mask Record of the Request.
rsp_functionalgroupidentifier | <> | 8bit Number | The Functional Group Identifier of the Response.
rsp_dtcstatusavailabilitymask | <> | 8bit Number | The DTC Status Availability Mask of the Response.
rsp_dtcseverityavailabilitymask | <> | 8bit Number | The DTC Severity Availability Mask of the Response.
rsp_dtcformatidentifier | <> | 8bit Number | The DTC Format Identifier of the Response.
rsp_dtcandseverityrecords | <> | Binary | The DTC And Severity Record of the Response. This is a List of 5 byte blocks. The first byte is the DTC Severity. The second, third and fourth byte are the DTC value(MSB first). The fifth byte is the statusOfDTC value.
Generated on Fri May 30 2025 17:16:14 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: ReportWWHOBDDTCWithPermanentStatus

ReportWWHOBDDTCWithPermanentStatus
UDS Service ReadDTCInformation

The UDS ReadDTCInformation ReportWWHOBDDTCWithPermanentStatus Subfuction ID 0x55.

You should first read through the Unified Access.
Here additional Tags of this ReadDTCInformation Subfunction can be looked up.
The Tags from UDS Service ReadDTCInformation and Service ISO-TP are also supported.

Property Tags

Tag | Default Value | Type | Description
req_subfunction | 0x55 | 8bit Number | The sub function or report type of the request. Setting this value will change the actual object type to that of the given sub function id.
rsp_subfunction | 0x55 | 8bit Number | The sub function or report type of the response. Setting this value will change the actual object type to that of the given sub function id.
req_functionalgroupidentifier | <> | 8bit Number | The Functional Group Identifier of the Request.
rsp_functionalgroupidentifier | <> | 8bit Number | The Functional Group Identifier of the Response.
rsp_dtcstatusavailabilitymask | <> | 8bit Number | The DTC Status Availability Mask of the Response.
rsp_dtcformatidentifier | <> | 8bit Number | The DTC Format Identifier of the Response.
rsp_dtcandstatusrecords | <> | Binary | The DTC And Status Records of the Response. This is a List of 4 byte blocks. The first, second and third byte are the DTC value(MSB first). The fourth byte is the statusOfDTC value.
Generated on Fri May 30 2025 17:16:14 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: UDS Service ReadMemoryByAddress

UDS Service ReadMemoryByAddress
Protocol ISO-TP

The UDS ReadMemoryByAddress service

You should first read through the Unified Access.
Here all specific Tags of an UDS read memory by address service can be looked up. The Tags from Service ISO-TP are also supported.

Property Tags

Tag | Default Value | Type | Description
service_id | 0x23 | 16bit Number | The Service ID or sid of the request.
rsp_service_id | 0x63 | 16bit Number | The Response Service ID or rsid of the response.
req_memoryAddress | <> | 64bit Number Binary | The memory address of the request. if set as a number only the required bytes are stored.
req_memorySize | <> | 64bit Number Binary | The memory size of the request. if set as a number only the required bytes are stored.
req_addressAndLengthFormatIdentifier | <> | 8bit Number | The address length format identifier of the request. This value is updated when setting req_memoryAddress or req_memorySize properties.
rsp_dataRecord | <> | Binary | The data record of the response.
Generated on Fri May 30 2025 17:16:14 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: UDS Service ReadScalingDataByIdentifier

UDS Service ReadScalingDataByIdentifier
Protocol ISO-TP

The UDS ReadScalingByIdentifier service

You should first read through the Unified Access.
Here all specific Tags of an UDS read scaling by identifier service can be looked up. The Tags from Service ISO-TP are also supported.

Property Tags

Tag | Default Value | Type | Description
service_id | 0x24 | 16bit Number | The Service ID or sid of the request.
rsp_service_id | 0x64 | 16bit Number | The Response Service ID or rsid of the response.
req_dataIdentifier | <> | 16bit Number | The data identifier of the request.
rsp_dataIdentifier | <> | 16bit Number | The data identifier of the response.
rsp_scalingByte | <> | 8bit Number | The scaling byte of the response.
rsp_scalingByteExtension | <> | Binary | The scaling byte extension of the response.
Generated on Fri May 30 2025 17:16:14 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: UDS Service RequestDownload

UDS Service RequestDownload
Protocol ISO-TP

The UDS RequestDownload service

You should first read through the Unified Access.
Here all specific Tags of an UDS request download service can be looked up. The Tags from Service ISO-TP are also supported.

Property Tags

Tag | Default Value | Type | Description
service_id | 0x34 | 16bit Number | The Service ID or sid of the request.
rsp_service_id | 0x74 | 16bit Number | The Response Service ID or rsid of the response.
req_dataFormatIdentifier | <> | 8bit Number | The data format identifier of the request.
req_memoryAddress | <> | 64bit Number Binary | The memory address of the request. If set as a number only the required bytes are stored.
req_memorySize | <> | 64bit Number Binary | The memory size of the request. If set as a number only the required bytes are stored.
req_addressAndLengthFormatIdentifier | <> | 8bit Number | The address length format identifier of the request. This value is updated by setting the requests address or size properties.
rsp_maxNumberOfBlockLength | <> | 64bit Number Binary | The max number of blocks of the response. If set as a number only the required bytes are stored.
rsp_lengthFormatIdentifier | <> | 8bit Number | The length format identifier of the response. This value is updated by setting the responses max number of block length property.
Generated on Fri May 30 2025 17:16:14 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: UDS Service RequestFileTransfer

UDS Service RequestFileTransfer
Protocol ISO-TP

The UDS RequestFileTransfer service

You should first read through the Unified Access.
Here all specific Tags of an UDS request file transfer service can be looked up. The Tags from Service ISO-TP are also supported.

Property Tags

Tag | Default Value | Type | Description
service_id | 0x38 | 16bit Number | The Service ID or sid of the request.
rsp_service_id | 0x78 | 16bit Number | The Response Service ID or rsid of the response.
req_modeOfOperation | <> | 8bit Number | The mode of operation of the request. Setting this value to 2 or 5 will remove the data format identifier and file length values. Setting this value to 4 will only remove the file length values.
req_filePathAndName | <> | Binary | The file path and name of the request.
req_dataFormatIdentifier | <> | 8bit Number | The data format identifier of the request.
req_fileSizeUnCompressed | <> | 64bit Number Binary | The file size uncompressed of the request. If the given value is shorter then file size parameter length the value is prepends zeros to match the length. If the value is longer the file size parameter length is enlarged. If the value is set as number the file size parameter is tested to be narrowed to the minimal required value.
req_fileSizeCompressed | <> | 64bit Number Binary | The file size uncompressed of the request. If the given value is shorter then file size parameter length the value is prepends zeros to match the length. If the value is longer the file size parameter length is enlarged. If the value is set as number the file size parameter is tested to be narrowed to the minimal required value.
req_filePathAndNameLength | <> | 16bit Number | The file path and name length of the request. This value is updated by setting the file path and name parameter.
req_fileSizeParameterLength | <> | 8bit Number | The file size parameter length of the request. Setting this value will update the file size uncompressed and file size compressed values.
rsp_modeOfOperation | <> | 8bit Number | The mode of operation of the response.
rsp_maxNumberOfBlockLength | <> | 64bit Number Binary | The maximum number of block length of the response. Setting this value will update the length format identifier.
rsp_dataFormatIdentifier | <> | 8bit Number | The data format identifier of the response.
rsp_fileSizeOrDirInfoParameterLength | <> | 16bit Number | The file size or dir info parameter length of the response. Setting this value updates the length of file size uncompressed or dir info length and, if the mode of operation is not 5, also file size compressed.
rsp_fileSizeCompressed | <> | 64bit Number Binary | The file size compressed of the response. Setting this value will update the file size or dir info parameter length.
rsp_lengthFormatIdentifier | <> | 8bit Number | The length format identifier of the response. Setting this value will update the max Number of blocks value.
rsp_fileSizeUnCompressedOrDirInfoLength | <> | 64bit Number Binary | The file size uncompressed or dir info length of the response. Setting this value will update the file size or dir info parameter length.
Generated on Fri May 30 2025 17:16:14 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: UDS Service RequestTransferExit

UDS Service RequestTransferExit
Protocol ISO-TP

The UDS RequestTransferExit service

You should first read through the Unified Access.
Here all specific Tags of an UDS request transfer exit service can be looked up. The Tags from Service ISO-TP are also supported.

Property Tags

Tag | Default Value | Type | Description
service_id | 0x37 | 16bit Number | The Service ID or sid of the request.
rsp_service_id | 0x77 | 16bit Number | The Response Service ID or rsid of the response.
req_transferRequestParameterRecord | <> | Binary | The transfer parameter record of the request.
rsp_transferResponseParameterRecord | <> | Binary | The transfer parameter record of the response.
Generated on Fri May 30 2025 17:16:14 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: UDS Service RequestUpload

UDS Service RequestUpload
Protocol ISO-TP

The UDS RequestUpload service

You should first read through the Unified Access.
Here all specific Tags of an UDS request upload service can be looked up. The Tags from Service ISO-TP are also supported.

Property Tags

Tag | Default Value | Type | Description
service_id | 0x35 | 16bit Number | The Service ID or sid of the request.
rsp_service_id | 0x75 | 16bit Number | The Response Service ID or rsid of the response.
req_dataFormatIdentifier | <> | 8bit Number | The data format identifier of the request.
req_memoryAddress | <> | 64bit Number Binary | The memory address of the request. if set as a number only the required bytes are stored.
req_memorySize | <> | 64bit Number Binary | The memory size of the request. if set as a number only the required bytes are stored.
req_addressAndLengthFormatIdentifier | <> | 8bit Number | The address length format identifier of the request. This value is updated by setting the requests address or size properties.
rsp_maxNumberOfBlockLength | <> | 64bit Number Binary | The max number of blocks of the response.
rsp_lengthFormatIdentifier | <> | 8bit Number | The length format identifier of the response. This value is updated by setting the responses max number of block length property.
Generated on Fri May 30 2025 17:16:14 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: UDS Service ResponseOnEvent

UDS Service ResponseOnEvent
Protocol ISO-TP

The UDS ResponseOnEvent service

You should first read through the Unified Access.
Here all specific Tags of an UDS response on event service can be looked up. The Tags from Service ISO-TP are also supported.

Property Tags

Tag | Default Value | Type | Description
service_id | 0x86 | 16bit Number | The Service ID or sid of the request.
rsp_service_id | 0xC6 | 16bit Number | The Response Service ID or rsid of the response.
Generated on Fri May 30 2025 17:16:14 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: UDS Service RoutineControl

UDS Service RoutineControl
Protocol ISO-TP

The UDS RoutineControl service

You should first read through the Unified Access.
Here all specific Tags of an UDS routine control service can be looked up. The Tags from Service ISO-TP are also supported.

Property Tags

Tag | Default Value | Type | Description
service_id | 0x31 | 16bit Number | The Service ID or sid of the request.
rsp_service_id | 0x71 | 16bit Number | The Response Service ID or rsid of the response.
req_subfunction | <> | 8bit Number | The sub function id or routine control type of the request.
rsp_subfunction | <> | 8bit Number | The sub function id or routine control type of the response.
req_routineIdentifier | <> | 16bit Number | The routine identifier of the request.
req_routineControlOptionRecord | <> | Binary | The control option record of the request.
rsp_routineIdentifier | <> | 16bit Number | The routine identifier of the response.
rsp_routineInfo | <> | 8bit Number | The routine information of the response.
rsp_routineStatusRecord | <> | Binary | The routine status record routine information of the response.
Generated on Fri May 30 2025 17:16:14 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: UDS Service SecuredDataTransmission

UDS Service SecuredDataTransmission
Protocol ISO-TP

The UDS SecuredDataTransmission service

You should first read through the Unified Access.
Here all specific Tags of an UDS secured data transmission service can be looked up. The Tags from Service ISO-TP are also supported.

Property Tags

Tag | Default Value | Type | Description
service_id | 0x84 | 16bit Number | The Service ID or sid of the request.
rsp_service_id | 0xC4 | 16bit Number | The Response Service ID or rsid of the response.
req_securityDataRequestRecord | <> | Binary | The security data record of the request.
rsp_securityDataResponseRecord | <> | Binary | The security data record of the response.
Generated on Fri May 30 2025 17:16:14 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: UDS Service SecurityAccess

UDS Service SecurityAccess
Protocol ISO-TP

The UDS SecurityAccess service

You should first read through the Unified Access.
Here all specific Tags of an UDS security access service can be looked up. The Tags from Service ISO-TP are also supported.

Property Tags

Tag | Default Value | Type | Description
service_id | 0x27 | 16bit Number | The Service ID or sid of the request.
rsp_service_id | 0x67 | 16bit Number | The Response Service ID or rsid of the response.
req_subfunction | 1 | 8bit Number | The sub function id or access type of the request. The default configuration is request seed.
rsp_subfunction | <> | 8bit Number | The sub function id or access type of the response.
req_securityKey | <> | Binary | The security key of the request.
rsp_securitySeed | <> | Binary | The security seed of the response.
req_securityAccessDataRecord | <> | Binary | The security access data record of the request. This is an alias for the security access key.
Generated on Fri May 30 2025 17:16:14 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: UDS Service TesterPresent

UDS Service TesterPresent
Protocol ISO-TP

The UDS TesterPresent service

You should first read through the Unified Access.
Here all specific Tags of an UDS tester present service can be looked up. The Tags from Service ISO-TP are also supported.

Property Tags

Tag | Default Value | Type | Description
service_id | 0x3E | 16bit Number | The Service ID or sid of the request.
rsp_service_id | 0x7E | 16bit Number | The Response Service ID or rsid of the response.
timeout_response | 0 | 32bit Number | The time within the slave has to respond. the default value is : don't wait for a response. Change this value along with the req_subfunction property.
cycle_time | 0 | 32bit Number | The interval in milliseconds, after which the tester present Service has to be rescheduled. Setting this value to 0 will stop the sending thread. All other values will start the thread or, if the previous value was not null, update the interval after the next service execution.
req_subfunction | 0x80 | 8bit Number | The sub function id or zeroid of the request. The default configuration is do not respond. timeout_response should be updated too if this value is changed.
rsp_subfunction | <> | 8bit Number | The sub function id or zeroid of the response.
Generated on Fri May 30 2025 17:16:14 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: UDS Service TransferData

UDS Service TransferData
Protocol ISO-TP

The UDS TransferData service

You should first read through the Unified Access.
Here all specific Tags of an UDS transfer data service can be looked up. The Tags from Service ISO-TP are also supported.

Property Tags

Tag | Default Value | Type | Description
service_id | 0x36 | 16bit Number | The Service ID or sid of the request.
rsp_service_id | 0x76 | 16bit Number | The Response Service ID or rsid of the response.
req_blockSequenceCounter | 0 | 8bit Number | The block sequence counter of the request.
req_transferRequestParameterRecord | <> | Binary | The transfer request parameter record of the request.
rsp_blockSequenceCounter | 0 | 8bit Number | The block sequence counter of the response.
rsp_transferResponseParameterRecord | <> | Binary | The transfer response parameter record of the response.
Generated on Fri May 30 2025 17:16:14 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: UDS Service WriteMemoryByAddress

UDS Service WriteMemoryByAddress
Protocol ISO-TP

The UDS WriteByDataIdentifier service

You should first read through the Unified Access.
Here all specific Tags of an UDS write memory by address service can be looked up. The Tags from Service ISO-TP are also supported.

Property Tags

Tag | Default Value | Type | Description
service_id | 0x3D | 16bit Number | The Service ID or sid of the request.
rsp_service_id | 0x7D | 16bit Number | The Response Service ID or rsid of the response.
req_memoryAddress | <> | 64bit Number Binary | The memory address of the request. if set as a number only the required bytes are stored.
req_dataRecord | <> | Binary | The data record of the request. Setting this will also set the memory size of the request.
req_memorySize | <> | 64bit Number Binary | The memory size of the request. if set as a number only the required bytes are stored.
req_addressAndLengthFormatIdentifier | <> | 8bit Number | The address length format identifier of the request. This value is updated by setting the requests address, size or data properties.
rsp_memoryAddress | <> | 64bit Number Binary | The memory address of the response. if set as a number only the required bytes are stored.
rsp_memorySize | <> | 64bit Number Binary | The memory size of the response. if set as a number only the required bytes are stored.
rsp_addressAndLengthFormatIdentifier | <> | 8bit Number | The address length format identifier of the response. This value is updated by setting the responses address and size properties.
Generated on Fri May 30 2025 17:16:14 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: AdHoc Protocols

AdHoc Protocols

AdHoc

TEST SITE ADHOC
Generated on Fri May 30 2025 17:16:14 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: Connection Handling

Functions
Connection Handling

Detailed Description

The following functions are used to setup a connection to a BabyLIN device.

Functions

void BL_DLLIMPORT | BLC_getVersion (int *major, int *minor)
Get the major and minor version number of the library. More...
void BL_DLLIMPORT | BLC_getExtendedVersion (int *major, int *minor, int *patch, int *buildrev)
Get the major, minor and patch version number of the library. More...
CPCHAR BL_DLLIMPORT | BLC_getVersionString (void)
Get the version string of the library. More...
int BL_DLLIMPORT | BLC_getBabyLinPorts (BLC_PORTINFO portListToBeFilled[], int *pFoundPortCount)
Retrieve a list of ports a BabyLIN is connected to. More...
int BL_DLLIMPORT | BLC_getBabyLinPortsTimout (BLC_PORTINFO portListToBeFilled[], int *pFoundPortCount, int timoutms)
Retrieve a list of ports a BabyLIN is connected to. More...
BL_HANDLE BL_DLLIMPORT | BLC_open (unsigned int port)
Open a connection to a BabyLIN USB-Serial device. More...
BL_HANDLE BL_DLLIMPORT | BLC_openNet (const char *ip, int port)
Open a connection to a BabyLIN device using ethernet. More...
BL_HANDLE BL_DLLIMPORT | BLC_openUSB (const char *device)
Open a connection to a BabyLIN USB device. More...
BL_HANDLE BL_DLLIMPORT | BLC_openPort (BLC_PORTINFO portInfo)
Open a connection to a BabyLIN device using BLC_PORTINFO information. More...
int BL_DLLIMPORT | BLC_convertUrl (const char *url, BLC_PORTINFO *portInfo)
convert a device url to BLC_PORTINFO to use in BLC_openPort More...
int BL_DLLIMPORT | BLC_close (BL_HANDLE handle)
Close connection to Device. More...
int BL_DLLIMPORT | BLC_closeAll (void)
Close ALL connections to ALL Devices. More...
int BL_DLLIMPORT | BLC_flush (BL_HANDLE handle)
Reset the BabyLIN device to an consistent and deactivated state. More...
int BL_DLLIMPORT | BLC_getTargetID (BL_HANDLE handle, BLC_TARGETID *targetID)
Requests the information about the target. More...
int BL_DLLIMPORT | BLC_getHWType (BL_HANDLE handle)
Returns the unique hardware type identifier for a device. More...
int BL_DLLIMPORT | BLC_getChannelCount (BL_HANDLE handle)
number of channels provided by the BabyLIN-Device More...
BL_HANDLE BL_DLLIMPORT | BLC_getChannelHandle (BL_HANDLE handle, int channelId)
Retrieve a handle to the specified channel. More...
int BL_DLLIMPORT | BLC_getChannelInfo (BL_HANDLE handle, BLC_CHANNELINFO *pinfo)
Retrieve informations about the Channel. More...
int BL_DLLIMPORT | BLC_getLastError (BL_HANDLE handle, char *pErrorBuffer, int bufferLength)
Returns a C-string with the textual representation of the last error. More...
CPCHAR BL_DLLIMPORT | BLC_getErrorString (int error_code)
Returns a C-string with the textual representation of an error code. More...
int BL_DLLIMPORT | BLC_getDetailedErrorString (int errorCode, int reportParameter, char *pErrorBuffer, int bufferLength)
Returns a C-string with the detailed textual representation of all possible error codes. Get a detailed textual error message for an error code. More...
int BL_DLLIMPORT | BLC_Reset (BL_HANDLE handle)
Resets the BabyLIN device to an consistent and deactivated state. More...

Function Documentation

int BL_DLLIMPORT BLC_close ( BL_HANDLE handle )

close an open connection, given by handle.

Parameters
[in] handle Handle representing the connection ( see BLC_open )
Returns
Status of operation; '=0' means successful, '!=0' otherwise. See standard return values for error, or for textual representation BLC_getLastError.
int BL_DLLIMPORT BLC_closeAll ( void )

Close all open connections; all handles are invalidated.

Returns
Status of operation; '=0' means successful, '!=0' otherwise. See standard return values for error, or for textual representation BLC_getLastError.
int BL_DLLIMPORT BLC_convertUrl | ( | const char * | url,
 |  | BLC_PORTINFO * | portInfo
 | ) |  |

this function tries to convert a given url to a complete struct of type BLC_PORTINFO.

The device url defines the device and protocol: serial://1 Opens a USB connection on Windows using the BabyLIN library protocol. serial:///dev/ttyUSB1 Opens a USB connection on Linux using the BabyLIN library protocol. tcp://127.0.0.1:2048 Opens a network connection to a Baby-LIN-MB-II using the BabyLIN library protocol of the SimpleMenu mode. ascii://127.0.0.1:10003 Opens a network connection to a Baby-LIN-MB-II using the ASCII protocol of the StandAlone mode.

Note: While using only a port number does work under Linux, it is not recommended to use it. It will only work for old devices that are listed as "ttyUSB" devices. Newer devices will be listed as "ttyACM" and will require the full path to the device, as it is ambiguous which device is meant otherwise.

Parameters
[in] | url | The device url to convert might be a system path (serial:///dev/ttyUSB1) for unix based systems, a comport number (serial://1) as is used for windows or a network address (tcp://127.0.0.1:2048) to connect to a network device. The ASCII protocol of Baby-LIN-MB-II is supported as well (ascii://127.0.0.1:10003). Additionally, there exist a special shortcut for serial:://1 resp. serial:///dev/ttyUSB1 consisting of the single port number [COM]1. Thus, if an integer is given as a port number (started by an optional COM, e.g. COM1), then the protocol is set to BabyLIN library protocol (serial).
[out] | portInfo | The BLC_PORTINFO struct to fill.
Returns
BL_OK on success, error code otherwise (in case of error, the BLC_PORTINFO structure is left untouched)
int BL_DLLIMPORT BLC_flush ( BL_HANDLE handle )

Afterwards, the device will no longer monitor the bus, neither acting as slave nor as master.

Parameters
[in] handle Handle representing a channel; returned previously by BLC_getChannelHandle().
Returns
Status of operation; '=0' means successful, '!=0' otherwise. See standard return values for error, or for textual representation (for return values < -1000) BLC_getLastError.
int BL_DLLIMPORT BLC_getBabyLinPorts | ( | BLC_PORTINFO | portListToBeFilled[],
 |  | int * | pFoundPortCount
 | ) |  |

The function doesn't try to connect to the found Ports wraps BLC_getBabyLinPortsTimout with timout value set to 0ms. This function will not find any network-devices.

Parameters
[out] | portListToBeFilled | Preallocated array to be filled
[in,out] | pFoundPortCount | Input the size of the allocated array. Output the filled size of the array.
Returns
The number of connected BabyLINs found (>=0) or < 0 on error

example:

BLC_PORTINFO ports[2];
int maxPortCount = 2;
int foundCount = BLC_getBabyLinPorts(ports, &maxPortCount);
int foundEmpty = BLC_getBabyLinPorts(NULL, NULL);
// if there were 3 BabyLin connected to usb:
// foundCount == 2
// foundEmpty == 3
//if there is only 1 Babylin connected:
foundCount = BLC_getBabyLinPorts(ports, &maxPortCount);
foundEmpty = BLC_getBabyLinPorts(NULL, NULL);
//foundEmpty == 1;
//foundCount == 1;
int BL_DLLIMPORT BLC_getBabyLinPortsTimout | ( | BLC_PORTINFO | portListToBeFilled[],
 |  | int * | pFoundPortCount,
 |  | int | timoutms
 | ) |  |

The function doesn't try to connect to the found Ports. You can not connect to UDP network devices they are only listed FYI and have to be configured in SimpleMenu mode first. Network devices of type TCP will have the default Port configured(2048) for connection. If the Device's simplemenu-tcp-com-port configuration value was changed. you will have to change the BLC_PORTINFO.port prior to connecting via BLC_openPort(...).

Parameters
[out] | portListToBeFilled | Array to be filled
[in,out] | pFoundPortCount | Input the size of the allocated array. Output the filled size of the array.
timoutms | A timeout value in ms to wait for replies of network devices. If timoutms is set to <= 0 this Function will not find/look for any Network devices.
Returns
The number of connected BabyLINs found (>=0) or < 0 on error
int BL_DLLIMPORT BLC_getChannelCount ( BL_HANDLE handle )
Parameters
[in] handle Handle representing the connection (see BLC_open)
Returns
Number of channels >= 0 or < 0 on error. See standard return values for error, or for textual representation (for return values < -1000) BLC_getLastError.
BL_HANDLE BL_DLLIMPORT BLC_getChannelHandle | ( | BL_HANDLE | handle,
 |  | int | channelId
 | ) |  |

This function returns a channel-handle for the specified channelId. A channel-handle is used to control a LIN- or CAN-BUS on the BabyLIN-device.

Parameters
[in] | handle | Handle representing the Device connection ( see BLC_open )
channelId | Identifier for the channel to get the handle of. Ranges from 0 to the number of channels supported by the device (see BLC_getChannelCount)
Returns
Handle to the channel, 0 on error. You may fetch the corresponding (textual) with BLC_getLastError.
int BL_DLLIMPORT BLC_getChannelInfo | ( | BL_HANDLE | handle,
 |  | BLC_CHANNELINFO * | pinfo
 | ) |  |
Parameters
[in] | handle | Channelhandle representing the Channel. (see BLC_getChannelHandle)
[out] | pinfo | Pointer to pre-allocated BLC_CHANNELINFO structure to hold the information after the successful call
Returns
Status of operation; '=0' means successful, '!=0' otherwise. See standard return values for error, or for textual representation (for return values < -1000) BLC_getLastError.
int BL_DLLIMPORT BLC_getDetailedErrorString | ( | int | errorCode,
 |  | int | reportParameter,
 |  | char * | pErrorBuffer,
 |  | int | bufferLength
 | ) |  |
Parameters
errorCode | The error code.
reportParameter | If the error code comes from an event or error report, pass the additional data/status value. Otherwise just pass 0.
[out] | pErrorBuffer | A buffer with enough space.
bufferLength | The length of the passed buffer
Returns
BL_BUFFER_TOO_SMALL If the buffer is too small, otherwise the number of sources.
CPCHAR BL_DLLIMPORT BLC_getErrorString ( int error_code )

Get a textual error message for an error code.

Deprecated:
use BLC_getDetailedErrorString() instead
void BL_DLLIMPORT BLC_getExtendedVersion | ( | int * | major,
 |  | int * | minor,
 |  | int * | patch,
 |  | int * | buildrev
 | ) |  |

This function retrieves the version in the given parameter variables of the library.

Parameters
[out] | major | Major part of version number.
[out] | minor | Minor part of version number.
[out] | patch | Patch part of version number.
[out] | buildrev | Build revision of version number.
int BL_DLLIMPORT BLC_getHWType ( BL_HANDLE handle )
Parameters
[in] handle Handle representing the connection ( see BLC_open ) The hardware type or BabyLIN-error return code. See (BLC_TARGETID::type) for hardware types. See standard return values for error, or for textual representation (for return values < -1000) BLC_getLastError.
int BL_DLLIMPORT BLC_getLastError | ( | BL_HANDLE | handle,
 |  | char * | pErrorBuffer,
 |  | int | bufferLength
 | ) |  |

Get a textual error message for Errorcodes < -1000.

Deprecated:
use BLC_getDetailedErrorString() instead
Parameters
[in] | handle | Handle to the erroneous connection or channel.
[out] | pErrorBuffer | Pointer to allocated memory buffer to store error message
bufferLength | Allocated length of pErrorBuffer
Returns
Status of operation; '=0' means successful, '!=0' otherwise. See standard return values for error, or for textual representation (for return values < -1000) BLC_getLastError.
int BL_DLLIMPORT BLC_getTargetID | ( | BL_HANDLE | handle,
 |  | BLC_TARGETID * | targetID
 | ) |  |
Parameters
[in] | handle | Handle representing the connection (see BLC_open )
[out] | targetID | Pointer to pre-allocated BLC_TARGETID structure to hold the information after the successful call
Returns
Status of operation; '=0' means successful, '!=0' otherwise. See standard return values for error, or for textual representation (for return values < -1000) BLC_getLastError.
void BL_DLLIMPORT BLC_getVersion | ( | int * | major,
 |  | int * | minor
 | ) |  |
Deprecated:
Use BLC_getExtendedVersion instead

This function retrieves the version in the given parameter variables of the library.

Parameters
[out] | major | Major part of version number.
[out] | minor | Minor part of version number.
CPCHAR BL_DLLIMPORT BLC_getVersionString ( void )

This function returns the version string of the library.

Returns
Returns a C-string with the version information.
BL_HANDLE BL_DLLIMPORT BLC_open ( unsigned int port )

This function tries to open the designated port and to start communication with the device.

Parameters
port The port, the BabyLIN is connected to. It uses Windows-style numbering, which means it starts with '1' for the first serial port. '0' is reserved. On linux systems, the port is represented by the path to the device file ("/dev/ttyUSB0" f.ex.)
Returns
Returns an handle for the BabyLIN-connection or NULL if the connection could not be established. You may fetch the corresponding (textual) error with BLC_getLastError.
Deprecated:
use BLC_openPort() together with BLC_convertUrl() or BLC_getBabyLinPorts()
BL_HANDLE BL_DLLIMPORT BLC_openNet | ( | const char * | ip,
 |  | int | port
 | ) |  |

This function tries to open the designated ip and port and to start communication with the device.

Parameters
[in] | ip | The ip-address of the BabyLIN to connect to
port | The ip-port of the BabyLIN toconnected to
Returns
Returns an handle for the BabyLIN-connection or NULL if the connection could not be established. You may fetch the corresponding (textual) error with BLC_getLastError.
Deprecated:
use BLC_openPort() together with BLC_convertUrl() or BLC_getBabyLinPorts()
BL_HANDLE BL_DLLIMPORT BLC_openPort ( BLC_PORTINFO portInfo )

This function tries to open the BabyLIN device of the BLC_PORTINFO information, i.e. works as a wrapper for BLC_open and BLC_openNet which automatically decides which connection to establish.

Note
Platform independent way of connecting to BabyLIN-devices found by BLC_getBabyLinPorts or BLC_getBabyLinPortsTimout
Parameters
portInfo The BLC_PORTINFO-structure of the BabyLIN to connect to ( see BLC_getBabyLinPorts )
Returns
Returns an handle for the BabyLIN-connection or NULL if the connection could not be established. You may fetch the corresponding (textual) error with BLC_getLastError.
BL_HANDLE BL_DLLIMPORT BLC_openUSB ( const char * device )

This function tries to open the designated port and to start communication with the device.

Parameters
[in] device The usb device string, the BabyLIN is connected to.
Returns
Returns an handle for the BabyLIN-connection or NULL if the connection could not be established. You may fetch the corresponding (textual) error with BLC_getLastError.
Deprecated:
use BLC_openPort() together with BLC_convertUrl()
int BL_DLLIMPORT BLC_Reset ( BL_HANDLE handle )

Afterwards, the device will no longer monitor the bus, neither acting as slave nor as master.

Parameters
[in] handle Handle representing the connection. (see BLC_open )
Returns
Status of operation; '=0' means successful, '!=0' otherwise. See standard return values for error, or for textual representation (for return values < -1000) BLC_getLastError.
Generated on Fri May 30 2025 17:16:14 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: Command Functions

Functions
Command Functions

Detailed Description

List of functions to access the LIN-BUS directly.

The following functions are used to send commands to a BabyLIN device to set or retrieve simulation or device parameters.

Functions

int BL_DLLIMPORT | BLC_sendRaw (BL_HANDLE handle, const unsigned char *command, unsigned int *length)
Send a (raw!) command to the BabyLIN device. More...
int BL_DLLIMPORT | BLC_setDTLMode (BL_HANDLE handle, int mode)
Set the Diagnostic Transport Layer mode. More...
int BL_DLLIMPORT | BLC_sendDTLRequest (BL_HANDLE handle, unsigned char nad, int length, unsigned char *data)
Send a DTL master request to a node. More...
int BL_DLLIMPORT | BLC_sendDTLResponse (BL_HANDLE handle, unsigned char nad, int length, unsigned char *data)
Send a DTL slave response to a node. More...
int BL_DLLIMPORT | BLC_sendRawSlaveResponse (BL_HANDLE handle, unsigned char *reqdata, unsigned char *reqmask, unsigned char *data, int length)
Send a (non-DTL) slave response upon receive of matching master request. More...
int BL_DLLIMPORT | BLC_sendRawMasterRequest (BL_HANDLE handle, unsigned char *data, int count)
Send a (non-DTL) Master request with the specified 8 bytes as data. More...
int BL_DLLIMPORT | BLC_getDTLRequestStatus (BL_HANDLE handle)
Returns the status of the last request-send operation. More...
int BL_DLLIMPORT | BLC_getDTLResponseStatus (BL_HANDLE handle)
Returns the status of the last resonse-send operation. More...
int BL_DLLIMPORT | BLC_getRawSlaveResponse (BL_HANDLE handle, unsigned char *data, int length)
Returns the first 'length' bytes of the current slave response-buffer. More...
int BL_DLLIMPORT | BLC_updRawSlaveResponse (BL_HANDLE handle)
BLC_updRawSlaveResponse resets the internal dtl buffer. More...
int BL_DLLIMPORT | BLC_lastAnswerHasData (BL_HANDLE handle)
Returns BL_OK if the last answer to a command, send to the given handle, contained additional data. More...
int BL_DLLIMPORT | BLC_getAnswerTypeByName (BL_HANDLE handle, const char *name, BL_ANSWER_TYPE *type, size_t *length)
Get type of a parameter of the last answer data from a BabyLIN. More...
int BL_DLLIMPORT | BLC_getAnswerTypeByIndex (BL_HANDLE handle, const unsigned int index, BL_ANSWER_TYPE *type, size_t *length)
Get type of a parameter of the last answer data from a BabyLIN. More...
int BL_DLLIMPORT | BLC_getAnswerNameByIndex (BL_HANDLE handle, int index, char *nameBuffer, int *nameBufferLength)
Get name of a parameter of the last answer data from a BabyLIN. More...
int BL_DLLIMPORT | BLC_getAnswerByName (BL_HANDLE handle, const char *name, void *buffer, size_t length)
Get the value of a parameter of the last answer data from a BabyLIN. More...
int BL_DLLIMPORT | BLC_getAnswerByIndex (BL_HANDLE handle, const unsigned int index, void *buffer, size_t length)
Get the value of a parameter of the last answer data from a BabyLIN. More...
int BL_DLLIMPORT | BLC_sendCommand (BL_HANDLE handle, const char *command)
Send a command to the BabyLIN device. More...
int BL_DLLIMPORT | BLC_sendASCIICommand (BL_HANDLE handle, const char *command, char *buffer, int bufferLength, int timeout_ms)
Sends a ASCII protocol command and wait for its response. More...
int BL_DLLIMPORT | BLC_setsig (BL_HANDLE handle, int signalNr, unsigned long long value)
Shorthand for "setsig" command (see BabyLIN commands to use in BL_- and BLC_sendCommand Functions ) More...
int BL_DLLIMPORT | BLC_mon_set (BL_HANDLE handle, int frameid, const int *databytes, int len)
Shorthand for "mon_set" command (see BabyLIN commands to use in BL_- and BLC_sendCommand Functions ) More...
int BL_DLLIMPORT | BLC_mon_xmit (BL_HANDLE handle, int frameId, int slottime)
Shorthand for "mon_xmit" command (see BabyLIN commands to use in BL_- and BLC_sendCommand Functions ) More...
int BL_DLLIMPORT | BLC_mon_set_xmit (BL_HANDLE handle, int frameId, const int *databytes, int len, int slottime)
Shorthand for "mon_set" followed by "mon_xmit" command (see BabyLIN commands to use in BL_- and BLC_sendCommand Functions ) More...
int BL_DLLIMPORT | BLC_macro_result (BL_HANDLE handle, int macro_nr, int64_t *return_value, unsigned int timeout_ms)
Convenience function for command "macro_result" handling answer data. More...
int BL_DLLIMPORT | BLC_getMacroResultString (BL_HANDLE handle, int macro_nr, char *dstbuf, int buflen)
Returns the result string of given macro, if it was set within the macro. More...
int BL_DLLIMPORT | BLC_varRead (BL_HANDLE handle, int signal_nr, char *dstbuf, int length)
Returns the result of a "varrd" command in a convienent way. More...
int BL_DLLIMPORT | BLC_varWrite (BL_HANDLE handle, int signal_nr, char *data, int data_len)
Writes an array of signals to values given by a bytearray. More...
BLC_ADHOC_PROTOCOL BL_DLLIMPORT | BLC_AdHoc_DefaultProtocol (ADHOC_PROTOCOL_TYPE type)
Creates a adhoc protocol struct with the default settings for the given protocol type. More...
BLC_ADHOC_SERVICE BL_DLLIMPORT | BLC_AdHoc_DefaultService (const BLC_ADHOC_PROTOCOL protocol)
Creates a adhoc service struct with the default settings for the service and protocol combination. More...
BLC_ADHOC_EXECUTE BL_DLLIMPORT BLC_AdHoc_DefaultExecute ()
Creates a adhoc execute struct with the default settings for the execution of adhoc protocols. More...
int BL_DLLIMPORT | BLC_AdHoc_CreateProtocol (BL_HANDLE channel, BLC_ADHOC_PROTOCOL *protocol, BL_ADHOC_HANDLE *protocol_handle)
Creates a adhoc protocol in the device with the given settings. More...
int BL_DLLIMPORT | BLC_AdHoc_CreateService (BL_HANDLE channel, BL_ADHOC_HANDLE protocol, BLC_ADHOC_SERVICE *service, BL_ADHOC_HANDLE *service_handle)
Creates a adhoc service in the device with the given settings for an existing protocol. More...
int BL_DLLIMPORT | BLC_AdHoc_Execute (BL_HANDLE channel, BL_ADHOC_HANDLE protocol_handle, BL_ADHOC_HANDLE service_handle, BLC_ADHOC_EXECUTE *execute_flags, const unsigned char *req_payload, int req_payload_length, unsigned char *rsp_payload, int *rsp_payload_length, int timeout)
Runs a given protocol service on the device in a blocking way, the function returns after the protocol is completly done, or the timeout expires. More...
int BL_DLLIMPORT | BLC_AdHoc_ExecuteAsync (BL_HANDLE channel, BL_ADHOC_HANDLE protocol_handle, BL_ADHOC_HANDLE service_handle, BLC_ADHOC_EXECUTE *execute_flags, const unsigned char *req_payload, int req_payload_length, BL_ADHOC_HANDLE *execute_handle)
Runs a given protocol service on the device in a non-blocking way, the function returns directly after the protocol has be started in the device. More...
int BL_DLLIMPORT | BLC_AdHoc_GetState (BL_HANDLE channel, BL_ADHOC_HANDLE execute_handle)
Returns the current state of the given protocol service. More...
int BL_DLLIMPORT | BLC_AdHoc_GetResponse (BL_HANDLE channel, BL_ADHOC_HANDLE execute_handle, unsigned char *rsp_payload, int *rsp_payload_size)
Returns the response payload of the given protocol service. More...
int BL_DLLIMPORT | BLC_AdHoc_DeleteProtocol (BL_HANDLE channel, BL_ADHOC_HANDLE protocol)
Deletes an existing adhoc protocol in the device. This deletes all child services of the protocol too. More...
int BL_DLLIMPORT | BLC_AdHoc_DeleteService (BL_HANDLE channel, BL_ADHOC_HANDLE protocol, BL_ADHOC_HANDLE service)
Deletes an existing adhoc service for the given protocol in the device. More...
int BL_DLLIMPORT | BLC_AdHoc_DeleteAllProtocol (BL_HANDLE channel)
Deletes all existing adhoc protocol for the given channel. This deletes all services too. More...
int BL_DLLIMPORT | BLC_AdHoc_DeleteAllService (BL_HANDLE channel, BL_ADHOC_HANDLE protocol)
Deletes all existing adhoc services for the given channel and protocol. More...
int BL_DLLIMPORT | BLC_getTableCount (BL_HANDLE handle, int64_t *table_count)
Returns the number of tables currently in the device / the loaded SDF. More...
int BL_DLLIMPORT | BLC_getTableRowCount (BL_HANDLE handle, int table_id, int64_t *row_count)
Returns the number of rows currently in the given table. More...
int BL_DLLIMPORT | BLC_getTableColumnCount (BL_HANDLE handle, int table_id, int64_t *column_count)
Returns the number of columns currently in the given table. More...
int BL_DLLIMPORT | BLC_tableRead (BL_HANDLE handle, int table_id, int row, int column, int64_t *read_value, char *buf, int *bufsz)
Returns the value of the specified table cell. More...
int BL_DLLIMPORT | BLC_tableWrite (BL_HANDLE handle, int table_id, int row, int column, int64_t value)
Writes the given integer value into the table cell. More...
int BL_DLLIMPORT | BLC_tableWriteText (BL_HANDLE handle, int table_id, int row, int column, const char *value)
Writes the given string value into the table cell. More...
int BL_DLLIMPORT | BLC_tableFill (BL_HANDLE handle, int table_id, int start_row, int start_column, int end_row, int end_column, int64_t fill_value, const char *fill_text)
Writes the given values into all table cells than span from (start_row, start_column) to (end_row, end_column). More...
int BL_DLLIMPORT | BLC_loggingStart (BL_HANDLE handle, const char *configFile)
BLC_loggingStart enables the standard logging feature for a specific device or channel. More...
int BL_DLLIMPORT | BLC_loggingAddComment (BL_HANDLE handle, const char *comment)
BLC_loggingAddComment Added a string to the logfile. More...
int BL_DLLIMPORT | BLC_loggingStop (BL_HANDLE handle)
BLC_loggingStop stop and close all active logfiles which were started via BLC_loggingStart and linked to the handle. This function did not stop the logging via a SDF file if used. More...
int BL_DLLIMPORT | BLC_loggingStopGlobal ()
BLC_loggingStopGlobal stop and close all active logfiles which were started via BLC_loggingStart. This function did not stop the logging via a SDF file if used. More...

Function Documentation

int BL_DLLIMPORT BLC_AdHoc_CreateProtocol | ( | BL_HANDLE | channel,
 |  | BLC_ADHOC_PROTOCOL * | protocol,
 |  | BL_ADHOC_HANDLE * | protocol_handle
 | ) |  |

Creates a adhoc protocol in the device with the given settings.

Parameters
[in] | channel | A channel handle for the channel on which the protocol shall be created.
[in] | protocol | A protocol definition struct containing the settings for the new protocol.
[out] | protocol_handle | The pointer to a handle value to return the devices created protocol to that is used to identify it. It might be set to NULL in case an error occured.
Returns
Status of operation; '=0' means successful, '!=0' otherwise. See standard return values for error, or for textual representation (for return values < -10000) BLC_getLastError.
int BL_DLLIMPORT BLC_AdHoc_CreateService | ( | BL_HANDLE | channel,
 |  | BL_ADHOC_HANDLE | protocol,
 |  | BLC_ADHOC_SERVICE * | service,
 |  | BL_ADHOC_HANDLE * | service_handle
 | ) |  |

Creates a adhoc service in the device with the given settings for an existing protocol.

Parameters
[in] | channel | A channel handle for the channel on which the service shall be created.
protocol | A protocol handle referencing a existing protocol in the device.
[in] | service | A service struct containing the settings for this new service.
[out] | service_handle | The pointer to a handle value to return the devices created service to that is used to identify it. It might be set to NULL in case an error occured.
Returns
Status of operation; '=0' means successful, '!=0' otherwise. See standard return values for error, or for textual representation (for return values < -10000) BLC_getLastError.
See Also
BLC_AdHoc_CreateProtocol
BLC_ADHOC_EXECUTE BL_DLLIMPORT BLC_AdHoc_DefaultExecute ( )

Creates a adhoc execute struct with the default settings for the execution of adhoc protocols.

Returns
A valid struct filled with default values for this service.
BLC_ADHOC_PROTOCOL BL_DLLIMPORT BLC_AdHoc_DefaultProtocol ( ADHOC_PROTOCOL_TYPE type )

Creates a adhoc protocol struct with the default settings for the given protocol type.

Parameters
type Type of the protocol to create.
Returns
A valid struct filled with default values for this protocol.
BLC_ADHOC_SERVICE BL_DLLIMPORT BLC_AdHoc_DefaultService ( const BLC_ADHOC_PROTOCOL protocol )

Creates a adhoc service struct with the default settings for the service and protocol combination.

Parameters
protocol A protocol description struct.
Returns
A valid struct filled with default values for this service.
int BL_DLLIMPORT BLC_AdHoc_DeleteAllProtocol ( BL_HANDLE channel )

Deletes all existing adhoc protocol for the given channel. This deletes all services too.

Parameters
[in] channel A channel handle for the channel where all protocols shall be deleted.
Returns
0 = Protocols were deleted successfully. else = An error code, see standard return values for error, or for textual representation (for return values < -10000) BLC_getLastError.
See Also
BLC_AdHoc_CreateProtocol
int BL_DLLIMPORT BLC_AdHoc_DeleteAllService | ( | BL_HANDLE | channel,
 |  | BL_ADHOC_HANDLE | protocol
 | ) |  |

Deletes all existing adhoc services for the given channel and protocol.

Parameters
[in] | channel | A channel handle for the channel where the protocol was created.
protocol | A protocol handle referencing the protocol which services shall be deleted.
Returns
0 = Services were deleted successfully. else = An error code, see standard return values for error, or for textual representation (for return values < -10000) BLC_getLastError.
See Also
BLC_AdHoc_CreateProtocol, BLC_AdHoc_CreateService
int BL_DLLIMPORT BLC_AdHoc_DeleteProtocol | ( | BL_HANDLE | channel,
 |  | BL_ADHOC_HANDLE | protocol
 | ) |  |

Deletes an existing adhoc protocol in the device. This deletes all child services of the protocol too.

Parameters
[in] | channel | A channel handle for the channel on which the protocol was created.
protocol | A handle to the protocol to delete.
Returns
0 = Protocol was deleted successfully. else = An error code, see standard return values for error, or for textual representation (for return values < -10000) BLC_getLastError.
See Also
BLC_AdHoc_CreateProtocol
int BL_DLLIMPORT BLC_AdHoc_DeleteService | ( | BL_HANDLE | channel,
 |  | BL_ADHOC_HANDLE | protocol,
 |  | BL_ADHOC_HANDLE | service
 | ) |  |

Deletes an existing adhoc service for the given protocol in the device.

Parameters
[in] | channel | A channel handle for the channel on which the service was created.
protocol | A handle to the protocol of the service.
service | A handle to the service which shall be deleted.
Returns
0 = Service was deleted successfully. else = An error code, see standard return values for error, or for textual representation (for return values < -10000) BLC_getLastError.
See Also
BLC_AdHoc_CreateProtocol, BLC_AdHoc_CreateService
int BL_DLLIMPORT BLC_AdHoc_Execute | ( | BL_HANDLE | channel,
 |  | BL_ADHOC_HANDLE | protocol_handle,
 |  | BL_ADHOC_HANDLE | service_handle,
 |  | BLC_ADHOC_EXECUTE * | execute_flags,
 |  | const unsigned char * | req_payload,
 |  | int | req_payload_length,
 |  | unsigned char * | rsp_payload,
 |  | int * | rsp_payload_length,
 |  | int | timeout
 | ) |  |

Runs a given protocol service on the device in a blocking way, the function returns after the protocol is completly done, or the timeout expires.

Parameters
[in] | channel | A channel handle for the channel on which the protocol service shall be executed.
protocol_handle | A protocol handle referencing a existing protocol in the device (see BLC_AdHoc_CreateProtocol).
service_handle | A service handle referencing a existing service in the device.
[in] | execute_flags | A BLC_ADHOC_EXECUTE struct defining some additional settings for the execute.
[in] | req_payload | The payload for the specified protocol service to use.
[in] | req_payload_length | The size of the payload buffer.
[out] | rsp_payload | A preallocated empty buffer where the protocol service response will be mapped into.
[in,out] | rsp_payload_length | Input the size of the response payload buffer. Output the length of the received payload.
timeout | The timeout when the function should return, even when the protocol service is not done. This value is in milliseconds (ms).
Returns
Status of operation; '=0' means successful, '!=0' otherwise. See standard return values for error, or for textual representation (for return values < -10000) BLC_getLastError.
See Also
BLC_AdHoc_CreateProtocol, BLC_AdHoc_CreateService
int BL_DLLIMPORT BLC_AdHoc_ExecuteAsync | ( | BL_HANDLE | channel,
 |  | BL_ADHOC_HANDLE | protocol_handle,
 |  | BL_ADHOC_HANDLE | service_handle,
 |  | BLC_ADHOC_EXECUTE * | execute_flags,
 |  | const unsigned char * | req_payload,
 |  | int | req_payload_length,
 |  | BL_ADHOC_HANDLE * | execute_handle
 | ) |  |

Runs a given protocol service on the device in a non-blocking way, the function returns directly after the protocol has be started in the device.

Parameters
[in] | channel | A channel handle for the channel on which the protocol service shall be executed.
protocol_handle | A protocol handle referencing a existing protocol in the device.
service_handle | A service handle referencing a existing service in the device.
[in] | execute_flags | A BLC_ADHOC_EXECUTE struct defining some additional settings for the execute.
[in] | req_payload | The payload for the specified protocol service to use.
[in] | req_payload_length | The size of the allocated response payload buffer.
[out] | execute_handle | A pointer to an preallocated instance of the struct. When this function is successful (see return values below) this handle will contain a reference to the running service, else it may be NULL.
Returns
Status of operation; '=0' means successful, '!=0' otherwise. See standard return values for error, or for textual representation (for return values < -10000) BLC_getLastError.
See Also
BLC_AdHoc_CreateProtocol, BLC_AdHoc_CreateService
int BL_DLLIMPORT BLC_AdHoc_GetResponse | ( | BL_HANDLE | channel,
 |  | BL_ADHOC_HANDLE | execute_handle,
 |  | unsigned char * | rsp_payload,
 |  | int * | rsp_payload_size
 | ) |  |

Returns the response payload of the given protocol service.

Parameters
[in] | channel | A channel handle for the channel on which the protocol service was executed.
execute_handle | The handle to the executed protocol service.
[out] | rsp_payload | A preallocated empty buffer where the protocol service response will be mapped into.
[in,out] | rsp_payload_size | Input the size of the preallocated response buffer. Output the length of received payload.
Returns
Returns: 0 = Response was read correctly, the buffer contains valid data. else = An error code, see standard return values for error, or for textual representation (for return values < -10000) BLC_getLastError.
int BL_DLLIMPORT BLC_AdHoc_GetState | ( | BL_HANDLE | channel,
 |  | BL_ADHOC_HANDLE | execute_handle
 | ) |  |

Returns the current state of the given protocol service.

Parameters
[in] | channel | A channel handle for the channel on which the protocol service was executed.
execute_handle | The handle to the executed protocol service.
Returns
Returns: 0 = Protocol service executed successfully. TODO: State ID codes else = An error code, see standard return values for error, or for textual representation (for return values < -10000) BLC_getLastError.
int BL_DLLIMPORT BLC_getAnswerByIndex | ( | BL_HANDLE | handle,
 |  | const unsigned int | index,
 |  | void * | buffer,
 |  | size_t | length
 | ) |  |

If the last answer to a command contained additional data, then this function copies the answer data set over into the destination buffer. Data set selected by index.

Parameters
[in] | handle | Handle representing the channel on which the answer data was received (see BLC_getChannelHandle )
index | Zero-based index of the answer data set
[out] | buffer | Pointer to destination buffer for the data set
length | Length of destination buffer
Returns
Status of operation; '=0' means successful, '!=0' otherwise. See standard return values for error, or for textual representation (for return values < -1000) BLC_getLastError.
int BL_DLLIMPORT BLC_getAnswerByName | ( | BL_HANDLE | handle,
 |  | const char * | name,
 |  | void * | buffer,
 |  | size_t | length
 | ) |  |

If the last answer to a command contained additional data, then this function copies the answer data set over into the destination buffer. Data set selected by name.

Parameters
[in] | handle | Handle representing the channel on which the answer data was received (see BLC_getChannelHandle )
[in] | name | Char*-string with the name of answer data set
[out] | buffer | Pointer to destination buffer for the data set
[in,out] | length | Input length of preallocated buffer. Output length of written data.
Returns
Status of operation; '=0' means successful, '!=0' otherwise. See standard return values for error, or for textual representation (for return values < -1000) BLC_getLastError.
int BL_DLLIMPORT BLC_getAnswerNameByIndex | ( | BL_HANDLE | handle,
 |  | int | index,
 |  | char * | nameBuffer,
 |  | int * | nameBufferLength
 | ) |  |
Parameters
[in] | handle | Handle representing the channel on which the answer data was received (see BLC_getChannelHandle )
index | Zero-based index of the answer data set.
[out] | nameBuffer | The buffer to store the name in.
[in,out] | nameBufferLength | Input a pointer to the length of the nameBuffer. Output the length of the name.
Returns
Status of operation; '=0' means successful, '!=0' otherwise. See standard return values for error, or for textual representation (for return values < -1000) BLC_getLastError.
int BL_DLLIMPORT BLC_getAnswerTypeByIndex | ( | BL_HANDLE | handle,
 |  | const unsigned int | index,
 |  | BL_ANSWER_TYPE * | type,
 |  | size_t * | length
 | ) |  |

If the last answer to a command contained additional data, then this function reports the type and size for a specific answer data set. Data set selected by index. The following types of data sets are possible: BL_ANSWER_TYPE_INT - 32bit integer BL_ANSWER_TYPE_STR - zero-terminated string (variable length) BL_ANSWER_TYPE_BIN - binary data (variable length)

Parameters
[in] | handle | Handle representing the channel on which the answer data was received (see BLC_getChannelHandle )
index | Zero-based index of the answer data set
[out] | type | Type of data set is returned within
[in,out] | length | Input the length of the allocated parameter type. Output the length of the returned data in parameter type.
Returns
Status of operation; '=0' means successful, '!=0' otherwise. See standard return values for error, or for textual representation (for return values < -1000) BLC_getLastError.
int BL_DLLIMPORT BLC_getAnswerTypeByName | ( | BL_HANDLE | handle,
 |  | const char * | name,
 |  | BL_ANSWER_TYPE * | type,
 |  | size_t * | length
 | ) |  |

If the last answer to a command contained additional data, then this function reports the type and size for a specific answer data set. Data set selected by name. The following types of data sets are possible: BL_ANSWER_TYPE_INT - 32bit integer BL_ANSWER_TYPE_STR - zero-terminated string (variable length) BL_ANSWER_TYPE_BIN - binary data (variable length)

Parameters
[in] | handle | Handle representing the channel on which the answer data was received (see BLC_getChannelHandle )
[in] | name | Char*-string with the name of answer data set
[out] | type | Type of data set is returned within
[in,out] | length | Input the length of the allocated parameter type. Output the length of the returned data in parameter type.
Returns
Status of operation; '=0' means successful, '!=0' otherwise. See standard return values for error, or for textual representation (for return values < -1000) BLC_getLastError.
int BL_DLLIMPORT BLC_getDTLRequestStatus ( BL_HANDLE handle )
Parameters
[in] handle Handle representing a LIN-channel (see BLC_getChannelHandle )
Returns
Status of last request operation if >= 0; see BL_DTL_STATUS for values. For < 0, see standard return values for error, or for textual representation (for return values < -1000) BLC_getLastError.
int BL_DLLIMPORT BLC_getDTLResponseStatus ( BL_HANDLE handle )
Parameters
[in] handle Handle representing a LIN-channel (see BLC_getChannelHandle )
Returns
Status of last request operation if >= 0; see BL_DTL_STATUS for values. For < 0, see standard return values for error, or for textual representation (for return values < -1000) BLC_getLastError.
int BL_DLLIMPORT BLC_getMacroResultString | ( | BL_HANDLE | handle,
 |  | int | macro_nr,
 |  | char * | dstbuf,
 |  | int | buflen
 | ) |  |

Requests the result string of a macro. If no result string was set, the function retuns BL_NO_DATA.

Parameters
[in] | handle | Handle representing a channel (see BLC_getChannelHandle )
macro_nr | The index of the macro from the section.
[out] | dstbuf | Pointer to char array which gets filled (must hold min. 'buflen' bytes).
buflen | How many bytes should get returned.
Returns
Status of operation; '=0' means successful, '!=0' otherwise. See standard return values for error, or for textual representation (for return values < -10000) BLC_getLastError.
int BL_DLLIMPORT BLC_getRawSlaveResponse | ( | BL_HANDLE | handle,
 |  | unsigned char * | data,
 |  | int | length
 | ) |  |

The internal raw-SlaveResponse-buffer is filled continuously with the data bytes of reported SlaveResp-frames and is being reset upon every call of BL_sendRawMasterRequest().

Parameters
[in] | handle | Handle representing a LIN-channel (see BLC_getChannelHandle )
[out] | data | Pointer to char array which gets filled (must hold min. 'length' bytes).
length | How many bytes should get returned.
Returns
Status of operation; '=0' means successful, '!=0' otherwise. See standard return values for error, or for textual representation (for return values < -1000) BLC_getLastError.
int BL_DLLIMPORT BLC_getTableColumnCount | ( | BL_HANDLE | handle,
 |  | int | table_id,
 |  | int64_t * | column_count
 | ) |  |

Returns the number of columns currently in the given table.

Parameters
[in] | handle | Channel handle to the channel where the command shall be executed.
table_id | The id for the table.
[out] | column_count | Preallocated pointer which will be filled with a valid value when the return value is BL_OK. Contains the number of columns in the table.
Returns
0 = Function has run successfully. else = An error code, see standard return values for error, or for textual representation (for return values < -10000) BLC_getLastError.
int BL_DLLIMPORT BLC_getTableCount | ( | BL_HANDLE | handle,
 |  | int64_t * | table_count
 | ) |  |

Returns the number of tables currently in the device / the loaded SDF.

Parameters
[in] | handle | Channel handle to the channel where the command shall be executed.
[out] | table_count | Preallocated pointer which will be filled with a valid value when the return value is BL_OK. Contains the number of tables.
Returns
0 = Function has run successfully. else = An error code, see standard return values for error, or for textual representation (for return values < -10000) BLC_getLastError.
int BL_DLLIMPORT BLC_getTableRowCount | ( | BL_HANDLE | handle,
 |  | int | table_id,
 |  | int64_t * | row_count
 | ) |  |

Returns the number of rows currently in the given table.

Parameters
[in] | handle | Channel handle to the channel where the command shall be executed.
table_id | The id for the table.
[out] | row_count | Preallocated pointer which will be filled with a valid value when the return value is BL_OK. Contains the number of rows in the table.
Returns
0 = Function has run successfully. else = An error code, see standard return values for error, or for textual representation (for return values < -10000) BLC_getLastError.
int BL_DLLIMPORT BLC_lastAnswerHasData ( BL_HANDLE handle )

If there is no additional data present it returns BL_NO_ANSWER_DATA.

Parameters
[in] handle Handle representing the Channel (see BLC_getChannelHandle ).
Returns
Status of operation; '=0' means successful, '!=0' otherwise. See standard return values for error, or for textual representation (for return values < -1000) BLC_getLastError.
int BL_DLLIMPORT BLC_loggingAddComment | ( | BL_HANDLE | handle,
 |  | const char * | comment
 | ) |  |
Parameters
[in] | handle | Handle representing the channel or device handle whose data should be logged. If one want to log a single channel (e.g. the first LIN) use the channel handle and get one logfile. If one want to log all device channels use the connection handle and get one logfile for each channel and one for the device channel.
[in] | comment | The comment string which would be added to the logfile which is linked to the handle.
Returns
BL_OK on success, errorcode otherwise
See Also
BLC_getChannelHandle and BLC_open
int BL_DLLIMPORT BLC_loggingStart | ( | BL_HANDLE | handle,
 |  | const char * | configFile
 | ) |  |
Parameters
[in] | handle | Handle representing the channel or device handle whose data should be logged. If one want to log a single channel (e.g. the first LIN) use the channel handle and get one logfile. If one want to log all device channels use the connection handle and get one logfile for each channel and one for the device channel.
[in] | configFile | The config file to load (can be created with the SimpleMenu). Setting "configFile" to a nullptr will load these default settings: ASCII mode, logging of frames, debug and error messages limit file size to 100MB and max. 2 files per channel. Output path is "User/Documents/Lipowsky Industrie-Elektronik GmbH/logs"
Returns
BL_OK on success, errorcode otherwise
See Also
BLC_getChannelHandle and BLC_open
int BL_DLLIMPORT BLC_loggingStop ( BL_HANDLE handle )
Parameters
[in] handle The handle of the device or channel to stop. If this is a device handle all corresponding channels will be stopped, if this is a channel handle, only the logging of this channel will be stopped.
Returns
BL_OK on success, errorcode otherwise
int BL_DLLIMPORT BLC_loggingStopGlobal ( )
Returns
BL_OK on success, errorcode otherwise
int BL_DLLIMPORT BLC_macro_result | ( | BL_HANDLE | handle,
 |  | int | macro_nr,
 |  | int64_t * | return_value,
 |  | unsigned int | timeout_ms
 | ) |  |

Executes "macro_result" in a loop until "macro_result" returns anything else than 150 (macro still running), or timeout_ms is exceeded A possible return value of "macro_result" is stored into return_value if the returncode was 155 (finished with error), 156 (finished with exception) or 0 (macro finished)

Parameters
[in] | handle | Handle representing the channel to send the command to (see BLC_getChannelHandle )
macro_nr | The index of the macro from the section.
[out] | return_value | The memory where to store the received macro result.
timeout_ms | The timeout in milliseconds for the macro to complete.
Returns
BLC_macro_result returns the last return value of the "macro_result" command. Return values 0, 155, 156 signal success, for other values see standard error values BabyLINReturncodes.h.
int BL_DLLIMPORT BLC_mon_set | ( | BL_HANDLE | handle,
 |  | int | frameid,
 |  | const int * | databytes,
 |  | int | len
 | ) |  |
Parameters
[in] | handle | Handle representing the channel to send the command to (see BLC_getChannelHandle )
frameid | The BUS-frame-id to set the framedata for
[out] | databytes | Array of databytes to use as the framedata
len | The length of the data
Returns
Status of operation; '=0' means successful, '!=0' otherwise. See standard return values for error, or for textual representation (for return values < -10000) BLC_getLastError.
int BL_DLLIMPORT BLC_mon_set_xmit | ( | BL_HANDLE | handle,
 |  | int | frameId,
 |  | const int * | databytes,
 |  | int | len,
 |  | int | slottime
 | ) |  |
Parameters
[in] | handle | Handle representing the channel to send the command to (see BLC_getChannelHandle )
frameId | The BUS-frame-id to set and transmit
[out] | databytes | Array of databytes to use as the framedata
len | The length of the data
slottime | Slottime = 0 equals a single transmit, slottime > 0 equals cyclic transmission of frame
Returns
Status of operation; '=0' means successful, '!=0' otherwise. See standard return values for error, or for textual representation (for return values < -10000) BLC_getLastError.
int BL_DLLIMPORT BLC_mon_xmit | ( | BL_HANDLE | handle,
 |  | int | frameId,
 |  | int | slottime
 | ) |  |
Parameters
[in] | handle | Handle representing the channel to send the command to (see BLC_getChannelHandle )
frameId | the BUS-frame-id to transmit
slottime | slottime = 0 equals a single transmit, slottime > 0 equals cyclic transmission of frame
Returns
Status of operation; '=0' means successful, '!=0' otherwise. See standard return values for error, or for textual representation (for return values < -10000) BLC_getLastError.
int BL_DLLIMPORT BLC_sendASCIICommand | ( | BL_HANDLE | handle,
 |  | const char * | command,
 |  | char * | buffer,
 |  | int | bufferLength,
 |  | int | timeout_ms
 | ) |  |

A command can be sent using the ASCII protocol. The function can be blocked, until a response was received.

Parameters
[in] | handle | A handle representing an ASCII connection
[in] | command | The command to send.
[out] | buffer | A buffer to receive the answer.
bufferLength | A buffer with enough space.
timeout_ms | The length of the passed buffer
Returns
Status of operation; '=0' means successful, '!=0' otherwise. See standard return values for error, or for textual representation (for return values < -10000) BLC_getLastError.
int BL_DLLIMPORT BLC_sendCommand | ( | BL_HANDLE | handle,
 |  | const char * | command
 | ) |  |

The command must match the command syntax as specified in the BabyLIN documentation (see BabyLIN commands to use in BL_- and BLC_sendCommand Functions ). The trailing ';' may be omitted;

Parameters
[in] | handle | Handle representing the channel to send the command to (see BLC_getChannelHandle )
[in] | command | C-string with Commands (e.g. "status;")
Returns
Status of operation; '=0' means successful, '!=0' otherwise. See standard return values for error, or for textual representation (for return values < -10000) BLC_getLastError.
int BL_DLLIMPORT BLC_sendDTLRequest | ( | BL_HANDLE | handle,
 |  | unsigned char | nad,
 |  | int | length,
 |  | unsigned char * | data
 | ) |  |
Parameters
[in] | handle | Handle representing a LIN-channel (see BLC_getChannelHandle )
nad | NAD of the node the request gets send to.
length | Length of the following data array.
[out] | data | DTL frame data (begins with SID, followed by up to 4095 data bytes).
Returns
Status of operation; '=0' means successful, '!=0' otherwise. See standard return values for error, or for textual representation (for return values < -1000) BLC_getLastError.
int BL_DLLIMPORT BLC_sendDTLResponse | ( | BL_HANDLE | handle,
 |  | unsigned char | nad,
 |  | int | length,
 |  | unsigned char * | data
 | ) |  |
Parameters
[in] | handle | Handle representing a LIN-channel (see BLC_getChannelHandle )
nad | NAD of the node the response gets send for.
length | Length of the following data array.
[out] | data | DTL frame data (begins with RSID, followed by up to 4095 data bytes).
Returns
Status of operation; '=0' means successful, '!=0' otherwise. See standard return values for error, or for textual representation (for return values < -1000) BL_getLastError().
int BL_DLLIMPORT BLC_sendRaw | ( | BL_HANDLE | handle,
 |  | const unsigned char * | command,
 |  | unsigned int * | length
 | ) |  |
Attention
The command must be encoded in the binary DP-Message format of BabyLIN.
Parameters
[in] | handle | Handle representing the connection. (see BLC_open )
[in] | command | Char*-Buffer with the designated Commands
[in,out] | length | Input length of buffer. Output set to actual sent command's length.
Returns
Status of operation; '=0' means successful, '!=0' otherwise. See standard return values for error, or for textual representation (for return values < -1000) BL_getLastError().
int BL_DLLIMPORT BLC_sendRawMasterRequest | ( | BL_HANDLE | handle,
 |  | unsigned char * | data,
 |  | int | count
 | ) |  |

The internal raw-SlaveResponse-buffer is being reset and the Baby-LIN device gets instructed to report the next 'count' slave response frames which in turn are accumulated into the slave response-buffer which can be queried by BL_getRawSlaveResponse().

Parameters
[in] | handle | Handle representing a LIN-channel (see BLC_getChannelHandle )
[in] | data | Master request frame data (exactly 8 bytes).
count | Number of expected slave response frames.
Returns
Status of operation; '=0' means successful, '!=0' otherwise. See standard return values for error, or for textual representation (for return values < -1000) BLC_getLastError.
int BL_DLLIMPORT BLC_sendRawSlaveResponse | ( | BL_HANDLE | handle,
 |  | unsigned char * | reqdata,
 |  | unsigned char * | reqmask,
 |  | unsigned char * | data,
 |  | int | length
 | ) |  |

Upon the reveive of the next master request frame, every bit of the request is compared to 'reqdata' if the corresponding bit of 'reqmask' is set (1). If all match, Baby-LIN starts to send out the data given in 'data', 8 bytes with each slave response frame.

Parameters
[in] | handle | Handle representing a LIN-channel (see BLC_getChannelHandle )
[in] | reqdata | Data of the expected master request (exactly 8 bytes).
[in] | reqmask | Mask for 'reqdata' to indicate which bits must match (exactly 8 bytes).
[out] | data | Slave response frame data (multiple of 8 bytes).
length | Length of data to send.
Returns
Status of operation; '=0' means successful, '!=0' otherwise. See standard return values for error, or for textual representation (for return values < -1000) BLC_getLastError.
int BL_DLLIMPORT BLC_setDTLMode | ( | BL_HANDLE | handle,
 |  | int | mode
 | ) |  |

There are different Diagnostic modes, which offer different levels of protocol functionality. The Baby-LIN will start with Diagnostic OFF on Power Up. If the BabyLIN acts as LIN master then the selection of an Diagnostic Mode happens trough the usage of the appropriate API function calls. So the API functions BL_sendRawMasterRequest or BL_sendRawSlaveResponse will start the Diagnostic RAW mode, where as the API calls BL_sendDTLRequest or BL_sendDTLResponse will start the Diagnostic DTL mode. If the BabyLIN acts as LIN slave then the DTL mode must be set by use of this function. It is not possible to use different Diagnostics modes at the same time !

List of DTL modes:

Mode | Name | Description
0 | DTL_NONE | no DTL Support
1 | DTL_RAW | RAW Mode DTL Support
2 | DTL_COOKED | Cooked Mode DTL Support
Parameters
[in] | handle | Handle representing a LIN-channel (see BLC_getChannelHandle )
mode | DTL mode
Returns
Status of operation; '=0' means successful, '!=0' otherwise. See standard return values for error, or for textual representation (for return values < -1000) BLC_getLastError.
int BL_DLLIMPORT BLC_setsig | ( | BL_HANDLE | handle,
 |  | int | signalNr,
 |  | unsigned long long | value
 | ) |  |
Parameters
[in] | handle | Handle representing the channel to send the command to (see BLC_getChannelHandle )
signalNr | The signal to set the value
value | The value to assign to the signal
Returns
Status of operation; '=0' means successful, '!=0' otherwise. See standard return values for error, or for textual representation (for return values < -10000) BLC_getLastError.
int BL_DLLIMPORT BLC_tableFill | ( | BL_HANDLE | handle,
 |  | int | table_id,
 |  | int | start_row,
 |  | int | start_column,
 |  | int | end_row,
 |  | int | end_column,
 |  | int64_t | fill_value,
 |  | const char * | fill_text
 | ) |  |

Writes the given values into all table cells than span from (start_row, start_column) to (end_row, end_column).

Parameters
[in] | handle | Channel handle to the channel where the command shall be executed.
table_id | The id for the table.
start_row | The start row of the table to write.
start_column | The start column of the table to write.
end_row | The end row of the table to write.
end_column | The end column of the table to write.
fill_value | This value is used for integer cells.
[out] | fill_text | This zero-terminated value is used for string cells.
Returns
0 = Function has run successfully. else = An error code, see standard return values for error, or for textual representation (for return values < -10000) BLC_getLastError.
int BL_DLLIMPORT BLC_tableRead | ( | BL_HANDLE | handle,
 |  | int | table_id,
 |  | int | row,
 |  | int | column,
 |  | int64_t * | read_value,
 |  | char * | buf,
 |  | int * | bufsz
 | ) |  |

Returns the value of the specified table cell.

Parameters
[in] | handle | Channel handle to the channel where the command shall be executed.
table_id | The id for the table.
row | The row of the table to read.
column | The column of the table to read.
[out] | read_value | Preallocated pointer which will be filled with a valid value when the return value is BL_OK. If the cell is a integer cell, this will be the cells value.
[out] | buf | Preallocated buffer which will be filled when the return value is BL_OK. If the cell is a string cell, this will be the cells value.
[in,out] | bufsz | Preallocated pointer to a value of size of buf, which will be filled with a valid value when the return value is BL_OK. If the cell is a string cell, this returns the length of cells data. For an integer cell this value is set to 0.
Returns
0 = Function has run successfully. else = An error code, see standard return values for error, or for textual representation (for return values < -10000) BLC_getLastError.
int BL_DLLIMPORT BLC_tableWrite | ( | BL_HANDLE | handle,
 |  | int | table_id,
 |  | int | row,
 |  | int | column,
 |  | int64_t | value
 | ) |  |

Writes the given integer value into the table cell.

Parameters
[in] | handle | Channel handle to the channel where the command shall be executed.
table_id | The id for the table.
row | The row of the table to write.
column | The column of the table to write.
value | The integer value to write into the cell.
Returns
0 = Function has run successfully. else = An error code, see standard return values for error, or for textual representation (for return values < -10000) BLC_getLastError.
int BL_DLLIMPORT BLC_tableWriteText | ( | BL_HANDLE | handle,
 |  | int | table_id,
 |  | int | row,
 |  | int | column,
 |  | const char * | value
 | ) |  |

Writes the given string value into the table cell.

Parameters
[in] | handle | Channel handle to the channel where the command shall be executed.
table_id | The id for the table.
row | The row of the table to write.
column | The column of the table to write.
[out] | value | The zero-terminated string value to write into the cell.
Returns
0 = Function has run successfully. else = An error code, see standard return values for error, or for textual representation (for return values < -10000) BLC_getLastError.
int BL_DLLIMPORT BLC_updRawSlaveResponse ( BL_HANDLE handle )
Parameters
[in] handle Handle representing a LIN-channel (see BLC_getChannelHandle )
Returns
Status of operation; '=0' means successful, '!=0' otherwise. See standard return values for error, or for textual representation (for return values < -1000) BLC_getLastError.
int BL_DLLIMPORT BLC_varRead | ( | BL_HANDLE | handle,
 |  | int | signal_nr,
 |  | char * | dstbuf,
 |  | int | length
 | ) |  |

Reads a number of signal values and puts them directly into a bytearray. Performs the same operation as a BLC_sendCommand with "varrd" but only allows 8bit signals to be read. This call blocks until all data is read and returned.

Parameters
[in] | handle | Handle representing a channel (see BLC_getChannelHandle )
signal_nr | The index of the first signal to read.
[out] | dstbuf | Pointer to char array which gets filled (must hold min. 'buflen' bytes).
length | How many signals should be read.
Returns
Status of operation; '=0' means successful, '!=0' otherwise. See standard return values for error, or for textual representation (for return values < -10000) BLC_getLastError.
int BL_DLLIMPORT BLC_varWrite | ( | BL_HANDLE | handle,
 |  | int | signal_nr,
 |  | char * | data,
 |  | int | data_len
 | ) |  |

Writes "data_len" number of signals, starting from "signal_nr" with byte values from the "data" array. Performs the same operation as a BLC_sendCommand with "varwr" in mode 1, but only allows 8bit values to be set.

Parameters
[in] | handle | Handle representing a channel (see BLC_getChannelHandle )
signal_nr | The index of the first signal to write.
[in] | data | Byte array with data to write. Each byte will be written in one signal.
data_len | How long the data buffer is. Also defines how many signals are written.
Returns
Status of operation; '=0' means successful, '!=0' otherwise. See standard return values for error, or for textual representation (for return values < -10000) BLC_getLastError.
Generated on Fri May 30 2025 17:16:14 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: Data Structures

Data Structures | Enumerations
Data Structures

Detailed Description

The following structures are used to retrieve data from a running BabyLIN device like frame- and signal-reports or error and debug information

Data Structures

struct | BLC_PORTINFO
Information about a BabyLIN port on the host operating system. More...
struct | BLC_TARGETID
Information about a connected BabyLIN device. More...
struct | BLC_CHANNELINFO
Information about a channel on a BabyLIN device. More...
struct | BLC_SDFINFO
struct | BLC_SECTIONINFO
struct | BLC_FRAME
struct | BLC_JUMBO_FRAME
struct | BLC_MACROSTATE
status of a macro More...
struct | BLC_SIGNAL
struct | BLC_ERROR
struct | BLC_DTL
struct | BLC_EVENT
union | ADHOC_PROTOCOL_FLAGS
struct | BLC_ADHOC_PROTOCOL
union | ADHOC_SERVICE_FLAGS
struct | BLC_ADHOC_SERVICE
struct | BLC_ADHOC_EXECUTE
struct | BLC_LOG

Enumerations

enum ADHOC_PROTOCOL_TYPE {
TYPE_RAW = 0, TYPE_DTL_ISOTP = 1, TYPE_ISOTP_WITHOUT_NAD = 2, TYPE_WEBASTO_UHW2 = 3,
TYPE_WEBASTO_STD = 5, TYPE_KLINE_RAW = 6
}
Type of an ad hoc protocol. More...

Enumeration Type Documentation

enum ADHOC_PROTOCOL_TYPE
Enumerator
TYPE_RAW
TYPE_DTL_ISOTP
TYPE_ISOTP_WITHOUT_NAD
TYPE_WEBASTO_UHW2
TYPE_WEBASTO_STD
TYPE_KLINE_RAW

Definition at line 497 of file BabyLINCAN_types.h.

Generated on Fri May 30 2025 17:16:14 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: BLC_PORTINFO Struct Reference

  • Data Structure Index
Data Fields
BLC_PORTINFO Struct Reference
Data Structures

Information about a BabyLIN port on the host operating system. More...

#include <BabyLINCAN_types.h>

Data Fields

int | portNr
The COM-port number the device is connected to (windows only), use this value for BLC_open. For Network devices this is the TCP port to connect to. More...
int | type
The type of interface of the connected device (0=USBSerial, 1=Not Connectable(Network UDP), 2=Network TCP). More...
char | name [256]
The name of the connected device (f.ex. BabyLIN RM-II). For Network devices this is the hostname of the device. More...
char | device [256]
The linux device file the BabyLIN is connected to (linux only) For Network devices this is the ip in dot notation. More...

Detailed Description

The structure holds information about a BabyLIN device connected to the PC Use BLC_getBabyLinPorts to retrieve a list of connected BabyLIN-Devices

Definition at line 20 of file BabyLINCAN_types.h.

The documentation for this struct was generated from the following file:
  • C:/JenkinsWS/workspace/orks_v2_LinWorksv2_Windows_trunk/source/externals/BabyLIN/src/libraries/BabyLIN/publicHeaders/BabyLINCAN_types.h
Generated on Fri May 30 2025 17:16:14 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: Callback Handling

Typedefs | Enumerator | Variables
Callback Handling

Detailed Description

The following functions are used to register callback functions for a BabyLIN connection. A callback will be called whenever a corresponding message is received on the connection it is registered to ( push method ). If you want to use a pull method to retrieve the data, have a look at the Pull Functions section of the documentation

The device, that generated the callback must not be closed from within the callback.

Typedefs

typedef void( | BLC_frame_callback_func )(BL_HANDLE, BLC_FRAME frame)
typedef void( | BLC_jumboframe_callback_func )(BL_HANDLE, BLC_JUMBO_FRAME jumbo_frame)
typedef void( | BLC_signal_callback_func )(BL_HANDLE, BLC_SIGNAL signal)
typedef void( | BLC_macrostate_callback_func )(BL_HANDLE, BLC_MACROSTATE macroState)
typedef void( | BLC_error_callback_func )(BL_HANDLE, BLC_ERROR error)
typedef void( | BLC_debug_callback_func )(BL_HANDLE, const char *text)
typedef void( | BLC_dtl_request_callback_func )(BL_HANDLE, BLC_DTL dtl_request)
typedef void( | BLC_dtl_response_callback_func )(BL_HANDLE, BLC_DTL dtl_response)
typedef void( | BLC_event_callback_func )(BL_HANDLE, BLC_EVENT event)
typedef void( | BLC_frame_callback_func_ptr )(BL_HANDLE, BLC_FRAME frame, void *)
typedef void( | BLC_jumboframe_callback_func_ptr )(BL_HANDLE, BLC_JUMBO_FRAME jumbo_frame, void *)
typedef void( | BLC_signal_callback_func_ptr )(BL_HANDLE, BLC_SIGNAL signal, void *)
typedef void( | BLC_macrostate_callback_func_ptr )(BL_HANDLE, BLC_MACROSTATE macroState, void *)
typedef void( | BLC_error_callback_func_ptr )(BL_HANDLE, BLC_ERROR error, void *)
typedef void( | BLC_debug_callback_func_ptr )(BL_HANDLE, const char *text, void *)
typedef void( | BLC_dtl_request_callback_func_ptr )(BL_HANDLE, BLC_DTL dtl_request, void *)
typedef void( | BLC_dtl_response_callback_func_ptr )(BL_HANDLE, BLC_DTL dtl_response, void *)
typedef void( | BLC_event_callback_func_ptr )(BL_HANDLE, BLC_EVENT event, void *)
typedef void( | BLC_log_callback_func_ptr )(BL_HANDLE, BLC_LOG log, void *)
typedef void( | BLC_lua_print_func_ptr )(const char *msg, void *userdata)

Variables

int | BLC_PORTINFO::portNr
The COM-port number the device is connected to (windows only), use this value for BLC_open. For Network devices this is the TCP port to connect to. More...
int | BLC_PORTINFO::type
The type of interface of the connected device (0=USBSerial, 1=Not Connectable(Network UDP), 2=Network TCP). More...
char | BLC_PORTINFO::name [256]
The name of the connected device (f.ex. BabyLIN RM-II). For Network devices this is the hostname of the device. More...
char | BLC_PORTINFO::device [256]
The linux device file the BabyLIN is connected to (linux only) For Network devices this is the ip in dot notation. More...
unsigned short | BLC_TARGETID::type
Type of the hardware. More...
unsigned short | BLC_TARGETID::version
unsigned short | BLC_TARGETID::build
unsigned short | BLC_TARGETID::flags
Software related flags. More...
long | BLC_TARGETID::serial
long | BLC_TARGETID::heapsize
long | BLC_TARGETID::numofchannels
char | BLC_TARGETID::name [128]
unsigned short | BLC_CHANNELINFO::id
Channel-id(i.e. 0 = device channel) More...
unsigned short | BLC_CHANNELINFO::type
Channel-Type(i.e. 0 = LIN, 1 = CAN, 99 = DEVICE) More...
char | BLC_CHANNELINFO::name [128]
Textual name of the Channel (zero-terminated C-string) More...
long | BLC_CHANNELINFO::maxbaudrate
Maximum Baudrate of Channel. More...
long | BLC_CHANNELINFO::reserved1
Flags describing the State of the Channel. More...
long | BLC_CHANNELINFO::reserved2
Reserved value (ignore for now) More...
long | BLC_CHANNELINFO::reserved3
Reserved value (ignore for now) More...
int | BLC_CHANNELINFO::associatedWithSectionNr
char | BLC_SDFINFO::filename [256]
short | BLC_SDFINFO::sectionCount
short | BLC_SDFINFO::version_major
short | BLC_SDFINFO::version_minor
char | BLC_SECTIONINFO::name [128]
int | BLC_SECTIONINFO::type
short | BLC_SECTIONINFO::nr
unsigned long | BLC_FRAME::chId
unsigned long | BLC_FRAME::timestamp
long | BLC_FRAME::intime
unsigned long | BLC_FRAME::frameId
unsigned char | BLC_FRAME::lenOfData
unsigned char | BLC_FRAME::frameData [8]
short | BLC_FRAME::frameFlags
Additional, informational frame flags. More...
short | BLC_FRAME::busFlags
Bus specific flags. More...
unsigned char | BLC_FRAME::checksum
Checksum of the frame stores a checksum V1 or V2 ( refer to busFlags which checksum type applies ) More...
unsigned long | BLC_JUMBO_FRAME::chId
unsigned long | BLC_JUMBO_FRAME::timestamp
long | BLC_JUMBO_FRAME::intime
unsigned long | BLC_JUMBO_FRAME::frameId
unsigned int | BLC_JUMBO_FRAME::lenOfData
unsigned char | BLC_JUMBO_FRAME::frameData [1024]
short | BLC_JUMBO_FRAME::frameFlags
Additional, informational frame flags. More...
short | BLC_JUMBO_FRAME::busFlags
Bus specific flags. More...
unsigned char | BLC_JUMBO_FRAME::checksum
checksum of the frame stores a checksum V1 or V2 ( refer to busFlags which checksum type applies ) More...
int | BLC_MACROSTATE::channelid
int | BLC_MACROSTATE::macronr
Macro-number the information is about. More...
int | BLC_MACROSTATE::cmdnr
The macro command number currently executed. More...
int | BLC_MACROSTATE::state
state of the macro execution More...
unsigned long | BLC_MACROSTATE::timestamp
Timestamp of the macro state. More...
int | BLC_SIGNAL::index
int | BLC_SIGNAL::isArray
unsigned long long | BLC_SIGNAL::value
int | BLC_SIGNAL::arrayLength
unsigned char | BLC_SIGNAL::array [8]
unsigned long | BLC_SIGNAL::timestamp
unsigned short | BLC_SIGNAL::chId
unsigned long | BLC_ERROR::timestamp
Time of occurence. The timestamp when the error occurred. More...
unsigned short | BLC_ERROR::type
Error type. More...
unsigned short | BLC_ERROR::status
Additional error information. More...
BL_DTL_STATUS BLC_DTL::status
unsigned char | BLC_DTL::nad
int | BLC_DTL::length
unsigned char | BLC_DTL::data [4 *1024]
unsigned int | BLC_EVENT::timestamp
Time of occurence. The timestamp (of the device (us)) when the error occurred. More...
unsigned int | BLC_EVENT::pc_timestamp
Time of occurence. The timestamp (of the PC (ms)) when the error occurred. More...
int | BLC_EVENT::event
The event that occured. More...
long long | BLC_EVENT::data
Additional information of an event. More...
int ADHOC_PROTOCOL_FLAGS::protocoltype: 6
unsigned int ADHOC_PROTOCOL_FLAGS::unused_1: 5
unsigned int ADHOC_PROTOCOL_FLAGS::tx_shortensf: 1
unsigned int ADHOC_PROTOCOL_FLAGS::tx_shortenlcf: 1
unsigned int ADHOC_PROTOCOL_FLAGS::unused_2: 3
unsigned int ADHOC_PROTOCOL_FLAGS::use_std_posresp: 1
unsigned int ADHOC_PROTOCOL_FLAGS::use_std_negresp: 1
unsigned int ADHOC_PROTOCOL_FLAGS::slaveprotocol: 1
unsigned int ADHOC_PROTOCOL_FLAGS::expect_shortenedsf: 2
unsigned int ADHOC_PROTOCOL_FLAGS::expect_shortenedlcf: 2
unsigned int ADHOC_PROTOCOL_FLAGS::unused_3: 5
unsigned int ADHOC_PROTOCOL_FLAGS::accept_any_csize: 1
unsigned int ADHOC_PROTOCOL_FLAGS::xmit_shortenflowctrl: 1
struct {
int ADHOC_PROTOCOL_FLAGS::protocoltype: 6
unsigned int ADHOC_PROTOCOL_FLAGS::unused_1: 5
unsigned int ADHOC_PROTOCOL_FLAGS::tx_shortensf: 1
unsigned int ADHOC_PROTOCOL_FLAGS::tx_shortenlcf: 1
unsigned int ADHOC_PROTOCOL_FLAGS::unused_2: 3
unsigned int ADHOC_PROTOCOL_FLAGS::use_std_posresp: 1
unsigned int ADHOC_PROTOCOL_FLAGS::use_std_negresp: 1
unsigned int ADHOC_PROTOCOL_FLAGS::slaveprotocol: 1
unsigned int ADHOC_PROTOCOL_FLAGS::expect_shortenedsf: 2
unsigned int ADHOC_PROTOCOL_FLAGS::expect_shortenedlcf: 2
unsigned int ADHOC_PROTOCOL_FLAGS::unused_3: 5
unsigned int ADHOC_PROTOCOL_FLAGS::accept_any_csize: 1
unsigned int ADHOC_PROTOCOL_FLAGS::xmit_shortenflowctrl: 1
} ADHOC_PROTOCOL_FLAGS::generic
unsigned int ADHOC_PROTOCOL_FLAGS::protocoltype: 6
unsigned int ADHOC_PROTOCOL_FLAGS::unused_1: 2
unsigned int ADHOC_PROTOCOL_FLAGS::xmit_chksumtype: 1
unsigned int ADHOC_PROTOCOL_FLAGS::expect_chksumtype: 2
unsigned int ADHOC_PROTOCOL_FLAGS::xmit_shortensf: 1
unsigned int ADHOC_PROTOCOL_FLAGS::xmit_shortenlcf: 1
unsigned int ADHOC_PROTOCOL_FLAGS::unused_2: 3
unsigned int ADHOC_PROTOCOL_FLAGS::use_std_posresp: 1
unsigned int ADHOC_PROTOCOL_FLAGS::use_std_negresp: 1
unsigned int ADHOC_PROTOCOL_FLAGS::slaveprotocol: 1
unsigned int ADHOC_PROTOCOL_FLAGS::expect_shortenedsf: 2
unsigned int ADHOC_PROTOCOL_FLAGS::expect_shortenedlcf: 2
unsigned int ADHOC_PROTOCOL_FLAGS::unused_3: 5
unsigned int ADHOC_PROTOCOL_FLAGS::accept_any_csize: 1
unsigned int ADHOC_PROTOCOL_FLAGS::xmit_shortenflowctrl: 1
struct {
unsigned int ADHOC_PROTOCOL_FLAGS::protocoltype: 6
unsigned int ADHOC_PROTOCOL_FLAGS::unused_1: 2
unsigned int ADHOC_PROTOCOL_FLAGS::xmit_chksumtype: 1
unsigned int ADHOC_PROTOCOL_FLAGS::expect_chksumtype: 2
unsigned int ADHOC_PROTOCOL_FLAGS::xmit_shortensf: 1
unsigned int ADHOC_PROTOCOL_FLAGS::xmit_shortenlcf: 1
unsigned int ADHOC_PROTOCOL_FLAGS::unused_2: 3
unsigned int ADHOC_PROTOCOL_FLAGS::use_std_posresp: 1
unsigned int ADHOC_PROTOCOL_FLAGS::use_std_negresp: 1
unsigned int ADHOC_PROTOCOL_FLAGS::slaveprotocol: 1
unsigned int ADHOC_PROTOCOL_FLAGS::expect_shortenedsf: 2
unsigned int ADHOC_PROTOCOL_FLAGS::expect_shortenedlcf: 2
unsigned int ADHOC_PROTOCOL_FLAGS::unused_3: 5
unsigned int ADHOC_PROTOCOL_FLAGS::accept_any_csize: 1
unsigned int ADHOC_PROTOCOL_FLAGS::xmit_shortenflowctrl: 1
} ADHOC_PROTOCOL_FLAGS::lin
unsigned int ADHOC_PROTOCOL_FLAGS::protocoltype: 6
unsigned int ADHOC_PROTOCOL_FLAGS::xmit_canfd_switch: 1
unsigned int ADHOC_PROTOCOL_FLAGS::xmit_canfd_frame: 1
unsigned int ADHOC_PROTOCOL_FLAGS::xmit_can_11_29bit: 1
unsigned int ADHOC_PROTOCOL_FLAGS::expect_can_11_29bit: 2
unsigned int ADHOC_PROTOCOL_FLAGS::xmit_shortensf: 1
unsigned int ADHOC_PROTOCOL_FLAGS::xmit_shortenlcf: 1
unsigned int ADHOC_PROTOCOL_FLAGS::unused_1: 3
unsigned int ADHOC_PROTOCOL_FLAGS::use_std_posresp: 1
unsigned int ADHOC_PROTOCOL_FLAGS::use_std_negresp: 1
unsigned int ADHOC_PROTOCOL_FLAGS::slaveprotocol: 1
unsigned int ADHOC_PROTOCOL_FLAGS::expect_shortenedsf: 2
unsigned int ADHOC_PROTOCOL_FLAGS::expect_shortenedlcf: 2
unsigned int ADHOC_PROTOCOL_FLAGS::expect_canfd_switch: 2
unsigned int ADHOC_PROTOCOL_FLAGS::expect_canfd_frame: 2
unsigned int ADHOC_PROTOCOL_FLAGS::xmit_no_flowctrl_wait: 1
unsigned int ADHOC_PROTOCOL_FLAGS::accept_any_csize: 1
unsigned int ADHOC_PROTOCOL_FLAGS::xmit_shortenflowctrl: 1
struct {
unsigned int ADHOC_PROTOCOL_FLAGS::protocoltype: 6
unsigned int ADHOC_PROTOCOL_FLAGS::xmit_canfd_switch: 1
unsigned int ADHOC_PROTOCOL_FLAGS::xmit_canfd_frame: 1
unsigned int ADHOC_PROTOCOL_FLAGS::xmit_can_11_29bit: 1
unsigned int ADHOC_PROTOCOL_FLAGS::expect_can_11_29bit: 2
unsigned int ADHOC_PROTOCOL_FLAGS::xmit_shortensf: 1
unsigned int ADHOC_PROTOCOL_FLAGS::xmit_shortenlcf: 1
unsigned int ADHOC_PROTOCOL_FLAGS::unused_1: 3
unsigned int ADHOC_PROTOCOL_FLAGS::use_std_posresp: 1
unsigned int ADHOC_PROTOCOL_FLAGS::use_std_negresp: 1
unsigned int ADHOC_PROTOCOL_FLAGS::slaveprotocol: 1
unsigned int ADHOC_PROTOCOL_FLAGS::expect_shortenedsf: 2
unsigned int ADHOC_PROTOCOL_FLAGS::expect_shortenedlcf: 2
unsigned int ADHOC_PROTOCOL_FLAGS::expect_canfd_switch: 2
unsigned int ADHOC_PROTOCOL_FLAGS::expect_canfd_frame: 2
unsigned int ADHOC_PROTOCOL_FLAGS::xmit_no_flowctrl_wait: 1
unsigned int ADHOC_PROTOCOL_FLAGS::accept_any_csize: 1
unsigned int ADHOC_PROTOCOL_FLAGS::xmit_shortenflowctrl: 1
} ADHOC_PROTOCOL_FLAGS::can
const char * | BLC_ADHOC_PROTOCOL::name
ADHOC_PROTOCOL_FLAGS BLC_ADHOC_PROTOCOL::flags
unsigned char | BLC_ADHOC_PROTOCOL::active
int | BLC_ADHOC_PROTOCOL::req_slot_time
int | BLC_ADHOC_PROTOCOL::rsp_slot_time
int | BLC_ADHOC_PROTOCOL::rsp_delay
unsigned char | BLC_ADHOC_PROTOCOL::fill_byte
unsigned int ADHOC_SERVICE_FLAGS::unused_1: 2
unsigned int ADHOC_SERVICE_FLAGS::unused_2: 2
unsigned int ADHOC_SERVICE_FLAGS::shortensf_txd: 2
unsigned int ADHOC_SERVICE_FLAGS::shortensf_rcv: 2
unsigned int ADHOC_SERVICE_FLAGS::shortenlcf_txd: 2
unsigned int ADHOC_SERVICE_FLAGS::shortenlcf_rcv: 2
unsigned int ADHOC_SERVICE_FLAGS::unused_3: 8
unsigned int ADHOC_SERVICE_FLAGS::use_std_posresp: 2
unsigned int ADHOC_SERVICE_FLAGS::use_std_negresp: 2
unsigned int ADHOC_SERVICE_FLAGS::requestonly: 1
unsigned int ADHOC_SERVICE_FLAGS::unused_4: 2
unsigned int ADHOC_SERVICE_FLAGS::accept_any_csize: 2
unsigned int ADHOC_SERVICE_FLAGS::unused_5: 3
struct {
unsigned int ADHOC_SERVICE_FLAGS::unused_1: 2
unsigned int ADHOC_SERVICE_FLAGS::unused_2: 2
unsigned int ADHOC_SERVICE_FLAGS::shortensf_txd: 2
unsigned int ADHOC_SERVICE_FLAGS::shortensf_rcv: 2
unsigned int ADHOC_SERVICE_FLAGS::shortenlcf_txd: 2
unsigned int ADHOC_SERVICE_FLAGS::shortenlcf_rcv: 2
unsigned int ADHOC_SERVICE_FLAGS::unused_3: 8
unsigned int ADHOC_SERVICE_FLAGS::use_std_posresp: 2
unsigned int ADHOC_SERVICE_FLAGS::use_std_negresp: 2
unsigned int ADHOC_SERVICE_FLAGS::requestonly: 1
unsigned int ADHOC_SERVICE_FLAGS::unused_4: 2
unsigned int ADHOC_SERVICE_FLAGS::accept_any_csize: 2
unsigned int ADHOC_SERVICE_FLAGS::unused_5: 3
} ADHOC_SERVICE_FLAGS::generic
unsigned int ADHOC_SERVICE_FLAGS::checksum_txd: 2
unsigned int ADHOC_SERVICE_FLAGS::checksum_rcv: 2
unsigned int ADHOC_SERVICE_FLAGS::shortensf_txd: 2
unsigned int ADHOC_SERVICE_FLAGS::shortensf_rcv: 2
unsigned int ADHOC_SERVICE_FLAGS::shortenlcf_txd: 2
unsigned int ADHOC_SERVICE_FLAGS::shortenlcf_rcv: 2
unsigned int ADHOC_SERVICE_FLAGS::unused_1: 8
unsigned int ADHOC_SERVICE_FLAGS::use_std_posresp: 2
unsigned int ADHOC_SERVICE_FLAGS::use_std_negresp: 2
unsigned int ADHOC_SERVICE_FLAGS::requestonly: 1
unsigned int ADHOC_SERVICE_FLAGS::unused_2: 2
unsigned int ADHOC_SERVICE_FLAGS::accept_any_csize: 2
unsigned int ADHOC_SERVICE_FLAGS::unused_3: 3
struct {
unsigned int ADHOC_SERVICE_FLAGS::checksum_txd: 2
unsigned int ADHOC_SERVICE_FLAGS::checksum_rcv: 2
unsigned int ADHOC_SERVICE_FLAGS::shortensf_txd: 2
unsigned int ADHOC_SERVICE_FLAGS::shortensf_rcv: 2
unsigned int ADHOC_SERVICE_FLAGS::shortenlcf_txd: 2
unsigned int ADHOC_SERVICE_FLAGS::shortenlcf_rcv: 2
unsigned int ADHOC_SERVICE_FLAGS::unused_1: 8
unsigned int ADHOC_SERVICE_FLAGS::use_std_posresp: 2
unsigned int ADHOC_SERVICE_FLAGS::use_std_negresp: 2
unsigned int ADHOC_SERVICE_FLAGS::requestonly: 1
unsigned int ADHOC_SERVICE_FLAGS::unused_2: 2
unsigned int ADHOC_SERVICE_FLAGS::accept_any_csize: 2
unsigned int ADHOC_SERVICE_FLAGS::unused_3: 3
} ADHOC_SERVICE_FLAGS::lin
unsigned int ADHOC_SERVICE_FLAGS::id_11_29_txd: 2
unsigned int ADHOC_SERVICE_FLAGS::id_11_29_rcv: 2
unsigned int ADHOC_SERVICE_FLAGS::shortensf_txd: 2
unsigned int ADHOC_SERVICE_FLAGS::shortensf_rcv: 2
unsigned int ADHOC_SERVICE_FLAGS::shortenlcf_txd: 2
unsigned int ADHOC_SERVICE_FLAGS::shortenlcf_rcv: 2
unsigned int ADHOC_SERVICE_FLAGS::fdbaudswitch_txd: 2
unsigned int ADHOC_SERVICE_FLAGS::fdbaudswitch_rcv: 2
unsigned int ADHOC_SERVICE_FLAGS::fdframe_txd: 2
unsigned int ADHOC_SERVICE_FLAGS::fdframe_rcv: 2
unsigned int ADHOC_SERVICE_FLAGS::use_std_posresp: 2
unsigned int ADHOC_SERVICE_FLAGS::use_std_negresp: 2
unsigned int ADHOC_SERVICE_FLAGS::requestonly: 1
unsigned int ADHOC_SERVICE_FLAGS::no_flowctrl_wait: 2
unsigned int ADHOC_SERVICE_FLAGS::accept_any_csize: 2
unsigned int ADHOC_SERVICE_FLAGS::unused_1: 3
struct {
unsigned int ADHOC_SERVICE_FLAGS::id_11_29_txd: 2
unsigned int ADHOC_SERVICE_FLAGS::id_11_29_rcv: 2
unsigned int ADHOC_SERVICE_FLAGS::shortensf_txd: 2
unsigned int ADHOC_SERVICE_FLAGS::shortensf_rcv: 2
unsigned int ADHOC_SERVICE_FLAGS::shortenlcf_txd: 2
unsigned int ADHOC_SERVICE_FLAGS::shortenlcf_rcv: 2
unsigned int ADHOC_SERVICE_FLAGS::fdbaudswitch_txd: 2
unsigned int ADHOC_SERVICE_FLAGS::fdbaudswitch_rcv: 2
unsigned int ADHOC_SERVICE_FLAGS::fdframe_txd: 2
unsigned int ADHOC_SERVICE_FLAGS::fdframe_rcv: 2
unsigned int ADHOC_SERVICE_FLAGS::use_std_posresp: 2
unsigned int ADHOC_SERVICE_FLAGS::use_std_negresp: 2
unsigned int ADHOC_SERVICE_FLAGS::requestonly: 1
unsigned int ADHOC_SERVICE_FLAGS::no_flowctrl_wait: 2
unsigned int ADHOC_SERVICE_FLAGS::accept_any_csize: 2
unsigned int ADHOC_SERVICE_FLAGS::unused_1: 3
} ADHOC_SERVICE_FLAGS::can
const char * | BLC_ADHOC_SERVICE::name
ADHOC_SERVICE_FLAGS BLC_ADHOC_SERVICE::flags
int | BLC_ADHOC_SERVICE::req_frame_id
long long | BLC_ADHOC_SERVICE::req_container_size
long long | BLC_ADHOC_SERVICE::req_payload_size
int | BLC_ADHOC_SERVICE::req_slot_time
int | BLC_ADHOC_SERVICE::rsp_frame_id
long long | BLC_ADHOC_SERVICE::rsp_container_size
long long | BLC_ADHOC_SERVICE::rsp_payload_size
int | BLC_ADHOC_SERVICE::rsp_slot_time
int | BLC_ADHOC_SERVICE::rsp_delay
int | BLC_ADHOC_EXECUTE::nad
int | BLC_ADHOC_EXECUTE::p2_extended
int | BLC_ADHOC_EXECUTE::flow_control_st_min
int | BLC_ADHOC_EXECUTE::flow_control_block_size
int | BLC_LOG::format_version
unsigned int | BLC_LOG::source_type
int BLC_LOG::id
int BLC_LOG::signal_index
struct {
int BLC_LOG::id
int BLC_LOG::signal_index
} BLC_LOG::channel
int BLC_LOG::id
int BLC_LOG::sub_index
struct {
int BLC_LOG::id
int BLC_LOG::sub_index
} BLC_LOG::group
union {
struct {
int BLC_LOG::id
int BLC_LOG::signal_index
} BLC_LOG::channel
struct {
int BLC_LOG::id
int BLC_LOG::sub_index
} BLC_LOG::group
} BLC_LOG::source
unsigned long long | BLC_LOG::timestamp_unix
unsigned long | BLC_LOG::timestamp_usec
unsigned int | BLC_LOG::value_signed
unsigned int | BLC_LOG::value_element_size
unsigned int | BLC_LOG::value_array_size
unsigned char | BLC_LOG::value_data [4 *1024]

Typedef Documentation

typedef void( BLC_debug_callback_func)(BL_HANDLE, const char *text)

Definition at line 838 of file BabyLINCAN_types.h.

typedef void( BLC_debug_callback_func_ptr)(BL_HANDLE, const char *text, void *)

Definition at line 851 of file BabyLINCAN_types.h.

typedef void( BLC_dtl_request_callback_func)(BL_HANDLE, BLC_DTL dtl_request)

Definition at line 839 of file BabyLINCAN_types.h.

typedef void( BLC_dtl_request_callback_func_ptr)(BL_HANDLE, BLC_DTL dtl_request, void *)

Definition at line 852 of file BabyLINCAN_types.h.

typedef void( BLC_dtl_response_callback_func)(BL_HANDLE, BLC_DTL dtl_response)

Definition at line 840 of file BabyLINCAN_types.h.

typedef void( BLC_dtl_response_callback_func_ptr)(BL_HANDLE, BLC_DTL dtl_response, void *)

Definition at line 853 of file BabyLINCAN_types.h.

typedef void( BLC_error_callback_func)(BL_HANDLE, BLC_ERROR error)

Definition at line 837 of file BabyLINCAN_types.h.

typedef void( BLC_error_callback_func_ptr)(BL_HANDLE, BLC_ERROR error, void *)

Definition at line 850 of file BabyLINCAN_types.h.

typedef void( BLC_event_callback_func)(BL_HANDLE, BLC_EVENT event)

Definition at line 841 of file BabyLINCAN_types.h.

typedef void( BLC_event_callback_func_ptr)(BL_HANDLE, BLC_EVENT event, void *)

Definition at line 854 of file BabyLINCAN_types.h.

typedef void( BLC_frame_callback_func)(BL_HANDLE, BLC_FRAME frame)

Definition at line 833 of file BabyLINCAN_types.h.

typedef void( BLC_frame_callback_func_ptr)(BL_HANDLE, BLC_FRAME frame, void *)

Definition at line 846 of file BabyLINCAN_types.h.

typedef void( BLC_jumboframe_callback_func)(BL_HANDLE, BLC_JUMBO_FRAME jumbo_frame)

Definition at line 834 of file BabyLINCAN_types.h.

typedef void( BLC_jumboframe_callback_func_ptr)(BL_HANDLE, BLC_JUMBO_FRAME jumbo_frame, void *)

Definition at line 847 of file BabyLINCAN_types.h.

typedef void( BLC_log_callback_func_ptr)(BL_HANDLE, BLC_LOG log, void *)

Definition at line 855 of file BabyLINCAN_types.h.

typedef void( BLC_lua_print_func_ptr)(const char *msg, void *userdata)

Definition at line 857 of file BabyLINCAN_types.h.

typedef void( BLC_macrostate_callback_func)(BL_HANDLE, BLC_MACROSTATE macroState)

Definition at line 836 of file BabyLINCAN_types.h.

typedef void( BLC_macrostate_callback_func_ptr)(BL_HANDLE, BLC_MACROSTATE macroState, void *)

Definition at line 849 of file BabyLINCAN_types.h.

typedef void( BLC_signal_callback_func)(BL_HANDLE, BLC_SIGNAL signal)

Definition at line 835 of file BabyLINCAN_types.h.

typedef void( BLC_signal_callback_func_ptr)(BL_HANDLE, BLC_SIGNAL signal, void *)

Definition at line 848 of file BabyLINCAN_types.h.

Variable Documentation

unsigned int ADHOC_PROTOCOL_FLAGS::accept_any_csize

Definition at line 540 of file BabyLINCAN_types.h.

unsigned { ... } ::accept_any_csize

Definition at line 540 of file BabyLINCAN_types.h.

unsigned { ... } ::accept_any_csize

Definition at line 570 of file BabyLINCAN_types.h.

unsigned { ... } ::accept_any_csize

Definition at line 613 of file BabyLINCAN_types.h.

unsigned int ADHOC_SERVICE_FLAGS::accept_any_csize

Definition at line 667 of file BabyLINCAN_types.h.

unsigned { ... } ::accept_any_csize

Definition at line 667 of file BabyLINCAN_types.h.

unsigned { ... } ::accept_any_csize

Definition at line 699 of file BabyLINCAN_types.h.

unsigned { ... } ::accept_any_csize

Definition at line 750 of file BabyLINCAN_types.h.

unsigned char BLC_ADHOC_PROTOCOL::active

Definition at line 626 of file BabyLINCAN_types.h.

unsigned char BLC_SIGNAL::array[8]

Definition at line 366 of file BabyLINCAN_types.h.

int BLC_SIGNAL::arrayLength

Definition at line 364 of file BabyLINCAN_types.h.

int BLC_CHANNELINFO::associatedWithSectionNr

the number of the section of the loaded sdf associated with this channel >= 0 means valid section number, -1: no mapping or no sdf loaded

Definition at line 146 of file BabyLINCAN_types.h.

unsigned short BLC_TARGETID::build

Definition at line 76 of file BabyLINCAN_types.h.

short BLC_FRAME::busFlags

for LIN-BUS: Used as a bitfield, multiple flags possible

Value | Description
0x01 | Valid CLASSIC checksum (V1)
0x02 | Valid EXTENDED checksum (V2)
0x04 | incomplete frame without checksum, not an error
0x08 | Errorframe (f.ex: no data)
0x10 | Frame is slave response to a master request. If set, the upper 3 bits of flags denote a master request id
0x20 | Event triggered frame (only if 0x10 is not set )
0x1C0 | Master request ID
0x600 | Frame Type: 0: regular LIN, 1: KLine Raw, 2: KLine Webasto

for CAN-BUS: Used as a bitfield, multiple flags possible

Value | Description
0x01 | 29 bit frame identifier
0x06 | Frame Type: 0: regular CAN, 1: CAN-FD, 2: CAN-FD with bitrate switching

Definition at line 234 of file BabyLINCAN_types.h.

short BLC_JUMBO_FRAME::busFlags

for LIN-BUS: Used as a bitfield, multiple flags possible

Value | Description
0x01 | Valid CLASSIC checksum (V1)
0x02 | Valid EXTENDED checksum (V2)
0x04 | incomplete frame without checksum, not an error
0x08 | Errorframe (f.ex: no data)
0x10 | Frame is slave response to a master request. If set, the upper 3 bits of flags denote a master request id
0x20 | Event triggered frame ( only if 0x10 is not set )
0x1C0 | Master request ID
0x600 | Frame Type: 0: regular LIN, 1: KLine Raw, 2: KLine Webasto

for CAN-BUS: Used as a bitfield, multiple flags possible

Value | Description
0x01 | 29 bit frame identifier
0x06 | Frame Type: 0: regular LIN, 1: CAN-FD, 2: CAN-FD with bitrate switching

Definition at line 304 of file BabyLINCAN_types.h.

struct { ... } ADHOC_PROTOCOL_FLAGS::can
struct { ... } ADHOC_SERVICE_FLAGS::can
struct { ... } BLC_LOG::channel
struct { ... } ::channel
int BLC_MACROSTATE::channelid

Definition at line 320 of file BabyLINCAN_types.h.

unsigned char BLC_FRAME::checksum

Definition at line 239 of file BabyLINCAN_types.h.

unsigned char BLC_JUMBO_FRAME::checksum

Definition at line 309 of file BabyLINCAN_types.h.

unsigned int ADHOC_SERVICE_FLAGS::checksum_rcv

Definition at line 681 of file BabyLINCAN_types.h.

unsigned { ... } ::checksum_rcv

Definition at line 681 of file BabyLINCAN_types.h.

unsigned int ADHOC_SERVICE_FLAGS::checksum_txd

Definition at line 676 of file BabyLINCAN_types.h.

unsigned { ... } ::checksum_txd

Definition at line 676 of file BabyLINCAN_types.h.

unsigned long BLC_FRAME::chId

Definition at line 176 of file BabyLINCAN_types.h.

unsigned long BLC_JUMBO_FRAME::chId

Definition at line 245 of file BabyLINCAN_types.h.

unsigned short BLC_SIGNAL::chId

Definition at line 370 of file BabyLINCAN_types.h.

int BLC_MACROSTATE::cmdnr

denotes the command-number in the macro macronr which is currently executed

valid if state denotes a running macro

Definition at line 332 of file BabyLINCAN_types.h.

unsigned char BLC_DTL::data[4 *1024]

Definition at line 457 of file BabyLINCAN_types.h.

long long BLC_EVENT::data

Definition at line 491 of file BabyLINCAN_types.h.

char BLC_PORTINFO::device[256]

Definition at line 38 of file BabyLINCAN_types.h.

int BLC_EVENT::event
Value | Name | Description | data
0 | EVENTID_REBOOT | The device was rebootet. |
1 | EVENTID_HWSTATE | The state of the LIN bus voltage has changed | 0: LIN bus voltage missing. : LIN bus voltage detected.
3 | EVENTID_DIRECT_MODE |
4 | EVENTID_BOOTLOADER_START | The bootloader is starting after a reboot. | The second parameter contains the hardware type.
5 | EVENTID_FIRMWARE_START | The firmware is starting after a reboot. | The second parameter contains the hardware type.
6 | EVENTID_BUSSPEED_CHANGE | The bus speed has changed. | The second parameter is the bus speed.
7 | EVENTID_ENLARGE_TIMEOUT_REQ | The firmware requests a change of the default timeout. | For internal use only.
8 | EVENTID_REBOOT_TO_FOLLOW | Is sent before the device executes a reboot.
9 | EVENTID_INJECTREJECT_BY_FRAMEID | An inject command was rejected. | A protocol with the same RX ID was actually executed.
10 | EVENTID_DISCONNECT | Device disconnected from host. | The parameter contains the reason: 0: No command was received from the host and triggered a timeout. 1: A channel crashed and was reset.
999 | EVENTID_RUNTIME_ERROR | A runtime error occurred. | The second parameter contains the error code.

Definition at line 487 of file BabyLINCAN_types.h.

unsigned int ADHOC_PROTOCOL_FLAGS::expect_can_11_29bit

Definition at line 584 of file BabyLINCAN_types.h.

unsigned { ... } ::expect_can_11_29bit

Definition at line 584 of file BabyLINCAN_types.h.

unsigned int ADHOC_PROTOCOL_FLAGS::expect_canfd_frame

Definition at line 609 of file BabyLINCAN_types.h.

unsigned { ... } ::expect_canfd_frame

Definition at line 609 of file BabyLINCAN_types.h.

unsigned int ADHOC_PROTOCOL_FLAGS::expect_canfd_switch

Definition at line 605 of file BabyLINCAN_types.h.

unsigned { ... } ::expect_canfd_switch

Definition at line 605 of file BabyLINCAN_types.h.

unsigned int ADHOC_PROTOCOL_FLAGS::expect_chksumtype

Definition at line 552 of file BabyLINCAN_types.h.

unsigned { ... } ::expect_chksumtype

Definition at line 552 of file BabyLINCAN_types.h.

unsigned int ADHOC_PROTOCOL_FLAGS::expect_shortenedlcf

Definition at line 537 of file BabyLINCAN_types.h.

unsigned { ... } ::expect_shortenedlcf

Definition at line 537 of file BabyLINCAN_types.h.

unsigned { ... } ::expect_shortenedlcf

Definition at line 567 of file BabyLINCAN_types.h.

unsigned { ... } ::expect_shortenedlcf

Definition at line 601 of file BabyLINCAN_types.h.

unsigned int ADHOC_PROTOCOL_FLAGS::expect_shortenedsf

Definition at line 533 of file BabyLINCAN_types.h.

unsigned { ... } ::expect_shortenedsf

Definition at line 533 of file BabyLINCAN_types.h.

unsigned { ... } ::expect_shortenedsf

Definition at line 565 of file BabyLINCAN_types.h.

unsigned { ... } ::expect_shortenedsf

Definition at line 597 of file BabyLINCAN_types.h.

unsigned int ADHOC_SERVICE_FLAGS::fdbaudswitch_rcv

Definition at line 730 of file BabyLINCAN_types.h.

unsigned { ... } ::fdbaudswitch_rcv

Definition at line 730 of file BabyLINCAN_types.h.

unsigned int ADHOC_SERVICE_FLAGS::fdbaudswitch_txd

Definition at line 725 of file BabyLINCAN_types.h.

unsigned { ... } ::fdbaudswitch_txd

Definition at line 725 of file BabyLINCAN_types.h.

unsigned int ADHOC_SERVICE_FLAGS::fdframe_rcv

Definition at line 740 of file BabyLINCAN_types.h.

unsigned { ... } ::fdframe_rcv

Definition at line 740 of file BabyLINCAN_types.h.

unsigned int ADHOC_SERVICE_FLAGS::fdframe_txd

Definition at line 735 of file BabyLINCAN_types.h.

unsigned { ... } ::fdframe_txd

Definition at line 735 of file BabyLINCAN_types.h.

char BLC_SDFINFO::filename[256]

Definition at line 152 of file BabyLINCAN_types.h.

unsigned char BLC_ADHOC_PROTOCOL::fill_byte

Definition at line 630 of file BabyLINCAN_types.h.

unsigned short BLC_TARGETID::flags
Value | Description
0x01 | Testversion

Definition at line 84 of file BabyLINCAN_types.h.

ADHOC_PROTOCOL_FLAGS BLC_ADHOC_PROTOCOL::flags

Definition at line 624 of file BabyLINCAN_types.h.

ADHOC_SERVICE_FLAGS BLC_ADHOC_SERVICE::flags

Definition at line 758 of file BabyLINCAN_types.h.

int BLC_ADHOC_EXECUTE::flow_control_block_size

Definition at line 776 of file BabyLINCAN_types.h.

int BLC_ADHOC_EXECUTE::flow_control_st_min

Definition at line 775 of file BabyLINCAN_types.h.

int BLC_LOG::format_version

Definition at line 782 of file BabyLINCAN_types.h.

unsigned char BLC_FRAME::frameData[8]

Definition at line 192 of file BabyLINCAN_types.h.

unsigned char BLC_JUMBO_FRAME::frameData[1024]

Definition at line 261 of file BabyLINCAN_types.h.

short BLC_FRAME::frameFlags

Used as a bitfield, multiple flags possible

Value | Description
0x01 | Frame has error
0x02 | Frame is selfsent (sent by the BabyLIN-Device, because it simulates the corresponding node)
0x04 | Timebase, if set, the unit of timestamp is ms, otherwise us
0x08 | The frame was a SDF specified frame
0x10 | The frame was an injected frame
0x20 | The frame was a protocol frame

Definition at line 208 of file BabyLINCAN_types.h.

short BLC_JUMBO_FRAME::frameFlags

Used as a bitfield, multiple flags possible

Value | Description
0x01 | Frame has error
0x02 | Frame is selfsent (sent by the BabyLIN-Device, because it simulates the corresponding node)
0x04 | Timebase, if set, the unit of timestamp is ms, otherwise us
0x08 | The frame was a SDF specified frame
0x10 | The frame was an injected frame
0x20 | The frame was a protocol frame
0x40 | The frame was not actually on the bus, only been mapped as its a SDF like inject

Definition at line 278 of file BabyLINCAN_types.h.

unsigned long BLC_FRAME::frameId

Definition at line 186 of file BabyLINCAN_types.h.

unsigned long BLC_JUMBO_FRAME::frameId

Definition at line 255 of file BabyLINCAN_types.h.

struct { ... } ADHOC_PROTOCOL_FLAGS::generic
struct { ... } ADHOC_SERVICE_FLAGS::generic
struct { ... } BLC_LOG::group
struct { ... } ::group
long BLC_TARGETID::heapsize

Definition at line 90 of file BabyLINCAN_types.h.

unsigned short BLC_CHANNELINFO::id

Definition at line 107 of file BabyLINCAN_types.h.

int BLC_LOG::id

Definition at line 789 of file BabyLINCAN_types.h.

int { ... } ::id

Definition at line 789 of file BabyLINCAN_types.h.

int { ... } ::id

Definition at line 795 of file BabyLINCAN_types.h.

unsigned int ADHOC_SERVICE_FLAGS::id_11_29_rcv

Definition at line 712 of file BabyLINCAN_types.h.

unsigned { ... } ::id_11_29_rcv

Definition at line 712 of file BabyLINCAN_types.h.

unsigned int ADHOC_SERVICE_FLAGS::id_11_29_txd

Definition at line 707 of file BabyLINCAN_types.h.

unsigned { ... } ::id_11_29_txd

Definition at line 707 of file BabyLINCAN_types.h.

int BLC_SIGNAL::index

Definition at line 358 of file BabyLINCAN_types.h.

long BLC_FRAME::intime

Definition at line 183 of file BabyLINCAN_types.h.

long BLC_JUMBO_FRAME::intime

Definition at line 252 of file BabyLINCAN_types.h.

int BLC_SIGNAL::isArray

Definition at line 360 of file BabyLINCAN_types.h.

int BLC_DTL::length

Definition at line 455 of file BabyLINCAN_types.h.

unsigned char BLC_FRAME::lenOfData

Definition at line 189 of file BabyLINCAN_types.h.

unsigned int BLC_JUMBO_FRAME::lenOfData

Definition at line 258 of file BabyLINCAN_types.h.

struct { ... } ADHOC_PROTOCOL_FLAGS::lin
struct { ... } ADHOC_SERVICE_FLAGS::lin
int BLC_MACROSTATE::macronr

Definition at line 324 of file BabyLINCAN_types.h.

long BLC_CHANNELINFO::maxbaudrate

Definition at line 116 of file BabyLINCAN_types.h.

unsigned char BLC_DTL::nad

Definition at line 452 of file BabyLINCAN_types.h.

int BLC_ADHOC_EXECUTE::nad

Definition at line 773 of file BabyLINCAN_types.h.

char BLC_PORTINFO::name[256]

Definition at line 34 of file BabyLINCAN_types.h.

char BLC_TARGETID::name[128]

Definition at line 96 of file BabyLINCAN_types.h.

char BLC_CHANNELINFO::name[128]

Definition at line 113 of file BabyLINCAN_types.h.

char BLC_SECTIONINFO::name[128]

Definition at line 164 of file BabyLINCAN_types.h.

const char* BLC_ADHOC_PROTOCOL::name

Definition at line 622 of file BabyLINCAN_types.h.

const char* BLC_ADHOC_SERVICE::name

Definition at line 757 of file BabyLINCAN_types.h.

unsigned { ... } ::no_flowctrl_wait

Definition at line 747 of file BabyLINCAN_types.h.

unsigned int ADHOC_SERVICE_FLAGS::no_flowctrl_wait

Definition at line 747 of file BabyLINCAN_types.h.

short BLC_SECTIONINFO::nr

Definition at line 170 of file BabyLINCAN_types.h.

long BLC_TARGETID::numofchannels

Definition at line 93 of file BabyLINCAN_types.h.

int BLC_ADHOC_EXECUTE::p2_extended

Definition at line 774 of file BabyLINCAN_types.h.

unsigned int BLC_EVENT::pc_timestamp

Definition at line 469 of file BabyLINCAN_types.h.

int BLC_PORTINFO::portNr

Definition at line 24 of file BabyLINCAN_types.h.

int ADHOC_PROTOCOL_FLAGS::protocoltype

Definition at line 516 of file BabyLINCAN_types.h.

int { ... } ::protocoltype

Definition at line 516 of file BabyLINCAN_types.h.

unsigned { ... } ::protocoltype

Definition at line 547 of file BabyLINCAN_types.h.

unsigned int ADHOC_PROTOCOL_FLAGS::protocoltype

Definition at line 547 of file BabyLINCAN_types.h.

unsigned { ... } ::protocoltype

Definition at line 576 of file BabyLINCAN_types.h.

long long BLC_ADHOC_SERVICE::req_container_size

Definition at line 761 of file BabyLINCAN_types.h.

int BLC_ADHOC_SERVICE::req_frame_id

Definition at line 760 of file BabyLINCAN_types.h.

long long BLC_ADHOC_SERVICE::req_payload_size

Definition at line 762 of file BabyLINCAN_types.h.

int BLC_ADHOC_PROTOCOL::req_slot_time

Definition at line 627 of file BabyLINCAN_types.h.

int BLC_ADHOC_SERVICE::req_slot_time

Definition at line 763 of file BabyLINCAN_types.h.

unsigned int ADHOC_SERVICE_FLAGS::requestonly

Definition at line 664 of file BabyLINCAN_types.h.

unsigned { ... } ::requestonly

Definition at line 664 of file BabyLINCAN_types.h.

unsigned { ... } ::requestonly

Definition at line 696 of file BabyLINCAN_types.h.

unsigned { ... } ::requestonly

Definition at line 746 of file BabyLINCAN_types.h.

long BLC_CHANNELINFO::reserved1

Bit0 : Indicates, whether the channel is disabled, due to missing licences.
Bit1 : Indicates, that SDFs of version 3 may be uploaded onto this Channel.
Bit2 : Deprecated: ignore the state of this bit.
Bit3 : Indicates, that the Channel is initialized (SDF/Section was loaded or Monitor Mode is active).
Bit4 : Indicates, that the channel has the ability and license to send and receive CAN FD frames.
Bit5 : Indicates, that the channel has the ability and license to send and receive CAN HS frames.
Bit6 : Indicates, that the channel has the ability and license to send and receive CAN LS frames.

Remarks
Some bits may not be set by older firmware version.
Please consider a firmware update.

Definition at line 136 of file BabyLINCAN_types.h.

long BLC_CHANNELINFO::reserved2

Definition at line 139 of file BabyLINCAN_types.h.

long BLC_CHANNELINFO::reserved3

Definition at line 142 of file BabyLINCAN_types.h.

long long BLC_ADHOC_SERVICE::rsp_container_size

Definition at line 766 of file BabyLINCAN_types.h.

int BLC_ADHOC_PROTOCOL::rsp_delay

Definition at line 629 of file BabyLINCAN_types.h.

int BLC_ADHOC_SERVICE::rsp_delay

Definition at line 769 of file BabyLINCAN_types.h.

int BLC_ADHOC_SERVICE::rsp_frame_id

Definition at line 765 of file BabyLINCAN_types.h.

long long BLC_ADHOC_SERVICE::rsp_payload_size

Definition at line 767 of file BabyLINCAN_types.h.

int BLC_ADHOC_PROTOCOL::rsp_slot_time

Definition at line 628 of file BabyLINCAN_types.h.

int BLC_ADHOC_SERVICE::rsp_slot_time

Definition at line 768 of file BabyLINCAN_types.h.

short BLC_SDFINFO::sectionCount

Definition at line 155 of file BabyLINCAN_types.h.

long BLC_TARGETID::serial

Definition at line 87 of file BabyLINCAN_types.h.

unsigned int ADHOC_SERVICE_FLAGS::shortenlcf_rcv

Definition at line 656 of file BabyLINCAN_types.h.

unsigned { ... } ::shortenlcf_rcv

Definition at line 656 of file BabyLINCAN_types.h.

unsigned { ... } ::shortenlcf_rcv

Definition at line 689 of file BabyLINCAN_types.h.

unsigned { ... } ::shortenlcf_rcv

Definition at line 720 of file BabyLINCAN_types.h.

unsigned int ADHOC_SERVICE_FLAGS::shortenlcf_txd

Definition at line 651 of file BabyLINCAN_types.h.

unsigned { ... } ::shortenlcf_txd

Definition at line 651 of file BabyLINCAN_types.h.

unsigned { ... } ::shortenlcf_txd

Definition at line 687 of file BabyLINCAN_types.h.

unsigned { ... } ::shortenlcf_txd

Definition at line 718 of file BabyLINCAN_types.h.

unsigned { ... } ::shortensf_rcv

Definition at line 646 of file BabyLINCAN_types.h.

unsigned int ADHOC_SERVICE_FLAGS::shortensf_rcv

Definition at line 646 of file BabyLINCAN_types.h.

unsigned { ... } ::shortensf_rcv

Definition at line 685 of file BabyLINCAN_types.h.

unsigned { ... } ::shortensf_rcv

Definition at line 716 of file BabyLINCAN_types.h.

unsigned int ADHOC_SERVICE_FLAGS::shortensf_txd

Definition at line 641 of file BabyLINCAN_types.h.

unsigned { ... } ::shortensf_txd

Definition at line 641 of file BabyLINCAN_types.h.

unsigned { ... } ::shortensf_txd

Definition at line 683 of file BabyLINCAN_types.h.

unsigned { ... } ::shortensf_txd

Definition at line 714 of file BabyLINCAN_types.h.

int { ... } ::signal_index

Definition at line 791 of file BabyLINCAN_types.h.

int BLC_LOG::signal_index

Definition at line 791 of file BabyLINCAN_types.h.

unsigned int ADHOC_PROTOCOL_FLAGS::slaveprotocol

Definition at line 529 of file BabyLINCAN_types.h.

unsigned { ... } ::slaveprotocol

Definition at line 529 of file BabyLINCAN_types.h.

unsigned { ... } ::slaveprotocol

Definition at line 563 of file BabyLINCAN_types.h.

unsigned { ... } ::slaveprotocol

Definition at line 595 of file BabyLINCAN_types.h.

union { ... } BLC_LOG::source
unsigned int BLC_LOG::source_type

Definition at line 784 of file BabyLINCAN_types.h.

int BLC_MACROSTATE::state
Value | Description
0x00 | Macro execution ended
0x01 | Macro execution started
0x02 | Macro execution running
0x03 | Macro execution error

Definition at line 344 of file BabyLINCAN_types.h.

unsigned short BLC_ERROR::status

Depends on type descriptions. for "dll status code":

status | description
1 | Lost connection to device

Definition at line 442 of file BabyLINCAN_types.h.

BL_DTL_STATUS BLC_DTL::status

Definition at line 449 of file BabyLINCAN_types.h.

int BLC_LOG::sub_index

Definition at line 797 of file BabyLINCAN_types.h.

int { ... } ::sub_index

Definition at line 797 of file BabyLINCAN_types.h.

unsigned long BLC_FRAME::timestamp

Definition at line 180 of file BabyLINCAN_types.h.

unsigned long BLC_JUMBO_FRAME::timestamp

Definition at line 249 of file BabyLINCAN_types.h.

unsigned long BLC_MACROSTATE::timestamp
Remarks
Previous BabyLIN DLL v10.22.0 this value was long! We recommend to recompile your app using BabyLIN library if you have linked against a version previous v10.22.0.

Definition at line 352 of file BabyLINCAN_types.h.

unsigned long BLC_SIGNAL::timestamp

Definition at line 368 of file BabyLINCAN_types.h.

unsigned long BLC_ERROR::timestamp

device-timstamp in us if error type is a device error (1-16)

pc timestamp in ms if error type is dll error (65535)

Definition at line 383 of file BabyLINCAN_types.h.

unsigned int BLC_EVENT::timestamp

Definition at line 465 of file BabyLINCAN_types.h.

unsigned long long BLC_LOG::timestamp_unix

Definition at line 802 of file BabyLINCAN_types.h.

unsigned long BLC_LOG::timestamp_usec

Definition at line 804 of file BabyLINCAN_types.h.

unsigned int ADHOC_PROTOCOL_FLAGS::tx_shortenlcf

Definition at line 521 of file BabyLINCAN_types.h.

unsigned { ... } ::tx_shortenlcf

Definition at line 521 of file BabyLINCAN_types.h.

unsigned { ... } ::tx_shortensf

Definition at line 519 of file BabyLINCAN_types.h.

unsigned int ADHOC_PROTOCOL_FLAGS::tx_shortensf

Definition at line 519 of file BabyLINCAN_types.h.

int BLC_PORTINFO::type

Devices of type 1 can not be Connected to via BLC_open...(...).

Definition at line 30 of file BabyLINCAN_types.h.

unsigned short BLC_TARGETID::type
Value | Device
0x100 | Baby-LIN
0x102 | Baby-LIN-RC
0x103 | Baby-LIN-KS01
0x200 | Baby-LIN-RM
0x510 | Baby-LIN-MB
0x300 | HARP
0x503 | Baby-LIN-II
0x501 | Baby-LIN-RC-II
0x500 | Baby-LIN-RM-II
0x700 | Baby-LIN-MB-II
0x502 | HARP-4
0x511 | HARP-5
0x508 | Baby-LIN-RM-III
0x509 | Baby-LIN-RC-II-B
0x504 | MIF_LIN-II
0x507 | MIF_CAN_FD
0x600 | Virtual_CAN

Definition at line 70 of file BabyLINCAN_types.h.

unsigned short BLC_CHANNELINFO::type

Definition at line 110 of file BabyLINCAN_types.h.

int BLC_SECTIONINFO::type

Definition at line 167 of file BabyLINCAN_types.h.

unsigned short BLC_ERROR::type
Value | Name | Description | Status
1 | ERRTYPE_ID | Parity error in ID
2 | ERRTYPE_DATA | Read data from BUS does not match send data | Frame-ID
3 | ERRTYPE_FRAMING | Framing error in data reception | Frame-ID
4 | ERRTYPE_CHECKSUM | Checksum failed | Frame-ID
5 | ERRTYPE_DATATO | Data timed out (incomplete msg reception) | Frame-ID
6 | ERRTYPE_SEQ | Unexpected state sequencing | internal status
8 | ERRTYPE_MACRO | Error in macro execution | internal status
9 | ERRTYPE_BUSBUSY | Bus is already used | internal status
10 | ERRTYPE_BUSOFF | Bus is offline (no bus power) | internal status
11 | ERRTYPE_BUSSPEED_DIFFERS | Actual bus-speed differs from LDF bus speed (Warning) | actual speed
12 | ERRTYPE_RX_FRAME_LEN | Frame length error | Frame-ID
13 | ERRTYPE_RX_INCOMPLETE | Incomplete frame received | Frame-ID
14 | ERRTYPE_RESP_LOST | Response send buffer overflow occured | unused
15 | ERRTYPE_CAN_NOERR | CAN error disappeared | unused
16 | ERRTYPE_CAN_ERR | CAN error | bitmap 0x01 noAck bitmap 0x02 stuffing error bitmap 0x04 framing error bitmap 0x08 recessive bit error bitmap 0x10 dominant bit error bitmap 0x20 checksum error
17 | ERRTYPE_FRAME_ERR | A received Frame does not match its definition in the SDF | The Frame number in the SDF
18 | ERRTYPE_LIN_SHORT_GND | LIN master Bus Low level too lang (master pull-up destroying danger) | unused
19 | ERRTYPE_INTERNAL_OVERFLOW | Queue overflow of an internal buffer/queue | internal status
20 | ERRTYPE_FLASH_SDF_LOAD | Error while loading SDF from persistent memory | internal status
21 | ERRTYPE_TX_HEADER_FAIL | An error occurred during the sending of a frame header | Frame-ID
22 | ERRTYPE_NO_CANPHY_SELECT | Bus was started without an activated CAN-Transceiver
23 | ERRTYPE_SLAVE_PROTOCOL_TIMEOUT | Slave protocol timeout
24 | ERRTYPE_CAN_STUFFERR | A CAN stuff error occurred
25 | ERRTYPE_CAN_FORMERR | A CAN form error occurred
26 | ERRTYPE_CAN_ACKERR | A CAN ack error occurred
27 | ERRTYPE_CAN_RECESSIVEBITERR | A CAN bit recessive error occurred
28 | ERRTYPE_CAN_DOMINANTBITERR | A CAN bit dominant error occurred
29 | ERRTYPE_CAN_CRCERR | A CAN CRC error occurred
30 | ERRTYPE_CAN_SETBYSWERR | A CAN frame can't be send on the bus
31 | ERRTYPE_CAN_BUSOFF | The CAN Bus is off
32 | ERRTYPE_SDF_LOG_COMMAND | Log file error | 0=An internal error occurred 1=The log command is unknown 2=The log command has too few parameters 3=The log command has too many parameters 4=The log file handle is invalid 10=A parameter is invalid 11=The first parameter is mandatory 12=The first parameter is no unsigned integer 13=The first parameter is no handle 14=The first parameter is no valid handle 21=The second parameter is mandatory 22=The second parameter is no unsigned integer 23=The second parameter is no handle 24=The second parameter is no valid handle 31=The third parameter is mandatory 32=The third parameter is no unsigned integer 33=The third parameter is no handle 34=The third parameter is no valid handle 100=Could not create log file 101=Could not close log file 102=Could not start log file 103=Could not stop log file 104=Could not pause log file 105=Could not resume log file 106=Could not write to file
33 | ERRTYPE_SD_SDF_LOAD | The SDF could not be loaded from the SD card
34 | ERRTYPE_PROTOCOL_DEFINITION | Error on protocol definition | 0=Error on CAN ID size 1=CAN flags mismatch 2=frame size too large
35 | ERRTYPE_PROTOCOL_SLAVE | Error on slave protocol
36 | ERRTYPE_PROTOCOL_MASTER | Error on master protocol | See macro error codes
256 | ERRTYPE_WARN_CANFD_FRAME | Warning: CAN-FD baudrate and flags are inconsistent
257 | ERRTYPE_WARN_MISSING_SYSCFG204 | Warning: SYSCFG204 not defined
258 | ERRTYPE_WARN_CANID_MULTIPLE_USE | CAN ID used in more than one frame definitions
512 | ERRTYPE_SLAVE_PROTOCOL_SKIPPED_MIXED_PROTOCOLTYPES | Skipped execution of slave protocol
513 | ERRTYPE_SLAVE_PROTOCOL_USE_FIRST | The first of multiple possible services is executed
514 | ERRTYPE_LOGGER | A logging error occurred | 0=No SD Card in device or no SD Card license 1=Log file number 99999 reached, please empty log directory 2=No free space on SD card 3=Can not open log file
999 | ERRTYPE_RUNTIME_SDFCODES | A runtime error occurred in the SDF
61166 | ERRTYPE_RUNTIME_DLLCONMBII | MB-II DLL-Connector error | 1=Connection lost 2=Message lost 3=Message dropped
65535 | ERRTYPE_RUNTIME_LIBRARY | Error in DLL occurred | 1=Connection lost 2=Message lost 3=Message dropped 4=Message was no report and not an answer to a transaction 5=The Baby-LIN library was not active for more than 2s 6=The Baby-LIN library was not active for more than 3s 7=The Baby-LIN library was not active for more than 4s 8=The Baby-LIN library was not active for more than 5s

Definition at line 433 of file BabyLINCAN_types.h.

unsigned { ... } ::unused_1

Definition at line 517 of file BabyLINCAN_types.h.

unsigned int ADHOC_PROTOCOL_FLAGS::unused_1

Definition at line 517 of file BabyLINCAN_types.h.

unsigned { ... } ::unused_1

Definition at line 548 of file BabyLINCAN_types.h.

unsigned { ... } ::unused_1

Definition at line 589 of file BabyLINCAN_types.h.

unsigned int ADHOC_SERVICE_FLAGS::unused_1

Definition at line 635 of file BabyLINCAN_types.h.

unsigned { ... } ::unused_1

Definition at line 635 of file BabyLINCAN_types.h.

unsigned { ... } ::unused_1

Definition at line 690 of file BabyLINCAN_types.h.

unsigned { ... } ::unused_1

Definition at line 751 of file BabyLINCAN_types.h.

unsigned int ADHOC_PROTOCOL_FLAGS::unused_2

Definition at line 522 of file BabyLINCAN_types.h.

unsigned { ... } ::unused_2

Definition at line 522 of file BabyLINCAN_types.h.

unsigned { ... } ::unused_2

Definition at line 557 of file BabyLINCAN_types.h.

unsigned int ADHOC_SERVICE_FLAGS::unused_2

Definition at line 636 of file BabyLINCAN_types.h.

unsigned { ... } ::unused_2

Definition at line 636 of file BabyLINCAN_types.h.

unsigned { ... } ::unused_2

Definition at line 697 of file BabyLINCAN_types.h.

unsigned { ... } ::unused_3

Definition at line 538 of file BabyLINCAN_types.h.

unsigned int ADHOC_PROTOCOL_FLAGS::unused_3

Definition at line 538 of file BabyLINCAN_types.h.

unsigned { ... } ::unused_3

Definition at line 568 of file BabyLINCAN_types.h.

unsigned { ... } ::unused_3

Definition at line 657 of file BabyLINCAN_types.h.

unsigned int ADHOC_SERVICE_FLAGS::unused_3

Definition at line 657 of file BabyLINCAN_types.h.

unsigned { ... } ::unused_3

Definition at line 700 of file BabyLINCAN_types.h.

unsigned int ADHOC_SERVICE_FLAGS::unused_4

Definition at line 665 of file BabyLINCAN_types.h.

unsigned { ... } ::unused_4

Definition at line 665 of file BabyLINCAN_types.h.

unsigned { ... } ::unused_5

Definition at line 668 of file BabyLINCAN_types.h.

unsigned int ADHOC_SERVICE_FLAGS::unused_5

Definition at line 668 of file BabyLINCAN_types.h.

unsigned { ... } ::use_std_negresp

Definition at line 527 of file BabyLINCAN_types.h.

unsigned int ADHOC_PROTOCOL_FLAGS::use_std_negresp

Definition at line 527 of file BabyLINCAN_types.h.

unsigned { ... } ::use_std_negresp

Definition at line 561 of file BabyLINCAN_types.h.

unsigned { ... } ::use_std_negresp

Definition at line 593 of file BabyLINCAN_types.h.

unsigned { ... } ::use_std_negresp

Definition at line 662 of file BabyLINCAN_types.h.

unsigned int ADHOC_SERVICE_FLAGS::use_std_negresp

Definition at line 662 of file BabyLINCAN_types.h.

unsigned { ... } ::use_std_negresp

Definition at line 694 of file BabyLINCAN_types.h.

unsigned { ... } ::use_std_negresp

Definition at line 744 of file BabyLINCAN_types.h.

unsigned { ... } ::use_std_posresp

Definition at line 525 of file BabyLINCAN_types.h.

unsigned int ADHOC_PROTOCOL_FLAGS::use_std_posresp

Definition at line 525 of file BabyLINCAN_types.h.

unsigned { ... } ::use_std_posresp

Definition at line 559 of file BabyLINCAN_types.h.

unsigned { ... } ::use_std_posresp

Definition at line 591 of file BabyLINCAN_types.h.

unsigned int ADHOC_SERVICE_FLAGS::use_std_posresp

Definition at line 660 of file BabyLINCAN_types.h.

unsigned { ... } ::use_std_posresp

Definition at line 660 of file BabyLINCAN_types.h.

unsigned { ... } ::use_std_posresp

Definition at line 692 of file BabyLINCAN_types.h.

unsigned { ... } ::use_std_posresp

Definition at line 742 of file BabyLINCAN_types.h.

unsigned long long BLC_SIGNAL::value

Definition at line 362 of file BabyLINCAN_types.h.

unsigned int BLC_LOG::value_array_size

Definition at line 811 of file BabyLINCAN_types.h.

unsigned char BLC_LOG::value_data[4 *1024]

Definition at line 813 of file BabyLINCAN_types.h.

unsigned int BLC_LOG::value_element_size

Definition at line 809 of file BabyLINCAN_types.h.

unsigned int BLC_LOG::value_signed

Definition at line 807 of file BabyLINCAN_types.h.

unsigned short BLC_TARGETID::version

Definition at line 73 of file BabyLINCAN_types.h.

short BLC_SDFINFO::version_major

Definition at line 158 of file BabyLINCAN_types.h.

short BLC_SDFINFO::version_minor

Definition at line 158 of file BabyLINCAN_types.h.

unsigned { ... } ::xmit_can_11_29bit

Definition at line 582 of file BabyLINCAN_types.h.

unsigned int ADHOC_PROTOCOL_FLAGS::xmit_can_11_29bit

Definition at line 582 of file BabyLINCAN_types.h.

unsigned int ADHOC_PROTOCOL_FLAGS::xmit_canfd_frame

Definition at line 580 of file BabyLINCAN_types.h.

unsigned { ... } ::xmit_canfd_frame

Definition at line 580 of file BabyLINCAN_types.h.

unsigned { ... } ::xmit_canfd_switch

Definition at line 578 of file BabyLINCAN_types.h.

unsigned int ADHOC_PROTOCOL_FLAGS::xmit_canfd_switch

Definition at line 578 of file BabyLINCAN_types.h.

unsigned { ... } ::xmit_chksumtype

Definition at line 550 of file BabyLINCAN_types.h.

unsigned int ADHOC_PROTOCOL_FLAGS::xmit_chksumtype

Definition at line 550 of file BabyLINCAN_types.h.

unsigned int ADHOC_PROTOCOL_FLAGS::xmit_no_flowctrl_wait

Definition at line 611 of file BabyLINCAN_types.h.

unsigned { ... } ::xmit_no_flowctrl_wait

Definition at line 611 of file BabyLINCAN_types.h.

unsigned int ADHOC_PROTOCOL_FLAGS::xmit_shortenflowctrl

Definition at line 542 of file BabyLINCAN_types.h.

unsigned { ... } ::xmit_shortenflowctrl

Definition at line 542 of file BabyLINCAN_types.h.

unsigned { ... } ::xmit_shortenflowctrl

Definition at line 572 of file BabyLINCAN_types.h.

unsigned { ... } ::xmit_shortenflowctrl

Definition at line 615 of file BabyLINCAN_types.h.

unsigned { ... } ::xmit_shortenlcf

Definition at line 556 of file BabyLINCAN_types.h.

unsigned int ADHOC_PROTOCOL_FLAGS::xmit_shortenlcf

Definition at line 556 of file BabyLINCAN_types.h.

unsigned { ... } ::xmit_shortenlcf

Definition at line 588 of file BabyLINCAN_types.h.

unsigned { ... } ::xmit_shortensf

Definition at line 554 of file BabyLINCAN_types.h.

unsigned int ADHOC_PROTOCOL_FLAGS::xmit_shortensf

Definition at line 554 of file BabyLINCAN_types.h.

unsigned { ... } ::xmit_shortensf

Definition at line 586 of file BabyLINCAN_types.h.

Generated on Fri May 30 2025 17:16:14 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: BLC_TARGETID Struct Reference

  • Data Structure Index
Data Fields
BLC_TARGETID Struct Reference
Data Structures

Information about a connected BabyLIN device. More...

#include <BabyLINCAN_types.h>

Data Fields

unsigned short | type
Type of the hardware. More...
unsigned short | version
unsigned short | build
unsigned short | flags
Software related flags. More...
long | serial
long | heapsize
long | numofchannels
char | name [128]

Detailed Description

The structure holds information about a connected BabyLIN device retreive informations using BLC_getTargetID or request by using BLC_sendCommand with command "targetid"

Definition at line 47 of file BabyLINCAN_types.h.

The documentation for this struct was generated from the following file:
  • C:/JenkinsWS/workspace/orks_v2_LinWorksv2_Windows_trunk/source/externals/BabyLIN/src/libraries/BabyLIN/publicHeaders/BabyLINCAN_types.h
Generated on Fri May 30 2025 17:16:14 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: BLC_CHANNELINFO Struct Reference

  • Data Structure Index
Data Fields
BLC_CHANNELINFO Struct Reference
Data Structures

Information about a channel on a BabyLIN device. More...

#include <BabyLINCAN_types.h>

Data Fields

unsigned short | id
Channel-id(i.e. 0 = device channel) More...
unsigned short | type
Channel-Type(i.e. 0 = LIN, 1 = CAN, 99 = DEVICE) More...
char | name [128]
Textual name of the Channel (zero-terminated C-string) More...
long | maxbaudrate
Maximum Baudrate of Channel. More...
long | reserved1
Flags describing the State of the Channel. More...
long | reserved2
Reserved value (ignore for now) More...
long | reserved3
Reserved value (ignore for now) More...
int | associatedWithSectionNr

Detailed Description

Return data of the command 'BLC_getChannelInfo' providing information about a channel (BUS-type, speed etc.)

Definition at line 105 of file BabyLINCAN_types.h.

The documentation for this struct was generated from the following file:
  • C:/JenkinsWS/workspace/orks_v2_LinWorksv2_Windows_trunk/source/externals/BabyLIN/src/libraries/BabyLIN/publicHeaders/BabyLINCAN_types.h
Generated on Fri May 30 2025 17:16:14 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: BLC_SDFINFO Struct Reference

  • Data Structure Index
Data Fields
BLC_SDFINFO Struct Reference
Data Structures

#include <BabyLINCAN_types.h>

Data Fields

char | filename [256]
short | sectionCount
short | version_major
short | version_minor

Detailed Description

Definition at line 150 of file BabyLINCAN_types.h.

The documentation for this struct was generated from the following file:
  • C:/JenkinsWS/workspace/orks_v2_LinWorksv2_Windows_trunk/source/externals/BabyLIN/src/libraries/BabyLIN/publicHeaders/BabyLINCAN_types.h
Generated on Fri May 30 2025 17:16:14 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: BLC_SECTIONINFO Struct Reference

  • Data Structure Index
Data Fields
BLC_SECTIONINFO Struct Reference
Data Structures

#include <BabyLINCAN_types.h>

Data Fields

char | name [128]
int | type
short | nr

Detailed Description

Definition at line 162 of file BabyLINCAN_types.h.

The documentation for this struct was generated from the following file:
  • C:/JenkinsWS/workspace/orks_v2_LinWorksv2_Windows_trunk/source/externals/BabyLIN/src/libraries/BabyLIN/publicHeaders/BabyLINCAN_types.h
Generated on Fri May 30 2025 17:16:14 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: BLC_FRAME Struct Reference

  • Data Structure Index
Data Fields
BLC_FRAME Struct Reference
Data Structures

#include <BabyLINCAN_types.h>

Data Fields

unsigned long | chId
unsigned long | timestamp
long | intime
unsigned long | frameId
unsigned char | lenOfData
unsigned char | frameData [8]
short | frameFlags
Additional, informational frame flags. More...
short | busFlags
Bus specific flags. More...
unsigned char | checksum
Checksum of the frame stores a checksum V1 or V2 ( refer to busFlags which checksum type applies ) More...

Detailed Description

Definition at line 174 of file BabyLINCAN_types.h.

The documentation for this struct was generated from the following file:
  • C:/JenkinsWS/workspace/orks_v2_LinWorksv2_Windows_trunk/source/externals/BabyLIN/src/libraries/BabyLIN/publicHeaders/BabyLINCAN_types.h
Generated on Fri May 30 2025 17:16:14 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: BLC_JUMBO_FRAME Struct Reference

  • Data Structure Index
Data Fields
BLC_JUMBO_FRAME Struct Reference
Data Structures

#include <BabyLINCAN_types.h>

Data Fields

unsigned long | chId
unsigned long | timestamp
long | intime
unsigned long | frameId
unsigned int | lenOfData
unsigned char | frameData [1024]
short | frameFlags
Additional, informational frame flags. More...
short | busFlags
Bus specific flags. More...
unsigned char | checksum
checksum of the frame stores a checksum V1 or V2 ( refer to busFlags which checksum type applies ) More...

Detailed Description

Definition at line 243 of file BabyLINCAN_types.h.

The documentation for this struct was generated from the following file:
  • C:/JenkinsWS/workspace/orks_v2_LinWorksv2_Windows_trunk/source/externals/BabyLIN/src/libraries/BabyLIN/publicHeaders/BabyLINCAN_types.h
Generated on Fri May 30 2025 17:16:14 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: BLC_MACROSTATE Struct Reference

  • Data Structure Index
Data Fields
BLC_MACROSTATE Struct Reference
Data Structures

status of a macro More...

#include <BabyLINCAN_types.h>

Data Fields

int | channelid
int | macronr
Macro-number the information is about. More...
int | cmdnr
The macro command number currently executed. More...
int | state
state of the macro execution More...
unsigned long | timestamp
Timestamp of the macro state. More...

Detailed Description

Information about a macro, used as parameter of a callback function registered by BLC_registerMacroStateCallback

Definition at line 318 of file BabyLINCAN_types.h.

The documentation for this struct was generated from the following file:
  • C:/JenkinsWS/workspace/orks_v2_LinWorksv2_Windows_trunk/source/externals/BabyLIN/src/libraries/BabyLIN/publicHeaders/BabyLINCAN_types.h
Generated on Fri May 30 2025 17:16:14 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: BLC_SIGNAL Struct Reference

  • Data Structure Index
Data Fields
BLC_SIGNAL Struct Reference
Data Structures

#include <BabyLINCAN_types.h>

Data Fields

int | index
int | isArray
unsigned long long | value
int | arrayLength
unsigned char | array [8]
unsigned long | timestamp
unsigned short | chId

Detailed Description

Definition at line 356 of file BabyLINCAN_types.h.

The documentation for this struct was generated from the following file:
  • C:/JenkinsWS/workspace/orks_v2_LinWorksv2_Windows_trunk/source/externals/BabyLIN/src/libraries/BabyLIN/publicHeaders/BabyLINCAN_types.h
Generated on Fri May 30 2025 17:16:14 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: BLC_ERROR Struct Reference

  • Data Structure Index
Data Fields
BLC_ERROR Struct Reference
Data Structures

#include <BabyLINCAN_types.h>

Data Fields

unsigned long | timestamp
Time of occurence. The timestamp when the error occurred. More...
unsigned short | type
Error type. More...
unsigned short | status
Additional error information. More...

Detailed Description

Definition at line 375 of file BabyLINCAN_types.h.

The documentation for this struct was generated from the following file:
  • C:/JenkinsWS/workspace/orks_v2_LinWorksv2_Windows_trunk/source/externals/BabyLIN/src/libraries/BabyLIN/publicHeaders/BabyLINCAN_types.h
Generated on Fri May 30 2025 17:16:14 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: BLC_DTL Struct Reference

  • Data Structure Index
Data Fields
BLC_DTL Struct Reference
Data Structures

#include <BabyLINCAN_types.h>

Data Fields

BL_DTL_STATUS status
unsigned char | nad
int | length
unsigned char | data [4 *1024]

Detailed Description

Definition at line 447 of file BabyLINCAN_types.h.

The documentation for this struct was generated from the following file:
  • C:/JenkinsWS/workspace/orks_v2_LinWorksv2_Windows_trunk/source/externals/BabyLIN/src/libraries/BabyLIN/publicHeaders/BabyLINCAN_types.h
Generated on Fri May 30 2025 17:16:14 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: BLC_EVENT Struct Reference

  • Data Structure Index
Data Fields
BLC_EVENT Struct Reference
Data Structures

#include <BabyLINCAN_types.h>

Data Fields

unsigned int | timestamp
Time of occurence. The timestamp (of the device (us)) when the error occurred. More...
unsigned int | pc_timestamp
Time of occurence. The timestamp (of the PC (ms)) when the error occurred. More...
int | event
The event that occured. More...
long long | data
Additional information of an event. More...

Detailed Description

Definition at line 461 of file BabyLINCAN_types.h.

The documentation for this struct was generated from the following file:
  • C:/JenkinsWS/workspace/orks_v2_LinWorksv2_Windows_trunk/source/externals/BabyLIN/src/libraries/BabyLIN/publicHeaders/BabyLINCAN_types.h
Generated on Fri May 30 2025 17:16:14 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: ADHOC_PROTOCOL_FLAGS Union Reference

  • Data Structure Index
Data Fields
ADHOC_PROTOCOL_FLAGS Union Reference
Data Structures

#include <BabyLINCAN_types.h>

Data Fields

struct {
int ADHOC_PROTOCOL_FLAGS::protocoltype: 6
unsigned int ADHOC_PROTOCOL_FLAGS::unused_1: 5
unsigned int ADHOC_PROTOCOL_FLAGS::tx_shortensf: 1
unsigned int ADHOC_PROTOCOL_FLAGS::tx_shortenlcf: 1
unsigned int ADHOC_PROTOCOL_FLAGS::unused_2: 3
unsigned int ADHOC_PROTOCOL_FLAGS::use_std_posresp: 1
unsigned int ADHOC_PROTOCOL_FLAGS::use_std_negresp: 1
unsigned int ADHOC_PROTOCOL_FLAGS::slaveprotocol: 1
unsigned int ADHOC_PROTOCOL_FLAGS::expect_shortenedsf: 2
unsigned int ADHOC_PROTOCOL_FLAGS::expect_shortenedlcf: 2
unsigned int ADHOC_PROTOCOL_FLAGS::unused_3: 5
unsigned int ADHOC_PROTOCOL_FLAGS::accept_any_csize: 1
unsigned int ADHOC_PROTOCOL_FLAGS::xmit_shortenflowctrl: 1
} generic
struct {
unsigned int ADHOC_PROTOCOL_FLAGS::protocoltype: 6
unsigned int ADHOC_PROTOCOL_FLAGS::unused_1: 2
unsigned int ADHOC_PROTOCOL_FLAGS::xmit_chksumtype: 1
unsigned int ADHOC_PROTOCOL_FLAGS::expect_chksumtype: 2
unsigned int ADHOC_PROTOCOL_FLAGS::xmit_shortensf: 1
unsigned int ADHOC_PROTOCOL_FLAGS::xmit_shortenlcf: 1
unsigned int ADHOC_PROTOCOL_FLAGS::unused_2: 3
unsigned int ADHOC_PROTOCOL_FLAGS::use_std_posresp: 1
unsigned int ADHOC_PROTOCOL_FLAGS::use_std_negresp: 1
unsigned int ADHOC_PROTOCOL_FLAGS::slaveprotocol: 1
unsigned int ADHOC_PROTOCOL_FLAGS::expect_shortenedsf: 2
unsigned int ADHOC_PROTOCOL_FLAGS::expect_shortenedlcf: 2
unsigned int ADHOC_PROTOCOL_FLAGS::unused_3: 5
unsigned int ADHOC_PROTOCOL_FLAGS::accept_any_csize: 1
unsigned int ADHOC_PROTOCOL_FLAGS::xmit_shortenflowctrl: 1
} lin
struct {
unsigned int ADHOC_PROTOCOL_FLAGS::protocoltype: 6
unsigned int ADHOC_PROTOCOL_FLAGS::xmit_canfd_switch: 1
unsigned int ADHOC_PROTOCOL_FLAGS::xmit_canfd_frame: 1
unsigned int ADHOC_PROTOCOL_FLAGS::xmit_can_11_29bit: 1
unsigned int ADHOC_PROTOCOL_FLAGS::expect_can_11_29bit: 2
unsigned int ADHOC_PROTOCOL_FLAGS::xmit_shortensf: 1
unsigned int ADHOC_PROTOCOL_FLAGS::xmit_shortenlcf: 1
unsigned int ADHOC_PROTOCOL_FLAGS::unused_1: 3
unsigned int ADHOC_PROTOCOL_FLAGS::use_std_posresp: 1
unsigned int ADHOC_PROTOCOL_FLAGS::use_std_negresp: 1
unsigned int ADHOC_PROTOCOL_FLAGS::slaveprotocol: 1
unsigned int ADHOC_PROTOCOL_FLAGS::expect_shortenedsf: 2
unsigned int ADHOC_PROTOCOL_FLAGS::expect_shortenedlcf: 2
unsigned int ADHOC_PROTOCOL_FLAGS::expect_canfd_switch: 2
unsigned int ADHOC_PROTOCOL_FLAGS::expect_canfd_frame: 2
unsigned int ADHOC_PROTOCOL_FLAGS::xmit_no_flowctrl_wait: 1
unsigned int ADHOC_PROTOCOL_FLAGS::accept_any_csize: 1
unsigned int ADHOC_PROTOCOL_FLAGS::xmit_shortenflowctrl: 1
} can

Detailed Description

Definition at line 506 of file BabyLINCAN_types.h.

The documentation for this union was generated from the following file:
  • C:/JenkinsWS/workspace/orks_v2_LinWorksv2_Windows_trunk/source/externals/BabyLIN/src/libraries/BabyLIN/publicHeaders/BabyLINCAN_types.h
Generated on Fri May 30 2025 17:16:14 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: BLC_ADHOC_PROTOCOL Struct Reference

  • Data Structure Index
Data Fields
BLC_ADHOC_PROTOCOL Struct Reference
Data Structures

#include <BabyLINCAN_types.h>

Data Fields

const char * | name
ADHOC_PROTOCOL_FLAGS flags
unsigned char | active
int | req_slot_time
int | rsp_slot_time
int | rsp_delay
unsigned char | fill_byte

Detailed Description

Definition at line 621 of file BabyLINCAN_types.h.

The documentation for this struct was generated from the following file:
  • C:/JenkinsWS/workspace/orks_v2_LinWorksv2_Windows_trunk/source/externals/BabyLIN/src/libraries/BabyLIN/publicHeaders/BabyLINCAN_types.h
Generated on Fri May 30 2025 17:16:14 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: ADHOC_SERVICE_FLAGS Union Reference

  • Data Structure Index
Data Fields
ADHOC_SERVICE_FLAGS Union Reference
Data Structures

#include <BabyLINCAN_types.h>

Data Fields

struct {
unsigned int ADHOC_SERVICE_FLAGS::unused_1: 2
unsigned int ADHOC_SERVICE_FLAGS::unused_2: 2
unsigned int ADHOC_SERVICE_FLAGS::shortensf_txd: 2
unsigned int ADHOC_SERVICE_FLAGS::shortensf_rcv: 2
unsigned int ADHOC_SERVICE_FLAGS::shortenlcf_txd: 2
unsigned int ADHOC_SERVICE_FLAGS::shortenlcf_rcv: 2
unsigned int ADHOC_SERVICE_FLAGS::unused_3: 8
unsigned int ADHOC_SERVICE_FLAGS::use_std_posresp: 2
unsigned int ADHOC_SERVICE_FLAGS::use_std_negresp: 2
unsigned int ADHOC_SERVICE_FLAGS::requestonly: 1
unsigned int ADHOC_SERVICE_FLAGS::unused_4: 2
unsigned int ADHOC_SERVICE_FLAGS::accept_any_csize: 2
unsigned int ADHOC_SERVICE_FLAGS::unused_5: 3
} generic
struct {
unsigned int ADHOC_SERVICE_FLAGS::checksum_txd: 2
unsigned int ADHOC_SERVICE_FLAGS::checksum_rcv: 2
unsigned int ADHOC_SERVICE_FLAGS::shortensf_txd: 2
unsigned int ADHOC_SERVICE_FLAGS::shortensf_rcv: 2
unsigned int ADHOC_SERVICE_FLAGS::shortenlcf_txd: 2
unsigned int ADHOC_SERVICE_FLAGS::shortenlcf_rcv: 2
unsigned int ADHOC_SERVICE_FLAGS::unused_1: 8
unsigned int ADHOC_SERVICE_FLAGS::use_std_posresp: 2
unsigned int ADHOC_SERVICE_FLAGS::use_std_negresp: 2
unsigned int ADHOC_SERVICE_FLAGS::requestonly: 1
unsigned int ADHOC_SERVICE_FLAGS::unused_2: 2
unsigned int ADHOC_SERVICE_FLAGS::accept_any_csize: 2
unsigned int ADHOC_SERVICE_FLAGS::unused_3: 3
} lin
struct {
unsigned int ADHOC_SERVICE_FLAGS::id_11_29_txd: 2
unsigned int ADHOC_SERVICE_FLAGS::id_11_29_rcv: 2
unsigned int ADHOC_SERVICE_FLAGS::shortensf_txd: 2
unsigned int ADHOC_SERVICE_FLAGS::shortensf_rcv: 2
unsigned int ADHOC_SERVICE_FLAGS::shortenlcf_txd: 2
unsigned int ADHOC_SERVICE_FLAGS::shortenlcf_rcv: 2
unsigned int ADHOC_SERVICE_FLAGS::fdbaudswitch_txd: 2
unsigned int ADHOC_SERVICE_FLAGS::fdbaudswitch_rcv: 2
unsigned int ADHOC_SERVICE_FLAGS::fdframe_txd: 2
unsigned int ADHOC_SERVICE_FLAGS::fdframe_rcv: 2
unsigned int ADHOC_SERVICE_FLAGS::use_std_posresp: 2
unsigned int ADHOC_SERVICE_FLAGS::use_std_negresp: 2
unsigned int ADHOC_SERVICE_FLAGS::requestonly: 1
unsigned int ADHOC_SERVICE_FLAGS::no_flowctrl_wait: 2
unsigned int ADHOC_SERVICE_FLAGS::accept_any_csize: 2
unsigned int ADHOC_SERVICE_FLAGS::unused_1: 3
} can

Detailed Description

Definition at line 633 of file BabyLINCAN_types.h.

The documentation for this union was generated from the following file:
  • C:/JenkinsWS/workspace/orks_v2_LinWorksv2_Windows_trunk/source/externals/BabyLIN/src/libraries/BabyLIN/publicHeaders/BabyLINCAN_types.h
Generated on Fri May 30 2025 17:16:14 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: BLC_ADHOC_SERVICE Struct Reference

  • Data Structure Index
Data Fields
BLC_ADHOC_SERVICE Struct Reference
Data Structures

#include <BabyLINCAN_types.h>

Data Fields

const char * | name
ADHOC_SERVICE_FLAGS flags
int | req_frame_id
long long | req_container_size
long long | req_payload_size
int | req_slot_time
int | rsp_frame_id
long long | rsp_container_size
long long | rsp_payload_size
int | rsp_slot_time
int | rsp_delay

Detailed Description

Definition at line 756 of file BabyLINCAN_types.h.

The documentation for this struct was generated from the following file:
  • C:/JenkinsWS/workspace/orks_v2_LinWorksv2_Windows_trunk/source/externals/BabyLIN/src/libraries/BabyLIN/publicHeaders/BabyLINCAN_types.h
Generated on Fri May 30 2025 17:16:14 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: BLC_ADHOC_EXECUTE Struct Reference

  • Data Structure Index
Data Fields
BLC_ADHOC_EXECUTE Struct Reference
Data Structures

#include <BabyLINCAN_types.h>

Data Fields

int | nad
int | p2_extended
int | flow_control_st_min
int | flow_control_block_size

Detailed Description

Definition at line 772 of file BabyLINCAN_types.h.

The documentation for this struct was generated from the following file:
  • C:/JenkinsWS/workspace/orks_v2_LinWorksv2_Windows_trunk/source/externals/BabyLIN/src/libraries/BabyLIN/publicHeaders/BabyLINCAN_types.h
Generated on Fri May 30 2025 17:16:14 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: BLC_LOG Struct Reference

  • Data Structure Index
Data Fields
BLC_LOG Struct Reference
Data Structures

#include <BabyLINCAN_types.h>

Data Fields

int | format_version
unsigned int | source_type
union {
struct {
int BLC_LOG::id
int BLC_LOG::signal_index
} BLC_LOG::channel
struct {
int BLC_LOG::id
int BLC_LOG::sub_index
} BLC_LOG::group
} source
unsigned long long | timestamp_unix
unsigned long | timestamp_usec
unsigned int | value_signed
unsigned int | value_element_size
unsigned int | value_array_size
unsigned char | value_data [4 *1024]

Detailed Description

Definition at line 780 of file BabyLINCAN_types.h.

The documentation for this struct was generated from the following file:
  • C:/JenkinsWS/workspace/orks_v2_LinWorksv2_Windows_trunk/source/externals/BabyLIN/src/libraries/BabyLIN/publicHeaders/BabyLINCAN_types.h
Generated on Fri May 30 2025 17:16:14 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: Pull Functions

Functions
Pull Functions

Detailed Description

The following functions are used to get data which has been received from a BabyLIN-device. This approach uses the pull method, i.e. you will not get any information pushed ( see Callback Handling ) when it's received. Instead you have to call these functions whenever you want to get retrieved data.

Functions

int BL_DLLIMPORT | BLC_getLastFrame (BL_HANDLE handle, int frameNr, BLC_FRAME *framedata)
Retrieve the last framedata available for a frame. More...
int BL_DLLIMPORT | BLC_getNextFrame (BL_HANDLE handle, BLC_FRAME *framedata)
Fetches the next frame on Channel from the receiver queue. More...
int BL_DLLIMPORT | BLC_getNextFrames (BL_HANDLE handle, BLC_FRAME *framedata, int *size)
Fetches the next frames on channel from the receiver queue. More...
int BL_DLLIMPORT | BLC_getNextFrameTimeout (BL_HANDLE handle, BLC_FRAME *framedata, int timeout_ms)
Fetches the next frame on Channel from the receiver queue with wait-timeout. More...
int BL_DLLIMPORT | BLC_getNextFramesTimeout (BL_HANDLE handle, BLC_FRAME *framedata, int timeout_ms, int *size)
Fetches the next frames on channel from the receiver queue with wait-timeout. More...
int BL_DLLIMPORT | BLC_getNextJumboFrame (BL_HANDLE handle, BLC_JUMBO_FRAME *framedata)
Fetches the next regular or jumbo frame on Channel from the receiver queue. More...
int BL_DLLIMPORT | BLC_getNextJumboFrames (BL_HANDLE handle, BLC_JUMBO_FRAME *framedata, int *size)
Fetches the next regular or jumbo frames on channel from the receiver queue. More...
int BL_DLLIMPORT | BLC_getNextJumboFrameTimeout (BL_HANDLE handle, BLC_JUMBO_FRAME *framedata, int timeout_ms)
Fetches the next regular or jumbo frame on Channel from the receiver queue with wait-timeout. More...
int BL_DLLIMPORT | BLC_getNextJumboFramesTimeout (BL_HANDLE handle, BLC_JUMBO_FRAME *framedata, int timeout_ms, int *size)
Fetches the next regular or jumbo frames on channel from the receiver queue with wait-timeout. More...
int BL_DLLIMPORT | BLC_getNextSignal (BL_HANDLE handle, BLC_SIGNAL *signaldata)
Fetches the next signal from the receiver queue. More...
int BL_DLLIMPORT | BLC_getNextSignals (BL_HANDLE handle, BLC_SIGNAL *signaldata, int *size)
Fetches the next signals from the receiver queue. More...
int BL_DLLIMPORT | BLC_getNextSignalsForNumber (BL_HANDLE handle, BLC_SIGNAL *signaldata, int size, int signalNumber)
Fetches the next signals for a specific signal from the receiver queue. More...
int BL_DLLIMPORT | BLC_getNextBusError (BL_HANDLE handle, BLC_ERROR *errordata)
Fetches the next Bus error from the receiver queue. More...
int BL_DLLIMPORT | BLC_getNextDTLRequest (BL_HANDLE handle, BLC_DTL *frame)
Fetches the next complete DTL request from the receiver queue. More...
int BL_DLLIMPORT | BLC_getNextDTLResponse (BL_HANDLE handle, BLC_DTL *frame)
Fetches the next complete DTL response from the receiver queue. More...
int BL_DLLIMPORT | BLC_getSignalValue (BL_HANDLE handle, int signalNr, unsigned long long *value)
Return the current signal value (for non-array signals). More...
int BL_DLLIMPORT | BLC_getSignalValueWithTimestamp (BL_HANDLE handle, int signalNr, unsigned long long *value, unsigned long long *timestamp)
Return the current signal value (for non-array signals) with timestamp. More...
int BL_DLLIMPORT | BLC_getSignalValueByName (BL_HANDLE handle, const char *signalName, unsigned long long *value)
Returns the current signal value (for non-array signals). More...
int BL_DLLIMPORT | BLC_getSignalArray (BL_HANDLE handle, int signalNr, unsigned char *array)
Returns the current signal value (for array signals). More...
int BL_DLLIMPORT | BLC_getSignalArrayWithTimestamp (BL_HANDLE handle, int signalNr, unsigned char *array, unsigned long long *timestamp)
Returns the current signal value (for array signals) with timstamp. More...
int BL_DLLIMPORT | BLC_getSignalArrayByName (BL_HANDLE handle, const char *signalName, unsigned char *array)
Returns the current signal value (for array signals). More...
int BL_DLLIMPORT | BLC_isSignalArray (BL_HANDLE handle, int idx)
Returns the type of a signal. More...
int BL_DLLIMPORT | BLC_encodeSignal (BL_HANDLE handle, int signalNr, unsigned long long value, char *encSignal, size_t *buffLen0, char *encUnit, size_t *buffLen1)
Encodes the signal's value as defined in the corresponding Signal Encoding tables of LDF/SDF. More...
int BL_DLLIMPORT | BLC_decodeSignal (BL_HANDLE handle, int signalNr, char *encSignal, int64_t *value)
BLC_decodeSignal takes an encoded Signal value and tries to compute it back to its Signal value. Rounding errors might occur for large signals or encoding scales and offsets. More...
int BL_DLLIMPORT | BLC_getSignalsInFrame (BL_HANDLE handle, int frameNr, BLC_SIGNAL *signalList, int signalListLen)
Get values of all signals mapped to a frame. More...
int BL_DLLIMPORT | BLC_getFrameDetails (BL_HANDLE handle, int idx, int *pbusid, int *psize, int *pnodenum, int *pframetype)
Returns some details for given frame entry. More...
int BL_DLLIMPORT | BLC_getNodeForSignal (BL_HANDLE handle, int signalNr)
Returns some details for given frame entry. More...

Function Documentation

int BL_DLLIMPORT BLC_decodeSignal | ( | BL_HANDLE | handle,
 |  | int | signalNr,
 |  | char * | encSignal,
 |  | int64_t * | value
 | ) |  |
Parameters
[in] | handle | The Channel handle the Signal does come from.
signalNr | The number of the Signal that has the encodings.
[out] | encSignal | The encoded signal value as a c-string(zero terminated).
[out] | value | The reverted value. rounding errors might occur.
Returns
BL_OK if the value could be converted, != 0 otherwise.
int BL_DLLIMPORT BLC_encodeSignal | ( | BL_HANDLE | handle,
 |  | int | signalNr,
 |  | unsigned long long | value,
 |  | char * | encSignal,
 |  | size_t * | buffLen0,
 |  | char * | encUnit,
 |  | size_t * | buffLen1
 | ) |  |

If no SignalEncoding is specified for this signal, the value itself is written into destination buffer 'description'. If one of the required pointers is NULL or the buffer size is too small, the function returns the needed minimum buffer length in 'length'. It's possible to use two variants to get encoded signal: 1) pointer 'encUnit' and 'buffLen1' set to NULL: then encoded signal saved inclusive unit in buffer 'encSignal' 2) pointer 'encUnit' and 'buffLen1' != NULL: unit of signal saved separately in buffer 'encUnit'

Parameters
[in] | handle | Handle representing the channel to which the signal belongs (see BLC_getChannelHandle )
signalNr | Number (Index) of the signal accordng to SDF.
value | Value to be encoded
[out] | encSignal | Points to save location of encoded signal value (inclusive 'unit', if 'encUnit' not used)
[in,out] | buffLen0 | Input the allocated length of 'encSignal' buffer. Output the length of the written data.
[out] | encUnit | Optional: points to save location of signal unit (if this pointer is NULL then 'unit' saved in 'encSignal' buffer also)
[in,out] | buffLen1 | Optional: Input the allocated length of 'encUnit' buffer (if this pointer is NULL then 'unit' saved in 'encSignal' buffer also). Output the length of the written data.
Returns
Status of operation; '=0' means successful, '!=0' otherwise. See standard return values for error, or for textual representation (for return values < -1000) BLC_getLastError.
int BL_DLLIMPORT BLC_getFrameDetails | ( | BL_HANDLE | handle,
 |  | int | idx,
 |  | int * | pbusid,
 |  | int * | psize,
 |  | int * | pnodenum,
 |  | int * | pframetype
 | ) |  |
Parameters
[in] | handle | Handle representing the channel to which the frame belongs (see BLC_getChannelHandle )
idx | Zero based index of requested frame entry (sdf number).
[out] | pbusid | Pointer to int, which gets filled with BUS ID (without parity bits on LIN-Bus)
[out] | psize | Pointer to int, which gets filled with size of frame in bytes
[out] | pnodenum | Pointer to int, which gets filled with nodeindex of publishing node for this frame
[out] | pframetype | Pointer to int, which gets filled with LIN version of this frame (LIN channel only)
int BL_DLLIMPORT BLC_getLastFrame | ( | BL_HANDLE | handle,
 |  | int | frameNr,
 |  | BLC_FRAME * | framedata
 | ) |  |
Attention
The Baby-LIN fills the receiver queue only if command "disframe" or "mon_on" is sent before ( see BabyLIN commands to use in BL_- and BLC_sendCommand Functions )
Parameters
[in] | handle | Handle representing the channel to get the frame data from (see BLC_getChannelHandle )
frameNr | Zero based index of requested frame entry.
[out] | framedata | Pointer to a pre-allocated BLC_FRAME structure.
Returns
Status of operation; '=0' means successful, '!=0' otherwise. See standard return values for error, or for textual representation (for return values < -1000) BLC_getLastError.
int BL_DLLIMPORT BLC_getNextBusError | ( | BL_HANDLE | handle,
 |  | BLC_ERROR * | errordata
 | ) |  |
Parameters
[in] | handle | Handle representing the channel to get the error data from (see BLC_getChannelHandle )
[out] | errordata | Pointer to a pre-allocated BLC_ERROR structure.
Returns
Status of operation; '=0' means successful, '!=0' otherwise. See standard return values for error, or for textual representation (for return values < -1000) BLC_getLastError.
int BL_DLLIMPORT BLC_getNextDTLRequest | ( | BL_HANDLE | handle,
 |  | BLC_DTL * | frame
 | ) |  |
Parameters
[in] | handle | Handle representing the channel to get the dtl data from (see BLC_getChannelHandle )
[out] | frame | Pointer to a pre-allocated BLC_DTL structure.
Returns
Status of operation; '=0' means successful, '!=0' otherwise. See standard return values for error, or for textual representation (for return values < -1000) BLC_getLastError.
int BL_DLLIMPORT BLC_getNextDTLResponse | ( | BL_HANDLE | handle,
 |  | BLC_DTL * | frame
 | ) |  |
Parameters
[in] | handle | Handle representing the channel to get the dtl data from (see BLC_getChannelHandle )
[out] | frame | Pointer to a pre-allocated BLC_DTL structure.
Returns
Status of operation; '=0' means successful, '!=0' otherwise. See standard return values for error, or for textual representation (for return values < -1000) BLC_getLastError.
int BL_DLLIMPORT BLC_getNextFrame | ( | BL_HANDLE | handle,
 |  | BLC_FRAME * | framedata
 | ) |  |
Attention
The Device fills the receiver queue only if command "disframe" or "mon_on" is sent before.
Parameters
[in] | handle | Handle representing the channel to get the frame data from (see BLC_getChannelHandle )
[out] | framedata | Pointer to a pre-allocated BLC_FRAME structure.
Returns
Status of operation; '=0' means successful, '!=0' otherwise. See standard return values for error, or for textual representation (for return values < -1000) BLC_getLastError.
int BL_DLLIMPORT BLC_getNextFrames | ( | BL_HANDLE | handle,
 |  | BLC_FRAME * | framedata,
 |  | int * | size
 | ) |  |
Attention
The device fills the receiver queue only if command "disframe" sent before.
Parameters
[in] | handle | Handle representing the channel to get the frame data from (see BLC_getChannelHandle )
[out] | framedata | Pointer to a pre-allocated BLC_FRAME (structure) array.
[in,out] | size | Input size of the preallocated BLC_FRAME array, which must be a positive value. On output, the actual number of retrieved BLC_FRAMEs, which might be less than *size on input.
Returns
Status of operation; '=0' means successful, '!=0' otherwise. See standard return values for error, or for textual representation (for return values < -1000) BLC_getLastError.
int BL_DLLIMPORT BLC_getNextFramesTimeout | ( | BL_HANDLE | handle,
 |  | BLC_FRAME * | framedata,
 |  | int | timeout_ms,
 |  | int * | size
 | ) |  |

Retrieves the next frames received from the BabyLIN. If no frame-data is available, the funktion will wait up to timeout_ms milliseconds for new data before it returns with a BL_TIMEOUT returncode

Attention
The Device fills the receiver queue only if command "disframe" or "mon_on" is sent before.
Parameters
[in] | handle | Handle representing the channel to get the frame data from (see BLC_getChannelHandle )
[out] | framedata | Pointer to a pre-allocated BLC_FRAME structure.
timeout_ms | Timeout to wait for new framedata
[in,out] | size | Input size of the preallocated BLC_FRAME array, which must be a positive value. On output, the actual number of retrieved BLC_FRAMEs, which might be less than *size on input.
Returns
Status of operation; '=0' means successful, '!=0' otherwise. See standard return values for error, or for textual representation (for return values < -1000) BLC_getLastError.
int BL_DLLIMPORT BLC_getNextFrameTimeout | ( | BL_HANDLE | handle,
 |  | BLC_FRAME * | framedata,
 |  | int | timeout_ms
 | ) |  |

Retrieves the next frame received from the BabyLIN. If no frame-data is available, the funktion will wait up to timeout_ms milliseconds for new data before it returns with a BL_TIMEOUT returncode

Attention
The Device fills the receiver queue only if command "disframe" or "mon_on" is sent before.
Parameters
[in] | handle | Handle representing the channel to get the frame data from (see BLC_getChannelHandle )
[out] | framedata | Pointer to a pre-allocated BLC_FRAME structure.
timeout_ms | Timeout to wait for new framedata
Returns
Status of operation; '=0' means successful, '!=0' otherwise. See standard return values for error, or for textual representation (for return values < -1000) BLC_getLastError.
int BL_DLLIMPORT BLC_getNextJumboFrame | ( | BL_HANDLE | handle,
 |  | BLC_JUMBO_FRAME * | framedata
 | ) |  |
Attention
The Device fills the receiver queue only if command "disframe" or "mon_on" is sent before.
Parameters
[in] | handle | Handle representing the channel to get the jumbo frame data from (see BLC_getChannelHandle )
[out] | framedata | Pointer to a pre-allocated BLC_JUMBO_FRAME structure.
Returns
Status of operation; '=0' means successful, '!=0' otherwise. See standard return values for error, or for textual representation (for return values < -1000) BLC_getLastError.
int BL_DLLIMPORT BLC_getNextJumboFrames | ( | BL_HANDLE | handle,
 |  | BLC_JUMBO_FRAME * | framedata,
 |  | int * | size
 | ) |  |
Attention
The device fills the receiver queue only if command "disframe" sent before.
Parameters
[in] | handle | Handle representing the channel to get the frame data from (see BLC_getChannelHandle )
[out] | framedata | Pointer to a pre-allocated BLC_JUMBO_FRAME (structure) array.
[in,out] | size | Input size of the preallocated BLC_FRAME array, which must be a positive value. On output, the actual number of retrieved BLC_JUMBO_FRAMEs, which might be less than *size on input.
Returns
Status of operation; '=0' means successful, '!=0' otherwise. See standard return values for error, or for textual representation (for return values < -1000) BLC_getLastError.
int BL_DLLIMPORT BLC_getNextJumboFramesTimeout | ( | BL_HANDLE | handle,
 |  | BLC_JUMBO_FRAME * | framedata,
 |  | int | timeout_ms,
 |  | int * | size
 | ) |  |

Retrieves the next jumbo frames received from the BabyLIN. If no frame-data is available, the function will wait up to timeout_ms milliseconds for new data before it returns with a BL_TIMEOUT returncode

Attention
The Device fills the receiver queue only if command "disframe" or "mon_on" is sent before.
Parameters
[in] | handle | Handle representing the channel to get the jumbo frame data from (see BLC_getChannelHandle )
[out] | framedata | Pointer to a pre-allocated BLC_JUMBO_FRAME structure.
timeout_ms | Timeout to wait for new framedata
[in,out] | size | Input size of the preallocated BLC_FRAME array, which must be a positive value. On output, the actual number of retrieved BLC_JUMBO_FRAMEs, which might be less than *size on input.
Returns
Status of operation; '=0' means successful, '!=0' otherwise. See standard return values for error, or for textual representation (for return values < -1000) BLC_getLastError.
int BL_DLLIMPORT BLC_getNextJumboFrameTimeout | ( | BL_HANDLE | handle,
 |  | BLC_JUMBO_FRAME * | framedata,
 |  | int | timeout_ms
 | ) |  |

Retrieves the next jumbo frame received from the BabyLIN. If no frame-data is available, the function will wait up to timeout_ms milliseconds for new data before it returns with a BL_TIMEOUT returncode

Attention
The Device fills the receiver queue only if command "disframe" or "mon_on" is sent before.
Parameters
[in] | handle | Handle representing the channel to get the jumbo frame data from (see BLC_getChannelHandle )
[out] | framedata | Pointer to a pre-allocated BLC_JUMBO_FRAME structure.
timeout_ms | Timeout to wait for new framedata
Returns
Status of operation; '=0' means successful, '!=0' otherwise. See standard return values for error, or for textual representation (for return values < -1000) BLC_getLastError.
int BL_DLLIMPORT BLC_getNextSignal | ( | BL_HANDLE | handle,
 |  | BLC_SIGNAL * | signaldata
 | ) |  |
Attention
The Baby-LIN fills the receiver queue only if command "dissignal" sent before.
Parameters
[in] | handle | Handle representing the channel to get the signal data from (see BLC_getChannelHandle )
[out] | signaldata | Pointer to a pre-allocated BLC_SIGNAL structure.
Returns
Status of operation; '=0' means successful, '!=0' otherwise. See standard return values for error, or for textual representation (for return values < -1000) BLC_getLastError.
int BL_DLLIMPORT BLC_getNextSignals | ( | BL_HANDLE | handle,
 |  | BLC_SIGNAL * | signaldata,
 |  | int * | size
 | ) |  |
Attention
The Baby-LIN fills the receiver queue only if command "dissignal" sent before.
Parameters
[in] | handle | Handle representing the channel to get the signal data from (see BLC_getChannelHandle )
[out] | signaldata | Pointer to a pre-allocated BLC_SIGNAL (structure) array.
[in,out] | size | Input size of the preallocated BLC_SIGNAL array, which must be a positive value. On output, the actual number of retrieved BLC_SIGNALs, which might be less than *size on input.
Returns
Status of operation; '=0' means successful, '!=' otherwise. See standard return values for error, or for textual representation (for return values < -1000) BLC_getLastError.
int BL_DLLIMPORT BLC_getNextSignalsForNumber | ( | BL_HANDLE | handle,
 |  | BLC_SIGNAL * | signaldata,
 |  | int | size,
 |  | int | signalNumber
 | ) |  |
Attention
The Baby-LIN fills the receiver queue only if command "dissignal" sent before.
This function will remove the signal values from the queue. Further signal receiving is no longer guaranteed to be in order.
Parameters
[in] | handle | Handle representing the channel to get the signal data from (see BLC_getChannelHandle )
[in] | signaldata | Pointer to a pre-allocated BLC_SIGNAL (structure) array.
size | Size of the pre-allocated BLC_SIGNAL array, in units of BLC_SIGNAL, which must be a positive value.
signalNumber | The signal number to get the signals for
Returns
Number of signals found, '<0' on error. See standard return values for error, or for textual representation (for return values < -1000) BLC_getLastError.
int BL_DLLIMPORT BLC_getNodeForSignal | ( | BL_HANDLE | handle,
 |  | int | signalNr
 | ) |  |
Parameters
[in] | handle | Handle representing the channel to which the signal belongs (see BLC_getChannelHandle )
signalNr | Zero based index of the signal entry (sdf number).
Returns
The number of the node the signal is published by. -1 if signal is virtual. Values <-1 on error. See standard return values for error, or for textual representation (for return values < -1000) BLC_getLastError.
int BL_DLLIMPORT BLC_getSignalArray | ( | BL_HANDLE | handle,
 |  | int | signalNr,
 |  | unsigned char * | array
 | ) |  |
Attention
The Baby-LIN reports the signal value only if command "dissignal" sent before.
Note
Special signalNr '-1' returns always the hex array { 0x01, 0x23, 0x45, 0x67, 0x89, 0xab, 0xcd, 0xef } in *array; signalNr '-2' returns a counted sequence, where the byte 0 holds the actual counter and the following bytes hold the 'history'; i.e.:
1st call: { 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00 }
2nd call: { 0x01, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00 }
3rd call: { 0x02, 0x01, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00 }
4th call: { 0x03, 0x02, 0x01, 0x00, 0x00, 0x00, 0x00, 0x00 }
...etc...
Parameters
[in] | handle | Handle representing the channel to get the signal value from (see BLC_getChannelHandle )
signalNr | Number of the signal accordng to SDF.
[out] | array | Pointer to an 8 byte array getting the value. It must always have the size of 8 bytes, even for smaller array signals!
Returns
Status of operation; '=0' means successful, '!=0' otherwise. See standard return values for error, or for textual representation (for return values < -1000) BLC_getLastError.
int BL_DLLIMPORT BLC_getSignalArrayByName | ( | BL_HANDLE | handle,
 |  | const char * | signalName,
 |  | unsigned char * | array
 | ) |  |
Attention
The Baby-LIN reports the signal value only if command "dissignal" sent before.
Parameters
[in] | handle | Handle representing the channel to get the signal value from (see BLC_getChannelHandle )
[in] | signalName | Name of the Signal as declared in LDF.
[out] | array | Pointer to an 8 byte array getting the value. It must always have the size of 8 bytes, even for smaller array signals!
Returns
Status of operation; '=0' means successful, '!=0' otherwise. See standard return values for error, or for textual representation (for return values < -1000) BLC_getLastError.
int BL_DLLIMPORT BLC_getSignalArrayWithTimestamp | ( | BL_HANDLE | handle,
 |  | int | signalNr,
 |  | unsigned char * | array,
 |  | unsigned long long * | timestamp
 | ) |  |
Attention
The Baby-LIN reports the signal value only if command "dissignal" sent before.
Note
Special signalNr '-1' returns always the hex array { 0x01, 0x23, 0x45, 0x67, 0x89, 0xab, 0xcd, 0xef } in *array; signalNr '-2' returns a counted sequence, where the byte 0 holds the actual counter and the following bytes hold the 'history'; i.e.:
1st call: { 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00 }
2nd call: { 0x01, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00 }
3rd call: { 0x02, 0x01, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00 }
4th call: { 0x03, 0x02, 0x01, 0x00, 0x00, 0x00, 0x00, 0x00 }
...etc...
Parameters
[in] | handle | Handle representing the channel to get the signal value from (see BLC_getChannelHandle )
signalNr | Number of the signal accordng to SDF.
[out] | array | Pointer to an 8 byte array getting the value. It must always have the size of 8 bytes, even for smaller array signals!
[out] | timestamp | Pointer to an word-sized variable getting the timestamp when the signal was received (PC-Timestamp (ms).
Returns
Status of operation; '=0' means successful, '!=0' otherwise. See standard return values for error, or for textual representation (for return values < -1000) BLC_getLastError.
int BL_DLLIMPORT BLC_getSignalsInFrame | ( | BL_HANDLE | handle,
 |  | int | frameNr,
 |  | BLC_SIGNAL * | signalList,
 |  | int | signalListLen
 | ) |  |
Parameters
[in] | handle | Handle representing the channel to which the frame belongs (see BLC_getChannelHandle )
frameNr | Frame number (according to SDF) to get the signal data from
[out] | signalList | Pre-allocated array of BLC_SIGNAL structures to store the signal data to
signalListLen | Length of the pre-allocated array of BLC_SIGNAL structures
Returns
The number of signals stored to signalList. Values <0 on error. See standard return values for error, or for textual representation (for return values < -1000) BLC_getLastError.
int BL_DLLIMPORT BLC_getSignalValue | ( | BL_HANDLE | handle,
 |  | int | signalNr,
 |  | unsigned long long * | value
 | ) |  |
Attention
The Baby-LIN reports the signal value only if command "dissignal" sent before.
Note
Special signalNr '-1' returns always 4711 in *value; signalNr '-2' returns a counter increased by 1 after every call.
Parameters
[in] | handle | Handle representing the channel to get the signal value from (see BLC_getChannelHandle )
signalNr | Number of the signal according to SDF.
[out] | value | Pointer to an word-sized variable getting the value.
Returns
Status of operation; '=0' means successful, '!=0' otherwise. See standard return values for error, or for textual representation (for return values < -1000) BLC_getLastError.
int BL_DLLIMPORT BLC_getSignalValueByName | ( | BL_HANDLE | handle,
 |  | const char * | signalName,
 |  | unsigned long long * | value
 | ) |  |
Attention
The Baby-LIN reports the signal value only if command "dissignal" sent before.
Parameters
[in] | handle | Handle representing the channel to get the signal value from (see BLC_getChannelHandle )
[in] | signalName | Name of the Signal as declared in LDF.
[out] | value | Pointer to an word-sized variable getting the value.
Returns
Status of operation; '=0' means successful, '!=0' otherwise. See standard return values for error, or for textual representation (for return values < -1000) BLC_getLastError.
int BL_DLLIMPORT BLC_getSignalValueWithTimestamp | ( | BL_HANDLE | handle,
 |  | int | signalNr,
 |  | unsigned long long * | value,
 |  | unsigned long long * | timestamp
 | ) |  |
Attention
The Baby-LIN reports the signal value only if command "dissignal" sent before.
Note
Special signalNr '-1' returns always 4711 in *value; signalNr '-2' returns a counter increased by 1 after every call.
Parameters
[in] | handle | Handle representing the channel to get the signal value from (see BLC_getChannelHandle )
signalNr | Number of the signal according to SDF.
[out] | value | Pointer to an word-sized variable getting the value.
[out] | timestamp | Pointer to an word-sized variable getting the timestamp when the signal was received (PC-Timestamp (ms)).
Returns
Status of operation; '=0' means successful, '!=0' otherwise. See standard return values for error, or for textual representation (for return values < -1000) BLC_getLastError.
int BL_DLLIMPORT BLC_isSignalArray | ( | BL_HANDLE | handle,
 |  | int | idx
 | ) |  |
Parameters
[in] | handle | Handle representing the channel to which the signal belongs (see BLC_getChannelHandle )
idx | Zero based index of requested signal entry.
Returns
Status of operation; Signal is Array == 1; Signal is scalar Value == 0. Values <0 on error. See standard return values for error, or for textual representation (for return values < -1000) BLC_getLastError.
Generated on Fri May 30 2025 17:16:14 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: SDF Handling

Functions
SDF Handling

Detailed Description

The following functions are used to retrieve information about the elements in a loaded SDF-file.

Functions

int BL_DLLIMPORT | BLC_loadSDF (BL_HANDLE handle, const char *filename, int download)
Loads the specified SDF-file into library and optionally the BabyLIN device. More...
int BL_DLLIMPORT | BLC_loadLDF (BL_HANDLE handle, const char *filename, int download)
Loads the specified LDFile into library and optionally the BabyLIN device. More...
int BL_DLLIMPORT | BLC_downloadSDF (BL_HANDLE handle, int mode)
Loads the previously loaded SDF-file into the BabyLIN device. More...
int BL_DLLIMPORT | BLC_isSDFOnDevice (BL_HANDLE handle, const char *filename)
Checks whether the given file is already loaded on a device. More...
int BL_DLLIMPORT | BLC_getSDFInfo (BL_HANDLE handle, BLC_SDFINFO *pSDFInfo)
Retrieve further Information about a loaded SDF. More...
int BL_DLLIMPORT | BLC_getSectionInfo (BL_HANDLE handle, int infoAboutSectionNr, BLC_SECTIONINFO *pSectionInfo)
Retrieve informations about a SDF-Section from a loaded SDF. More...
CPCHAR BL_DLLIMPORT | BLC_getChannelSectionDescription (BL_HANDLE handle)
Retrieve description string of a SDF-Section from a loaded SDF. More...
int BL_DLLIMPORT | BLC_getNodeCount (BL_HANDLE handle)
Returns the number of nodes on the BUS. More...
int BL_DLLIMPORT | BLC_getNodeName (BL_HANDLE handle, int idx, char *dstbuf, int buflen)
Returns the name of a given node. More...
int BL_DLLIMPORT | BLC_getFrameCount (BL_HANDLE handle)
Returns the number of frames of the BUS description. More...
int BL_DLLIMPORT | BLC_getFrameName (BL_HANDLE handle, int idx, char *dstbuf, int buflen)
Returns the name of a given frame. More...
int BL_DLLIMPORT | BLC_getSignalCount (BL_HANDLE handle)
Returns the number of signals. More...
int BL_DLLIMPORT | BLC_getSignalName (BL_HANDLE handle, int idx, char *dstbuf, int buflen)
Returns the name of given signal. More...
int BL_DLLIMPORT | BLC_isSignalEmulated (BL_HANDLE handle, int idx)
Retrieve information about wheather a signal is emulated by the BabyLIN-Device or not. More...
int BL_DLLIMPORT | BLC_getSignalSize (BL_HANDLE handle, int idx)
Retrieve size of a signal. More...
int BL_DLLIMPORT | BLC_getSignalsInFrameCount (BL_HANDLE handle, int idx)
Retrieve the number of signals mapped in a frame. More...
int BL_DLLIMPORT | BLC_getSignalInFrame (BL_HANDLE handle, int frameIndex, int signalIndex)
Retrieve the signal number of a signal mapped in a frame. More...
int BL_DLLIMPORT | BLC_getFrameNrForFrameId (BL_HANDLE handle, unsigned int frameId)
Retrieve the SDF frame number for a given BUS frame-id. More...
int BL_DLLIMPORT | BLC_getFrameIdForFrameNr (BL_HANDLE handle, unsigned char frameNr)
Retrieve the BUS frame-id for a given SDF frame number. More...

Function Documentation

int BL_DLLIMPORT BLC_downloadSDF | ( | BL_HANDLE | handle,
 |  | int | mode
 | ) |  |

The SDF could be generated by LINWorks/SessionConf from a LDF file and must have been loaded previously by an BL_loadSDF() command. WARNING: this resets the device!

Parameters
[in] | handle | Handle representing the connection. (see BLC_open )
mode | The mode to load the SDF. 0= don't load ; 1= download without check ; 2= download only if the CRC of the loaded SDF is different
Returns
Status of operation; '=0' means successful, '!=0' otherwise. See standard return values for error, or for textual representation (for return values < -1000) BLC_getLastError.
CPCHAR BL_DLLIMPORT BLC_getChannelSectionDescription ( BL_HANDLE handle )
Parameters
[in] handle Handle of the channel to get the sdf section description of
Returns
int BL_DLLIMPORT BLC_getFrameCount ( BL_HANDLE handle )

Number of frames of the bus according to the informations in the loaded SDF.

Parameters
[in] handle Handle representing a channel (see BLC_getChannelHandle )
Returns
Number of frames of the bus according to the informations in the loaded SDF. Values <0 on error. See standard return values for error, or for textual representation (for return values < -1000) BLC_getLastError.
int BL_DLLIMPORT BLC_getFrameIdForFrameNr | ( | BL_HANDLE | handle,
 |  | unsigned char | frameNr
 | ) |  |
Parameters
[in] | handle | Handle representing a channel (see BLC_getChannelHandle )
frameNr | Zero based index of the frame (see BLC_getFrameCount )
Returns
BUS frameId to the given frame index Values <0 on error. See standard return values for error, or for textual representation (for return values < -1000) BLC_getLastError.
int BL_DLLIMPORT BLC_getFrameName | ( | BL_HANDLE | handle,
 |  | int | idx,
 |  | char * | dstbuf,
 |  | int | buflen
 | ) |  |

Name of a frame of the bus according to the informations in the loaded SDF.

Parameters
[in] | handle | Handle representing a channel (see BLC_getChannelHandle )
idx | Zero based index of requested frame entry (see BLC_getFrameCount )
[out] | dstbuf | Pointer to char array which gets filled (must hold min. 'buflen' bytes).
buflen | How many bytes should get returned.
Returns
Status of operation; '>=0' means successful and is the length of the frame name, excluding the terminating '\0'. See standard return values for values '<0', or for textual representation (for return values < -1000) BLC_getLastError.
int BL_DLLIMPORT BLC_getFrameNrForFrameId | ( | BL_HANDLE | handle,
 |  | unsigned int | frameId
 | ) |  |
Parameters
[in] | handle | Handle representing a channel (see BLC_getChannelHandle )
frameId | The BUS frameId to get the frame number. Special Bits that change the interpretation of frameId: Bit 32(0x80000000) : the given Id is a 29Bit ID.
Returns
Zero based index of the frame in the SDF Values <0 on error. See standard return values for error, or for textual representation (for return values < -1000) BLC_getLastError.
int BL_DLLIMPORT BLC_getNodeCount ( BL_HANDLE handle )

Number of nodes connected to the bus according to the informations in the loaded SDF.

Parameters
[in] handle Handle representing a channel (see BLC_getChannelHandle )
Returns
Number of nodes connected to the bus according to the informations in the loaded SDF. Values <0 on error. See standard return values for error, or for textual representation (for return values < -1000) BLC_getLastError.
int BL_DLLIMPORT BLC_getNodeName | ( | BL_HANDLE | handle,
 |  | int | idx,
 |  | char * | dstbuf,
 |  | int | buflen
 | ) |  |

Name of a node connected to the bus according to the informations in the loaded SDF.

Parameters
[in] | handle | Handle representing a channel (see BLC_getChannelHandle )
idx | Zero based index of requested node entry (see BLC_getNodeCount )
[out] | dstbuf | Pointer to char array which gets filled (must hold min. 'buflen' bytes).
buflen | How many bytes should get returned.
Returns
Status of operation; '>0' is the length of the string in "dstbuf", '<0' otherwise. See standard return values for error, or for textual representation (for return values < -1000) BLC_getLastError.
int BL_DLLIMPORT BLC_getSDFInfo | ( | BL_HANDLE | handle,
 |  | BLC_SDFINFO * | pSDFInfo
 | ) |  |

Need a loaded SDF (see BLC_loadSDF or BLC_loadLDF )

Parameters
[in] | handle | handle to a valid connection
[out] | pSDFInfo | Points to a pre-allocated BLC_SDFINFO to be filled with information
Returns
Status of operation; '=0' means successful, '!=0' otherwise. See standard return values for error, or for textual representation (for return values < -1000) BLC_getLastError.
int BL_DLLIMPORT BLC_getSectionInfo | ( | BL_HANDLE | handle,
 |  | int | infoAboutSectionNr,
 |  | BLC_SECTIONINFO * | pSectionInfo
 | ) |  |
Parameters
[in] | handle | Handle of a valid connection
infoAboutSectionNr | The section number to retrieve information of. Ranges from 0 to the number of sections in the loaded SDF (see BLC_getSDFInfo and BLC_SDFINFO::sectionCount )
[out] | pSectionInfo | Address of a pre-allocated BLC_SECTIONINFO
Returns
Status of operation; '=0' means successful, '!=0' otherwise. See standard return values for error, or for textual representation (for return values < -1000) BLC_getLastError.
int BL_DLLIMPORT BLC_getSignalCount ( BL_HANDLE handle )

Number of signals of the bus according to the informations in the loaded SDF.

Parameters
[in] handle Handle representing a channel (see BLC_getChannelHandle )
Returns
Number of signals of the bus according to the informations in the loaded SDF. Values <0 on error. See standard return values for error, or for textual representation (for return values < -1000) BLC_getLastError.
int BL_DLLIMPORT BLC_getSignalInFrame | ( | BL_HANDLE | handle,
 |  | int | frameIndex,
 |  | int | signalIndex
 | ) |  |
Parameters
[in] | handle | Handle representing a channel (see BLC_getChannelHandle )
frameIndex | Zero based index of the frame the signal is mapped to (see BLC_getFrameCount )
signalIndex | Zero based index of the signal as mapped to the frame (see BLC_getSignalsInFrameCount )
Returns
Zero based index of the signal in the SDF Values <0 on error. See standard return values for error, or for textual representation (for return values < -1000) BLC_getLastError.
int BL_DLLIMPORT BLC_getSignalName | ( | BL_HANDLE | handle,
 |  | int | idx,
 |  | char * | dstbuf,
 |  | int | buflen
 | ) |  |

Name of a signal of the bus according to the informations in the loaded SDF.

Parameters
[in] | handle | Handle representing a channel (see BLC_getChannelHandle )
idx | Zero based index of requested signal entry (see BLC_getSignalCount )
[out] | dstbuf | Pointer to char array which gets filled (must hold min. 'buflen' bytes).
buflen | How many bytes should get returned.
Returns
Status of operation; '>=0' means successful and is the length of the signal name, excluding the terminating '\0'. See standard return values for values '<0', or for textual representation (for return values < -1000) BLC_getLastError.
int BL_DLLIMPORT BLC_getSignalsInFrameCount | ( | BL_HANDLE | handle,
 |  | int | idx
 | ) |  |
Parameters
[in] | handle | Handle representing a channel (see BLC_getChannelHandle )
idx | Zero based index of requested frame entry (see BLC_getFrameCount )
Returns
Number of signals mapped in the frame Values <0 on error. See standard return values for error, or for textual representation (for return values < -1000) BLC_getLastError.
int BL_DLLIMPORT BLC_getSignalSize | ( | BL_HANDLE | handle,
 |  | int | idx
 | ) |  |

Size of a signal of the bus according to the informations in the loaded SDF.

Parameters
[in] | handle | Handle representing a channel (see BLC_getChannelHandle )
idx | Zero based index of requested signal entry (see BLC_getSignalCount )
Returns
Size of the signal in bits. Values <0 on error. See standard return values for error, or for textual representation (for return values < -1000) BLC_getLastError.
int BL_DLLIMPORT BLC_isSDFOnDevice | ( | BL_HANDLE | handle,
 |  | const char * | filename
 | ) |  |

If the device already has an SDF loaded, this method checks if the SDF at the given path and the SDF on the device are the same. Important: This method only works with SDFv3 devices.

Parameters
[in] | handle | Handle representing the device. (see BLC_open )
[in] | filename | The path of the SDF to compare.
Returns
BL_OK = SDFs match BL_SDF_INCOMPATIBLE = SDFs do not match BL_NO_SDF = no SDF loaded on device BL_SDF_INSUFFICIENT_FIRMWARE = the device does not support this feature. e.g. a SDFv2 device. See standard return values for error, or for textual representation (for return values < -1000) BLC_getLastError.
int BL_DLLIMPORT BLC_isSignalEmulated | ( | BL_HANDLE | handle,
 |  | int | idx
 | ) |  |

A signal is emulated if the node to which it belongs (according to the SDF) is emulated by the BabyLIN-Device (see "setnodesimu" sendCommand in SDF Related Commands to change node emulation at runtime )

Parameters
[in] | handle | Handle representing a channel (see BLC_getChannelHandle )
idx | Zero based index of requested signal entry (see BLC_getSignalCount )
Returns
'=0' means signal is not emulated, '=1' if emulated, '<0' denotes error. See standard return values for error, or for textual representation (for return values < -1000) BLC_getLastError.
int BL_DLLIMPORT BLC_loadLDF | ( | BL_HANDLE | handle,
 |  | const char * | filename,
 |  | int | download
 | ) |  |

Loads a given LDF, converts the LDF to a SDF ( without SDF specific features ) and optionally downloads the generated SDF to the device. To actually use the LDF, you almost always need to set the emulated node too. You can do this by using the "setnodesimu" command using BLC_sendCommand.

Attention
This resets the device upon download
Parameters
[in] | handle | Handle representing the connection. (see BLC_open )
[in] | filename | C-string with the (fully qualified) filename (i.e. "mybus.ldf", if in the same directory, or "c:/data/mybus.ldf").
download | Boolean value, determines if the generated SDF profile gets downloaded into the BabyLIN device (!=0) or only used in the library (=0).
Returns
Status of operation; '=0' means successful, '!=0' otherwise. See standard return values for error, or for textual representation (for return values < -1000) BLC_getLastError.
int BL_DLLIMPORT BLC_loadSDF | ( | BL_HANDLE | handle,
 |  | const char * | filename,
 |  | int | download
 | ) |  |

The SDF is generated by LINWorks/SessionConf from a LDF file.

Attention
This resets the device upon download
Parameters
[in] | handle | Handle representing the connection. (see BLC_open )
[in] | filename | C-string with the (fully qualified) filename (i.e. "mybus.sdf", if in the same directory, or "c:/data/mybus.sdf").
download | Boolean value, determines if the SDF profile gets downloaded into the BabyLIN device (!=0) or only used in the library (=0).
Returns
Status of operation; '=0' means successful, '!=0' otherwise. See standard return values for error, or for textual representation (for return values < -1000) BLC_getLastError.
Generated on Fri May 30 2025 17:16:14 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: SDF functions

Macros | Typedefs | Functions
SDF functions

Detailed Description

The following structures are used to load and retrieve data from a SDF. The API allows to load and retrieve SDF informations without an existing BabyLIN-Device connection and is particulaly useful for SDF preloading or SDF loading to download to multiple BabyLIN devices. Functions prefixed with BLC_ require an existing connection to a BabyLIN with a loaded SDF on the corresponding channel.

Macros

#define | SDF_OK 0
#define | SDF_HANDLE_INVALID -100024
#define | SDF_IN_USE -100025

Typedefs

typedef void * SDF_HANDLE

Functions

int BL_DLLIMPORT | BLC_SDF_getNodeNr (BL_HANDLE handle, const char *name)
Get the SDF's number for node by name. More...
int BL_DLLIMPORT | BLC_SDF_getSignalNr (BL_HANDLE handle, const char *name)
Get the SDF's number for signal by name. More...
int BL_DLLIMPORT | BLC_SDF_getFrameNr (BL_HANDLE handle, const char *name)
Get the SDF's number for frame by name. More...
int BL_DLLIMPORT | BLC_SDF_getScheduleNr (BL_HANDLE handle, const char *name)
Get the SDF's number for schedule by name. More...
int BL_DLLIMPORT | BLC_SDF_getNumSchedules (BL_HANDLE handle)
Get the number of schedule tables in the SDF. More...
CPCHAR BL_DLLIMPORT | BLC_SDF_getScheduleName (BL_HANDLE handle, int schedule_nr)
Get the SDF's name of schedule by number. More...
int BL_DLLIMPORT | BLC_SDF_getMacroNr (BL_HANDLE handle, const char *name)
Get the SDF's number for macro by name. More...
SDF_HANDLE BL_DLLIMPORT | SDF_open (const char *filename)
Loads a SDFile to memory and returns a SDF_HANDLE. More...
SDF_HANDLE BL_DLLIMPORT | SDF_openLDF (const char *filename)
Loads a LDFFile to memory, creates a temporary SDF and returns a SDF_HANDLE. More...
int BL_DLLIMPORT | SDF_close (SDF_HANDLE handle)
Closes a SDFile opened using SDF_open. More...
int BL_DLLIMPORT | SDF_hasMacroCommandOverwriteEnabled (SDF_HANDLE sdfhandle)
Returns whether the command overwriting feature for macro names is enabled. More...
int BL_DLLIMPORT | SDF_downloadToDevice (SDF_HANDLE sdfhandle, BL_HANDLE blhandle, int mode)
Download a SDFile to a BabyLIN device. More...
int BL_DLLIMPORT | SDF_downloadSectionToChannel (SDF_HANDLE sectionhandle, BL_HANDLE channelhandle)
Download a SDFile to a BabyLIN device. More...
int BL_DLLIMPORT | SDF_getSectionCount (SDF_HANDLE sdfhandle)
Get number of sections in SDF. More...
SDF_HANDLE BL_DLLIMPORT | SDF_getSectionHandle (SDF_HANDLE handle, int sectionNr)
Get handle to a section of a sdf. More...
int BL_DLLIMPORT | SDF_getSectionInfo (SDF_HANDLE handle, SDF_SECTIONINFO *info)
Get information about a section. More...

Macro Definition Documentation

#define SDF_HANDLE_INVALID -100024

Definition at line 32 of file SDF.h.

#define SDF_IN_USE -100025

Definition at line 33 of file SDF.h.

#define SDF_OK 0

Definition at line 31 of file SDF.h.

Typedef Documentation

typedef void* SDF_HANDLE

Definition at line 35 of file SDF.h.

Function Documentation

int BL_DLLIMPORT BLC_SDF_getFrameNr | ( | BL_HANDLE | handle,
 |  | const char * | name
 | ) |  |
Parameters
handle | Handle representing the connection; returned previously by getChannelHandle().
name | Name of the frame.
Returns
Returns the frame's number or -1 if there's no frame with specified name. Even smaller numbers designate error codes as defined in BabyLIN.h.
int BL_DLLIMPORT BLC_SDF_getMacroNr | ( | BL_HANDLE | handle,
 |  | const char * | name
 | ) |  |
Parameters
handle | Handle representing the connection; returned previously by getChannelHandle().
name | Name of the macro.
Returns
Returns the macro's number or -1 if there's no macro with specified name. Even smaller numbers designate error codes as defined in BabyLIN.h.
int BL_DLLIMPORT BLC_SDF_getNodeNr | ( | BL_HANDLE | handle,
 |  | const char * | name
 | ) |  |
Parameters
handle | Handle representing the connection; returned previously by getChannelHandle().
name | Name of the node.
Returns
Returns the node's number or -1 if there's no signal with specified name. Even smaller numbers designate error codes as defined in BabyLIN.h.
int BL_DLLIMPORT BLC_SDF_getNumSchedules ( BL_HANDLE handle )
Parameters
handle Handle representing the connection; returned previously by getChannelHandle().
Returns
Returns the number of schedule tablesname or 0 if there's no schedule defined.
CPCHAR BL_DLLIMPORT BLC_SDF_getScheduleName | ( | BL_HANDLE | handle,
 |  | int | schedule_nr
 | ) |  |
Parameters
handle | Handle representing the connection; returned previously by getChannelHandle().
schedule_nr | Index of the schedule.
Returns
Returns the schedule's name or empty string if there's no schedule with specified index.
int BL_DLLIMPORT BLC_SDF_getScheduleNr | ( | BL_HANDLE | handle,
 |  | const char * | name
 | ) |  |
Parameters
handle | Handle representing the connection; returned previously by getChannelHandle().
name | Name of the schedule.
Returns
Returns the schedule's number or -1 if there's no schedule with specified name. Even smaller numbers designate error codes as defined in BabyLIN.h.
int BL_DLLIMPORT BLC_SDF_getSignalNr | ( | BL_HANDLE | handle,
 |  | const char * | name
 | ) |  |
Parameters
handle | Handle representing the connection; returned previously by getChannelHandle().
name | Name of the signal.
Returns
Returns the signal's number or -1 if there's no signal with specified name. Even smaller numbers designate error codes as defined in BabyLIN.h.
int BL_DLLIMPORT SDF_close ( SDF_HANDLE handle )
Parameters
[in] handle The SDFile handle to close
Returns
0 on success
int BL_DLLIMPORT SDF_downloadSectionToChannel | ( | SDF_HANDLE | sectionhandle,
 |  | BL_HANDLE | channelhandle
 | ) |  |
Parameters
[in] | sectionhandle | The SDFile from SDF_open to download
[in] | channelhandle | The BabyLIN channel handle from BLC_getChannelHandle to download to
Returns
See BLC_loadSDF returncodes (0 = success)
int BL_DLLIMPORT SDF_downloadToDevice | ( | SDF_HANDLE | sdfhandle,
 |  | BL_HANDLE | blhandle,
 |  | int | mode
 | ) |  |
Parameters
[in] | sdfhandle | The SDFile from SDF_open to download
[in] | blhandle | The BabyLIN connection handle from BLC_open to download to
[in] | mode | See BLC_loadSDF modes
Returns
See BLC_loadSDF returncodes (0 = success)
int BL_DLLIMPORT SDF_getSectionCount ( SDF_HANDLE sdfhandle )
Parameters
[in] sdfhandle The SDFile from SDF_open
Returns
Number of sections ( negative value on error )
SDF_HANDLE BL_DLLIMPORT SDF_getSectionHandle | ( | SDF_HANDLE | handle,
 |  | int | sectionNr
 | ) |  |
Parameters
[in] | handle | The handle of the sdf to get the section handle from
[in] | sectionNr | The section number to get the handle for
Returns
Handle to the section ( 0 on error )
int BL_DLLIMPORT SDF_getSectionInfo | ( | SDF_HANDLE | handle,
 |  | SDF_SECTIONINFO * | info
 | ) |  |
Parameters
[in] | handle | The section handle to retrieve informations about
[out] | info | Pointer to pre-allocated SDF_SECTIONINFO structure to fill
Returns
0 on success
int BL_DLLIMPORT SDF_hasMacroCommandOverwriteEnabled ( SDF_HANDLE sdfhandle )
Parameters
[in] sdfhandle The SDFile from SDF_open
Returns
0 = feature disabled for this SDF, 1 = feature enabled, commands will be interpreted as macro names first, if that fails, it will execute the normal command e.g "reboot", if it exists.
SDF_HANDLE BL_DLLIMPORT SDF_open ( const char * filename )
Parameters
[in] filename The filename to load, can be absolute or relative to the current working directory
Returns
To the loaded SDFile or 0 on error
SDF_HANDLE BL_DLLIMPORT SDF_openLDF ( const char * filename )
Parameters
[in] filename The filename to load, can be absolute or relative to the current working directory
Returns
To the loaded SDFile or 0 on error
Generated on Fri May 30 2025 17:16:14 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: Direct Mode operation

Functions
Direct Mode operation

Detailed Description

Functions

int BL_DLLIMPORT | BLC_dmStart (BL_HANDLE handle, int baudrate, int bitwidth, int stopbits, int parity)
Starts direct mode on channel with given baudrate, bitwidth, stopbits and parity settings. If the direct mode is already active on the channel, it will be restarted. The command prepares the channel with BLC_dmReportConfig settings of 5ms and 8 bytes. More...
int BL_DLLIMPORT | BLC_dmReportConfig (BL_HANDLE handle, int timeout, int bytes)
Configure the reporting policy of the device in respect to a timeout and/or a block of bytes. The device will report any data read from the bus if the read data exceeds the given byte count or after [timeout] milliseconds idle time. More...
int BL_DLLIMPORT | BLC_dmWrite (BL_HANDLE handle, const char *data, unsigned int dataSize)
Writes data in directmode to the bus. More...
int BL_DLLIMPORT | BLC_dmRead (BL_HANDLE handle, char *buffer, unsigned int bufferSize)
Read data in direct mode. More...
int BL_DLLIMPORT | BLC_dmReadTimeout (BL_HANDLE handle, char *buffer, unsigned int bufferSize, unsigned int timeout_ms)
Same as BLC_dmRead with waiting timeout in ms. More...
int BL_DLLIMPORT | BLC_dmPulse (BL_HANDLE handle, unsigned int lowtime_us, unsigned int paddingtime_us)
Issue a pulse on the bus. More...
int BL_DLLIMPORT | BLC_dmDelay (BL_HANDLE channel, unsigned int paddingtime_us)
Delay the next operation by the given time. More...
int BL_DLLIMPORT | BLC_dmStop (BL_HANDLE handle)
Stop direct mode. More...
int BL_DLLIMPORT | BLC_dmPrepare (BL_HANDLE channel, unsigned char mode)
BLC_dmPrepare enters or exits the preparation state. More...

Function Documentation

int BL_DLLIMPORT BLC_dmDelay | ( | BL_HANDLE | channel,
 |  | unsigned int | paddingtime_us
 | ) |  |

this function is an alias for "@ref BLC_dmPulse(channel, 0, paddingtime_us)". If no bus power is available, the delay will be queued to be sent when bus power is available.

Parameters
[in] | channel | A handle representing the channel to which the frame belongs
paddingtime_us | The time in mico seconds to idle before taking the next action.
Returns
BL_OK on success, errocode otherwise
See Also
BLC_getChannelHandle
int BL_DLLIMPORT BLC_dmPrepare | ( | BL_HANDLE | channel,
 |  | unsigned char | mode
 | ) |  |
Parameters
[in] | channel | The channel handle to work on.
mode | The preparation mode to set. 1 for entering preparation mode, 0 to exit it and 2 to clear the preparation buffer.
Returns
BL_OK on success, errorcode otherwise
int BL_DLLIMPORT BLC_dmPulse | ( | BL_HANDLE | handle,
 |  | unsigned int | lowtime_us,
 |  | unsigned int | paddingtime_us
 | ) |  |

with a duration of lowtime_us in us. After the pulse, any further action will be delayed paddingtime_us if no bus power is available, the pulse will be queued to be sent when bus power is available

Parameters
[in] | handle | Handle representing the channel to which the frame belongs (see BLC_getChannelHandle )
lowtime_us | The time in micro seconds to hold the output on dominant level.
paddingtime_us | The time in mico seconds to idle before taking the next action.
Returns
BL_OK on success, errocode otherwise
int BL_DLLIMPORT BLC_dmRead | ( | BL_HANDLE | handle,
 |  | char * | buffer,
 |  | unsigned int | bufferSize
 | ) |  |

reads maximum bufferSize bytes to buffer. Will wait for data for infinite amount of time. If the DirectMode is active this function or BLC_dmReadTimeout have to be called to prevent the internal buffer from allocating all system memory.

Parameters
[in] | handle | Handle representing the channel to which the frame belongs (see BLC_getChannelHandle )
[out] | buffer | The buffer having at least [bufferSize] space to store received data.
bufferSize | The amount of data to read.
Returns
Number of bytes read, values <0 indicate error code
int BL_DLLIMPORT BLC_dmReadTimeout | ( | BL_HANDLE | handle,
 |  | char * | buffer,
 |  | unsigned int | bufferSize,
 |  | unsigned int | timeout_ms
 | ) |  |

If the DirectMode is active this function or BLC_dmRead have to be called to prevent the internal buffer from allocating all system memory.

Parameters
[in] | handle | Handle representing the channel to which the frame belongs (see BLC_getChannelHandle )
[out] | buffer | The buffer having at least [bufferSize] space to store received data.
bufferSize | The amount of data to read.
timeout_ms | The timeout in milliseconds after which the function returns with less then bufferSize data read.
Returns
Number of bytes read, values <0 indicate error code
int BL_DLLIMPORT BLC_dmReportConfig | ( | BL_HANDLE | handle,
 |  | int | timeout,
 |  | int | bytes
 | ) |  |

direct mode has to be active

Parameters
[in] | handle | Handle representing the channel to which the frame belongs (see BLC_getChannelHandle )
[in] | timeout | The time in milliseconds until the bus is determined as idle resulting in a report of data even thou less then [bytes] data was received.
bytes | The amount of data after wich a report is generated.
Returns
BL_OK on success, errorcode otherwise
int BL_DLLIMPORT BLC_dmStart | ( | BL_HANDLE | handle,
 |  | int | baudrate,
 |  | int | bitwidth,
 |  | int | stopbits,
 |  | int | parity
 | ) |  |
Parameters
[in] | handle | Handle representing the channel to which the frame belongs (see BLC_getChannelHandle )
baudrate | The baudrate to configure while in direct mode.
bitwidth | This parameter is not yet used and has to be set to 0. The bitwidth will be 8.
stopbits | This parameter is not yet used and has to be set to 0. It will be 1 stopbit.
parity | This parameter is not yet used and has to be set to 0. Parity bit is deactivated.
Returns
BL_OK on success, errorcode otherwise
int BL_DLLIMPORT BLC_dmStop ( BL_HANDLE handle )
Parameters
[in] handle Handle representing the channel to which the frame belongs
Returns
BL_OK on success, errorcode otherwise
See Also
BLC_getChannelHandle
int BL_DLLIMPORT BLC_dmWrite | ( | BL_HANDLE | handle,
 |  | const char * | data,
 |  | unsigned int | dataSize
 | ) |  |

direct mode has to be active

if no bus power is available, the data will be queued to be sent when bus power is available

Parameters
[in] | handle | Handle representing the channel to which the frame belongs (see BLC_getChannelHandle )
[in] | data | The buffer containing the data to send.
dataSize | The amount of data in the buffer. only 1023 bytes can be send to the device in one call.
Returns
Number of bytes written, values <0 indicate error code.
Generated on Fri May 30 2025 17:16:14 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: SDF scripting

Modules
SDF scripting

Detailed Description

General

The DLL supports the execution of a SDF script file. These are normal ".sdf" files which contain script code instead of the binary SDF data.
SDF scripts only work on PC and the MB-II but not in the standalone application mode of normal devices, as the device can't execute the scripts.

Use cases

Normally, a script SDF is coupled with a normal binary SDF and is used to execute script code when the normal SDF is loaded.
This way, you can modify the data of the binary SDF, like setting signals or table values.
This also allows to automatically start operation when a SDF is loaded.

Creating a script SDF

To create a script SDF, you only need to create a new file with the ".sdf" extension.
You can now edit this file with any texteditor.

Script SDFs require a certain header to work and be loadable by the DLL or the SimpeMenu.
The first line of your script has to be:

1 -- [HEADER] SDFType=script ScriptVersion=100

You can now specify a binary SDF to load if you need one:

1 sdf_file = "YourBinarySDF.sdf"

And you can specify functions that will be called after the DLL loaded the binary SDF and the script SDF.

1 function OnDownloadSection_1(channel)
2
3 end

You can modify the function names suffix of "1" to match the required channel.
The channel numbering is the same as the number of the section of SDF as shown in the SessionConf.
So the function in the example above will be loaded when (and *only when!) the SDFs section 1 is loaded onto a device.
Especially on the BabyLIN-MB-II this might not always be the case, which will result in the function not being called.

See Channel for further information about the "channel" argument of this function.

Hello World!

Using the information from above, a simple, minimum script SDF could look like this:
1 -- [HEADER] SDFType=script ScriptVersion=100
2 sdf_file = "YourBinarySDF.sdf"
3
4 function OnDownloadSection_1(channel)
5 print("Hello from a script SDF!")
6 end
This example will print "Hello from a script SDF!" to a registered LUA callback and not modify the binary SDF.

DLL callbacks

You can register callbacks that will be run, if a script SDF print something using the "print" script function using the BLC_registerLuaPrintCallback DLL function.
You can also register the BLC_registerLuaErrorCallback which will print error information when your script fails. This might be helpful to debug issues.

Modules

Global scope
Functions and variables available in the global scope.
Function scope
Functions and variables available in the function scope.
Generated on Fri May 30 2025 17:16:14 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: Global scope

Global scope
SDF scripting

Global scope

The global scope means any script statements outside of "function [...]" blocks.
Currently there are only a few functions or variables to set from the global scope:
Name | Description
sdf_file | A variable containing the name of the SDF to load. Default: ''
sdf_force_download | If this variable is set to "false", the binary SDF pointed to by "sdf_file" might not be actually reloaded. This is useful if you want to reexecute the script SDF but not change the current binary SDF state. Warning: If this value is 'false', reloading the script SDF does not change the binary SDFs state. So any running bus will keep running and all virtual signals etc. will keep their values and NOT be resetted to the default values. Default: true
Generated on Fri May 30 2025 17:16:14 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: Function scope

Modules
Function scope
SDF scripting

Detailed Description

Function scope

The function scope means any script statements inside of "function [...]" blocks.
The function is always called with one parameter, the channel object. This object represents the device channel the section is loaded onto.
Using this object, you can query some device or SDF data and manipulate other objects.

The following functions/object/variables are available, please see their corresponding pages for detailed information:
Name | Type | Reference
Print | Function | Prints a string to the BLC_registerLuaPrintCallback See Print
Sleep | Function | Sleeps for a given time in milliseconds. See Sleep
Channel | Object | Represents a channel on the device. See Channel

Modules

Print
Prints a given string.
Sleep
Sleeps for a given time.
Channel
Object representing a channel on the device.
Table
Object representing a table in the SDF.
Generated on Fri May 30 2025 17:16:14 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: Print

Print
Function scope

Print

Description

Prints the given arguments as a string to the BLC_registerLuaPrintCallback.
It accepts variable number of arguments and will try to convert them from any type to a string.
The function does not return anything.

Syntax:

1 print(str, [any ...])

Examples

1 print("SimpleString")
2 print('SingleQuotedString')
3 print('Concat'..' this'..' string')
4 print('Concat with a variable: '..var)
5 print('Concat with a variable: ', var1, var2, var3)
Generated on Fri May 30 2025 17:16:14 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: Sleep

Sleep
Function scope

Sleep

Description

Stops the execution of the script for the given amount of time.
It accepts a single number typed argument, which represents the time to sleep in milliseconds.
The function does not return anything.

Syntax:

1 sleep(time_ms)

Examples

1 -- Sleep for 100ms
2 Sleep(100)
3
4 -- Sleep for 1 second
5 Sleep(10*100)
6
7 -- Sleep a variable time
8 Sleep(variable_name)
Generated on Fri May 30 2025 17:16:14 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: Channel

Channel
Function scope

Channel

Description

An object represeting a channel on the device.
This object is mainly used in the "OnDownloadSection_[...]" functions as argument.
You can call several functions on this object to interact with the device or the binary SDF.

All functions are callable like this:

1 function OnDownloadSection_1(channel)
2 -- 'channel' is the name of an object of the type 'Channel'
3 -- You call functions with the syntax 'variable_name:function_name'
4 local channel_id = channel:GetId()
5 end

Available Functions

Channel:GetId()

Returns the device index of the channel.
Needs no arguments.
The function returns a single number typed value for the index.

Syntax:

1 index = Channel:GetId()

Examples:

1 local channel_id = channel:GetId()
2 print('Channel ID: ', channel_id)

Channel:GetHandle()

Returns the handle to the channel. This value is the same as a BLC_openPort would return.
Note: Each reload of the script SDF, as well as each call to BLC_openPort may result in different values for the handle refering to this channel.
During runtime, this value is garantueed to not change until the device is closed.
Needs no arguments.
The function returns a single number typed value for the index.

Syntax:

1 handle = Channel:GetHandle()

Examples:

1 local channel_handle = channel:GetHandle()
2 print('Channel handle: ', channel_handle)

Channel:GetName()

Returns the name of the channel.
Needs no arguments.
The function returns a single string typed value for the name.

Syntax:

1 name = Channel:GetName()

Examples:

1 local channel_name = channel:GetName()
2 print('Channel name: ', channel_name)

Channel:GetType()

Returns the type of the channel.
Needs no arguments.
The function returns a number typed value for the type.
ChannelType is defined as:

1 ChannelType = {DEVICE = 0, LIN = 1, CAN_LS = 2, CAN_HS = 3, CAN_FD = 4}

You can directly use these values, please do not use the number values directly!
Syntax:

1 type = Channel:GetType()

Examples:

1 local channel_type = channel:GetType()
2 if(channel_type == ChannelType.CAN_LS) then
3 print("This is only printed if the channel is CAN lowspeed!")
4 end

Channel:GetMaximumBaudrate()

Returns the maximum bus speed the channel supports.
Needs no arguments.
The function returns a single number typed value for the speed.

Syntax:

1 max_speed = Channel:GetMaximumBaudrate()

Examples:

1 local max_speed = channel:GetMaximumBaudrate()
2 print('Channel maximum speed: ', max_speed)

Channel:IsDisabled()

Returns the activation state of the channel.
Note: This value is always true when called on a channel object from a 'OnDownloadSection_[...]' function. Needs no arguments.
The function returns a single boolean typed value for the activation state.

Syntax:

1 is_disabled = Channel:IsDisabled()

Examples:

1 local channel_disabled = channel:IsDisabled()
2 print('Channel is disabled: ', channel_disabled)

Channel:HasSDFv3Support()

Returns whether the channel supports version 3 SDFs.
Needs no arguments.
The function returns a single boolean typed value for the state.

Syntax:

1 supports_v3 = Channel:HasSDFv3Support()

Examples:

1 local channel_support_sdfv3 = channel:HasSDFv3Support()
2 print('Channel supports SDFv3: ', channel_support_sdfv3)

Channel:ExecuteMacro()

Executes a macro on the device.
Requires the macro identifier as argument.
Optionally you can also set the timeout (in milliseconds) and macro parameters as arguments.

The macro identifier can be a number value, representing a macro index, or a string value representing the macro name.
Note: When using a string for the macro name, make sure the SDF macro names are unique.
The first found macro with a matching name will be executed if there are several identically named macros.
The macro parameters have to be a table value.
The timeout has to be a number value.

The function will return both the macro return code as a number value, as well as the macro result string as a string value.

Syntax:

1 macro_ret_code, macro_result_str = Channel:ExecuteMacro(macro, [arguments], [timeout])

Examples:

1 -- Executes the macro with id '0'
2 local macro_ret_code, macro_result_str = channel:ExecuteMacro(0)
3
4 -- Executes the first macro with the name 'ExampleMacro'
5 local macro_ret_code, macro_result_str = channel:ExecuteMacro('ExampleMacro')
6
7 -- Executes the macro with id '0' with a timeout of 500 milliseconds
8 local macro_ret_code, macro_result_str = channel:ExecuteMacro(0, 500)
9
10 -- Executes the macro with id '0' with a list of parameters
11 local macro_ret_code, macro_result_str = channel:ExecuteMacro(0, {1,2,3,4})
12
13 -- Executes the macro with id '0' with a list of parameters and a timeout of 500 milliseconds
14 local macro_ret_code, macro_result_str = channel:ExecuteMacro(0, {1,2,3,4}, 500)
15
16 -- The parameter list and the timeout can also be switched in place
17 local macro_ret_code, macro_result_str = channel:ExecuteMacro(0, 500, {1,2,3,4})

Channel:GetTableCount()

Returns the number of Tables in the section that is loaded onto this channel.
Needs no arguments.
The function returns a single number typed value for the count.

Syntax:

1 table_count = Channel:GetTableCount()

Examples:

1 local table_count = channel:GetTableCount()
2 print("This SDF has "..table_count.. " tables.")

Channel:GetTable()

Returns a table object for the index in this channel.
Requires a number valued table index as argument. This value is the same as in the SDF.
The function returns a single 'Table' typed object.

See Table to see what you can do with a 'Table' object.
Syntax:

1 table = Channel:GetTable(index)

Examples:

1 -- 'tbl' is now an object referencing the SDF table with index 0.
2 local tbl = channel:GetTable(0)
Generated on Fri May 30 2025 17:16:14 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: Table

Table
Function scope

Table

Description

An object represeting a table in the SDF.
This object is used to read out or change table values.

All functions are callable like this:

1 function OnDownloadSection_1(channel)
2 -- tbl may contain a reference to the table at index 0 in the SDF, if the SDF has such a table.
3 local tbl = channel:GetTable(0)
4
5 -- Call "GetId()" function on the table.
6 local tbl_id = tbl:GetId()
7 end

Available Functions

Table:GetId()

Returns the SDF index of the table.
Needs no arguments.
The function returns a single number typed value for the index.

Syntax:

1 sdf_index = Table:GetId()

Example:

1 local table_id = table:GetId()
2 print('Table ID: ', table_id)

Table:GetRowCount()

Returns the number of rows in the table.
Needs no arguments.
The function returns a single number typed value for the row count.

Syntax:

1 row_count = Table:GetRowCount()

Examples:

1 local tbl_row_count = table:GetRowCount()
2 print('Table has this many rows: ', tbl_row_count)

Table:GetColumnCount()

Returns the number of columns in the table.
Needs no arguments.
The function returns a single number typed value for the column count.

Syntax:

1 col_count = Table:GetColumnCount()

Examples:

1 local tbl_col_count = table:GetColumnCount()
2 print('Table has this many columns: ', tbl_col_count)

Table:Read()

Returns the value of the given cell in the table.
Requires a row and column index as number typed arguments.
The function returns either a number or string typed value depending on the SDF column description for the value of the cell.

Syntax:

1 value = Table:Read(row, column)

Examples:

1 -- Reads out the value at row 0 column 1.
2 local value = table:Read(0, 1)
3 print('Table value at row 0 column 1: ', value)

Table:Write()

Writes a value into a cell in the table.
Requires a row and column index as number typed arguments, as well as a string or number typed value to write.
Note: Writing a string value into a number cell and vise versa, will do nothing, the cell content is not changed in this case.
The function does not return anything.

Syntax:

1 Table:Write(row, column, value)

Examples:

1 -- Write a number value of 1234 into row 0 column 1, assuming its a integer column:
2 local value = table:Read(0, 1, 1234)
3
4 -- Write a string value into row 0 column 2, assuming its a string column:
5 local value = table:Read(0, 2, "ExampleString")

Table:Fill()

Fills all cells with a value.
Requires a start cell as table type, a end cell as table type and optionally a number and a string type for the values to fill.
If the optional value types are not passen, the cells will be filled with 0 or an empty string.
The function does not return anything.

Syntax:

1 Table:Fill({start_row, start_column}, {end_row, end_column}, [number_value, string_value])

Examples:

1 -- Fills the cells from row 0 column 0 to row 4 colum 4 with an empty string or 0 depending on the columns type.
2 table:Fill({0, 0}, {4, 4})
3
4 -- Fills the cells from row 0 column 0 to row 4 colum 4 with an empty string or 0 depending on the columns type.
5 table:Fill({0, 0}, {4, 4}, 0, "")
6
7 -- Fills the cells from row 0 column 0 to row 4 colum 4 with the string 'ExampleString' or 1234 depending on the columns type.
8 table:Fill({0, 0}, {4, 4}, 1234, "ExampleString")

Table:Clear()

Clears the table.
Needs no arguments.
The function does not return anything.

This function is equivialent to:

1 table:Fill({0, 0}, {table:GetRowCount() - 1, table:GetColumnCount() - 1})

Syntax:

1 Table:Clear()

Examples:

1 -- Clears the table. All cells will contain either an empty string or 0 depending on the columns type.
2 table:Clear()
Generated on Fri May 30 2025 17:16:14 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: Legacy Parts

Modules | Macros | Typedefs | Functions
Legacy Parts

Detailed Description

List of functions to access the LIN-BUS directly.

Incomplete features. Do not use.

Modules

Legacy Connection Handling
List of legacy BabyLIN connection handling function.
Legacy Command Functions
List of legacy functions to send commands to a BabyLIN device.
Legacy Data Structures
List of legacy BabyLIN structures.
Legacy Callback Handling
List of legacy functions to manage callback functions.
Legacy Pull Functions
List of legacy functions to pull retrieved data from a connection.
Legacy SDF Handling
List of legacy functions to get information about the loaded SDF.
Legacy SDF Functions
List of legacy SDF functions.

Macros

#define BL_EXCEPTION_FILTER_ATTR

Typedefs

typedef long(BL_EXCEPTION_FILTER_ATTR * exception_filter )(struct _EXCEPTION_POINTERS *ExceptionInfo)

Functions

void BL_DLLIMPORT | BLC_overwriteCrashHandler (exception_filter function, const char *application_name, int dump_external_code, int show_msgbox_on_crash)
int BL_DLLIMPORT | BLC_runLuaCode (BL_HANDLE handle, const char *lua_code)

Macro Definition Documentation

#define BL_EXCEPTION_FILTER_ATTR

Definition at line 2335 of file BabyLINCAN.h.

Typedef Documentation

typedef long(BL_EXCEPTION_FILTER_ATTR* exception_filter)(struct _EXCEPTION_POINTERS *ExceptionInfo)

Definition at line 2337 of file BabyLINCAN.h.

Function Documentation

void BL_DLLIMPORT BLC_overwriteCrashHandler | ( | exception_filter | function,
 |  | const char * | application_name,
 |  | int | dump_external_code,
 |  | int | show_msgbox_on_crash
 | ) |  |
int BL_DLLIMPORT BLC_runLuaCode | ( | BL_HANDLE | handle,
 |  | const char * | lua_code
 | ) |  |
Generated on Fri May 30 2025 17:16:14 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: Legacy Connection Handling

Functions
Legacy Connection Handling
Legacy Parts

Detailed Description

The following functions are used to setup a connection to a BabyLIN device. These functions are outdated and no longer used for the new BabyLIN API.

Functions

int BL_DLLIMPORT | BL_searchBabyLinPorts (BL_portInfo_t *pdest, int *psize)
int BL_DLLIMPORT | BL_searchBabyLIN (int port)
void BL_DLLIMPORT | BL_getVersion (int *major, int *minor)
CPCHAR BL_DLLIMPORT | BL_getVersionString (void)
BL_HANDLE BL_DLLIMPORT | BL_open (unsigned int port)
int BL_DLLIMPORT | BL_close (BL_HANDLE handle)
int BL_DLLIMPORT | BL_closeAll (void)
int BL_DLLIMPORT | BL_flush (BL_HANDLE handle)
int BL_DLLIMPORT | BL_getTargetID (BL_HANDLE handle, BL_targetid_t *targetID)
int BL_DLLIMPORT | BL_loadSDF (BL_HANDLE handle, const char *filename, int download)
int BL_DLLIMPORT | BL_downloadSDF (BL_HANDLE handle)
CPCHAR BL_DLLIMPORT | BL_getLastError (BL_HANDLE handle)

Function Documentation

int BL_DLLIMPORT BL_close ( BL_HANDLE handle )

BL_close() closes an open connection, given by handle.

Parameters
[in] handle Handle representing the connection; returned previously by BL_open.
Returns
Status of operation; '=0' means successful, '!=0' otherwise. See standard return values for error, or for textual representation BL_getLastError().
int BL_DLLIMPORT BL_closeAll ( void )

BL_closeAll() closes all open connections; all handles are invalidated.

Returns
Status of operation; '=0' means successful, '!=0' otherwise. See standard return values for error, or for textual representation BL_getLastError().
int BL_DLLIMPORT BL_downloadSDF ( BL_HANDLE handle )

The SDF could be generated by LINWorks/SessionConf from a LDF file and must have been loaded previously by an BL_loadSDF() command. WARNING: this resets the device!

Parameters
[in] handle Handle representing the connection; returned previously by BL_open().
Returns
Status of operation; '=0' means successful, '!=0' otherwise. See standard return values for error, or for textual representation (for return values < -1000) BL_getLastError().
int BL_DLLIMPORT BL_flush ( BL_HANDLE handle )

Afterwards, the device will no longer monitor the bus, neither acting as slave nor as master.

Parameters
[in] handle Handle representing the connection; returned previously by BL_open().
Returns
Status of operation; '=0' means successful, '!=0' otherwise. See standard return values for error, or for textual representation (for return values < -1000) BL_getLastError().
CPCHAR BL_DLLIMPORT BL_getLastError ( BL_HANDLE handle )

The string returned is a pointer to an internal variable; don't ever try to free it! The errors are described in English. Note however, only Errorcodes < -1000 get described - all other return values are directly sent by the device. Values >0 usually denote the index of the wrong parameter of a command. Values <0 define other errors like 'out of memory' and alike. Consult the BabyLIN documentation for further reference.

Parameters
[in] handle Handle to the erroneous connection.
Returns
C-String with textual description of last error.
int BL_DLLIMPORT BL_getTargetID | ( | BL_HANDLE | handle,
 |  | BL_targetid_t * | targetID
 | ) |  |
Parameters
[in] | handle | Handle representing the connection; returned previously by connectDevice().
[in] | targetID | pointer to BL_targetid_t structure to hold the information after the successful call, has to be allocated.
Returns
Status of operation; '=0' means successful, '!=0' otherwise. See standard return values for error, or for textual representation (for return values < -1000) getLastDeviceError().
void BL_DLLIMPORT BL_getVersion | ( | int * | major,
 |  | int * | minor
 | ) |  |

This function enters the version in the given parameter variables of the library.

Parameters
[in] | major | Major part of version number.
[in] | minor | Minor part of version number.
CPCHAR BL_DLLIMPORT BL_getVersionString ( void )

This function returns the version string of the library.

Returns
A C-string with the version information.
int BL_DLLIMPORT BL_loadSDF | ( | BL_HANDLE | handle,
 |  | const char * | filename,
 |  | int | download
 | ) |  |

The SDF could be generated by LINWorks/SessionConf from a LDF file. WARNING: this resets the device upon download!

Parameters
[in] | handle | Handle representing the connection; returned previously by BL_open().
filename | C-string with the (fully qualified) filename (i.e. "mybus.sdf", if in the same directory, or "c:/data/mybus.sdf").
download | Boolean value, determines if the SDF profile gets downloaded into the BabyLIN device (!=0) or only used in the library (=0).
Returns
Status of operation; '=0' means successful, '!=0' otherwise. See standard return values for error, or for textual representation (for return values < -1000) BL_getLastError().
BL_HANDLE BL_DLLIMPORT BL_open ( unsigned int port )

This function tries to open the designated port and to start communication with the device.

Parameters
port Represents the port number; it uses Windows-style numbering, which means it starts with '1' for the first serial port. '0' is reserved.
Returns
Returns an handle for the designated connection; on failure NULL. You may fetch the corresponding (textual) error (for return values < -1000) with BL_getLastError().
int BL_DLLIMPORT BL_searchBabyLIN ( int port )
int BL_DLLIMPORT BL_searchBabyLinPorts | ( | BL_portInfo_t * | pdest,
 |  | int * | psize
 | ) |  |
Parameters
[in] | pdest | Pointer to BLC_portInfo_t array, where the infos about the recognized Baby-LIN's will be supplied. If this pointer is given with NULL, the function will only return the count of available devices.
[in,out] | psize | Pointer to integer which holds the maximum count of entries, which may be filled by the function into the array pdest. If this pointer is given with NULL, the function will only return the count of available devices.
Returns
Returns number of available Baby-LIN devices.
Generated on Fri May 30 2025 17:16:14 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: Legacy Command Functions

Functions
Legacy Command Functions
Legacy Parts

Detailed Description

The following functions are used to send commands to a BabyLIN device to set or retrieve simulation or device parameters. These functions are outdated and no longer used for the new BabyLIN API.

Functions

int BL_DLLIMPORT | BL_sendCommand (BL_HANDLE handle, const char *command)
int BL_DLLIMPORT | BL_sendCommandD (BL_HANDLE handle, const char *command, char *data, int *length)
int BL_DLLIMPORT | BL_sendCommandF (BL_HANDLE handle, const char *command,...)
int BL_DLLIMPORT | BL_sendCommandFs (BL_HANDLE handle, const char *command, const char *name)
int BL_DLLIMPORT | BL_mon_set (BL_HANDLE handle, int frameid, const int *databytes, int len)
int BL_DLLIMPORT | BL_mon_xmit (BL_HANDLE handle, int frameId, int slottime)
int BL_DLLIMPORT | BL_mon_set_xmit (BL_HANDLE handle, int frameId, const int *databytes, int len, int slottime)
int BL_DLLIMPORT | BL_sendRaw (BL_HANDLE handle, const unsigned char *command, unsigned int *length)
int BL_DLLIMPORT | BL_setDTLMode (BL_HANDLE handle, int mode)
int BL_DLLIMPORT | BL_sendDTLRequest (BL_HANDLE handle, unsigned char nad, int length, unsigned char *data)
int BL_DLLIMPORT | BL_sendDTLResponse (BL_HANDLE handle, unsigned char nad, int length, unsigned char *data)
int BL_DLLIMPORT | BL_sendRawSlaveResponse (BL_HANDLE handle, unsigned char *reqdata, unsigned char *reqmask, unsigned char *data, int length)
int BL_DLLIMPORT | BL_sendRawMasterRequest (BL_HANDLE handle, unsigned char *data, int count)
int BL_DLLIMPORT | BL_getDTLRequestStatus (BL_HANDLE handle)
int BL_DLLIMPORT | BL_getDTLResponseStatus (BL_HANDLE handle)
int BL_DLLIMPORT | BL_getRawSlaveResponse (BL_HANDLE handle, unsigned char *data, int length)
int BL_DLLIMPORT | BL_updRawSlaveResponse (BL_HANDLE handle)
int BL_DLLIMPORT | BL_lastAnswerHasData (BL_HANDLE handle)
int BL_DLLIMPORT | BL_getAnswerTypeByName (BL_HANDLE handle, const char *name, BL_ANSWER_TYPE *type, size_t *length)
int BL_DLLIMPORT | BL_getAnswerTypeByIndex (BL_HANDLE handle, const unsigned int index, BL_ANSWER_TYPE *type, size_t *length)
int BL_DLLIMPORT | BL_getAnswerByName (BL_HANDLE handle, const char *name, void *buffer, size_t length)
int BL_DLLIMPORT | BL_getAnswerByIndex (BL_HANDLE handle, const unsigned int index, void *buffer, size_t length)

Function Documentation

int BL_DLLIMPORT BL_getAnswerByIndex | ( | BL_HANDLE | handle,
 |  | const unsigned int | index,
 |  | void * | buffer,
 |  | size_t | length
 | ) |  |
Parameters
[in] | handle | Handle representing the connection; returned previously by BL_open().
index | Zero-based index of the answer data set
[out] | buffer | Pointer to destination buffer for the data set
length | Length of destination buffer
Returns
Status of operation; '=0' means successful, '!=0' otherwise. See standard return values for error, or for textual representation (for return values < -1000) BL_getLastError().
int BL_DLLIMPORT BL_getAnswerByName | ( | BL_HANDLE | handle,
 |  | const char * | name,
 |  | void * | buffer,
 |  | size_t | length
 | ) |  |
Parameters
[in] | handle | Handle representing the connection; returned previously by BL_open().
[in] | name | Char*-string with the name of answer data set
[out] | buffer | Pointer to destination buffer for the data set
length | Length of destination buffer
Returns
Status of operation; '=0' means successful, '!=0' otherwise. See standard return values for error, or for textual representation (for return values < -1000) BL_getLastError().
int BL_DLLIMPORT BL_getAnswerTypeByIndex | ( | BL_HANDLE | handle,
 |  | const unsigned int | index,
 |  | BL_ANSWER_TYPE * | type,
 |  | size_t * | length
 | ) |  |

The following types of data sets are possible: BL_ANSWER_TYPE_INT - 32bit integer BL_ANSWER_TYPE_STR - zero-terminated string (variable length) BL_ANSWER_TYPE_BIN - binary data (variable length)

Parameters
[in] | handle | Handle representing the connection; returned previously by BL_open().
index | Zero-based index of the answer data set
[out] | type | Type of data set is returned within
[out] | length | Length of data set is returned within
Returns
Status of operation; '=0' means successful, '!=0' otherwise. See standard return values for error, or for textual representation (for return values < -1000) BL_getLastError().
int BL_DLLIMPORT BL_getAnswerTypeByName | ( | BL_HANDLE | handle,
 |  | const char * | name,
 |  | BL_ANSWER_TYPE * | type,
 |  | size_t * | length
 | ) |  |

The following types of data sets are possible: BL_ANSWER_TYPE_INT - 32bit integer BL_ANSWER_TYPE_STR - zero-terminated string (variable length) BL_ANSWER_TYPE_BIN - binary data (variable length)

Parameters
[in] | handle | Handle representing the connection; returned previously by BL_open().
[in] | name | Char*-string with the name of answer data set
[out] | type | Type of data set is returned within
[out] | length | Length of data set is returned within
Returns
Status of operation; '=0' means successful, '!=0' otherwise. See standard return values for error, or for textual representation (for return values < -1000) BL_getLastError().
int BL_DLLIMPORT BL_getDTLRequestStatus ( BL_HANDLE handle )
Parameters
[in] handle Handle representing the connection; returned previously by BL_open().
Returns
Status of last request operation if >= 0; see BL_DTL_STATUS for values. For < 0, see standard return values for error, or for textual representation (for return values < -1000) BL_getLastError().
int BL_DLLIMPORT BL_getDTLResponseStatus ( BL_HANDLE handle )
Parameters
[in] handle Handle representing the connection; returned previously by BL_open().
Returns
Status of last request operation if >= 0; see BL_DTL_STATUS for values. For < 0, see standard return values for error, or for textual representation (for return values < -1000) BL_getLastError().
int BL_DLLIMPORT BL_getRawSlaveResponse | ( | BL_HANDLE | handle,
 |  | unsigned char * | data,
 |  | int | length
 | ) |  |

The internal raw-SlaveResponse-buffer is filled continuously with the data bytes of reported SlaveResp-frames and is being reset upon every call of BL_sendRawMasterRequest().

Parameters
[in] | handle | Handle representing the connection; returned previously by BL_open().
[out] | data | Pointer to char array which gets filled (must hold min. 'length' bytes).
length | How many bytes should get returned.
Returns
Status of operation; '=0' means successful, '!=0' otherwise. See standard return values for error, or for textual representation (for return values < -1000) BL_getLastError().
int BL_DLLIMPORT BL_lastAnswerHasData ( BL_HANDLE handle )

If there is no additional data present it returns BL_NO_ANSWER_DATA.

Parameters
[in] handle Handle representing the connection; returned previously by BL_open().
Returns
Status of operation; '=0' means successful, '!=0' otherwise. See standard return values for error, or for textual representation (for return values < -1000) BL_getLastError().
int BL_DLLIMPORT BL_mon_set | ( | BL_HANDLE | handle,
 |  | int | frameid,
 |  | const int * | databytes,
 |  | int | len
 | ) |  |
int BL_DLLIMPORT BL_mon_set_xmit | ( | BL_HANDLE | handle,
 |  | int | frameId,
 |  | const int * | databytes,
 |  | int | len,
 |  | int | slottime
 | ) |  |
int BL_DLLIMPORT BL_mon_xmit | ( | BL_HANDLE | handle,
 |  | int | frameId,
 |  | int | slottime
 | ) |  |
int BL_DLLIMPORT BL_sendCommand | ( | BL_HANDLE | handle,
 |  | const char * | command
 | ) |  |

The command must match the command syntax as specified in the BabyLIN documentation. The trailing ';' may be omitted; but you may not specify several commands at once!

Parameters
[in] | handle | Handle representing the connection; returned previously by BL_open().
[in] | command | C-string with Commands (e.g. "status;")
Returns
Status of operation; '=0' means successful, '!=0' otherwise. See standard return values for error, or for textual representation (for return values < -1000) getLastDeviceError().
int BL_DLLIMPORT BL_sendCommandD | ( | BL_HANDLE | handle,
 |  | const char * | command,
 |  | char * | data,
 |  | int * | length
 | ) |  |

The command must match the command syntax as specified in the BabyLIN documentation. The trailing ';' may be omitted; but you may not specify several commands at once! The content of '*length' will be set to really received number of data bytes. If one of the required pointers 'data' or 'length' is NULL or the buffer size is too small, the function returns the needed minimum buffer length in '*length' (if this pointer is valid).

Parameters
[in] | handle | Handle representing the connection; returned previously by BL_open().
[in] | command | C-string with Commands (e.g. "status;")
[out] | data | Pointer to data save location (destination buffer)
[in,out] | length | Pointer to requested data length.
Returns
Status of operation; '=0' means successful, '!=0' otherwise. See standard return values for error, or for textual representation (for return values < -1000) BL_getLastError().
int BL_DLLIMPORT BL_sendCommandF | ( | BL_HANDLE | handle,
 |  | const char * | command,
 |  |  | ...
 | ) |  |

The command must match the command syntax as specified in the BabyLIN documentation. The trailing ';' may be omitted; but you may not specify several commands at once! This function works similiar to functions like 'printf'. You may specify placeholders, whose value get specified as parameter to the function.

Possible placeholders are: S insert signal number for name specified as parameter F insert frame number for name specified as parameter M insert macro number for name specified as parameter

Examples: BL_sendCommandF(handle, "setsig %S 1;", "signal name"); BL_sendCommandF(handle, "disframe %F;", "frame name"); BL_sendCommandF(handle, "macro_exec %M;", "macro name");

Parameters
[in] | handle | Handle representing the connection; returned previously by BL_open().
[in] | command | C-string with Commands and placeholders (e.g. "setsig %S 1;").
... Additional parameters, as specified by placeholders. Status of operation; '=0' means successful, '!=0' otherwise. See standard return values for error, or for textual representation (for return values < -1000) BL_getLastError().
int BL_DLLIMPORT BL_sendCommandFs | ( | BL_HANDLE | handle,
 |  | const char * | command,
 |  | const char * | name
 | ) |  |

The command must match the command syntax as specified in the BabyLIN documentation. The trailing ';' may be omitted; but you may not specify several commands at once! This function works similiar to functions like 'printf'. You may specify placeholders, whose value get specified as parameter to the function.

Possible placeholders are: S Insert signal number for name specified as parameter F Insert frame number for name specified as parameter M Insert macro number for name specified as parameter

Examples: BL_sendCommandFs(handle, "setsig %S 1;", "signal name"); BL_sendCommandFs(handle, "disframe %F;", "frame name"); BL_sendCommandFs(handle, "macro_exec %M;", "macro name");

Parameters
[in] | handle | Handle representing the connection; returned previously by BL_open().
[in] | command | C-string with Commands and placeholders (e.g. "setsig %S 1;").
[in] | name | Name of signal, frame or macro
Returns
Status of operation; '=0' means successful, '!=0' otherwise. See standard return values for error, or for textual representation (for return values < -1000) BL_getLastError().
int BL_DLLIMPORT BL_sendDTLRequest | ( | BL_HANDLE | handle,
 |  | unsigned char | nad,
 |  | int | length,
 |  | unsigned char * | data
 | ) |  |
Parameters
[in] | handle | Handle representing the connection; returned previously by BL_open().
nad | NAD of the node the request gets send to.
length | Length of the following data array.
[in] | data | DTL frame data (begins with SID, followed by up to 4095 data bytes).
Returns
Status of operation; '=0' means successful, '!=0' otherwise. See standard return values for error, or for textual representation (for return values < -1000) BL_getLastError().
int BL_DLLIMPORT BL_sendDTLResponse | ( | BL_HANDLE | handle,
 |  | unsigned char | nad,
 |  | int | length,
 |  | unsigned char * | data
 | ) |  |
Parameters
[in] | handle | Handle representing the connection; returned previously by BL_open().
nad | NAD of the node the response gets send for.
length | Length of the following data array.
[in] | data | DTL frame data (begins with RSID, followed by up to 4095 data bytes).
Returns
Status of operation; '=0' means successful, '!=0' otherwise. See standard return values for error, or for textual representation (for return values < -1000) BL_getLastError().
int BL_DLLIMPORT BL_sendRaw | ( | BL_HANDLE | handle,
 |  | const unsigned char * | command,
 |  | unsigned int * | length
 | ) |  |

The command must be encoded in the binary DP-Message format of BabyLIN.

Parameters
[in] | handle | Handle representing the connection; returned previously by BL_open().
[in] | command | char*-Buffer with the designated Commands.
[in,out] | length | Length of buffer; gets set to actual sent command's length.
Returns
Status of operation; '=0' means successful, '!=0' otherwise. See standard return values for error, or for textual representation (for return values < -1000) BL_getLastError().
int BL_DLLIMPORT BL_sendRawMasterRequest | ( | BL_HANDLE | handle,
 |  | unsigned char * | data,
 |  | int | count
 | ) |  |

The internal raw-SlaveResponse-buffer is being reset and the Baby-LIN device gets instructed to report the next 'count' slave response frames which in turn are accumulated into the SlaveResponse-buffer which can be queried by BL_getRawSlaveResponse().

Parameters
[in] | handle | Handle representing the connection; returned previously by BL_open().
[in] | data | Master Request frame data (exactly 8 bytes).
count | Number of expected slave response frames.
Returns
Status of operation; '=0' means successful, '!=0' otherwise. See standard return values for error, or for textual representation (for return values < -1000) BL_getLastError().
int BL_DLLIMPORT BL_sendRawSlaveResponse | ( | BL_HANDLE | handle,
 |  | unsigned char * | reqdata,
 |  | unsigned char * | reqmask,
 |  | unsigned char * | data,
 |  | int | length
 | ) |  |

Upon the reveive of the next master request frame, the every bit of the request is compared to 'reqdata' if the corresponding bit of 'reqmask' is set (1). If all match, Baby-LIN starts to send out the data given in 'data', 8 bytes with each slave response frame.

Parameters
[in] | handle | Handle representing the connection; returned previously by BL_open().
[in] | reqdata | Data of the expected master request (exactly 8 bytes).
[in] | reqmask | Mask for 'reqdata' to indicate which bits must match (exactly 8 bytes).
[in] | data | Slave response frame data (multiple of 8 bytes).
length | Length of data to send.
Returns
Status of operation; '=0' means successful, '!=0' otherwise. See standard return values for error, or for textual representation (for return values < -1000) BL_getLastError().
int BL_DLLIMPORT BL_setDTLMode | ( | BL_HANDLE | handle,
 |  | int | mode
 | ) |  |

There are different Diagnostic modes, which offer different levels of protocol functionality. The Baby-LIN will start with Diagnostic OFF on Power Up. If the BabyLIN acts as LIN master then the selection of an Diagnostic Mode happens trough the usage of the appropriate API function calls. So the API functions BL_sendRawMasterRequest or BL_sendRawSlaveResponse will start the Diagnostic RAW mode, where as the API calls BL_sendDTLRequest or BL_sendDTLResponse will start the Diagnostic DTL mode. If the BabyLIN acts as LIN slave then the DTL mode must be set by use of this function. It is not possible to use different Diagnostics modes at the same time !

Parameters
[in] | handle | Handle representing the connection; returned previously by BL_open().
mode | DTL mode: 0 = DTL_NONE = no DTL Support 1 = DTL_RAW = RAW Mode DTL Support 2 = DTL_COOKED = Cooked Mode DTL Support
Returns
Status of operation; '=0' means successful, '!=0' otherwise. See standard return values for error, or for textual representation (for return values < -1000) BL_getLastError().
int BL_DLLIMPORT BL_updRawSlaveResponse ( BL_HANDLE handle )
Generated on Fri May 30 2025 17:16:14 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: Legacy Data Structures

Data Structures
Legacy Data Structures
Legacy Parts

Detailed Description

The following structures are used to retrieve data from a running BabyLIN device like frame- and signal-reports or error and debug information Most of the structures are outdated and no longer used for the new BabyLIN API.

Data Structures

struct | BL_signal_t
Carries information about one signal. More...
struct | BL_targetid_t
struct | BL_error_t
struct | BL_frame_t
struct | BL_dtl_t
struct | BL_portInfo_t
Information about a BabyLIN port on the host operating system. More...
Generated on Fri May 30 2025 17:16:14 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: BL_signal_t Struct Reference

  • Data Structure Index
Data Fields
BL_signal_t Struct Reference
Legacy Data Structures

Carries information about one signal. More...

#include <BabyLIN.h>

Data Fields

unsigned char | index
int | isArray
unsigned short | value
int | arrayLength
unsigned char | array [8]

Detailed Description

Deprecated:

Definition at line 18 of file BabyLIN.h.

Field Documentation

unsigned char BL_signal_t::array[8]

Definition at line 28 of file BabyLIN.h.

int BL_signal_t::arrayLength

Definition at line 26 of file BabyLIN.h.

unsigned char BL_signal_t::index

Definition at line 20 of file BabyLIN.h.

int BL_signal_t::isArray

Definition at line 22 of file BabyLIN.h.

unsigned short BL_signal_t::value

Definition at line 24 of file BabyLIN.h.

The documentation for this struct was generated from the following file:
  • C:/JenkinsWS/workspace/orks_v2_LinWorksv2_Windows_trunk/source/externals/BabyLIN/src/libraries/BabyLIN/publicHeaders/BabyLIN.h
Generated on Fri May 30 2025 17:16:14 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: BL_targetid_t Struct Reference

  • Data Structure Index
Data Fields
BL_targetid_t Struct Reference
Legacy Data Structures

#include <BabyLIN.h>

Data Fields

unsigned short | type
Type of the hardware. More...
unsigned short | version
unsigned short | build
unsigned short | flags
Software related flags. More...
long | serial
long | heapsize
long | spare
char | name [128]

Detailed Description

Definition at line 32 of file BabyLIN.h.

Field Documentation

unsigned short BL_targetid_t::build

Definition at line 53 of file BabyLIN.h.

unsigned short BL_targetid_t::flags
Value | Description
0x01 | Testversion

Definition at line 61 of file BabyLIN.h.

long BL_targetid_t::heapsize

Definition at line 67 of file BabyLIN.h.

char BL_targetid_t::name[128]

Definition at line 73 of file BabyLIN.h.

long BL_targetid_t::serial

Definition at line 64 of file BabyLIN.h.

long BL_targetid_t::spare

Definition at line 70 of file BabyLIN.h.

unsigned short BL_targetid_t::type
Value | Device
0x100 | Baby-LIN
0x101 | Baby-LIN-PLUS
0x102 | Baby-LIN-RC
0x103 | Baby-LIN-KS01
0x200 | Baby-LIN-RM
0x300 | HARP
0x400 | Baby-LIN-RC-PLUS
0x500 | Baby-LIN-RMII
0x502 | HARP-4

Definition at line 47 of file BabyLIN.h.

unsigned short BL_targetid_t::version

Definition at line 50 of file BabyLIN.h.

The documentation for this struct was generated from the following file:
  • C:/JenkinsWS/workspace/orks_v2_LinWorksv2_Windows_trunk/source/externals/BabyLIN/src/libraries/BabyLIN/publicHeaders/BabyLIN.h
Generated on Fri May 30 2025 17:16:14 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: BL_error_t Struct Reference

  • Data Structure Index
Data Fields
BL_error_t Struct Reference
Legacy Data Structures

#include <BabyLIN.h>

Data Fields

unsigned long | timestamp
Time of occurence (usec, since first start of LIN activity). More...
unsigned short | type
Error type. More...
unsigned short | status
Additional error information. More...

Detailed Description

Definition at line 77 of file BabyLIN.h.

Field Documentation

unsigned short BL_error_t::status

See type descriptions for detailed Information

Definition at line 105 of file BabyLIN.h.

unsigned long BL_error_t::timestamp

Definition at line 81 of file BabyLIN.h.

unsigned short BL_error_t::type
Value | Name | Description | Status
1 | ERRTYPE_ID | Parity error in ID |
2 | ERRTYPE_DATA | Read data from BUS does not match send data | Frame-ID
3 | ERRTYPE_FRAMING | Framing error in data reception | Frame-ID
4 | ERRTYPE_CHECKSUM | Checksum failed | Frame-ID
5 | ERRTYPE_DATATO | Data timed out (incomplete msg reception) | Frame-ID
6 | ERRTYPE_SEQ | Unexpected state sequencing | internal status
8 | ERRTYPE_MACRO | Error in macro execution | internal status
9 | ERRTYPE_BUSBUSY | Bus is already used | internal status
10 | ERRTYPE_BUSOFF | Bus is offline (no bus power) | internal status

|11|ERRTYPE_BUSSPEED_DIFFERS|Actual bus-speed differs from LDF bus speed (Warning) |actual speed| |12|ERRTYPE_KWP_ERROR|Error in KWP|KWP error code| |13|ERRTYPE_APPLICATION|Application error|unused|

Definition at line 100 of file BabyLIN.h.

The documentation for this struct was generated from the following file:
  • C:/JenkinsWS/workspace/orks_v2_LinWorksv2_Windows_trunk/source/externals/BabyLIN/src/libraries/BabyLIN/publicHeaders/BabyLIN.h
Generated on Fri May 30 2025 17:16:14 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: BL_frame_t Struct Reference

  • Data Structure Index
Data Fields
BL_frame_t Struct Reference
Legacy Data Structures

#include <BabyLIN.h>

Data Fields

unsigned char | extended
unsigned char | flags
Additional, informational flags. More...
unsigned long | timestamp
unsigned short | breaklength
unsigned short | synctime
unsigned char | length
struct {
unsigned char value
unsigned short time
} framedata [10]
unsigned short | status
no longer used More...

Detailed Description

Definition at line 109 of file BabyLIN.h.

Field Documentation

unsigned short BL_frame_t::breaklength

Definition at line 133 of file BabyLIN.h.

unsigned char BL_frame_t::extended

Definition at line 111 of file BabyLIN.h.

unsigned char BL_frame_t::flags

Used as a bitfield, multiple flags possible

Value | Description
0x01 | Valid CLASSIC checksum (V1)
0x02 | Valid EXTENDED checksum (V2)
0x04 | incomplete frame without checksum, not an error
0x08 | Errorframe (f.ex: no data)
0x10 | Frame is slave response to a master request. If set, the upper 3 bits of flags denote a master request id
0x20 | Event triggered frame ( only if 0x10 is not set )

Definition at line 127 of file BabyLIN.h.

struct { ... } BL_frame_t::framedata[10]

First value is the frame's ID (or SDF-number, if extended == 0), followed by the data bytes; the last value-time tuple is the checksum byte. The times are measured from the end of the previous data byte to the end of the current byte (all in us, timing information only valid if extended != 0):

unsigned char BL_frame_t::length

Definition at line 140 of file BabyLIN.h.

unsigned short BL_frame_t::status
Deprecated:
no longer used

Definition at line 157 of file BabyLIN.h.

unsigned short BL_frame_t::synctime

Definition at line 136 of file BabyLIN.h.

unsigned short BL_frame_t::time

Definition at line 150 of file BabyLIN.h.

unsigned long BL_frame_t::timestamp

Definition at line 130 of file BabyLIN.h.

unsigned char BL_frame_t::value

Definition at line 149 of file BabyLIN.h.

The documentation for this struct was generated from the following file:
  • C:/JenkinsWS/workspace/orks_v2_LinWorksv2_Windows_trunk/source/externals/BabyLIN/src/libraries/BabyLIN/publicHeaders/BabyLIN.h
Generated on Fri May 30 2025 17:16:14 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: BL_dtl_t Struct Reference

  • Data Structure Index
Data Fields
BL_dtl_t Struct Reference
Legacy Data Structures

#include <BabyLIN.h>

Data Fields

BL_DTL_STATUS status
unsigned char | nad
int | length
unsigned char | data [4 *1024]

Detailed Description

Definition at line 161 of file BabyLIN.h.

Field Documentation

unsigned char BL_dtl_t::data[4 *1024]

Definition at line 171 of file BabyLIN.h.

int BL_dtl_t::length

Definition at line 169 of file BabyLIN.h.

unsigned char BL_dtl_t::nad

Definition at line 166 of file BabyLIN.h.

BL_DTL_STATUS BL_dtl_t::status

Definition at line 163 of file BabyLIN.h.

The documentation for this struct was generated from the following file:
  • C:/JenkinsWS/workspace/orks_v2_LinWorksv2_Windows_trunk/source/externals/BabyLIN/src/libraries/BabyLIN/publicHeaders/BabyLIN.h
Generated on Fri May 30 2025 17:16:14 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: BL_portInfo_t Struct Reference

  • Data Structure Index
Data Fields
BL_portInfo_t Struct Reference
Legacy Data Structures

Information about a BabyLIN port on the host operating system. More...

#include <BabyLIN.h>

Data Fields

int | portNr
int | type
char | name [256]
char | device [256]

Detailed Description

The structure holds information about a BabyLIN device connected to the PC. Use BL_searchBabyLinPorts to retrieve a list of connected BabyLIN-Devices

Definition at line 179 of file BabyLIN.h.

Field Documentation

char BL_portInfo_t::device[256]

The linux device file the BabyLIN is connected to (linux only)

Definition at line 187 of file BabyLIN.h.

char BL_portInfo_t::name[256]

The name of the connected device (f.ex. BabyLIN RM-II)

Definition at line 185 of file BabyLIN.h.

int BL_portInfo_t::portNr

The COM-port number the device is connected to (windows only), use this value for BLC_open

Definition at line 181 of file BabyLIN.h.

int BL_portInfo_t::type

The type of interface of the connected device (0=USB)

Definition at line 183 of file BabyLIN.h.

The documentation for this struct was generated from the following file:
  • C:/JenkinsWS/workspace/orks_v2_LinWorksv2_Windows_trunk/source/externals/BabyLIN/src/libraries/BabyLIN/publicHeaders/BabyLIN.h
Generated on Fri May 30 2025 17:16:14 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: Legacy Callback Handling

Typedefs | Functions
Legacy Callback Handling
Legacy Parts

Detailed Description

The following functions are used to register callback functions for a BabyLIN connection. A callback will be called whenever a corresponding message is received on the connection it is registered to ( push method ). If you want to use a pull method to retrieve the data, have a look at the Legacy Pull Functions section of the documentation. These functions are outdated and no longer used for the new BabyLIN API. The device, that generated the callback must not be closed from within the callback.

Typedefs

typedef void( | BL_frame_callback_func )(BL_frame_t frame)
typedef void( | BL_signal_callback_func )(BL_signal_t signal)
typedef void( | BL_buserror_callback_func )(BL_error_t error)
typedef void( | BL_debug_callback_func )(const char *text)
typedef void( | BL_dtl_request_callback_func )(BL_dtl_t frame)
typedef void( | BL_dtl_response_callback_func )(BL_dtl_t frame)

Functions

int BL_DLLIMPORT | BL_registerFrameCallback (BL_HANDLE handle, BL_frame_callback_func *callback)
int BL_DLLIMPORT | BL_registerSignalCallback (BL_HANDLE handle, BL_signal_callback_func *callback)
int BL_DLLIMPORT | BL_registerBusErrorCallback (BL_HANDLE handle, BL_buserror_callback_func *callback)
int BL_DLLIMPORT | BL_registerDebugCallback (BL_HANDLE handle, BL_debug_callback_func *callback)
int BL_DLLIMPORT | BL_registerDTLRequestCallback (BL_HANDLE handle, BL_dtl_request_callback_func *callback)
int BL_DLLIMPORT | BL_registerDTLResponseCallback (BL_HANDLE handle, BL_dtl_response_callback_func *callback)

Typedef Documentation

typedef void( BL_buserror_callback_func)(BL_error_t error)

Definition at line 415 of file BabyLIN.h.

typedef void( BL_debug_callback_func)(const char *text)

Definition at line 417 of file BabyLIN.h.

typedef void( BL_dtl_request_callback_func)(BL_dtl_t frame)

Definition at line 419 of file BabyLIN.h.

typedef void( BL_dtl_response_callback_func)(BL_dtl_t frame)

Definition at line 421 of file BabyLIN.h.

typedef void( BL_frame_callback_func)(BL_frame_t frame)

Definition at line 411 of file BabyLIN.h.

typedef void( BL_signal_callback_func)(BL_signal_t signal)

Definition at line 413 of file BabyLIN.h.

Function Documentation

int BL_DLLIMPORT BL_registerBusErrorCallback | ( | BL_HANDLE | handle,
 |  | BL_buserror_callback_func * | callback
 | ) |  |

Issuing a NULL-pointer de-registers the callback function. As the function is called from another thread context, take care of thread-safety (i.e. using mutexes, etc.).

Parameters
[in] | handle | Handle representing the connection; returned previously by BL_open().
[in] | callback | Pointer to a function call-compatible to BL_frame_buserror_func.
Returns
Status of operation; '=0' means successful, '!=0' otherwise. See standard return values for error, or for textual representation (for return values < -1000) BL_getLastError().
int BL_DLLIMPORT BL_registerDebugCallback | ( | BL_HANDLE | handle,
 |  | BL_debug_callback_func * | callback
 | ) |  |

Issuing a NULL-pointer de-registers the callback function. As the function is called from another thread context, take care of thread-safety (i.e. using mutexes, etc.).

Parameters
[in] | handle | Handle representing the connection; returned previously by BL_open().
[in] | callback | Pointer to a function call-compatible to BL_debug_callback_func.
Returns
Status of operation; '=0' means successful, '!=0' otherwise. See standard return values for error, or for textual representation (for return values < -1000) BL_getLastError().
int BL_DLLIMPORT BL_registerDTLRequestCallback | ( | BL_HANDLE | handle,
 |  | BL_dtl_request_callback_func * | callback
 | ) |  |

Issuing a NULL-pointer de-registers the callback function. As the function is called from another thread context, take care of thread-safety (i.e. using mutexes, etc.).

Parameters
[in] | handle | Handle representing the connection; returned previously by BL_open().
[in] | callback | Pointer to a function call-compatible to BL_dtl_request_callback_func.
Returns
Status of operation; '=0' means successful, '!=0' otherwise. See standard return values for error, or for textual representation (for return values < -1000) BL_getLastError().
int BL_DLLIMPORT BL_registerDTLResponseCallback | ( | BL_HANDLE | handle,
 |  | BL_dtl_response_callback_func * | callback
 | ) |  |

Issuing a NULL-pointer de-registers the callback function. As the function is called from another thread context, take care of thread-safety (i.e. using mutexes, etc.).

Parameters
[in] | handle | Handle representing the connection; returned previously by BL_open().
[in] | callback | Pointer to a function call-compatible to BL_dtl_response_callback_func.
Returns
Status of operation; '=0' means successful, '!=0' otherwise. See standard return values for error, or for textual representation (for return values < -1000) BL_getLastError().
int BL_DLLIMPORT BL_registerFrameCallback | ( | BL_HANDLE | handle,
 |  | BL_frame_callback_func * | callback
 | ) |  |

Issuing a NULL-pointer de-registers the callback function. As the function is called from another thread context, take care of thread-safety (i.e. using mutexes, etc.).

Parameters
[in] | handle | Handle representing the connection; returned previously by BL_open().
[in] | callback | Pointer to a function call-compatible to BL_frame_callback_func.
Returns
Status of operation; '=0' means successful, '!=0' otherwise. See standard return values for error, or for textual representation (for return values < -1000) BL_getLastError().
int BL_DLLIMPORT BL_registerSignalCallback | ( | BL_HANDLE | handle,
 |  | BL_signal_callback_func * | callback
 | ) |  |

Issuing a NULL-pointer de-registers the callback function. As the function is called from another thread context, take care of thread-safety (i.e. using mutexes, etc.).

Parameters
[in] | handle | Handle representing the connection; returned previously by BL_open().
[in] | callback | Pointer to a function call-compatible to BL_signal_callback_func.
Returns
Status of operation; '=0' means successful, '!=0' otherwise. See standard return values for error, or for textual representation (for return values < -1000) BL_getLastError().
Generated on Fri May 30 2025 17:16:14 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: Legacy Pull Functions

Functions
Legacy Pull Functions
Legacy Parts

Detailed Description

The following functions are used to get data which has been received from a BabyLIN-device. This approach uses the pull method, i.e. you will not get any information pushed ( see Callback Handling ) when it's received. Instead you have to call these functions whenever you want to get retrieved data. These functions are outdated and no longer used for the new BabyLIN API.

Functions

int BL_DLLIMPORT | BL_getNextFrame (BL_HANDLE handle, BL_frame_t *framedata)
int BL_DLLIMPORT | BL_getNextFrameTimeout (BL_HANDLE handle, BL_frame_t *framedata, int timeout_ms)
int BL_DLLIMPORT | BL_getLastFrame (BL_HANDLE handle, int frameNr, BL_frame_t *framedata)
int BL_DLLIMPORT | BL_getNextSignal (BL_HANDLE handle, BL_signal_t *signaldata)
int BL_DLLIMPORT | BL_getNextBusError (BL_HANDLE handle, BL_error_t *errordata)
int BL_DLLIMPORT | BL_getNextDTLRequest (BL_HANDLE handle, BL_dtl_t *frame)
int BL_DLLIMPORT | BL_getNextDTLResponse (BL_HANDLE handle, BL_dtl_t *frame)
int BL_DLLIMPORT | BL_getSignalValue (BL_HANDLE handle, int signalNr, unsigned short *value)
int BL_DLLIMPORT | BL_getSignalValueByName (BL_HANDLE handle, const char *signalName, unsigned short *value)
int BL_DLLIMPORT | BL_getSignalArray (BL_HANDLE handle, int signalNr, unsigned char *array)
int BL_DLLIMPORT | BL_getSignalArrayByName (BL_HANDLE handle, const char *signalName, unsigned char *array)
int BL_DLLIMPORT | BL_isSignalArray (BL_HANDLE handle, int idx)
int BL_DLLIMPORT | BL_encodeSignal (BL_HANDLE handle, int signalNr, unsigned int value, char *encSignal, size_t *buffLen0, char *encUnit, size_t *buffLen1)
int BL_DLLIMPORT | BL_getSignalsInFrame (BL_HANDLE handle, int frameNr, BL_signal_t *signalList, int signalListLen)
int BL_DLLIMPORT | BL_getSignalDataFromFrame (BL_HANDLE handle, BL_frame_t *frame, int signalIdx, BL_signal_t *signal)
int BL_DLLIMPORT | BL_getFrameDetails (BL_HANDLE handle, int idx, int *plinid, int *psize, int *pnodenum, int *pframetype)
Returns some details for given frame entry. More...

Function Documentation

int BL_DLLIMPORT BL_encodeSignal | ( | BL_HANDLE | handle,
 |  | int | signalNr,
 |  | unsigned int | value,
 |  | char * | encSignal,
 |  | size_t * | buffLen0,
 |  | char * | encUnit,
 |  | size_t * | buffLen1
 | ) |  |

If no SignalEncoding is specified for this signal, the value itself is written into destination buffer 'description'. If one of the required pointers is NULL or the buffer size is too small, the function returns the needed minimum buffer length in 'length'. It's possible to use two variants to get encoded signal: 1) pointer 'encUnit' and 'buffLen1' set to NULL: then encoded signal saved inclusive unit in buffer 'encSignal' 2) pointer 'encUnit' and 'buffLen1' != NULL: unit of signal saved separately in buffer 'encUnit'

Parameters
[in] | handle | Handle representing the connection; returned previously by BL_open().
signalNr | Number (Index) of the signal accordng to SDF.
value | Value to be encoded
[out] | encSignal | points to save location of encoded signal value (inclusive 'unit', if 'encUnit' not used)
[in,out] | buffLen0 | Length of 'encSignal' buffer
[out] | encUnit | Optional: points to save location of signal unit (if this pointer is NULL then 'unit' saved in 'encSignal' buffer also)
[in,out] | buffLen1 | Optional: length of 'encUnit' buffer (if this pointer is NULL then 'unit' saved in 'encSignal' buffer also)
Returns
Status of operation; '=0' means successful, '!=0' otherwise. See standard return values for error, or for textual representation (for return values < -1000) BL_getLastError().
int BL_DLLIMPORT BL_getFrameDetails | ( | BL_HANDLE | handle,
 |  | int | idx,
 |  | int * | plinid,
 |  | int * | psize,
 |  | int * | pnodenum,
 |  | int * | pframetype
 | ) |  |
Parameters
[in] | handle | Handle representing the connection; returned previously by BL_open()
idx | Zero based index of requested frame entry (sdf number).
[out] | plinid | Pointer to int, which gets filled with LIN ID (without parity bits).
[in,out] | psize | Pointer to int, which gets filled with size of frame in bytes.
[out] | pnodenum | Pointer to int, which gets filled with nodeindex of publishing node for this frame.
[out] | pframetype | Pointer to int, which gets filled with Lin version of this frame.
Returns
BL_OK on success, errocoe otherwise
int BL_DLLIMPORT BL_getLastFrame | ( | BL_HANDLE | handle,
 |  | int | frameNr,
 |  | BL_frame_t * | framedata
 | ) |  |
Parameters
[in] | handle | Handle representing the connection; returned previously by connectDevice().
frameNr | Number of Frame do you received in queue.
[out] | framedata | Pointer to a BL_frame_t structure.
Returns
Status of operation; '=0' means successful, '!=0' otherwise. See standard return values for error, or for textual representation (for return values < -1000) BL_getLastChannelError().
int BL_DLLIMPORT BL_getNextBusError | ( | BL_HANDLE | handle,
 |  | BL_error_t * | errordata
 | ) |  |
Parameters
[in] | handle | Handle representing the connection; returned previously by BL_open().
[out] | errordata | Pointer to a BL_error_t structure.
Returns
Status of operation; '=0' means successful, '!=0' otherwise. See standard return values for error, or for textual representation (for return values < -1000) BL_getLastError().
int BL_DLLIMPORT BL_getNextDTLRequest | ( | BL_HANDLE | handle,
 |  | BL_dtl_t * | frame
 | ) |  |
Parameters
[in] | handle | Handle representing the connection; returned previously by BL_open().
[out] | frame | Pointer to a BL_dtl_t structure.
Returns
Status of operation; '=0' means successful, '!=0' otherwise. See standard return values for error, or for textual representation (for return values < -1000) BL_getLastError().
int BL_DLLIMPORT BL_getNextDTLResponse | ( | BL_HANDLE | handle,
 |  | BL_dtl_t * | frame
 | ) |  |
Parameters
[in] | handle | Handle representing the connection; returned previously by BL_open().
[out] | frame | Pointer to a BL_dtl_t structure.
Returns
Status of operation; '=0' means successful, '!=0' otherwise. See standard return values for error, or for textual representation (for return values < -1000) BL_getLastError().
int BL_DLLIMPORT BL_getNextFrame | ( | BL_HANDLE | handle,
 |  | BL_frame_t * | framedata
 | ) |  |
Parameters
[in] | handle | Handle representing the connection; returned previously by getChannelHandle().
[out] | frameata | Pointer to a frame_t structure.
Returns
Status of operation; '=0' means successful, '!=0' otherwise. See standard return values for error, or for textual representation (for return values < -1000) BL_getLastChannelError().
int BL_DLLIMPORT BL_getNextFrameTimeout | ( | BL_HANDLE | handle,
 |  | BL_frame_t * | framedata,
 |  | int | timeout_ms
 | ) |  |
int BL_DLLIMPORT BL_getNextSignal | ( | BL_HANDLE | handle,
 |  | BL_signal_t * | signaldata
 | ) |  |
Parameters
[in] | handle | Handle representing the connection; returned previously by BL_open().
[out] | signaldata | Pointer to a BL_signal_t structure.
Returns
Status of operation; '=0' means successful, '!=0' otherwise. See standard return values for error, or for textual representation (for return values < -1000) BL_getLastError().
int BL_DLLIMPORT BL_getSignalArray | ( | BL_HANDLE | handle,
 |  | int | signalNr,
 |  | unsigned char * | array
 | ) |  |

Special signalNr '-1' returns always the hex array { 0x01, 0x23, 0x45, 0x67, 0x89, 0xab, 0xcd, 0xef } in *array; signalNr '-2' returns a counted sequence, where the byte 0 holds the actual counter and the following bytes hold the 'history'; i.e.: 1st call: { 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00 } 2nd call: { 0x01, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00 } 3rd call: { 0x02, 0x01, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00 } 4th call: { 0x03, 0x02, 0x01, 0x00, 0x00, 0x00, 0x00, 0x00 } ...etc...

Parameters
[in] | handle | Handle representing the connection; returned previously by BL_open().
signalNr | Number of the signal accordng to SDF.
[out] | array | Pointer to an 8 byte array getting the value. It must always have the size of 8 bytes, even for smaller array signals!
Returns
Status of operation; '=0' means successful, '!=0' otherwise. See standard return values for error, or for textual representation (for return values < -1000) BL_getLastError().
int BL_DLLIMPORT BL_getSignalArrayByName | ( | BL_HANDLE | handle,
 |  | const char * | signalName,
 |  | unsigned char * | array
 | ) |  |
Parameters
[in] | handle | Handle representing the connection; returned previously by BL_open().
[in] | signalName | Name of the Signal as declared in LDF.
[out] | array | Pointer to an 8 byte array getting the value. It must always have the size of 8 bytes, even for smaller array signals!
Returns
Status of operation; '=0' means successful, '!=0' otherwise. See standard return values for error, or for textual representation (for return values < -1000) BL_getLastError().
int BL_DLLIMPORT BL_getSignalDataFromFrame | ( | BL_HANDLE | handle,
 |  | BL_frame_t * | frame,
 |  | int | signalIdx,
 |  | BL_signal_t * | signal
 | ) |  |
int BL_DLLIMPORT BL_getSignalsInFrame | ( | BL_HANDLE | handle,
 |  | int | frameNr,
 |  | BL_signal_t * | signalList,
 |  | int | signalListLen
 | ) |  |
int BL_DLLIMPORT BL_getSignalValue | ( | BL_HANDLE | handle,
 |  | int | signalNr,
 |  | unsigned short * | value
 | ) |  |

Special signalNr '-1' returns always 4711 in *value; signalNr '-2' returns a counter increased by 1 after every call.

Parameters
[in] | handle | Handle representing the connection; returned previously by BL_open().
signalNr | Number of the signal accordng to SDF.
[out] | value | Pointer to an word-sized variable getting the value.
Returns
Status of operation; '=0' means successful, '!=0' otherwise. See standard return values for error, or for textual representation (for return values < -1000) BL_getLastError().
int BL_DLLIMPORT BL_getSignalValueByName | ( | BL_HANDLE | handle,
 |  | const char * | signalName,
 |  | unsigned short * | value
 | ) |  |
Parameters
[in] | handle | Handle representing the connection; returned previously by BL_open().
[in] | signalName | Name of the Signal as declared in LDF.
[out] | value | Pointer to an word-sized variable getting the value.
Returns
Status of operation; '=0' means successful, '!=0' otherwise. See standard return values for error, or for textual representation (for return values < -1000) BL_getLastError().
int BL_DLLIMPORT BL_isSignalArray | ( | BL_HANDLE | handle,
 |  | int | idx
 | ) |  |
Parameters
[in] | handle | Handle representing the connection; returned previously by BL_open().
idx | Zero based index of requested signal entry.
Returns
Status of operation; Signal is Array == 1; Signal is Skala Value == 0.
Generated on Fri May 30 2025 17:16:14 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: Legacy SDF Handling

Functions
Legacy SDF Handling
Legacy Parts

Detailed Description

The following functions are used to retrieve information about the elements in a loaded SDF-file. These functions are outdated and no longer used for the new BabyLIN API.

Functions

int BL_DLLIMPORT | BL_getNodeCount (BL_HANDLE handle)
int BL_DLLIMPORT | BL_getNodeName (BL_HANDLE handle, int idx, char *dstbuf, int buflen)
int BL_DLLIMPORT | BL_getFrameCount (BL_HANDLE handle)
int BL_DLLIMPORT | BL_getFrameName (BL_HANDLE handle, int idx, char *dstbuf, int buflen)
int BL_DLLIMPORT | BL_getSignalCount (BL_HANDLE handle)
int BL_DLLIMPORT | BL_getSignalName (BL_HANDLE handle, int idx, char *dstbuf, int buflen)
int BL_DLLIMPORT | BL_getSignalsInFrameCount (BL_HANDLE handle, int idx)
int BL_DLLIMPORT | BL_getSignalInFrame (BL_HANDLE handle, int frameIndex, int signalIndex)
int BL_DLLIMPORT | BL_getFrameNrForFrameId (BL_HANDLE handle, unsigned char frameId)

Function Documentation

int BL_DLLIMPORT BL_getFrameCount ( BL_HANDLE handle )
Parameters
[in] handle Handle representing the connection; returned previously by BL_open().
Returns
Number of frames set by lframe message.
int BL_DLLIMPORT BL_getFrameName | ( | BL_HANDLE | handle,
 |  | int | idx,
 |  | char * | dstbuf,
 |  | int | buflen
 | ) |  |
Parameters
[in] | handle | Handle representing the connection; returned previously by BL_open().
idx | Zero based index of requested frame entry.
[out] | dstbuf | Pointer to char array which gets filled (must hold min. 'buflen' bytes).
buflen | How many bytes should get returned.
Returns
Status of operation; '=0' means successful, '!=0' otherwise.
int BL_DLLIMPORT BL_getFrameNrForFrameId | ( | BL_HANDLE | handle,
 |  | unsigned char | frameId
 | ) |  |
int BL_DLLIMPORT BL_getNodeCount ( BL_HANDLE handle )
Parameters
[in] handle Handle representing the connection; returned previously by BL_open().
Returns
Number of nodes set by lnode message.
int BL_DLLIMPORT BL_getNodeName | ( | BL_HANDLE | handle,
 |  | int | idx,
 |  | char * | dstbuf,
 |  | int | buflen
 | ) |  |
Parameters
[in] | handle | Handle representing the connection; returned previously by BL_open().
idx | Zero based index of requested node entry.
[out] | dstbuf | Pointer to char array which gets filled (must hold min. 'buflen' bytes).
buflen | How many bytes should get returned.
Returns
Status of operation; '=0' means successful, '!=0' otherwise.
int BL_DLLIMPORT BL_getSignalCount ( BL_HANDLE handle )
Parameters
[in] handle Handle representing the connection; returned previously by BL_open().
Returns
Number of signals set by lsignal message.
int BL_DLLIMPORT BL_getSignalInFrame | ( | BL_HANDLE | handle,
 |  | int | frameIndex,
 |  | int | signalIndex
 | ) |  |
int BL_DLLIMPORT BL_getSignalName | ( | BL_HANDLE | handle,
 |  | int | idx,
 |  | char * | dstbuf,
 |  | int | buflen
 | ) |  |
Parameters
[in] | handle | Handle representing the connection; returned previously by BL_open().
idx | Zero based index of requested signal entry.
[out] | dstbuf | Pointer to char array which gets filled (must hold min. 'buflen' bytes).
buflen | How many bytes should get returned.
Returns
Status of operation; '>=0' means successful and indicates the amount of copied bytes, excluding the terminating '\0'. Values blow 0 indicate errors.
int BL_DLLIMPORT BL_getSignalsInFrameCount | ( | BL_HANDLE | handle,
 |  | int | idx
 | ) |  |
Parameters
[in] | handle | Handle representing the connection; returned previously by BL_open().
idx | Zero based index of requested frame entry.
Returns
Number of signals set by lsignal message.
Generated on Fri May 30 2025 17:16:14 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: Legacy SDF Functions

Functions
Legacy SDF Functions
Legacy Parts

Detailed Description

The following structures are used to retrieve data from a SDF loaded to a BabyLIN. As these functions requeire a loaded SDF onto a BabyLIN, a existing connection to a BabyLIN is mendatory. Please see the new SDF API in SDF functions on how to handle SDFs without a BabyLIN connection.

Functions

int BL_DLLIMPORT | BL_SDF_getNodeNr (BL_HANDLE handle, const char *name)
int BL_DLLIMPORT | BL_SDF_getSignalNr (BL_HANDLE handle, const char *name)
int BL_DLLIMPORT | BL_SDF_getFrameNr (BL_HANDLE handle, const char *name)
int BL_DLLIMPORT | BL_SDF_getScheduleNr (BL_HANDLE handle, const char *name)
int BL_DLLIMPORT | BL_SDF_getNumSchedules (BL_HANDLE handle)
CPCHAR BL_DLLIMPORT | BL_SDF_getScheduleName (BL_HANDLE handle, int schedule_nr)
int BL_DLLIMPORT | BL_SDF_getMacroNr (BL_HANDLE handle, const char *name)

Function Documentation

int BL_DLLIMPORT BL_SDF_getFrameNr | ( | BL_HANDLE | handle,
 |  | const char * | name
 | ) |  |
Parameters
handle | Handle representing the connection; returned previously by BL_open().
name | Name of the frame.
Returns
Returns the frame's number or -1 if there's no frame with specified name. Even smaller numbers designate error codes as defined in BabyLIN.h.
int BL_DLLIMPORT BL_SDF_getMacroNr | ( | BL_HANDLE | handle,
 |  | const char * | name
 | ) |  |
Parameters
handle | Handle representing the connection; returned previously by BL_open().
name | Name of the macro.
Returns
Returns the macro's number or -1 if there's no macro with specified name. Even smaller numbers designate error codes as defined in BabyLIN.h.
int BL_DLLIMPORT BL_SDF_getNodeNr | ( | BL_HANDLE | handle,
 |  | const char * | name
 | ) |  |
Parameters
handle | Handle representing the connection; returned previously by BL_open().
name | Name of the node.
Returns
Returns the node's number or -1 if there's no signal with specified name. Even smaller numbers designate error codes as defined in BabyLIN.h.
int BL_DLLIMPORT BL_SDF_getNumSchedules ( BL_HANDLE handle )
Parameters
handle Handle representing the connection; returned previously by BL_open().
Returns
Returns the number of schedule tablesname or 0 if there's no schedule defined.
CPCHAR BL_DLLIMPORT BL_SDF_getScheduleName | ( | BL_HANDLE | handle,
 |  | int | schedule_nr
 | ) |  |
Parameters
handle | Handle representing the connection; returned previously by BL_open().
schedule_nr | Index of the schedule.
Returns
Returns the schedule's name or empty string if there's no schedule with specified index.
int BL_DLLIMPORT BL_SDF_getScheduleNr | ( | BL_HANDLE | handle,
 |  | const char * | name
 | ) |  |
Parameters
handle | Handle representing the connection; returned previously by BL_open().
name | Name of the schedule.
Returns
Returns the schedule's number or -1 if there's no schedule with specified name. Even smaller numbers designate error codes as defined in BabyLIN.h.
int BL_DLLIMPORT BL_SDF_getSignalNr | ( | BL_HANDLE | handle,
 |  | const char * | name
 | ) |  |
Parameters
handle | Handle representing the connection; returned previously by BL_open().
name | Name of the signal.
Returns
Returns the signal's number or -1 if there's no signal with specified name. Even smaller numbers designate error codes as defined in BabyLIN.h.
Generated on Fri May 30 2025 17:16:14 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: Globals

  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
  • Macros
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
Here is a list of all functions, variables, defines, enums, and typedefs with links to the files they belong to:

- a -

  • ADD_LIST : BabyLIN_RP1210.h
  • ADHOC_PROTOCOL_TYPE : BabyLINCAN_types.h
  • BL_ADHOC_HANDLE : BabyLINReturncodes.h
  • BL_ANSWER_DATA_NOT_EXISTENT : BabyLINReturncodes.h
  • BL_ANSWER_TYPE : BabyLINReturncodes.h
  • BL_ANSWER_TYPE_BIN : BabyLINReturncodes.h
  • BL_ANSWER_TYPE_FLOAT : BabyLINReturncodes.h
  • BL_ANSWER_TYPE_INT : BabyLINReturncodes.h
  • BL_ANSWER_TYPE_INT64 : BabyLINReturncodes.h
  • BL_ANSWER_TYPE_STR : BabyLINReturncodes.h
  • BL_ANSWER_TYPE_UNKNOWN : BabyLINReturncodes.h
  • BLC_AdHoc_CreateProtocol() : BabyLINCAN.h
  • BLC_AdHoc_CreateService() : BabyLINCAN.h
  • BLC_AdHoc_DefaultExecute() : BabyLINCAN.h
  • BLC_AdHoc_DefaultProtocol() : BabyLINCAN.h
  • BLC_AdHoc_DefaultService() : BabyLINCAN.h
  • BLC_AdHoc_DeleteAllProtocol() : BabyLINCAN.h
  • BLC_AdHoc_DeleteAllService() : BabyLINCAN.h
  • BLC_AdHoc_DeleteProtocol() : BabyLINCAN.h
  • BLC_AdHoc_DeleteService() : BabyLINCAN.h
  • BLC_AdHoc_Execute() : BabyLINCAN.h
  • BLC_ADHOC_EXECUTE_RUNNING : BabyLINReturncodes.h
  • BLC_AdHoc_ExecuteAsync() : BabyLINCAN.h
  • BLC_AdHoc_GetResponse() : BabyLINCAN.h
  • BLC_AdHoc_GetState() : BabyLINCAN.h
  • BLC_ADHOC_INVALID_HANDLE : BabyLINReturncodes.h
  • BLC_ADHOC_MCR_OFFSET : BabyLINReturncodes.h
Generated on Fri May 30 2025 17:16:14 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: Globals

  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
  • Macros
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
Here is a list of all functions, variables, defines, enums, and typedefs with links to the files they belong to:

- b -

  • BIT0 : BabyLIN_RP1210.h
  • BIT1 : BabyLIN_RP1210.h
  • BIT2 : BabyLIN_RP1210.h
  • BIT3 : BabyLIN_RP1210.h
  • BIT4 : BabyLIN_RP1210.h
  • BIT7 : BabyLIN_RP1210.h
  • BITE : BabyLIN_RP1210.h
  • BITS : BabyLIN_RP1210.h
  • BL_BUFFER_TOO_SMALL : BabyLINReturncodes.h
  • BL_buserror_callback_func : BabyLIN.h
  • BLOCK_INFINITE : BabyLIN_RP1210.h
  • BLOCK_UNTIL_DONE : BabyLIN_RP1210.h
  • BLOCKING_IO : BabyLIN_RP1210.h
  • BYTE1_OF_INT4 : BabyLIN_RP1210.h
  • BYTE2_0F_INT4 : BabyLIN_RP1210.h
  • BYTE3_0F_INT4 : BabyLIN_RP1210.h
  • BYTEO_OF_INT4 : BabyLIN_RP1210.h
Generated on Fri May 30 2025 17:16:14 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: Globals

  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
  • Macros
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
Here is a list of all functions, variables, defines, enums, and typedefs with links to the files they belong to:

- c -

  • BL_close() : BabyLIN.h
  • BL_closeAll() : BabyLIN.h
  • BL_CMD_NOT_SUPPORTED : BabyLINReturncodes.h
  • BL_CMD_SYNTAX_ERROR : BabyLINReturncodes.h
  • BLC_close() : BabyLINCAN.h
  • BLC_closeAll() : BabyLINCAN.h
  • BLC_convertUrl() : BabyLINCAN.h
  • BLC_createHandle() : BabyLIN_UnifiedAccess.h
  • CHANGE_BAUD_NOW : BabyLIN_RP1210.h
  • CONNECTED : BabyLIN_RP1210.h
  • CONNECTED_WIRED : BabyLIN_RP1210.h
  • CONNECTED_WIRELESS : BabyLIN_RP1210.h
  • CONVERTED_MODE : BabyLIN_RP1210.h
  • CPCHAR : BabyLINSDF.h , BabyLINReturncodes.h
Generated on Fri May 30 2025 17:16:14 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: Globals

  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
  • Macros
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
Here is a list of all functions, variables, defines, enums, and typedefs with links to the files they belong to:

- d -

  • BL_debug_callback_func : BabyLIN.h
  • BL_DLLIMPORT : BabyLINReturncodes.h
  • BL_DOWNLOAD_IN_PROGRESS : BabyLINReturncodes.h
  • BL_downloadSDF() : BabyLIN.h
  • BL_DP_MSG_ERROR : BabyLINReturncodes.h
  • BL_dtl_request_callback_func : BabyLIN.h
  • BL_dtl_response_callback_func : BabyLIN.h
  • BL_DTL_STATUS : BabyLINReturncodes.h
  • BLC_debug_callback_func : BabyLINCAN_types.h
  • BLC_debug_callback_func_ptr : BabyLINCAN_types.h
  • BLC_decodeSignal() : BabyLINCAN.h
  • BLC_destroy() : BabyLIN_UnifiedAccess.h
  • BLC_discover() : BabyLIN_UnifiedAccess.h
  • BLC_dmDelay() : BabyLINCAN.h
  • BLC_dmPrepare() : BabyLINCAN.h
  • BLC_dmPulse() : BabyLINCAN.h
  • BLC_dmRead() : BabyLINCAN.h
  • BLC_dmReadTimeout() : BabyLINCAN.h
  • BLC_dmReportConfig() : BabyLINCAN.h
  • BLC_dmStart() : BabyLINCAN.h
  • BLC_dmStop() : BabyLINCAN.h
  • BLC_dmWrite() : BabyLINCAN.h
  • BLC_downloadSDF() : BabyLINCAN.h
  • BLC_dtl_request_callback_func : BabyLINCAN_types.h
  • BLC_dtl_request_callback_func_ptr : BabyLINCAN_types.h
  • BLC_dtl_response_callback_func : BabyLINCAN_types.h
  • BLC_dtl_response_callback_func_ptr : BabyLINCAN_types.h
  • DEPRECATED : BabyLINReturncodes.h
  • DESTROY_LIST : BabyLIN_RP1210.h
Generated on Fri May 30 2025 17:16:14 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: Globals

  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
  • Macros
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
Here is a list of all functions, variables, defines, enums, and typedefs with links to the files they belong to:

- e -

  • BL_encodeSignal() : BabyLIN.h
  • BL_ENCODING_NOT_EXISTENT : BabyLINReturncodes.h
  • BL_ERR_CFG_REFERENCE : BabyLINReturncodes.h
  • BL_ERR_CHANNEL : BabyLINReturncodes.h
  • BL_ERR_CONDITION : BabyLINReturncodes.h
  • BL_ERR_CRC : BabyLINReturncodes.h
  • BL_ERR_DATAFLASH : BabyLINReturncodes.h
  • BL_ERR_DATAFLASH_INDEX : BabyLINReturncodes.h
  • BL_ERR_DATAFLASH_INIT : BabyLINReturncodes.h
  • BL_ERR_DATAFLASH_NOSPACE : BabyLINReturncodes.h
  • BL_ERR_DP_ARRAY_SIZE : BabyLINReturncodes.h
  • BL_ERR_DP_CORRUPT : BabyLINReturncodes.h
  • BL_ERR_DP_MAPPING : BabyLINReturncodes.h
  • BL_ERR_DP_NAME_TO_LONG : BabyLINReturncodes.h
  • BL_ERR_DP_NAME_TO_SHORT : BabyLINReturncodes.h
  • BL_ERR_DP_NONAME : BabyLINReturncodes.h
  • BL_ERR_DP_PARSE : BabyLINReturncodes.h
  • BL_ERR_DP_PARSE_TOP : BabyLINReturncodes.h
  • BL_ERR_DP_SEQUENCE : BabyLINReturncodes.h
  • BL_ERR_EVENT_REFERENCE : BabyLINReturncodes.h
  • BL_ERR_FRAME_REFERENCE : BabyLINReturncodes.h
  • BL_ERR_FRAMEID_LOOKUP_FAILED : BabyLINReturncodes.h
  • BL_ERR_HEAP_EXHAUSTED : BabyLINReturncodes.h
  • BL_ERR_LICENCE : BabyLINReturncodes.h
  • BL_ERR_MACRO_REFERENCE : BabyLINReturncodes.h
  • BL_ERR_MACROSEL_REFERENCE : BabyLINReturncodes.h
  • BL_ERR_NOT_INITIALIZED : BabyLINReturncodes.h
  • BL_ERR_NULLPOINTER : BabyLINReturncodes.h
  • BL_ERR_PARAMCOUNT : BabyLINReturncodes.h
  • BL_ERR_PARAMVALUE : BabyLINReturncodes.h
  • BL_ERR_SDF_HEADER : BabyLINReturncodes.h
  • BL_ERR_SECTION_MAPPING : BabyLINReturncodes.h
  • BL_ERR_SECTION_TYPE : BabyLINReturncodes.h
  • BL_ERR_SERVICEQUEUE_EXHAUSTED : BabyLINReturncodes.h
  • BL_ERR_SIG_REFERENCE : BabyLINReturncodes.h
  • BL_ERR_SIGFUNC_REFERENCE : BabyLINReturncodes.h
  • BL_ERR_UNDEF : BabyLINReturncodes.h
  • BL_ERR_UNKNOWN_CMD : BabyLINReturncodes.h
  • BL_EXCEPTION_FILTER_ATTR : BabyLINCAN.h
  • BLC_encodeSignal() : BabyLINCAN.h
  • BLC_error_callback_func : BabyLINCAN_types.h
  • BLC_error_callback_func_ptr : BabyLINCAN_types.h
  • BLC_event_callback_func : BabyLINCAN_types.h
  • BLC_event_callback_func_ptr : BabyLINCAN_types.h
  • BLC_execute() : BabyLIN_UnifiedAccess.h
  • BLC_execute_async() : BabyLIN_UnifiedAccess.h
  • ECHO_OFF : BabyLIN_RP1210.h
  • ECHO_ON : BabyLIN_RP1210.h
  • ERR_ADAPTER_NOT_RESPONDING : BabyLIN_RP1210.h
  • ERR_ADDRESS_CLAIM_FAILED : BabyLIN_RP1210.h
  • ERR_ADDRESS_LOST : BabyLIN_RP1210.h
  • ERR_ADDRESS_NEVER_CLAIMED : BabyLIN_RP1210.h
  • ERR_ADDRESS_RELEASE_FAILED : BabyLIN_RP1210.h
  • ERR_BABYLIN_DEVICE_NOT_FOUND : BabyLIN_RP1210.h
  • ERR_BLOCK_NOT_ALLOWED : BabyLIN_RP1210.h
  • ERR_BUS_OFF : BabyLIN_RP1210.h
  • ERR_CAN_BAUD_SET_NONSTANDARD : BabyLIN_RP1210.h
  • ERR_CANNOT_CLAIM_BROADCAST_ADDRESS : BabyLIN_RP1210.h
  • ERR_CANNOT_SET_CAN_BAUDRATE : BabyLIN_RP1210.h
  • ERR_CANNOT_SET_PRIORITY : BabyLIN_RP1210.h
  • ERR_CHANGE_MODE_FAILED : BabyLIN_RP1210.h
  • ERR_CLIENT_ALREADY_CONNECTED : BabyLIN_RP1210.h
  • ERR_CLIENT_AREA_FULL : BabyLIN_RP1210.h
  • ERR_CLIENT_DISCONNECTED : BabyLIN_RP1210.h
  • ERR_CODE_NOT_FOUND : BabyLIN_RP1210.h
  • ERR_COMM_DEVICE_IN_USE : BabyLIN_RP1210.h
  • ERR_COMMAND_NOT_SUPPORTED : BabyLIN_RP1210.h
  • ERR_COMMAND_QUEUE_IS_FULL : BabyLIN_RP1210.h
  • ERR_COMMAND_TIMED_OUT : BabyLIN_RP1210.h
  • ERR_CONNECT_NOT_ALLOWED : BabyLIN_RP1210.h
  • ERR_COULD_NOT_TX_ADDRESS_CLAIMED : BabyLIN_RP1210.h
  • ERR_DATA_LINK_CONFLICT : BabyLIN_RP1210.h
  • ERR_DEVICE_IN_USE : BabyLIN_RP1210.h
  • ERR_DEVICE_NOT_SUPPORTED : BabyLIN_RP1210.h
  • ERR_DLL_NOT_INITIALIZED : BabyLIN_RP1210.h
  • ERR_FREE_MEMORY : BabyLIN_RP1210.h
  • ERR_HARDWARE_NOT_RESPONDING : BabyLIN_RP1210.h
  • ERR_HARDWARE_NOT_SUPPORTED : BabyLIN_RP1210.h
  • ERR_HARDWARE_STATUS_CHANGE : BabyLIN_RP1210.h
  • ERR_I5015765_BAUD_SET_NONSTANDARD : BabyLIN_RP1210.h
  • ERR_INI_FILE_NOT_IN_WIN_DIR : BabyLIN_RP1210.h
  • ERR_INI_KEY_NOT_FOUND : BabyLIN_RP1210.h
  • ERR_INI_SECTION_NOT_FOUND : BabyLIN_RP1210.h
  • ERR_INVALID_CLIENT_ID : BabyLIN_RP1210.h
  • ERR_INVALID_COMMAND : BabyLIN_RP1210.h
  • ERR_INVALID_DEVICE : BabyLIN_RP1210.h
  • ERR_INVALID_IOCTL_ID : BabyLIN_RP1210.h
  • ERR_INVALID_KEY_STRING : BabyLIN_RP1210.h
  • ERR_INVALID_PORT_PARAM : BabyLIN_RP1210.h
  • ERR_INVALID_PROTOCOL : BabyLIN_RP1210.h
  • ERR_J1708_BAUD_SET_NONSTANDARD : BabyLIN_RP1210.h
  • ERR_J1939_BAUD_SET_NONSTANDARD : BabyLIN_RP1210.h
  • ERR_MAX_FILTERS_EXCEEDED : BabyLIN_RP1210.h
  • ERR_MAX_NOTIFY_EXCEEDED : BabyLIN_RP1210.h
  • ERR_MESSAGE_NOT_SENT : BabyLIN_RP1210.h
  • ERR_MESSAGE_TOO_LONG : BabyLIN_RP1210.h
  • ERR_MULTIPLE_CLIENTS_CONNECTED : BabyLIN_RP1210.h
  • ERR_MULTIPLE_CONNECTIONS_NOT_ALLOWED_NOW : BabyLIN_RP1210.h
  • ERR_NOT_ENOUGH_MEMORY : BabyLIN_RP1210.h
  • ERR_NULL_PARAMETER : BabyLIN_RP1210.h
  • ERR_OS_NOT_SUPPORTED : BabyLIN_RP1210.h
  • ERR_OUT_OF_ADDRESS_RESOURCES : BabyLIN_RP1210.h
  • ERR_RX_QUEUE_CORRUPT : BabyLIN_RP1210.h
  • ERR_RX_QUEUE_FULL : BabyLIN_RP1210.h
  • ERR_TX_QUEUE_CORRUPT : BabyLIN_RP1210.h
  • ERR_TX_QUEUE_FULL : BabyLIN_RP1210.h
  • ERR_TXMESSAGE_STATUS : BabyLIN_RP1210.h
  • ERR_WINDOW_HANDLE_REQUIRED : BabyLIN_RP1210.h
  • exception_filter : BabyLINCAN.h
  • EXTENDED_CAN : BabyLIN_RP1210.h
  • EXTENDED_CAN_ISO15765_EXTENDED : BabyLIN_RP1210.h
Generated on Fri May 30 2025 17:16:14 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: Globals

  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
  • Macros
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
Here is a list of all functions, variables, defines, enums, and typedefs with links to the files they belong to:

- f -

  • BL_FILE_ERROR : BabyLINReturncodes.h
  • BL_flush() : BabyLIN.h
  • BL_frame_callback_func : BabyLIN.h
  • BLC_flush() : BabyLINCAN.h
  • BLC_frame_callback_func : BabyLINCAN_types.h
  • BLC_frame_callback_func_ptr : BabyLINCAN_types.h
  • FALSE : BabyLIN_RP1210.h
  • FAST_INIT : BabyLIN_RP1210.h
  • FILTER_DESTINATION : BabyLIN_RP1210.h
  • FILTER_EXCLUSIVE : BabyLIN_RP1210.h
  • FILTER_INCLUSIVE : BabyLIN_RP1210.h
  • FILTER_PASS_ALL : BabyLIN_RP1210.h
  • FILTER_PASS_NONE : BabyLIN_RP1210.h
  • FILTER_PASS_SOME : BabyLIN_RP1210.h
  • FILTER_PGN : BabyLIN_RP1210.h
  • FILTER_SOURCE : BabyLIN_RP1210.h
  • FIVE_BAUD_INIT : BabyLIN_RP1210.h
Generated on Fri May 30 2025 17:16:14 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: Globals

  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
  • Macros
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
Here is a list of all functions, variables, defines, enums, and typedefs with links to the files they belong to:

- g -

  • BL_getAnswerByIndex() : BabyLIN.h
  • BL_getAnswerByName() : BabyLIN.h
  • BL_getAnswerTypeByIndex() : BabyLIN.h
  • BL_getAnswerTypeByName() : BabyLIN.h
  • BL_getDTLRequestStatus() : BabyLIN.h
  • BL_getDTLResponseStatus() : BabyLIN.h
  • BL_getFrameCount() : BabyLIN.h
  • BL_getFrameDetails() : BabyLIN.h
  • BL_getFrameName() : BabyLIN.h
  • BL_getFrameNrForFrameId() : BabyLIN.h
  • BL_getLastError() : BabyLIN.h
  • BL_getLastFrame() : BabyLIN.h
  • BL_getNextBusError() : BabyLIN.h
  • BL_getNextDTLRequest() : BabyLIN.h
  • BL_getNextDTLResponse() : BabyLIN.h
  • BL_getNextFrame() : BabyLIN.h
  • BL_getNextFrameTimeout() : BabyLIN.h
  • BL_getNextSignal() : BabyLIN.h
  • BL_getNodeCount() : BabyLIN.h
  • BL_getNodeName() : BabyLIN.h
  • BL_getRawSlaveResponse() : BabyLIN.h
  • BL_getSignalArray() : BabyLIN.h
  • BL_getSignalArrayByName() : BabyLIN.h
  • BL_getSignalCount() : BabyLIN.h
  • BL_getSignalDataFromFrame() : BabyLIN.h
  • BL_getSignalInFrame() : BabyLIN.h
  • BL_getSignalName() : BabyLIN.h
  • BL_getSignalsInFrame() : BabyLIN.h
  • BL_getSignalsInFrameCount() : BabyLIN.h
  • BL_getSignalValue() : BabyLIN.h
  • BL_getSignalValueByName() : BabyLIN.h
  • BL_getTargetID() : BabyLIN.h
  • BL_getVersion() : BabyLIN.h
  • BL_getVersionString() : BabyLIN.h
  • BLC_getAnswerByIndex() : BabyLINCAN.h
  • BLC_getAnswerByName() : BabyLINCAN.h
  • BLC_getAnswerNameByIndex() : BabyLINCAN.h
  • BLC_getAnswerTypeByIndex() : BabyLINCAN.h
  • BLC_getAnswerTypeByName() : BabyLINCAN.h
  • BLC_getBabyLinPorts() : BabyLINCAN.h
  • BLC_getBabyLinPortsTimout() : BabyLINCAN.h
  • BLC_getBinary() : BabyLIN_UnifiedAccess.h
  • BLC_getChannelCount() : BabyLINCAN.h
  • BLC_getChannelHandle() : BabyLINCAN.h
  • BLC_getChannelInfo() : BabyLINCAN.h
  • BLC_getChannelSectionDescription() : BabyLINCAN.h
  • BLC_getDetailedErrorString() : BabyLINCAN.h
  • BLC_getDTLRequestStatus() : BabyLINCAN.h
  • BLC_getDTLResponseStatus() : BabyLINCAN.h
  • BLC_getErrorString() : BabyLINCAN.h
  • BLC_getExtendedVersion() : BabyLINCAN.h
  • BLC_getFrameCount() : BabyLINCAN.h
  • BLC_getFrameDetails() : BabyLINCAN.h
  • BLC_getFrameIdForFrameNr() : BabyLINCAN.h
  • BLC_getFrameName() : BabyLINCAN.h
  • BLC_getFrameNrForFrameId() : BabyLINCAN.h
  • BLC_getHWType() : BabyLINCAN.h
  • BLC_getLastError() : BabyLINCAN.h
  • BLC_getLastFrame() : BabyLINCAN.h
  • BLC_getMacroResultString() : BabyLINCAN.h
  • BLC_getNextBusError() : BabyLINCAN.h
  • BLC_getNextDTLRequest() : BabyLINCAN.h
  • BLC_getNextDTLResponse() : BabyLINCAN.h
  • BLC_getNextFrame() : BabyLINCAN.h
  • BLC_getNextFrames() : BabyLINCAN.h
  • BLC_getNextFramesTimeout() : BabyLINCAN.h
  • BLC_getNextFrameTimeout() : BabyLINCAN.h
  • BLC_getNextJumboFrame() : BabyLINCAN.h
  • BLC_getNextJumboFrames() : BabyLINCAN.h
  • BLC_getNextJumboFramesTimeout() : BabyLINCAN.h
  • BLC_getNextJumboFrameTimeout() : BabyLINCAN.h
  • BLC_getNextSignal() : BabyLINCAN.h
  • BLC_getNextSignals() : BabyLINCAN.h
  • BLC_getNextSignalsForNumber() : BabyLINCAN.h
  • BLC_getNodeCount() : BabyLINCAN.h
  • BLC_getNodeForSignal() : BabyLINCAN.h
  • BLC_getNodeName() : BabyLINCAN.h
  • BLC_getRawSlaveResponse() : BabyLINCAN.h
  • BLC_getSDFInfo() : BabyLINCAN.h
  • BLC_getSectionInfo() : BabyLINCAN.h
  • BLC_getSignalArray() : BabyLINCAN.h
  • BLC_getSignalArrayByName() : BabyLINCAN.h
  • BLC_getSignalArrayWithTimestamp() : BabyLINCAN.h
  • BLC_getSignalCount() : BabyLINCAN.h
  • BLC_getSignalInFrame() : BabyLINCAN.h
  • BLC_getSignalName() : BabyLINCAN.h
  • BLC_getSignalsInFrame() : BabyLINCAN.h
  • BLC_getSignalsInFrameCount() : BabyLINCAN.h
  • BLC_getSignalSize() : BabyLINCAN.h
  • BLC_getSignalValue() : BabyLINCAN.h
  • BLC_getSignalValueByName() : BabyLINCAN.h
  • BLC_getSignalValueWithTimestamp() : BabyLINCAN.h
  • BLC_getSignedNumber() : BabyLIN_UnifiedAccess.h
  • BLC_getTableColumnCount() : BabyLINCAN.h
  • BLC_getTableCount() : BabyLINCAN.h
  • BLC_getTableRowCount() : BabyLINCAN.h
  • BLC_getTargetID() : BabyLINCAN.h
  • BLC_getUnsignedNumber() : BabyLIN_UnifiedAccess.h
  • BLC_getVersion() : BabyLINCAN.h
  • BLC_getVersionString() : BabyLINCAN.h
  • BLCns_getChannelInfo() : BabyLINCAN_nostruct.h
  • BLCns_getLastFrame() : BabyLINCAN_nostruct.h
  • BLCns_getNextBusError() : BabyLINCAN_nostruct.h
  • BLCns_getNextDTLRequest() : BabyLINCAN_nostruct.h
  • BLCns_getNextDTLResponse() : BabyLINCAN_nostruct.h
  • BLCns_getNextFrame() : BabyLINCAN_nostruct.h
  • BLCns_getNextFrames() : BabyLINCAN_nostruct.h
  • BLCns_getNextFramesTimeout() : BabyLINCAN_nostruct.h
  • BLCns_getNextFrameTimeout() : BabyLINCAN_nostruct.h
  • BLCns_getNextJumboFrame() : BabyLINCAN_nostruct.h
  • BLCns_getNextJumboFrames() : BabyLINCAN_nostruct.h
  • BLCns_getNextJumboFramesTimeout() : BabyLINCAN_nostruct.h
  • BLCns_getNextJumboFrameTimeout() : BabyLINCAN_nostruct.h
  • BLCns_getNextSignal() : BabyLINCAN_nostruct.h
  • BLCns_getNextSignals() : BabyLINCAN_nostruct.h
  • BLCns_getNextSignalsForNumber() : BabyLINCAN_nostruct.h
  • BLCns_getSDFInfo() : BabyLINCAN_nostruct.h
  • BLCns_getSectionInfo() : BabyLINCAN_nostruct.h
  • BLCns_getTargetID() : BabyLINCAN_nostruct.h
  • BLCns_getVersionString() : BabyLINCAN_nostruct.h
  • GET_CONFIG : BabyLIN_RP1210.h
Generated on Fri May 30 2025 17:16:14 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: Globals

  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
  • Macros
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
Here is a list of all functions, variables, defines, enums, and typedefs with links to the files they belong to:

- h -

  • BL_HANDLE : BabyLINReturncodes.h , BabyLINSDF.h
  • BL_HANDLE_INVALID : BabyLINReturncodes.h
  • HIBYTE_OF_WORD : BabyLIN_RP1210.h
  • HINIBBLE_OF_CHAR : BabyLIN_RP1210.h
  • HIWORD_OF_INT4 : BabyLIN_RP1210.h
  • HWND : BabyLIN_RP1210.h
Generated on Fri May 30 2025 17:16:14 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: Globals

  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
  • Macros
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
Here is a list of all functions, variables, defines, enums, and typedefs with links to the files they belong to:

- i -

  • BL_INVALID_MODE : BabyLINReturncodes.h
  • BL_isSignalArray() : BabyLIN.h
  • BLC_isSDFOnDevice() : BabyLINCAN.h
  • BLC_isSignalArray() : BabyLINCAN.h
  • BLC_isSignalEmulated() : BabyLINCAN.h
  • ISO15765_ACTUAL_MESSAGE : BabyLIN_RP1210.h
  • ISO15765_CONFIRM : BabyLIN_RP1210.h
  • ISO15765_FF_INDICATION : BabyLIN_RP1210.h
  • ISO15765_RX_ERROR_INDICATION : BabyLIN_RP1210.h
Generated on Fri May 30 2025 17:16:14 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: Globals

  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
  • Macros
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
Here is a list of all functions, variables, defines, enums, and typedefs with links to the files they belong to:

- j -

  • BLC_jumboframe_callback_func : BabyLINCAN_types.h
  • BLC_jumboframe_callback_func_ptr : BabyLINCAN_types.h
Generated on Fri May 30 2025 17:16:14 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: Globals

  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
  • Macros
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
Here is a list of all functions, variables, defines, enums, and typedefs with links to the files they belong to:

- l -

  • BL_lastAnswerHasData() : BabyLIN.h
  • BL_loadSDF() : BabyLIN.h
  • BLC_lastAnswerHasData() : BabyLINCAN.h
  • BLC_loadLDF() : BabyLINCAN.h
  • BLC_loadSDF() : BabyLINCAN.h
  • BLC_log_callback_func_ptr : BabyLINCAN_types.h
  • BLC_loggingAddComment() : BabyLINCAN.h
  • BLC_loggingStart() : BabyLINCAN.h
  • BLC_loggingStop() : BabyLINCAN.h
  • BLC_loggingStopGlobal() : BabyLINCAN.h
  • BLC_lua_print_func_ptr : BabyLINCAN_types.h
  • BLC_LUA_RUNTIME_ERROR : BabyLINReturncodes.h
  • LD_COMPLETED : BabyLINReturncodes.h
  • LD_FAILED : BabyLINReturncodes.h
  • LD_IN_PROGRESS : BabyLINReturncodes.h
  • LIST_LENGTH : BabyLIN_RP1210.h
  • LOBYTE_OF_WORD : BabyLIN_RP1210.h
  • LONIBBLE_OF_CHAR : BabyLIN_RP1210.h
  • LOWORD_OF_INT4 : BabyLIN_RP1210.h
Generated on Fri May 30 2025 17:16:14 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: Globals

  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
  • Macros
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
Here is a list of all functions, variables, defines, enums, and typedefs with links to the files they belong to:

- m -

  • BL_MACRO_ERRCODE_IN_RESULT : BabyLINReturncodes.h
  • BL_MACRO_EXCEPTIONCODE_IN_RESULT : BabyLINReturncodes.h
  • BL_MACRO_NEVER_EXECUTED : BabyLINReturncodes.h
  • BL_MACRO_OTHER_RUNNING : BabyLINReturncodes.h
  • BL_MACRO_SAME_RUNNING : BabyLINReturncodes.h
  • BL_MACRO_START_FAIL : BabyLINReturncodes.h
  • BL_MACRO_STILL_RUNNING : BabyLINReturncodes.h
  • BL_mon_set() : BabyLIN.h
  • BL_mon_set_xmit() : BabyLIN.h
  • BL_mon_xmit() : BabyLIN.h
  • BLC_macro_result() : BabyLINCAN.h
  • BLC_macrostate_callback_func : BabyLINCAN_types.h
  • BLC_macrostate_callback_func_ptr : BabyLINCAN_types.h
  • BLC_mon_set() : BabyLINCAN.h
  • BLC_mon_set_xmit() : BabyLINCAN.h
  • BLC_mon_xmit() : BabyLINCAN.h
  • MAX_ISO15765_MESSAGE_LENGTH : BabyLIN_RP1210.h
  • MAX_J1708_MESSAGE_LENGTH : BabyLIN_RP1210.h
  • MAX_J1939_MESSAGE_LENGTH : BabyLIN_RP1210.h
  • MSG_FIRST_CHANGE_BAUD : BabyLIN_RP1210.h
Generated on Fri May 30 2025 17:16:14 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: Globals

  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
  • Macros
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
Here is a list of all functions, variables, defines, enums, and typedefs with links to the files they belong to:

- n -

  • BL_NO_ANSWER : BabyLINReturncodes.h
  • BL_NO_ANSWER_DATA : BabyLINReturncodes.h
  • BL_NO_CHANNELS_AVAILABLE : BabyLINReturncodes.h
  • BL_NO_CONNECTION : BabyLINReturncodes.h
  • BL_NO_DATA : BabyLINReturncodes.h
  • BL_NO_SDF : BabyLINReturncodes.h
  • N_BUFFER_OVERFLOW : BabyLIN_RP1210.h
  • N_ERROR : BabyLIN_RP1210.h
  • N_INVALID_FS : BabyLIN_RP1210.h
  • N_OK : BabyLIN_RP1210.h
  • N_TIMEOUT_A : BabyLIN_RP1210.h
  • N_TIMEOUT_Bs : BabyLIN_RP1210.h
  • N_TIMEOUT_C : BabyLIN_RP1210.h
  • N_UNEXP_PDU : BabyLIN_RP1210.h
  • N_WFT_OVRN : BabyLIN_RP1210.h
  • N_WRONG_SN : BabyLIN_RP1210.h
  • NO_ERRORS : BabyLIN_RP1210.h
  • NON_BLOCKING_IO : BabyLIN_RP1210.h
  • NOT_CONNECTED : BabyLIN_RP1210.h
  • NULL_WINDOW : BabyLIN_RP1210.h
Generated on Fri May 30 2025 17:16:14 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: Globals

  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
  • Macros
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
Here is a list of all functions, variables, defines, enums, and typedefs with links to the files they belong to:

- o -

  • BL_OK : BabyLINReturncodes.h
  • BL_open() : BabyLIN.h
  • BL_OPERATION_PENDING : BabyLINReturncodes.h
  • BLC_open() : BabyLINCAN.h
  • BLC_openNet() : BabyLINCAN.h
  • BLC_openPort() : BabyLINCAN.h
  • BLC_openUSB() : BabyLINCAN.h
  • BLC_overwriteCrashHandler() : BabyLINCAN.h
  • BLCns_openPort() : BabyLINCAN_nostruct.h
  • BLCns_openURL() : BabyLINCAN_nostruct.h
Generated on Fri May 30 2025 17:16:14 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: Globals

  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
  • Macros
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
Here is a list of all functions, variables, defines, enums, and typedefs with links to the files they belong to:

- p -

  • BL_PC_SIDE_ERRORS : BabyLINReturncodes.h
  • PASS_J1939_CLAIM_MESSAGES : BabyLIN_RP1210.h
Generated on Fri May 30 2025 17:16:14 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: Globals

  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
  • Macros
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
Here is a list of all functions, variables, defines, enums, and typedefs with links to the files they belong to:

- r -

  • BL_registerBusErrorCallback() : BabyLIN.h
  • BL_registerDebugCallback() : BabyLIN.h
  • BL_registerDTLRequestCallback() : BabyLIN.h
  • BL_registerDTLResponseCallback() : BabyLIN.h
  • BL_registerFrameCallback() : BabyLIN.h
  • BL_registerSignalCallback() : BabyLIN.h
  • BL_RESOURCE_ERROR : BabyLINReturncodes.h
  • BLC_registerDebugCallback() : BabyLINCAN.h
  • BLC_registerDTLRequestCallback() : BabyLINCAN.h
  • BLC_registerDTLResponseCallback() : BabyLINCAN.h
  • BLC_registerErrorCallback() : BabyLINCAN.h
  • BLC_registerEventCallback() : BabyLINCAN.h
  • BLC_registerFrameCallback() : BabyLINCAN.h
  • BLC_registerJumboFrameCallback() : BabyLINCAN.h
  • BLC_registerLuaErrorCallback() : BabyLINCAN.h
  • BLC_registerLuaPrintCallback() : BabyLINCAN.h
  • BLC_registerMacroStateCallback() : BabyLINCAN.h
  • BLC_registerSignalCallback() : BabyLINCAN.h
  • BLC_registerUserDataDebugCallback() : BabyLINCAN.h
  • BLC_registerUserDataDTLRequestCallback() : BabyLINCAN.h
  • BLC_registerUserDataDTLResponseCallback() : BabyLINCAN.h
  • BLC_registerUserDataErrorCallback() : BabyLINCAN.h
  • BLC_registerUserDataEvent() : BabyLINCAN.h
  • BLC_registerUserDataEventCallback() : BabyLINCAN.h
  • BLC_registerUserDataFrameCallback() : BabyLINCAN.h
  • BLC_registerUserDataJumboFrameCallback() : BabyLINCAN.h
  • BLC_registerUserDataLogCallback() : BabyLINCAN.h
  • BLC_registerUserDataMacroStateCallback() : BabyLINCAN.h
  • BLC_registerUserDataSignalCallback() : BabyLINCAN.h
  • BLC_releaseHandle() : BabyLIN_UnifiedAccess.h
  • BLC_Reset() : BabyLINCAN.h
  • BLC_RP1210_ListAvailableDevices() : BabyLIN_RP1210.h
  • BLC_RP1210_ListRegisteredDevices() : BabyLIN_RP1210.h
  • BLC_RP1210_RegisterAllAvailableDevices() : BabyLIN_RP1210.h
  • BLC_RP1210_RegisterDevice() : BabyLIN_RP1210.h
  • BLC_RP1210_UnregisterAllDevices() : BabyLIN_RP1210.h
  • BLC_RP1210_UnregisterDevice() : BabyLIN_RP1210.h
  • BLC_RP1210_UnregisterDeviceById() : BabyLIN_RP1210.h
  • BLC_runLuaCode() : BabyLINCAN.h
  • RAW_MODE : BabyLIN_RP1210.h
  • RECEIVE_OFF : BabyLIN_RP1210.h
  • RECEIVE_ON : BabyLIN_RP1210.h
  • REMOVE_ENTRY : BabyLIN_RP1210.h
  • RETURN_BEFORE_COMPLETION : BabyLIN_RP1210.h
  • RP1210_BAUD_1000k : BabyLIN_RP1210.h
  • RP1210_BAUD_125k : BabyLIN_RP1210.h
  • RP1210_BAUD_19200 : BabyLIN_RP1210.h
  • RP1210_BAUD_250k : BabyLIN_RP1210.h
  • RP1210_BAUD_38400 : BabyLIN_RP1210.h
  • RP1210_BAUD_500k : BabyLIN_RP1210.h
  • RP1210_BAUD_57600 : BabyLIN_RP1210.h
  • RP1210_BAUD_9600 : BabyLIN_RP1210.h
  • RP1210_Clear_ISO15765_Flow_Control : BabyLIN_RP1210.h
  • RP1210_ClientConnect() : BabyLIN_RP1210.h
  • RP1210_ClientDisconnect() : BabyLIN_RP1210.h
  • RP1210_Disallow_Further_Connections : BabyLIN_RP1210.h
  • RP1210_Echo_Transmitted_Messages : BabyLIN_RP1210.h
  • RP1210_Flush_Tx_Rx_Buffers : BabyLIN_RP1210.h
  • RP1210_Generic_Driver_Command : BabyLIN_RP1210.h
  • RP1210_Get_Protocol_Connection_Speed : BabyLIN_RP1210.h
  • RP1210_Get_Wireless_State : BabyLIN_RP1210.h
  • RP1210_GetErrorMsg() : BabyLIN_RP1210.h
  • RP1210_GetHardwareStatus() : BabyLIN_RP1210.h
  • RP1210_GetLastErrorMsg() : BabyLIN_RP1210.h
  • RP1210_Protect_J1939_Address : BabyLIN_RP1210.h
  • RP1210_ReadDetailedVersion() : BabyLIN_RP1210.h
  • RP1210_ReadMessage() : BabyLIN_RP1210.h
  • RP1210_ReadVersion() : BabyLIN_RP1210.h
  • RP1210_Release_J1939_Address : BabyLIN_RP1210.h
  • RP1210_Reset_Device : BabyLIN_RP1210.h
  • RP1210_SendCommand() : BabyLIN_RP1210.h
  • RP1210_SendMessage() : BabyLIN_RP1210.h
  • RP1210_Set_All_Filters_States_to_Discard : BabyLIN_RP1210.h
  • RP1210_Set_All_Filters_States_to_Pass : BabyLIN_RP1210.h
  • RP1210_Set_BlockTimeout : BabyLIN_RP1210.h
  • RP1210_Set_Broadcast_For_CAN : BabyLIN_RP1210.h
  • RP1210_Set_Broadcast_For_ISO15765 : BabyLIN_RP1210.h
  • RP1210_Set_Broadcast_For_ISO9141 : BabyLIN_RP1210.h
  • RP1210_Set_Broadcast_For_J1708 : BabyLIN_RP1210.h
  • RP1210_Set_Broadcast_For_J1850 : BabyLIN_RP1210.h
  • RP1210_Set_Broadcast_For_J1939 : BabyLIN_RP1210.h
  • RP1210_Set_Broadcast_For_KWP2000 : BabyLIN_RP1210.h
  • RP1210_Set_CAN_Baud : BabyLIN_RP1210.h
  • RP1210_Set_CAN_Filter_Type : BabyLIN_RP1210.h
  • RP1210_Set_ISO15765_Baud : BabyLIN_RP1210.h
  • RP1210_Set_ISO15765_Filter_Type : BabyLIN_RP1210.h
  • RP1210_Set_ISO15765_Flow_Control : BabyLIN_RP1210.h
  • RP1210_Set_ISO9141KWP2000_Mode : BabyLIN_RP1210.h
  • RP1210_Set_J1708_Baud : BabyLIN_RP1210.h
  • RP1210_Set_J1708_Filter_Type : BabyLIN_RP1210.h
  • RP1210_Set_J1708_Mode : BabyLIN_RP1210.h
  • RP1210_Set_J1850_Filter_Type : BabyLIN_RP1210.h
  • RP1210_Set_J1939_Baud : BabyLIN_RP1210.h
  • RP1210_Set_J1939_Filter_Type : BabyLIN_RP1210.h
  • RP1210_Set_J1939_Interpacket_Time : BabyLIN_RP1210.h
  • RP1210_Set_Message_Filtering_For_CAN : BabyLIN_RP1210.h
  • RP1210_Set_Message_Filtering_For_ISO15765 : BabyLIN_RP1210.h
  • RP1210_Set_Message_Filtering_For_J1708 : BabyLIN_RP1210.h
  • RP1210_Set_Message_Filtering_For_J1850 : BabyLIN_RP1210.h
  • RP1210_Set_Message_Filtering_For_J1939 : BabyLIN_RP1210.h
  • RP1210_Set_Message_Receive : BabyLIN_RP1210.h
  • RP1210_SetMaxErrorMsgSize : BabyLIN_RP1210.h
Generated on Fri May 30 2025 17:16:14 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: Globals

  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
  • Macros
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
Here is a list of all functions, variables, defines, enums, and typedefs with links to the files they belong to:

- s -

  • BL_SDF_getFrameNr() : BabyLINSDF.h
  • BL_SDF_getMacroNr() : BabyLINSDF.h
  • BL_SDF_getNodeNr() : BabyLINSDF.h
  • BL_SDF_getNumSchedules() : BabyLINSDF.h
  • BL_SDF_getScheduleName() : BabyLINSDF.h
  • BL_SDF_getScheduleNr() : BabyLINSDF.h
  • BL_SDF_getSignalNr() : BabyLINSDF.h
  • BL_SDF_INCOMPATIBLE : BabyLINReturncodes.h
  • BL_SDF_INSUFFICIENT_FIRMWARE : BabyLINReturncodes.h
  • BL_searchBabyLIN() : BabyLIN.h
  • BL_searchBabyLinPorts() : BabyLIN.h
  • BL_sendCommand() : BabyLIN.h
  • BL_sendCommandD() : BabyLIN.h
  • BL_sendCommandF() : BabyLIN.h
  • BL_sendCommandFs() : BabyLIN.h
  • BL_sendDTLRequest() : BabyLIN.h
  • BL_sendDTLResponse() : BabyLIN.h
  • BL_sendRaw() : BabyLIN.h
  • BL_sendRawMasterRequest() : BabyLIN.h
  • BL_sendRawSlaveResponse() : BabyLIN.h
  • BL_SERIAL_PORT_ERROR : BabyLINReturncodes.h
  • BL_setDTLMode() : BabyLIN.h
  • BL_signal_callback_func : BabyLIN.h
  • BL_SIGNAL_IS_ARRAY : BabyLINReturncodes.h
  • BL_SIGNAL_IS_SCALAR : BabyLINReturncodes.h
  • BL_SIGNAL_NOT_EXISTENT : BabyLINReturncodes.h
  • BLC_SDF_getFrameNr() : BabyLINCANSDF.h
  • BLC_SDF_getMacroNr() : BabyLINCANSDF.h
  • BLC_SDF_getNodeNr() : BabyLINCANSDF.h
  • BLC_SDF_getNumSchedules() : BabyLINCANSDF.h
  • BLC_SDF_getScheduleName() : BabyLINCANSDF.h
  • BLC_SDF_getScheduleNr() : BabyLINCANSDF.h
  • BLC_SDF_getSignalNr() : BabyLINCANSDF.h
  • BLC_sendASCIICommand() : BabyLINCAN.h
  • BLC_sendCommand() : BabyLINCAN.h
  • BLC_sendDTLRequest() : BabyLINCAN.h
  • BLC_sendDTLResponse() : BabyLINCAN.h
  • BLC_sendRaw() : BabyLINCAN.h
  • BLC_sendRawMasterRequest() : BabyLINCAN.h
  • BLC_sendRawSlaveResponse() : BabyLINCAN.h
  • BLC_setBinary() : BabyLIN_UnifiedAccess.h
  • BLC_setCallback() : BabyLIN_UnifiedAccess.h
  • BLC_setDTLMode() : BabyLINCAN.h
  • BLC_setsig() : BabyLINCAN.h
  • BLC_setSignedNumber() : BabyLIN_UnifiedAccess.h
  • BLC_setUnsignedNumber() : BabyLIN_UnifiedAccess.h
  • BLC_signal_callback_func : BabyLINCAN_types.h
  • BLC_signal_callback_func_ptr : BabyLINCAN_types.h
  • SDF_close() : SDF.h
  • SDF_downloadSectionToChannel() : SDF.h
  • SDF_downloadToDevice() : SDF.h
  • SDF_getSectionCount() : SDF.h
  • SDF_getSectionHandle() : SDF.h
  • SDF_getSectionInfo() : SDF.h
  • SDF_HANDLE : SDF.h
  • SDF_HANDLE_INVALID : SDF.h , BabyLINReturncodes.h
  • SDF_hasMacroCommandOverwriteEnabled() : SDF.h
  • SDF_IN_USE : BabyLINReturncodes.h , SDF.h
  • SDF_OK : BabyLINReturncodes.h , SDF.h
  • SDF_open() : SDF.h
  • SDF_openLDF() : SDF.h
  • SET_CONFIG : BabyLIN_RP1210.h
  • SILENT_J1939_CLAIM : BabyLIN_RP1210.h
  • STANDARD_CAN : BabyLIN_RP1210.h
  • STANDARD_CAN_ISO15765_EXTENDED : BabyLIN_RP1210.h
  • STANDARD_MIXED_CAN_ISO15765 : BabyLIN_RP1210.h
  • STDCALL : BabyLIN_RP1210.h
Generated on Fri May 30 2025 17:16:14 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: Globals

  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
  • Macros
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
Here is a list of all functions, variables, defines, enums, and typedefs with links to the files they belong to:

- t -

  • BL_TIMEOUT : BabyLINReturncodes.h
  • BLC_tableFill() : BabyLINCAN.h
  • BLC_tableRead() : BabyLINCAN.h
  • BLC_tableWrite() : BabyLINCAN.h
  • BLC_tableWriteText() : BabyLINCAN.h
  • TRUE : BabyLIN_RP1210.h
  • TYPE_DTL_ISOTP : BabyLINCAN_types.h
  • TYPE_ISOTP_WITHOUT_NAD : BabyLINCAN_types.h
  • TYPE_KLINE_RAW : BabyLINCAN_types.h
  • TYPE_RAW : BabyLINCAN_types.h
  • TYPE_WEBASTO_STD : BabyLINCAN_types.h
  • TYPE_WEBASTO_UHW2 : BabyLINCAN_types.h
Generated on Fri May 30 2025 17:16:14 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: Globals

  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
  • Macros
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
Here is a list of all functions, variables, defines, enums, and typedefs with links to the files they belong to:

- u -

  • BL_UNKNOWN_COMMAND : BabyLINReturncodes.h
  • BL_updRawSlaveResponse() : BabyLIN.h
  • BLC_UA_EXECUTION_FAILED : BabyLINReturncodes.h
  • BLC_UA_GET_VALUE_REJECTED : BabyLINReturncodes.h
  • BLC_UA_INVALID_PARAMETER : BabyLINReturncodes.h
  • BLC_UA_INVALID_PARAMETER_COUNT : BabyLINReturncodes.h
  • BLC_UA_NO_GETTER_DEFINED : BabyLINReturncodes.h
  • BLC_UA_NO_REQUEST_DATA : BabyLINReturncodes.h
  • BLC_UA_NO_SETTER_DEFINED : BabyLINReturncodes.h
  • BLC_UA_NOT_RESOLVABLE_TAG_FIRST : BabyLINReturncodes.h
  • BLC_UA_NOT_RESOLVABLE_TAG_MAX : BabyLINReturncodes.h
  • BLC_UA_REQUESTED_OBJECT_NOT_FOUND_FIRST : BabyLINReturncodes.h
  • BLC_UA_REQUESTED_OBJECT_NOT_FOUND_MAX : BabyLINReturncodes.h
  • BLC_UA_SERVICE_FLOWCONTROL_INVALIDSTATE : BabyLINReturncodes.h
  • BLC_UA_SERVICE_FLOWCONTROL_OVERFLOW : BabyLINReturncodes.h
  • BLC_UA_SERVICE_FLOWCONTROL_WAITSTATES : BabyLINReturncodes.h
  • BLC_UA_SERVICE_FRAME_ORDER : BabyLINReturncodes.h
  • BLC_UA_SERVICE_FRAME_PACKAGING_ERROR : BabyLINReturncodes.h
  • BLC_UA_SERVICE_TIMEOUT_FLOWCONTROL_RECEIVE : BabyLINReturncodes.h
  • BLC_UA_SERVICE_TIMEOUT_FLOWCONTROL_SEND : BabyLINReturncodes.h
  • BLC_UA_SERVICE_TIMEOUT_RESPONSE : BabyLINReturncodes.h
  • BLC_UA_SERVICE_TIMEOUT_SEND : BabyLINReturncodes.h
  • BLC_UA_SET_VALUE_REJECTED : BabyLINReturncodes.h
  • BLC_unifiedaccess_async_callback_func_ptr : BabyLIN_UnifiedAccess.h
  • BLC_unifiedaccess_callback_func_ptr : BabyLIN_UnifiedAccess.h
  • BLC_updRawSlaveResponse() : BabyLINCAN.h
  • U8 : BabyLIN_RP1210.h
Generated on Fri May 30 2025 17:16:14 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: Globals

  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
  • Macros
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
Here is a list of all functions, variables, defines, enums, and typedefs with links to the files they belong to:

- v -

  • BLC_varRead() : BabyLINCAN.h
  • BLC_varWrite() : BabyLINCAN.h
  • VIEW_B_LIST : BabyLIN_RP1210.h
Generated on Fri May 30 2025 17:16:14 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: Globals

  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
  • Macros
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
Here is a list of all functions, variables, defines, enums, and typedefs with links to the files they belong to:

- w -

  • BL_WRONG_PARAMETER : BabyLINReturncodes.h
Generated on Fri May 30 2025 17:16:14 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: Globals

  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
  • Macros
  • a
  • c
  • d
  • e
  • f
  • g
  • i
  • l
  • m
  • o
  • r
  • s
  • t
  • u
  • v

- a -

  • BLC_AdHoc_CreateProtocol() : BabyLINCAN.h
  • BLC_AdHoc_CreateService() : BabyLINCAN.h
  • BLC_AdHoc_DefaultExecute() : BabyLINCAN.h
  • BLC_AdHoc_DefaultProtocol() : BabyLINCAN.h
  • BLC_AdHoc_DefaultService() : BabyLINCAN.h
  • BLC_AdHoc_DeleteAllProtocol() : BabyLINCAN.h
  • BLC_AdHoc_DeleteAllService() : BabyLINCAN.h
  • BLC_AdHoc_DeleteProtocol() : BabyLINCAN.h
  • BLC_AdHoc_DeleteService() : BabyLINCAN.h
  • BLC_AdHoc_Execute() : BabyLINCAN.h
  • BLC_AdHoc_ExecuteAsync() : BabyLINCAN.h
  • BLC_AdHoc_GetResponse() : BabyLINCAN.h
  • BLC_AdHoc_GetState() : BabyLINCAN.h
Generated on Fri May 30 2025 17:16:14 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: Globals

  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
  • Macros
  • a
  • c
  • d
  • e
  • f
  • g
  • i
  • l
  • m
  • o
  • r
  • s
  • t
  • u
  • v

- c -

  • BL_close() : BabyLIN.h
  • BL_closeAll() : BabyLIN.h
  • BLC_close() : BabyLINCAN.h
  • BLC_closeAll() : BabyLINCAN.h
  • BLC_convertUrl() : BabyLINCAN.h
  • BLC_createHandle() : BabyLIN_UnifiedAccess.h
Generated on Fri May 30 2025 17:16:14 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: Globals

  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
  • Macros
  • a
  • c
  • d
  • e
  • f
  • g
  • i
  • l
  • m
  • o
  • r
  • s
  • t
  • u
  • v

- d -

  • BL_downloadSDF() : BabyLIN.h
  • BLC_decodeSignal() : BabyLINCAN.h
  • BLC_destroy() : BabyLIN_UnifiedAccess.h
  • BLC_discover() : BabyLIN_UnifiedAccess.h
  • BLC_dmDelay() : BabyLINCAN.h
  • BLC_dmPrepare() : BabyLINCAN.h
  • BLC_dmPulse() : BabyLINCAN.h
  • BLC_dmRead() : BabyLINCAN.h
  • BLC_dmReadTimeout() : BabyLINCAN.h
  • BLC_dmReportConfig() : BabyLINCAN.h
  • BLC_dmStart() : BabyLINCAN.h
  • BLC_dmStop() : BabyLINCAN.h
  • BLC_dmWrite() : BabyLINCAN.h
  • BLC_downloadSDF() : BabyLINCAN.h
Generated on Fri May 30 2025 17:16:14 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: Globals

  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
  • Macros
  • a
  • c
  • d
  • e
  • f
  • g
  • i
  • l
  • m
  • o
  • r
  • s
  • t
  • u
  • v

- e -

  • BL_encodeSignal() : BabyLIN.h , BabyLINCAN.h
  • BLC_execute() : BabyLIN_UnifiedAccess.h
  • BLC_execute_async() : BabyLIN_UnifiedAccess.h
Generated on Fri May 30 2025 17:16:14 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: Globals

  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
  • Macros
  • a
  • c
  • d
  • e
  • f
  • g
  • i
  • l
  • m
  • o
  • r
  • s
  • t
  • u
  • v

- f -

  • BL_flush() : BabyLIN.h , BabyLINCAN.h
Generated on Fri May 30 2025 17:16:14 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: Globals

  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
  • Macros
  • a
  • c
  • d
  • e
  • f
  • g
  • i
  • l
  • m
  • o
  • r
  • s
  • t
  • u
  • v

- g -

  • BL_getAnswerByIndex() : BabyLIN.h
  • BL_getAnswerByName() : BabyLIN.h
  • BL_getAnswerTypeByIndex() : BabyLIN.h
  • BL_getAnswerTypeByName() : BabyLIN.h
  • BL_getDTLRequestStatus() : BabyLIN.h
  • BL_getDTLResponseStatus() : BabyLIN.h
  • BL_getFrameCount() : BabyLIN.h
  • BL_getFrameDetails() : BabyLIN.h
  • BL_getFrameName() : BabyLIN.h
  • BL_getFrameNrForFrameId() : BabyLIN.h
  • BL_getLastError() : BabyLIN.h
  • BL_getLastFrame() : BabyLIN.h
  • BL_getNextBusError() : BabyLIN.h
  • BL_getNextDTLRequest() : BabyLIN.h
  • BL_getNextDTLResponse() : BabyLIN.h
  • BL_getNextFrame() : BabyLIN.h
  • BL_getNextFrameTimeout() : BabyLIN.h
  • BL_getNextSignal() : BabyLIN.h
  • BL_getNodeCount() : BabyLIN.h
  • BL_getNodeName() : BabyLIN.h
  • BL_getRawSlaveResponse() : BabyLIN.h
  • BL_getSignalArray() : BabyLIN.h
  • BL_getSignalArrayByName() : BabyLIN.h
  • BL_getSignalCount() : BabyLIN.h
  • BL_getSignalDataFromFrame() : BabyLIN.h
  • BL_getSignalInFrame() : BabyLIN.h
  • BL_getSignalName() : BabyLIN.h
  • BL_getSignalsInFrame() : BabyLIN.h
  • BL_getSignalsInFrameCount() : BabyLIN.h
  • BL_getSignalValue() : BabyLIN.h
  • BL_getSignalValueByName() : BabyLIN.h
  • BL_getTargetID() : BabyLIN.h
  • BL_getVersion() : BabyLIN.h
  • BL_getVersionString() : BabyLIN.h
  • BLC_getAnswerByIndex() : BabyLINCAN.h
  • BLC_getAnswerByName() : BabyLINCAN.h
  • BLC_getAnswerNameByIndex() : BabyLINCAN.h
  • BLC_getAnswerTypeByIndex() : BabyLINCAN.h
  • BLC_getAnswerTypeByName() : BabyLINCAN.h
  • BLC_getBabyLinPorts() : BabyLINCAN.h
  • BLC_getBabyLinPortsTimout() : BabyLINCAN.h
  • BLC_getBinary() : BabyLIN_UnifiedAccess.h
  • BLC_getChannelCount() : BabyLINCAN.h
  • BLC_getChannelHandle() : BabyLINCAN.h
  • BLC_getChannelInfo() : BabyLINCAN.h
  • BLC_getChannelSectionDescription() : BabyLINCAN.h
  • BLC_getDetailedErrorString() : BabyLINCAN.h
  • BLC_getDTLRequestStatus() : BabyLINCAN.h
  • BLC_getDTLResponseStatus() : BabyLINCAN.h
  • BLC_getErrorString() : BabyLINCAN.h
  • BLC_getExtendedVersion() : BabyLINCAN.h
  • BLC_getFrameCount() : BabyLINCAN.h
  • BLC_getFrameDetails() : BabyLINCAN.h
  • BLC_getFrameIdForFrameNr() : BabyLINCAN.h
  • BLC_getFrameName() : BabyLINCAN.h
  • BLC_getFrameNrForFrameId() : BabyLINCAN.h
  • BLC_getHWType() : BabyLINCAN.h
  • BLC_getLastError() : BabyLINCAN.h
  • BLC_getLastFrame() : BabyLINCAN.h
  • BLC_getMacroResultString() : BabyLINCAN.h
  • BLC_getNextBusError() : BabyLINCAN.h
  • BLC_getNextDTLRequest() : BabyLINCAN.h
  • BLC_getNextDTLResponse() : BabyLINCAN.h
  • BLC_getNextFrame() : BabyLINCAN.h
  • BLC_getNextFrames() : BabyLINCAN.h
  • BLC_getNextFramesTimeout() : BabyLINCAN.h
  • BLC_getNextFrameTimeout() : BabyLINCAN.h
  • BLC_getNextJumboFrame() : BabyLINCAN.h
  • BLC_getNextJumboFrames() : BabyLINCAN.h
  • BLC_getNextJumboFramesTimeout() : BabyLINCAN.h
  • BLC_getNextJumboFrameTimeout() : BabyLINCAN.h
  • BLC_getNextSignal() : BabyLINCAN.h
  • BLC_getNextSignals() : BabyLINCAN.h
  • BLC_getNextSignalsForNumber() : BabyLINCAN.h
  • BLC_getNodeCount() : BabyLINCAN.h
  • BLC_getNodeForSignal() : BabyLINCAN.h
  • BLC_getNodeName() : BabyLINCAN.h
  • BLC_getRawSlaveResponse() : BabyLINCAN.h
  • BLC_getSDFInfo() : BabyLINCAN.h
  • BLC_getSectionInfo() : BabyLINCAN.h
  • BLC_getSignalArray() : BabyLINCAN.h
  • BLC_getSignalArrayByName() : BabyLINCAN.h
  • BLC_getSignalArrayWithTimestamp() : BabyLINCAN.h
  • BLC_getSignalCount() : BabyLINCAN.h
  • BLC_getSignalInFrame() : BabyLINCAN.h
  • BLC_getSignalName() : BabyLINCAN.h
  • BLC_getSignalsInFrame() : BabyLINCAN.h
  • BLC_getSignalsInFrameCount() : BabyLINCAN.h
  • BLC_getSignalSize() : BabyLINCAN.h
  • BLC_getSignalValue() : BabyLINCAN.h
  • BLC_getSignalValueByName() : BabyLINCAN.h
  • BLC_getSignalValueWithTimestamp() : BabyLINCAN.h
  • BLC_getSignedNumber() : BabyLIN_UnifiedAccess.h
  • BLC_getTableColumnCount() : BabyLINCAN.h
  • BLC_getTableCount() : BabyLINCAN.h
  • BLC_getTableRowCount() : BabyLINCAN.h
  • BLC_getTargetID() : BabyLINCAN.h
  • BLC_getUnsignedNumber() : BabyLIN_UnifiedAccess.h
  • BLC_getVersion() : BabyLINCAN.h
  • BLC_getVersionString() : BabyLINCAN.h
  • BLCns_getChannelInfo() : BabyLINCAN_nostruct.h
  • BLCns_getLastFrame() : BabyLINCAN_nostruct.h
  • BLCns_getNextBusError() : BabyLINCAN_nostruct.h
  • BLCns_getNextDTLRequest() : BabyLINCAN_nostruct.h
  • BLCns_getNextDTLResponse() : BabyLINCAN_nostruct.h
  • BLCns_getNextFrame() : BabyLINCAN_nostruct.h
  • BLCns_getNextFrames() : BabyLINCAN_nostruct.h
  • BLCns_getNextFramesTimeout() : BabyLINCAN_nostruct.h
  • BLCns_getNextFrameTimeout() : BabyLINCAN_nostruct.h
  • BLCns_getNextJumboFrame() : BabyLINCAN_nostruct.h
  • BLCns_getNextJumboFrames() : BabyLINCAN_nostruct.h
  • BLCns_getNextJumboFramesTimeout() : BabyLINCAN_nostruct.h
  • BLCns_getNextJumboFrameTimeout() : BabyLINCAN_nostruct.h
  • BLCns_getNextSignal() : BabyLINCAN_nostruct.h
  • BLCns_getNextSignals() : BabyLINCAN_nostruct.h
  • BLCns_getNextSignalsForNumber() : BabyLINCAN_nostruct.h
  • BLCns_getSDFInfo() : BabyLINCAN_nostruct.h
  • BLCns_getSectionInfo() : BabyLINCAN_nostruct.h
  • BLCns_getTargetID() : BabyLINCAN_nostruct.h
  • BLCns_getVersionString() : BabyLINCAN_nostruct.h
Generated on Fri May 30 2025 17:16:14 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: Globals

  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
  • Macros
  • a
  • c
  • d
  • e
  • f
  • g
  • i
  • l
  • m
  • o
  • r
  • s
  • t
  • u
  • v

- i -

  • BL_isSignalArray() : BabyLIN.h
  • BLC_isSDFOnDevice() : BabyLINCAN.h
  • BLC_isSignalArray() : BabyLINCAN.h
  • BLC_isSignalEmulated() : BabyLINCAN.h
Generated on Fri May 30 2025 17:16:14 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: Globals

  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
  • Macros
  • a
  • c
  • d
  • e
  • f
  • g
  • i
  • l
  • m
  • o
  • r
  • s
  • t
  • u
  • v

- l -

  • BL_lastAnswerHasData() : BabyLIN.h
  • BL_loadSDF() : BabyLIN.h
  • BLC_lastAnswerHasData() : BabyLINCAN.h
  • BLC_loadLDF() : BabyLINCAN.h
  • BLC_loadSDF() : BabyLINCAN.h
  • BLC_loggingAddComment() : BabyLINCAN.h
  • BLC_loggingStart() : BabyLINCAN.h
  • BLC_loggingStop() : BabyLINCAN.h
  • BLC_loggingStopGlobal() : BabyLINCAN.h
Generated on Fri May 30 2025 17:16:14 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: Globals

  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
  • Macros
  • a
  • c
  • d
  • e
  • f
  • g
  • i
  • l
  • m
  • o
  • r
  • s
  • t
  • u
  • v

- m -

  • BL_mon_set() : BabyLIN.h
  • BL_mon_set_xmit() : BabyLIN.h
  • BL_mon_xmit() : BabyLIN.h
  • BLC_macro_result() : BabyLINCAN.h
  • BLC_mon_set() : BabyLINCAN.h
  • BLC_mon_set_xmit() : BabyLINCAN.h
  • BLC_mon_xmit() : BabyLINCAN.h
Generated on Fri May 30 2025 17:16:14 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: Globals

  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
  • Macros
  • a
  • c
  • d
  • e
  • f
  • g
  • i
  • l
  • m
  • o
  • r
  • s
  • t
  • u
  • v

- o -

  • BL_open() : BabyLIN.h , BabyLINCAN.h
  • BLC_openNet() : BabyLINCAN.h
  • BLC_openPort() : BabyLINCAN.h
  • BLC_openUSB() : BabyLINCAN.h
  • BLC_overwriteCrashHandler() : BabyLINCAN.h
  • BLCns_openPort() : BabyLINCAN_nostruct.h
  • BLCns_openURL() : BabyLINCAN_nostruct.h
Generated on Fri May 30 2025 17:16:14 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: Globals

  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
  • Macros
  • a
  • c
  • d
  • e
  • f
  • g
  • i
  • l
  • m
  • o
  • r
  • s
  • t
  • u
  • v

- r -

  • BL_registerBusErrorCallback() : BabyLIN.h
  • BL_registerDebugCallback() : BabyLIN.h
  • BL_registerDTLRequestCallback() : BabyLIN.h
  • BL_registerDTLResponseCallback() : BabyLIN.h
  • BL_registerFrameCallback() : BabyLIN.h
  • BL_registerSignalCallback() : BabyLIN.h
  • BLC_registerDebugCallback() : BabyLINCAN.h
  • BLC_registerDTLRequestCallback() : BabyLINCAN.h
  • BLC_registerDTLResponseCallback() : BabyLINCAN.h
  • BLC_registerErrorCallback() : BabyLINCAN.h
  • BLC_registerEventCallback() : BabyLINCAN.h
  • BLC_registerFrameCallback() : BabyLINCAN.h
  • BLC_registerJumboFrameCallback() : BabyLINCAN.h
  • BLC_registerLuaErrorCallback() : BabyLINCAN.h
  • BLC_registerLuaPrintCallback() : BabyLINCAN.h
  • BLC_registerMacroStateCallback() : BabyLINCAN.h
  • BLC_registerSignalCallback() : BabyLINCAN.h
  • BLC_registerUserDataDebugCallback() : BabyLINCAN.h
  • BLC_registerUserDataDTLRequestCallback() : BabyLINCAN.h
  • BLC_registerUserDataDTLResponseCallback() : BabyLINCAN.h
  • BLC_registerUserDataErrorCallback() : BabyLINCAN.h
  • BLC_registerUserDataEvent() : BabyLINCAN.h
  • BLC_registerUserDataEventCallback() : BabyLINCAN.h
  • BLC_registerUserDataFrameCallback() : BabyLINCAN.h
  • BLC_registerUserDataJumboFrameCallback() : BabyLINCAN.h
  • BLC_registerUserDataLogCallback() : BabyLINCAN.h
  • BLC_registerUserDataMacroStateCallback() : BabyLINCAN.h
  • BLC_registerUserDataSignalCallback() : BabyLINCAN.h
  • BLC_releaseHandle() : BabyLIN_UnifiedAccess.h
  • BLC_Reset() : BabyLINCAN.h
  • BLC_RP1210_ListAvailableDevices() : BabyLIN_RP1210.h
  • BLC_RP1210_ListRegisteredDevices() : BabyLIN_RP1210.h
  • BLC_RP1210_RegisterAllAvailableDevices() : BabyLIN_RP1210.h
  • BLC_RP1210_RegisterDevice() : BabyLIN_RP1210.h
  • BLC_RP1210_UnregisterAllDevices() : BabyLIN_RP1210.h
  • BLC_RP1210_UnregisterDevice() : BabyLIN_RP1210.h
  • BLC_RP1210_UnregisterDeviceById() : BabyLIN_RP1210.h
  • BLC_runLuaCode() : BabyLINCAN.h
  • RP1210_ClientConnect() : BabyLIN_RP1210.h
  • RP1210_ClientDisconnect() : BabyLIN_RP1210.h
  • RP1210_GetErrorMsg() : BabyLIN_RP1210.h
  • RP1210_GetHardwareStatus() : BabyLIN_RP1210.h
  • RP1210_GetLastErrorMsg() : BabyLIN_RP1210.h
  • RP1210_ReadDetailedVersion() : BabyLIN_RP1210.h
  • RP1210_ReadMessage() : BabyLIN_RP1210.h
  • RP1210_ReadVersion() : BabyLIN_RP1210.h
  • RP1210_SendCommand() : BabyLIN_RP1210.h
  • RP1210_SendMessage() : BabyLIN_RP1210.h
Generated on Fri May 30 2025 17:16:14 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: Globals

  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
  • Macros
  • a
  • c
  • d
  • e
  • f
  • g
  • i
  • l
  • m
  • o
  • r
  • s
  • t
  • u
  • v

- s -

  • BL_SDF_getFrameNr() : BabyLINSDF.h
  • BL_SDF_getMacroNr() : BabyLINSDF.h
  • BL_SDF_getNodeNr() : BabyLINSDF.h
  • BL_SDF_getNumSchedules() : BabyLINSDF.h
  • BL_SDF_getScheduleName() : BabyLINSDF.h
  • BL_SDF_getScheduleNr() : BabyLINSDF.h
  • BL_SDF_getSignalNr() : BabyLINSDF.h
  • BL_searchBabyLIN() : BabyLIN.h
  • BL_searchBabyLinPorts() : BabyLIN.h
  • BL_sendCommand() : BabyLIN.h
  • BL_sendCommandD() : BabyLIN.h
  • BL_sendCommandF() : BabyLIN.h
  • BL_sendCommandFs() : BabyLIN.h
  • BL_sendDTLRequest() : BabyLIN.h
  • BL_sendDTLResponse() : BabyLIN.h
  • BL_sendRaw() : BabyLIN.h
  • BL_sendRawMasterRequest() : BabyLIN.h
  • BL_sendRawSlaveResponse() : BabyLIN.h
  • BL_setDTLMode() : BabyLIN.h
  • BLC_SDF_getFrameNr() : BabyLINCANSDF.h
  • BLC_SDF_getMacroNr() : BabyLINCANSDF.h
  • BLC_SDF_getNodeNr() : BabyLINCANSDF.h
  • BLC_SDF_getNumSchedules() : BabyLINCANSDF.h
  • BLC_SDF_getScheduleName() : BabyLINCANSDF.h
  • BLC_SDF_getScheduleNr() : BabyLINCANSDF.h
  • BLC_SDF_getSignalNr() : BabyLINCANSDF.h
  • BLC_sendASCIICommand() : BabyLINCAN.h
  • BLC_sendCommand() : BabyLINCAN.h
  • BLC_sendDTLRequest() : BabyLINCAN.h
  • BLC_sendDTLResponse() : BabyLINCAN.h
  • BLC_sendRaw() : BabyLINCAN.h
  • BLC_sendRawMasterRequest() : BabyLINCAN.h
  • BLC_sendRawSlaveResponse() : BabyLINCAN.h
  • BLC_setBinary() : BabyLIN_UnifiedAccess.h
  • BLC_setCallback() : BabyLIN_UnifiedAccess.h
  • BLC_setDTLMode() : BabyLINCAN.h
  • BLC_setsig() : BabyLINCAN.h
  • BLC_setSignedNumber() : BabyLIN_UnifiedAccess.h
  • BLC_setUnsignedNumber() : BabyLIN_UnifiedAccess.h
  • SDF_close() : SDF.h
  • SDF_downloadSectionToChannel() : SDF.h
  • SDF_downloadToDevice() : SDF.h
  • SDF_getSectionCount() : SDF.h
  • SDF_getSectionHandle() : SDF.h
  • SDF_getSectionInfo() : SDF.h
  • SDF_hasMacroCommandOverwriteEnabled() : SDF.h
  • SDF_open() : SDF.h
  • SDF_openLDF() : SDF.h
Generated on Fri May 30 2025 17:16:14 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: Globals

  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
  • Macros
  • a
  • c
  • d
  • e
  • f
  • g
  • i
  • l
  • m
  • o
  • r
  • s
  • t
  • u
  • v

- t -

  • BLC_tableFill() : BabyLINCAN.h
  • BLC_tableRead() : BabyLINCAN.h
  • BLC_tableWrite() : BabyLINCAN.h
  • BLC_tableWriteText() : BabyLINCAN.h
Generated on Fri May 30 2025 17:16:14 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: Globals

  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
  • Macros
  • a
  • c
  • d
  • e
  • f
  • g
  • i
  • l
  • m
  • o
  • r
  • s
  • t
  • u
  • v

- u -

  • BL_updRawSlaveResponse() : BabyLIN.h , BabyLINCAN.h
Generated on Fri May 30 2025 17:16:14 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: Globals

  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
  • Macros
  • a
  • c
  • d
  • e
  • f
  • g
  • i
  • l
  • m
  • o
  • r
  • s
  • t
  • u
  • v

- v -

  • BLC_varRead() : BabyLINCAN.h
  • BLC_varWrite() : BabyLINCAN.h
Generated on Fri May 30 2025 17:16:14 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: Globals

  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
  • Macros
  • a
  • b
  • c
  • d
  • e
  • f
  • h
  • j
  • l
  • m
  • s
  • u

- a -

  • BL_ADHOC_HANDLE : BabyLINReturncodes.h

- b -

  • BL_buserror_callback_func : BabyLIN.h

- c -

  • CPCHAR : BabyLINReturncodes.h , BabyLINSDF.h

- d -

  • BL_debug_callback_func : BabyLIN.h
  • BL_dtl_request_callback_func : BabyLIN.h
  • BL_dtl_response_callback_func : BabyLIN.h
  • BLC_debug_callback_func : BabyLINCAN_types.h
  • BLC_debug_callback_func_ptr : BabyLINCAN_types.h
  • BLC_dtl_request_callback_func : BabyLINCAN_types.h
  • BLC_dtl_request_callback_func_ptr : BabyLINCAN_types.h
  • BLC_dtl_response_callback_func : BabyLINCAN_types.h
  • BLC_dtl_response_callback_func_ptr : BabyLINCAN_types.h

- e -

  • BLC_error_callback_func : BabyLINCAN_types.h
  • BLC_error_callback_func_ptr : BabyLINCAN_types.h
  • BLC_event_callback_func : BabyLINCAN_types.h
  • BLC_event_callback_func_ptr : BabyLINCAN_types.h
  • exception_filter : BabyLINCAN.h

- f -

  • BL_frame_callback_func : BabyLIN.h , BabyLINCAN_types.h
  • BLC_frame_callback_func_ptr : BabyLINCAN_types.h

- h -

  • BL_HANDLE : BabyLINReturncodes.h , BabyLINSDF.h

- j -

  • BLC_jumboframe_callback_func : BabyLINCAN_types.h
  • BLC_jumboframe_callback_func_ptr : BabyLINCAN_types.h

- l -

  • BLC_log_callback_func_ptr : BabyLINCAN_types.h
  • BLC_lua_print_func_ptr : BabyLINCAN_types.h

- m -

  • BLC_macrostate_callback_func : BabyLINCAN_types.h
  • BLC_macrostate_callback_func_ptr : BabyLINCAN_types.h

- s -

  • BL_signal_callback_func : BabyLIN.h , BabyLINCAN_types.h
  • BLC_signal_callback_func_ptr : BabyLINCAN_types.h
  • SDF_HANDLE : SDF.h

- u -

  • BLC_unifiedaccess_async_callback_func_ptr : BabyLIN_UnifiedAccess.h
  • BLC_unifiedaccess_callback_func_ptr : BabyLIN_UnifiedAccess.h
  • U8 : BabyLIN_RP1210.h
Generated on Fri May 30 2025 17:16:14 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: Globals

  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
  • Macros
  • ADHOC_PROTOCOL_TYPE : BabyLINCAN_types.h
  • BL_ANSWER_TYPE : BabyLINReturncodes.h
  • BL_DTL_STATUS : BabyLINReturncodes.h
Generated on Fri May 30 2025 17:16:14 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: Globals

  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
  • Macros
  • BL_ANSWER_TYPE_BIN : BabyLINReturncodes.h
  • BL_ANSWER_TYPE_FLOAT : BabyLINReturncodes.h
  • BL_ANSWER_TYPE_INT : BabyLINReturncodes.h
  • BL_ANSWER_TYPE_INT64 : BabyLINReturncodes.h
  • BL_ANSWER_TYPE_STR : BabyLINReturncodes.h
  • BL_ANSWER_TYPE_UNKNOWN : BabyLINReturncodes.h
  • LD_COMPLETED : BabyLINReturncodes.h
  • LD_FAILED : BabyLINReturncodes.h
  • LD_IN_PROGRESS : BabyLINReturncodes.h
  • TYPE_DTL_ISOTP : BabyLINCAN_types.h
  • TYPE_ISOTP_WITHOUT_NAD : BabyLINCAN_types.h
  • TYPE_KLINE_RAW : BabyLINCAN_types.h
  • TYPE_RAW : BabyLINCAN_types.h
  • TYPE_WEBASTO_STD : BabyLINCAN_types.h
  • TYPE_WEBASTO_UHW2 : BabyLINCAN_types.h
Generated on Fri May 30 2025 17:16:14 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: Globals

  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
  • Macros
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w

- a -

  • ADD_LIST : BabyLIN_RP1210.h
  • BL_ANSWER_DATA_NOT_EXISTENT : BabyLINReturncodes.h
  • BLC_ADHOC_EXECUTE_RUNNING : BabyLINReturncodes.h
  • BLC_ADHOC_INVALID_HANDLE : BabyLINReturncodes.h
  • BLC_ADHOC_MCR_OFFSET : BabyLINReturncodes.h
Generated on Fri May 30 2025 17:16:14 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: Globals

  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
  • Macros
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w

- b -

  • BIT0 : BabyLIN_RP1210.h
  • BIT1 : BabyLIN_RP1210.h
  • BIT2 : BabyLIN_RP1210.h
  • BIT3 : BabyLIN_RP1210.h
  • BIT4 : BabyLIN_RP1210.h
  • BIT7 : BabyLIN_RP1210.h
  • BITE : BabyLIN_RP1210.h
  • BITS : BabyLIN_RP1210.h
  • BL_BUFFER_TOO_SMALL : BabyLINReturncodes.h
  • BLOCK_INFINITE : BabyLIN_RP1210.h
  • BLOCK_UNTIL_DONE : BabyLIN_RP1210.h
  • BLOCKING_IO : BabyLIN_RP1210.h
  • BYTE1_OF_INT4 : BabyLIN_RP1210.h
  • BYTE2_0F_INT4 : BabyLIN_RP1210.h
  • BYTE3_0F_INT4 : BabyLIN_RP1210.h
  • BYTEO_OF_INT4 : BabyLIN_RP1210.h
Generated on Fri May 30 2025 17:16:14 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: Globals

  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
  • Macros
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w

- c -

  • BL_CMD_NOT_SUPPORTED : BabyLINReturncodes.h
  • BL_CMD_SYNTAX_ERROR : BabyLINReturncodes.h
  • CHANGE_BAUD_NOW : BabyLIN_RP1210.h
  • CONNECTED : BabyLIN_RP1210.h
  • CONNECTED_WIRED : BabyLIN_RP1210.h
  • CONNECTED_WIRELESS : BabyLIN_RP1210.h
  • CONVERTED_MODE : BabyLIN_RP1210.h
Generated on Fri May 30 2025 17:16:14 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: Globals

  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
  • Macros
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w

- d -

  • BL_DLLIMPORT : BabyLINReturncodes.h
  • BL_DOWNLOAD_IN_PROGRESS : BabyLINReturncodes.h
  • BL_DP_MSG_ERROR : BabyLINReturncodes.h
  • DEPRECATED : BabyLINReturncodes.h
  • DESTROY_LIST : BabyLIN_RP1210.h
Generated on Fri May 30 2025 17:16:14 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: Globals

  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
  • Macros
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w

- e -

  • BL_ENCODING_NOT_EXISTENT : BabyLINReturncodes.h
  • BL_ERR_CFG_REFERENCE : BabyLINReturncodes.h
  • BL_ERR_CHANNEL : BabyLINReturncodes.h
  • BL_ERR_CONDITION : BabyLINReturncodes.h
  • BL_ERR_CRC : BabyLINReturncodes.h
  • BL_ERR_DATAFLASH : BabyLINReturncodes.h
  • BL_ERR_DATAFLASH_INDEX : BabyLINReturncodes.h
  • BL_ERR_DATAFLASH_INIT : BabyLINReturncodes.h
  • BL_ERR_DATAFLASH_NOSPACE : BabyLINReturncodes.h
  • BL_ERR_DP_ARRAY_SIZE : BabyLINReturncodes.h
  • BL_ERR_DP_CORRUPT : BabyLINReturncodes.h
  • BL_ERR_DP_MAPPING : BabyLINReturncodes.h
  • BL_ERR_DP_NAME_TO_LONG : BabyLINReturncodes.h
  • BL_ERR_DP_NAME_TO_SHORT : BabyLINReturncodes.h
  • BL_ERR_DP_NONAME : BabyLINReturncodes.h
  • BL_ERR_DP_PARSE : BabyLINReturncodes.h
  • BL_ERR_DP_PARSE_TOP : BabyLINReturncodes.h
  • BL_ERR_DP_SEQUENCE : BabyLINReturncodes.h
  • BL_ERR_EVENT_REFERENCE : BabyLINReturncodes.h
  • BL_ERR_FRAME_REFERENCE : BabyLINReturncodes.h
  • BL_ERR_FRAMEID_LOOKUP_FAILED : BabyLINReturncodes.h
  • BL_ERR_HEAP_EXHAUSTED : BabyLINReturncodes.h
  • BL_ERR_LICENCE : BabyLINReturncodes.h
  • BL_ERR_MACRO_REFERENCE : BabyLINReturncodes.h
  • BL_ERR_MACROSEL_REFERENCE : BabyLINReturncodes.h
  • BL_ERR_NOT_INITIALIZED : BabyLINReturncodes.h
  • BL_ERR_NULLPOINTER : BabyLINReturncodes.h
  • BL_ERR_PARAMCOUNT : BabyLINReturncodes.h
  • BL_ERR_PARAMVALUE : BabyLINReturncodes.h
  • BL_ERR_SDF_HEADER : BabyLINReturncodes.h
  • BL_ERR_SECTION_MAPPING : BabyLINReturncodes.h
  • BL_ERR_SECTION_TYPE : BabyLINReturncodes.h
  • BL_ERR_SERVICEQUEUE_EXHAUSTED : BabyLINReturncodes.h
  • BL_ERR_SIG_REFERENCE : BabyLINReturncodes.h
  • BL_ERR_SIGFUNC_REFERENCE : BabyLINReturncodes.h
  • BL_ERR_UNDEF : BabyLINReturncodes.h
  • BL_ERR_UNKNOWN_CMD : BabyLINReturncodes.h
  • BL_EXCEPTION_FILTER_ATTR : BabyLINCAN.h
  • ECHO_OFF : BabyLIN_RP1210.h
  • ECHO_ON : BabyLIN_RP1210.h
  • ERR_ADAPTER_NOT_RESPONDING : BabyLIN_RP1210.h
  • ERR_ADDRESS_CLAIM_FAILED : BabyLIN_RP1210.h
  • ERR_ADDRESS_LOST : BabyLIN_RP1210.h
  • ERR_ADDRESS_NEVER_CLAIMED : BabyLIN_RP1210.h
  • ERR_ADDRESS_RELEASE_FAILED : BabyLIN_RP1210.h
  • ERR_BABYLIN_DEVICE_NOT_FOUND : BabyLIN_RP1210.h
  • ERR_BLOCK_NOT_ALLOWED : BabyLIN_RP1210.h
  • ERR_BUS_OFF : BabyLIN_RP1210.h
  • ERR_CAN_BAUD_SET_NONSTANDARD : BabyLIN_RP1210.h
  • ERR_CANNOT_CLAIM_BROADCAST_ADDRESS : BabyLIN_RP1210.h
  • ERR_CANNOT_SET_CAN_BAUDRATE : BabyLIN_RP1210.h
  • ERR_CANNOT_SET_PRIORITY : BabyLIN_RP1210.h
  • ERR_CHANGE_MODE_FAILED : BabyLIN_RP1210.h
  • ERR_CLIENT_ALREADY_CONNECTED : BabyLIN_RP1210.h
  • ERR_CLIENT_AREA_FULL : BabyLIN_RP1210.h
  • ERR_CLIENT_DISCONNECTED : BabyLIN_RP1210.h
  • ERR_CODE_NOT_FOUND : BabyLIN_RP1210.h
  • ERR_COMM_DEVICE_IN_USE : BabyLIN_RP1210.h
  • ERR_COMMAND_NOT_SUPPORTED : BabyLIN_RP1210.h
  • ERR_COMMAND_QUEUE_IS_FULL : BabyLIN_RP1210.h
  • ERR_COMMAND_TIMED_OUT : BabyLIN_RP1210.h
  • ERR_CONNECT_NOT_ALLOWED : BabyLIN_RP1210.h
  • ERR_COULD_NOT_TX_ADDRESS_CLAIMED : BabyLIN_RP1210.h
  • ERR_DATA_LINK_CONFLICT : BabyLIN_RP1210.h
  • ERR_DEVICE_IN_USE : BabyLIN_RP1210.h
  • ERR_DEVICE_NOT_SUPPORTED : BabyLIN_RP1210.h
  • ERR_DLL_NOT_INITIALIZED : BabyLIN_RP1210.h
  • ERR_FREE_MEMORY : BabyLIN_RP1210.h
  • ERR_HARDWARE_NOT_RESPONDING : BabyLIN_RP1210.h
  • ERR_HARDWARE_NOT_SUPPORTED : BabyLIN_RP1210.h
  • ERR_HARDWARE_STATUS_CHANGE : BabyLIN_RP1210.h
  • ERR_I5015765_BAUD_SET_NONSTANDARD : BabyLIN_RP1210.h
  • ERR_INI_FILE_NOT_IN_WIN_DIR : BabyLIN_RP1210.h
  • ERR_INI_KEY_NOT_FOUND : BabyLIN_RP1210.h
  • ERR_INI_SECTION_NOT_FOUND : BabyLIN_RP1210.h
  • ERR_INVALID_CLIENT_ID : BabyLIN_RP1210.h
  • ERR_INVALID_COMMAND : BabyLIN_RP1210.h
  • ERR_INVALID_DEVICE : BabyLIN_RP1210.h
  • ERR_INVALID_IOCTL_ID : BabyLIN_RP1210.h
  • ERR_INVALID_KEY_STRING : BabyLIN_RP1210.h
  • ERR_INVALID_PORT_PARAM : BabyLIN_RP1210.h
  • ERR_INVALID_PROTOCOL : BabyLIN_RP1210.h
  • ERR_J1708_BAUD_SET_NONSTANDARD : BabyLIN_RP1210.h
  • ERR_J1939_BAUD_SET_NONSTANDARD : BabyLIN_RP1210.h
  • ERR_MAX_FILTERS_EXCEEDED : BabyLIN_RP1210.h
  • ERR_MAX_NOTIFY_EXCEEDED : BabyLIN_RP1210.h
  • ERR_MESSAGE_NOT_SENT : BabyLIN_RP1210.h
  • ERR_MESSAGE_TOO_LONG : BabyLIN_RP1210.h
  • ERR_MULTIPLE_CLIENTS_CONNECTED : BabyLIN_RP1210.h
  • ERR_MULTIPLE_CONNECTIONS_NOT_ALLOWED_NOW : BabyLIN_RP1210.h
  • ERR_NOT_ENOUGH_MEMORY : BabyLIN_RP1210.h
  • ERR_NULL_PARAMETER : BabyLIN_RP1210.h
  • ERR_OS_NOT_SUPPORTED : BabyLIN_RP1210.h
  • ERR_OUT_OF_ADDRESS_RESOURCES : BabyLIN_RP1210.h
  • ERR_RX_QUEUE_CORRUPT : BabyLIN_RP1210.h
  • ERR_RX_QUEUE_FULL : BabyLIN_RP1210.h
  • ERR_TX_QUEUE_CORRUPT : BabyLIN_RP1210.h
  • ERR_TX_QUEUE_FULL : BabyLIN_RP1210.h
  • ERR_TXMESSAGE_STATUS : BabyLIN_RP1210.h
  • ERR_WINDOW_HANDLE_REQUIRED : BabyLIN_RP1210.h
  • EXTENDED_CAN : BabyLIN_RP1210.h
  • EXTENDED_CAN_ISO15765_EXTENDED : BabyLIN_RP1210.h
Generated on Fri May 30 2025 17:16:14 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: Globals

  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
  • Macros
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w

- f -

  • BL_FILE_ERROR : BabyLINReturncodes.h
  • FALSE : BabyLIN_RP1210.h
  • FAST_INIT : BabyLIN_RP1210.h
  • FILTER_DESTINATION : BabyLIN_RP1210.h
  • FILTER_EXCLUSIVE : BabyLIN_RP1210.h
  • FILTER_INCLUSIVE : BabyLIN_RP1210.h
  • FILTER_PASS_ALL : BabyLIN_RP1210.h
  • FILTER_PASS_NONE : BabyLIN_RP1210.h
  • FILTER_PASS_SOME : BabyLIN_RP1210.h
  • FILTER_PGN : BabyLIN_RP1210.h
  • FILTER_SOURCE : BabyLIN_RP1210.h
  • FIVE_BAUD_INIT : BabyLIN_RP1210.h
Generated on Fri May 30 2025 17:16:14 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: Globals

  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
  • Macros
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w

- g -

  • GET_CONFIG : BabyLIN_RP1210.h
Generated on Fri May 30 2025 17:16:14 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: Globals

  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
  • Macros
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w

- h -

  • BL_HANDLE_INVALID : BabyLINReturncodes.h
  • HIBYTE_OF_WORD : BabyLIN_RP1210.h
  • HINIBBLE_OF_CHAR : BabyLIN_RP1210.h
  • HIWORD_OF_INT4 : BabyLIN_RP1210.h
  • HWND : BabyLIN_RP1210.h
Generated on Fri May 30 2025 17:16:14 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: Globals

  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
  • Macros
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w

- i -

  • BL_INVALID_MODE : BabyLINReturncodes.h
  • ISO15765_ACTUAL_MESSAGE : BabyLIN_RP1210.h
  • ISO15765_CONFIRM : BabyLIN_RP1210.h
  • ISO15765_FF_INDICATION : BabyLIN_RP1210.h
  • ISO15765_RX_ERROR_INDICATION : BabyLIN_RP1210.h
Generated on Fri May 30 2025 17:16:14 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: Globals

  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
  • Macros
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w

- l -

  • BLC_LUA_RUNTIME_ERROR : BabyLINReturncodes.h
  • LIST_LENGTH : BabyLIN_RP1210.h
  • LOBYTE_OF_WORD : BabyLIN_RP1210.h
  • LONIBBLE_OF_CHAR : BabyLIN_RP1210.h
  • LOWORD_OF_INT4 : BabyLIN_RP1210.h
Generated on Fri May 30 2025 17:16:14 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: Globals

  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
  • Macros
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w

- m -

  • BL_MACRO_ERRCODE_IN_RESULT : BabyLINReturncodes.h
  • BL_MACRO_EXCEPTIONCODE_IN_RESULT : BabyLINReturncodes.h
  • BL_MACRO_NEVER_EXECUTED : BabyLINReturncodes.h
  • BL_MACRO_OTHER_RUNNING : BabyLINReturncodes.h
  • BL_MACRO_SAME_RUNNING : BabyLINReturncodes.h
  • BL_MACRO_START_FAIL : BabyLINReturncodes.h
  • BL_MACRO_STILL_RUNNING : BabyLINReturncodes.h
  • MAX_ISO15765_MESSAGE_LENGTH : BabyLIN_RP1210.h
  • MAX_J1708_MESSAGE_LENGTH : BabyLIN_RP1210.h
  • MAX_J1939_MESSAGE_LENGTH : BabyLIN_RP1210.h
  • MSG_FIRST_CHANGE_BAUD : BabyLIN_RP1210.h
Generated on Fri May 30 2025 17:16:14 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: Globals

  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
  • Macros
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w

- n -

  • BL_NO_ANSWER : BabyLINReturncodes.h
  • BL_NO_ANSWER_DATA : BabyLINReturncodes.h
  • BL_NO_CHANNELS_AVAILABLE : BabyLINReturncodes.h
  • BL_NO_CONNECTION : BabyLINReturncodes.h
  • BL_NO_DATA : BabyLINReturncodes.h
  • BL_NO_SDF : BabyLINReturncodes.h
  • N_BUFFER_OVERFLOW : BabyLIN_RP1210.h
  • N_ERROR : BabyLIN_RP1210.h
  • N_INVALID_FS : BabyLIN_RP1210.h
  • N_OK : BabyLIN_RP1210.h
  • N_TIMEOUT_A : BabyLIN_RP1210.h
  • N_TIMEOUT_Bs : BabyLIN_RP1210.h
  • N_TIMEOUT_C : BabyLIN_RP1210.h
  • N_UNEXP_PDU : BabyLIN_RP1210.h
  • N_WFT_OVRN : BabyLIN_RP1210.h
  • N_WRONG_SN : BabyLIN_RP1210.h
  • NO_ERRORS : BabyLIN_RP1210.h
  • NON_BLOCKING_IO : BabyLIN_RP1210.h
  • NOT_CONNECTED : BabyLIN_RP1210.h
  • NULL_WINDOW : BabyLIN_RP1210.h
Generated on Fri May 30 2025 17:16:14 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: Globals

  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
  • Macros
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w

- o -

  • BL_OK : BabyLINReturncodes.h
  • BL_OPERATION_PENDING : BabyLINReturncodes.h
Generated on Fri May 30 2025 17:16:14 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: Globals

  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
  • Macros
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w

- p -

  • BL_PC_SIDE_ERRORS : BabyLINReturncodes.h
  • PASS_J1939_CLAIM_MESSAGES : BabyLIN_RP1210.h
Generated on Fri May 30 2025 17:16:15 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: Globals

  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
  • Macros
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w

- r -

  • BL_RESOURCE_ERROR : BabyLINReturncodes.h
  • RAW_MODE : BabyLIN_RP1210.h
  • RECEIVE_OFF : BabyLIN_RP1210.h
  • RECEIVE_ON : BabyLIN_RP1210.h
  • REMOVE_ENTRY : BabyLIN_RP1210.h
  • RETURN_BEFORE_COMPLETION : BabyLIN_RP1210.h
  • RP1210_BAUD_1000k : BabyLIN_RP1210.h
  • RP1210_BAUD_125k : BabyLIN_RP1210.h
  • RP1210_BAUD_19200 : BabyLIN_RP1210.h
  • RP1210_BAUD_250k : BabyLIN_RP1210.h
  • RP1210_BAUD_38400 : BabyLIN_RP1210.h
  • RP1210_BAUD_500k : BabyLIN_RP1210.h
  • RP1210_BAUD_57600 : BabyLIN_RP1210.h
  • RP1210_BAUD_9600 : BabyLIN_RP1210.h
  • RP1210_Clear_ISO15765_Flow_Control : BabyLIN_RP1210.h
  • RP1210_Disallow_Further_Connections : BabyLIN_RP1210.h
  • RP1210_Echo_Transmitted_Messages : BabyLIN_RP1210.h
  • RP1210_Flush_Tx_Rx_Buffers : BabyLIN_RP1210.h
  • RP1210_Generic_Driver_Command : BabyLIN_RP1210.h
  • RP1210_Get_Protocol_Connection_Speed : BabyLIN_RP1210.h
  • RP1210_Get_Wireless_State : BabyLIN_RP1210.h
  • RP1210_Protect_J1939_Address : BabyLIN_RP1210.h
  • RP1210_Release_J1939_Address : BabyLIN_RP1210.h
  • RP1210_Reset_Device : BabyLIN_RP1210.h
  • RP1210_Set_All_Filters_States_to_Discard : BabyLIN_RP1210.h
  • RP1210_Set_All_Filters_States_to_Pass : BabyLIN_RP1210.h
  • RP1210_Set_BlockTimeout : BabyLIN_RP1210.h
  • RP1210_Set_Broadcast_For_CAN : BabyLIN_RP1210.h
  • RP1210_Set_Broadcast_For_ISO15765 : BabyLIN_RP1210.h
  • RP1210_Set_Broadcast_For_ISO9141 : BabyLIN_RP1210.h
  • RP1210_Set_Broadcast_For_J1708 : BabyLIN_RP1210.h
  • RP1210_Set_Broadcast_For_J1850 : BabyLIN_RP1210.h
  • RP1210_Set_Broadcast_For_J1939 : BabyLIN_RP1210.h
  • RP1210_Set_Broadcast_For_KWP2000 : BabyLIN_RP1210.h
  • RP1210_Set_CAN_Baud : BabyLIN_RP1210.h
  • RP1210_Set_CAN_Filter_Type : BabyLIN_RP1210.h
  • RP1210_Set_ISO15765_Baud : BabyLIN_RP1210.h
  • RP1210_Set_ISO15765_Filter_Type : BabyLIN_RP1210.h
  • RP1210_Set_ISO15765_Flow_Control : BabyLIN_RP1210.h
  • RP1210_Set_ISO9141KWP2000_Mode : BabyLIN_RP1210.h
  • RP1210_Set_J1708_Baud : BabyLIN_RP1210.h
  • RP1210_Set_J1708_Filter_Type : BabyLIN_RP1210.h
  • RP1210_Set_J1708_Mode : BabyLIN_RP1210.h
  • RP1210_Set_J1850_Filter_Type : BabyLIN_RP1210.h
  • RP1210_Set_J1939_Baud : BabyLIN_RP1210.h
  • RP1210_Set_J1939_Filter_Type : BabyLIN_RP1210.h
  • RP1210_Set_J1939_Interpacket_Time : BabyLIN_RP1210.h
  • RP1210_Set_Message_Filtering_For_CAN : BabyLIN_RP1210.h
  • RP1210_Set_Message_Filtering_For_ISO15765 : BabyLIN_RP1210.h
  • RP1210_Set_Message_Filtering_For_J1708 : BabyLIN_RP1210.h
  • RP1210_Set_Message_Filtering_For_J1850 : BabyLIN_RP1210.h
  • RP1210_Set_Message_Filtering_For_J1939 : BabyLIN_RP1210.h
  • RP1210_Set_Message_Receive : BabyLIN_RP1210.h
  • RP1210_SetMaxErrorMsgSize : BabyLIN_RP1210.h
Generated on Fri May 30 2025 17:16:15 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: Globals

  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
  • Macros
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w

- s -

  • BL_SDF_INCOMPATIBLE : BabyLINReturncodes.h
  • BL_SDF_INSUFFICIENT_FIRMWARE : BabyLINReturncodes.h
  • BL_SERIAL_PORT_ERROR : BabyLINReturncodes.h
  • BL_SIGNAL_IS_ARRAY : BabyLINReturncodes.h
  • BL_SIGNAL_IS_SCALAR : BabyLINReturncodes.h
  • BL_SIGNAL_NOT_EXISTENT : BabyLINReturncodes.h
  • SDF_HANDLE_INVALID : BabyLINReturncodes.h , SDF.h
  • SDF_IN_USE : SDF.h , BabyLINReturncodes.h
  • SDF_OK : SDF.h , BabyLINReturncodes.h
  • SET_CONFIG : BabyLIN_RP1210.h
  • SILENT_J1939_CLAIM : BabyLIN_RP1210.h
  • STANDARD_CAN : BabyLIN_RP1210.h
  • STANDARD_CAN_ISO15765_EXTENDED : BabyLIN_RP1210.h
  • STANDARD_MIXED_CAN_ISO15765 : BabyLIN_RP1210.h
  • STDCALL : BabyLIN_RP1210.h
Generated on Fri May 30 2025 17:16:15 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: Globals

  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
  • Macros
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w

- t -

  • BL_TIMEOUT : BabyLINReturncodes.h
  • TRUE : BabyLIN_RP1210.h
Generated on Fri May 30 2025 17:16:15 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: Globals

  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
  • Macros
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w

- u -

  • BL_UNKNOWN_COMMAND : BabyLINReturncodes.h
  • BLC_UA_EXECUTION_FAILED : BabyLINReturncodes.h
  • BLC_UA_GET_VALUE_REJECTED : BabyLINReturncodes.h
  • BLC_UA_INVALID_PARAMETER : BabyLINReturncodes.h
  • BLC_UA_INVALID_PARAMETER_COUNT : BabyLINReturncodes.h
  • BLC_UA_NO_GETTER_DEFINED : BabyLINReturncodes.h
  • BLC_UA_NO_REQUEST_DATA : BabyLINReturncodes.h
  • BLC_UA_NO_SETTER_DEFINED : BabyLINReturncodes.h
  • BLC_UA_NOT_RESOLVABLE_TAG_FIRST : BabyLINReturncodes.h
  • BLC_UA_NOT_RESOLVABLE_TAG_MAX : BabyLINReturncodes.h
  • BLC_UA_REQUESTED_OBJECT_NOT_FOUND_FIRST : BabyLINReturncodes.h
  • BLC_UA_REQUESTED_OBJECT_NOT_FOUND_MAX : BabyLINReturncodes.h
  • BLC_UA_SERVICE_FLOWCONTROL_INVALIDSTATE : BabyLINReturncodes.h
  • BLC_UA_SERVICE_FLOWCONTROL_OVERFLOW : BabyLINReturncodes.h
  • BLC_UA_SERVICE_FLOWCONTROL_WAITSTATES : BabyLINReturncodes.h
  • BLC_UA_SERVICE_FRAME_ORDER : BabyLINReturncodes.h
  • BLC_UA_SERVICE_FRAME_PACKAGING_ERROR : BabyLINReturncodes.h
  • BLC_UA_SERVICE_TIMEOUT_FLOWCONTROL_RECEIVE : BabyLINReturncodes.h
  • BLC_UA_SERVICE_TIMEOUT_FLOWCONTROL_SEND : BabyLINReturncodes.h
  • BLC_UA_SERVICE_TIMEOUT_RESPONSE : BabyLINReturncodes.h
  • BLC_UA_SERVICE_TIMEOUT_SEND : BabyLINReturncodes.h
  • BLC_UA_SET_VALUE_REJECTED : BabyLINReturncodes.h
Generated on Fri May 30 2025 17:16:15 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: Globals

  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
  • Macros
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w

- v -

  • VIEW_B_LIST : BabyLIN_RP1210.h
Generated on Fri May 30 2025 17:16:15 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: Globals

  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
  • Macros
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w

- w -

  • BL_WRONG_PARAMETER : BabyLINReturncodes.h
Generated on Fri May 30 2025 17:16:15 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: Data Structure Index

  • Data Structure Index
Data Structure Index
A | C | D | E | F | J | L | M | P | R | S | T
A
E
M
BLC_SECTIONINFO
e
BLC_SIGNAL
ADHOC_PROTOCOL_FLAGS BLC_ERROR BLC_MACROSTATE SBYTEARRAY BL_error_t
ADHOC_SERVICE_FLAGS BLC_EVENT
P
SCONFIG
f
BLC_ADHOC_EXECUTE
F
SCONFIG_LIST
BLC_ADHOC_PROTOCOL BLC_PORTINFO SDF_SECTIONINFO BL_frame_t
BLC_ADHOC_SERVICE BLC_FRAME
R
T
p
C
J
BLC_RP1210_DEVICE BLC_TARGETID BL_portInfo_t
BLC_CHANNELINFO BLC_JUMBO_FRAME
S
d
s
D
L
BLC_SDFINFO BL_dtl_t BL_signal_t
BLC_DTL BLC_LOG
A | C | D | E | F | J | L | M | P | R | S | T
Generated on Fri May 30 2025 17:16:15 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: markdowns/AdHocProtocols/AdHoc.md File Reference

markdowns/AdHocProtocols/AdHoc.md File Reference

Go to the source code of this file.

Generated on Fri May 30 2025 17:16:13 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: markdowns/AdHocProtocols/AdHoc.md Source File

markdowns/AdHocProtocols/AdHoc.md
Go to the documentation of this file.
1 @ingroup adhoc
2
3 TEST SITE ADHOC
Generated on Fri May 30 2025 17:16:12 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: Data Structures

  • Data Structure Index
Data Structures
Here are the data structures with brief descriptions:
o C ADHOC_PROTOCOL_FLAGS |
o C ADHOC_SERVICE_FLAGS |
o C BL_dtl_t |
o C BL_error_t |
o C BL_frame_t |
o C BL_portInfo_t | Information about a BabyLIN port on the host operating system
o C BL_signal_t | Carries information about one signal
o C BL_targetid_t |
o C BLC_ADHOC_EXECUTE |
o C BLC_ADHOC_PROTOCOL |
o C BLC_ADHOC_SERVICE |
o C BLC_CHANNELINFO | Information about a channel on a BabyLIN device
o C BLC_DTL |
o C BLC_ERROR |
o C BLC_EVENT |
o C BLC_FRAME |
o C BLC_JUMBO_FRAME |
o C BLC_LOG |
o C BLC_MACROSTATE | Status of a macro
o C BLC_PORTINFO | Information about a BabyLIN port on the host operating system
o C BLC_RP1210_DEVICE |
o C BLC_SDFINFO |
o C BLC_SECTIONINFO |
o C BLC_SIGNAL |
o C BLC_TARGETID | Information about a connected BabyLIN device
o C SBYTEARRAY |
o C SCONFIG |
o C SCONFIG_LIST |
\ C SDF_SECTIONINFO |
Generated on Fri May 30 2025 17:16:15 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: C:/JenkinsWS/workspace/orks_v2_LinWorksv2_Windows_trunk/source/externals/BabyLIN/src/libraries/BabyLIN/publicHeaders/BabyLIN.h File Reference

  • externals
  • BabyLIN
  • src
  • libraries
  • BabyLIN
  • publicHeaders
Data Structures | Typedefs | Functions
BabyLIN.h File Reference
#include "BabyLINReturncodes.h"
#include <stddef.h>

Go to the source code of this file.

Data Structures

struct | BL_signal_t
Carries information about one signal. More...
struct | BL_targetid_t
struct | BL_error_t
struct | BL_frame_t
struct | BL_dtl_t
struct | BL_portInfo_t
Information about a BabyLIN port on the host operating system. More...

Typedefs

typedef void( | BL_frame_callback_func )(BL_frame_t frame)
typedef void( | BL_signal_callback_func )(BL_signal_t signal)
typedef void( | BL_buserror_callback_func )(BL_error_t error)
typedef void( | BL_debug_callback_func )(const char *text)
typedef void( | BL_dtl_request_callback_func )(BL_dtl_t frame)
typedef void( | BL_dtl_response_callback_func )(BL_dtl_t frame)

Functions

int BL_DLLIMPORT | BL_searchBabyLinPorts (BL_portInfo_t *pdest, int *psize)
int BL_DLLIMPORT | BL_searchBabyLIN (int port)
void BL_DLLIMPORT | BL_getVersion (int *major, int *minor)
CPCHAR BL_DLLIMPORT | BL_getVersionString (void)
BL_HANDLE BL_DLLIMPORT | BL_open (unsigned int port)
int BL_DLLIMPORT | BL_close (BL_HANDLE handle)
int BL_DLLIMPORT | BL_closeAll (void)
int BL_DLLIMPORT | BL_flush (BL_HANDLE handle)
int BL_DLLIMPORT | BL_getTargetID (BL_HANDLE handle, BL_targetid_t *targetID)
int BL_DLLIMPORT | BL_loadSDF (BL_HANDLE handle, const char *filename, int download)
int BL_DLLIMPORT | BL_downloadSDF (BL_HANDLE handle)
CPCHAR BL_DLLIMPORT | BL_getLastError (BL_HANDLE handle)
int BL_DLLIMPORT | BL_getNodeCount (BL_HANDLE handle)
int BL_DLLIMPORT | BL_getNodeName (BL_HANDLE handle, int idx, char *dstbuf, int buflen)
int BL_DLLIMPORT | BL_getFrameCount (BL_HANDLE handle)
int BL_DLLIMPORT | BL_getFrameName (BL_HANDLE handle, int idx, char *dstbuf, int buflen)
int BL_DLLIMPORT | BL_getSignalCount (BL_HANDLE handle)
int BL_DLLIMPORT | BL_getSignalName (BL_HANDLE handle, int idx, char *dstbuf, int buflen)
int BL_DLLIMPORT | BL_getSignalsInFrameCount (BL_HANDLE handle, int idx)
int BL_DLLIMPORT | BL_getSignalInFrame (BL_HANDLE handle, int frameIndex, int signalIndex)
int BL_DLLIMPORT | BL_getFrameNrForFrameId (BL_HANDLE handle, unsigned char frameId)
int BL_DLLIMPORT | BL_registerFrameCallback (BL_HANDLE handle, BL_frame_callback_func *callback)
int BL_DLLIMPORT | BL_registerSignalCallback (BL_HANDLE handle, BL_signal_callback_func *callback)
int BL_DLLIMPORT | BL_registerBusErrorCallback (BL_HANDLE handle, BL_buserror_callback_func *callback)
int BL_DLLIMPORT | BL_registerDebugCallback (BL_HANDLE handle, BL_debug_callback_func *callback)
int BL_DLLIMPORT | BL_registerDTLRequestCallback (BL_HANDLE handle, BL_dtl_request_callback_func *callback)
int BL_DLLIMPORT | BL_registerDTLResponseCallback (BL_HANDLE handle, BL_dtl_response_callback_func *callback)
int BL_DLLIMPORT | BL_sendCommand (BL_HANDLE handle, const char *command)
int BL_DLLIMPORT | BL_sendCommandD (BL_HANDLE handle, const char *command, char *data, int *length)
int BL_DLLIMPORT | BL_sendCommandF (BL_HANDLE handle, const char *command,...)
int BL_DLLIMPORT | BL_sendCommandFs (BL_HANDLE handle, const char *command, const char *name)
int BL_DLLIMPORT | BL_mon_set (BL_HANDLE handle, int frameid, const int *databytes, int len)
int BL_DLLIMPORT | BL_mon_xmit (BL_HANDLE handle, int frameId, int slottime)
int BL_DLLIMPORT | BL_mon_set_xmit (BL_HANDLE handle, int frameId, const int *databytes, int len, int slottime)
int BL_DLLIMPORT | BL_sendRaw (BL_HANDLE handle, const unsigned char *command, unsigned int *length)
int BL_DLLIMPORT | BL_setDTLMode (BL_HANDLE handle, int mode)
int BL_DLLIMPORT | BL_sendDTLRequest (BL_HANDLE handle, unsigned char nad, int length, unsigned char *data)
int BL_DLLIMPORT | BL_sendDTLResponse (BL_HANDLE handle, unsigned char nad, int length, unsigned char *data)
int BL_DLLIMPORT | BL_sendRawSlaveResponse (BL_HANDLE handle, unsigned char *reqdata, unsigned char *reqmask, unsigned char *data, int length)
int BL_DLLIMPORT | BL_sendRawMasterRequest (BL_HANDLE handle, unsigned char *data, int count)
int BL_DLLIMPORT | BL_getDTLRequestStatus (BL_HANDLE handle)
int BL_DLLIMPORT | BL_getDTLResponseStatus (BL_HANDLE handle)
int BL_DLLIMPORT | BL_getRawSlaveResponse (BL_HANDLE handle, unsigned char *data, int length)
int BL_DLLIMPORT | BL_updRawSlaveResponse (BL_HANDLE handle)
int BL_DLLIMPORT | BL_lastAnswerHasData (BL_HANDLE handle)
int BL_DLLIMPORT | BL_getAnswerTypeByName (BL_HANDLE handle, const char *name, BL_ANSWER_TYPE *type, size_t *length)
int BL_DLLIMPORT | BL_getAnswerTypeByIndex (BL_HANDLE handle, const unsigned int index, BL_ANSWER_TYPE *type, size_t *length)
int BL_DLLIMPORT | BL_getAnswerByName (BL_HANDLE handle, const char *name, void *buffer, size_t length)
int BL_DLLIMPORT | BL_getAnswerByIndex (BL_HANDLE handle, const unsigned int index, void *buffer, size_t length)
int BL_DLLIMPORT | BL_getNextFrame (BL_HANDLE handle, BL_frame_t *framedata)
int BL_DLLIMPORT | BL_getNextFrameTimeout (BL_HANDLE handle, BL_frame_t *framedata, int timeout_ms)
int BL_DLLIMPORT | BL_getLastFrame (BL_HANDLE handle, int frameNr, BL_frame_t *framedata)
int BL_DLLIMPORT | BL_getNextSignal (BL_HANDLE handle, BL_signal_t *signaldata)
int BL_DLLIMPORT | BL_getNextBusError (BL_HANDLE handle, BL_error_t *errordata)
int BL_DLLIMPORT | BL_getNextDTLRequest (BL_HANDLE handle, BL_dtl_t *frame)
int BL_DLLIMPORT | BL_getNextDTLResponse (BL_HANDLE handle, BL_dtl_t *frame)
int BL_DLLIMPORT | BL_getSignalValue (BL_HANDLE handle, int signalNr, unsigned short *value)
int BL_DLLIMPORT | BL_getSignalValueByName (BL_HANDLE handle, const char *signalName, unsigned short *value)
int BL_DLLIMPORT | BL_getSignalArray (BL_HANDLE handle, int signalNr, unsigned char *array)
int BL_DLLIMPORT | BL_getSignalArrayByName (BL_HANDLE handle, const char *signalName, unsigned char *array)
int BL_DLLIMPORT | BL_isSignalArray (BL_HANDLE handle, int idx)
int BL_DLLIMPORT | BL_encodeSignal (BL_HANDLE handle, int signalNr, unsigned int value, char *encSignal, size_t *buffLen0, char *encUnit, size_t *buffLen1)
int BL_DLLIMPORT | BL_getSignalsInFrame (BL_HANDLE handle, int frameNr, BL_signal_t *signalList, int signalListLen)
int BL_DLLIMPORT | BL_getSignalDataFromFrame (BL_HANDLE handle, BL_frame_t *frame, int signalIdx, BL_signal_t *signal)
int BL_DLLIMPORT | BL_getFrameDetails (BL_HANDLE handle, int idx, int *plinid, int *psize, int *pnodenum, int *pframetype)
Returns some details for given frame entry. More...
Generated on Fri May 30 2025 17:16:13 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: C:/JenkinsWS/workspace/orks_v2_LinWorksv2_Windows_trunk/source/externals/BabyLIN/src/libraries/BabyLIN/publicHeaders/BabyLIN.h Source File

  • externals
  • BabyLIN
  • src
  • libraries
  • BabyLIN
  • publicHeaders
BabyLIN.h
Go to the documentation of this file.
1 #ifndef BABYLIN_OLD_H
2 #define BABYLIN_OLD_H
3
4 #include "BabyLINReturncodes.h"
5
18 typedef struct _BL_signal_t {
19 // ! Index number of signal; see the SDF for the adequate number.
20 unsigned char index;
21 // ! Defines whether this signal is a normal, value-based one (0) or LIN2.0 array signal (1).
22 int isArray;
23 // ! Value of the signal.
24 unsigned short value;
25 // ! Length of the array.
26 int arrayLength;
27 // ! Value(s) of the signal, if isArray == 1.
28 unsigned char array[8];
29 } BL_signal_t;
30
31 // ! Return data of the command 'targetid'
32 typedef struct _BL_targetid_t {
47 unsigned short type;
48
49 // ! Software version
50 unsigned short version;
51
52 // ! Software build number
53 unsigned short build;
54
61 unsigned short flags;
62
63 // ! Device's serial number
64 long serial;
65
66 // ! Remaining heap size on device (memory available for SDF dowload)
67 long heapsize;
68
69 // ! Reserved value (ignore for now)
70 long spare;
71
72 // ! Textual name of the device (zero-terminated C-string)
73 char name[128];
74 } BL_targetid_t;
75
76 // ! Represents a LIN error message
77 typedef struct _BL_error_t {
81 unsigned long timestamp;
100 unsigned short type;
105 unsigned short status;
106 } BL_error_t;
107
108 // ! Carries information about one frame
109 typedef struct _BL_frame_t {
110 // ! Set to != 0 if timing information present.
111 unsigned char extended;
112
113 // clang-format off
126 // clang-format on
127 unsigned char flags;
128
129 // ! Global time index of frame transmission start (in us).
130 unsigned long timestamp;
131
132 // ! Duration of BREAK (us, only if extended != 0).
133 unsigned short breaklength;
134
135 // ! Time between BREAK-end and SYNC-end (us, only if extended != 0).
136 unsigned short synctime;
137
138 // ! Length of frame (including ID byte, data bytes and checksum byte). If == 1, only the ID byte
139 // is existent (i.e. unresponded slave response)!
140 unsigned char length;
141
142 // ! Transmitted data, LSB first, up to length tuples.
148 struct {
149 unsigned char value;
150 unsigned short time;
151 } framedata[10];
152
157 unsigned short status;
158 } BL_frame_t;
159
160 // ! Carries information about DTL protocol (both requests and responses).
161 typedef struct _BL_dtl_t {
162 // ! Status of protocol frame see BL_DTL_STATUS for details
163 BL_DTL_STATUS status;
164
165 // ! NAD of protocol frame
166 unsigned char nad;
167
168 // ! Length of the data-array.
169 int length;
170 // ! Frame data, beginning with the (R)SID.
171 unsigned char data[4 * 1024];
172 } BL_dtl_t;
173
179 typedef struct _BL_portInfo_t {
181 int portNr;
183 int type;
185 char name[256];
187 char device[256];
188 } BL_portInfo_t;
189
192 #if defined(__cplusplus)
193 #include <cstddef> // get "size_t", used by function BL_encodeSignal())
194 extern "C" {
195 #else
196 #include <stddef.h> // get "size_t", used by function BL_encodeSignal())
197 #endif
198
207 // ! Returns number of available Baby-LIN devices.
217 int BL_DLLIMPORT BL_searchBabyLinPorts(BL_portInfo_t* pdest, int* psize);
218
219 int BL_DLLIMPORT BL_searchBabyLIN(int port);
220
221 // ! Get the major and minor version number of the library
227 void BL_DLLIMPORT BL_getVersion(int* major, int* minor);
228
229 // ! Get the version string of the library
234 CPCHAR BL_DLLIMPORT BL_getVersionString(void);
235
236 // ! Open a connection to a BabyLIN device.
245 #if defined(_WIN32)
246 BL_HANDLE BL_DLLIMPORT BL_open(unsigned int port);
247 #else
248 BL_HANDLE BL_DLLIMPORT BL_open(const char* port);
249 #endif
250
251 // ! Close connection to Device.
257 int BL_DLLIMPORT BL_close(BL_HANDLE handle);
258
259 // ! Close ALL connections to ALL Devices.
264 int BL_DLLIMPORT BL_closeAll(void);
265
266 // ! Resets the BabyLIN device to an consistent and deactivated state.
273 int BL_DLLIMPORT BL_flush(BL_HANDLE handle);
274
275 // ! Requests the information about the target
284 int BL_DLLIMPORT BL_getTargetID(BL_HANDLE handle, BL_targetid_t* targetID);
285
286 // ! Loads the specified SDF-file into library and optionally the BabyLIN device.
298 int BL_DLLIMPORT BL_loadSDF(BL_HANDLE handle, const char* filename, int download);
299
300 // ! Loads the already loaded SDF-file into the BabyLIN device.
308 int BL_DLLIMPORT BL_downloadSDF(BL_HANDLE handle);
309
310 // ! Returns a C-string with the textual representation of the last error.
320 CPCHAR BL_DLLIMPORT BL_getLastError(BL_HANDLE handle);
321
332 // ! Returns the number of node entries.
337 int BL_DLLIMPORT BL_getNodeCount(BL_HANDLE handle);
338
339 // ! Returns the name of given node entry.
347 int BL_DLLIMPORT BL_getNodeName(BL_HANDLE handle, int idx, char* dstbuf, int buflen);
348
349 // ! Returns the number of frame entries.
354 int BL_DLLIMPORT BL_getFrameCount(BL_HANDLE handle);
355
356 // ! Returns the name of given frame entry.
364 int BL_DLLIMPORT BL_getFrameName(BL_HANDLE handle, int idx, char* dstbuf, int buflen);
365
366 // ! Returns the number of signal entries.
371 int BL_DLLIMPORT BL_getSignalCount(BL_HANDLE handle);
372
373 // ! Returns the name of given signal entry.
382 int BL_DLLIMPORT BL_getSignalName(BL_HANDLE handle, int idx, char* dstbuf, int buflen);
383
384 // ! Returns the number of signal entries in Frame idx.
390 int BL_DLLIMPORT BL_getSignalsInFrameCount(BL_HANDLE handle, int idx);
391
392 int BL_DLLIMPORT BL_getSignalInFrame(BL_HANDLE handle, int frameIndex, int signalIndex);
393
394 int BL_DLLIMPORT BL_getFrameNrForFrameId(BL_HANDLE handle, unsigned char frameId);
395
410 // ! callback function header whenever a frame report is received from a BabyLIN device
411 typedef void(BL_frame_callback_func)(BL_frame_t frame);
412 // ! callback function header whenever a signal report is received from a BabyLIN device
413 typedef void(BL_signal_callback_func)(BL_signal_t signal);
414 // ! callback function header whenever a buserror report is received from a BabyLIN device
415 typedef void(BL_buserror_callback_func)(BL_error_t error);
416 // ! callback function header whenever a debug message is received from a BabyLIN device
417 typedef void(BL_debug_callback_func)(const char* text);
418 // ! callback function header whenever a dtl request is received from a BabyLIN device
419 typedef void(BL_dtl_request_callback_func)(BL_dtl_t frame);
420 // ! callback function header whenever a dtl response is received from a BabyLIN device
421 typedef void(BL_dtl_response_callback_func)(BL_dtl_t frame);
422
423 // ! Registers a callback function, which is called on every reception of a (monitored) frame.
432 int BL_DLLIMPORT BL_registerFrameCallback(BL_HANDLE handle, BL_frame_callback_func* callback);
433
434 // ! Registers a callback function, which is called on every reception of a (monitored) signal.
443 int BL_DLLIMPORT BL_registerSignalCallback(BL_HANDLE handle, BL_signal_callback_func* callback);
444
445 // ! Registers a callback function, which is called on every reception of a bus error.
454 int BL_DLLIMPORT
455 BL_registerBusErrorCallback(BL_HANDLE handle,
456 BL_buserror_callback_func* callback); // for backwards compatibility
457
458 // ! Registers a callback function, which is called on every reception of a debug message.
467 int BL_DLLIMPORT BL_registerDebugCallback(BL_HANDLE handle, BL_debug_callback_func* callback);
468
469 // ! Registers a callback function, which is called on every reception of a DTL request, but only if
470 // at least one Slave is emulated.
479 int BL_DLLIMPORT BL_registerDTLRequestCallback(BL_HANDLE handle,
480 BL_dtl_request_callback_func* callback);
481
482 // ! Registers a callback function, which is called on every reception of a DTL response, but only
483 // if BabyLIN emulates the master node.
492 int BL_DLLIMPORT BL_registerDTLResponseCallback(BL_HANDLE handle,
493 BL_dtl_response_callback_func* callback);
494
506 // ! Sends the (textual) specified command to the BabyLIN device.
515 int BL_DLLIMPORT BL_sendCommand(BL_HANDLE handle, const char* command);
516
517 // ! Sends the (textual) specified command to the BabyLIN device. Data response requested.
531 int BL_DLLIMPORT BL_sendCommandD(BL_HANDLE handle, const char* command, char* data, int* length);
532
533 // ! Sends the (textual) specified command to the BabyLIN device with the ability to insert specific
534 // parameters.
557 int BL_DLLIMPORT BL_sendCommandF(BL_HANDLE handle, const char* command, ...);
558
559 // ! Sends the (textual) specified command to the BabyLIN device with the ability to insert specific
560 // parameters.
583 int BL_DLLIMPORT BL_sendCommandFs(BL_HANDLE handle, const char* command, const char* name);
584
585 int BL_DLLIMPORT BL_mon_set(BL_HANDLE handle, int frameid, const int* databytes, int len);
586 int BL_DLLIMPORT BL_mon_xmit(BL_HANDLE handle, int frameId, int slottime);
587 int BL_DLLIMPORT
588 BL_mon_set_xmit(BL_HANDLE handle, int frameId, const int* databytes, int len, int slottime);
589
590 // ! Sends the (raw!) command to the BabyLIN device.
599 int BL_DLLIMPORT BL_sendRaw(BL_HANDLE handle, const unsigned char* command, unsigned int* length);
600
601 // ! Sets the Diagnostic Transport Layer mode.
621 int BL_DLLIMPORT BL_setDTLMode(BL_HANDLE handle, int mode);
622
623 // ! Sends the given DTL master request to the node identified by 'nad'.
633 int BL_DLLIMPORT BL_sendDTLRequest(BL_HANDLE handle,
634 unsigned char nad,
635 int length,
636 unsigned char* data);
637
638 // ! Sends the given DTL slave response for the node identified by 'nad'.
648 int BL_DLLIMPORT BL_sendDTLResponse(BL_HANDLE handle,
649 unsigned char nad,
650 int length,
651 unsigned char* data);
652
653 // ! Sends the given (non-DTL) slave response upon receive of matching master request with the
654 // specified as data (in as many frames as needed).
669 int BL_DLLIMPORT BL_sendRawSlaveResponse(BL_HANDLE handle,
670 unsigned char* reqdata,
671 unsigned char* reqmask,
672 unsigned char* data,
673 int length);
674
675 // ! Sends the given (non-DTL) master request with the specified 8 bytes as data.
688 int BL_DLLIMPORT BL_sendRawMasterRequest(BL_HANDLE handle, unsigned char* data, int count);
689
690 // ! Returns the status of the last request-send operation.
697 int BL_DLLIMPORT BL_getDTLRequestStatus(BL_HANDLE handle);
698
699 // ! Returns the status of the last request-send operation.
706 int BL_DLLIMPORT BL_getDTLResponseStatus(BL_HANDLE handle);
707
708 // ! Returns the first 'length' bytes of the current slave response-buffer.
720 int BL_DLLIMPORT BL_getRawSlaveResponse(BL_HANDLE handle, unsigned char* data, int length);
721 int BL_DLLIMPORT BL_updRawSlaveResponse(BL_HANDLE handle);
722
723 // ! Returns BL_OK if the last answer to a command contained additional data.
730 int BL_DLLIMPORT BL_lastAnswerHasData(BL_HANDLE handle);
731
732 // ! If the last answer to a command contained additional data, then this function reports
733 // ! the type and size for a specific answer data set. Data set selected by name.
747 int BL_DLLIMPORT BL_getAnswerTypeByName(BL_HANDLE handle,
748 const char* name,
749 BL_ANSWER_TYPE* type,
750 size_t* length);
751
752 // ! If the last answer to a command contained additional data, then this function reports
753 // ! the type and size for a specific answer data set. Data set selected by index.
767 int BL_DLLIMPORT BL_getAnswerTypeByIndex(BL_HANDLE handle,
768 const unsigned int index,
769 BL_ANSWER_TYPE* type,
770 size_t* length);
771
772 // ! If the last answer to a command contained additional data, then this function copies
773 // ! the answer data set over into the destination buffer. Data set selected by name.
783 int BL_DLLIMPORT BL_getAnswerByName(BL_HANDLE handle,
784 const char* name,
785 void* buffer,
786 size_t length);
787
788 // ! If the last answer to a command contained additional data, then this function copies
789 // ! the answer data set over into the destination buffer. Data set selected by index.
799 int BL_DLLIMPORT BL_getAnswerByIndex(BL_HANDLE handle,
800 const unsigned int index,
801 void* buffer,
802 size_t length);
803
817 // ! Fetches the next frame on Channel from the receiver queue.
818 // ! Note: The Device fills the receiver queue only if command "disframe" sent before.
827 int BL_DLLIMPORT BL_getNextFrame(BL_HANDLE handle, BL_frame_t* framedata);
828 int BL_DLLIMPORT BL_getNextFrameTimeout(BL_HANDLE handle, BL_frame_t* framedata, int timeout_ms);
829
830 // ! Fetches the frame with frame ID from the receiver queue.
831 // ! Note: The Baby-LIN fills the receiver queue only if command "disframe" sent before.
841 int BL_DLLIMPORT BL_getLastFrame(BL_HANDLE handle, int frameNr, BL_frame_t* framedata);
842
843 // ! Fetches the next signal from the receiver queue.
844 // ! Note: The Baby-LIN fills the receiver queue only if command "dissignal" sent before.
853 int BL_DLLIMPORT BL_getNextSignal(BL_HANDLE handle, BL_signal_t* signaldata);
854
855 // ! Fetches the next LIN-bus error from the receiver queue.
863 int BL_DLLIMPORT BL_getNextBusError(BL_HANDLE handle, BL_error_t* errordata);
864
865 // ! Fetches the next complete DTL request from the receiver queue.
873 int BL_DLLIMPORT BL_getNextDTLRequest(BL_HANDLE handle, BL_dtl_t* frame);
874
875 // ! Fetches the next complete DTL response from the receiver queue.
883 int BL_DLLIMPORT BL_getNextDTLResponse(BL_HANDLE handle, BL_dtl_t* frame);
884
885 // ! Returns the current signal value (for non-array signals).
886 // ! Note: The Baby-LIN reports the signal value only if command "dissignal" sent before.
896 int BL_DLLIMPORT BL_getSignalValue(BL_HANDLE handle, int signalNr, unsigned short* value);
897
898 // ! Returns the current signal value (for non-array signals).
899 // ! Note: The Baby-LIN reports the signal value only if command "dissignal" sent before.
908 int BL_DLLIMPORT BL_getSignalValueByName(BL_HANDLE handle,
909 const char* signalName,
910 unsigned short* value);
911
912 // ! Returns the current signal value (for array signals).
913 // ! Note: The Baby-LIN reports the signal value only if command "dissignal" sent before.
931 int BL_DLLIMPORT BL_getSignalArray(BL_HANDLE handle, int signalNr, unsigned char* array);
932
933 // ! Returns the current signal value (for array signals).
934 // ! Note: The Baby-LIN reports the signal value only if command "dissignal" sent before.
944 int BL_DLLIMPORT BL_getSignalArrayByName(BL_HANDLE handle,
945 const char* signalName,
946 unsigned char* array);
947
948 // ! Returns the SignalType about of given signal entry.
954 int BL_DLLIMPORT BL_isSignalArray(BL_HANDLE handle, int idx);
955
956 // ! Encodes the signal's value as defined in the corresponding Signal Encoding tables of LDF/SDF.
978 int BL_DLLIMPORT BL_encodeSignal(BL_HANDLE handle,
979 int signalNr,
980 unsigned int value,
981 char* encSignal,
982 size_t* buffLen0,
983 char* encUnit,
984 size_t* buffLen1);
985 int BL_DLLIMPORT BL_getSignalsInFrame(BL_HANDLE handle,
986 int frameNr,
987 BL_signal_t* signalList,
988 int signalListLen);
989 int BL_DLLIMPORT BL_getSignalDataFromFrame(BL_HANDLE handle,
990 BL_frame_t* frame,
991 int signalIdx,
992 BL_signal_t* signal);
993
1006 int BL_DLLIMPORT BL_getFrameDetails(
1007 BL_HANDLE handle, int idx, int* plinid, int* psize, int* pnodenum, int* pframetype);
1008
1011 #if defined(__cplusplus)
1012 } // extern "C"
1013 #endif
1014
1015 #endif // BabyLIN_old.h
BL_getTargetID
int BL_DLLIMPORT BL_getTargetID(BL_HANDLE handle, BL_targetid_t *targetID)
BL_getNodeCount
int BL_DLLIMPORT BL_getNodeCount(BL_HANDLE handle)
BL_signal_t::value
unsigned short value
Definition: BabyLIN.h:24
BL_registerFrameCallback
int BL_DLLIMPORT BL_registerFrameCallback(BL_HANDLE handle, BL_frame_callback_func *callback)
BL_targetid_t::version
unsigned short version
Definition: BabyLIN.h:50
BL_frame_t::timestamp
unsigned long timestamp
Definition: BabyLIN.h:130
BL_getNextDTLResponse
int BL_DLLIMPORT BL_getNextDTLResponse(BL_HANDLE handle, BL_dtl_t *frame)
BL_dtl_t::length
int length
Definition: BabyLIN.h:169
BL_targetid_t::serial
long serial
Definition: BabyLIN.h:64
BL_error_t
Definition: BabyLIN.h:77
BL_getVersionString
CPCHAR BL_DLLIMPORT BL_getVersionString(void)
BL_getFrameName
int BL_DLLIMPORT BL_getFrameName(BL_HANDLE handle, int idx, char *dstbuf, int buflen)
BL_closeAll
int BL_DLLIMPORT BL_closeAll(void)
BL_signal_t
Carries information about one signal.
Definition: BabyLIN.h:18
BL_close
int BL_DLLIMPORT BL_close(BL_HANDLE handle)
BL_getSignalCount
int BL_DLLIMPORT BL_getSignalCount(BL_HANDLE handle)
BL_getFrameNrForFrameId
int BL_DLLIMPORT BL_getFrameNrForFrameId(BL_HANDLE handle, unsigned char frameId)
BL_frame_t::status
unsigned short status
no longer used
Definition: BabyLIN.h:157
BL_getNodeName
int BL_DLLIMPORT BL_getNodeName(BL_HANDLE handle, int idx, char *dstbuf, int buflen)
BL_sendDTLResponse
int BL_DLLIMPORT BL_sendDTLResponse(BL_HANDLE handle, unsigned char nad, int length, unsigned char *data)
BL_getRawSlaveResponse
int BL_DLLIMPORT BL_getRawSlaveResponse(BL_HANDLE handle, unsigned char *data, int length)
BL_lastAnswerHasData
int BL_DLLIMPORT BL_lastAnswerHasData(BL_HANDLE handle)
BL_portInfo_t
Information about a BabyLIN port on the host operating system.
Definition: BabyLIN.h:179
BL_debug_callback_func
void( BL_debug_callback_func)(const char *text)
Definition: BabyLIN.h:417
BL_error_t::status
unsigned short status
Additional error information.
Definition: BabyLIN.h:105
BL_searchBabyLinPorts
int BL_DLLIMPORT BL_searchBabyLinPorts(BL_portInfo_t *pdest, int *psize)
BL_DTL_STATUS
BL_DTL_STATUS
DTL protocol status answers. Part of BLC_DTL data structure. Retrieve status of pending DTL actions u...
Definition: BabyLINReturncodes.h:300
BL_targetid_t::heapsize
long heapsize
Definition: BabyLIN.h:67
BL_getSignalInFrame
int BL_DLLIMPORT BL_getSignalInFrame(BL_HANDLE handle, int frameIndex, int signalIndex)
BL_registerSignalCallback
int BL_DLLIMPORT BL_registerSignalCallback(BL_HANDLE handle, BL_signal_callback_func *callback)
BL_getSignalsInFrame
int BL_DLLIMPORT BL_getSignalsInFrame(BL_HANDLE handle, int frameNr, BL_signal_t *signalList, int signalListLen)
BL_getAnswerTypeByName
int BL_DLLIMPORT BL_getAnswerTypeByName(BL_HANDLE handle, const char *name, BL_ANSWER_TYPE *type, size_t *length)
BL_sendCommandF
int BL_DLLIMPORT BL_sendCommandF(BL_HANDLE handle, const char *command,...)
BL_frame_t
Definition: BabyLIN.h:109
BL_dtl_request_callback_func
void( BL_dtl_request_callback_func)(BL_dtl_t frame)
Definition: BabyLIN.h:419
BL_frame_callback_func
void( BL_frame_callback_func)(BL_frame_t frame)
Definition: BabyLIN.h:411
BL_frame_t::value
unsigned char value
Definition: BabyLIN.h:149
BL_mon_xmit
int BL_DLLIMPORT BL_mon_xmit(BL_HANDLE handle, int frameId, int slottime)
BL_signal_t::index
unsigned char index
Definition: BabyLIN.h:20
BL_buserror_callback_func
void( BL_buserror_callback_func)(BL_error_t error)
Definition: BabyLIN.h:415
BL_getSignalArray
int BL_DLLIMPORT BL_getSignalArray(BL_HANDLE handle, int signalNr, unsigned char *array)
BL_targetid_t::build
unsigned short build
Definition: BabyLIN.h:53
BL_sendCommandFs
int BL_DLLIMPORT BL_sendCommandFs(BL_HANDLE handle, const char *command, const char *name)
BL_isSignalArray
int BL_DLLIMPORT BL_isSignalArray(BL_HANDLE handle, int idx)
BL_encodeSignal
int BL_DLLIMPORT BL_encodeSignal(BL_HANDLE handle, int signalNr, unsigned int value, char *encSignal, size_t *buffLen0, char *encUnit, size_t *buffLen1)
BL_getAnswerByIndex
int BL_DLLIMPORT BL_getAnswerByIndex(BL_HANDLE handle, const unsigned int index, void *buffer, size_t length)
BL_mon_set_xmit
int BL_DLLIMPORT BL_mon_set_xmit(BL_HANDLE handle, int frameId, const int *databytes, int len, int slottime)
BL_getNextFrame
int BL_DLLIMPORT BL_getNextFrame(BL_HANDLE handle, BL_frame_t *framedata)
BL_frame_t::extended
unsigned char extended
Definition: BabyLIN.h:111
BL_getAnswerTypeByIndex
int BL_DLLIMPORT BL_getAnswerTypeByIndex(BL_HANDLE handle, const unsigned int index, BL_ANSWER_TYPE *type, size_t *length)
BL_getDTLResponseStatus
int BL_DLLIMPORT BL_getDTLResponseStatus(BL_HANDLE handle)
BL_portInfo_t::portNr
int portNr
Definition: BabyLIN.h:181
BL_getFrameDetails
int BL_DLLIMPORT BL_getFrameDetails(BL_HANDLE handle, int idx, int *plinid, int *psize, int *pnodenum, int *pframetype)
Returns some details for given frame entry.
BL_portInfo_t::type
int type
Definition: BabyLIN.h:183
BL_ANSWER_TYPE
BL_ANSWER_TYPE
type of an answer data token retrieve type using BLC_getAnswerTypeByName or BLC_getAnswerTypeByIndex ...
Definition: BabyLINReturncodes.h:280
BL_getNextBusError
int BL_DLLIMPORT BL_getNextBusError(BL_HANDLE handle, BL_error_t *errordata)
BL_error_t::timestamp
unsigned long timestamp
Time of occurence (usec, since first start of LIN activity).
Definition: BabyLIN.h:81
BL_HANDLE
void * BL_HANDLE
Definition: BabyLINReturncodes.h:34
BL_getNextDTLRequest
int BL_DLLIMPORT BL_getNextDTLRequest(BL_HANDLE handle, BL_dtl_t *frame)
BL_getAnswerByName
int BL_DLLIMPORT BL_getAnswerByName(BL_HANDLE handle, const char *name, void *buffer, size_t length)
BL_registerDTLRequestCallback
int BL_DLLIMPORT BL_registerDTLRequestCallback(BL_HANDLE handle, BL_dtl_request_callback_func *callback)
BL_sendRaw
int BL_DLLIMPORT BL_sendRaw(BL_HANDLE handle, const unsigned char *command, unsigned int *length)
BL_loadSDF
int BL_DLLIMPORT BL_loadSDF(BL_HANDLE handle, const char *filename, int download)
BL_getLastFrame
int BL_DLLIMPORT BL_getLastFrame(BL_HANDLE handle, int frameNr, BL_frame_t *framedata)
BL_updRawSlaveResponse
int BL_DLLIMPORT BL_updRawSlaveResponse(BL_HANDLE handle)
BL_dtl_t::nad
unsigned char nad
Definition: BabyLIN.h:166
BL_getVersion
void BL_DLLIMPORT BL_getVersion(int *major, int *minor)
BL_targetid_t::spare
long spare
Definition: BabyLIN.h:70
BL_frame_t::synctime
unsigned short synctime
Definition: BabyLIN.h:136
BL_dtl_response_callback_func
void( BL_dtl_response_callback_func)(BL_dtl_t frame)
Definition: BabyLIN.h:421
BL_getNextFrameTimeout
int BL_DLLIMPORT BL_getNextFrameTimeout(BL_HANDLE handle, BL_frame_t *framedata, int timeout_ms)
BL_getSignalValueByName
int BL_DLLIMPORT BL_getSignalValueByName(BL_HANDLE handle, const char *signalName, unsigned short *value)
BL_open
BL_HANDLE BL_DLLIMPORT BL_open(unsigned int port)
BL_sendRawMasterRequest
int BL_DLLIMPORT BL_sendRawMasterRequest(BL_HANDLE handle, unsigned char *data, int count)
BL_getSignalArrayByName
int BL_DLLIMPORT BL_getSignalArrayByName(BL_HANDLE handle, const char *signalName, unsigned char *array)
BL_signal_t::arrayLength
int arrayLength
Definition: BabyLIN.h:26
BL_getLastError
CPCHAR BL_DLLIMPORT BL_getLastError(BL_HANDLE handle)
BL_sendCommand
int BL_DLLIMPORT BL_sendCommand(BL_HANDLE handle, const char *command)
BL_targetid_t
Definition: BabyLIN.h:32
BL_error_t::type
unsigned short type
Error type.
Definition: BabyLIN.h:100
BL_dtl_t
Definition: BabyLIN.h:161
BL_frame_t::time
unsigned short time
Definition: BabyLIN.h:150
BL_getNextSignal
int BL_DLLIMPORT BL_getNextSignal(BL_HANDLE handle, BL_signal_t *signaldata)
BL_getSignalDataFromFrame
int BL_DLLIMPORT BL_getSignalDataFromFrame(BL_HANDLE handle, BL_frame_t *frame, int signalIdx, BL_signal_t *signal)
BL_targetid_t::flags
unsigned short flags
Software related flags.
Definition: BabyLIN.h:61
BL_getSignalValue
int BL_DLLIMPORT BL_getSignalValue(BL_HANDLE handle, int signalNr, unsigned short *value)
BL_DLLIMPORT
#define BL_DLLIMPORT
Definition: BabyLINReturncodes.h:9
BabyLINReturncodes.h
BL_downloadSDF
int BL_DLLIMPORT BL_downloadSDF(BL_HANDLE handle)
BL_signal_callback_func
void( BL_signal_callback_func)(BL_signal_t signal)
Definition: BabyLIN.h:413
BL_setDTLMode
int BL_DLLIMPORT BL_setDTLMode(BL_HANDLE handle, int mode)
BL_registerDTLResponseCallback
int BL_DLLIMPORT BL_registerDTLResponseCallback(BL_HANDLE handle, BL_dtl_response_callback_func *callback)
BL_frame_t::breaklength
unsigned short breaklength
Definition: BabyLIN.h:133
BL_getDTLRequestStatus
int BL_DLLIMPORT BL_getDTLRequestStatus(BL_HANDLE handle)
CPCHAR
const char * CPCHAR
Definition: BabyLINReturncodes.h:36
BL_dtl_t::status
BL_DTL_STATUS status
Definition: BabyLIN.h:163
BL_sendCommandD
int BL_DLLIMPORT BL_sendCommandD(BL_HANDLE handle, const char *command, char *data, int *length)
BL_targetid_t::type
unsigned short type
Type of the hardware.
Definition: BabyLIN.h:47
BL_getSignalsInFrameCount
int BL_DLLIMPORT BL_getSignalsInFrameCount(BL_HANDLE handle, int idx)
BL_searchBabyLIN
int BL_DLLIMPORT BL_searchBabyLIN(int port)
BL_sendDTLRequest
int BL_DLLIMPORT BL_sendDTLRequest(BL_HANDLE handle, unsigned char nad, int length, unsigned char *data)
BL_registerBusErrorCallback
int BL_DLLIMPORT BL_registerBusErrorCallback(BL_HANDLE handle, BL_buserror_callback_func *callback)
BL_getFrameCount
int BL_DLLIMPORT BL_getFrameCount(BL_HANDLE handle)
BL_frame_t::flags
unsigned char flags
Additional, informational flags.
Definition: BabyLIN.h:127
BL_getSignalName
int BL_DLLIMPORT BL_getSignalName(BL_HANDLE handle, int idx, char *dstbuf, int buflen)
BL_sendRawSlaveResponse
int BL_DLLIMPORT BL_sendRawSlaveResponse(BL_HANDLE handle, unsigned char *reqdata, unsigned char *reqmask, unsigned char *data, int length)
BL_frame_t::length
unsigned char length
Definition: BabyLIN.h:140
BL_mon_set
int BL_DLLIMPORT BL_mon_set(BL_HANDLE handle, int frameid, const int *databytes, int len)
BL_signal_t::isArray
int isArray
Definition: BabyLIN.h:22
BL_registerDebugCallback
int BL_DLLIMPORT BL_registerDebugCallback(BL_HANDLE handle, BL_debug_callback_func *callback)
BL_flush
int BL_DLLIMPORT BL_flush(BL_HANDLE handle)
Generated on Fri May 30 2025 17:16:13 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: C:/JenkinsWS/workspace/orks_v2_LinWorksv2_Windows_trunk/source/externals/BabyLIN/src/libraries/BabyLIN/privateHeaders/BabyLIN_Doxygen_Structure.h File Reference

  • externals
  • BabyLIN
  • src
  • libraries
  • BabyLIN
  • privateHeaders
BabyLIN_Doxygen_Structure.h File Reference

Go to the source code of this file.

Generated on Fri May 30 2025 17:16:13 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: C:/JenkinsWS/workspace/orks_v2_LinWorksv2_Windows_trunk/source/externals/BabyLIN/src/libraries/BabyLIN/privateHeaders/BabyLIN_Doxygen_Structure.h Source File

  • externals
  • BabyLIN
  • src
  • libraries
  • BabyLIN
  • privateHeaders
BabyLIN_Doxygen_Structure.h
Go to the documentation of this file.
1 // this header is for doxygen format only
2 // clang-format off
307 // clang-format on
Generated on Fri May 30 2025 17:16:13 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: C:/JenkinsWS/workspace/orks_v2_LinWorksv2_Windows_trunk/source/externals/BabyLIN/src/libraries/BabyLIN/publicHeaders/BabyLIN_RP1210.h File Reference

  • externals
  • BabyLIN
  • src
  • libraries
  • BabyLIN
  • publicHeaders
Data Structures | Macros | Typedefs | Functions
BabyLIN_RP1210.h File Reference
#include <windows.h>
#include <stdbool.h>
#include <stdint.h>
#include "BabyLINReturncodes.h"

Go to the source code of this file.

Data Structures

struct | SCONFIG
struct | SCONFIG_LIST
struct | SBYTEARRAY
struct | BLC_RP1210_DEVICE

Macros

#define | STDCALL WINAPI
#define | STDCALL
#define | HWND void*
#define | RP1210_Reset_Device 0
#define | RP1210_Set_All_Filters_States_to_Pass 3
#define | RP1210_Set_Message_Filtering_For_J1939 4
#define | RP1210_Set_Message_Filtering_For_CAN 5
#define | RP1210_Set_Message_Filtering_For_J1708 7
#define | RP1210_Set_Message_Filtering_For_J1850 8
#define | RP1210_Set_Message_Filtering_For_ISO15765 9
#define | RP1210_Generic_Driver_Command 14
#define | RP1210_Set_J1708_Mode 15
#define | RP1210_Echo_Transmitted_Messages 16
#define | RP1210_Set_All_Filters_States_to_Discard 17
#define | RP1210_Set_Message_Receive 18
#define | RP1210_Protect_J1939_Address 19
#define | RP1210_Set_Broadcast_For_J1708 20
#define | RP1210_Set_Broadcast_For_CAN 21
#define | RP1210_Set_Broadcast_For_J1939 22
#define | RP1210_Set_Broadcast_For_J1850 23
#define | RP1210_Set_J1708_Filter_Type 24
#define | RP1210_Set_J1939_Filter_Type 25
#define | RP1210_Set_CAN_Filter_Type 26
#define | RP1210_Set_J1939_Interpacket_Time 27
#define | RP1210_SetMaxErrorMsgSize 28
#define | RP1210_Disallow_Further_Connections 29
#define | RP1210_Set_J1850_Filter_Type 30
#define | RP1210_Release_J1939_Address 31
#define | RP1210_Set_ISO15765_Filter_Type 32
#define | RP1210_Set_Broadcast_For_ISO15765 33
#define | RP1210_Set_ISO15765_Flow_Control 34
#define | RP1210_Clear_ISO15765_Flow_Control 35
#define | RP1210_Set_J1939_Baud 37
#define | RP1210_Set_ISO15765_Baud 38
#define | RP1210_Set_BlockTimeout 215
#define | RP1210_Set_J1708_Baud 305
#define | RP1210_Flush_Tx_Rx_Buffers 39
#define | RP1210_Set_Broadcast_For_KWP2000 41
#define | RP1210_Set_Broadcast_For_ISO9141 42
#define | RP1210_Get_Protocol_Connection_Speed 45
#define | RP1210_Set_ISO9141KWP2000_Mode 46
#define | RP1210_Set_CAN_Baud 47
#define | RP1210_Get_Wireless_State 48
#define | CONNECTED_WIRED 0
#define | CONNECTED_WIRELESS 1
#define | BIT0 1
#define | BIT1 2
#define | BIT2 4
#define | BIT3 8
#define | BIT4 16
#define | BITS 32
#define | BITE 64
#define | BIT7 128
#define | HIWORD_OF_INT4(x) ((x >> 16) & 0xFFFF)
#define | LOWORD_OF_INT4(x) (x & 0x0000FFFF)
#define | HIBYTE_OF_WORD(x) ((x >> 8) & 0xFF)
#define | LOBYTE_OF_WORD(x) (x & 0x0OFF)
#define | HINIBBLE_OF_CHAR(x) ((x & 0xFO) >> 4)
#define | LONIBBLE_OF_CHAR(x) (x & 0xOF)
#define | BYTEO_OF_INT4(x) LOBYTE_OF_WORD(LOWORD_OF_INT4(x))
#define | BYTE1_OF_INT4(x) HIBYTE_OF_WORD(LOWORD_OF_INT4(x))
#define | BYTE2_0F_INT4(x) LOBYTE_OF_WORD(HIWORD_OF_INT4(x))
#define | BYTE3_0F_INT4(x) HIBYTE_OF_WORD(HIWORD_OF_INT4(x))
#define | CONNECTED 1
#define | NOT_CONNECTED (-1)
#define | FILTER_PASS_NONE 0
#define | FILTER_PASS_SOME 1
#define | FILTER_PASS_ALL 2
#define | NULL_WINDOW 0
#define | BLOCKING_IO 1
#define | NON_BLOCKING_IO 0
#define | BLOCK_INFINITE 0
#define | BLOCK_UNTIL_DONE 0
#define | RETURN_BEFORE_COMPLETION 2
#define | CONVERTED_MODE 1
#define | RAW_MODE 0
#define | MAX_J1708_MESSAGE_LENGTH 512
#define | MAX_J1939_MESSAGE_LENGTH 1796
#define | MAX_ISO15765_MESSAGE_LENGTH 4108
#define | ECHO_OFF 0x00
#define | ECHO_ON 0x01
#define | RECEIVE_ON 0x01
#define | RECEIVE_OFF 0x00
#define | ADD_LIST 0x01
#define | VIEW_B_LIST 0x02
#define | DESTROY_LIST 0x03
#define | REMOVE_ENTRY 0x04
#define | LIST_LENGTH 0x05
#define | FILTER_PGN 0x00000001
#define | FILTER_SOURCE 0x00000004
#define | FILTER_DESTINATION 0x00000008
#define | FILTER_INCLUSIVE 0x00
#define | FILTER_EXCLUSIVE 0x01
#define | SILENT_J1939_CLAIM 0x00
#define | PASS_J1939_CLAIM_MESSAGES 0x01
#define | CHANGE_BAUD_NOW 0x00
#define | MSG_FIRST_CHANGE_BAUD 0x01
#define | RP1210_BAUD_9600 0x00
#define | RP1210_BAUD_19200 0x01
#define | RP1210_BAUD_38400 0x02
#define | RP1210_BAUD_57600 0x03
#define | RP1210_BAUD_125k 0x04
#define | RP1210_BAUD_250k 0x05
#define | RP1210_BAUD_500k 0x06
#define | RP1210_BAUD_1000k 0x07
#define | STANDARD_CAN 0x00
#define | EXTENDED_CAN 0x01
#define | STANDARD_CAN_ISO15765_EXTENDED 0x02
#define | EXTENDED_CAN_ISO15765_EXTENDED 0x03
#define | STANDARD_MIXED_CAN_ISO15765 0x04
#define | ISO15765_ACTUAL_MESSAGE 0x00
#define | ISO15765_CONFIRM 0x01
#define | ISO15765_FF_INDICATION 0x02
#define | ISO15765_RX_ERROR_INDICATION 0x03
#define | N_OK 0x00
#define | N_TIMEOUT_A 0x01
#define | N_TIMEOUT_Bs 0x02
#define | N_TIMEOUT_C 0x03
#define | N_WRONG_SN 0x04
#define | N_INVALID_FS 0x05
#define | N_UNEXP_PDU 0x06
#define | N_WFT_OVRN 0x07
#define | N_BUFFER_OVERFLOW 0x08
#define | N_ERROR 0x09
#define | TRUE 0x01
#define | FALSE 0x00
#define | NO_ERRORS 0
#define | ERR_DLL_NOT_INITIALIZED 128
#define | ERR_INVALID_CLIENT_ID 129
#define | ERR_CLIENT_ALREADY_CONNECTED 130
#define | ERR_CLIENT_AREA_FULL 131
#define | ERR_FREE_MEMORY 132
#define | ERR_NOT_ENOUGH_MEMORY 133
#define | ERR_INVALID_DEVICE 134
#define | ERR_DEVICE_IN_USE 135
#define | ERR_INVALID_PROTOCOL 136
#define | ERR_TX_QUEUE_FULL 137
#define | ERR_TX_QUEUE_CORRUPT 138
#define | ERR_RX_QUEUE_FULL 139
#define | ERR_RX_QUEUE_CORRUPT 140
#define | ERR_MESSAGE_TOO_LONG 141
#define | ERR_HARDWARE_NOT_RESPONDING 142
#define | ERR_COMMAND_NOT_SUPPORTED 143
#define | ERR_INVALID_COMMAND 144
#define | ERR_TXMESSAGE_STATUS 145
#define | ERR_ADDRESS_CLAIM_FAILED 146
#define | ERR_CANNOT_SET_PRIORITY 147
#define | ERR_CLIENT_DISCONNECTED 148
#define | ERR_CONNECT_NOT_ALLOWED 149
#define | ERR_CHANGE_MODE_FAILED 150
#define | ERR_BUS_OFF 151
#define | ERR_COULD_NOT_TX_ADDRESS_CLAIMED 152
#define | ERR_ADDRESS_LOST 153
#define | ERR_CODE_NOT_FOUND 154
#define | ERR_BLOCK_NOT_ALLOWED 155
#define | ERR_MULTIPLE_CLIENTS_CONNECTED 156
#define | ERR_ADDRESS_NEVER_CLAIMED 157
#define | ERR_WINDOW_HANDLE_REQUIRED 158
#define | ERR_MESSAGE_NOT_SENT 159
#define | ERR_MAX_NOTIFY_EXCEEDED 160
#define | ERR_MAX_FILTERS_EXCEEDED 161
#define | ERR_HARDWARE_STATUS_CHANGE 162
#define | ERR_INI_FILE_NOT_IN_WIN_DIR 202
#define | ERR_INI_SECTION_NOT_FOUND 204
#define | ERR_INI_KEY_NOT_FOUND 205
#define | ERR_INVALID_KEY_STRING 206
#define | ERR_DEVICE_NOT_SUPPORTED 207
#define | ERR_INVALID_PORT_PARAM 208
#define | ERR_COMMAND_TIMED_OUT 213
#define | ERR_OS_NOT_SUPPORTED 220
#define | ERR_COMMAND_QUEUE_IS_FULL 222
#define | ERR_CANNOT_SET_CAN_BAUDRATE 224
#define | ERR_CANNOT_CLAIM_BROADCAST_ADDRESS 225
#define | ERR_OUT_OF_ADDRESS_RESOURCES 226
#define | ERR_ADDRESS_RELEASE_FAILED 227
#define | ERR_COMM_DEVICE_IN_USE 230
#define | ERR_DATA_LINK_CONFLICT 441
#define | ERR_ADAPTER_NOT_RESPONDING 453
#define | ERR_CAN_BAUD_SET_NONSTANDARD 454
#define | ERR_MULTIPLE_CONNECTIONS_NOT_ALLOWED_NOW 455
#define | ERR_J1708_BAUD_SET_NONSTANDARD 456
#define | ERR_J1939_BAUD_SET_NONSTANDARD 457
#define | ERR_I5015765_BAUD_SET_NONSTANDARD 458
#define | ERR_INVALID_IOCTL_ID 600
#define | ERR_NULL_PARAMETER 601
#define | ERR_HARDWARE_NOT_SUPPORTED 602
#define | ERR_BABYLIN_DEVICE_NOT_FOUND 1000
#define | GET_CONFIG 0x01
#define | SET_CONFIG 0x02
#define | FIVE_BAUD_INIT 0x04
#define | FAST_INIT 0x05

Typedefs

typedef unsigned char U8

Functions

short BL_DLLIMPORT STDCALL | RP1210_ClientConnect (HWND hwndClient, short nDeviceId, char *fpchProtocol, long lSendBuffer, long lReceiveBuffer, short nIsAppPacketizingIncomingMsgs)
short BL_DLLIMPORT STDCALL | RP1210_ClientDisconnect (short nClientID)
short BL_DLLIMPORT STDCALL | RP1210_SendMessage (short nClientID, char *fpchClientMessage, short nMessageSize, short nNotifyStatusOnTx, short nBlockOnSend)
short BL_DLLIMPORT STDCALL | RP1210_ReadMessage (short nClientID, char *fpchAPIMessage, short nBufferSize, short nBlockOnRead)
short BL_DLLIMPORT STDCALL | RP1210_SendCommand (short nCommandNumber, short nClientID, char *fpchClientCommand, short nMessageSize)
void BL_DLLIMPORT STDCALL | RP1210_ReadVersion (char *fpchDLLMajorVersion, char *fpchDLLMinorVersion, char *fpchAPIMajorVersion, char *fpchAPIMinorVersion)
short BL_DLLIMPORT STDCALL | RP1210_ReadDetailedVersion (short nClientID, char *fpchAPIVersionInfo, char *fpchDLLVersionInfo, char *fpchFWVersionInfo)
short BL_DLLIMPORT STDCALL | RP1210_GetHardwareStatus (short nClientID, char *fpchClientlnfo, short nInfoSize, short nBlockOnRequest)
short BL_DLLIMPORT STDCALL | RP1210_GetErrorMsg (short err_code, char *fpchMessage)
short BL_DLLIMPORT STDCALL | RP1210_GetLastErrorMsg (short err_code, int *SubErrorCode, char *fpchMessage, short nClientID)
int BL_DLLIMPORT | BLC_RP1210_ListAvailableDevices (BLC_RP1210_DEVICE *device_list, int device_list_sz)
List all devices that are available for registration with RP1210. The list will not contain devices that are already registered with RP1210. More...
int BL_DLLIMPORT | BLC_RP1210_ListRegisteredDevices (BLC_RP1210_DEVICE *device_list, int device_list_sz)
List all devices that are registered with RP1210. The list may contain devices that are currently not available (e.g. unplugged). More...
int BL_DLLIMPORT | BLC_RP1210_RegisterAllAvailableDevices (bool remove_unavailable_devices)
Register all available devices with RP1210. More...
int BL_DLLIMPORT | BLC_RP1210_RegisterDevice (BLC_RP1210_DEVICE &device)
Register a device with RP1210. More...
int BL_DLLIMPORT | BLC_RP1210_UnregisterDeviceById (short device_id)
Unregister a device from RP1210 by its device id. More...
int BL_DLLIMPORT | BLC_RP1210_UnregisterDevice (const BLC_RP1210_DEVICE &device)
Unregister a device from RP1210. More...
int BL_DLLIMPORT | BLC_RP1210_UnregisterAllDevices ()
Unregister all devices from RP1210. More...

Macro Definition Documentation

#define ADD_LIST 0x01

Definition at line 122 of file BabyLIN_RP1210.h.

#define BIT0 1

Definition at line 73 of file BabyLIN_RP1210.h.

#define BIT1 2

Definition at line 74 of file BabyLIN_RP1210.h.

#define BIT2 4

Definition at line 75 of file BabyLIN_RP1210.h.

#define BIT3 8

Definition at line 76 of file BabyLIN_RP1210.h.

#define BIT4 16

Definition at line 77 of file BabyLIN_RP1210.h.

#define BIT7 128

Definition at line 80 of file BabyLIN_RP1210.h.

#define BITE 64

Definition at line 79 of file BabyLIN_RP1210.h.

#define BITS 32

Definition at line 78 of file BabyLIN_RP1210.h.

#define BLOCK_INFINITE 0

Definition at line 106 of file BabyLIN_RP1210.h.

#define BLOCK_UNTIL_DONE 0

Definition at line 107 of file BabyLIN_RP1210.h.

#define BLOCKING_IO 1

Definition at line 104 of file BabyLIN_RP1210.h.

#define BYTE1_OF_INT4 ( x ) HIBYTE_OF_WORD(LOWORD_OF_INT4(x))

Definition at line 92 of file BabyLIN_RP1210.h.

#define BYTE2_0F_INT4 ( x ) LOBYTE_OF_WORD(HIWORD_OF_INT4(x))

Definition at line 93 of file BabyLIN_RP1210.h.

#define BYTE3_0F_INT4 ( x ) HIBYTE_OF_WORD(HIWORD_OF_INT4(x))

Definition at line 94 of file BabyLIN_RP1210.h.

#define BYTEO_OF_INT4 ( x ) LOBYTE_OF_WORD(LOWORD_OF_INT4(x))

Definition at line 91 of file BabyLIN_RP1210.h.

#define CHANGE_BAUD_NOW 0x00

Definition at line 137 of file BabyLIN_RP1210.h.

#define CONNECTED 1

Definition at line 96 of file BabyLIN_RP1210.h.

#define CONNECTED_WIRED 0

Definition at line 70 of file BabyLIN_RP1210.h.

#define CONNECTED_WIRELESS 1

Definition at line 71 of file BabyLIN_RP1210.h.

#define CONVERTED_MODE 1

Definition at line 109 of file BabyLIN_RP1210.h.

#define DESTROY_LIST 0x03

Definition at line 124 of file BabyLIN_RP1210.h.

#define ECHO_OFF 0x00

Definition at line 116 of file BabyLIN_RP1210.h.

#define ECHO_ON 0x01

Definition at line 117 of file BabyLIN_RP1210.h.

#define ERR_ADAPTER_NOT_RESPONDING 453

Definition at line 229 of file BabyLIN_RP1210.h.

#define ERR_ADDRESS_CLAIM_FAILED 146

Definition at line 197 of file BabyLIN_RP1210.h.

#define ERR_ADDRESS_LOST 153

Definition at line 204 of file BabyLIN_RP1210.h.

#define ERR_ADDRESS_NEVER_CLAIMED 157

Definition at line 208 of file BabyLIN_RP1210.h.

#define ERR_ADDRESS_RELEASE_FAILED 227

Definition at line 226 of file BabyLIN_RP1210.h.

#define ERR_BABYLIN_DEVICE_NOT_FOUND 1000

Definition at line 240 of file BabyLIN_RP1210.h.

#define ERR_BLOCK_NOT_ALLOWED 155

Definition at line 206 of file BabyLIN_RP1210.h.

#define ERR_BUS_OFF 151

Definition at line 202 of file BabyLIN_RP1210.h.

#define ERR_CAN_BAUD_SET_NONSTANDARD 454

Definition at line 230 of file BabyLIN_RP1210.h.

#define ERR_CANNOT_CLAIM_BROADCAST_ADDRESS 225

Definition at line 224 of file BabyLIN_RP1210.h.

#define ERR_CANNOT_SET_CAN_BAUDRATE 224

Definition at line 223 of file BabyLIN_RP1210.h.

#define ERR_CANNOT_SET_PRIORITY 147

Definition at line 198 of file BabyLIN_RP1210.h.

#define ERR_CHANGE_MODE_FAILED 150

Definition at line 201 of file BabyLIN_RP1210.h.

#define ERR_CLIENT_ALREADY_CONNECTED 130

Definition at line 181 of file BabyLIN_RP1210.h.

#define ERR_CLIENT_AREA_FULL 131

Definition at line 182 of file BabyLIN_RP1210.h.

#define ERR_CLIENT_DISCONNECTED 148

Definition at line 199 of file BabyLIN_RP1210.h.

#define ERR_CODE_NOT_FOUND 154

Definition at line 205 of file BabyLIN_RP1210.h.

#define ERR_COMM_DEVICE_IN_USE 230

Definition at line 227 of file BabyLIN_RP1210.h.

#define ERR_COMMAND_NOT_SUPPORTED 143

Definition at line 194 of file BabyLIN_RP1210.h.

#define ERR_COMMAND_QUEUE_IS_FULL 222

Definition at line 222 of file BabyLIN_RP1210.h.

#define ERR_COMMAND_TIMED_OUT 213

Definition at line 220 of file BabyLIN_RP1210.h.

#define ERR_CONNECT_NOT_ALLOWED 149

Definition at line 200 of file BabyLIN_RP1210.h.

#define ERR_COULD_NOT_TX_ADDRESS_CLAIMED 152

Definition at line 203 of file BabyLIN_RP1210.h.

#define ERR_DATA_LINK_CONFLICT 441

Definition at line 228 of file BabyLIN_RP1210.h.

#define ERR_DEVICE_IN_USE 135

Definition at line 186 of file BabyLIN_RP1210.h.

#define ERR_DEVICE_NOT_SUPPORTED 207

Definition at line 218 of file BabyLIN_RP1210.h.

#define ERR_DLL_NOT_INITIALIZED 128

Definition at line 179 of file BabyLIN_RP1210.h.

#define ERR_FREE_MEMORY 132

Definition at line 183 of file BabyLIN_RP1210.h.

#define ERR_HARDWARE_NOT_RESPONDING 142

Definition at line 193 of file BabyLIN_RP1210.h.

#define ERR_HARDWARE_NOT_SUPPORTED 602

Definition at line 237 of file BabyLIN_RP1210.h.

#define ERR_HARDWARE_STATUS_CHANGE 162

Definition at line 213 of file BabyLIN_RP1210.h.

#define ERR_I5015765_BAUD_SET_NONSTANDARD 458

Definition at line 234 of file BabyLIN_RP1210.h.

#define ERR_INI_FILE_NOT_IN_WIN_DIR 202

Definition at line 214 of file BabyLIN_RP1210.h.

#define ERR_INI_KEY_NOT_FOUND 205

Definition at line 216 of file BabyLIN_RP1210.h.

#define ERR_INI_SECTION_NOT_FOUND 204

Definition at line 215 of file BabyLIN_RP1210.h.

#define ERR_INVALID_CLIENT_ID 129

Definition at line 180 of file BabyLIN_RP1210.h.

#define ERR_INVALID_COMMAND 144

Definition at line 195 of file BabyLIN_RP1210.h.

#define ERR_INVALID_DEVICE 134

Definition at line 185 of file BabyLIN_RP1210.h.

#define ERR_INVALID_IOCTL_ID 600

Definition at line 235 of file BabyLIN_RP1210.h.

#define ERR_INVALID_KEY_STRING 206

Definition at line 217 of file BabyLIN_RP1210.h.

#define ERR_INVALID_PORT_PARAM 208

Definition at line 219 of file BabyLIN_RP1210.h.

#define ERR_INVALID_PROTOCOL 136

Definition at line 187 of file BabyLIN_RP1210.h.

#define ERR_J1708_BAUD_SET_NONSTANDARD 456

Definition at line 232 of file BabyLIN_RP1210.h.

#define ERR_J1939_BAUD_SET_NONSTANDARD 457

Definition at line 233 of file BabyLIN_RP1210.h.

#define ERR_MAX_FILTERS_EXCEEDED 161

Definition at line 212 of file BabyLIN_RP1210.h.

#define ERR_MAX_NOTIFY_EXCEEDED 160

Definition at line 211 of file BabyLIN_RP1210.h.

#define ERR_MESSAGE_NOT_SENT 159

Definition at line 210 of file BabyLIN_RP1210.h.

#define ERR_MESSAGE_TOO_LONG 141

Definition at line 192 of file BabyLIN_RP1210.h.

#define ERR_MULTIPLE_CLIENTS_CONNECTED 156

Definition at line 207 of file BabyLIN_RP1210.h.

#define ERR_MULTIPLE_CONNECTIONS_NOT_ALLOWED_NOW 455

Definition at line 231 of file BabyLIN_RP1210.h.

#define ERR_NOT_ENOUGH_MEMORY 133

Definition at line 184 of file BabyLIN_RP1210.h.

#define ERR_NULL_PARAMETER 601

Definition at line 236 of file BabyLIN_RP1210.h.

#define ERR_OS_NOT_SUPPORTED 220

Definition at line 221 of file BabyLIN_RP1210.h.

#define ERR_OUT_OF_ADDRESS_RESOURCES 226

Definition at line 225 of file BabyLIN_RP1210.h.

#define ERR_RX_QUEUE_CORRUPT 140

Definition at line 191 of file BabyLIN_RP1210.h.

#define ERR_RX_QUEUE_FULL 139

Definition at line 190 of file BabyLIN_RP1210.h.

#define ERR_TX_QUEUE_CORRUPT 138

Definition at line 189 of file BabyLIN_RP1210.h.

#define ERR_TX_QUEUE_FULL 137

Definition at line 188 of file BabyLIN_RP1210.h.

#define ERR_TXMESSAGE_STATUS 145

Definition at line 196 of file BabyLIN_RP1210.h.

#define ERR_WINDOW_HANDLE_REQUIRED 158

Definition at line 209 of file BabyLIN_RP1210.h.

#define EXTENDED_CAN 0x01

Definition at line 149 of file BabyLIN_RP1210.h.

#define EXTENDED_CAN_ISO15765_EXTENDED 0x03

Definition at line 151 of file BabyLIN_RP1210.h.

#define FALSE 0x00

Definition at line 172 of file BabyLIN_RP1210.h.

#define FAST_INIT 0x05

Definition at line 246 of file BabyLIN_RP1210.h.

#define FILTER_DESTINATION 0x00000008

Definition at line 130 of file BabyLIN_RP1210.h.

#define FILTER_EXCLUSIVE 0x01

Definition at line 132 of file BabyLIN_RP1210.h.

#define FILTER_INCLUSIVE 0x00

Definition at line 131 of file BabyLIN_RP1210.h.

#define FILTER_PASS_ALL 2

Definition at line 100 of file BabyLIN_RP1210.h.

#define FILTER_PASS_NONE 0

Definition at line 98 of file BabyLIN_RP1210.h.

#define FILTER_PASS_SOME 1

Definition at line 99 of file BabyLIN_RP1210.h.

#define FILTER_PGN 0x00000001

Definition at line 128 of file BabyLIN_RP1210.h.

#define FILTER_SOURCE 0x00000004

Definition at line 129 of file BabyLIN_RP1210.h.

#define FIVE_BAUD_INIT 0x04

Definition at line 245 of file BabyLIN_RP1210.h.

#define GET_CONFIG 0x01

Definition at line 243 of file BabyLIN_RP1210.h.

#define HIBYTE_OF_WORD ( x ) ((x >> 8) & 0xFF)

Definition at line 87 of file BabyLIN_RP1210.h.

#define HINIBBLE_OF_CHAR ( x ) ((x & 0xFO) >> 4)

Definition at line 89 of file BabyLIN_RP1210.h.

#define HIWORD_OF_INT4 ( x ) ((x >> 16) & 0xFFFF)

Definition at line 85 of file BabyLIN_RP1210.h.

#define HWND void*

Definition at line 16 of file BabyLIN_RP1210.h.

#define ISO15765_ACTUAL_MESSAGE 0x00

Definition at line 154 of file BabyLIN_RP1210.h.

#define ISO15765_CONFIRM 0x01

Definition at line 155 of file BabyLIN_RP1210.h.

#define ISO15765_FF_INDICATION 0x02

Definition at line 156 of file BabyLIN_RP1210.h.

#define ISO15765_RX_ERROR_INDICATION 0x03

Definition at line 157 of file BabyLIN_RP1210.h.

#define LIST_LENGTH 0x05

Definition at line 126 of file BabyLIN_RP1210.h.

#define LOBYTE_OF_WORD ( x ) (x & 0x0OFF)

Definition at line 88 of file BabyLIN_RP1210.h.

#define LONIBBLE_OF_CHAR ( x ) (x & 0xOF)

Definition at line 90 of file BabyLIN_RP1210.h.

#define LOWORD_OF_INT4 ( x ) (x & 0x0000FFFF)

Definition at line 86 of file BabyLIN_RP1210.h.

#define MAX_ISO15765_MESSAGE_LENGTH 4108

Definition at line 114 of file BabyLIN_RP1210.h.

#define MAX_J1708_MESSAGE_LENGTH 512

Definition at line 112 of file BabyLIN_RP1210.h.

#define MAX_J1939_MESSAGE_LENGTH 1796

Definition at line 113 of file BabyLIN_RP1210.h.

#define MSG_FIRST_CHANGE_BAUD 0x01

Definition at line 138 of file BabyLIN_RP1210.h.

#define N_BUFFER_OVERFLOW 0x08

Definition at line 167 of file BabyLIN_RP1210.h.

#define N_ERROR 0x09

Definition at line 168 of file BabyLIN_RP1210.h.

#define N_INVALID_FS 0x05

Definition at line 164 of file BabyLIN_RP1210.h.

#define N_OK 0x00

Definition at line 159 of file BabyLIN_RP1210.h.

#define N_TIMEOUT_A 0x01

Definition at line 160 of file BabyLIN_RP1210.h.

#define N_TIMEOUT_Bs 0x02

Definition at line 161 of file BabyLIN_RP1210.h.

#define N_TIMEOUT_C 0x03

Definition at line 162 of file BabyLIN_RP1210.h.

#define N_UNEXP_PDU 0x06

Definition at line 165 of file BabyLIN_RP1210.h.

#define N_WFT_OVRN 0x07

Definition at line 166 of file BabyLIN_RP1210.h.

#define N_WRONG_SN 0x04

Definition at line 163 of file BabyLIN_RP1210.h.

#define NO_ERRORS 0

Definition at line 178 of file BabyLIN_RP1210.h.

#define NON_BLOCKING_IO 0

Definition at line 105 of file BabyLIN_RP1210.h.

#define NOT_CONNECTED (-1)

Definition at line 97 of file BabyLIN_RP1210.h.

#define NULL_WINDOW 0

Definition at line 102 of file BabyLIN_RP1210.h.

#define PASS_J1939_CLAIM_MESSAGES 0x01

Definition at line 135 of file BabyLIN_RP1210.h.

#define RAW_MODE 0

Definition at line 110 of file BabyLIN_RP1210.h.

#define RECEIVE_OFF 0x00

Definition at line 120 of file BabyLIN_RP1210.h.

#define RECEIVE_ON 0x01

Definition at line 119 of file BabyLIN_RP1210.h.

#define REMOVE_ENTRY 0x04

Definition at line 125 of file BabyLIN_RP1210.h.

#define RETURN_BEFORE_COMPLETION 2

Definition at line 108 of file BabyLIN_RP1210.h.

#define RP1210_BAUD_1000k 0x07

Definition at line 146 of file BabyLIN_RP1210.h.

#define RP1210_BAUD_125k 0x04

Definition at line 143 of file BabyLIN_RP1210.h.

#define RP1210_BAUD_19200 0x01

Definition at line 140 of file BabyLIN_RP1210.h.

#define RP1210_BAUD_250k 0x05

Definition at line 144 of file BabyLIN_RP1210.h.

#define RP1210_BAUD_38400 0x02

Definition at line 141 of file BabyLIN_RP1210.h.

#define RP1210_BAUD_500k 0x06

Definition at line 145 of file BabyLIN_RP1210.h.

#define RP1210_BAUD_57600 0x03

Definition at line 142 of file BabyLIN_RP1210.h.

#define RP1210_BAUD_9600 0x00

Definition at line 139 of file BabyLIN_RP1210.h.

#define RP1210_Clear_ISO15765_Flow_Control 35

Definition at line 54 of file BabyLIN_RP1210.h.

#define RP1210_Disallow_Further_Connections 29

Definition at line 48 of file BabyLIN_RP1210.h.

#define RP1210_Echo_Transmitted_Messages 16

Definition at line 35 of file BabyLIN_RP1210.h.

#define RP1210_Flush_Tx_Rx_Buffers 39

Definition at line 59 of file BabyLIN_RP1210.h.

#define RP1210_Generic_Driver_Command 14

Definition at line 33 of file BabyLIN_RP1210.h.

#define RP1210_Get_Protocol_Connection_Speed 45

Definition at line 62 of file BabyLIN_RP1210.h.

#define RP1210_Get_Wireless_State 48

Definition at line 65 of file BabyLIN_RP1210.h.

#define RP1210_Protect_J1939_Address 19

Definition at line 38 of file BabyLIN_RP1210.h.

#define RP1210_Release_J1939_Address 31

Definition at line 50 of file BabyLIN_RP1210.h.

#define RP1210_Reset_Device 0

Definition at line 26 of file BabyLIN_RP1210.h.

#define RP1210_Set_All_Filters_States_to_Discard 17

Definition at line 36 of file BabyLIN_RP1210.h.

#define RP1210_Set_All_Filters_States_to_Pass 3

Definition at line 27 of file BabyLIN_RP1210.h.

#define RP1210_Set_BlockTimeout 215

Definition at line 57 of file BabyLIN_RP1210.h.

#define RP1210_Set_Broadcast_For_CAN 21

Definition at line 40 of file BabyLIN_RP1210.h.

#define RP1210_Set_Broadcast_For_ISO15765 33

Definition at line 52 of file BabyLIN_RP1210.h.

#define RP1210_Set_Broadcast_For_ISO9141 42

Definition at line 61 of file BabyLIN_RP1210.h.

#define RP1210_Set_Broadcast_For_J1708 20

Definition at line 39 of file BabyLIN_RP1210.h.

#define RP1210_Set_Broadcast_For_J1850 23

Definition at line 42 of file BabyLIN_RP1210.h.

#define RP1210_Set_Broadcast_For_J1939 22

Definition at line 41 of file BabyLIN_RP1210.h.

#define RP1210_Set_Broadcast_For_KWP2000 41

Definition at line 60 of file BabyLIN_RP1210.h.

#define RP1210_Set_CAN_Baud 47

Definition at line 64 of file BabyLIN_RP1210.h.

#define RP1210_Set_CAN_Filter_Type 26

Definition at line 45 of file BabyLIN_RP1210.h.

#define RP1210_Set_ISO15765_Baud 38

Definition at line 56 of file BabyLIN_RP1210.h.

#define RP1210_Set_ISO15765_Filter_Type 32

Definition at line 51 of file BabyLIN_RP1210.h.

#define RP1210_Set_ISO15765_Flow_Control 34

Definition at line 53 of file BabyLIN_RP1210.h.

#define RP1210_Set_ISO9141KWP2000_Mode 46

Definition at line 63 of file BabyLIN_RP1210.h.

#define RP1210_Set_J1708_Baud 305

Definition at line 58 of file BabyLIN_RP1210.h.

#define RP1210_Set_J1708_Filter_Type 24

Definition at line 43 of file BabyLIN_RP1210.h.

#define RP1210_Set_J1708_Mode 15

Definition at line 34 of file BabyLIN_RP1210.h.

#define RP1210_Set_J1850_Filter_Type 30

Definition at line 49 of file BabyLIN_RP1210.h.

#define RP1210_Set_J1939_Baud 37

Definition at line 55 of file BabyLIN_RP1210.h.

#define RP1210_Set_J1939_Filter_Type 25

Definition at line 44 of file BabyLIN_RP1210.h.

#define RP1210_Set_J1939_Interpacket_Time 27

Definition at line 46 of file BabyLIN_RP1210.h.

#define RP1210_Set_Message_Filtering_For_CAN 5

Definition at line 29 of file BabyLIN_RP1210.h.

#define RP1210_Set_Message_Filtering_For_ISO15765 9

Definition at line 32 of file BabyLIN_RP1210.h.

#define RP1210_Set_Message_Filtering_For_J1708 7

Definition at line 30 of file BabyLIN_RP1210.h.

#define RP1210_Set_Message_Filtering_For_J1850 8

Definition at line 31 of file BabyLIN_RP1210.h.

#define RP1210_Set_Message_Filtering_For_J1939 4

Definition at line 28 of file BabyLIN_RP1210.h.

#define RP1210_Set_Message_Receive 18

Definition at line 37 of file BabyLIN_RP1210.h.

#define RP1210_SetMaxErrorMsgSize 28

Definition at line 47 of file BabyLIN_RP1210.h.

#define SET_CONFIG 0x02

Definition at line 244 of file BabyLIN_RP1210.h.

#define SILENT_J1939_CLAIM 0x00

Definition at line 134 of file BabyLIN_RP1210.h.

#define STANDARD_CAN 0x00

Definition at line 148 of file BabyLIN_RP1210.h.

#define STANDARD_CAN_ISO15765_EXTENDED 0x02

Definition at line 150 of file BabyLIN_RP1210.h.

#define STANDARD_MIXED_CAN_ISO15765 0x04

Definition at line 152 of file BabyLIN_RP1210.h.

#define STDCALL WINAPI

Definition at line 15 of file BabyLIN_RP1210.h.

#define STDCALL

Definition at line 15 of file BabyLIN_RP1210.h.

#define TRUE 0x01

Definition at line 171 of file BabyLIN_RP1210.h.

#define VIEW_B_LIST 0x02

Definition at line 123 of file BabyLIN_RP1210.h.

Typedef Documentation

typedef unsigned char U8

Definition at line 24 of file BabyLIN_RP1210.h.

Function Documentation

int BL_DLLIMPORT BLC_RP1210_ListAvailableDevices | ( | BLC_RP1210_DEVICE * | device_list,
 |  | int | device_list_sz
 | ) |  |
Parameters
[in] | device_list | Pointer to a pre-allocated array of BLC_RP1210_DEVICE structures. May be NULL.
[in] | device_list_sz | Size of the device_list array, may be 0 if device_list is NULL.
Returns
Status of operation; '>=0' means number of available devices, '<0' indicates an error.
int BL_DLLIMPORT BLC_RP1210_ListRegisteredDevices | ( | BLC_RP1210_DEVICE * | device_list,
 |  | int | device_list_sz
 | ) |  |
Parameters
[in] | device_list | Pointer to a pre-allocated array of BLC_RP1210_DEVICE structures. May be NULL.
[in] | device_list_sz | Size of the device_list array, may be 0 if device_list is NULL.
Returns
Status of operation; '>=0' means number of registered devices, '<0' indicates an error.
int BL_DLLIMPORT BLC_RP1210_RegisterAllAvailableDevices ( bool remove_unavailable_devices )
Parameters
[in] remove_unavailable_devices If true, devices that are no longer available will be unregistered.
Returns
Status of operation; '>=0' means number of registered devices, '<0' indicates an error.
int BL_DLLIMPORT BLC_RP1210_RegisterDevice ( BLC_RP1210_DEVICE & device )
Parameters
[in] device Device to register. Must be valid.
Returns
Status of operation; '>0' is the device id of the registered device, '<0' indicates an error.
int BL_DLLIMPORT BLC_RP1210_UnregisterAllDevices ( )
Returns
Status of operation; '=0' means successful, '!=0' indicates an error.
int BL_DLLIMPORT BLC_RP1210_UnregisterDevice ( const BLC_RP1210_DEVICE & device )
Parameters
[in] device Device to unregister. Must be valid.
Returns
Status of operation; '=0' means successful, '!=0' indicates an error.
int BL_DLLIMPORT BLC_RP1210_UnregisterDeviceById ( short device_id )
Parameters
[in] device_id Device id of the device to unregister.
Returns
Status of operation; '>0' is the device id of the registered device, '<0' indicates an error.
short BL_DLLIMPORT STDCALL RP1210_ClientConnect | ( | HWND | hwndClient,
 |  | short | nDeviceId,
 |  | char * | fpchProtocol,
 |  | long | lSendBuffer,
 |  | long | lReceiveBuffer,
 |  | short | nIsAppPacketizingIncomingMsgs
 | ) |  |
short BL_DLLIMPORT STDCALL RP1210_ClientDisconnect ( short nClientID )
short BL_DLLIMPORT STDCALL RP1210_GetErrorMsg | ( | short | err_code,
 |  | char * | fpchMessage
 | ) |  |
short BL_DLLIMPORT STDCALL RP1210_GetHardwareStatus | ( | short | nClientID,
 |  | char * | fpchClientlnfo,
 |  | short | nInfoSize,
 |  | short | nBlockOnRequest
 | ) |  |
short BL_DLLIMPORT STDCALL RP1210_GetLastErrorMsg | ( | short | err_code,
 |  | int * | SubErrorCode,
 |  | char * | fpchMessage,
 |  | short | nClientID
 | ) |  |
short BL_DLLIMPORT STDCALL RP1210_ReadDetailedVersion | ( | short | nClientID,
 |  | char * | fpchAPIVersionInfo,
 |  | char * | fpchDLLVersionInfo,
 |  | char * | fpchFWVersionInfo
 | ) |  |
short BL_DLLIMPORT STDCALL RP1210_ReadMessage | ( | short | nClientID,
 |  | char * | fpchAPIMessage,
 |  | short | nBufferSize,
 |  | short | nBlockOnRead
 | ) |  |
void BL_DLLIMPORT STDCALL RP1210_ReadVersion | ( | char * | fpchDLLMajorVersion,
 |  | char * | fpchDLLMinorVersion,
 |  | char * | fpchAPIMajorVersion,
 |  | char * | fpchAPIMinorVersion
 | ) |  |
short BL_DLLIMPORT STDCALL RP1210_SendCommand | ( | short | nCommandNumber,
 |  | short | nClientID,
 |  | char * | fpchClientCommand,
 |  | short | nMessageSize
 | ) |  |
short BL_DLLIMPORT STDCALL RP1210_SendMessage | ( | short | nClientID,
 |  | char * | fpchClientMessage,
 |  | short | nMessageSize,
 |  | short | nNotifyStatusOnTx,
 |  | short | nBlockOnSend
 | ) |  |
Generated on Fri May 30 2025 17:16:13 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: C:/JenkinsWS/workspace/orks_v2_LinWorksv2_Windows_trunk/source/externals/BabyLIN/src/libraries/BabyLIN/publicHeaders/BabyLIN_RP1210.h Source File

  • externals
  • BabyLIN
  • src
  • libraries
  • BabyLIN
  • publicHeaders
BabyLIN_RP1210.h
Go to the documentation of this file.
1 #ifndef BABYLIN_RP1210_H
2 #define BABYLIN_RP1210_H
3
4 #ifdef __cplusplus
5 extern "C" {
6 #endif
7
8 #ifdef _WIN32
9 #include <windows.h>
10 #define STDCALL WINAPI
11 #endif
12
13 // No STDCALL on non-Windows platforms
14 #ifndef WIN32
15 #define STDCALL
16 #define HWND void*
17 #endif
18
19 #include <stdbool.h>
20 #include <stdint.h>
21
22 #include "BabyLINReturncodes.h"
23
24 typedef unsigned char U8;
25
26 #define RP1210_Reset_Device 0
27 #define RP1210_Set_All_Filters_States_to_Pass 3
28 #define RP1210_Set_Message_Filtering_For_J1939 4
29 #define RP1210_Set_Message_Filtering_For_CAN 5
30 #define RP1210_Set_Message_Filtering_For_J1708 7
31 #define RP1210_Set_Message_Filtering_For_J1850 8
32 #define RP1210_Set_Message_Filtering_For_ISO15765 9
33 #define RP1210_Generic_Driver_Command 14
34 #define RP1210_Set_J1708_Mode 15
35 #define RP1210_Echo_Transmitted_Messages 16
36 #define RP1210_Set_All_Filters_States_to_Discard 17
37 #define RP1210_Set_Message_Receive 18
38 #define RP1210_Protect_J1939_Address 19
39 #define RP1210_Set_Broadcast_For_J1708 20
40 #define RP1210_Set_Broadcast_For_CAN 21
41 #define RP1210_Set_Broadcast_For_J1939 22
42 #define RP1210_Set_Broadcast_For_J1850 23
43 #define RP1210_Set_J1708_Filter_Type 24
44 #define RP1210_Set_J1939_Filter_Type 25
45 #define RP1210_Set_CAN_Filter_Type 26
46 #define RP1210_Set_J1939_Interpacket_Time 27
47 #define RP1210_SetMaxErrorMsgSize 28
48 #define RP1210_Disallow_Further_Connections 29
49 #define RP1210_Set_J1850_Filter_Type 30
50 #define RP1210_Release_J1939_Address 31
51 #define RP1210_Set_ISO15765_Filter_Type 32
52 #define RP1210_Set_Broadcast_For_ISO15765 33
53 #define RP1210_Set_ISO15765_Flow_Control 34
54 #define RP1210_Clear_ISO15765_Flow_Control 35
55 #define RP1210_Set_J1939_Baud 37
56 #define RP1210_Set_ISO15765_Baud 38
57 #define RP1210_Set_BlockTimeout 215
58 #define RP1210_Set_J1708_Baud 305
59 #define RP1210_Flush_Tx_Rx_Buffers 39
60 #define RP1210_Set_Broadcast_For_KWP2000 41
61 #define RP1210_Set_Broadcast_For_ISO9141 42
62 #define RP1210_Get_Protocol_Connection_Speed 45
63 #define RP1210_Set_ISO9141KWP2000_Mode 46
64 #define RP1210_Set_CAN_Baud 47
65 #define RP1210_Get_Wireless_State 48
66
67 //
68 // RP1210C Constants
69 //
70 #define CONNECTED_WIRED 0
71 #define CONNECTED_WIRELESS 1
72
73 #define BIT0 1 // Bit 0 - Used for masking bits
74 #define BIT1 2 // Bit 1 - Used for masking bits
75 #define BIT2 4 // Bit 2 - Used for masking bits
76 #define BIT3 8 // Bit 3 - Used for masking bits
77 #define BIT4 16 // Bit 4 - Used for masking bits
78 #define BITS 32 // Bit 5 - Used for masking bits
79 #define BITE 64 // Bit 6 - Used for masking bits
80 #define BIT7 128 // Bit 7 - Used for masking bits
81
82 //
83 // Defined used to help in unpacking Motorola format numbers.
84 //
85 #define HIWORD_OF_INT4(x) ((x >> 16) & 0xFFFF)
86 #define LOWORD_OF_INT4(x) (x & 0x0000FFFF)
87 #define HIBYTE_OF_WORD(x) ((x >> 8) & 0xFF)
88 #define LOBYTE_OF_WORD(x) (x & 0x0OFF)
89 #define HINIBBLE_OF_CHAR(x) ((x & 0xFO) >> 4)
90 #define LONIBBLE_OF_CHAR(x) (x & 0xOF)
91 #define BYTEO_OF_INT4(x) LOBYTE_OF_WORD(LOWORD_OF_INT4(x))
92 #define BYTE1_OF_INT4(x) HIBYTE_OF_WORD(LOWORD_OF_INT4(x))
93 #define BYTE2_0F_INT4(x) LOBYTE_OF_WORD(HIWORD_OF_INT4(x))
94 #define BYTE3_0F_INT4(x) HIBYTE_OF_WORD(HIWORD_OF_INT4(x))
95
96 #define CONNECTED 1 // Current connection state = Connected
97 #define NOT_CONNECTED (-1) // Current connection state = Disconnected
98 #define FILTER_PASS_NONE 0 // Current filter state = DISCARD ALL MESSAGES
99 #define FILTER_PASS_SOME 1 // Current filter state - PASS SOME (some filters set)
100 #define FILTER_PASS_ALL 2 // Current filter state = PASS ALL
101
102 #define NULL_WINDOW 0 // Windows 3.1 is no longer supported.
103
104 #define BLOCKING_IO 1 // For Blocking calls to send/read.
105 #define NON_BLOCKING_IO 0 // For Non-Blocking calls to send/read.
106 #define BLOCK_INFINITE 0 // For Non-Blocking calls to send/read.
107 #define BLOCK_UNTIL_DONE 0
108 #define RETURN_BEFORE_COMPLETION 2
109 #define CONVERTED_MODE 1 // RP1210Mode="Converted"
110 #define RAW_MODE 0 // RP1210Mode="Raw"
111
112 #define MAX_J1708_MESSAGE_LENGTH 512 // Maximum size a J1708 message can be (+1)
113 #define MAX_J1939_MESSAGE_LENGTH 1796 // Maximum size a J1939 message can be (+1)
114 #define MAX_ISO15765_MESSAGE_LENGTH 4108 // Maximum size an ISO15765 message can be (+1)
115
116 #define ECHO_OFF 0x00 // EchoMode
117 #define ECHO_ON 0x01 // EchoMode
118
119 #define RECEIVE_ON 0x01 // Set Message Receive
120 #define RECEIVE_OFF 0x00 // Set Message Receive
121
122 #define ADD_LIST 0x01 // Add a message to the list.
123 #define VIEW_B_LIST 0x02 // View an entry in the list.
124 #define DESTROY_LIST 0x03 // Remove all entries in the list.
125 #define REMOVE_ENTRY 0x04 // Remove a specific entry from the list.
126 #define LIST_LENGTH 0x05 // Returns number of items in list.
127
128 #define FILTER_PGN 0x00000001 // Setting of J1939 filters
129 #define FILTER_SOURCE 0x00000004 // Setting of J1939 filters
130 #define FILTER_DESTINATION 0x00000008 // Setting of J1939 filters
131 #define FILTER_INCLUSIVE 0x00 // FilterMode
132 #define FILTER_EXCLUSIVE 0x01 // FilterMode
133
134 #define SILENT_J1939_CLAIM 0x00 // Claim J1939 Address
135 #define PASS_J1939_CLAIM_MESSAGES 0x01 // Claim J1939 Address
136
137 #define CHANGE_BAUD_NOW 0x00 // Change Baud
138 #define MSG_FIRST_CHANGE_BAUD 0x01 // Change Baud
139 #define RP1210_BAUD_9600 0x00 // Change Baud
140 #define RP1210_BAUD_19200 0x01 // Change Baud
141 #define RP1210_BAUD_38400 0x02 // Change Baud
142 #define RP1210_BAUD_57600 0x03 // Change Baud
143 #define RP1210_BAUD_125k 0x04 // Change Baud
144 #define RP1210_BAUD_250k 0x05 // Change Baud
145 #define RP1210_BAUD_500k 0x06 // Change Baud
146 #define RP1210_BAUD_1000k 0x07 // Change Baud
147
148 #define STANDARD_CAN 0x00 // Filters
149 #define EXTENDED_CAN 0x01 // Filters
150 #define STANDARD_CAN_ISO15765_EXTENDED 0x02 // 11-bit with ISO15765 extended address
151 #define EXTENDED_CAN_ISO15765_EXTENDED 0x03 // 29-bit with ISO15765 extended address
152 #define STANDARD_MIXED_CAN_ISO15765 0x04 // 11-bit identifier with mixed addressing
153
154 #define ISO15765_ACTUAL_MESSAGE 0x00 // ISO15765 ReadMessage - type of data
155 #define ISO15765_CONFIRM 0x01 // ISO15765 ReadMessage - type of data
156 #define ISO15765_FF_INDICATION 0x02 // ISO15765 ReadMessage - type of data
157 #define ISO15765_RX_ERROR_INDICATION 0x03 // ISO15765 ReadMessage - Type of data
158
159 #define N_OK 0x00
160 #define N_TIMEOUT_A 0x01
161 #define N_TIMEOUT_Bs 0x02
162 #define N_TIMEOUT_C 0x03
163 #define N_WRONG_SN 0x04
164 #define N_INVALID_FS 0x05
165 #define N_UNEXP_PDU 0x06
166 #define N_WFT_OVRN 0x07
167 #define N_BUFFER_OVERFLOW 0x08
168 #define N_ERROR 0x09
169
170 #ifndef TRUE
171 #define TRUE 0x01
172 #define FALSE 0x00
173 #endif
174
175 //
176 // RP1210C Return Definitions
177 //
178 #define NO_ERRORS 0
179 #define ERR_DLL_NOT_INITIALIZED 128
180 #define ERR_INVALID_CLIENT_ID 129
181 #define ERR_CLIENT_ALREADY_CONNECTED 130
182 #define ERR_CLIENT_AREA_FULL 131
183 #define ERR_FREE_MEMORY 132
184 #define ERR_NOT_ENOUGH_MEMORY 133
185 #define ERR_INVALID_DEVICE 134
186 #define ERR_DEVICE_IN_USE 135
187 #define ERR_INVALID_PROTOCOL 136
188 #define ERR_TX_QUEUE_FULL 137
189 #define ERR_TX_QUEUE_CORRUPT 138
190 #define ERR_RX_QUEUE_FULL 139
191 #define ERR_RX_QUEUE_CORRUPT 140
192 #define ERR_MESSAGE_TOO_LONG 141
193 #define ERR_HARDWARE_NOT_RESPONDING 142
194 #define ERR_COMMAND_NOT_SUPPORTED 143
195 #define ERR_INVALID_COMMAND 144
196 #define ERR_TXMESSAGE_STATUS 145
197 #define ERR_ADDRESS_CLAIM_FAILED 146
198 #define ERR_CANNOT_SET_PRIORITY 147
199 #define ERR_CLIENT_DISCONNECTED 148
200 #define ERR_CONNECT_NOT_ALLOWED 149
201 #define ERR_CHANGE_MODE_FAILED 150
202 #define ERR_BUS_OFF 151
203 #define ERR_COULD_NOT_TX_ADDRESS_CLAIMED 152
204 #define ERR_ADDRESS_LOST 153
205 #define ERR_CODE_NOT_FOUND 154
206 #define ERR_BLOCK_NOT_ALLOWED 155
207 #define ERR_MULTIPLE_CLIENTS_CONNECTED 156
208 #define ERR_ADDRESS_NEVER_CLAIMED 157
209 #define ERR_WINDOW_HANDLE_REQUIRED 158
210 #define ERR_MESSAGE_NOT_SENT 159
211 #define ERR_MAX_NOTIFY_EXCEEDED 160
212 #define ERR_MAX_FILTERS_EXCEEDED 161
213 #define ERR_HARDWARE_STATUS_CHANGE 162
214 #define ERR_INI_FILE_NOT_IN_WIN_DIR 202
215 #define ERR_INI_SECTION_NOT_FOUND 204
216 #define ERR_INI_KEY_NOT_FOUND 205
217 #define ERR_INVALID_KEY_STRING 206
218 #define ERR_DEVICE_NOT_SUPPORTED 207
219 #define ERR_INVALID_PORT_PARAM 208
220 #define ERR_COMMAND_TIMED_OUT 213
221 #define ERR_OS_NOT_SUPPORTED 220
222 #define ERR_COMMAND_QUEUE_IS_FULL 222
223 #define ERR_CANNOT_SET_CAN_BAUDRATE 224
224 #define ERR_CANNOT_CLAIM_BROADCAST_ADDRESS 225
225 #define ERR_OUT_OF_ADDRESS_RESOURCES 226
226 #define ERR_ADDRESS_RELEASE_FAILED 227
227 #define ERR_COMM_DEVICE_IN_USE 230
228 #define ERR_DATA_LINK_CONFLICT 441
229 #define ERR_ADAPTER_NOT_RESPONDING 453
230 #define ERR_CAN_BAUD_SET_NONSTANDARD 454
231 #define ERR_MULTIPLE_CONNECTIONS_NOT_ALLOWED_NOW 455
232 #define ERR_J1708_BAUD_SET_NONSTANDARD 456
233 #define ERR_J1939_BAUD_SET_NONSTANDARD 457
234 #define ERR_I5015765_BAUD_SET_NONSTANDARD 458
235 #define ERR_INVALID_IOCTL_ID 600
236 #define ERR_NULL_PARAMETER 601
237 #define ERR_HARDWARE_NOT_SUPPORTED 602
238
239 // BabyLIN specific error codes
240 #define ERR_BABYLIN_DEVICE_NOT_FOUND 1000
241
242 //
243 #define GET_CONFIG 0x01
244 #define SET_CONFIG 0x02
245 #define FIVE_BAUD_INIT 0x04
246 #define FAST_INIT 0x05
247
248 // ISO9141/KWP2000 Ioctl values reserved 0x03, 0x06-0xFFFF
249 // Ioctl values that are vendor specific 0x10000-0xFFFFFFFF
250
251 typedef struct {
252 unsigned long Parameter; // name of parameter
253 unsigned long Value; // value of the parameter
254 } SCONFIG;
255
256 typedef struct {
257 unsigned long Num0fParams; // number of SCONFIG elements
258 SCONFIG* pConfig; // array of SCONFIG elements
259 } SCONFIG_LIST;
260
261 typedef struct {
262 unsigned long NumOfBytes; // number of bytes in the array
263 unsigned char* pBytes; // array of bytes
264 } SBYTEARRAY;
265
266 //
267 // TMC RP1210C Defined Function Prototypes
268 //
269
270 short BL_DLLIMPORT STDCALL RP1210_ClientConnect(HWND hwndClient,
271 short nDeviceId,
272 char* fpchProtocol,
273 long lSendBuffer,
274 long lReceiveBuffer,
275 short nIsAppPacketizingIncomingMsgs);
276
277 short BL_DLLIMPORT STDCALL RP1210_ClientDisconnect(short nClientID);
278
279 short BL_DLLIMPORT STDCALL RP1210_SendMessage(short nClientID,
280 char* fpchClientMessage,
281 short nMessageSize,
282 short nNotifyStatusOnTx,
283 short nBlockOnSend);
284
285 short BL_DLLIMPORT STDCALL RP1210_ReadMessage(short nClientID,
286 char* fpchAPIMessage,
287 short nBufferSize,
288 short nBlockOnRead);
289
290 short BL_DLLIMPORT STDCALL RP1210_SendCommand(short nCommandNumber,
291 short nClientID,
292 char* fpchClientCommand,
293 short nMessageSize);
294
295 void BL_DLLIMPORT STDCALL RP1210_ReadVersion(char* fpchDLLMajorVersion,
296 char* fpchDLLMinorVersion,
297 char* fpchAPIMajorVersion,
298 char* fpchAPIMinorVersion);
299
300 short BL_DLLIMPORT STDCALL RP1210_ReadDetailedVersion(short nClientID,
301 char* fpchAPIVersionInfo,
302 char* fpchDLLVersionInfo,
303 char* fpchFWVersionInfo);
304
305 short BL_DLLIMPORT STDCALL RP1210_GetHardwareStatus(short nClientID,
306 char* fpchClientlnfo,
307 short nInfoSize,
308 short nBlockOnRequest);
309
310 short BL_DLLIMPORT STDCALL RP1210_GetErrorMsg(short err_code, char* fpchMessage);
311
312 short BL_DLLIMPORT STDCALL RP1210_GetLastErrorMsg(short err_code,
313 int* SubErrorCode,
314 char* fpchMessage,
315 short nClientID);
316
317 //
318 // BabyLIN specific functions (not part of RP1210 standard)
319 //
320 typedef struct {
321 // Serial number of the device.
322 uint32_t serial_number;
323 // Hardware type of the device. See BLC_TARGETID for possible values.
324 uint32_t hardware_type;
325 // Number of CAN channels on the device.
326 int32_t can_channel_count;
327
328 // The RP1210 device id this device has assigned. -1 if not assigned.
329 short id;
330 // RP1210 device name.
331 char name[256];
332 // RP1210 device description.
333 char description[256];
334 } BLC_RP1210_DEVICE;
335
343 int BL_DLLIMPORT BLC_RP1210_ListAvailableDevices(BLC_RP1210_DEVICE* device_list,
344 int device_list_sz);
345
353 int BL_DLLIMPORT BLC_RP1210_ListRegisteredDevices(BLC_RP1210_DEVICE* device_list,
354 int device_list_sz);
355
361 int BL_DLLIMPORT BLC_RP1210_RegisterAllAvailableDevices(bool remove_unavailable_devices);
362
368 int BL_DLLIMPORT BLC_RP1210_RegisterDevice(BLC_RP1210_DEVICE& device);
369
375 int BL_DLLIMPORT BLC_RP1210_UnregisterDeviceById(short device_id);
376
381 int BL_DLLIMPORT BLC_RP1210_UnregisterDevice(const BLC_RP1210_DEVICE& device);
382
386 int BL_DLLIMPORT BLC_RP1210_UnregisterAllDevices();
387
388 #ifdef __cplusplus
389 }
390 #endif
391
392 #endif
SCONFIG::Value
unsigned long Value
Definition: BabyLIN_RP1210.h:253
BLC_RP1210_DEVICE::id
short id
Definition: BabyLIN_RP1210.h:329
BLC_RP1210_RegisterDevice
int BL_DLLIMPORT BLC_RP1210_RegisterDevice(BLC_RP1210_DEVICE &device)
Register a device with RP1210.
RP1210_ClientDisconnect
short BL_DLLIMPORT STDCALL RP1210_ClientDisconnect(short nClientID)
RP1210_ReadDetailedVersion
short BL_DLLIMPORT STDCALL RP1210_ReadDetailedVersion(short nClientID, char *fpchAPIVersionInfo, char *fpchDLLVersionInfo, char *fpchFWVersionInfo)
RP1210_GetLastErrorMsg
short BL_DLLIMPORT STDCALL RP1210_GetLastErrorMsg(short err_code, int *SubErrorCode, char *fpchMessage, short nClientID)
RP1210_GetErrorMsg
short BL_DLLIMPORT STDCALL RP1210_GetErrorMsg(short err_code, char *fpchMessage)
BLC_RP1210_DEVICE::hardware_type
uint32_t hardware_type
Definition: BabyLIN_RP1210.h:324
BLC_RP1210_DEVICE
Definition: BabyLIN_RP1210.h:320
SCONFIG_LIST::pConfig
SCONFIG * pConfig
Definition: BabyLIN_RP1210.h:258
BLC_RP1210_UnregisterDevice
int BL_DLLIMPORT BLC_RP1210_UnregisterDevice(const BLC_RP1210_DEVICE &device)
Unregister a device from RP1210.
SCONFIG_LIST
Definition: BabyLIN_RP1210.h:256
RP1210_SendCommand
short BL_DLLIMPORT STDCALL RP1210_SendCommand(short nCommandNumber, short nClientID, char *fpchClientCommand, short nMessageSize)
RP1210_SendMessage
short BL_DLLIMPORT STDCALL RP1210_SendMessage(short nClientID, char *fpchClientMessage, short nMessageSize, short nNotifyStatusOnTx, short nBlockOnSend)
BLC_RP1210_UnregisterAllDevices
int BL_DLLIMPORT BLC_RP1210_UnregisterAllDevices()
Unregister all devices from RP1210.
BLC_RP1210_RegisterAllAvailableDevices
int BL_DLLIMPORT BLC_RP1210_RegisterAllAvailableDevices(bool remove_unavailable_devices)
Register all available devices with RP1210.
SCONFIG
Definition: BabyLIN_RP1210.h:251
RP1210_ReadVersion
void BL_DLLIMPORT STDCALL RP1210_ReadVersion(char *fpchDLLMajorVersion, char *fpchDLLMinorVersion, char *fpchAPIMajorVersion, char *fpchAPIMinorVersion)
STDCALL
#define STDCALL
Definition: BabyLIN_RP1210.h:15
HWND
#define HWND
Definition: BabyLIN_RP1210.h:16
BLC_RP1210_DEVICE::can_channel_count
int32_t can_channel_count
Definition: BabyLIN_RP1210.h:326
BLC_RP1210_ListAvailableDevices
int BL_DLLIMPORT BLC_RP1210_ListAvailableDevices(BLC_RP1210_DEVICE *device_list, int device_list_sz)
List all devices that are available for registration with RP1210. The list will not contain devices t...
BLC_RP1210_ListRegisteredDevices
int BL_DLLIMPORT BLC_RP1210_ListRegisteredDevices(BLC_RP1210_DEVICE *device_list, int device_list_sz)
List all devices that are registered with RP1210. The list may contain devices that are currently not...
SBYTEARRAY::pBytes
unsigned char * pBytes
Definition: BabyLIN_RP1210.h:263
RP1210_ReadMessage
short BL_DLLIMPORT STDCALL RP1210_ReadMessage(short nClientID, char *fpchAPIMessage, short nBufferSize, short nBlockOnRead)
BL_DLLIMPORT
#define BL_DLLIMPORT
Definition: BabyLINReturncodes.h:9
SBYTEARRAY
Definition: BabyLIN_RP1210.h:261
BabyLINReturncodes.h
SCONFIG::Parameter
unsigned long Parameter
Definition: BabyLIN_RP1210.h:252
RP1210_GetHardwareStatus
short BL_DLLIMPORT STDCALL RP1210_GetHardwareStatus(short nClientID, char *fpchClientlnfo, short nInfoSize, short nBlockOnRequest)
BLC_RP1210_UnregisterDeviceById
int BL_DLLIMPORT BLC_RP1210_UnregisterDeviceById(short device_id)
Unregister a device from RP1210 by its device id.
SBYTEARRAY::NumOfBytes
unsigned long NumOfBytes
Definition: BabyLIN_RP1210.h:262
RP1210_ClientConnect
short BL_DLLIMPORT STDCALL RP1210_ClientConnect(HWND hwndClient, short nDeviceId, char *fpchProtocol, long lSendBuffer, long lReceiveBuffer, short nIsAppPacketizingIncomingMsgs)
BLC_RP1210_DEVICE::serial_number
uint32_t serial_number
Definition: BabyLIN_RP1210.h:322
U8
unsigned char U8
Definition: BabyLIN_RP1210.h:24
SCONFIG_LIST::Num0fParams
unsigned long Num0fParams
Definition: BabyLIN_RP1210.h:257
Generated on Fri May 30 2025 17:16:13 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: C:/JenkinsWS/workspace/orks_v2_LinWorksv2_Windows_trunk/source/externals/BabyLIN/src/libraries/BabyLIN/publicHeaders/BabyLIN_UnifiedAccess.h File Reference

  • externals
  • BabyLIN
  • src
  • libraries
  • BabyLIN
  • publicHeaders
Typedefs | Functions
BabyLIN_UnifiedAccess.h File Reference
#include "BabyLINCAN.h"
#include <stddef.h>
#include <stdint.h>

Go to the source code of this file.

Typedefs

typedef void(* | BLC_unifiedaccess_callback_func_ptr )(BL_HANDLE handle, void *userdata)
The function prototype used for registering callbacks. More...
typedef void(* | BLC_unifiedaccess_async_callback_func_ptr )(int32_t result, BL_HANDLE handle, void *userdata)
The function prototype used for executing asynchron tasks. More...

Functions

int32_t BL_DLLIMPORT | BLC_createHandle (BL_HANDLE handle, const char *path, BL_HANDLE *result)
BLC_createHandle retrieves a handle to a loaded Object or creates a new Object. More...
int32_t BL_DLLIMPORT | BLC_destroy (BL_HANDLE handle)
BLC_destroy removes the handle from the currently opened Objects and removes the Object from its parent. More...
int32_t BL_DLLIMPORT | BLC_releaseHandle (BL_HANDLE handle)
BLC_releaseHandle removes the handle from the currently opened Objects. More...
int32_t BL_DLLIMPORT | BLC_discover (BL_HANDLE handle, const char *path, uint8_t *result, uint32_t *result_length)
BLC_discover fills the result array with space separated identifiers, that can be used in the path parameters. More...
int32_t BL_DLLIMPORT | BLC_getSignedNumber (BL_HANDLE handle, const char *path, int64_t *result)
BLC_getSignedNumber gets a signed value from the given handle. More...
int32_t BL_DLLIMPORT | BLC_getUnsignedNumber (BL_HANDLE handle, const char *path, uint64_t *result)
BLC_getUnsignedNumber gets a unsigned value from the given handle. More...
int32_t BL_DLLIMPORT | BLC_getBinary (BL_HANDLE handle, const char *path, uint8_t *result, uint32_t *result_length)
BLC_getBinary gets a binary value from the given handle. More...
int32_t BL_DLLIMPORT | BLC_setSignedNumber (BL_HANDLE handle, const char *path, int64_t value)
BLC_setSignedNumber sets a signed value of the given handle. More...
int32_t BL_DLLIMPORT | BLC_setUnsignedNumber (BL_HANDLE handle, const char *path, uint64_t value)
BLC_setUnsignedNumber sets an unsigned value of the given handle. More...
int32_t BL_DLLIMPORT | BLC_setBinary (BL_HANDLE handle, const char *path, const uint8_t *value, uint32_t value_length)
BLC_setBinary sets a binary value of the given handle. More...
int32_t BL_DLLIMPORT | BLC_setCallback (BL_HANDLE handle, const char *path, BLC_unifiedaccess_callback_func_ptr callback, void *userdata)
BLC_setCallback sets a callback function for an event of the given handle. More...
int32_t BL_DLLIMPORT | BLC_execute (BL_HANDLE handle, const char *path)
BLC_execute executes a method of the given handle. More...
int32_t BL_DLLIMPORT | BLC_execute_async (BL_HANDLE handle, const char *path, BLC_unifiedaccess_async_callback_func_ptr callback, void *userdata)
BLC_execute_async a method of the given handle. More...
Generated on Fri May 30 2025 17:16:13 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: C:/JenkinsWS/workspace/orks_v2_LinWorksv2_Windows_trunk/source/externals/BabyLIN/src/libraries/BabyLIN/publicHeaders/BabyLIN_UnifiedAccess.h Source File

  • externals
  • BabyLIN
  • src
  • libraries
  • BabyLIN
  • publicHeaders
BabyLIN_UnifiedAccess.h
Go to the documentation of this file.
1 #ifndef BABYLIN_UNIFIEDACCESS_H
2 #define BABYLIN_UNIFIEDACCESS_H
3
74 #include "BabyLINCAN.h"
75
76 #if defined(__cplusplus)
77 #include <cstddef>
78 #include <cstdint>
79 extern "C" {
80 #else
81 #include <stddef.h>
82 #include <stdint.h>
83 #endif
84
93 typedef void (*BLC_unifiedaccess_callback_func_ptr)(BL_HANDLE handle, void* userdata);
101 typedef void (*BLC_unifiedaccess_async_callback_func_ptr)(int32_t result,
102 BL_HANDLE handle,
103 void* userdata);
104
125 int32_t BL_DLLIMPORT BLC_createHandle(BL_HANDLE handle, const char* path, BL_HANDLE* result);
126
137 int32_t BL_DLLIMPORT BLC_destroy(BL_HANDLE handle);
138
148 int32_t BL_DLLIMPORT BLC_releaseHandle(BL_HANDLE handle);
149
172 int32_t BL_DLLIMPORT BLC_discover(BL_HANDLE handle,
173 const char* path,
174 uint8_t* result,
175 uint32_t* result_length);
176
191 int32_t BL_DLLIMPORT BLC_getSignedNumber(BL_HANDLE handle, const char* path, int64_t* result);
192
206 int32_t BL_DLLIMPORT BLC_getUnsignedNumber(BL_HANDLE handle, const char* path, uint64_t* result);
207
225 int32_t BL_DLLIMPORT BLC_getBinary(BL_HANDLE handle,
226 const char* path,
227 uint8_t* result,
228 uint32_t* result_length);
229
243 int32_t BL_DLLIMPORT BLC_setSignedNumber(BL_HANDLE handle, const char* path, int64_t value);
244
258 int32_t BL_DLLIMPORT BLC_setUnsignedNumber(BL_HANDLE handle, const char* path, uint64_t value);
259
275 int32_t BL_DLLIMPORT BLC_setBinary(BL_HANDLE handle,
276 const char* path,
277 const uint8_t* value,
278 uint32_t value_length);
279
294 int32_t BL_DLLIMPORT BLC_setCallback(BL_HANDLE handle,
295 const char* path,
296 BLC_unifiedaccess_callback_func_ptr callback,
297 void* userdata);
298
312 int32_t BL_DLLIMPORT BLC_execute(BL_HANDLE handle, const char* path);
313
331 int32_t BL_DLLIMPORT BLC_execute_async(BL_HANDLE handle,
332 const char* path,
333 BLC_unifiedaccess_async_callback_func_ptr callback,
334 void* userdata);
335
336 #if defined(__cplusplus)
337 }
338 #endif
339
342 #endif // BABYLIN_UNIFIEDACCESS_H
BLC_destroy
int32_t BL_DLLIMPORT BLC_destroy(BL_HANDLE handle)
BLC_destroy removes the handle from the currently opened Objects and removes the Object from its pare...
BLC_execute
int32_t BL_DLLIMPORT BLC_execute(BL_HANDLE handle, const char *path)
BLC_execute executes a method of the given handle.
BLC_setCallback
int32_t BL_DLLIMPORT BLC_setCallback(BL_HANDLE handle, const char *path, BLC_unifiedaccess_callback_func_ptr callback, void *userdata)
BLC_setCallback sets a callback function for an event of the given handle.
BabyLINCAN.h
BLC_createHandle
int32_t BL_DLLIMPORT BLC_createHandle(BL_HANDLE handle, const char *path, BL_HANDLE *result)
BLC_createHandle retrieves a handle to a loaded Object or creates a new Object.
BLC_getSignedNumber
int32_t BL_DLLIMPORT BLC_getSignedNumber(BL_HANDLE handle, const char *path, int64_t *result)
BLC_getSignedNumber gets a signed value from the given handle.
BLC_unifiedaccess_async_callback_func_ptr
void(* BLC_unifiedaccess_async_callback_func_ptr)(int32_t result, BL_HANDLE handle, void *userdata)
The function prototype used for executing asynchron tasks.
Definition: BabyLIN_UnifiedAccess.h:101
BLC_setSignedNumber
int32_t BL_DLLIMPORT BLC_setSignedNumber(BL_HANDLE handle, const char *path, int64_t value)
BLC_setSignedNumber sets a signed value of the given handle.
BLC_unifiedaccess_callback_func_ptr
void(* BLC_unifiedaccess_callback_func_ptr)(BL_HANDLE handle, void *userdata)
The function prototype used for registering callbacks.
Definition: BabyLIN_UnifiedAccess.h:93
BL_HANDLE
void * BL_HANDLE
Definition: BabyLINReturncodes.h:34
BLC_execute_async
int32_t BL_DLLIMPORT BLC_execute_async(BL_HANDLE handle, const char *path, BLC_unifiedaccess_async_callback_func_ptr callback, void *userdata)
BLC_execute_async a method of the given handle.
BLC_getUnsignedNumber
int32_t BL_DLLIMPORT BLC_getUnsignedNumber(BL_HANDLE handle, const char *path, uint64_t *result)
BLC_getUnsignedNumber gets a unsigned value from the given handle.
BL_DLLIMPORT
#define BL_DLLIMPORT
Definition: BabyLINReturncodes.h:9
BLC_releaseHandle
int32_t BL_DLLIMPORT BLC_releaseHandle(BL_HANDLE handle)
BLC_releaseHandle removes the handle from the currently opened Objects.
BLC_setBinary
int32_t BL_DLLIMPORT BLC_setBinary(BL_HANDLE handle, const char *path, const uint8_t *value, uint32_t value_length)
BLC_setBinary sets a binary value of the given handle.
BLC_setUnsignedNumber
int32_t BL_DLLIMPORT BLC_setUnsignedNumber(BL_HANDLE handle, const char *path, uint64_t value)
BLC_setUnsignedNumber sets an unsigned value of the given handle.
BLC_discover
int32_t BL_DLLIMPORT BLC_discover(BL_HANDLE handle, const char *path, uint8_t *result, uint32_t *result_length)
BLC_discover fills the result array with space separated identifiers, that can be used in the path pa...
BLC_getBinary
int32_t BL_DLLIMPORT BLC_getBinary(BL_HANDLE handle, const char *path, uint8_t *result, uint32_t *result_length)
BLC_getBinary gets a binary value from the given handle.
Generated on Fri May 30 2025 17:16:13 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: C:/JenkinsWS/workspace/orks_v2_LinWorksv2_Windows_trunk/source/externals/BabyLIN/src/libraries/BabyLIN/publicHeaders/BabyLINCAN.h File Reference

  • externals
  • BabyLIN
  • src
  • libraries
  • BabyLIN
  • publicHeaders
Macros | Typedefs | Functions
BabyLINCAN.h File Reference
#include "BabyLINCAN_types.h"
#include <stddef.h>
#include <stdint.h>

Go to the source code of this file.

Macros

#define BL_EXCEPTION_FILTER_ATTR

Typedefs

typedef long(BL_EXCEPTION_FILTER_ATTR * exception_filter )(struct _EXCEPTION_POINTERS *ExceptionInfo)

Functions

int BL_DLLIMPORT | BLC_registerJumboFrameCallback (BL_HANDLE handle, BLC_jumboframe_callback_func *callback)
Registers a callback function, which is called on every reception of a (monitored) jumbo frame. More...
int BL_DLLIMPORT | BLC_registerFrameCallback (BL_HANDLE handle, BLC_frame_callback_func *callback)
Registers a callback function, which is called on every reception of a (monitored) frame. More...
int BL_DLLIMPORT | BLC_registerSignalCallback (BL_HANDLE handle, BLC_signal_callback_func *callback)
Registers a callback function, which is called on every reception of a monitored signal. More...
int BL_DLLIMPORT | BLC_registerErrorCallback (BL_HANDLE handle, BLC_error_callback_func *callback)
Registers a callback function, which is called on every reception of an error message. More...
int BL_DLLIMPORT | BLC_registerMacroStateCallback (BL_HANDLE handle, BLC_macrostate_callback_func *callback)
Registers a callback function, which is called whenever the execution state of a macro changes. More...
int BL_DLLIMPORT | BLC_registerDebugCallback (BL_HANDLE handle, BLC_debug_callback_func *callback)
Registers a callback function, which is called whenever a debug message from a BabyLIN-Device is received. More...
int BL_DLLIMPORT | BLC_registerDTLRequestCallback (BL_HANDLE handle, BLC_dtl_request_callback_func *callback)
Registers a callback function, which is called whenever dtl request is received. More...
int BL_DLLIMPORT | BLC_registerDTLResponseCallback (BL_HANDLE handle, BLC_dtl_response_callback_func *callback)
Registers a callback function, which is called whenever dtl response is received. More...
int BL_DLLIMPORT | BLC_registerUserDataJumboFrameCallback (BL_HANDLE handle, BLC_jumboframe_callback_func_ptr *callback, void *userdata)
Registers a callback function, which is called on every reception of a (monitored) jumbo frame. More...
int BL_DLLIMPORT | BLC_registerUserDataFrameCallback (BL_HANDLE handle, BLC_frame_callback_func_ptr *callback, void *userdata)
Registers a callback function, which is called on every reception of a (monitored) frame. More...
int BL_DLLIMPORT | BLC_registerUserDataEvent (BL_HANDLE handle, BLC_event_callback_func_ptr *callback, void *userdata)
Registers a callback function, which is called on every reception of an event report. More...
int BL_DLLIMPORT | BLC_registerUserDataEventCallback (BL_HANDLE handle, BLC_event_callback_func_ptr *callback, void *userdata)
Alias for BLC_registerUserDataEvent. More...
int BL_DLLIMPORT | BLC_registerEventCallback (BL_HANDLE handle, BLC_event_callback_func *callback)
Alias for BLC_registerUserDataEvent without user data. More...
int BL_DLLIMPORT | BLC_registerUserDataSignalCallback (BL_HANDLE handle, BLC_signal_callback_func_ptr *callback, void *userdata)
Registers a callback function, which is called on every reception of a monitored signal. More...
int BL_DLLIMPORT | BLC_registerUserDataErrorCallback (BL_HANDLE handle, BLC_error_callback_func_ptr *callback, void *userdata)
Registers a callback function, which is called on every reception of an error message. More...
int BL_DLLIMPORT | BLC_registerUserDataMacroStateCallback (BL_HANDLE handle, BLC_macrostate_callback_func_ptr *callback, void *userdata)
Registers a callback function, which is called whenever the execution state of a macro changes. More...
int BL_DLLIMPORT | BLC_registerUserDataDebugCallback (BL_HANDLE handle, BLC_debug_callback_func_ptr *callback, void *userdata)
Registers a callback function, which is called whenever a debug message from a BabyLIN-Device is received. More...
int BL_DLLIMPORT | BLC_registerUserDataDTLRequestCallback (BL_HANDLE handle, BLC_dtl_request_callback_func_ptr *callback, void *userdata)
Registers a callback function, which is called whenever dtl request is received. More...
int BL_DLLIMPORT | BLC_registerUserDataDTLResponseCallback (BL_HANDLE handle, BLC_dtl_response_callback_func_ptr *callback, void *userdata)
Registers a callback function, which is called whenever dtl response is received. More...
int BL_DLLIMPORT | BLC_registerLuaPrintCallback (BL_HANDLE handle, BLC_lua_print_func_ptr *func, void *userdata)
Registers a callback that will be called when the lua "print" function is called. More...
int BL_DLLIMPORT | BLC_registerLuaErrorCallback (BL_HANDLE handle, BLC_lua_print_func_ptr *func, void *userdata)
Registers a callback that will be called on any LUA engine error. You can register this callback to debug your script SDFs. More...
int BL_DLLIMPORT | BLC_registerUserDataLogCallback (BL_HANDLE handle, BLC_log_callback_func_ptr *callback, void *userdata)
Registers a callback function, which is called whenever a log message is received. More...
void BL_DLLIMPORT | BLC_getVersion (int *major, int *minor)
Get the major and minor version number of the library. More...
void BL_DLLIMPORT | BLC_getExtendedVersion (int *major, int *minor, int *patch, int *buildrev)
Get the major, minor and patch version number of the library. More...
CPCHAR BL_DLLIMPORT | BLC_getVersionString (void)
Get the version string of the library. More...
int BL_DLLIMPORT | BLC_getBabyLinPorts (BLC_PORTINFO portListToBeFilled[], int *pFoundPortCount)
Retrieve a list of ports a BabyLIN is connected to. More...
int BL_DLLIMPORT | BLC_getBabyLinPortsTimout (BLC_PORTINFO portListToBeFilled[], int *pFoundPortCount, int timoutms)
Retrieve a list of ports a BabyLIN is connected to. More...
BL_HANDLE BL_DLLIMPORT | BLC_open (unsigned int port)
Open a connection to a BabyLIN USB-Serial device. More...
BL_HANDLE BL_DLLIMPORT | BLC_openNet (const char *ip, int port)
Open a connection to a BabyLIN device using ethernet. More...
BL_HANDLE BL_DLLIMPORT | BLC_openUSB (const char *device)
Open a connection to a BabyLIN USB device. More...
BL_HANDLE BL_DLLIMPORT | BLC_openPort (BLC_PORTINFO portInfo)
Open a connection to a BabyLIN device using BLC_PORTINFO information. More...
int BL_DLLIMPORT | BLC_convertUrl (const char *url, BLC_PORTINFO *portInfo)
convert a device url to BLC_PORTINFO to use in BLC_openPort More...
int BL_DLLIMPORT | BLC_close (BL_HANDLE handle)
Close connection to Device. More...
int BL_DLLIMPORT | BLC_closeAll (void)
Close ALL connections to ALL Devices. More...
int BL_DLLIMPORT | BLC_flush (BL_HANDLE handle)
Reset the BabyLIN device to an consistent and deactivated state. More...
int BL_DLLIMPORT | BLC_getTargetID (BL_HANDLE handle, BLC_TARGETID *targetID)
Requests the information about the target. More...
int BL_DLLIMPORT | BLC_getHWType (BL_HANDLE handle)
Returns the unique hardware type identifier for a device. More...
int BL_DLLIMPORT | BLC_getChannelCount (BL_HANDLE handle)
number of channels provided by the BabyLIN-Device More...
BL_HANDLE BL_DLLIMPORT | BLC_getChannelHandle (BL_HANDLE handle, int channelId)
Retrieve a handle to the specified channel. More...
int BL_DLLIMPORT | BLC_getChannelInfo (BL_HANDLE handle, BLC_CHANNELINFO *pinfo)
Retrieve informations about the Channel. More...
int BL_DLLIMPORT | BLC_getLastError (BL_HANDLE handle, char *pErrorBuffer, int bufferLength)
Returns a C-string with the textual representation of the last error. More...
CPCHAR BL_DLLIMPORT | BLC_getErrorString (int error_code)
Returns a C-string with the textual representation of an error code. More...
int BL_DLLIMPORT | BLC_getDetailedErrorString (int errorCode, int reportParameter, char *pErrorBuffer, int bufferLength)
Returns a C-string with the detailed textual representation of all possible error codes. Get a detailed textual error message for an error code. More...
int BL_DLLIMPORT | BLC_Reset (BL_HANDLE handle)
Resets the BabyLIN device to an consistent and deactivated state. More...
int BL_DLLIMPORT | BLC_loadSDF (BL_HANDLE handle, const char *filename, int download)
Loads the specified SDF-file into library and optionally the BabyLIN device. More...
int BL_DLLIMPORT | BLC_loadLDF (BL_HANDLE handle, const char *filename, int download)
Loads the specified LDFile into library and optionally the BabyLIN device. More...
int BL_DLLIMPORT | BLC_downloadSDF (BL_HANDLE handle, int mode)
Loads the previously loaded SDF-file into the BabyLIN device. More...
int BL_DLLIMPORT | BLC_isSDFOnDevice (BL_HANDLE handle, const char *filename)
Checks whether the given file is already loaded on a device. More...
int BL_DLLIMPORT | BLC_getSDFInfo (BL_HANDLE handle, BLC_SDFINFO *pSDFInfo)
Retrieve further Information about a loaded SDF. More...
int BL_DLLIMPORT | BLC_getSectionInfo (BL_HANDLE handle, int infoAboutSectionNr, BLC_SECTIONINFO *pSectionInfo)
Retrieve informations about a SDF-Section from a loaded SDF. More...
CPCHAR BL_DLLIMPORT | BLC_getChannelSectionDescription (BL_HANDLE handle)
Retrieve description string of a SDF-Section from a loaded SDF. More...
int BL_DLLIMPORT | BLC_getNodeCount (BL_HANDLE handle)
Returns the number of nodes on the BUS. More...
int BL_DLLIMPORT | BLC_getNodeName (BL_HANDLE handle, int idx, char *dstbuf, int buflen)
Returns the name of a given node. More...
int BL_DLLIMPORT | BLC_getFrameCount (BL_HANDLE handle)
Returns the number of frames of the BUS description. More...
int BL_DLLIMPORT | BLC_getFrameName (BL_HANDLE handle, int idx, char *dstbuf, int buflen)
Returns the name of a given frame. More...
int BL_DLLIMPORT | BLC_getSignalCount (BL_HANDLE handle)
Returns the number of signals. More...
int BL_DLLIMPORT | BLC_getSignalName (BL_HANDLE handle, int idx, char *dstbuf, int buflen)
Returns the name of given signal. More...
int BL_DLLIMPORT | BLC_isSignalEmulated (BL_HANDLE handle, int idx)
Retrieve information about wheather a signal is emulated by the BabyLIN-Device or not. More...
int BL_DLLIMPORT | BLC_getSignalSize (BL_HANDLE handle, int idx)
Retrieve size of a signal. More...
int BL_DLLIMPORT | BLC_getSignalsInFrameCount (BL_HANDLE handle, int idx)
Retrieve the number of signals mapped in a frame. More...
int BL_DLLIMPORT | BLC_getSignalInFrame (BL_HANDLE handle, int frameIndex, int signalIndex)
Retrieve the signal number of a signal mapped in a frame. More...
int BL_DLLIMPORT | BLC_getFrameNrForFrameId (BL_HANDLE handle, unsigned int frameId)
Retrieve the SDF frame number for a given BUS frame-id. More...
int BL_DLLIMPORT | BLC_getFrameIdForFrameNr (BL_HANDLE handle, unsigned char frameNr)
Retrieve the BUS frame-id for a given SDF frame number. More...
int BL_DLLIMPORT | BLC_sendRaw (BL_HANDLE handle, const unsigned char *command, unsigned int *length)
Send a (raw!) command to the BabyLIN device. More...
int BL_DLLIMPORT | BLC_setDTLMode (BL_HANDLE handle, int mode)
Set the Diagnostic Transport Layer mode. More...
int BL_DLLIMPORT | BLC_sendDTLRequest (BL_HANDLE handle, unsigned char nad, int length, unsigned char *data)
Send a DTL master request to a node. More...
int BL_DLLIMPORT | BLC_sendDTLResponse (BL_HANDLE handle, unsigned char nad, int length, unsigned char *data)
Send a DTL slave response to a node. More...
int BL_DLLIMPORT | BLC_sendRawSlaveResponse (BL_HANDLE handle, unsigned char *reqdata, unsigned char *reqmask, unsigned char *data, int length)
Send a (non-DTL) slave response upon receive of matching master request. More...
int BL_DLLIMPORT | BLC_sendRawMasterRequest (BL_HANDLE handle, unsigned char *data, int count)
Send a (non-DTL) Master request with the specified 8 bytes as data. More...
int BL_DLLIMPORT | BLC_getDTLRequestStatus (BL_HANDLE handle)
Returns the status of the last request-send operation. More...
int BL_DLLIMPORT | BLC_getDTLResponseStatus (BL_HANDLE handle)
Returns the status of the last resonse-send operation. More...
int BL_DLLIMPORT | BLC_getRawSlaveResponse (BL_HANDLE handle, unsigned char *data, int length)
Returns the first 'length' bytes of the current slave response-buffer. More...
int BL_DLLIMPORT | BLC_updRawSlaveResponse (BL_HANDLE handle)
BLC_updRawSlaveResponse resets the internal dtl buffer. More...
int BL_DLLIMPORT | BLC_lastAnswerHasData (BL_HANDLE handle)
Returns BL_OK if the last answer to a command, send to the given handle, contained additional data. More...
int BL_DLLIMPORT | BLC_getAnswerTypeByName (BL_HANDLE handle, const char *name, BL_ANSWER_TYPE *type, size_t *length)
Get type of a parameter of the last answer data from a BabyLIN. More...
int BL_DLLIMPORT | BLC_getAnswerTypeByIndex (BL_HANDLE handle, const unsigned int index, BL_ANSWER_TYPE *type, size_t *length)
Get type of a parameter of the last answer data from a BabyLIN. More...
int BL_DLLIMPORT | BLC_getAnswerNameByIndex (BL_HANDLE handle, int index, char *nameBuffer, int *nameBufferLength)
Get name of a parameter of the last answer data from a BabyLIN. More...
int BL_DLLIMPORT | BLC_getAnswerByName (BL_HANDLE handle, const char *name, void *buffer, size_t length)
Get the value of a parameter of the last answer data from a BabyLIN. More...
int BL_DLLIMPORT | BLC_getAnswerByIndex (BL_HANDLE handle, const unsigned int index, void *buffer, size_t length)
Get the value of a parameter of the last answer data from a BabyLIN. More...
int BL_DLLIMPORT | BLC_sendCommand (BL_HANDLE handle, const char *command)
Send a command to the BabyLIN device. More...
int BL_DLLIMPORT | BLC_sendASCIICommand (BL_HANDLE handle, const char *command, char *buffer, int bufferLength, int timeout_ms)
Sends a ASCII protocol command and wait for its response. More...
int BL_DLLIMPORT | BLC_setsig (BL_HANDLE handle, int signalNr, unsigned long long value)
Shorthand for "setsig" command (see BabyLIN commands to use in BL_- and BLC_sendCommand Functions ) More...
int BL_DLLIMPORT | BLC_mon_set (BL_HANDLE handle, int frameid, const int *databytes, int len)
Shorthand for "mon_set" command (see BabyLIN commands to use in BL_- and BLC_sendCommand Functions ) More...
int BL_DLLIMPORT | BLC_mon_xmit (BL_HANDLE handle, int frameId, int slottime)
Shorthand for "mon_xmit" command (see BabyLIN commands to use in BL_- and BLC_sendCommand Functions ) More...
int BL_DLLIMPORT | BLC_mon_set_xmit (BL_HANDLE handle, int frameId, const int *databytes, int len, int slottime)
Shorthand for "mon_set" followed by "mon_xmit" command (see BabyLIN commands to use in BL_- and BLC_sendCommand Functions ) More...
int BL_DLLIMPORT | BLC_macro_result (BL_HANDLE handle, int macro_nr, int64_t *return_value, unsigned int timeout_ms)
Convenience function for command "macro_result" handling answer data. More...
int BL_DLLIMPORT | BLC_getMacroResultString (BL_HANDLE handle, int macro_nr, char *dstbuf, int buflen)
Returns the result string of given macro, if it was set within the macro. More...
int BL_DLLIMPORT | BLC_varRead (BL_HANDLE handle, int signal_nr, char *dstbuf, int length)
Returns the result of a "varrd" command in a convienent way. More...
int BL_DLLIMPORT | BLC_varWrite (BL_HANDLE handle, int signal_nr, char *data, int data_len)
Writes an array of signals to values given by a bytearray. More...
BLC_ADHOC_PROTOCOL BL_DLLIMPORT | BLC_AdHoc_DefaultProtocol (ADHOC_PROTOCOL_TYPE type)
Creates a adhoc protocol struct with the default settings for the given protocol type. More...
BLC_ADHOC_SERVICE BL_DLLIMPORT | BLC_AdHoc_DefaultService (const BLC_ADHOC_PROTOCOL protocol)
Creates a adhoc service struct with the default settings for the service and protocol combination. More...
BLC_ADHOC_EXECUTE BL_DLLIMPORT BLC_AdHoc_DefaultExecute ()
Creates a adhoc execute struct with the default settings for the execution of adhoc protocols. More...
int BL_DLLIMPORT | BLC_AdHoc_CreateProtocol (BL_HANDLE channel, BLC_ADHOC_PROTOCOL *protocol, BL_ADHOC_HANDLE *protocol_handle)
Creates a adhoc protocol in the device with the given settings. More...
int BL_DLLIMPORT | BLC_AdHoc_CreateService (BL_HANDLE channel, BL_ADHOC_HANDLE protocol, BLC_ADHOC_SERVICE *service, BL_ADHOC_HANDLE *service_handle)
Creates a adhoc service in the device with the given settings for an existing protocol. More...
int BL_DLLIMPORT | BLC_AdHoc_Execute (BL_HANDLE channel, BL_ADHOC_HANDLE protocol_handle, BL_ADHOC_HANDLE service_handle, BLC_ADHOC_EXECUTE *execute_flags, const unsigned char *req_payload, int req_payload_length, unsigned char *rsp_payload, int *rsp_payload_length, int timeout)
Runs a given protocol service on the device in a blocking way, the function returns after the protocol is completly done, or the timeout expires. More...
int BL_DLLIMPORT | BLC_AdHoc_ExecuteAsync (BL_HANDLE channel, BL_ADHOC_HANDLE protocol_handle, BL_ADHOC_HANDLE service_handle, BLC_ADHOC_EXECUTE *execute_flags, const unsigned char *req_payload, int req_payload_length, BL_ADHOC_HANDLE *execute_handle)
Runs a given protocol service on the device in a non-blocking way, the function returns directly after the protocol has be started in the device. More...
int BL_DLLIMPORT | BLC_AdHoc_GetState (BL_HANDLE channel, BL_ADHOC_HANDLE execute_handle)
Returns the current state of the given protocol service. More...
int BL_DLLIMPORT | BLC_AdHoc_GetResponse (BL_HANDLE channel, BL_ADHOC_HANDLE execute_handle, unsigned char *rsp_payload, int *rsp_payload_size)
Returns the response payload of the given protocol service. More...
int BL_DLLIMPORT | BLC_AdHoc_DeleteProtocol (BL_HANDLE channel, BL_ADHOC_HANDLE protocol)
Deletes an existing adhoc protocol in the device. This deletes all child services of the protocol too. More...
int BL_DLLIMPORT | BLC_AdHoc_DeleteService (BL_HANDLE channel, BL_ADHOC_HANDLE protocol, BL_ADHOC_HANDLE service)
Deletes an existing adhoc service for the given protocol in the device. More...
int BL_DLLIMPORT | BLC_AdHoc_DeleteAllProtocol (BL_HANDLE channel)
Deletes all existing adhoc protocol for the given channel. This deletes all services too. More...
int BL_DLLIMPORT | BLC_AdHoc_DeleteAllService (BL_HANDLE channel, BL_ADHOC_HANDLE protocol)
Deletes all existing adhoc services for the given channel and protocol. More...
int BL_DLLIMPORT | BLC_getTableCount (BL_HANDLE handle, int64_t *table_count)
Returns the number of tables currently in the device / the loaded SDF. More...
int BL_DLLIMPORT | BLC_getTableRowCount (BL_HANDLE handle, int table_id, int64_t *row_count)
Returns the number of rows currently in the given table. More...
int BL_DLLIMPORT | BLC_getTableColumnCount (BL_HANDLE handle, int table_id, int64_t *column_count)
Returns the number of columns currently in the given table. More...
int BL_DLLIMPORT | BLC_tableRead (BL_HANDLE handle, int table_id, int row, int column, int64_t *read_value, char *buf, int *bufsz)
Returns the value of the specified table cell. More...
int BL_DLLIMPORT | BLC_tableWrite (BL_HANDLE handle, int table_id, int row, int column, int64_t value)
Writes the given integer value into the table cell. More...
int BL_DLLIMPORT | BLC_tableWriteText (BL_HANDLE handle, int table_id, int row, int column, const char *value)
Writes the given string value into the table cell. More...
int BL_DLLIMPORT | BLC_tableFill (BL_HANDLE handle, int table_id, int start_row, int start_column, int end_row, int end_column, int64_t fill_value, const char *fill_text)
Writes the given values into all table cells than span from (start_row, start_column) to (end_row, end_column). More...
int BL_DLLIMPORT | BLC_getLastFrame (BL_HANDLE handle, int frameNr, BLC_FRAME *framedata)
Retrieve the last framedata available for a frame. More...
int BL_DLLIMPORT | BLC_getNextFrame (BL_HANDLE handle, BLC_FRAME *framedata)
Fetches the next frame on Channel from the receiver queue. More...
int BL_DLLIMPORT | BLC_getNextFrames (BL_HANDLE handle, BLC_FRAME *framedata, int *size)
Fetches the next frames on channel from the receiver queue. More...
int BL_DLLIMPORT | BLC_getNextFrameTimeout (BL_HANDLE handle, BLC_FRAME *framedata, int timeout_ms)
Fetches the next frame on Channel from the receiver queue with wait-timeout. More...
int BL_DLLIMPORT | BLC_getNextFramesTimeout (BL_HANDLE handle, BLC_FRAME *framedata, int timeout_ms, int *size)
Fetches the next frames on channel from the receiver queue with wait-timeout. More...
int BL_DLLIMPORT | BLC_getNextJumboFrame (BL_HANDLE handle, BLC_JUMBO_FRAME *framedata)
Fetches the next regular or jumbo frame on Channel from the receiver queue. More...
int BL_DLLIMPORT | BLC_getNextJumboFrames (BL_HANDLE handle, BLC_JUMBO_FRAME *framedata, int *size)
Fetches the next regular or jumbo frames on channel from the receiver queue. More...
int BL_DLLIMPORT | BLC_getNextJumboFrameTimeout (BL_HANDLE handle, BLC_JUMBO_FRAME *framedata, int timeout_ms)
Fetches the next regular or jumbo frame on Channel from the receiver queue with wait-timeout. More...
int BL_DLLIMPORT | BLC_getNextJumboFramesTimeout (BL_HANDLE handle, BLC_JUMBO_FRAME *framedata, int timeout_ms, int *size)
Fetches the next regular or jumbo frames on channel from the receiver queue with wait-timeout. More...
int BL_DLLIMPORT | BLC_getNextSignal (BL_HANDLE handle, BLC_SIGNAL *signaldata)
Fetches the next signal from the receiver queue. More...
int BL_DLLIMPORT | BLC_getNextSignals (BL_HANDLE handle, BLC_SIGNAL *signaldata, int *size)
Fetches the next signals from the receiver queue. More...
int BL_DLLIMPORT | BLC_getNextSignalsForNumber (BL_HANDLE handle, BLC_SIGNAL *signaldata, int size, int signalNumber)
Fetches the next signals for a specific signal from the receiver queue. More...
int BL_DLLIMPORT | BLC_getNextBusError (BL_HANDLE handle, BLC_ERROR *errordata)
Fetches the next Bus error from the receiver queue. More...
int BL_DLLIMPORT | BLC_getNextDTLRequest (BL_HANDLE handle, BLC_DTL *frame)
Fetches the next complete DTL request from the receiver queue. More...
int BL_DLLIMPORT | BLC_getNextDTLResponse (BL_HANDLE handle, BLC_DTL *frame)
Fetches the next complete DTL response from the receiver queue. More...
int BL_DLLIMPORT | BLC_getSignalValue (BL_HANDLE handle, int signalNr, unsigned long long *value)
Return the current signal value (for non-array signals). More...
int BL_DLLIMPORT | BLC_getSignalValueWithTimestamp (BL_HANDLE handle, int signalNr, unsigned long long *value, unsigned long long *timestamp)
Return the current signal value (for non-array signals) with timestamp. More...
int BL_DLLIMPORT | BLC_getSignalValueByName (BL_HANDLE handle, const char *signalName, unsigned long long *value)
Returns the current signal value (for non-array signals). More...
int BL_DLLIMPORT | BLC_getSignalArray (BL_HANDLE handle, int signalNr, unsigned char *array)
Returns the current signal value (for array signals). More...
int BL_DLLIMPORT | BLC_getSignalArrayWithTimestamp (BL_HANDLE handle, int signalNr, unsigned char *array, unsigned long long *timestamp)
Returns the current signal value (for array signals) with timstamp. More...
int BL_DLLIMPORT | BLC_getSignalArrayByName (BL_HANDLE handle, const char *signalName, unsigned char *array)
Returns the current signal value (for array signals). More...
int BL_DLLIMPORT | BLC_isSignalArray (BL_HANDLE handle, int idx)
Returns the type of a signal. More...
int BL_DLLIMPORT | BLC_encodeSignal (BL_HANDLE handle, int signalNr, unsigned long long value, char *encSignal, size_t *buffLen0, char *encUnit, size_t *buffLen1)
Encodes the signal's value as defined in the corresponding Signal Encoding tables of LDF/SDF. More...
int BL_DLLIMPORT | BLC_decodeSignal (BL_HANDLE handle, int signalNr, char *encSignal, int64_t *value)
BLC_decodeSignal takes an encoded Signal value and tries to compute it back to its Signal value. Rounding errors might occur for large signals or encoding scales and offsets. More...
int BL_DLLIMPORT | BLC_getSignalsInFrame (BL_HANDLE handle, int frameNr, BLC_SIGNAL *signalList, int signalListLen)
Get values of all signals mapped to a frame. More...
int BL_DLLIMPORT | BLC_getFrameDetails (BL_HANDLE handle, int idx, int *pbusid, int *psize, int *pnodenum, int *pframetype)
Returns some details for given frame entry. More...
int BL_DLLIMPORT | BLC_getNodeForSignal (BL_HANDLE handle, int signalNr)
Returns some details for given frame entry. More...
int BL_DLLIMPORT | BLC_dmStart (BL_HANDLE handle, int baudrate, int bitwidth, int stopbits, int parity)
Starts direct mode on channel with given baudrate, bitwidth, stopbits and parity settings. If the direct mode is already active on the channel, it will be restarted. The command prepares the channel with BLC_dmReportConfig settings of 5ms and 8 bytes. More...
int BL_DLLIMPORT | BLC_dmReportConfig (BL_HANDLE handle, int timeout, int bytes)
Configure the reporting policy of the device in respect to a timeout and/or a block of bytes. The device will report any data read from the bus if the read data exceeds the given byte count or after [timeout] milliseconds idle time. More...
int BL_DLLIMPORT | BLC_dmWrite (BL_HANDLE handle, const char *data, unsigned int dataSize)
Writes data in directmode to the bus. More...
int BL_DLLIMPORT | BLC_dmRead (BL_HANDLE handle, char *buffer, unsigned int bufferSize)
Read data in direct mode. More...
int BL_DLLIMPORT | BLC_dmReadTimeout (BL_HANDLE handle, char *buffer, unsigned int bufferSize, unsigned int timeout_ms)
Same as BLC_dmRead with waiting timeout in ms. More...
int BL_DLLIMPORT | BLC_dmPulse (BL_HANDLE handle, unsigned int lowtime_us, unsigned int paddingtime_us)
Issue a pulse on the bus. More...
int BL_DLLIMPORT | BLC_dmDelay (BL_HANDLE channel, unsigned int paddingtime_us)
Delay the next operation by the given time. More...
int BL_DLLIMPORT | BLC_dmStop (BL_HANDLE handle)
Stop direct mode. More...
int BL_DLLIMPORT | BLC_dmPrepare (BL_HANDLE channel, unsigned char mode)
BLC_dmPrepare enters or exits the preparation state. More...
int BL_DLLIMPORT | BLC_loggingStart (BL_HANDLE handle, const char *configFile)
BLC_loggingStart enables the standard logging feature for a specific device or channel. More...
int BL_DLLIMPORT | BLC_loggingAddComment (BL_HANDLE handle, const char *comment)
BLC_loggingAddComment Added a string to the logfile. More...
int BL_DLLIMPORT | BLC_loggingStop (BL_HANDLE handle)
BLC_loggingStop stop and close all active logfiles which were started via BLC_loggingStart and linked to the handle. This function did not stop the logging via a SDF file if used. More...
int BL_DLLIMPORT | BLC_loggingStopGlobal ()
BLC_loggingStopGlobal stop and close all active logfiles which were started via BLC_loggingStart. This function did not stop the logging via a SDF file if used. More...
void BL_DLLIMPORT | BLC_overwriteCrashHandler (exception_filter function, const char *application_name, int dump_external_code, int show_msgbox_on_crash)
int BL_DLLIMPORT | BLC_runLuaCode (BL_HANDLE handle, const char *lua_code)

Function Documentation

int BL_DLLIMPORT BLC_registerDebugCallback | ( | BL_HANDLE | handle,
 |  | BLC_debug_callback_func * | callback
 | ) |  |

Issuing a NULL-pointer de-registers the callback function. As the function is called from another thread context, take care of thread-safety (i.e. using mutexes, etc.).

Parameters
[in] | handle | Handle representing the channel emitting the error; returned previously by
[in] | callback | Pointer to a function call-compatible to BLC_debug_callback_func.
Returns
Status of operation; '=0' means successful, '!=0' otherwise. See standard return values for error, or for textual representation (for return values < -1000) BLC_getLastError.
int BL_DLLIMPORT BLC_registerDTLRequestCallback | ( | BL_HANDLE | handle,
 |  | BLC_dtl_request_callback_func * | callback
 | ) |  |

Issuing a NULL-pointer de-registers the callback function. As the function is called from another thread context, take care of thread-safety (i.e. using mutexes, etc.).

Parameters
[in] | handle | Handle representing the channel emitting the error; returned previously by
[in] | callback | Pointer to a function call-compatible to BLC_dtl_request_callback_func.
Returns
Status of operation; '=0' means successful, '!=0' otherwise. See standard return values for error, or for textual representation (for return values < -1000) BLC_getLastError.
int BL_DLLIMPORT BLC_registerDTLResponseCallback | ( | BL_HANDLE | handle,
 |  | BLC_dtl_response_callback_func * | callback
 | ) |  |

Issuing a NULL-pointer de-registers the callback function. As the function is called from another thread context, take care of thread-safety (i.e. using mutexes, etc.).

Parameters
[in] | handle | Handle representing the channel emitting the error; returned previously by
[in] | callback | Pointer to a function call-compatible to BLC_dtl_response_callback_func.
Returns
Status of operation; '=0' means successful, '!=0' otherwise. See standard return values for error, or for textual representation (for return values < -1000) BLC_getLastError.
int BL_DLLIMPORT BLC_registerErrorCallback | ( | BL_HANDLE | handle,
 |  | BLC_error_callback_func * | callback
 | ) |  |

Issuing a NULL-pointer de-registers the callback function. As the function is called from another thread context, take care of thread-safety (i.e. using mutexes, etc.).

Parameters
[in] | handle | Handle representing the channel emitting the error; returned previously by
[in] | callback | Pointer to a function call-compatible to BLC_error_callback_func.
Returns
Status of operation; '=0' means successful, '!=0' otherwise. See standard return values for error, or for textual representation (for return values < -1000) BLC_getLastError.
int BL_DLLIMPORT BLC_registerEventCallback | ( | BL_HANDLE | handle,
 |  | BLC_event_callback_func * | callback
 | ) |  |
int BL_DLLIMPORT BLC_registerFrameCallback | ( | BL_HANDLE | handle,
 |  | BLC_frame_callback_func * | callback
 | ) |  |

Issuing a NULL-pointer de-registers the callback function. As the function is called from another thread context, take care of thread-safety (i.e. using mutexes, etc.).

Parameters
[in] | handle | Handle representing the channel id which the frame occurred
[in] | callback | Pointer to a function call-compatible to BLC_frame_callback_func.
Returns
Status of operation; '=0' means successful, '!=0' otherwise. See standard return values for error, or for textual representation (for return values < -1000) BLC_getLastError.
int BL_DLLIMPORT BLC_registerJumboFrameCallback | ( | BL_HANDLE | handle,
 |  | BLC_jumboframe_callback_func * | callback
 | ) |  |
Deprecated:
Use BLC_registerUserDataJumboFrameCallback instead

Issuing a NULL-pointer de-registers the callback function. As the function is called from another thread context, take care of thread-safety (i.e. using mutexes, etc.).

Parameters
[in] | handle | Handle representing the channel id which the frame occurred
[in] | callback | Pointer to a function call-compatible to BLC_jumboframe_callback_func.
Returns
Status of operation; '=0' means successful, '!=0' otherwise. See standard return values for error, or for textual representation (for return values < -1000) BLC_getLastError.
int BL_DLLIMPORT BLC_registerLuaErrorCallback | ( | BL_HANDLE | handle,
 |  | BLC_lua_print_func_ptr * | func,
 |  | void * | userdata
 | ) |  |

Registers a callback that will be called on any LUA engine error. You can register this callback to debug your script SDFs.

Parameters
[in] | handle | The connection for the callback
[in] | func | The function to be called as callback.
[in] | userdata | Any user supplied data, which will be available in the callback (e.g as connection or channel handle)
int BL_DLLIMPORT BLC_registerLuaPrintCallback | ( | BL_HANDLE | handle,
 |  | BLC_lua_print_func_ptr * | func,
 |  | void * | userdata
 | ) |  |

Registers a callback that will be called when the lua "print" function is called.

Parameters
[in] | handle | The connection for the callback
[in] | func | The function to be called as callback.
[in] | userdata | Any user supplied data, which will be available in the callback (e.g as connection or channel handle)
int BL_DLLIMPORT BLC_registerMacroStateCallback | ( | BL_HANDLE | handle,
 |  | BLC_macrostate_callback_func * | callback
 | ) |  |

Issuing a NULL-pointer de-registers the callback function. As the function is called from another thread context, take care of thread-safety (i.e. using mutexes, etc.).

Parameters
[in] | handle | Handle representing the channel emitting the error; returned previously by
[in] | callback | Pointer to a function call-compatible to BLC_macrostate_callback_func.
Returns
Status of operation; '=0' means successful, '!=0' otherwise. See standard return values for error, or for textual representation (for return values < -1000) BLC_getLastError.
int BL_DLLIMPORT BLC_registerSignalCallback | ( | BL_HANDLE | handle,
 |  | BLC_signal_callback_func * | callback
 | ) |  |

Issuing a NULL-pointer de-registers the callback function. As the function is called from another thread context, take care of thread-safety (i.e. using mutexes, etc.).

Parameters
[in] | handle | Handle representing the channel on which the signal occurred;
[in] | callback | Pointer to a function call-compatible to BLC_signal_callback_func.
Returns
Status of operation; '=0' means successful, '!=0' otherwise. See standard return values for error, or for textual representation (for return values < -1000) BLC_getLastError.
int BL_DLLIMPORT BLC_registerUserDataDebugCallback | ( | BL_HANDLE | handle,
 |  | BLC_debug_callback_func_ptr * | callback,
 |  | void * | userdata
 | ) |  |

Issuing a NULL-pointer de-registers the callback function. As the function is called from another thread context, take care of thread-safety (i.e. using mutexes, etc.).

Parameters
[in] | handle | Handle representing the channel emitting the error; returned previously by
[in] | callback | Pointer to a function call-compatible to BLC_debug_callback_func_ptr.
[in] | userdata | Pointer to custom user data to pass to BLC_error_callback_func_ptr.
Returns
Status of operation; '=0' means successful, '!=0' otherwise. See standard return values for error, or for textual representation (for return values < -1000) BLC_getLastError.
int BL_DLLIMPORT BLC_registerUserDataDTLRequestCallback | ( | BL_HANDLE | handle,
 |  | BLC_dtl_request_callback_func_ptr * | callback,
 |  | void * | userdata
 | ) |  |

Issuing a NULL-pointer de-registers the callback function. As the function is called from another thread context, take care of thread-safety (i.e. using mutexes, etc.).

Parameters
[in] | handle | Handle representing the channel emitting the error; returned previously by
[in] | callback | Pointer to a function call-compatible to BLC_dtl_request_callback_func_ptr.
[in] | userdata | Pointer to custom user data to pass to BLC_error_callback_func_ptr.
Returns
Status of operation; '=0' means successful, '!=0' otherwise. See standard return values for error, or for textual representation (for return values < -1000) BLC_getLastError.
int BL_DLLIMPORT BLC_registerUserDataDTLResponseCallback | ( | BL_HANDLE | handle,
 |  | BLC_dtl_response_callback_func_ptr * | callback,
 |  | void * | userdata
 | ) |  |

Issuing a NULL-pointer de-registers the callback function. As the function is called from another thread context, take care of thread-safety (i.e. using mutexes, etc.).

Parameters
[in] | handle | Handle representing the channel emitting the error; returned previously by
[in] | callback | Pointer to a function call-compatible to BLC_dtl_request_callback_func_ptr.
[in] | userdata | Pointer to custom user data to pass to BLC_error_callback_func_ptr.
Returns
Status of operation; '=0' means successful, '!=0' otherwise. See standard return values for error, or for textual representation (for return values < -1000) BLC_getLastError.
int BL_DLLIMPORT BLC_registerUserDataErrorCallback | ( | BL_HANDLE | handle,
 |  | BLC_error_callback_func_ptr * | callback,
 |  | void * | userdata
 | ) |  |

Issuing a NULL-pointer de-registers the callback function. As the function is called from another thread context, take care of thread-safety (i.e. using mutexes, etc.).

Parameters
[in] | handle | Handle representing the channel emitting the error; returned previously by
[in] | callback | Pointer to a function call-compatible to BLC_error_callback_func_ptr.
[in] | userdata | Pointer to custom user data to pass to BLC_error_callback_func_ptr.
Returns
Status of operation; '=0' means successful, '!=0' otherwise. See standard return values for error, or for textual representation (for return values < -1000) BLC_getLastError.
int BL_DLLIMPORT BLC_registerUserDataEvent | ( | BL_HANDLE | handle,
 |  | BLC_event_callback_func_ptr * | callback,
 |  | void * | userdata
 | ) |  |

Issuing a NULL-pointer de-registers the callback function. As the function is called from another thread context, take care of thread-safety (i.e. using mutexes, etc.).

Parameters
[in] | handle | Handle representing the channel id which the event occurred
[in] | callback | Pointer to a function call-compatible to BLC_event_callback_func_ptr.
[in] | userdata | Pointer to custom user data to pass to BLC_event_callback_func_ptr.
Returns
Status of operation; '=0' means successful, '!=0' otherwise. See standard return values for error, or for textual representation (for return values < -1000) BLC_getLastError.
int BL_DLLIMPORT BLC_registerUserDataEventCallback | ( | BL_HANDLE | handle,
 |  | BLC_event_callback_func_ptr * | callback,
 |  | void * | userdata
 | ) |  |
int BL_DLLIMPORT BLC_registerUserDataFrameCallback | ( | BL_HANDLE | handle,
 |  | BLC_frame_callback_func_ptr * | callback,
 |  | void * | userdata
 | ) |  |

Issuing a NULL-pointer de-registers the callback function. As the function is called from another thread context, take care of thread-safety (i.e. using mutexes, etc.).

Parameters
[in] | handle | Handle representing the channel id which the frame occurred
[in] | callback | Pointer to a function call-compatible to BLC_frame_callback_func_ptr.
[in] | userdata | Pointer to custom user data to pass to BLC_frame_callback_func_ptr.
Returns
Status of operation; '=0' means successful, '!=0' otherwise. See standard return values for error, or for textual representation (for return values < -1000) BLC_getLastError.
int BL_DLLIMPORT BLC_registerUserDataJumboFrameCallback | ( | BL_HANDLE | handle,
 |  | BLC_jumboframe_callback_func_ptr * | callback,
 |  | void * | userdata
 | ) |  |

Issuing a NULL-pointer de-registers the callback function. As the function is called from another thread context, take care of thread-safety (i.e. using mutexes, etc.).

Parameters
[in] | handle | Handle representing the channel id which the frame occurred
[in] | callback | Pointer to a function call-compatible to BLC_jumboframe_callback_func_ptr.
[in] | userdata | Pointer to custom user data to pass to BLC_jumboframe_callback_func_ptr.
Returns
Status of operation; '=0' means successful, '!=0' otherwise. See standard return values for error, or for textual representation (for return values < -1000) BLC_getLastError.
int BL_DLLIMPORT BLC_registerUserDataLogCallback | ( | BL_HANDLE | handle,
 |  | BLC_log_callback_func_ptr * | callback,
 |  | void * | userdata
 | ) |  |

Issuing a NULL-pointer de-registers the callback function. Since the function is called from another thread context, take care of thread-safety (i.e. using mutexes, etc.).

Parameters
handle | Handle representing the channel the callback for logs must be registered to
callback | Pointer to a function call-compatible to BLC_log_callback_func_ptr.
userdata | Pointer to custom user data to pass to BLC_log_callback_func_ptr.
Returns
Status of operation; '=0' means successful, '!=0' otherwise. See standard return values for error, or for textual representation (for return values < -1000) BLC_getLastError.
int BL_DLLIMPORT BLC_registerUserDataMacroStateCallback | ( | BL_HANDLE | handle,
 |  | BLC_macrostate_callback_func_ptr * | callback,
 |  | void * | userdata
 | ) |  |

Issuing a NULL-pointer de-registers the callback function. As the function is called from another thread context, take care of thread-safety (i.e. using mutexes, etc.).

Parameters
[in] | handle | Handle representing the channel emitting the error; returned previously by
[in] | callback | Pointer to a function call-compatible to BLC_macrostate_callback_func_ptr.
[in] | userdata | Pointer to custom user data to pass to BLC_error_callback_func_ptr.
Returns
Status of operation; '=0' means successful, '!=0' otherwise. See standard return values for error, or for textual representation (for return values < -1000) BLC_getLastError.
int BL_DLLIMPORT BLC_registerUserDataSignalCallback | ( | BL_HANDLE | handle,
 |  | BLC_signal_callback_func_ptr * | callback,
 |  | void * | userdata
 | ) |  |

Issuing a NULL-pointer de-registers the callback function. As the function is called from another thread context, take care of thread-safety (i.e. using mutexes, etc.).

Parameters
[in] | handle | Handle representing the channel on which the signal occurred;
[in] | callback | Pointer to a function call-compatible to BLC_signal_callback_func_ptr.
[in] | userdata | Pointer to custom user data to pass to BLC_signal_callback_func_ptr.
Returns
Status of operation; '=0' means successful, '!=0' otherwise. See standard return values for error, or for textual representation (for return values < -1000) BLC_getLastError.
Generated on Fri May 30 2025 17:16:13 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: C:/JenkinsWS/workspace/orks_v2_LinWorksv2_Windows_trunk/source/externals/BabyLIN/src/libraries/BabyLIN/publicHeaders/BabyLINCAN.h Source File

  • externals
  • BabyLIN
  • src
  • libraries
  • BabyLIN
  • publicHeaders
BabyLINCAN.h
Go to the documentation of this file.
1 #ifndef BABYLIN_H
2 #define BABYLIN_H
3
4 #include "BabyLINCAN_types.h"
5
6 #if defined(__cplusplus)
7 #include <cstddef> // get "size_t", used by function BL_encodeSignal())
8 #include <cstdint>
9 extern "C" {
10 #else
11 #include <stddef.h> // get "size_t", used by function BL_encodeSignal())
12 #include <stdint.h>
13 #endif
14
28 int BL_DLLIMPORT BLC_registerJumboFrameCallback(BL_HANDLE handle,
29 BLC_jumboframe_callback_func* callback);
30
41 int BL_DLLIMPORT BLC_registerFrameCallback(BL_HANDLE handle, BLC_frame_callback_func* callback);
42
53 int BL_DLLIMPORT BLC_registerSignalCallback(BL_HANDLE handle, BLC_signal_callback_func* callback);
54
65 int BL_DLLIMPORT BLC_registerErrorCallback(BL_HANDLE handle, BLC_error_callback_func* callback);
66
78 int BL_DLLIMPORT BLC_registerMacroStateCallback(BL_HANDLE handle,
79 BLC_macrostate_callback_func* callback);
80
92 int BL_DLLIMPORT BLC_registerDebugCallback(BL_HANDLE handle, BLC_debug_callback_func* callback);
93
105 int BL_DLLIMPORT BLC_registerDTLRequestCallback(BL_HANDLE handle,
106 BLC_dtl_request_callback_func* callback);
107
119 int BL_DLLIMPORT BLC_registerDTLResponseCallback(BL_HANDLE handle,
120 BLC_dtl_response_callback_func* callback);
121
136 int BL_DLLIMPORT BLC_registerUserDataJumboFrameCallback(BL_HANDLE handle,
137 BLC_jumboframe_callback_func_ptr* callback,
138 void* userdata);
139
152 int BL_DLLIMPORT BLC_registerUserDataFrameCallback(BL_HANDLE handle,
153 BLC_frame_callback_func_ptr* callback,
154 void* userdata);
155
167 int BL_DLLIMPORT BLC_registerUserDataEvent(BL_HANDLE handle,
168 BLC_event_callback_func_ptr* callback,
169 void* userdata);
170
173 int BL_DLLIMPORT BLC_registerUserDataEventCallback(BL_HANDLE handle,
174 BLC_event_callback_func_ptr* callback,
175 void* userdata);
176
179 int BL_DLLIMPORT BLC_registerEventCallback(BL_HANDLE handle, BLC_event_callback_func* callback);
180
192 int BL_DLLIMPORT BLC_registerUserDataSignalCallback(BL_HANDLE handle,
193 BLC_signal_callback_func_ptr* callback,
194 void* userdata);
195
207 int BL_DLLIMPORT BLC_registerUserDataErrorCallback(BL_HANDLE handle,
208 BLC_error_callback_func_ptr* callback,
209 void* userdata);
223 int BL_DLLIMPORT BLC_registerUserDataMacroStateCallback(BL_HANDLE handle,
224 BLC_macrostate_callback_func_ptr* callback,
225 void* userdata);
238 int BL_DLLIMPORT BLC_registerUserDataDebugCallback(BL_HANDLE handle,
239 BLC_debug_callback_func_ptr* callback,
240 void* userdata);
253 int BL_DLLIMPORT BLC_registerUserDataDTLRequestCallback(BL_HANDLE handle,
254 BLC_dtl_request_callback_func_ptr* callback,
255 void* userdata);
268 int BL_DLLIMPORT BLC_registerUserDataDTLResponseCallback(BL_HANDLE handle,
269 BLC_dtl_response_callback_func_ptr* callback,
270 void* userdata);
271
281 int BL_DLLIMPORT BLC_registerLuaPrintCallback(BL_HANDLE handle,
282 BLC_lua_print_func_ptr* func,
283 void* userdata);
295 int BL_DLLIMPORT BLC_registerLuaErrorCallback(BL_HANDLE handle,
296 BLC_lua_print_func_ptr* func,
297 void* userdata);
298
310 int BL_DLLIMPORT BLC_registerUserDataLogCallback(BL_HANDLE handle,
311 BLC_log_callback_func_ptr* callback,
312 void* userdata);
313
316
334 void BL_DLLIMPORT BLC_getVersion(int* major, int* minor);
335
344 void BL_DLLIMPORT BLC_getExtendedVersion(int* major, int* minor, int* patch, int* buildrev);
345
351 CPCHAR BL_DLLIMPORT BLC_getVersionString(void);
352
381 int BL_DLLIMPORT BLC_getBabyLinPorts(BLC_PORTINFO portListToBeFilled[], int* pFoundPortCount);
382
398 int BL_DLLIMPORT BLC_getBabyLinPortsTimout(BLC_PORTINFO portListToBeFilled[],
399 int* pFoundPortCount,
400 int timoutms);
401
414 #if defined(_WIN32)
415 BL_HANDLE BL_DLLIMPORT BLC_open(unsigned int port);
416 #else
417 BL_HANDLE BL_DLLIMPORT BLC_open(const char* port);
418 #endif
419
432 BL_HANDLE BL_DLLIMPORT BLC_openNet(const char* ip, int port);
433
443 BL_HANDLE BL_DLLIMPORT BLC_openUSB(const char* device);
444
460 BL_HANDLE BL_DLLIMPORT BLC_openPort(BLC_PORTINFO portInfo);
461
491 int BL_DLLIMPORT BLC_convertUrl(const char* url, BLC_PORTINFO* portInfo);
492
500 int BL_DLLIMPORT BLC_close(BL_HANDLE handle);
501
508 int BL_DLLIMPORT BLC_closeAll(void);
509
519 int BL_DLLIMPORT BLC_flush(BL_HANDLE handle);
520
530 int BL_DLLIMPORT BLC_getTargetID(BL_HANDLE handle, BLC_TARGETID* targetID);
531
539 int BL_DLLIMPORT BLC_getHWType(BL_HANDLE handle);
540
548 int BL_DLLIMPORT BLC_getChannelCount(BL_HANDLE handle);
549
561 BL_HANDLE BL_DLLIMPORT BLC_getChannelHandle(BL_HANDLE handle, int channelId);
562
572 int BL_DLLIMPORT BLC_getChannelInfo(BL_HANDLE handle, BLC_CHANNELINFO* pinfo);
573
587 int BL_DLLIMPORT BLC_getLastError(BL_HANDLE handle, char* pErrorBuffer, int bufferLength);
588
595 CPCHAR BL_DLLIMPORT BLC_getErrorString(int error_code);
596
607 int BL_DLLIMPORT BLC_getDetailedErrorString(int errorCode,
608 int reportParameter,
609 char* pErrorBuffer,
610 int bufferLength);
611
620 int BL_DLLIMPORT BLC_Reset(BL_HANDLE handle);
621
646 int BL_DLLIMPORT BLC_loadSDF(BL_HANDLE handle, const char* filename, int download);
647
665 int BL_DLLIMPORT BLC_loadLDF(BL_HANDLE handle, const char* filename, int download);
666
679 int BL_DLLIMPORT BLC_downloadSDF(BL_HANDLE handle, int mode);
680
695 int BL_DLLIMPORT BLC_isSDFOnDevice(BL_HANDLE handle, const char* filename);
696
706 int BL_DLLIMPORT BLC_getSDFInfo(BL_HANDLE handle, BLC_SDFINFO* pSDFInfo);
707
719 int BL_DLLIMPORT BLC_getSectionInfo(BL_HANDLE handle,
720 int infoAboutSectionNr,
721 BLC_SECTIONINFO* pSectionInfo);
722
728 CPCHAR BL_DLLIMPORT BLC_getChannelSectionDescription(BL_HANDLE handle);
729
738 int BL_DLLIMPORT BLC_getNodeCount(BL_HANDLE handle);
739
751 int BL_DLLIMPORT BLC_getNodeName(BL_HANDLE handle, int idx, char* dstbuf, int buflen);
752
761 int BL_DLLIMPORT BLC_getFrameCount(BL_HANDLE handle);
762
775 int BL_DLLIMPORT BLC_getFrameName(BL_HANDLE handle, int idx, char* dstbuf, int buflen);
776
785 int BL_DLLIMPORT BLC_getSignalCount(BL_HANDLE handle);
786
799 int BL_DLLIMPORT BLC_getSignalName(BL_HANDLE handle, int idx, char* dstbuf, int buflen);
800
812 int BL_DLLIMPORT BLC_isSignalEmulated(BL_HANDLE handle, int idx);
813
823 int BL_DLLIMPORT BLC_getSignalSize(BL_HANDLE handle, int idx);
824
833 int BL_DLLIMPORT BLC_getSignalsInFrameCount(BL_HANDLE handle, int idx);
834
846 int BL_DLLIMPORT BLC_getSignalInFrame(BL_HANDLE handle, int frameIndex, int signalIndex);
847
857 int BL_DLLIMPORT BLC_getFrameNrForFrameId(BL_HANDLE handle, unsigned int frameId);
858
867 int BL_DLLIMPORT BLC_getFrameIdForFrameNr(BL_HANDLE handle, unsigned char frameNr);
868
890 int BL_DLLIMPORT BLC_sendRaw(BL_HANDLE handle, const unsigned char* command, unsigned int* length);
891
915 int BL_DLLIMPORT BLC_setDTLMode(BL_HANDLE handle, int mode);
916
927 int BL_DLLIMPORT BLC_sendDTLRequest(BL_HANDLE handle,
928 unsigned char nad,
929 int length,
930 unsigned char* data);
931
942 int BL_DLLIMPORT BLC_sendDTLResponse(BL_HANDLE handle,
943 unsigned char nad,
944 int length,
945 unsigned char* data);
946
962 int BL_DLLIMPORT BLC_sendRawSlaveResponse(BL_HANDLE handle,
963 unsigned char* reqdata,
964 unsigned char* reqmask,
965 unsigned char* data,
966 int length);
967
981 int BL_DLLIMPORT BLC_sendRawMasterRequest(BL_HANDLE handle, unsigned char* data, int count);
982
990 int BL_DLLIMPORT BLC_getDTLRequestStatus(BL_HANDLE handle);
991
999 int BL_DLLIMPORT BLC_getDTLResponseStatus(BL_HANDLE handle);
1000
1013 int BL_DLLIMPORT BLC_getRawSlaveResponse(BL_HANDLE handle, unsigned char* data, int length);
1014
1023 int BL_DLLIMPORT BLC_updRawSlaveResponse(BL_HANDLE handle);
1024
1034 int BL_DLLIMPORT BLC_lastAnswerHasData(BL_HANDLE handle);
1035
1055 int BL_DLLIMPORT BLC_getAnswerTypeByName(BL_HANDLE handle,
1056 const char* name,
1057 BL_ANSWER_TYPE* type,
1058 size_t* length);
1059
1079 int BL_DLLIMPORT BLC_getAnswerTypeByIndex(BL_HANDLE handle,
1080 const unsigned int index,
1081 BL_ANSWER_TYPE* type,
1082 size_t* length);
1083
1096 int BL_DLLIMPORT BLC_getAnswerNameByIndex(BL_HANDLE handle,
1097 int index,
1098 char* nameBuffer,
1099 int* nameBufferLength);
1100
1115 int BL_DLLIMPORT BLC_getAnswerByName(BL_HANDLE handle,
1116 const char* name,
1117 void* buffer,
1118 size_t length);
1119
1134 int BL_DLLIMPORT BLC_getAnswerByIndex(BL_HANDLE handle,
1135 const unsigned int index,
1136 void* buffer,
1137 size_t length);
1138
1151 int BL_DLLIMPORT BLC_sendCommand(BL_HANDLE handle, const char* command);
1152
1168 int BL_DLLIMPORT BLC_sendASCIICommand(
1169 BL_HANDLE handle, const char* command, char* buffer, int bufferLength, int timeout_ms);
1170
1181 int BL_DLLIMPORT BLC_setsig(BL_HANDLE handle, int signalNr, unsigned long long value);
1182
1194 int BL_DLLIMPORT BLC_mon_set(BL_HANDLE handle, int frameid, const int* databytes, int len);
1195
1207 int BL_DLLIMPORT BLC_mon_xmit(BL_HANDLE handle, int frameId, int slottime);
1208
1222 int BL_DLLIMPORT
1223 BLC_mon_set_xmit(BL_HANDLE handle, int frameId, const int* databytes, int len, int slottime);
1224
1241 int BL_DLLIMPORT BLC_macro_result(BL_HANDLE handle,
1242 int macro_nr,
1243 int64_t* return_value,
1244 unsigned int timeout_ms);
1245
1260 int BL_DLLIMPORT BLC_getMacroResultString(BL_HANDLE handle, int macro_nr, char* dstbuf, int buflen);
1261
1276 int BL_DLLIMPORT BLC_varRead(BL_HANDLE handle, int signal_nr, char* dstbuf, int length);
1277
1292 int BL_DLLIMPORT BLC_varWrite(BL_HANDLE handle, int signal_nr, char* data, int data_len);
1293
1300 BLC_ADHOC_PROTOCOL BL_DLLIMPORT BLC_AdHoc_DefaultProtocol(ADHOC_PROTOCOL_TYPE type);
1301
1310 BLC_ADHOC_SERVICE BL_DLLIMPORT BLC_AdHoc_DefaultService(const BLC_ADHOC_PROTOCOL protocol);
1311
1318 BLC_ADHOC_EXECUTE BL_DLLIMPORT BLC_AdHoc_DefaultExecute();
1319
1334 int BL_DLLIMPORT BLC_AdHoc_CreateProtocol(BL_HANDLE channel,
1335 BLC_ADHOC_PROTOCOL* protocol,
1336 BL_ADHOC_HANDLE* protocol_handle);
1337
1353 int BL_DLLIMPORT BLC_AdHoc_CreateService(BL_HANDLE channel,
1354 BL_ADHOC_HANDLE protocol,
1355 BLC_ADHOC_SERVICE* service,
1356 BL_ADHOC_HANDLE* service_handle);
1357
1385 int BL_DLLIMPORT BLC_AdHoc_Execute(BL_HANDLE channel,
1386 BL_ADHOC_HANDLE protocol_handle,
1387 BL_ADHOC_HANDLE service_handle,
1388 BLC_ADHOC_EXECUTE* execute_flags,
1389 const unsigned char* req_payload,
1390 int req_payload_length,
1391 unsigned char* rsp_payload,
1392 int* rsp_payload_length,
1393 int timeout);
1394
1416 int BL_DLLIMPORT BLC_AdHoc_ExecuteAsync(BL_HANDLE channel,
1417 BL_ADHOC_HANDLE protocol_handle,
1418 BL_ADHOC_HANDLE service_handle,
1419 BLC_ADHOC_EXECUTE* execute_flags,
1420 const unsigned char* req_payload,
1421 int req_payload_length,
1422 BL_ADHOC_HANDLE* execute_handle);
1423
1435 int BL_DLLIMPORT BLC_AdHoc_GetState(BL_HANDLE channel, BL_ADHOC_HANDLE execute_handle);
1436
1452 int BL_DLLIMPORT BLC_AdHoc_GetResponse(BL_HANDLE channel,
1453 BL_ADHOC_HANDLE execute_handle,
1454 unsigned char* rsp_payload,
1455 int* rsp_payload_size);
1456
1469 int BL_DLLIMPORT BLC_AdHoc_DeleteProtocol(BL_HANDLE channel, BL_ADHOC_HANDLE protocol);
1470
1482 int BL_DLLIMPORT BLC_AdHoc_DeleteService(BL_HANDLE channel,
1483 BL_ADHOC_HANDLE protocol,
1484 BL_ADHOC_HANDLE service);
1485
1495 int BL_DLLIMPORT BLC_AdHoc_DeleteAllProtocol(BL_HANDLE channel);
1496
1507 int BL_DLLIMPORT BLC_AdHoc_DeleteAllService(BL_HANDLE channel, BL_ADHOC_HANDLE protocol);
1508
1519 int BL_DLLIMPORT BLC_getTableCount(BL_HANDLE handle, int64_t* table_count);
1520
1532 int BL_DLLIMPORT BLC_getTableRowCount(BL_HANDLE handle, int table_id, int64_t* row_count);
1533
1545 int BL_DLLIMPORT BLC_getTableColumnCount(BL_HANDLE handle, int table_id, int64_t* column_count);
1546
1567 int BL_DLLIMPORT BLC_tableRead(BL_HANDLE handle,
1568 int table_id,
1569 int row,
1570 int column,
1571 int64_t* read_value,
1572 char* buf,
1573 int* bufsz);
1574
1587 int BL_DLLIMPORT BLC_tableWrite(BL_HANDLE handle, int table_id, int row, int column, int64_t value);
1588
1601 int BL_DLLIMPORT
1602 BLC_tableWriteText(BL_HANDLE handle, int table_id, int row, int column, const char* value);
1603
1621 int BL_DLLIMPORT BLC_tableFill(BL_HANDLE handle,
1622 int table_id,
1623 int start_row,
1624 int start_column,
1625 int end_row,
1626 int end_column,
1627 int64_t fill_value,
1628 const char* fill_text);
1629
1654 int BL_DLLIMPORT BLC_getLastFrame(BL_HANDLE handle, int frameNr, BLC_FRAME* framedata);
1655
1667 int BL_DLLIMPORT BLC_getNextFrame(BL_HANDLE handle, BLC_FRAME* framedata);
1668
1682 int BL_DLLIMPORT BLC_getNextFrames(BL_HANDLE handle, BLC_FRAME* framedata, int* size);
1683
1699 int BL_DLLIMPORT BLC_getNextFrameTimeout(BL_HANDLE handle, BLC_FRAME* framedata, int timeout_ms);
1700
1720 int BL_DLLIMPORT BLC_getNextFramesTimeout(BL_HANDLE handle,
1721 BLC_FRAME* framedata,
1722 int timeout_ms,
1723 int* size);
1724
1736 int BL_DLLIMPORT BLC_getNextJumboFrame(BL_HANDLE handle, BLC_JUMBO_FRAME* framedata);
1737
1751 int BL_DLLIMPORT BLC_getNextJumboFrames(BL_HANDLE handle, BLC_JUMBO_FRAME* framedata, int* size);
1752
1769 int BL_DLLIMPORT BLC_getNextJumboFrameTimeout(BL_HANDLE handle,
1770 BLC_JUMBO_FRAME* framedata,
1771 int timeout_ms);
1772
1793 int BL_DLLIMPORT BLC_getNextJumboFramesTimeout(BL_HANDLE handle,
1794 BLC_JUMBO_FRAME* framedata,
1795 int timeout_ms,
1796 int* size);
1797
1809 int BL_DLLIMPORT BLC_getNextSignal(BL_HANDLE handle, BLC_SIGNAL* signaldata);
1810
1825 int BL_DLLIMPORT BLC_getNextSignals(BL_HANDLE handle, BLC_SIGNAL* signaldata, int* size);
1826
1843 int BL_DLLIMPORT BLC_getNextSignalsForNumber(BL_HANDLE handle,
1844 BLC_SIGNAL* signaldata,
1845 int size,
1846 int signalNumber);
1847
1857 int BL_DLLIMPORT BLC_getNextBusError(BL_HANDLE handle, BLC_ERROR* errordata);
1858
1868 int BL_DLLIMPORT BLC_getNextDTLRequest(BL_HANDLE handle, BLC_DTL* frame);
1869
1879 int BL_DLLIMPORT BLC_getNextDTLResponse(BL_HANDLE handle, BLC_DTL* frame);
1880
1895 int BL_DLLIMPORT BLC_getSignalValue(BL_HANDLE handle, int signalNr, unsigned long long* value);
1896
1913 int BL_DLLIMPORT BLC_getSignalValueWithTimestamp(BL_HANDLE handle,
1914 int signalNr,
1915 unsigned long long* value,
1916 unsigned long long* timestamp);
1917
1929 int BL_DLLIMPORT BLC_getSignalValueByName(BL_HANDLE handle,
1930 const char* signalName,
1931 unsigned long long* value);
1932
1965 int BL_DLLIMPORT BLC_getSignalArray(BL_HANDLE handle, int signalNr, unsigned char* array);
1966
2001 int BL_DLLIMPORT BLC_getSignalArrayWithTimestamp(BL_HANDLE handle,
2002 int signalNr,
2003 unsigned char* array,
2004 unsigned long long* timestamp);
2005
2018 int BL_DLLIMPORT BLC_getSignalArrayByName(BL_HANDLE handle,
2019 const char* signalName,
2020 unsigned char* array);
2021
2031 int BL_DLLIMPORT BLC_isSignalArray(BL_HANDLE handle, int idx);
2032
2059 int BL_DLLIMPORT BLC_encodeSignal(BL_HANDLE handle,
2060 int signalNr,
2061 unsigned long long value,
2062 char* encSignal,
2063 size_t* buffLen0,
2064 char* encUnit,
2065 size_t* buffLen1);
2066
2077 int BL_DLLIMPORT BLC_decodeSignal(BL_HANDLE handle, int signalNr, char* encSignal, int64_t* value);
2078
2091 int BL_DLLIMPORT BLC_getSignalsInFrame(BL_HANDLE handle,
2092 int frameNr,
2093 BLC_SIGNAL* signalList,
2094 int signalListLen);
2095
2110 int BL_DLLIMPORT BLC_getFrameDetails(
2111 BL_HANDLE handle, int idx, int* pbusid, int* psize, int* pnodenum, int* pframetype);
2112
2123 int BL_DLLIMPORT BLC_getNodeForSignal(BL_HANDLE handle, int signalNr);
2145 int BL_DLLIMPORT
2146 BLC_dmStart(BL_HANDLE handle, int baudrate, int bitwidth, int stopbits, int parity);
2147
2161 int BL_DLLIMPORT BLC_dmReportConfig(BL_HANDLE handle, int timeout, int bytes);
2162
2176 int BL_DLLIMPORT BLC_dmWrite(BL_HANDLE handle, const char* data, unsigned int dataSize);
2177
2191 int BL_DLLIMPORT BLC_dmRead(BL_HANDLE handle, char* buffer, unsigned int bufferSize);
2192
2207 int BL_DLLIMPORT BLC_dmReadTimeout(BL_HANDLE handle,
2208 char* buffer,
2209 unsigned int bufferSize,
2210 unsigned int timeout_ms);
2211
2225 int BL_DLLIMPORT BLC_dmPulse(BL_HANDLE handle,
2226 unsigned int lowtime_us,
2227 unsigned int paddingtime_us);
2228
2240 int BL_DLLIMPORT BLC_dmDelay(BL_HANDLE channel, unsigned int paddingtime_us);
2241
2249 int BL_DLLIMPORT BLC_dmStop(BL_HANDLE handle);
2250
2259 int BL_DLLIMPORT BLC_dmPrepare(BL_HANDLE channel, unsigned char mode);
2284 int BL_DLLIMPORT BLC_loggingStart(BL_HANDLE handle, const char* configFile);
2285
2299 int BL_DLLIMPORT BLC_loggingAddComment(BL_HANDLE handle, const char* comment);
2300
2311 int BL_DLLIMPORT BLC_loggingStop(BL_HANDLE handle);
2312
2319 int BL_DLLIMPORT BLC_loggingStopGlobal();
2332 #ifdef WIN32
2333 #define BL_EXCEPTION_FILTER_ATTR __stdcall
2334 #else
2335 #define BL_EXCEPTION_FILTER_ATTR
2336 #endif
2337 typedef long(BL_EXCEPTION_FILTER_ATTR* exception_filter)(struct _EXCEPTION_POINTERS* ExceptionInfo);
2338 void BL_DLLIMPORT BLC_overwriteCrashHandler(exception_filter function,
2339 const char* application_name,
2340 int dump_external_code,
2341 int show_msgbox_on_crash);
2342
2343 int BL_DLLIMPORT BLC_runLuaCode(BL_HANDLE handle, const char* lua_code);
2344
2347 #if defined(__cplusplus)
2348 } // extern "C"
2349 #endif
2350
2351 #endif // BABYLIN_H
BLC_sendDTLResponse
int BL_DLLIMPORT BLC_sendDTLResponse(BL_HANDLE handle, unsigned char nad, int length, unsigned char *data)
Send a DTL slave response to a node.
BLC_dtl_response_callback_func_ptr
void( BLC_dtl_response_callback_func_ptr)(BL_HANDLE, BLC_DTL dtl_response, void *)
Definition: BabyLINCAN_types.h:853
BLC_overwriteCrashHandler
void BL_DLLIMPORT BLC_overwriteCrashHandler(exception_filter function, const char *application_name, int dump_external_code, int show_msgbox_on_crash)
BLC_JUMBO_FRAME
Definition: BabyLINCAN_types.h:243
BLC_close
int BL_DLLIMPORT BLC_close(BL_HANDLE handle)
Close connection to Device.
BLC_openPort
BL_HANDLE BL_DLLIMPORT BLC_openPort(BLC_PORTINFO portInfo)
Open a connection to a BabyLIN device using BLC_PORTINFO information.
BLC_lua_print_func_ptr
void( BLC_lua_print_func_ptr)(const char *msg, void *userdata)
Definition: BabyLINCAN_types.h:857
BLC_registerUserDataDebugCallback
int BL_DLLIMPORT BLC_registerUserDataDebugCallback(BL_HANDLE handle, BLC_debug_callback_func_ptr *callback, void *userdata)
Registers a callback function, which is called whenever a debug message from a BabyLIN-Device is rece...
BLC_flush
int BL_DLLIMPORT BLC_flush(BL_HANDLE handle)
Reset the BabyLIN device to an consistent and deactivated state.
BLC_event_callback_func_ptr
void( BLC_event_callback_func_ptr)(BL_HANDLE, BLC_EVENT event, void *)
Definition: BabyLINCAN_types.h:854
BLC_loggingStop
int BL_DLLIMPORT BLC_loggingStop(BL_HANDLE handle)
BLC_loggingStop stop and close all active logfiles which were started via BLC_loggingStart and linked...
BLC_error_callback_func_ptr
void( BLC_error_callback_func_ptr)(BL_HANDLE, BLC_ERROR error, void *)
Definition: BabyLINCAN_types.h:850
BLC_ADHOC_PROTOCOL
Definition: BabyLINCAN_types.h:621
BLC_dmPrepare
int BL_DLLIMPORT BLC_dmPrepare(BL_HANDLE channel, unsigned char mode)
BLC_dmPrepare enters or exits the preparation state.
BLC_openUSB
BL_HANDLE BL_DLLIMPORT BLC_openUSB(const char *device)
Open a connection to a BabyLIN USB device.
BLC_dmPulse
int BL_DLLIMPORT BLC_dmPulse(BL_HANDLE handle, unsigned int lowtime_us, unsigned int paddingtime_us)
Issue a pulse on the bus.
BLC_registerUserDataErrorCallback
int BL_DLLIMPORT BLC_registerUserDataErrorCallback(BL_HANDLE handle, BLC_error_callback_func_ptr *callback, void *userdata)
Registers a callback function, which is called on every reception of an error message.
BLC_getNodeName
int BL_DLLIMPORT BLC_getNodeName(BL_HANDLE handle, int idx, char *dstbuf, int buflen)
Returns the name of a given node.
BLC_registerLuaErrorCallback
int BL_DLLIMPORT BLC_registerLuaErrorCallback(BL_HANDLE handle, BLC_lua_print_func_ptr *func, void *userdata)
Registers a callback that will be called on any LUA engine error. You can register this callback to d...
BLC_registerUserDataMacroStateCallback
int BL_DLLIMPORT BLC_registerUserDataMacroStateCallback(BL_HANDLE handle, BLC_macrostate_callback_func_ptr *callback, void *userdata)
Registers a callback function, which is called whenever the execution state of a macro changes...
BLC_AdHoc_DefaultProtocol
BLC_ADHOC_PROTOCOL BL_DLLIMPORT BLC_AdHoc_DefaultProtocol(ADHOC_PROTOCOL_TYPE type)
Creates a adhoc protocol struct with the default settings for the given protocol type.
BLC_getAnswerTypeByIndex
int BL_DLLIMPORT BLC_getAnswerTypeByIndex(BL_HANDLE handle, const unsigned int index, BL_ANSWER_TYPE *type, size_t *length)
Get type of a parameter of the last answer data from a BabyLIN.
BLC_AdHoc_ExecuteAsync
int BL_DLLIMPORT BLC_AdHoc_ExecuteAsync(BL_HANDLE channel, BL_ADHOC_HANDLE protocol_handle, BL_ADHOC_HANDLE service_handle, BLC_ADHOC_EXECUTE *execute_flags, const unsigned char *req_payload, int req_payload_length, BL_ADHOC_HANDLE *execute_handle)
Runs a given protocol service on the device in a non-blocking way, the function returns directly afte...
BLC_getNextJumboFrame
int BL_DLLIMPORT BLC_getNextJumboFrame(BL_HANDLE handle, BLC_JUMBO_FRAME *framedata)
Fetches the next regular or jumbo frame on Channel from the receiver queue.
BLC_dmStop
int BL_DLLIMPORT BLC_dmStop(BL_HANDLE handle)
Stop direct mode.
BLC_getSectionInfo
int BL_DLLIMPORT BLC_getSectionInfo(BL_HANDLE handle, int infoAboutSectionNr, BLC_SECTIONINFO *pSectionInfo)
Retrieve informations about a SDF-Section from a loaded SDF.
BLC_registerLuaPrintCallback
int BL_DLLIMPORT BLC_registerLuaPrintCallback(BL_HANDLE handle, BLC_lua_print_func_ptr *func, void *userdata)
Registers a callback that will be called when the lua "print" function is called. ...
BLC_getNodeCount
int BL_DLLIMPORT BLC_getNodeCount(BL_HANDLE handle)
Returns the number of nodes on the BUS.
BLC_TARGETID
Information about a connected BabyLIN device.
Definition: BabyLINCAN_types.h:47
BL_EXCEPTION_FILTER_ATTR
#define BL_EXCEPTION_FILTER_ATTR
Definition: BabyLINCAN.h:2335
BLC_getChannelInfo
int BL_DLLIMPORT BLC_getChannelInfo(BL_HANDLE handle, BLC_CHANNELINFO *pinfo)
Retrieve informations about the Channel.
BLC_getSignalArray
int BL_DLLIMPORT BLC_getSignalArray(BL_HANDLE handle, int signalNr, unsigned char *array)
Returns the current signal value (for array signals).
BLC_getSignalValueByName
int BL_DLLIMPORT BLC_getSignalValueByName(BL_HANDLE handle, const char *signalName, unsigned long long *value)
Returns the current signal value (for non-array signals).
BLC_downloadSDF
int BL_DLLIMPORT BLC_downloadSDF(BL_HANDLE handle, int mode)
Loads the previously loaded SDF-file into the BabyLIN device.
BLC_convertUrl
int BL_DLLIMPORT BLC_convertUrl(const char *url, BLC_PORTINFO *portInfo)
convert a device url to BLC_PORTINFO to use in BLC_openPort
BLC_AdHoc_DeleteService
int BL_DLLIMPORT BLC_AdHoc_DeleteService(BL_HANDLE channel, BL_ADHOC_HANDLE protocol, BL_ADHOC_HANDLE service)
Deletes an existing adhoc service for the given protocol in the device.
BLC_getMacroResultString
int BL_DLLIMPORT BLC_getMacroResultString(BL_HANDLE handle, int macro_nr, char *dstbuf, int buflen)
Returns the result string of given macro, if it was set within the macro.
BLC_sendRawMasterRequest
int BL_DLLIMPORT BLC_sendRawMasterRequest(BL_HANDLE handle, unsigned char *data, int count)
Send a (non-DTL) Master request with the specified 8 bytes as data.
BLC_Reset
int BL_DLLIMPORT BLC_Reset(BL_HANDLE handle)
Resets the BabyLIN device to an consistent and deactivated state.
BLC_signal_callback_func_ptr
void( BLC_signal_callback_func_ptr)(BL_HANDLE, BLC_SIGNAL signal, void *)
Definition: BabyLINCAN_types.h:848
BLC_mon_set
int BL_DLLIMPORT BLC_mon_set(BL_HANDLE handle, int frameid, const int *databytes, int len)
Shorthand for "mon_set" command (see BabyLIN commands to use in BL_- and BLC_sendCommand Functions ) ...
BLC_macrostate_callback_func
void( BLC_macrostate_callback_func)(BL_HANDLE, BLC_MACROSTATE macroState)
Definition: BabyLINCAN_types.h:836
BLC_getSignalValue
int BL_DLLIMPORT BLC_getSignalValue(BL_HANDLE handle, int signalNr, unsigned long long *value)
Return the current signal value (for non-array signals).
BLC_getNextFrameTimeout
int BL_DLLIMPORT BLC_getNextFrameTimeout(BL_HANDLE handle, BLC_FRAME *framedata, int timeout_ms)
Fetches the next frame on Channel from the receiver queue with wait-timeout.
BLC_registerDTLResponseCallback
int BL_DLLIMPORT BLC_registerDTLResponseCallback(BL_HANDLE handle, BLC_dtl_response_callback_func *callback)
Registers a callback function, which is called whenever dtl response is received. ...
BLC_getNextDTLResponse
int BL_DLLIMPORT BLC_getNextDTLResponse(BL_HANDLE handle, BLC_DTL *frame)
Fetches the next complete DTL response from the receiver queue.
BLC_getChannelHandle
BL_HANDLE BL_DLLIMPORT BLC_getChannelHandle(BL_HANDLE handle, int channelId)
Retrieve a handle to the specified channel.
BLC_registerSignalCallback
int BL_DLLIMPORT BLC_registerSignalCallback(BL_HANDLE handle, BLC_signal_callback_func *callback)
Registers a callback function, which is called on every reception of a monitored signal.
BLC_encodeSignal
int BL_DLLIMPORT BLC_encodeSignal(BL_HANDLE handle, int signalNr, unsigned long long value, char *encSignal, size_t *buffLen0, char *encUnit, size_t *buffLen1)
Encodes the signal's value as defined in the corresponding Signal Encoding tables of LDF/SDF...
BLC_getFrameName
int BL_DLLIMPORT BLC_getFrameName(BL_HANDLE handle, int idx, char *dstbuf, int buflen)
Returns the name of a given frame.
BLC_getTableCount
int BL_DLLIMPORT BLC_getTableCount(BL_HANDLE handle, int64_t *table_count)
Returns the number of tables currently in the device / the loaded SDF.
BLC_log_callback_func_ptr
void( BLC_log_callback_func_ptr)(BL_HANDLE, BLC_LOG log, void *)
Definition: BabyLINCAN_types.h:855
BLC_sendCommand
int BL_DLLIMPORT BLC_sendCommand(BL_HANDLE handle, const char *command)
Send a command to the BabyLIN device.
BLC_macrostate_callback_func_ptr
void( BLC_macrostate_callback_func_ptr)(BL_HANDLE, BLC_MACROSTATE macroState, void *)
Definition: BabyLINCAN_types.h:849
BLC_getDetailedErrorString
int BL_DLLIMPORT BLC_getDetailedErrorString(int errorCode, int reportParameter, char *pErrorBuffer, int bufferLength)
Returns a C-string with the detailed textual representation of all possible error codes...
BLC_dmStart
int BL_DLLIMPORT BLC_dmStart(BL_HANDLE handle, int baudrate, int bitwidth, int stopbits, int parity)
Starts direct mode on channel with given baudrate, bitwidth, stopbits and parity settings. If the direct mode is already active on the channel, it will be restarted. The command prepares the channel with BLC_dmReportConfig settings of 5ms and 8 bytes.
ADHOC_PROTOCOL_TYPE
ADHOC_PROTOCOL_TYPE
Type of an ad hoc protocol.
Definition: BabyLINCAN_types.h:497
BLC_getAnswerNameByIndex
int BL_DLLIMPORT BLC_getAnswerNameByIndex(BL_HANDLE handle, int index, char *nameBuffer, int *nameBufferLength)
Get name of a parameter of the last answer data from a BabyLIN.
BLC_AdHoc_Execute
int BL_DLLIMPORT BLC_AdHoc_Execute(BL_HANDLE channel, BL_ADHOC_HANDLE protocol_handle, BL_ADHOC_HANDLE service_handle, BLC_ADHOC_EXECUTE *execute_flags, const unsigned char *req_payload, int req_payload_length, unsigned char *rsp_payload, int *rsp_payload_length, int timeout)
Runs a given protocol service on the device in a blocking way, the function returns after the protoco...
BLC_registerEventCallback
int BL_DLLIMPORT BLC_registerEventCallback(BL_HANDLE handle, BLC_event_callback_func *callback)
Alias for BLC_registerUserDataEvent without user data.
BLC_registerUserDataLogCallback
int BL_DLLIMPORT BLC_registerUserDataLogCallback(BL_HANDLE handle, BLC_log_callback_func_ptr *callback, void *userdata)
Registers a callback function, which is called whenever a log message is received.
BLC_getFrameDetails
int BL_DLLIMPORT BLC_getFrameDetails(BL_HANDLE handle, int idx, int *pbusid, int *psize, int *pnodenum, int *pframetype)
Returns some details for given frame entry.
BLC_registerDTLRequestCallback
int BL_DLLIMPORT BLC_registerDTLRequestCallback(BL_HANDLE handle, BLC_dtl_request_callback_func *callback)
Registers a callback function, which is called whenever dtl request is received.
BLC_dtl_response_callback_func
void( BLC_dtl_response_callback_func)(BL_HANDLE, BLC_DTL dtl_response)
Definition: BabyLINCAN_types.h:840
BLC_registerUserDataDTLResponseCallback
int BL_DLLIMPORT BLC_registerUserDataDTLResponseCallback(BL_HANDLE handle, BLC_dtl_response_callback_func_ptr *callback, void *userdata)
Registers a callback function, which is called whenever dtl response is received. ...
BLC_varWrite
int BL_DLLIMPORT BLC_varWrite(BL_HANDLE handle, int signal_nr, char *data, int data_len)
Writes an array of signals to values given by a bytearray.
BLC_getExtendedVersion
void BL_DLLIMPORT BLC_getExtendedVersion(int *major, int *minor, int *patch, int *buildrev)
Get the major, minor and patch version number of the library.
BLC_tableWrite
int BL_DLLIMPORT BLC_tableWrite(BL_HANDLE handle, int table_id, int row, int column, int64_t value)
Writes the given integer value into the table cell.
BLC_sendRawSlaveResponse
int BL_DLLIMPORT BLC_sendRawSlaveResponse(BL_HANDLE handle, unsigned char *reqdata, unsigned char *reqmask, unsigned char *data, int length)
Send a (non-DTL) slave response upon receive of matching master request.
BLC_dtl_request_callback_func
void( BLC_dtl_request_callback_func)(BL_HANDLE, BLC_DTL dtl_request)
Definition: BabyLINCAN_types.h:839
BLC_getLastFrame
int BL_DLLIMPORT BLC_getLastFrame(BL_HANDLE handle, int frameNr, BLC_FRAME *framedata)
Retrieve the last framedata available for a frame.
BLC_getChannelSectionDescription
CPCHAR BL_DLLIMPORT BLC_getChannelSectionDescription(BL_HANDLE handle)
Retrieve description string of a SDF-Section from a loaded SDF.
BLC_setsig
int BL_DLLIMPORT BLC_setsig(BL_HANDLE handle, int signalNr, unsigned long long value)
Shorthand for "setsig" command (see BabyLIN commands to use in BL_- and BLC_sendCommand Functions ) ...
BLC_updRawSlaveResponse
int BL_DLLIMPORT BLC_updRawSlaveResponse(BL_HANDLE handle)
BLC_updRawSlaveResponse resets the internal dtl buffer.
BLC_registerUserDataEventCallback
int BL_DLLIMPORT BLC_registerUserDataEventCallback(BL_HANDLE handle, BLC_event_callback_func_ptr *callback, void *userdata)
Alias for BLC_registerUserDataEvent.
BLC_frame_callback_func
void( BLC_frame_callback_func)(BL_HANDLE, BLC_FRAME frame)
Definition: BabyLINCAN_types.h:833
BLC_loggingStart
int BL_DLLIMPORT BLC_loggingStart(BL_HANDLE handle, const char *configFile)
BLC_loggingStart enables the standard logging feature for a specific device or channel.
BLC_getBabyLinPorts
int BL_DLLIMPORT BLC_getBabyLinPorts(BLC_PORTINFO portListToBeFilled[], int *pFoundPortCount)
Retrieve a list of ports a BabyLIN is connected to.
BLC_dmReportConfig
int BL_DLLIMPORT BLC_dmReportConfig(BL_HANDLE handle, int timeout, int bytes)
Configure the reporting policy of the device in respect to a timeout and/or a block of bytes...
BLC_decodeSignal
int BL_DLLIMPORT BLC_decodeSignal(BL_HANDLE handle, int signalNr, char *encSignal, int64_t *value)
BLC_decodeSignal takes an encoded Signal value and tries to compute it back to its Signal value...
BLC_ADHOC_SERVICE
Definition: BabyLINCAN_types.h:756
BLC_getRawSlaveResponse
int BL_DLLIMPORT BLC_getRawSlaveResponse(BL_HANDLE handle, unsigned char *data, int length)
Returns the first 'length' bytes of the current slave response-buffer.
BLC_closeAll
int BL_DLLIMPORT BLC_closeAll(void)
Close ALL connections to ALL Devices.
BLC_tableFill
int BL_DLLIMPORT BLC_tableFill(BL_HANDLE handle, int table_id, int start_row, int start_column, int end_row, int end_column, int64_t fill_value, const char *fill_text)
Writes the given values into all table cells than span from (start_row, start_column) to (end_row...
BLC_registerErrorCallback
int BL_DLLIMPORT BLC_registerErrorCallback(BL_HANDLE handle, BLC_error_callback_func *callback)
Registers a callback function, which is called on every reception of an error message.
BLC_signal_callback_func
void( BLC_signal_callback_func)(BL_HANDLE, BLC_SIGNAL signal)
Definition: BabyLINCAN_types.h:835
BLC_getNextJumboFrames
int BL_DLLIMPORT BLC_getNextJumboFrames(BL_HANDLE handle, BLC_JUMBO_FRAME *framedata, int *size)
Fetches the next regular or jumbo frames on channel from the receiver queue.
BLC_getVersionString
CPCHAR BL_DLLIMPORT BLC_getVersionString(void)
Get the version string of the library.
BLC_getErrorString
CPCHAR BL_DLLIMPORT BLC_getErrorString(int error_code)
Returns a C-string with the textual representation of an error code.
BL_ANSWER_TYPE
BL_ANSWER_TYPE
type of an answer data token retrieve type using BLC_getAnswerTypeByName or BLC_getAnswerTypeByIndex ...
Definition: BabyLINReturncodes.h:280
BLC_SIGNAL
Definition: BabyLINCAN_types.h:356
BLC_getNextFramesTimeout
int BL_DLLIMPORT BLC_getNextFramesTimeout(BL_HANDLE handle, BLC_FRAME *framedata, int timeout_ms, int *size)
Fetches the next frames on channel from the receiver queue with wait-timeout.
BLC_getNextSignal
int BL_DLLIMPORT BLC_getNextSignal(BL_HANDLE handle, BLC_SIGNAL *signaldata)
Fetches the next signal from the receiver queue.
BLC_DTL
Definition: BabyLINCAN_types.h:447
BLC_getDTLRequestStatus
int BL_DLLIMPORT BLC_getDTLRequestStatus(BL_HANDLE handle)
Returns the status of the last request-send operation.
BL_HANDLE
void * BL_HANDLE
Definition: BabyLINReturncodes.h:34
BLC_getSignalsInFrameCount
int BL_DLLIMPORT BLC_getSignalsInFrameCount(BL_HANDLE handle, int idx)
Retrieve the number of signals mapped in a frame.
BLC_getFrameNrForFrameId
int BL_DLLIMPORT BLC_getFrameNrForFrameId(BL_HANDLE handle, unsigned int frameId)
Retrieve the SDF frame number for a given BUS frame-id.
BLC_getNextJumboFramesTimeout
int BL_DLLIMPORT BLC_getNextJumboFramesTimeout(BL_HANDLE handle, BLC_JUMBO_FRAME *framedata, int timeout_ms, int *size)
Fetches the next regular or jumbo frames on channel from the receiver queue with wait-timeout.
BL_ADHOC_HANDLE
int BL_ADHOC_HANDLE
Definition: BabyLINReturncodes.h:35
BLC_runLuaCode
int BL_DLLIMPORT BLC_runLuaCode(BL_HANDLE handle, const char *lua_code)
BLC_AdHoc_CreateProtocol
int BL_DLLIMPORT BLC_AdHoc_CreateProtocol(BL_HANDLE channel, BLC_ADHOC_PROTOCOL *protocol, BL_ADHOC_HANDLE *protocol_handle)
Creates a adhoc protocol in the device with the given settings.
BLC_event_callback_func
void( BLC_event_callback_func)(BL_HANDLE, BLC_EVENT event)
Definition: BabyLINCAN_types.h:841
BLC_dmRead
int BL_DLLIMPORT BLC_dmRead(BL_HANDLE handle, char *buffer, unsigned int bufferSize)
Read data in direct mode.
BLC_isSignalEmulated
int BL_DLLIMPORT BLC_isSignalEmulated(BL_HANDLE handle, int idx)
Retrieve information about wheather a signal is emulated by the BabyLIN-Device or not...
BLC_getNodeForSignal
int BL_DLLIMPORT BLC_getNodeForSignal(BL_HANDLE handle, int signalNr)
Returns some details for given frame entry.
BLC_getSignalsInFrame
int BL_DLLIMPORT BLC_getSignalsInFrame(BL_HANDLE handle, int frameNr, BLC_SIGNAL *signalList, int signalListLen)
Get values of all signals mapped to a frame.
BLC_getChannelCount
int BL_DLLIMPORT BLC_getChannelCount(BL_HANDLE handle)
number of channels provided by the BabyLIN-Device
BLC_getAnswerByName
int BL_DLLIMPORT BLC_getAnswerByName(BL_HANDLE handle, const char *name, void *buffer, size_t length)
Get the value of a parameter of the last answer data from a BabyLIN.
BLC_getNextBusError
int BL_DLLIMPORT BLC_getNextBusError(BL_HANDLE handle, BLC_ERROR *errordata)
Fetches the next Bus error from the receiver queue.
BLC_PORTINFO
Information about a BabyLIN port on the host operating system.
Definition: BabyLINCAN_types.h:20
BLC_getSignalValueWithTimestamp
int BL_DLLIMPORT BLC_getSignalValueWithTimestamp(BL_HANDLE handle, int signalNr, unsigned long long *value, unsigned long long *timestamp)
Return the current signal value (for non-array signals) with timestamp.
BLC_registerUserDataSignalCallback
int BL_DLLIMPORT BLC_registerUserDataSignalCallback(BL_HANDLE handle, BLC_signal_callback_func_ptr *callback, void *userdata)
Registers a callback function, which is called on every reception of a monitored signal.
BLC_ADHOC_EXECUTE
Definition: BabyLINCAN_types.h:772
BLC_isSignalArray
int BL_DLLIMPORT BLC_isSignalArray(BL_HANDLE handle, int idx)
Returns the type of a signal.
BLC_getHWType
int BL_DLLIMPORT BLC_getHWType(BL_HANDLE handle)
Returns the unique hardware type identifier for a device.
BLC_openNet
BL_HANDLE BL_DLLIMPORT BLC_openNet(const char *ip, int port)
Open a connection to a BabyLIN device using ethernet.
BLC_jumboframe_callback_func
void( BLC_jumboframe_callback_func)(BL_HANDLE, BLC_JUMBO_FRAME jumbo_frame)
Definition: BabyLINCAN_types.h:834
BLC_getTableColumnCount
int BL_DLLIMPORT BLC_getTableColumnCount(BL_HANDLE handle, int table_id, int64_t *column_count)
Returns the number of columns currently in the given table.
BLC_loggingStopGlobal
int BL_DLLIMPORT BLC_loggingStopGlobal()
BLC_loggingStopGlobal stop and close all active logfiles which were started via BLC_loggingStart. This function did not stop the logging via a SDF file if used.
BLC_varRead
int BL_DLLIMPORT BLC_varRead(BL_HANDLE handle, int signal_nr, char *dstbuf, int length)
Returns the result of a "varrd" command in a convienent way.
BLC_AdHoc_CreateService
int BL_DLLIMPORT BLC_AdHoc_CreateService(BL_HANDLE channel, BL_ADHOC_HANDLE protocol, BLC_ADHOC_SERVICE *service, BL_ADHOC_HANDLE *service_handle)
Creates a adhoc service in the device with the given settings for an existing protocol.
BLC_getNextDTLRequest
int BL_DLLIMPORT BLC_getNextDTLRequest(BL_HANDLE handle, BLC_DTL *frame)
Fetches the next complete DTL request from the receiver queue.
BLC_getSDFInfo
int BL_DLLIMPORT BLC_getSDFInfo(BL_HANDLE handle, BLC_SDFINFO *pSDFInfo)
Retrieve further Information about a loaded SDF.
BLC_tableRead
int BL_DLLIMPORT BLC_tableRead(BL_HANDLE handle, int table_id, int row, int column, int64_t *read_value, char *buf, int *bufsz)
Returns the value of the specified table cell.
BLC_getTableRowCount
int BL_DLLIMPORT BLC_getTableRowCount(BL_HANDLE handle, int table_id, int64_t *row_count)
Returns the number of rows currently in the given table.
BLC_registerUserDataFrameCallback
int BL_DLLIMPORT BLC_registerUserDataFrameCallback(BL_HANDLE handle, BLC_frame_callback_func_ptr *callback, void *userdata)
Registers a callback function, which is called on every reception of a (monitored) frame...
BLC_getLastError
int BL_DLLIMPORT BLC_getLastError(BL_HANDLE handle, char *pErrorBuffer, int bufferLength)
Returns a C-string with the textual representation of the last error.
BLC_getNextSignalsForNumber
int BL_DLLIMPORT BLC_getNextSignalsForNumber(BL_HANDLE handle, BLC_SIGNAL *signaldata, int size, int signalNumber)
Fetches the next signals for a specific signal from the receiver queue.
BLC_jumboframe_callback_func_ptr
void( BLC_jumboframe_callback_func_ptr)(BL_HANDLE, BLC_JUMBO_FRAME jumbo_frame, void *)
Definition: BabyLINCAN_types.h:847
BLC_getAnswerByIndex
int BL_DLLIMPORT BLC_getAnswerByIndex(BL_HANDLE handle, const unsigned int index, void *buffer, size_t length)
Get the value of a parameter of the last answer data from a BabyLIN.
BLC_getSignalName
int BL_DLLIMPORT BLC_getSignalName(BL_HANDLE handle, int idx, char *dstbuf, int buflen)
Returns the name of given signal.
BLC_getNextJumboFrameTimeout
int BL_DLLIMPORT BLC_getNextJumboFrameTimeout(BL_HANDLE handle, BLC_JUMBO_FRAME *framedata, int timeout_ms)
Fetches the next regular or jumbo frame on Channel from the receiver queue with wait-timeout.
BLC_getAnswerTypeByName
int BL_DLLIMPORT BLC_getAnswerTypeByName(BL_HANDLE handle, const char *name, BL_ANSWER_TYPE *type, size_t *length)
Get type of a parameter of the last answer data from a BabyLIN.
BLC_CHANNELINFO
Information about a channel on a BabyLIN device.
Definition: BabyLINCAN_types.h:105
BabyLINCAN_types.h
BLC_registerUserDataEvent
int BL_DLLIMPORT BLC_registerUserDataEvent(BL_HANDLE handle, BLC_event_callback_func_ptr *callback, void *userdata)
Registers a callback function, which is called on every reception of an event report.
BLC_registerUserDataDTLRequestCallback
int BL_DLLIMPORT BLC_registerUserDataDTLRequestCallback(BL_HANDLE handle, BLC_dtl_request_callback_func_ptr *callback, void *userdata)
Registers a callback function, which is called whenever dtl request is received.
BLC_AdHoc_DeleteAllService
int BL_DLLIMPORT BLC_AdHoc_DeleteAllService(BL_HANDLE channel, BL_ADHOC_HANDLE protocol)
Deletes all existing adhoc services for the given channel and protocol.
BLC_getNextFrame
int BL_DLLIMPORT BLC_getNextFrame(BL_HANDLE handle, BLC_FRAME *framedata)
Fetches the next frame on Channel from the receiver queue.
BLC_dmWrite
int BL_DLLIMPORT BLC_dmWrite(BL_HANDLE handle, const char *data, unsigned int dataSize)
Writes data in directmode to the bus.
BL_DLLIMPORT
#define BL_DLLIMPORT
Definition: BabyLINReturncodes.h:9
BLC_dmReadTimeout
int BL_DLLIMPORT BLC_dmReadTimeout(BL_HANDLE handle, char *buffer, unsigned int bufferSize, unsigned int timeout_ms)
Same as BLC_dmRead with waiting timeout in ms.
BLC_getFrameIdForFrameNr
int BL_DLLIMPORT BLC_getFrameIdForFrameNr(BL_HANDLE handle, unsigned char frameNr)
Retrieve the BUS frame-id for a given SDF frame number.
BLC_getVersion
void BL_DLLIMPORT BLC_getVersion(int *major, int *minor)
Get the major and minor version number of the library.
BLC_setDTLMode
int BL_DLLIMPORT BLC_setDTLMode(BL_HANDLE handle, int mode)
Set the Diagnostic Transport Layer mode.
BLC_registerJumboFrameCallback
int BL_DLLIMPORT BLC_registerJumboFrameCallback(BL_HANDLE handle, BLC_jumboframe_callback_func *callback)
Registers a callback function, which is called on every reception of a (monitored) jumbo frame...
BLC_getSignalCount
int BL_DLLIMPORT BLC_getSignalCount(BL_HANDLE handle)
Returns the number of signals.
exception_filter
long(BL_EXCEPTION_FILTER_ATTR * exception_filter)(struct _EXCEPTION_POINTERS *ExceptionInfo)
Definition: BabyLINCAN.h:2337
CPCHAR
const char * CPCHAR
Definition: BabyLINReturncodes.h:36
BLC_error_callback_func
void( BLC_error_callback_func)(BL_HANDLE, BLC_ERROR error)
Definition: BabyLINCAN_types.h:837
BLC_getSignalSize
int BL_DLLIMPORT BLC_getSignalSize(BL_HANDLE handle, int idx)
Retrieve size of a signal.
BLC_AdHoc_DefaultService
BLC_ADHOC_SERVICE BL_DLLIMPORT BLC_AdHoc_DefaultService(const BLC_ADHOC_PROTOCOL protocol)
Creates a adhoc service struct with the default settings for the service and protocol combination...
BLC_registerMacroStateCallback
int BL_DLLIMPORT BLC_registerMacroStateCallback(BL_HANDLE handle, BLC_macrostate_callback_func *callback)
Registers a callback function, which is called whenever the execution state of a macro changes...
BLC_mon_xmit
int BL_DLLIMPORT BLC_mon_xmit(BL_HANDLE handle, int frameId, int slottime)
Shorthand for "mon_xmit" command (see BabyLIN commands to use in BL_- and BLC_sendCommand Functions )...
BLC_dmDelay
int BL_DLLIMPORT BLC_dmDelay(BL_HANDLE channel, unsigned int paddingtime_us)
Delay the next operation by the given time.
BLC_getFrameCount
int BL_DLLIMPORT BLC_getFrameCount(BL_HANDLE handle)
Returns the number of frames of the BUS description.
BLC_AdHoc_GetState
int BL_DLLIMPORT BLC_AdHoc_GetState(BL_HANDLE channel, BL_ADHOC_HANDLE execute_handle)
Returns the current state of the given protocol service.
BLC_loggingAddComment
int BL_DLLIMPORT BLC_loggingAddComment(BL_HANDLE handle, const char *comment)
BLC_loggingAddComment Added a string to the logfile.
BLC_sendRaw
int BL_DLLIMPORT BLC_sendRaw(BL_HANDLE handle, const unsigned char *command, unsigned int *length)
Send a (raw!) command to the BabyLIN device.
BLC_sendDTLRequest
int BL_DLLIMPORT BLC_sendDTLRequest(BL_HANDLE handle, unsigned char nad, int length, unsigned char *data)
Send a DTL master request to a node.
BLC_SDFINFO
Definition: BabyLINCAN_types.h:150
BLC_mon_set_xmit
int BL_DLLIMPORT BLC_mon_set_xmit(BL_HANDLE handle, int frameId, const int *databytes, int len, int slottime)
Shorthand for "mon_set" followed by "mon_xmit" command (see BabyLIN commands to use in BL_- and BLC_s...
BLC_AdHoc_GetResponse
int BL_DLLIMPORT BLC_AdHoc_GetResponse(BL_HANDLE channel, BL_ADHOC_HANDLE execute_handle, unsigned char *rsp_payload, int *rsp_payload_size)
Returns the response payload of the given protocol service.
BLC_loadLDF
int BL_DLLIMPORT BLC_loadLDF(BL_HANDLE handle, const char *filename, int download)
Loads the specified LDFile into library and optionally the BabyLIN device.
BLC_SECTIONINFO
Definition: BabyLINCAN_types.h:162
BLC_ERROR
Definition: BabyLINCAN_types.h:375
BLC_frame_callback_func_ptr
void( BLC_frame_callback_func_ptr)(BL_HANDLE, BLC_FRAME frame, void *)
Definition: BabyLINCAN_types.h:846
BLC_getNextFrames
int BL_DLLIMPORT BLC_getNextFrames(BL_HANDLE handle, BLC_FRAME *framedata, int *size)
Fetches the next frames on channel from the receiver queue.
BLC_dtl_request_callback_func_ptr
void( BLC_dtl_request_callback_func_ptr)(BL_HANDLE, BLC_DTL dtl_request, void *)
Definition: BabyLINCAN_types.h:852
BLC_macro_result
int BL_DLLIMPORT BLC_macro_result(BL_HANDLE handle, int macro_nr, int64_t *return_value, unsigned int timeout_ms)
Convenience function for command "macro_result" handling answer data.
BLC_AdHoc_DefaultExecute
BLC_ADHOC_EXECUTE BL_DLLIMPORT BLC_AdHoc_DefaultExecute()
Creates a adhoc execute struct with the default settings for the execution of adhoc protocols...
BLC_getNextSignals
int BL_DLLIMPORT BLC_getNextSignals(BL_HANDLE handle, BLC_SIGNAL *signaldata, int *size)
Fetches the next signals from the receiver queue.
BLC_getDTLResponseStatus
int BL_DLLIMPORT BLC_getDTLResponseStatus(BL_HANDLE handle)
Returns the status of the last resonse-send operation.
BLC_getTargetID
int BL_DLLIMPORT BLC_getTargetID(BL_HANDLE handle, BLC_TARGETID *targetID)
Requests the information about the target.
BLC_getSignalArrayWithTimestamp
int BL_DLLIMPORT BLC_getSignalArrayWithTimestamp(BL_HANDLE handle, int signalNr, unsigned char *array, unsigned long long *timestamp)
Returns the current signal value (for array signals) with timstamp.
BLC_FRAME
Definition: BabyLINCAN_types.h:174
BLC_AdHoc_DeleteProtocol
int BL_DLLIMPORT BLC_AdHoc_DeleteProtocol(BL_HANDLE channel, BL_ADHOC_HANDLE protocol)
Deletes an existing adhoc protocol in the device. This deletes all child services of the protocol too...
BLC_debug_callback_func
void( BLC_debug_callback_func)(BL_HANDLE, const char *text)
Definition: BabyLINCAN_types.h:838
BLC_isSDFOnDevice
int BL_DLLIMPORT BLC_isSDFOnDevice(BL_HANDLE handle, const char *filename)
Checks whether the given file is already loaded on a device.
BLC_getSignalArrayByName
int BL_DLLIMPORT BLC_getSignalArrayByName(BL_HANDLE handle, const char *signalName, unsigned char *array)
Returns the current signal value (for array signals).
BLC_lastAnswerHasData
int BL_DLLIMPORT BLC_lastAnswerHasData(BL_HANDLE handle)
Returns BL_OK if the last answer to a command, send to the given handle, contained additional data...
BLC_debug_callback_func_ptr
void( BLC_debug_callback_func_ptr)(BL_HANDLE, const char *text, void *)
Definition: BabyLINCAN_types.h:851
BLC_AdHoc_DeleteAllProtocol
int BL_DLLIMPORT BLC_AdHoc_DeleteAllProtocol(BL_HANDLE channel)
Deletes all existing adhoc protocol for the given channel. This deletes all services too...
BLC_getSignalInFrame
int BL_DLLIMPORT BLC_getSignalInFrame(BL_HANDLE handle, int frameIndex, int signalIndex)
Retrieve the signal number of a signal mapped in a frame.
BLC_registerDebugCallback
int BL_DLLIMPORT BLC_registerDebugCallback(BL_HANDLE handle, BLC_debug_callback_func *callback)
Registers a callback function, which is called whenever a debug message from a BabyLIN-Device is rece...
BLC_loadSDF
int BL_DLLIMPORT BLC_loadSDF(BL_HANDLE handle, const char *filename, int download)
Loads the specified SDF-file into library and optionally the BabyLIN device.
BLC_registerFrameCallback
int BL_DLLIMPORT BLC_registerFrameCallback(BL_HANDLE handle, BLC_frame_callback_func *callback)
Registers a callback function, which is called on every reception of a (monitored) frame...
BLC_getBabyLinPortsTimout
int BL_DLLIMPORT BLC_getBabyLinPortsTimout(BLC_PORTINFO portListToBeFilled[], int *pFoundPortCount, int timoutms)
Retrieve a list of ports a BabyLIN is connected to.
BLC_open
BL_HANDLE BL_DLLIMPORT BLC_open(unsigned int port)
Open a connection to a BabyLIN USB-Serial device.
BLC_registerUserDataJumboFrameCallback
int BL_DLLIMPORT BLC_registerUserDataJumboFrameCallback(BL_HANDLE handle, BLC_jumboframe_callback_func_ptr *callback, void *userdata)
Registers a callback function, which is called on every reception of a (monitored) jumbo frame...
BLC_tableWriteText
int BL_DLLIMPORT BLC_tableWriteText(BL_HANDLE handle, int table_id, int row, int column, const char *value)
Writes the given string value into the table cell.
BLC_sendASCIICommand
int BL_DLLIMPORT BLC_sendASCIICommand(BL_HANDLE handle, const char *command, char *buffer, int bufferLength, int timeout_ms)
Sends a ASCII protocol command and wait for its response.
Generated on Fri May 30 2025 17:16:13 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: C:/JenkinsWS/workspace/orks_v2_LinWorksv2_Windows_trunk/source/externals/BabyLIN/src/libraries/BabyLIN/publicHeaders/BabyLINCAN_nostruct.h File Reference

  • externals
  • BabyLIN
  • src
  • libraries
  • BabyLIN
  • publicHeaders
Functions
BabyLINCAN_nostruct.h File Reference
#include "BabyLINCAN.h"
#include <stddef.h>
#include <stdint.h>

Go to the source code of this file.

Functions

BL_HANDLE BL_DLLIMPORT | BLCns_openPort (int portNr, int type, char *name, char *device)
Open a connection to a BabyLIN device using BLC_PORTINFO information. More...
BL_HANDLE BL_DLLIMPORT | BLCns_openURL (char *url)
Open a connection to a BabyLIN device using BLC_PORTINFO information. More...
int BL_DLLIMPORT | BLCns_getTargetID (BL_HANDLE handle, unsigned short *type, unsigned short *version, unsigned short *flags, long *serial, long *heapsize, long *numofchannels, char *name, int nameLength)
Requests the information about the target. More...
int BL_DLLIMPORT | BLCns_getChannelInfo (BL_HANDLE handle, unsigned short *id, unsigned short *type, char *name, int nameLength, long *maxbaudrate, long *reserved1, long *reserved2, long *reserved3, int *associatedWithSectionNr)
Retrieve informations about the Channel. More...
int BL_DLLIMPORT | BLCns_getVersionString (char *buffer, int bufferlen)
Get the version string of the library. More...
int BL_DLLIMPORT | BLCns_getLastFrame (BL_HANDLE handle, int frameNr, unsigned long *chId, unsigned long *timestamp, long *intime, unsigned long *frameId, unsigned char *lenOfData, unsigned char *frameData, short *frameFlags, short *busFlags, unsigned char *checksum)
Retrieve the last framedata available for a frame. More...
int BL_DLLIMPORT | BLCns_getNextFrame (BL_HANDLE handle, unsigned long *chId, unsigned long *timestamp, long *intime, unsigned long *frameId, unsigned char *lenOfData, unsigned char *frameData, short *frameFlags, short *busFlags, unsigned char *checksum)
Fetches the next frame on Channel from the receiver queue. More...
int BL_DLLIMPORT | BLCns_getNextFrames (BL_HANDLE handle, unsigned long chId[], unsigned long timestamp[], long intime[], unsigned long frameId[], unsigned char lenOfData[], unsigned char frameData[], short frameFlags[], short busFlags[], unsigned char checksum[], int *size)
Fetches the next frames on Channel from the receiver queue. More...
int BL_DLLIMPORT | BLCns_getNextFrameTimeout (BL_HANDLE handle, unsigned long *chId, unsigned long *timestamp, long *intime, unsigned long *frameId, unsigned char *lenOfData, unsigned char *frameData, short *frameFlags, short *busFlags, unsigned char *checksum, int timeout_ms)
Fetches the next frame on Channel from the receiver queue with wait-timeout. More...
int BL_DLLIMPORT | BLCns_getNextFramesTimeout (BL_HANDLE handle, unsigned long chId[], unsigned long timestamp[], long intime[], unsigned long frameId[], unsigned char lenOfData[], unsigned char frameData[], short frameFlags[], short busFlags[], unsigned char checksum[], int timeout_ms, int *size)
Fetches the next frames on Channel from the receiver queue with wait-timeout. More...
int BL_DLLIMPORT | BLCns_getNextJumboFrame (BL_HANDLE handle, unsigned long *chId, unsigned long *timestamp, long *intime, unsigned long *frameId, unsigned int *lenOfData, unsigned char *frameData, short *frameFlags, short *busFlags, unsigned char *checksum)
Fetches the next jumbp frame on Channel from the receiver queue. More...
int BL_DLLIMPORT | BLCns_getNextJumboFrames (BL_HANDLE handle, unsigned long chId[], unsigned long timestamp[], long intime[], unsigned long frameId[], unsigned int lenOfData[], unsigned char frameData[], short frameFlags[], short busFlags[], unsigned char checksum[], int *size)
Fetches the next jumbo frames on Channel from the receiver queue. More...
int BL_DLLIMPORT | BLCns_getNextJumboFrameTimeout (BL_HANDLE handle, unsigned long *chId, unsigned long *timestamp, long *intime, unsigned long *frameId, unsigned int *lenOfData, unsigned char *frameData, short *frameFlags, short *busFlags, unsigned char *checksum, int timeout_ms)
Fetches the next jumbo frame on Channel from the receiver queue with wait-timeout. More...
int BL_DLLIMPORT | BLCns_getNextJumboFramesTimeout (BL_HANDLE handle, unsigned long chId[], unsigned long timestamp[], long intime[], unsigned long frameId[], unsigned int lenOfData[], unsigned char frameData[], short frameFlags[], short busFlags[], unsigned char checksum[], int timeout_ms, int *size)
Fetches the next jumbo frames on Channel from the receiver queue with wait-timeout. More...
int BL_DLLIMPORT | BLCns_getNextSignal (BL_HANDLE handle, int *index, int *isArray, unsigned long long *value, int *arrayLength, unsigned char *array, unsigned long *timestamp, unsigned short *chId)
Fetches the next signal from the receiver queue. More...
int BL_DLLIMPORT | BLCns_getNextSignals (BL_HANDLE handle, int index[], int isArray[], unsigned long long value[], int arrayLength[], unsigned char array[], unsigned long timestamp[], unsigned short chId[], int *size)
Fetches the next signals from the receiver queue. More...
int BL_DLLIMPORT | BLCns_getNextSignalsForNumber (BL_HANDLE handle, int index[], int isArray[], unsigned long long value[], int arrayLength[], unsigned char array[], unsigned long timestamp[], unsigned short chId[], int size, int signalNumber)
Fetches the next signals for a signal number from the receiver queue. More...
int BL_DLLIMPORT | BLCns_getNextBusError (BL_HANDLE handle, unsigned long *timestamp, unsigned short *type, unsigned short *status)
Fetches the next Bus error from the receiver queue. More...
int BL_DLLIMPORT | BLCns_getNextDTLRequest (BL_HANDLE handle, BL_DTL_STATUS *status, unsigned char *nad, int *length, unsigned char *data)
Fetches the next complete DTL request from the receiver queue. More...
int BL_DLLIMPORT | BLCns_getNextDTLResponse (BL_HANDLE handle, BL_DTL_STATUS *status, unsigned char *nad, int *length, unsigned char *data)
Fetches the next complete DTL response from the receiver queue. More...
int BL_DLLIMPORT | BLCns_getSDFInfo (BL_HANDLE handle, char *filename, short *sectionCount, short *version_major, short *version_minor)
Retrieve further Information about a loaded SDF. More...
int BL_DLLIMPORT | BLCns_getSectionInfo (BL_HANDLE handle, int infoAboutSectionNr, char *name, int *type, short *nr)
Retrieve informations about a SDF-Section from a loaded SDF. More...

Function Documentation

int BL_DLLIMPORT BLCns_getChannelInfo | ( | BL_HANDLE | handle,
 |  | unsigned short * | id,
 |  | unsigned short * | type,
 |  | char * | name,
 |  | int | nameLength,
 |  | long * | maxbaudrate,
 |  | long * | reserved1,
 |  | long * | reserved2,
 |  | long * | reserved3,
 |  | int * | associatedWithSectionNr
 | ) |  |
Attention
This function is required by certain BabyLIN Wrappers.
It is strongly recommended, that it is not used in C/C++ applications.
Parameters
handle | Channel-handle representing the Channel. (see BLC_getChannelHandle)
id | The channel id.
type | The channel type as described in BLC_CHANNELINFO.
name | The channel name, has to be preallocated.
nameLength | The size of the name array.
maxbaudrate | The maximal baud-rate as described in BLC_CHANNELINFO.
reserved1 | Reserved for future use.
reserved2 | Reserved for future use.
reserved3 | Reserved for future use.
associatedWithSectionNr | The index of the section as described in BLC_CHANNELINFO.
Returns
Status of operation; '=0' means successful, '!=0' otherwise. See standard return values for error, or for textual representation (for return values < -1000) BLC_getLastError.
int BL_DLLIMPORT BLCns_getLastFrame | ( | BL_HANDLE | handle,
 |  | int | frameNr,
 |  | unsigned long * | chId,
 |  | unsigned long * | timestamp,
 |  | long * | intime,
 |  | unsigned long * | frameId,
 |  | unsigned char * | lenOfData,
 |  | unsigned char * | frameData,
 |  | short * | frameFlags,
 |  | short * | busFlags,
 |  | unsigned char * | checksum
 | ) |  |
Attention
This function is required by certain BabyLIN Wrappers.
It is strongly recommended, that it is not used in C/C++ applications.
The Baby-LIN fills the receiver queue only if command "disframe" or "mon_on" is sent before ( see BabyLIN commands to use in BL_- and BLC_sendCommand Functions )
Parameters
handle | Is the Handle representing the channel to get the frame data from (see BLC_getChannelHandle )
frameNr | Zero based index of requested frame entry.
chId | The channel id, the frame came in at.
timestamp | The timestamp given the frame from the device as described in the BLC_FRAME struct.
intime | The PC time when the frame came in as described in the BLC_FRAME struct.
frameId | The frame id as described in the BLC_FRAME struct.
lenOfData | The length of the frame data array.
frameData | Pointer to a preallocated array to be filled with the frames data.
frameFlags | The frame flags as described in the BLC_FRAME struct.
busFlags | The bus specific flags as described in the BLC_FRAME struct.
checksum | Only valid for LIN channels the frames checksum byte.
Returns
Status of operation; '=0' means successful, '!=0' otherwise. See standard return values for error, or for textual representation (for return values < -1000) BLC_getLastError.
int BL_DLLIMPORT BLCns_getNextBusError | ( | BL_HANDLE | handle,
 |  | unsigned long * | timestamp,
 |  | unsigned short * | type,
 |  | unsigned short * | status
 | ) |  |
Attention
This function is required by certain BabyLIN Wrappers.
It is strongly recommended, that it is not used in C/C++ applications.
Parameters
handle | Handle representing the channel to get the error data from (see BLC_getChannelHandle )
timestamp | The timestamp when the error was recorded by the device.
type | The error type.
status | The error status.
Returns
Status of operation; '=0' means successful, '!=0' otherwise. See standard return values for error, or for textual representation (for return values < -1000) BLC_getLastError.
int BL_DLLIMPORT BLCns_getNextDTLRequest | ( | BL_HANDLE | handle,
 |  | BL_DTL_STATUS * | status,
 |  | unsigned char * | nad,
 |  | int * | length,
 |  | unsigned char * | data
 | ) |  |
Attention
This function is required by certain BabyLIN Wrappers.
It is strongly recommended, that it is not used in C/C++ applications.
Parameters
handle | Handle representing the channel to get the DTL data from (see BLC_getChannelHandle )
status | The DTL status.
nad | The NAD of that DTL request.
length | The length of the DTL data, has to hold the length of the preallocated data buffer.
data | The DTL data, has to be preallocated.
Returns
Status of operation; '=0' means successful, '!=0' otherwise. See standard return values for error, or for textual representation (for return values < -1000) BLC_getLastError.
int BL_DLLIMPORT BLCns_getNextDTLResponse | ( | BL_HANDLE | handle,
 |  | BL_DTL_STATUS * | status,
 |  | unsigned char * | nad,
 |  | int * | length,
 |  | unsigned char * | data
 | ) |  |
Attention
This function is required by certain BabyLIN Wrappers.
It is strongly recommended, that it is not used in C/C++ applications.
Parameters
handle | Handle representing the channel to get the DTL data from (see BLC_getChannelHandle )
status | The DTL status.
nad | The NAD of that DTL response.
length | The length of the DTL data, has to hold the length of the preallocated data buffer.
data | The DTL data, has to be preallocated.
Returns
Status of operation; '=0' means successful, '!=0' otherwise. See standard return values for error, or for textual representation (for return values < -1000) BLC_getLastError.
int BL_DLLIMPORT BLCns_getNextFrame | ( | BL_HANDLE | handle,
 |  | unsigned long * | chId,
 |  | unsigned long * | timestamp,
 |  | long * | intime,
 |  | unsigned long * | frameId,
 |  | unsigned char * | lenOfData,
 |  | unsigned char * | frameData,
 |  | short * | frameFlags,
 |  | short * | busFlags,
 |  | unsigned char * | checksum
 | ) |  |
Attention
This function is required by certain BabyLIN Wrappers.
It is strongly recommended, that it is not used in C/C++ applications.
The Device fills the receiver queue only if command "disframe" or "mon_on" is sent before.
Parameters
handle | Handle representing the channel to get the frame data from (see BLC_getChannelHandle )
chId | The channel id, the frame came in at.
timestamp | The timestamp given the frame from the device as described in the BLC_FRAME struct.
intime | The PC time when the frame came in as described in the BLC_FRAME struct.
frameId | The frame id as described in the BLC_FRAME struct.
lenOfData | The length of the frame data array.
frameData | Pointer to a preallocated array to be filled witht he frame data.
frameFlags | The frame flags as described in the BLC_FRAME struct.
busFlags | The bus specific flags as described in the BLC_FRAME struct.
checksum | Only valid for LIN channels the frames checksum byte.
Returns
Status of operation; '=0' means successful, '!=0' otherwise. See standard return values for error, or for textual representation (for return values < -1000) BLC_getLastError.
int BL_DLLIMPORT BLCns_getNextFrames | ( | BL_HANDLE | handle,
 |  | unsigned long | chId[],
 |  | unsigned long | timestamp[],
 |  | long | intime[],
 |  | unsigned long | frameId[],
 |  | unsigned char | lenOfData[],
 |  | unsigned char | frameData[],
 |  | short | frameFlags[],
 |  | short | busFlags[],
 |  | unsigned char | checksum[],
 |  | int * | size
 | ) |  |
Attention
This function is required by certain BabyLIN Wrappers.
It is strongly recommended, that it is not used in C/C++ applications.
The Device fills the receiver queue only if command "disframe" or "mon_on" is sent before.
Parameters
handle | Handle representing the channel to get the frame data from (see BLC_getChannelHandle )
chId | Array of channel identifiers for the corresponding fetched frames.
timestamp | Array of timestamps for the corresponding fetched frames.
intime | Array of arrival timestamps for the corresponding fetched frames.
frameId | Array of frame identifiers for the corresponding fetched frames.
lenOfData | Array of data lengths for the data of of the corresponding fetched frames.
frameData | Array of frame data arrays for the corresponding fetched frames.
frameFlags | Array of frame flags for the corresponding fetched frames.
busFlags | Array of bus flags for the corresponding fetched frames.
checksum | Array of checksums for the corresponding fetched frames.
size | Input/Output parameter. On input, number of BLC_FRAMEs to be fetched, which must be a positive value.
Returns
The actual number of retrieved BLC_FRAMEs, which might be less than *size on input. Status of operation; '=0' means successful, '!=0' otherwise. See standard return values for error, or for textual representation (for return values < -1000) BLC_getLastError.
int BL_DLLIMPORT BLCns_getNextFramesTimeout | ( | BL_HANDLE | handle,
 |  | unsigned long | chId[],
 |  | unsigned long | timestamp[],
 |  | long | intime[],
 |  | unsigned long | frameId[],
 |  | unsigned char | lenOfData[],
 |  | unsigned char | frameData[],
 |  | short | frameFlags[],
 |  | short | busFlags[],
 |  | unsigned char | checksum[],
 |  | int | timeout_ms,
 |  | int * | size
 | ) |  |
Attention
This function is required by certain BabyLIN Wrappers.
It is strongly recommended, that it is not used in C/C++ applications.
The Device fills the receiver queue only if command "disframe" or "mon_on" is sent before.

Retrieves the next frame received from the BabyLIN. If no frame-data is available, the function will wait up to timeout_ms milliseconds before new data before it returns with a BL_TIMEOUT return code.

Parameters
handle | Handle representing the channel to get the frame data from (see BLC_getChannelHandle )
chId | Array of channel identifiers for the corresponding fetched frames.
timestamp | Array of timestamps for the corresponding fetched frames.
intime | Array of arrival timestamps for the corresponding fetched frames.
frameId | Array of frame identifiers for the corresponding fetched frames.
lenOfData | Array of data lengths for the data of of the corresponding fetched frames.
frameData | Array of frame data arrays for the corresponding fetched frames.
frameFlags | Array of frame flags for the corresponding fetched frames.
busFlags | Array of bus flags for the corresponding fetched frames.
checksum | Array of checksums for the corresponding fetched frames.
timeout_ms | Timeout to wait for new framedata
size | Input/Output parameter. On input, number of BLC_FRAMEs to be fetched, which must be a positive value. On output, the actual number of retrieved BLC_FRAMEs, which might be less than *size on input.
Returns
Status of operation; '=0' means successful, '!=0' otherwise. See standard return values for error, or for textual representation (for return values < -1000) BLC_getLastError.
int BL_DLLIMPORT BLCns_getNextFrameTimeout | ( | BL_HANDLE | handle,
 |  | unsigned long * | chId,
 |  | unsigned long * | timestamp,
 |  | long * | intime,
 |  | unsigned long * | frameId,
 |  | unsigned char * | lenOfData,
 |  | unsigned char * | frameData,
 |  | short * | frameFlags,
 |  | short * | busFlags,
 |  | unsigned char * | checksum,
 |  | int | timeout_ms
 | ) |  |
Attention
This function is required by certain BabyLIN Wrappers.
It is strongly recommended, that it is not used in C/C++ applications.
The Device fills the receiver queue only if command "disframe" or "mon_on" is sent before.

Retrieves the next frame received from the BabyLIN. If no frame-data is available, the function will wait up to timeout_ms milliseconds for new data before it returns with a BL_TIMEOUT return code.

Parameters
handle | Handle representing the channel to get the frame data from (see BLC_getChannelHandle )
chId | The channel id, the frame came in at.
timestamp | The timestamp given the frame from the device as described in the BLC_FRAME struct.
intime | The PC time when the frame came in as described in the BLC_FRAME struct.
frameId | The frame id as described in the BLC_FRAME struct.
lenOfData | The length of the frame data array.
frameData | Pointer to a preallocated array that will be filled with the frame data.
frameFlags | The frame flags as described in the BLC_FRAME struct.
busFlags | The bus specific flags as described in the BLC_FRAME struct.
checksum | only valid for LIN channels the frames checksum byte.
timeout_ms | Timeout to wait for new framedata.
Returns
Status of operation; '=0' means successful, '!=0' otherwise. See standard return values for error, or for textual representation (for return values < -1000) BLC_getLastError.
int BL_DLLIMPORT BLCns_getNextJumboFrame | ( | BL_HANDLE | handle,
 |  | unsigned long * | chId,
 |  | unsigned long * | timestamp,
 |  | long * | intime,
 |  | unsigned long * | frameId,
 |  | unsigned int * | lenOfData,
 |  | unsigned char * | frameData,
 |  | short * | frameFlags,
 |  | short * | busFlags,
 |  | unsigned char * | checksum
 | ) |  |
Attention
This function is required by certain BabyLIN Wrappers.
It is strongly recommended, that it is not used in C/C++ applications.
The Device fills the receiver queue only if command "disframe" or "mon_on" is sent before.
Parameters
handle | Handle representing the channel to get the frame data from (see BLC_getChannelHandle )
chId | The channel id, the frame came in at.
timestamp | The timestamp given the frame from the device as described in the BLC_FRAME struct.
intime | The PC time when the frame came in as described in the BLC_JUMBO_FRAME struct.
frameId | The frame id as described in the BLC_JUMBO_FRAME struct.
lenOfData | The length of the frame data array.
frameData | Pointer to a preallocated array to be filled witht he frame data.
frameFlags | The frame flags as described in the BLC_JUMBO_FRAME struct.
busFlags | The bus specific flags as described in the BLC_JUMBO_FRAME struct.
checksum | Only valid for LIN channels the frames checksum byte.
Returns
Status of operation; '=0' means successful, '!=0' otherwise. See standard return values for error, or for textual representation (for return values < -1000) BLC_getLastError.
int BL_DLLIMPORT BLCns_getNextJumboFrames | ( | BL_HANDLE | handle,
 |  | unsigned long | chId[],
 |  | unsigned long | timestamp[],
 |  | long | intime[],
 |  | unsigned long | frameId[],
 |  | unsigned int | lenOfData[],
 |  | unsigned char | frameData[],
 |  | short | frameFlags[],
 |  | short | busFlags[],
 |  | unsigned char | checksum[],
 |  | int * | size
 | ) |  |
Attention
This function is required by certain BabyLIN Wrappers.
It is strongly recommended, that it is not used in C/C++ applications.
The Device fills the receiver queue only if command "disframe" or "mon_on" is sent before.
Parameters
handle | Handle representing the channel to get the frame data from (see BLC_getChannelHandle )
chId | Array of channel identifiers for the corresponding fetched frames.
timestamp | Array of timestamps for the corresponding fetched frames.
intime | Array of arrival timestamps for the corresponding fetched frames.
frameId | Array of frame identifiers for the corresponding fetched frames.
lenOfData | Array of data lengths for the data of of the corresponding fetched frames.
frameData | Array of frame data arrays for the corresponding fetched frames.
frameFlags | Array of frame flags for the corresponding fetched frames.
busFlags | Array of bus flags for the corresponding fetched frames.
checksum | Array of checksums for the corresponding fetched frames.
size | Input/Output parameter. On input, number of BLC_JUMBO_FRAME to be fetched, which must be a positive value.
Returns
The actual number of retrieved BLC_JUMBO_FRAMEs, which might be less than *size on input. Status of operation; '=0' means successful, '!=0' otherwise. See standard return values for error, or for textual representation (for return values < -1000) BLC_getLastError.
int BL_DLLIMPORT BLCns_getNextJumboFramesTimeout | ( | BL_HANDLE | handle,
 |  | unsigned long | chId[],
 |  | unsigned long | timestamp[],
 |  | long | intime[],
 |  | unsigned long | frameId[],
 |  | unsigned int | lenOfData[],
 |  | unsigned char | frameData[],
 |  | short | frameFlags[],
 |  | short | busFlags[],
 |  | unsigned char | checksum[],
 |  | int | timeout_ms,
 |  | int * | size
 | ) |  |
Attention
This function is required by certain BabyLIN Wrappers.
It is strongly recommended, that it is not used in C/C++ applications.
The Device fills the receiver queue only if command "disframe" or "mon_on" is sent before.

Retrieves the next frame received from the BabyLIN. If no frame-data is available, the function will wait up to timeout_ms milliseconds before new data before it returns with a BL_TIMEOUT return code.

Parameters
handle | Handle representing the channel to get the frame data from (see BLC_getChannelHandle )
chId | Array of channel identifiers for the corresponding fetched frames.
timestamp | Array of timestamps for the corresponding fetched frames.
intime | Array of arrival timestamps for the corresponding fetched frames.
frameId | Array of frame identifiers for the corresponding fetched frames.
lenOfData | Array of data lengths for the data of of the corresponding fetched frames.
frameData | Array of frame data arrays for the corresponding fetched frames.
frameFlags | Array of frame flags for the corresponding fetched frames.
busFlags | Array of bus flags for the corresponding fetched frames.
checksum | Array of checksums for the corresponding fetched frames.
timeout_ms | Timeout to wait for new framedata
size | Input/Output parameter. On input, number of BLC_JUMBO_FRAMEs to be fetched, which must be a positive value. On output, the actual number of retrieved BLC_JUMBO_FRAMEEs, which might be less than *size on input.
Returns
Status of operation; '=0' means successful, '!=0' otherwise. See standard return values for error, or for textual representation (for return values < -1000) BLC_getLastError.
int BL_DLLIMPORT BLCns_getNextJumboFrameTimeout | ( | BL_HANDLE | handle,
 |  | unsigned long * | chId,
 |  | unsigned long * | timestamp,
 |  | long * | intime,
 |  | unsigned long * | frameId,
 |  | unsigned int * | lenOfData,
 |  | unsigned char * | frameData,
 |  | short * | frameFlags,
 |  | short * | busFlags,
 |  | unsigned char * | checksum,
 |  | int | timeout_ms
 | ) |  |
Attention
This function is required by certain BabyLIN Wrappers.
It is strongly recommended, that it is not used in C/C++ applications.
The Device fills the receiver queue only if command "disframe" or "mon_on" is sent before.

Retrieves the next jumbo frame received from the BabyLIN. If no frame-data is available, the function will wait up to timeout_ms milliseconds for new data before it returns with a BL_TIMEOUT return code.

Parameters
handle | Handle representing the channel to get the frame data from (see BLC_getChannelHandle )
chId | The channel id, the frame came in at.
timestamp | The timestamp given the frame from the device as described in the BLC_FRAME struct.
intime | The PC time when the frame came in as described in the BLC_JUMBO_FRAME struct.
frameId | The frame id as described in the BLC_JUMBO_FRAME struct.
lenOfData | The length of the frame data array.
frameData | Pointer to a preallocated array that will be filled with the frame data.
frameFlags | The frame flags as described in the BLC_JUMBO_FRAME struct.
busFlags | The bus specific flags as described in the BLC_JUMBO_FRAME struct.
checksum | Only valid for LIN channels the frames checksum byte.
timeout_ms | Timeout to wait for new framedata.
Returns
Status of operation; '=0' means successful, '!=0' otherwise. See standard return values for error, or for textual representation (for return values < -1000) BLC_getLastError.
int BL_DLLIMPORT BLCns_getNextSignal | ( | BL_HANDLE | handle,
 |  | int * | index,
 |  | int * | isArray,
 |  | unsigned long long * | value,
 |  | int * | arrayLength,
 |  | unsigned char * | array,
 |  | unsigned long * | timestamp,
 |  | unsigned short * | chId
 | ) |  |
Attention
This function is required by certain BabyLIN Wrappers.
It is strongly recommended, that it is not used in C/C++ applications.
The Baby-LIN fills the receiver queue only if command "dissignal" sent before.
Parameters
handle | Handle representing the channel to get the signal data from (see BLC_getChannelHandle )
index | The signal number of the received signal.
isArray | != 0 if the signal is marked as array signal.
value | The signal value for non array signals only.
arrayLength | The length of the given array and the amount of bytes copied into it.
array | The signal data of array signals.
timestamp | The timestamp given the signal report by the device.
chId | The id of the channel that did report the signal value.
Returns
Status of operation; '=0' means successful, '!=0' otherwise. See standard return values for error, or for textual representation (for return values < -1000) BLC_getLastError.
int BL_DLLIMPORT BLCns_getNextSignals | ( | BL_HANDLE | handle,
 |  | int | index[],
 |  | int | isArray[],
 |  | unsigned long long | value[],
 |  | int | arrayLength[],
 |  | unsigned char | array[],
 |  | unsigned long | timestamp[],
 |  | unsigned short | chId[],
 |  | int * | size
 | ) |  |
Attention
This function is required by certain BabyLIN Wrappers.
It is strongly recommended, that it is not used in C/C++ applications.
The Baby-LIN fills the receiver queue only if command "dissignal" sent before.
Parameters
handle | Handle representing the channel to get the signal data from (see BLC_getChannelHandle )
index | Output parameter: array of indices of the corresponding retrieved signals.
isArray | Output parameter: array of boolean values, indicating if the corresponding retrieved signal is an array.
value | Output parameter: array of signal values for the corresponding retrieved signals.
arrayLength | Output parameter: array of array lengths for the data arrays contained in the retrieved signals.
array | Output parameter: array of 8*(*size) bytes, containing for each retrieved signal an 8-byte data array if the resp. array length is greater 0.
timestamp | Output parameter: array of timestamps for the corresponding retrieved signals.
chId | Output parameter: array of channel identifiers for the corresponding retreived signals.
size | Input/Output parameter. On input, number of BLC_SIGNAL to be fetched, which must be a positive value. On output, the actual number of retrieved BLC_SIGNALs, which might be less than *size on input.
Returns
Status of operation; '=0' means successful, '!=0' otherwise. See standard return values for error, or for textual representation (for return values < -1000) BLC_getLastError.
int BL_DLLIMPORT BLCns_getNextSignalsForNumber | ( | BL_HANDLE | handle,
 |  | int | index[],
 |  | int | isArray[],
 |  | unsigned long long | value[],
 |  | int | arrayLength[],
 |  | unsigned char | array[],
 |  | unsigned long | timestamp[],
 |  | unsigned short | chId[],
 |  | int | size,
 |  | int | signalNumber
 | ) |  |
Attention
This function is required by certain BabyLIN Wrappers.
It is strongly recommended, that it is not used in C/C++ applications.
The Baby-LIN fills the receiver queue only if command "dissignal" sent before.
Parameters
handle | Handle representing the channel to get the signal data from (see BLC_getChannelHandle )
index | Output parameter: array of indices of the corresponding retrieved signals.
isArray | Output parameter: array of boolean values, indicating if the corresponding retrieved signal is an array.
value | Output parameter: array of signal values for the corresponding retrieved signals.
arrayLength | Output parameter: array of array lengths for the data arrays contained in the retrieved signals.
array | Output parameter: array of 8*(*size) bytes, containing for each retrieved signal an 8-byte data array if the resp. array length is greater 0.
timestamp | Output parameter: array of timestamps for the corresponding retrieved signals.
chId | Output parameter: array of channel identifiers for the corresponding retrieved signals.
size | Input/Output parameter. On input, number of BLC_SIGNAL to be fetched, which must be a positive value. On output, the actual number of retrieved BLC_SIGNALs, which might be less than *size on input.
signalNumber | The signal number to return signals for
Returns
Status of operation; '=0' means successful, '!=0' otherwise. See standard return values for error, or for textual representation (for return values < -1000) BLC_getLastError.
int BL_DLLIMPORT BLCns_getSDFInfo | ( | BL_HANDLE | handle,
 |  | char * | filename,
 |  | short * | sectionCount,
 |  | short * | version_major,
 |  | short * | version_minor
 | ) |  |
Attention
This function is required by certain BabyLIN Wrappers.
It is strongly recommended, that it is not used in C/C++ applications.

Need a loaded SDF (see BLC_loadSDF or BLC_loadLDF )

Parameters
handle | Handle to a valid connection
filename | The loaded SDFs file name.
sectionCount | The amount of sections in that SDF.
version_major | The SDFs major version.
version_minor | The SDFs minor version.
Returns
Status of operation; '=0' means successful, '!=0' otherwise. See standard return values for error, or for textual representation (for return values < -1000) BLC_getLastError.
int BL_DLLIMPORT BLCns_getSectionInfo | ( | BL_HANDLE | handle,
 |  | int | infoAboutSectionNr,
 |  | char * | name,
 |  | int * | type,
 |  | short * | nr
 | ) |  |
Attention
This function is required by certain BabyLIN Wrappers.
It is strongly recommended, that it is not used in C/C++ applications.
Parameters
handle | handle of a valid connection
infoAboutSectionNr | The section number to retrieve information of. Ranges from 0 to the number of sections in the loaded SDF (see BLC_getSDFInfo and BLC_SDFINFO::sectionCount )
name | The sections name.
type | The section type e.g. LIN.
nr | The section number.
Returns
Status of operation; '=0' means successful, '!=0' otherwise. See standard return values for error, or for textual representation (for return values < -1000) BLC_getLastError.
int BL_DLLIMPORT BLCns_getTargetID | ( | BL_HANDLE | handle,
 |  | unsigned short * | type,
 |  | unsigned short * | version,
 |  | unsigned short * | flags,
 |  | long * | serial,
 |  | long * | heapsize,
 |  | long * | numofchannels,
 |  | char * | name,
 |  | int | nameLength
 | ) |  |
Attention
This function is required by certain BabyLIN Wrappers.
It is strongly recommended, that it is not used in C/C++ applications.
Parameters
handle | Handle representing the connection (see BLC_open )
type | The target type refer to BLC_TARGETID for value description.
version | The firmware version of the device.
flags | The flags as described in BLC_TARGETID.
serial | Devices serial number.
heapsize | The devices heap size.
numofchannels | The number of channels as described in BLC_TARGETID.
name | The product name, has to be preallocated.
nameLength | Length of the product name array.
Returns
Status of operation; '=0' means successful, '!=0' otherwise. See standard return values for error, or for textual representation (for return values < -1000) BLC_getLastError.
int BL_DLLIMPORT BLCns_getVersionString | ( | char * | buffer,
 |  | int | bufferlen
 | ) |  |
Attention
This function is required by certain BabyLIN Wrappers.
It is strongly recommended, that it is not used in C/C++ applications.

This function returns the version string of the library.

Parameters
buffer | A preallocated buffer to store the version string in.
bufferlen | The length of the preallocated buffer.
Returns
Returns a C-string with the version information.
BL_HANDLE BL_DLLIMPORT BLCns_openPort | ( | int | portNr,
 |  | int | type,
 |  | char * | name,
 |  | char * | device
 | ) |  |
Attention
This function is required by certain BabyLIN Wrappers.
It is strongly recommended, that it is not used in C/C++ applications.

This function tries to open the BabyLIN device of the BLC_PORTINFO information, i.e. works as a wrapper for BLC_open and BLC_openNet which automatically decides which connection to establish.

Note
Platform independent way of connecting to BabyLIN-devices found by BLC_getBabyLinPorts or BLC_getBabyLinPortsTimout.
the BLC_PORTINFO-structure of the BabyLIN to connect to ( see BLC_getBabyLinPorts ) is divided in its members here.
Parameters
portNr | The Comport number on Windows for serial devices or the TCP port for network devices.
type | The type of the connection to establish refer to BLC_PORTINFO 's type field for value descriptions.
name | A 256 character array. name is not yet used and has to have a '\0' as first character.
device | A 256 character array. device is the path to the serial connection under Linux (e.g. /dev/ttyUSB0) or the TCP IP address of the device to connect to.
Returns
Returns an handle for the BabyLIN-connection or NULL if the connection could not be established. You may fetch the corresponding (textual) error with BLC_getLastError.
BL_HANDLE BL_DLLIMPORT BLCns_openURL ( char * url )
Attention
This function is required by certain BabyLIN Wrappers.
It is strongly recommended, that it is not used in C/C++ applications.

This function tries to open the BabyLIN device specified by the BLC_PORTINFO derived from the given URL.

Parameters
url The device URL to convert might be a system path (/dev/ttyUSB1) for Unix based systems, a comport (COM1) as is used for windows or a network address (tcp://127.0.0.1:2048) to connect to a network device.
Returns
Returns an handle for the BabyLIN-connection or NULL if the connection could not be established or the given URL is malformed. You may fetch the corresponding (textual) error with BLC_getLastError.
Generated on Fri May 30 2025 17:16:13 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: C:/JenkinsWS/workspace/orks_v2_LinWorksv2_Windows_trunk/source/externals/BabyLIN/src/libraries/BabyLIN/publicHeaders/BabyLINCAN_nostruct.h Source File

  • externals
  • BabyLIN
  • src
  • libraries
  • BabyLIN
  • publicHeaders
BabyLINCAN_nostruct.h
Go to the documentation of this file.
1 #ifndef BABYLINCAN_NOSTRUCT_H
2 #define BABYLINCAN_NOSTRUCT_H
3
4 #include "BabyLINCAN.h"
5
6 #if defined(__cplusplus)
7 #include <cstddef> // get "size_t", used by function BL_encodeSignal())
8 #include <cstdint>
9 extern "C" {
10 #else
11 #include <stddef.h> // get "size_t", used by function BL_encodeSignal())
12 #include <stdint.h>
13 #endif
14
42 BL_HANDLE BL_DLLIMPORT BLCns_openPort(int portNr, int type, char* name, char* device);
43
60 BL_HANDLE BL_DLLIMPORT BLCns_openURL(char* url);
61
81 int BL_DLLIMPORT BLCns_getTargetID(BL_HANDLE handle,
82 unsigned short* type,
83 unsigned short* version,
84 unsigned short* flags,
85 long* serial,
86 long* heapsize,
87 long* numofchannels,
88 char* name,
89 int nameLength);
90
110 int BL_DLLIMPORT BLCns_getChannelInfo(BL_HANDLE handle,
111 unsigned short* id,
112 unsigned short* type,
113 char* name,
114 int nameLength,
115 long* maxbaudrate,
116 long* reserved1,
117 long* reserved2,
118 long* reserved3,
119 int* associatedWithSectionNr);
120
132 int BL_DLLIMPORT BLCns_getVersionString(char* buffer, int bufferlen);
133
158 int BL_DLLIMPORT BLCns_getLastFrame(BL_HANDLE handle,
159 int frameNr,
160 unsigned long* chId,
161 unsigned long* timestamp,
162 long* intime,
163 unsigned long* frameId,
164 unsigned char* lenOfData,
165 unsigned char* frameData,
166 short* frameFlags,
167 short* busFlags,
168 unsigned char* checksum);
169
194 int BL_DLLIMPORT BLCns_getNextFrame(BL_HANDLE handle,
195 unsigned long* chId,
196 unsigned long* timestamp,
197 long* intime,
198 unsigned long* frameId,
199 unsigned char* lenOfData,
200 unsigned char* frameData,
201 short* frameFlags,
202 short* busFlags,
203 unsigned char* checksum);
204
230 int BL_DLLIMPORT BLCns_getNextFrames(BL_HANDLE handle,
231 unsigned long chId[],
232 unsigned long timestamp[],
233 long intime[],
234 unsigned long frameId[],
235 unsigned char lenOfData[],
236 unsigned char frameData[],
237 short frameFlags[],
238 short busFlags[],
239 unsigned char checksum[],
240 int* size);
241
271 int BL_DLLIMPORT BLCns_getNextFrameTimeout(BL_HANDLE handle,
272 unsigned long* chId,
273 unsigned long* timestamp,
274 long* intime,
275 unsigned long* frameId,
276 unsigned char* lenOfData,
277 unsigned char* frameData,
278 short* frameFlags,
279 short* busFlags,
280 unsigned char* checksum,
281 int timeout_ms);
282
313 int BL_DLLIMPORT BLCns_getNextFramesTimeout(BL_HANDLE handle,
314 unsigned long chId[],
315 unsigned long timestamp[],
316 long intime[],
317 unsigned long frameId[],
318 unsigned char lenOfData[],
319 unsigned char frameData[],
320 short frameFlags[],
321 short busFlags[],
322 unsigned char checksum[],
323 int timeout_ms,
324 int* size);
325
351 int BL_DLLIMPORT BLCns_getNextJumboFrame(BL_HANDLE handle,
352 unsigned long* chId,
353 unsigned long* timestamp,
354 long* intime,
355 unsigned long* frameId,
356 unsigned int* lenOfData,
357 unsigned char* frameData,
358 short* frameFlags,
359 short* busFlags,
360 unsigned char* checksum);
361
387 int BL_DLLIMPORT BLCns_getNextJumboFrames(BL_HANDLE handle,
388 unsigned long chId[],
389 unsigned long timestamp[],
390 long intime[],
391 unsigned long frameId[],
392 unsigned int lenOfData[],
393 unsigned char frameData[],
394 short frameFlags[],
395 short busFlags[],
396 unsigned char checksum[],
397 int* size);
398
429 int BL_DLLIMPORT BLCns_getNextJumboFrameTimeout(BL_HANDLE handle,
430 unsigned long* chId,
431 unsigned long* timestamp,
432 long* intime,
433 unsigned long* frameId,
434 unsigned int* lenOfData,
435 unsigned char* frameData,
436 short* frameFlags,
437 short* busFlags,
438 unsigned char* checksum,
439 int timeout_ms);
440
472 int BL_DLLIMPORT BLCns_getNextJumboFramesTimeout(BL_HANDLE handle,
473 unsigned long chId[],
474 unsigned long timestamp[],
475 long intime[],
476 unsigned long frameId[],
477 unsigned int lenOfData[],
478 unsigned char frameData[],
479 short frameFlags[],
480 short busFlags[],
481 unsigned char checksum[],
482 int timeout_ms,
483 int* size);
484
504 int BL_DLLIMPORT BLCns_getNextSignal(BL_HANDLE handle,
505 int* index,
506 int* isArray,
507 unsigned long long* value,
508 int* arrayLength,
509 unsigned char* array,
510 unsigned long* timestamp,
511 unsigned short* chId);
512
542 int BL_DLLIMPORT BLCns_getNextSignals(BL_HANDLE handle,
543 int index[],
544 int isArray[],
545 unsigned long long value[],
546 int arrayLength[],
547 unsigned char array[],
548 unsigned long timestamp[],
549 unsigned short chId[],
550 int* size);
551
581 int BL_DLLIMPORT BLCns_getNextSignalsForNumber(BL_HANDLE handle,
582 int index[],
583 int isArray[],
584 unsigned long long value[],
585 int arrayLength[],
586 unsigned char array[],
587 unsigned long timestamp[],
588 unsigned short chId[],
589 int size,
590 int signalNumber);
591
606 int BL_DLLIMPORT BLCns_getNextBusError(BL_HANDLE handle,
607 unsigned long* timestamp,
608 unsigned short* type,
609 unsigned short* status);
610
627 int BL_DLLIMPORT BLCns_getNextDTLRequest(
628 BL_HANDLE handle, BL_DTL_STATUS* status, unsigned char* nad, int* length, unsigned char* data);
629
646 int BL_DLLIMPORT BLCns_getNextDTLResponse(
647 BL_HANDLE handle, BL_DTL_STATUS* status, unsigned char* nad, int* length, unsigned char* data);
648
664 int BL_DLLIMPORT BLCns_getSDFInfo(BL_HANDLE handle,
665 char* filename,
666 short* sectionCount,
667 short* version_major,
668 short* version_minor);
669
686 int BL_DLLIMPORT
687 BLCns_getSectionInfo(BL_HANDLE handle, int infoAboutSectionNr, char* name, int* type, short* nr);
688
689 #if defined(__cplusplus)
690 } // extern "C"
691 #endif
692 #endif // BABYLINCAN_NOSTRUCT_H
BLCns_getSectionInfo
int BL_DLLIMPORT BLCns_getSectionInfo(BL_HANDLE handle, int infoAboutSectionNr, char *name, int *type, short *nr)
Retrieve informations about a SDF-Section from a loaded SDF.
BLCns_getNextSignal
int BL_DLLIMPORT BLCns_getNextSignal(BL_HANDLE handle, int *index, int *isArray, unsigned long long *value, int *arrayLength, unsigned char *array, unsigned long *timestamp, unsigned short *chId)
Fetches the next signal from the receiver queue.
BLCns_getNextFrame
int BL_DLLIMPORT BLCns_getNextFrame(BL_HANDLE handle, unsigned long *chId, unsigned long *timestamp, long *intime, unsigned long *frameId, unsigned char *lenOfData, unsigned char *frameData, short *frameFlags, short *busFlags, unsigned char *checksum)
Fetches the next frame on Channel from the receiver queue.
BLCns_getNextFrames
int BL_DLLIMPORT BLCns_getNextFrames(BL_HANDLE handle, unsigned long chId[], unsigned long timestamp[], long intime[], unsigned long frameId[], unsigned char lenOfData[], unsigned char frameData[], short frameFlags[], short busFlags[], unsigned char checksum[], int *size)
Fetches the next frames on Channel from the receiver queue.
BabyLINCAN.h
BL_DTL_STATUS
BL_DTL_STATUS
DTL protocol status answers. Part of BLC_DTL data structure. Retrieve status of pending DTL actions u...
Definition: BabyLINReturncodes.h:300
BLCns_getNextBusError
int BL_DLLIMPORT BLCns_getNextBusError(BL_HANDLE handle, unsigned long *timestamp, unsigned short *type, unsigned short *status)
Fetches the next Bus error from the receiver queue.
BLCns_openURL
BL_HANDLE BL_DLLIMPORT BLCns_openURL(char *url)
Open a connection to a BabyLIN device using BLC_PORTINFO information.
BLCns_getChannelInfo
int BL_DLLIMPORT BLCns_getChannelInfo(BL_HANDLE handle, unsigned short *id, unsigned short *type, char *name, int nameLength, long *maxbaudrate, long *reserved1, long *reserved2, long *reserved3, int *associatedWithSectionNr)
Retrieve informations about the Channel.
BLCns_getNextJumboFrameTimeout
int BL_DLLIMPORT BLCns_getNextJumboFrameTimeout(BL_HANDLE handle, unsigned long *chId, unsigned long *timestamp, long *intime, unsigned long *frameId, unsigned int *lenOfData, unsigned char *frameData, short *frameFlags, short *busFlags, unsigned char *checksum, int timeout_ms)
Fetches the next jumbo frame on Channel from the receiver queue with wait-timeout.
BL_HANDLE
void * BL_HANDLE
Definition: BabyLINReturncodes.h:34
BLCns_getVersionString
int BL_DLLIMPORT BLCns_getVersionString(char *buffer, int bufferlen)
Get the version string of the library.
BLCns_getSDFInfo
int BL_DLLIMPORT BLCns_getSDFInfo(BL_HANDLE handle, char *filename, short *sectionCount, short *version_major, short *version_minor)
Retrieve further Information about a loaded SDF.
BLCns_getNextSignals
int BL_DLLIMPORT BLCns_getNextSignals(BL_HANDLE handle, int index[], int isArray[], unsigned long long value[], int arrayLength[], unsigned char array[], unsigned long timestamp[], unsigned short chId[], int *size)
Fetches the next signals from the receiver queue.
BLCns_getNextSignalsForNumber
int BL_DLLIMPORT BLCns_getNextSignalsForNumber(BL_HANDLE handle, int index[], int isArray[], unsigned long long value[], int arrayLength[], unsigned char array[], unsigned long timestamp[], unsigned short chId[], int size, int signalNumber)
Fetches the next signals for a signal number from the receiver queue.
BLCns_openPort
BL_HANDLE BL_DLLIMPORT BLCns_openPort(int portNr, int type, char *name, char *device)
Open a connection to a BabyLIN device using BLC_PORTINFO information.
BLCns_getLastFrame
int BL_DLLIMPORT BLCns_getLastFrame(BL_HANDLE handle, int frameNr, unsigned long *chId, unsigned long *timestamp, long *intime, unsigned long *frameId, unsigned char *lenOfData, unsigned char *frameData, short *frameFlags, short *busFlags, unsigned char *checksum)
Retrieve the last framedata available for a frame.
BLCns_getNextDTLRequest
int BL_DLLIMPORT BLCns_getNextDTLRequest(BL_HANDLE handle, BL_DTL_STATUS *status, unsigned char *nad, int *length, unsigned char *data)
Fetches the next complete DTL request from the receiver queue.
BLCns_getNextJumboFrames
int BL_DLLIMPORT BLCns_getNextJumboFrames(BL_HANDLE handle, unsigned long chId[], unsigned long timestamp[], long intime[], unsigned long frameId[], unsigned int lenOfData[], unsigned char frameData[], short frameFlags[], short busFlags[], unsigned char checksum[], int *size)
Fetches the next jumbo frames on Channel from the receiver queue.
BLCns_getNextJumboFramesTimeout
int BL_DLLIMPORT BLCns_getNextJumboFramesTimeout(BL_HANDLE handle, unsigned long chId[], unsigned long timestamp[], long intime[], unsigned long frameId[], unsigned int lenOfData[], unsigned char frameData[], short frameFlags[], short busFlags[], unsigned char checksum[], int timeout_ms, int *size)
Fetches the next jumbo frames on Channel from the receiver queue with wait-timeout.
BL_DLLIMPORT
#define BL_DLLIMPORT
Definition: BabyLINReturncodes.h:9
BLCns_getNextFrameTimeout
int BL_DLLIMPORT BLCns_getNextFrameTimeout(BL_HANDLE handle, unsigned long *chId, unsigned long *timestamp, long *intime, unsigned long *frameId, unsigned char *lenOfData, unsigned char *frameData, short *frameFlags, short *busFlags, unsigned char *checksum, int timeout_ms)
Fetches the next frame on Channel from the receiver queue with wait-timeout.
BLCns_getNextJumboFrame
int BL_DLLIMPORT BLCns_getNextJumboFrame(BL_HANDLE handle, unsigned long *chId, unsigned long *timestamp, long *intime, unsigned long *frameId, unsigned int *lenOfData, unsigned char *frameData, short *frameFlags, short *busFlags, unsigned char *checksum)
Fetches the next jumbp frame on Channel from the receiver queue.
BLCns_getNextDTLResponse
int BL_DLLIMPORT BLCns_getNextDTLResponse(BL_HANDLE handle, BL_DTL_STATUS *status, unsigned char *nad, int *length, unsigned char *data)
Fetches the next complete DTL response from the receiver queue.
BLCns_getTargetID
int BL_DLLIMPORT BLCns_getTargetID(BL_HANDLE handle, unsigned short *type, unsigned short *version, unsigned short *flags, long *serial, long *heapsize, long *numofchannels, char *name, int nameLength)
Requests the information about the target.
BLCns_getNextFramesTimeout
int BL_DLLIMPORT BLCns_getNextFramesTimeout(BL_HANDLE handle, unsigned long chId[], unsigned long timestamp[], long intime[], unsigned long frameId[], unsigned char lenOfData[], unsigned char frameData[], short frameFlags[], short busFlags[], unsigned char checksum[], int timeout_ms, int *size)
Fetches the next frames on Channel from the receiver queue with wait-timeout.
Generated on Fri May 30 2025 17:16:13 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: C:/JenkinsWS/workspace/orks_v2_LinWorksv2_Windows_trunk/source/externals/BabyLIN/src/libraries/BabyLIN/publicHeaders/BabyLINCAN_types.h File Reference

  • externals
  • BabyLIN
  • src
  • libraries
  • BabyLIN
  • publicHeaders
Data Structures | Typedefs | Enumerations
BabyLINCAN_types.h File Reference
#include "BabyLINReturncodes.h"

Go to the source code of this file.

Data Structures

struct | BLC_PORTINFO
Information about a BabyLIN port on the host operating system. More...
struct | BLC_TARGETID
Information about a connected BabyLIN device. More...
struct | BLC_CHANNELINFO
Information about a channel on a BabyLIN device. More...
struct | BLC_SDFINFO
struct | BLC_SECTIONINFO
struct | BLC_FRAME
struct | BLC_JUMBO_FRAME
struct | BLC_MACROSTATE
status of a macro More...
struct | BLC_SIGNAL
struct | BLC_ERROR
struct | BLC_DTL
struct | BLC_EVENT
union | ADHOC_PROTOCOL_FLAGS
struct | BLC_ADHOC_PROTOCOL
union | ADHOC_SERVICE_FLAGS
struct | BLC_ADHOC_SERVICE
struct | BLC_ADHOC_EXECUTE
struct | BLC_LOG

Typedefs

typedef void( | BLC_frame_callback_func )(BL_HANDLE, BLC_FRAME frame)
typedef void( | BLC_jumboframe_callback_func )(BL_HANDLE, BLC_JUMBO_FRAME jumbo_frame)
typedef void( | BLC_signal_callback_func )(BL_HANDLE, BLC_SIGNAL signal)
typedef void( | BLC_macrostate_callback_func )(BL_HANDLE, BLC_MACROSTATE macroState)
typedef void( | BLC_error_callback_func )(BL_HANDLE, BLC_ERROR error)
typedef void( | BLC_debug_callback_func )(BL_HANDLE, const char *text)
typedef void( | BLC_dtl_request_callback_func )(BL_HANDLE, BLC_DTL dtl_request)
typedef void( | BLC_dtl_response_callback_func )(BL_HANDLE, BLC_DTL dtl_response)
typedef void( | BLC_event_callback_func )(BL_HANDLE, BLC_EVENT event)
typedef void( | BLC_frame_callback_func_ptr )(BL_HANDLE, BLC_FRAME frame, void *)
typedef void( | BLC_jumboframe_callback_func_ptr )(BL_HANDLE, BLC_JUMBO_FRAME jumbo_frame, void *)
typedef void( | BLC_signal_callback_func_ptr )(BL_HANDLE, BLC_SIGNAL signal, void *)
typedef void( | BLC_macrostate_callback_func_ptr )(BL_HANDLE, BLC_MACROSTATE macroState, void *)
typedef void( | BLC_error_callback_func_ptr )(BL_HANDLE, BLC_ERROR error, void *)
typedef void( | BLC_debug_callback_func_ptr )(BL_HANDLE, const char *text, void *)
typedef void( | BLC_dtl_request_callback_func_ptr )(BL_HANDLE, BLC_DTL dtl_request, void *)
typedef void( | BLC_dtl_response_callback_func_ptr )(BL_HANDLE, BLC_DTL dtl_response, void *)
typedef void( | BLC_event_callback_func_ptr )(BL_HANDLE, BLC_EVENT event, void *)
typedef void( | BLC_log_callback_func_ptr )(BL_HANDLE, BLC_LOG log, void *)
typedef void( | BLC_lua_print_func_ptr )(const char *msg, void *userdata)

Enumerations

enum ADHOC_PROTOCOL_TYPE {
TYPE_RAW = 0, TYPE_DTL_ISOTP = 1, TYPE_ISOTP_WITHOUT_NAD = 2, TYPE_WEBASTO_UHW2 = 3,
TYPE_WEBASTO_STD = 5, TYPE_KLINE_RAW = 6
}
Type of an ad hoc protocol. More...
Generated on Fri May 30 2025 17:16:13 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: C:/JenkinsWS/workspace/orks_v2_LinWorksv2_Windows_trunk/source/externals/BabyLIN/src/libraries/BabyLIN/publicHeaders/BabyLINCAN_types.h Source File

  • externals
  • BabyLIN
  • src
  • libraries
  • BabyLIN
  • publicHeaders
BabyLINCAN_types.h
Go to the documentation of this file.
1 #ifndef BABYLINCAN_TYPES_H
2 #define BABYLINCAN_TYPES_H
3
4 #include "BabyLINReturncodes.h"
5
20 typedef struct _BLC_PORTINFO {
24 int portNr;
30 int type;
34 char name[256];
38 char device[256];
39 } BLC_PORTINFO;
40
47 typedef struct _BLC_TARGETID {
70 unsigned short type;
71
72 // ! Firmware version of the device
73 unsigned short version;
74
75 // ! Firmware build number
76 unsigned short build;
77
84 unsigned short flags;
85
86 // ! Device's serial number
87 long serial;
88
89 // ! Remaining heap size on device (memory available for SDF dowload)
90 long heapsize;
91
92 // ! number of channels
93 long numofchannels;
94
95 // ! Textual name of the device (zero-terminated C-string)
96 char name[128];
97 } BLC_TARGETID;
98
105 typedef struct _BLC_CHANNELINFO {
107 unsigned short id;
108
110 unsigned short type;
111
113 char name[128];
114
116 long maxbaudrate;
117
136 long reserved1;
137
139 long reserved2;
140
142 long reserved3;
143
146 int associatedWithSectionNr;
147 } BLC_CHANNELINFO;
148
149 // ! Return data of the command @ref BLC_getSDFInfo
150 typedef struct _BLC_SDFINFO {
151 // ! Filename of the loaded sdf
152 char filename[256];
153
154 // ! number of sections in the SDF. A file consists of at least one Section (LIN, CAN or DEVICE)
155 short sectionCount;
156
157 // ! SDF-version
158 short version_major, version_minor;
159 } BLC_SDFINFO;
160
161 // ! Return data of the command @ref BLC_getSectionInfo
162 typedef struct _BLC_SECTIONINFO {
163 // ! Textual name of the Section (zero-terminated C-string) as defined using SessionConf
164 char name[128];
165
166 // ! Channel-Type(i.e. 0 = LIN, 1 = CAN, 99 = DEVICE)
167 int type;
168
169 // ! Number of the section within the SDF ( zero-based index )
170 short nr;
171 } BLC_SECTIONINFO;
172
173 // ! Carries information about one frame, is used as API interface
174 typedef struct _BLC_FRAME {
175 // ! Id of the channel within the device
176 unsigned long chId;
177
178 // ! Global time index of frame transmission start (in us). Received from target, represents the
179 // time since the Target was powered on.
180 unsigned long timestamp;
181
182 // ! Timestamp with pc time, used to calculate age of framedata, to allow timeout functions (ms)
183 long intime;
184
185 // ! FrameID of Frame ( as appeared on the BUS. On LIN BUS without parity bits )
186 unsigned long frameId;
187
188 // ! Length of frameData
189 unsigned char lenOfData;
190
191 // ! Databytes of the frame
192 unsigned char frameData[8];
193
194 // clang-format off
207 // clang-format on
208 short frameFlags;
209
210 // clang-format off
233 // clang-format on
234 short busFlags;
235
239 unsigned char checksum;
240 } BLC_FRAME;
241
242 // ! Carries information about one frame, is used as API interface
243 typedef struct _BLC_JUMBO_FRAME {
244 // ! Id of the channel within the device
245 unsigned long chId;
246
247 // ! Global time index of frame transmission start (in us). Received from target, represents the
248 // time since the Target was powered on.
249 unsigned long timestamp;
250
251 // ! Timestamp with pc time, used to calculate age of framedata, to allow timeout functions (ms)
252 long intime;
253
254 // ! FrameID of Frame ( as appeared on the BUS. On LIN BUS without parity bits )
255 unsigned long frameId;
256
257 // ! Length of frameData
258 unsigned int lenOfData;
259
260 // ! Databytes of the frame
261 unsigned char frameData[1024];
262
263 // clang-format off
277 // clang-format on
278 short frameFlags;
279
280 // clang-format off
303 // clang-format on
304 short busFlags;
305
309 unsigned char checksum;
310 } BLC_JUMBO_FRAME;
311
318 typedef struct _BLC_MACROSTATE {
319 // ! channel number this information belongs to
320 int channelid;
321
324 int macronr;
325
332 int cmdnr;
333
344 int state;
345
352 unsigned long timestamp;
353 } BLC_MACROSTATE;
354
355 // ! Carries information about one signal.
356 typedef struct _BLC_SIGNAL {
357 // ! Index number of signal; see the SDF for the adequate number
358 int index;
359 // ! Defines whether this signal is a normal, value-based one (0) or LIN2.0 array signal (1).
360 int isArray;
361 // ! Value of the signal.
362 unsigned long long value;
363 // ! Length of the array.
364 int arrayLength;
365 // ! Value(s) of the signal, if isArray == 1.
366 unsigned char array[8];
367 // ! Global time index of frame transmission start (in usec).
368 unsigned long timestamp;
369 // ! Current Channelid
370 unsigned short chId;
371 } BLC_SIGNAL;
372
373 /* clang-format off */
374 // ! Represents a BUS error message
375 typedef struct _BLC_ERROR{
383 unsigned long timestamp;
433 unsigned short type;
442 unsigned short status;
443 } BLC_ERROR;
444 /* clang-format on */
445
446 // ! Carries information about DTL protocol (both requests and responses).
447 typedef struct _BLC_DTL {
448 // ! Status of protocol frame
449 BL_DTL_STATUS status;
450
451 // ! NAD of protocol frame
452 unsigned char nad;
453
454 // ! Length of the data-array.
455 int length;
456 // ! frame data, beginning with the (R)SID.
457 unsigned char data[4 * 1024];
458 } BLC_DTL;
459
460 // ! Events from a device
461 typedef struct _BLC_EVENT {
465 unsigned int timestamp;
469 unsigned int pc_timestamp;
470 /* clang-format off */
487 int event;
488 /* clang-format on */
491 long long data;
492 } BLC_EVENT;
493
497 typedef enum {
498 TYPE_RAW = 0,
499 TYPE_DTL_ISOTP = 1,
500 TYPE_ISOTP_WITHOUT_NAD = 2,
501 TYPE_WEBASTO_UHW2 = 3,
502 TYPE_WEBASTO_STD = 5,
503 TYPE_KLINE_RAW = 6,
504 } ADHOC_PROTOCOL_TYPE;
505
506 typedef union {
507 struct {
508 // any value of PROTOCOL_TYPE
509 // 0: Raw
510 // 1: DTL/ISO-TP with NAD
511 // 2: ISO-TP without NAD (CAN only)
512 // 3: Webasto KLine UHW V2 (LIN only)
513 // 4: Raw Jumbo (LIN only)
514 // 5: Webasto KLine Standard (LIN only)
515 //
516 int protocoltype : 6;
517 unsigned int unused_1 : 5;
518 // shorten sf (single frame) on transmission
519 unsigned int tx_shortensf : 1;
520 // shorten last consecutive frame on transmission
521 unsigned int tx_shortenlcf : 1;
522 unsigned int unused_2 : 3;
523 // if set a pos response has to fulfil RSID = SID | 0x40 rule other wise everything with
524 // matching length is positive signals are mapped on positive Response only
525 unsigned int use_std_posresp : 1;
526 // interpret neg. response as 0x7f sid errorcode
527 unsigned int use_std_negresp : 1;
528 // this bit is set for a slave protocol definition
529 unsigned int slaveprotocol : 1;
530 // 0: no (Only full frames are accepted) Default bei V0
531 // 1: yes (Only shortened frames are accepted)
532 // 2: ignore, accept both (Full and shortened frames are accepted)
533 unsigned int expect_shortenedsf : 2;
534 // 0: no (Only full frames are accepted)
535 // 1: yes (Only shortened frames are accepted)
536 // 2: ignore, accept both (Full and shortened frames are accepted) Default bei V0
537 unsigned int expect_shortenedlcf : 2;
538 unsigned int unused_3 : 5;
539 // accept any containersize on reception
540 unsigned int accept_any_csize : 1;
541 // send shortened FloawCtrl frame (for CAN only)
542 unsigned int xmit_shortenflowctrl : 1;
543 } generic;
544
545 struct {
546 // See generic definition above.
547 unsigned int protocoltype : 6;
548 unsigned int unused_1 : 2;
549 // classic or enhanced checksum
550 unsigned int xmit_chksumtype : 1;
551 // classic or enhanced checksum or both
552 unsigned int expect_chksumtype : 2;
553 // See generic definition above.
554 unsigned int xmit_shortensf : 1;
555 // See generic definition above.
556 unsigned int xmit_shortenlcf : 1;
557 unsigned int unused_2 : 3;
558 // See generic definition above.
559 unsigned int use_std_posresp : 1;
560 // See generic definition above.
561 unsigned int use_std_negresp : 1;
562 // See generic definition above.
563 unsigned int slaveprotocol : 1;
564 // See generic definition above.
565 unsigned int expect_shortenedsf : 2;
566 // See generic definition above.
567 unsigned int expect_shortenedlcf : 2;
568 unsigned int unused_3 : 5;
569 // See generic definition above.
570 unsigned int accept_any_csize : 1;
571 // See generic definition above.
572 unsigned int xmit_shortenflowctrl : 1;
573 } lin;
574 struct {
575 // See generic definition above.
576 unsigned int protocoltype : 6;
577 // use can FD baudswitch on transmission
578 unsigned int xmit_canfd_switch : 1;
579 // use can FD frame on transmission
580 unsigned int xmit_canfd_frame : 1;
581 // use can 29 bit frame id if set on transmission
582 unsigned int xmit_can_11_29bit : 1;
583 // expect can 29 bit frame id if set on reception
584 unsigned int expect_can_11_29bit : 2;
585 // shorten sf (single frame) on transmission
586 unsigned int xmit_shortensf : 1;
587 // shorten last consecutive frame on transmission
588 unsigned int xmit_shortenlcf : 1;
589 unsigned int unused_1 : 3;
590 // See generic definition above.
591 unsigned int use_std_posresp : 1;
592 // See generic definition above.
593 unsigned int use_std_negresp : 1;
594 // See generic definition above.
595 unsigned int slaveprotocol : 1;
596 // See generic definition above.
597 unsigned int expect_shortenedsf : 2;
598 // 0: no (Only full frames are accepted)
599 // 1: yes (Only shortened frames are accepted)
600 // 2: ignore, accept both (Full and shortened frames are accepted)
601 unsigned int expect_shortenedlcf : 2;
602 // 0: no (Only CAN-FD frames without baudswitch are accepted)
603 // 1: yes (Only CAN-FD frames with baudswitch are accepted)
604 // 2: ignore, accept both (All CAN-FD frames are accepted)
605 unsigned int expect_canfd_switch : 2;
606 // 0: no (Only normal CAN frames are accepted)
607 // 1: yes (Only CAN-FD frames are accepted)
608 // 2: ignore, accept both (All CAN frames are accepted)
609 unsigned int expect_canfd_frame : 2;
610 // 1: don't wait for FlowControl on IsoTp transmissions
611 unsigned int xmit_no_flowctrl_wait : 1;
612 // See generic definition above.
613 unsigned int accept_any_csize : 1;
614 // See generic definition above.
615 unsigned int xmit_shortenflowctrl : 1;
616
617 } can;
618 } ADHOC_PROTOCOL_FLAGS;
619
620 // ! Ad-Hoc protocol
621 typedef struct _BLC_ADHOC_PROTOCOL {
622 const char* name;
623
624 ADHOC_PROTOCOL_FLAGS flags;
625
626 unsigned char active;
627 int req_slot_time;
628 int rsp_slot_time;
629 int rsp_delay;
630 unsigned char fill_byte;
631 } BLC_ADHOC_PROTOCOL;
632
633 typedef union {
634 struct {
635 unsigned int unused_1 : 2;
636 unsigned int unused_2 : 2;
637 // shorten sf (single frame) on transmission
638 // 0: no
639 // 1: yes
640 // 2: default from protocol
641 unsigned int shortensf_txd : 2;
642 // expect shorten sf (single frame) on reception
643 // 0: no
644 // 1: yes
645 // 2: ignore
646 unsigned int shortensf_rcv : 2;
647 // shorten last consecutive frame on transmission
648 // 0: no
649 // 1: yes
650 // 2: default from protocol
651 unsigned int shortenlcf_txd : 2;
652 // shorten last consecutive frame on reception
653 // 0: no
654 // 1: yes
655 // 2: ignore
656 unsigned int shortenlcf_rcv : 2;
657 unsigned int unused_3 : 8;
658 // if set a pos response has to fulfil RSID = SID | 0x40 rule other wise everything with
659 // matching length is positive signals are mapped on positive Response only
660 unsigned int use_std_posresp : 2;
661 // interpret neg. response as 0x7f sid errorcode
662 unsigned int use_std_negresp : 2;
663 // Service does not expect a answer, if set
664 unsigned int requestonly : 1;
665 unsigned int unused_4 : 2;
666 // accept any containersize on reception
667 unsigned int accept_any_csize : 2;
668 unsigned int unused_5 : 3;
669 } generic;
670
671 struct {
672 // Checksum type for transmission
673 // 0: classic
674 // 1: enhanced
675 // 2: protocol default
676 unsigned int checksum_txd : 2;
677 // Checksum type for reception
678 // 0: classic
679 // 1: enhanced
680 // 2: ignore
681 unsigned int checksum_rcv : 2;
682 // See generic definition above.
683 unsigned int shortensf_txd : 2;
684 // See generic definition above.
685 unsigned int shortensf_rcv : 2;
686 // See generic definition above.
687 unsigned int shortenlcf_txd : 2;
688 // See generic definition above.
689 unsigned int shortenlcf_rcv : 2;
690 unsigned int unused_1 : 8;
691 // See generic definition above.
692 unsigned int use_std_posresp : 2;
693 // See generic definition above.
694 unsigned int use_std_negresp : 2;
695 // See generic definition above.
696 unsigned int requestonly : 1;
697 unsigned int unused_2 : 2;
698 // See generic definition above.
699 unsigned int accept_any_csize : 2;
700 unsigned int unused_3 : 3;
701 } lin;
702 struct {
703 // CAN frame id type for transmission
704 // 0: 11 Bit
705 // 1: 29 Bit
706 // 2: Protocol default
707 unsigned int id_11_29_txd : 2;
708 // CAN frame id type for reception
709 // 0: 11 Bit
710 // 1: 29 Bit
711 // 2: ignore
712 unsigned int id_11_29_rcv : 2;
713 // See generic definition above.
714 unsigned int shortensf_txd : 2;
715 // See generic definition above.
716 unsigned int shortensf_rcv : 2;
717 // See generic definition above.
718 unsigned int shortenlcf_txd : 2;
719 // See generic definition above.
720 unsigned int shortenlcf_rcv : 2;
721 // CAN FD baudrate switching for transmission
722 // 0: off
723 // 1: on
724 // 2: protocol default
725 unsigned int fdbaudswitch_txd : 2;
726 // CAN FD baudrate switching for reception
727 // 0: off
728 // 1: on
729 // 2: ignore
730 unsigned int fdbaudswitch_rcv : 2;
731 // CAN FD frame for transmission
732 // 0: off
733 // 1: on
734 // 2: protocol default
735 unsigned int fdframe_txd : 2;
736 // CAN FD frame for transmission
737 // 0: off
738 // 1: on
739 // 2: ignore
740 unsigned int fdframe_rcv : 2;
741 // See generic definition above.
742 unsigned int use_std_posresp : 2;
743 // See generic definition above.
744 unsigned int use_std_negresp : 2;
745 // See generic definition above.
746 unsigned int requestonly : 1;
747 unsigned int no_flowctrl_wait : 2;
748
749 // See generic definition above.
750 unsigned int accept_any_csize : 2;
751 unsigned int unused_1 : 3;
752 } can;
753 } ADHOC_SERVICE_FLAGS;
754
755 // ! Ad-Hoc service
756 typedef struct {
757 const char* name;
758 ADHOC_SERVICE_FLAGS flags;
759
760 int req_frame_id;
761 long long req_container_size;
762 long long req_payload_size;
763 int req_slot_time;
764
765 int rsp_frame_id;
766 long long rsp_container_size;
767 long long rsp_payload_size;
768 int rsp_slot_time;
769 int rsp_delay;
770 } BLC_ADHOC_SERVICE;
771
772 typedef struct {
773 int nad;
774 int p2_extended;
775 int flow_control_st_min;
776 int flow_control_block_size;
777 } BLC_ADHOC_EXECUTE;
778
779 // ! Carries information about one signal.
780 typedef struct _BLC_LOG {
781 // ! Index number of signal; see the SDF for the adequate number
782 int format_version;
783 // ! (0) channel source: channel.id / channel.signal_index, (1) group source: group.id / group.sub_index
784 unsigned int source_type;
785 // ! Information about the source of the log
786 union {
787 struct {
788 // ! the channel id
789 int id;
790 // ! the signal id
791 int signal_index;
792 } channel;
793 struct {
794 // ! the group id
795 int id;
796 // ! the sub index
797 int sub_index;
798 } group;
799 } source;
800
801 // ! unix time index of the log (in sec).
802 unsigned long long timestamp_unix;
803 // ! Global time index of the log (in usec).
804 unsigned long timestamp_usec;
805
806 // ! Value type of the value content 0x0 unsigned, 0x1 signed
807 unsigned int value_signed;
808 // ! byte size of one element (possible values are one of {1, 2, 4, 8})
809 unsigned int value_element_size;
810 // ! array size of the value (is always greater then 0)
811 unsigned int value_array_size;
812 // ! values as single value if value_array_size == 1 or as array of values for value_array_size > 1
813 unsigned char value_data[4 * 1024];
814 } BLC_LOG;
815
830 // !these Callbacks will tell you the data(as done with old callbacks) AND the Channel which send
831 // the Data !to find out which Device send the data use => !BL_HANDLE hConnection =
832 // BLC_getConnectionOfChannel(BLC_CHANNEL hChannel);
833 typedef void(BLC_frame_callback_func)(BL_HANDLE, BLC_FRAME frame);
834 typedef void(BLC_jumboframe_callback_func)(BL_HANDLE, BLC_JUMBO_FRAME jumbo_frame);
835 typedef void(BLC_signal_callback_func)(BL_HANDLE, BLC_SIGNAL signal);
836 typedef void(BLC_macrostate_callback_func)(BL_HANDLE, BLC_MACROSTATE macroState);
837 typedef void(BLC_error_callback_func)(BL_HANDLE, BLC_ERROR error);
838 typedef void(BLC_debug_callback_func)(BL_HANDLE, const char* text);
839 typedef void(BLC_dtl_request_callback_func)(BL_HANDLE, BLC_DTL dtl_request);
840 typedef void(BLC_dtl_response_callback_func)(BL_HANDLE, BLC_DTL dtl_response);
841 typedef void(BLC_event_callback_func)(BL_HANDLE, BLC_EVENT event);
842
843 // !these Callbacks will tell you the data(as done with old callbacks), plus the Channel which send
844 // the Data and a user data pointer !added when registering the function !to find out which Device
845 // send the data use => !BL_HANDLE hConnection = BLC_getConnectionOfChannel(BLC_CHANNEL hChannel);
846 typedef void(BLC_frame_callback_func_ptr)(BL_HANDLE, BLC_FRAME frame, void*);
847 typedef void(BLC_jumboframe_callback_func_ptr)(BL_HANDLE, BLC_JUMBO_FRAME jumbo_frame, void*);
848 typedef void(BLC_signal_callback_func_ptr)(BL_HANDLE, BLC_SIGNAL signal, void*);
849 typedef void(BLC_macrostate_callback_func_ptr)(BL_HANDLE, BLC_MACROSTATE macroState, void*);
850 typedef void(BLC_error_callback_func_ptr)(BL_HANDLE, BLC_ERROR error, void*);
851 typedef void(BLC_debug_callback_func_ptr)(BL_HANDLE, const char* text, void*);
852 typedef void(BLC_dtl_request_callback_func_ptr)(BL_HANDLE, BLC_DTL dtl_request, void*);
853 typedef void(BLC_dtl_response_callback_func_ptr)(BL_HANDLE, BLC_DTL dtl_response, void*);
854 typedef void(BLC_event_callback_func_ptr)(BL_HANDLE, BLC_EVENT event, void*);
855 typedef void(BLC_log_callback_func_ptr)(BL_HANDLE, BLC_LOG log, void*);
856
857 typedef void(BLC_lua_print_func_ptr)(const char* msg, void* userdata);
858
859 #endif // BABYLINCAN_TYPES_H
BLC_dtl_response_callback_func_ptr
void( BLC_dtl_response_callback_func_ptr)(BL_HANDLE, BLC_DTL dtl_response, void *)
Definition: BabyLINCAN_types.h:853
BLC_JUMBO_FRAME
Definition: BabyLINCAN_types.h:243
BLC_CHANNELINFO::maxbaudrate
long maxbaudrate
Maximum Baudrate of Channel.
Definition: BabyLINCAN_types.h:116
BLC_lua_print_func_ptr
void( BLC_lua_print_func_ptr)(const char *msg, void *userdata)
Definition: BabyLINCAN_types.h:857
BLC_SDFINFO::sectionCount
short sectionCount
Definition: BabyLINCAN_types.h:155
TYPE_WEBASTO_STD
Definition: BabyLINCAN_types.h:502
BLC_event_callback_func_ptr
void( BLC_event_callback_func_ptr)(BL_HANDLE, BLC_EVENT event, void *)
Definition: BabyLINCAN_types.h:854
BLC_error_callback_func_ptr
void( BLC_error_callback_func_ptr)(BL_HANDLE, BLC_ERROR error, void *)
Definition: BabyLINCAN_types.h:850
BLC_ADHOC_PROTOCOL
Definition: BabyLINCAN_types.h:621
BLC_MACROSTATE::timestamp
unsigned long timestamp
Timestamp of the macro state.
Definition: BabyLINCAN_types.h:352
BLC_TARGETID::heapsize
long heapsize
Definition: BabyLINCAN_types.h:90
BLC_ADHOC_PROTOCOL::flags
ADHOC_PROTOCOL_FLAGS flags
Definition: BabyLINCAN_types.h:624
BLC_TARGETID
Information about a connected BabyLIN device.
Definition: BabyLINCAN_types.h:47
BLC_JUMBO_FRAME::frameId
unsigned long frameId
Definition: BabyLINCAN_types.h:255
BLC_CHANNELINFO::id
unsigned short id
Channel-id(i.e. 0 = device channel)
Definition: BabyLINCAN_types.h:107
BLC_ADHOC_EXECUTE::p2_extended
int p2_extended
Definition: BabyLINCAN_types.h:774
BLC_LOG::@7::@9::sub_index
int sub_index
Definition: BabyLINCAN_types.h:797
BLC_LOG::format_version
int format_version
Definition: BabyLINCAN_types.h:782
BLC_ADHOC_SERVICE::req_slot_time
int req_slot_time
Definition: BabyLINCAN_types.h:763
BLC_ADHOC_SERVICE::name
const char * name
Definition: BabyLINCAN_types.h:757
BLC_LOG::value_signed
unsigned int value_signed
Definition: BabyLINCAN_types.h:807
BLC_FRAME::chId
unsigned long chId
Definition: BabyLINCAN_types.h:176
BLC_signal_callback_func_ptr
void( BLC_signal_callback_func_ptr)(BL_HANDLE, BLC_SIGNAL signal, void *)
Definition: BabyLINCAN_types.h:848
BLC_ERROR::timestamp
unsigned long timestamp
Time of occurence. The timestamp when the error occurred.
Definition: BabyLINCAN_types.h:383
BLC_macrostate_callback_func
void( BLC_macrostate_callback_func)(BL_HANDLE, BLC_MACROSTATE macroState)
Definition: BabyLINCAN_types.h:836
BLC_LOG::source_type
unsigned int source_type
Definition: BabyLINCAN_types.h:784
BLC_ERROR::type
unsigned short type
Error type.
Definition: BabyLINCAN_types.h:433
BLC_log_callback_func_ptr
void( BLC_log_callback_func_ptr)(BL_HANDLE, BLC_LOG log, void *)
Definition: BabyLINCAN_types.h:855
BLC_macrostate_callback_func_ptr
void( BLC_macrostate_callback_func_ptr)(BL_HANDLE, BLC_MACROSTATE macroState, void *)
Definition: BabyLINCAN_types.h:849
BLC_ADHOC_PROTOCOL::rsp_slot_time
int rsp_slot_time
Definition: BabyLINCAN_types.h:628
ADHOC_PROTOCOL_TYPE
ADHOC_PROTOCOL_TYPE
Type of an ad hoc protocol.
Definition: BabyLINCAN_types.h:497
BL_DTL_STATUS
BL_DTL_STATUS
DTL protocol status answers. Part of BLC_DTL data structure. Retrieve status of pending DTL actions u...
Definition: BabyLINReturncodes.h:300
BLC_TARGETID::serial
long serial
Definition: BabyLINCAN_types.h:87
BLC_LOG::value_array_size
unsigned int value_array_size
Definition: BabyLINCAN_types.h:811
BLC_MACROSTATE::channelid
int channelid
Definition: BabyLINCAN_types.h:320
BLC_ADHOC_SERVICE::flags
ADHOC_SERVICE_FLAGS flags
Definition: BabyLINCAN_types.h:758
BLC_ADHOC_EXECUTE::nad
int nad
Definition: BabyLINCAN_types.h:773
BLC_dtl_response_callback_func
void( BLC_dtl_response_callback_func)(BL_HANDLE, BLC_DTL dtl_response)
Definition: BabyLINCAN_types.h:840
BLC_CHANNELINFO::type
unsigned short type
Channel-Type(i.e. 0 = LIN, 1 = CAN, 99 = DEVICE)
Definition: BabyLINCAN_types.h:110
BLC_FRAME::frameId
unsigned long frameId
Definition: BabyLINCAN_types.h:186
BLC_SIGNAL::arrayLength
int arrayLength
Definition: BabyLINCAN_types.h:364
BLC_dtl_request_callback_func
void( BLC_dtl_request_callback_func)(BL_HANDLE, BLC_DTL dtl_request)
Definition: BabyLINCAN_types.h:839
BLC_ADHOC_PROTOCOL::name
const char * name
Definition: BabyLINCAN_types.h:622
BLC_TARGETID::type
unsigned short type
Type of the hardware.
Definition: BabyLINCAN_types.h:70
BLC_SIGNAL::value
unsigned long long value
Definition: BabyLINCAN_types.h:362
BLC_ADHOC_SERVICE::rsp_slot_time
int rsp_slot_time
Definition: BabyLINCAN_types.h:768
BLC_ADHOC_SERVICE::req_container_size
long long req_container_size
Definition: BabyLINCAN_types.h:761
BLC_ADHOC_PROTOCOL::fill_byte
unsigned char fill_byte
Definition: BabyLINCAN_types.h:630
BLC_frame_callback_func
void( BLC_frame_callback_func)(BL_HANDLE, BLC_FRAME frame)
Definition: BabyLINCAN_types.h:833
BLC_SIGNAL::index
int index
Definition: BabyLINCAN_types.h:358
BLC_ADHOC_SERVICE
Definition: BabyLINCAN_types.h:756
BLC_TARGETID::numofchannels
long numofchannels
Definition: BabyLINCAN_types.h:93
BLC_ERROR::status
unsigned short status
Additional error information.
Definition: BabyLINCAN_types.h:442
BLC_MACROSTATE::state
int state
state of the macro execution
Definition: BabyLINCAN_types.h:344
BLC_JUMBO_FRAME::chId
unsigned long chId
Definition: BabyLINCAN_types.h:245
BLC_TARGETID::version
unsigned short version
Definition: BabyLINCAN_types.h:73
BLC_CHANNELINFO::associatedWithSectionNr
int associatedWithSectionNr
Definition: BabyLINCAN_types.h:146
BLC_CHANNELINFO::reserved2
long reserved2
Reserved value (ignore for now)
Definition: BabyLINCAN_types.h:139
BLC_signal_callback_func
void( BLC_signal_callback_func)(BL_HANDLE, BLC_SIGNAL signal)
Definition: BabyLINCAN_types.h:835
BLC_LOG::@7::@8::signal_index
int signal_index
Definition: BabyLINCAN_types.h:791
BLC_ADHOC_PROTOCOL::active
unsigned char active
Definition: BabyLINCAN_types.h:626
BLC_DTL::length
int length
Definition: BabyLINCAN_types.h:455
BLC_SIGNAL
Definition: BabyLINCAN_types.h:356
BLC_JUMBO_FRAME::timestamp
unsigned long timestamp
Definition: BabyLINCAN_types.h:249
BLC_LOG
Definition: BabyLINCAN_types.h:780
BLC_MACROSTATE
status of a macro
Definition: BabyLINCAN_types.h:318
BLC_JUMBO_FRAME::checksum
unsigned char checksum
checksum of the frame stores a checksum V1 or V2 ( refer to busFlags which checksum type applies ) ...
Definition: BabyLINCAN_types.h:309
BLC_DTL
Definition: BabyLINCAN_types.h:447
BL_HANDLE
void * BL_HANDLE
Definition: BabyLINReturncodes.h:34
BLC_ADHOC_EXECUTE::flow_control_st_min
int flow_control_st_min
Definition: BabyLINCAN_types.h:775
BLC_LOG::timestamp_unix
unsigned long long timestamp_unix
Definition: BabyLINCAN_types.h:802
BLC_ADHOC_SERVICE::rsp_payload_size
long long rsp_payload_size
Definition: BabyLINCAN_types.h:767
BLC_JUMBO_FRAME::frameFlags
short frameFlags
Additional, informational frame flags.
Definition: BabyLINCAN_types.h:278
BLC_SDFINFO::version_minor
short version_minor
Definition: BabyLINCAN_types.h:158
BLC_event_callback_func
void( BLC_event_callback_func)(BL_HANDLE, BLC_EVENT event)
Definition: BabyLINCAN_types.h:841
TYPE_DTL_ISOTP
Definition: BabyLINCAN_types.h:499
BLC_FRAME::busFlags
short busFlags
Bus specific flags.
Definition: BabyLINCAN_types.h:234
BLC_JUMBO_FRAME::intime
long intime
Definition: BabyLINCAN_types.h:252
BLC_FRAME::lenOfData
unsigned char lenOfData
Definition: BabyLINCAN_types.h:189
BLC_ADHOC_PROTOCOL::req_slot_time
int req_slot_time
Definition: BabyLINCAN_types.h:627
BLC_LOG::@7::@9::id
int id
Definition: BabyLINCAN_types.h:795
BLC_ADHOC_SERVICE::req_frame_id
int req_frame_id
Definition: BabyLINCAN_types.h:760
BLC_DTL::nad
unsigned char nad
Definition: BabyLINCAN_types.h:452
BLC_JUMBO_FRAME::busFlags
short busFlags
Bus specific flags.
Definition: BabyLINCAN_types.h:304
BLC_PORTINFO
Information about a BabyLIN port on the host operating system.
Definition: BabyLINCAN_types.h:20
BLC_FRAME::intime
long intime
Definition: BabyLINCAN_types.h:183
BLC_EVENT::timestamp
unsigned int timestamp
Time of occurence. The timestamp (of the device (us)) when the error occurred.
Definition: BabyLINCAN_types.h:465
BLC_SIGNAL::isArray
int isArray
Definition: BabyLINCAN_types.h:360
BLC_ADHOC_EXECUTE
Definition: BabyLINCAN_types.h:772
ADHOC_SERVICE_FLAGS
Definition: BabyLINCAN_types.h:633
BLC_jumboframe_callback_func
void( BLC_jumboframe_callback_func)(BL_HANDLE, BLC_JUMBO_FRAME jumbo_frame)
Definition: BabyLINCAN_types.h:834
BLC_LOG::value_element_size
unsigned int value_element_size
Definition: BabyLINCAN_types.h:809
BLC_CHANNELINFO::reserved1
long reserved1
Flags describing the State of the Channel.
Definition: BabyLINCAN_types.h:136
BLC_FRAME::timestamp
unsigned long timestamp
Definition: BabyLINCAN_types.h:180
BLC_SIGNAL::chId
unsigned short chId
Definition: BabyLINCAN_types.h:370
BLC_SECTIONINFO::nr
short nr
Definition: BabyLINCAN_types.h:170
BLC_JUMBO_FRAME::lenOfData
unsigned int lenOfData
Definition: BabyLINCAN_types.h:258
BLC_ADHOC_PROTOCOL::rsp_delay
int rsp_delay
Definition: BabyLINCAN_types.h:629
ADHOC_PROTOCOL_FLAGS
Definition: BabyLINCAN_types.h:506
BLC_jumboframe_callback_func_ptr
void( BLC_jumboframe_callback_func_ptr)(BL_HANDLE, BLC_JUMBO_FRAME jumbo_frame, void *)
Definition: BabyLINCAN_types.h:847
TYPE_RAW
Definition: BabyLINCAN_types.h:498
BLC_LOG::@7::@8::id
int id
Definition: BabyLINCAN_types.h:789
BLC_EVENT::pc_timestamp
unsigned int pc_timestamp
Time of occurence. The timestamp (of the PC (ms)) when the error occurred.
Definition: BabyLINCAN_types.h:469
BLC_CHANNELINFO
Information about a channel on a BabyLIN device.
Definition: BabyLINCAN_types.h:105
BLC_TARGETID::build
unsigned short build
Definition: BabyLINCAN_types.h:76
BLC_SECTIONINFO::type
int type
Definition: BabyLINCAN_types.h:167
BabyLINReturncodes.h
TYPE_WEBASTO_UHW2
Definition: BabyLINCAN_types.h:501
BLC_TARGETID::flags
unsigned short flags
Software related flags.
Definition: BabyLINCAN_types.h:84
BLC_SIGNAL::timestamp
unsigned long timestamp
Definition: BabyLINCAN_types.h:368
BLC_error_callback_func
void( BLC_error_callback_func)(BL_HANDLE, BLC_ERROR error)
Definition: BabyLINCAN_types.h:837
BLC_PORTINFO::type
int type
The type of interface of the connected device (0=USBSerial, 1=Not Connectable(Network UDP)...
Definition: BabyLINCAN_types.h:30
BLC_ADHOC_SERVICE::rsp_frame_id
int rsp_frame_id
Definition: BabyLINCAN_types.h:765
BLC_LOG::timestamp_usec
unsigned long timestamp_usec
Definition: BabyLINCAN_types.h:804
BLC_MACROSTATE::macronr
int macronr
Macro-number the information is about.
Definition: BabyLINCAN_types.h:324
BLC_FRAME::checksum
unsigned char checksum
Checksum of the frame stores a checksum V1 or V2 ( refer to busFlags which checksum type applies ) ...
Definition: BabyLINCAN_types.h:239
BLC_ADHOC_SERVICE::rsp_container_size
long long rsp_container_size
Definition: BabyLINCAN_types.h:766
BLC_SDFINFO
Definition: BabyLINCAN_types.h:150
BLC_ADHOC_SERVICE::rsp_delay
int rsp_delay
Definition: BabyLINCAN_types.h:769
BLC_EVENT::data
long long data
Additional information of an event.
Definition: BabyLINCAN_types.h:491
BLC_EVENT::event
int event
The event that occured.
Definition: BabyLINCAN_types.h:487
BLC_ADHOC_EXECUTE::flow_control_block_size
int flow_control_block_size
Definition: BabyLINCAN_types.h:776
TYPE_ISOTP_WITHOUT_NAD
Definition: BabyLINCAN_types.h:500
BLC_SECTIONINFO
Definition: BabyLINCAN_types.h:162
BLC_ERROR
Definition: BabyLINCAN_types.h:375
BLC_frame_callback_func_ptr
void( BLC_frame_callback_func_ptr)(BL_HANDLE, BLC_FRAME frame, void *)
Definition: BabyLINCAN_types.h:846
BLC_DTL::status
BL_DTL_STATUS status
Definition: BabyLINCAN_types.h:449
BLC_dtl_request_callback_func_ptr
void( BLC_dtl_request_callback_func_ptr)(BL_HANDLE, BLC_DTL dtl_request, void *)
Definition: BabyLINCAN_types.h:852
BLC_CHANNELINFO::reserved3
long reserved3
Reserved value (ignore for now)
Definition: BabyLINCAN_types.h:142
BLC_ADHOC_SERVICE::req_payload_size
long long req_payload_size
Definition: BabyLINCAN_types.h:762
BLC_PORTINFO::portNr
int portNr
The COM-port number the device is connected to (windows only), use this value for BLC_open...
Definition: BabyLINCAN_types.h:24
BLC_EVENT
Definition: BabyLINCAN_types.h:461
BLC_FRAME
Definition: BabyLINCAN_types.h:174
BLC_debug_callback_func
void( BLC_debug_callback_func)(BL_HANDLE, const char *text)
Definition: BabyLINCAN_types.h:838
BLC_debug_callback_func_ptr
void( BLC_debug_callback_func_ptr)(BL_HANDLE, const char *text, void *)
Definition: BabyLINCAN_types.h:851
BLC_MACROSTATE::cmdnr
int cmdnr
The macro command number currently executed.
Definition: BabyLINCAN_types.h:332
TYPE_KLINE_RAW
Definition: BabyLINCAN_types.h:503
BLC_FRAME::frameFlags
short frameFlags
Additional, informational frame flags.
Definition: BabyLINCAN_types.h:208
Generated on Fri May 30 2025 17:16:13 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: C:/JenkinsWS/workspace/orks_v2_LinWorksv2_Windows_trunk/source/externals/BabyLIN/src/libraries/BabyLIN/publicHeaders/BabyLINCANSDF.h File Reference

  • externals
  • BabyLIN
  • src
  • libraries
  • BabyLIN
  • publicHeaders
Functions
BabyLINCANSDF.h File Reference
#include "BabyLINReturncodes.h"

Go to the source code of this file.

Functions

int BL_DLLIMPORT | BLC_SDF_getNodeNr (BL_HANDLE handle, const char *name)
Get the SDF's number for node by name. More...
int BL_DLLIMPORT | BLC_SDF_getSignalNr (BL_HANDLE handle, const char *name)
Get the SDF's number for signal by name. More...
int BL_DLLIMPORT | BLC_SDF_getFrameNr (BL_HANDLE handle, const char *name)
Get the SDF's number for frame by name. More...
int BL_DLLIMPORT | BLC_SDF_getScheduleNr (BL_HANDLE handle, const char *name)
Get the SDF's number for schedule by name. More...
int BL_DLLIMPORT | BLC_SDF_getNumSchedules (BL_HANDLE handle)
Get the number of schedule tables in the SDF. More...
CPCHAR BL_DLLIMPORT | BLC_SDF_getScheduleName (BL_HANDLE handle, int schedule_nr)
Get the SDF's name of schedule by number. More...
int BL_DLLIMPORT | BLC_SDF_getMacroNr (BL_HANDLE handle, const char *name)
Get the SDF's number for macro by name. More...
Generated on Fri May 30 2025 17:16:13 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: C:/JenkinsWS/workspace/orks_v2_LinWorksv2_Windows_trunk/source/externals/BabyLIN/src/libraries/BabyLIN/publicHeaders/BabyLINCANSDF.h Source File

  • externals
  • BabyLIN
  • src
  • libraries
  • BabyLIN
  • publicHeaders
BabyLINCANSDF.h
Go to the documentation of this file.
1 #ifndef BABYLINCANSDF_H
2 #define BABYLINCANSDF_H
3
4 #include "BabyLINReturncodes.h"
5
6 #if defined(__cplusplus)
7 extern "C" {
8 #endif
9
22 int BL_DLLIMPORT BLC_SDF_getNodeNr(BL_HANDLE handle, const char* name);
23
32 int BL_DLLIMPORT BLC_SDF_getSignalNr(BL_HANDLE handle, const char* name);
33
42 int BL_DLLIMPORT BLC_SDF_getFrameNr(BL_HANDLE handle, const char* name);
43
52 int BL_DLLIMPORT BLC_SDF_getScheduleNr(BL_HANDLE handle, const char* name);
53
60 int BL_DLLIMPORT BLC_SDF_getNumSchedules(BL_HANDLE handle);
61
71 CPCHAR BL_DLLIMPORT BLC_SDF_getScheduleName(BL_HANDLE handle, int schedule_nr);
72
81 int BL_DLLIMPORT BLC_SDF_getMacroNr(BL_HANDLE handle, const char* name);
84 #if defined(__cplusplus)
85 } // extern "C"
86 #endif
87
88 #endif // BABYLINCANSDF_H
BLC_SDF_getMacroNr
int BL_DLLIMPORT BLC_SDF_getMacroNr(BL_HANDLE handle, const char *name)
Get the SDF's number for macro by name.
BLC_SDF_getSignalNr
int BL_DLLIMPORT BLC_SDF_getSignalNr(BL_HANDLE handle, const char *name)
Get the SDF's number for signal by name.
BLC_SDF_getNodeNr
int BL_DLLIMPORT BLC_SDF_getNodeNr(BL_HANDLE handle, const char *name)
Get the SDF's number for node by name.
BLC_SDF_getNumSchedules
int BL_DLLIMPORT BLC_SDF_getNumSchedules(BL_HANDLE handle)
Get the number of schedule tables in the SDF.
BL_HANDLE
void * BL_HANDLE
Definition: BabyLINReturncodes.h:34
BLC_SDF_getFrameNr
int BL_DLLIMPORT BLC_SDF_getFrameNr(BL_HANDLE handle, const char *name)
Get the SDF's number for frame by name.
BL_DLLIMPORT
#define BL_DLLIMPORT
Definition: BabyLINReturncodes.h:9
BabyLINReturncodes.h
CPCHAR
const char * CPCHAR
Definition: BabyLINReturncodes.h:36
BLC_SDF_getScheduleName
CPCHAR BL_DLLIMPORT BLC_SDF_getScheduleName(BL_HANDLE handle, int schedule_nr)
Get the SDF's name of schedule by number.
BLC_SDF_getScheduleNr
int BL_DLLIMPORT BLC_SDF_getScheduleNr(BL_HANDLE handle, const char *name)
Get the SDF's number for schedule by name.
Generated on Fri May 30 2025 17:16:13 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: C:/JenkinsWS/workspace/orks_v2_LinWorksv2_Windows_trunk/source/externals/BabyLIN/src/libraries/BabyLIN/publicHeaders/BabyLINReturncodes.h File Reference

  • externals
  • BabyLIN
  • src
  • libraries
  • BabyLIN
  • publicHeaders
Macros | Typedefs | Enumerations
BabyLINReturncodes.h File Reference

Go to the source code of this file.

Macros

#define | BL_DLLIMPORT
#define | DEPRECATED
#define | BL_OK 0
#define | SDF_OK 0
#define | BL_PC_SIDE_ERRORS -100000
#define | BL_RESOURCE_ERROR -100001
#define | BL_HANDLE_INVALID -100002
#define | BL_NO_CONNECTION -100003
#define | BL_SERIAL_PORT_ERROR -100004
#define | BL_CMD_SYNTAX_ERROR -100005
#define | BL_NO_ANSWER -100006
#define | BL_FILE_ERROR -100007
#define | BL_WRONG_PARAMETER -100008
#define | BL_NO_DATA -100009
#define | BL_NO_SDF -100010
#define | BL_DP_MSG_ERROR -100011
#define | BL_SIGNAL_NOT_EXISTENT -100012
#define | BL_SIGNAL_IS_SCALAR -100013
#define | BL_SIGNAL_IS_ARRAY -100014
#define | BL_SDF_INSUFFICIENT_FIRMWARE -100015
#define | BL_ENCODING_NOT_EXISTENT -100016
#define | BL_BUFFER_TOO_SMALL -100017
#define | BL_NO_ANSWER_DATA -100018
#define | BL_ANSWER_DATA_NOT_EXISTENT -100019
#define | BL_NO_CHANNELS_AVAILABLE -100020
#define | BL_UNKNOWN_COMMAND -100021
#define | BL_TIMEOUT -100022
#define | BL_SDF_INCOMPATIBLE -100023
#define | SDF_HANDLE_INVALID -100024
#define | SDF_IN_USE -100025
#define | BL_DOWNLOAD_IN_PROGRESS -100026
#define | BL_INVALID_MODE -100027
#define | BLC_UA_EXECUTION_FAILED -100093
#define | BLC_UA_INVALID_PARAMETER_COUNT -100094
#define | BLC_UA_GET_VALUE_REJECTED -100095
#define | BLC_UA_INVALID_PARAMETER -100096
#define | BLC_UA_NO_GETTER_DEFINED -100097
#define | BLC_UA_NO_SETTER_DEFINED -100098
#define | BLC_UA_SET_VALUE_REJECTED -100099
#define | BLC_UA_NOT_RESOLVABLE_TAG_FIRST -100100
#define | BLC_UA_NOT_RESOLVABLE_TAG_MAX -100200
#define | BLC_UA_NO_REQUEST_DATA -100201
#define | BLC_UA_SERVICE_FRAME_ORDER -100202
#define | BLC_UA_SERVICE_TIMEOUT_SEND -100203
#define | BLC_UA_SERVICE_TIMEOUT_RESPONSE -100204
#define | BLC_UA_SERVICE_TIMEOUT_FLOWCONTROL_SEND -100205
#define | BLC_UA_SERVICE_FLOWCONTROL_INVALIDSTATE -100206
#define | BLC_UA_SERVICE_FLOWCONTROL_WAITSTATES -100207
#define | BLC_UA_SERVICE_FLOWCONTROL_OVERFLOW -100208
#define | BLC_UA_SERVICE_TIMEOUT_FLOWCONTROL_RECEIVE -100209
#define | BLC_UA_SERVICE_FRAME_PACKAGING_ERROR -100210
#define | BLC_UA_REQUESTED_OBJECT_NOT_FOUND_FIRST -101100
#define | BLC_UA_REQUESTED_OBJECT_NOT_FOUND_MAX -101200
#define | BLC_ADHOC_INVALID_HANDLE -1
#define | BLC_ADHOC_EXECUTE_RUNNING -102000
#define | BLC_ADHOC_MCR_OFFSET 71000
#define | BLC_LUA_RUNTIME_ERROR -103000
#define | BL_ERR_SDF_HEADER 98
#define | BL_ERR_DP_CORRUPT 101
#define | BL_ERR_DP_SEQUENCE 102
#define | BL_ERR_DP_MAPPING 103
#define | BL_ERR_CHANNEL 104
#define | BL_ERR_SECTION_TYPE 105
#define | BL_ERR_NULLPOINTER 106
#define | BL_ERR_SECTION_MAPPING 107
#define | BL_ERR_DATAFLASH_INIT 108
#define | BL_ERR_DATAFLASH_INDEX 109
#define | BL_ERR_DATAFLASH_NOSPACE 110
#define | BL_ERR_DATAFLASH 111
#define | BL_ERR_LICENCE 112
#define | BL_ERR_HEAP_EXHAUSTED 113
#define | BL_ERR_SIG_REFERENCE 114
#define | BL_ERR_FRAME_REFERENCE 115
#define | BL_ERR_CFG_REFERENCE 116
#define | BL_ERR_MACROSEL_REFERENCE 117
#define | BL_ERR_EVENT_REFERENCE 118
#define | BL_ERR_SIGFUNC_REFERENCE 119
#define | BL_ERR_CRC 120
#define | BL_ERR_NOT_INITIALIZED 121
#define | BL_ERR_FRAMEID_LOOKUP_FAILED 122
#define | BL_ERR_MACRO_REFERENCE 130
#define | BL_ERR_PARAMVALUE 200
#define | BL_ERR_CONDITION 210
#define | BL_ERR_PARAMCOUNT 211
#define | BL_ERR_SERVICEQUEUE_EXHAUSTED 300
#define | BL_ERR_DP_PARSE 900
#define | BL_ERR_DP_PARSE_TOP 980
#define | BL_ERR_DP_ARRAY_SIZE 989
#define | BL_ERR_DP_NONAME 990
#define | BL_ERR_DP_NAME_TO_SHORT 991
#define | BL_ERR_DP_NAME_TO_LONG 992
#define | BL_CMD_NOT_SUPPORTED 997
#define | BL_ERR_UNDEF 998
#define | BL_ERR_UNKNOWN_CMD 999
#define | BL_OPERATION_PENDING -1
#define | BL_MACRO_STILL_RUNNING 150
#define | BL_MACRO_SAME_RUNNING 151
#define | BL_MACRO_OTHER_RUNNING 152
#define | BL_MACRO_START_FAIL 153
#define | BL_MACRO_NEVER_EXECUTED 154
#define | BL_MACRO_ERRCODE_IN_RESULT 155
#define | BL_MACRO_EXCEPTIONCODE_IN_RESULT 156

Typedefs

typedef void * | BL_HANDLE
typedef int | BL_ADHOC_HANDLE
typedef const char * | CPCHAR

Enumerations

enum BL_ANSWER_TYPE {
BL_ANSWER_TYPE_INT, BL_ANSWER_TYPE_STR, BL_ANSWER_TYPE_BIN, BL_ANSWER_TYPE_INT64,
BL_ANSWER_TYPE_FLOAT, BL_ANSWER_TYPE_UNKNOWN
}
type of an answer data token retrieve type using BLC_getAnswerTypeByName or BLC_getAnswerTypeByIndex More...
enum BL_DTL_STATUS { LD_COMPLETED = 0, LD_FAILED, LD_IN_PROGRESS }
DTL protocol status answers. Part of BLC_DTL data structure. Retrieve status of pending DTL actions using BLC_getDTLRequestStatus or BLC_getDTLResponseStatus. More...

Macro Definition Documentation

#define BL_DLLIMPORT

Definition at line 9 of file BabyLINReturncodes.h.

#define DEPRECATED

Definition at line 29 of file BabyLINReturncodes.h.

Typedef Documentation

typedef int BL_ADHOC_HANDLE

Definition at line 35 of file BabyLINReturncodes.h.

typedef void* BL_HANDLE

Definition at line 34 of file BabyLINReturncodes.h.

typedef const char* CPCHAR

Definition at line 36 of file BabyLINReturncodes.h.

Enumeration Type Documentation

enum BL_ANSWER_TYPE
Enumerator
BL_ANSWER_TYPE_INT | token is an integer value
BL_ANSWER_TYPE_STR | token is a string value
BL_ANSWER_TYPE_BIN | token is a binary value
BL_ANSWER_TYPE_INT64 | token is a 64BitInteger value
BL_ANSWER_TYPE_FLOAT | token is a Floatingpoint value
BL_ANSWER_TYPE_UNKNOWN | token is an unknown value

Definition at line 280 of file BabyLINReturncodes.h.

enum BL_DTL_STATUS
Enumerator
LD_COMPLETED | DTL action completed
LD_FAILED | DTL action failed
LD_IN_PROGRESS | DTL action in progress

Definition at line 300 of file BabyLINReturncodes.h.

Generated on Fri May 30 2025 17:16:13 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: C:/JenkinsWS/workspace/orks_v2_LinWorksv2_Windows_trunk/source/externals/BabyLIN/src/libraries/BabyLIN/publicHeaders/BabyLINReturncodes.h Source File

  • externals
  • BabyLIN
  • src
  • libraries
  • BabyLIN
  • publicHeaders
BabyLINReturncodes.h
Go to the documentation of this file.
1 #ifndef BABYLINRETURNCODES_H
2 #define BABYLINRETURNCODES_H
3
4 #if !defined(BL_DLLIMPORT)
5 #if defined(_WIN32) || defined(__WIN32__) || defined(WIN32)
6 #if BUILD_BABYLIN_DLL
7 #define BL_DLLIMPORT __declspec(dllexport)
8 #else /* Not BUILDING_DLL */
9 #define BL_DLLIMPORT
10 #endif /* Not BUILDING_DLL */
11 #else
12 #if BUILD_BABYLIN_DLL
13 #define BL_DLLIMPORT __attribute__((visibility("protected")))
14 #else /* Not BUILDING_DLL */
15 #define BL_DLLIMPORT
16 #endif /* Not BUILDING_DLL */
17 #endif
18 #else
19 // #undef BL_DLLIMPORT
20 // #define BL_DLLIMPORT
21 #endif
22
23 #ifndef DEPRECATED
24 #ifdef _MSC_VER
25 #define DEPRECATED __declspec(deprecated)
26 #elif defined(__GNUC__) | defined(__clang__)
27 #define DEPRECATED __attribute__((__deprecated__))
28 #else
29 #define DEPRECATED
30 #endif
31 #endif
32
33 // ! @brief represents a connection to a BabyLIN-device or one of the channels
34 typedef void* BL_HANDLE;
35 typedef int BL_ADHOC_HANDLE;
36 typedef const char* CPCHAR;
37
48 #define BL_OK 0
49 #define SDF_OK 0
50
51 #define BL_PC_SIDE_ERRORS -100000
52
53 #define BL_RESOURCE_ERROR -100001
54
55 #define BL_HANDLE_INVALID -100002
56
57 #define BL_NO_CONNECTION -100003
58
59 #define BL_SERIAL_PORT_ERROR -100004
60
61 #define BL_CMD_SYNTAX_ERROR -100005
62
63 #define BL_NO_ANSWER -100006
64
65 #define BL_FILE_ERROR -100007
66
67 #define BL_WRONG_PARAMETER -100008
68
69 #define BL_NO_DATA -100009
70
71 #define BL_NO_SDF -100010
72
73 #define BL_DP_MSG_ERROR -100011
74
75 #define BL_SIGNAL_NOT_EXISTENT -100012
76
77 #define BL_SIGNAL_IS_SCALAR -100013
78
79 #define BL_SIGNAL_IS_ARRAY -100014
80
81 #define BL_SDF_INSUFFICIENT_FIRMWARE -100015
82
83 #define BL_ENCODING_NOT_EXISTENT -100016
84
85 #define BL_BUFFER_TOO_SMALL -100017
86
87 #define BL_NO_ANSWER_DATA -100018
88
89 #define BL_ANSWER_DATA_NOT_EXISTENT -100019
90
91 #define BL_NO_CHANNELS_AVAILABLE -100020
92
93 #define BL_UNKNOWN_COMMAND -100021
94
95 #define BL_TIMEOUT -100022
96
98 #define BL_SDF_INCOMPATIBLE -100023
99
100 #define SDF_HANDLE_INVALID -100024
101
102 #define SDF_IN_USE -100025
103
104 #define BL_DOWNLOAD_IN_PROGRESS -100026
105
106 #define BL_INVALID_MODE -100027
107
109 #define BLC_UA_EXECUTION_FAILED -100093
110
111 #define BLC_UA_INVALID_PARAMETER_COUNT -100094
112
113 #define BLC_UA_GET_VALUE_REJECTED -100095
114
116 #define BLC_UA_INVALID_PARAMETER -100096
117
119 #define BLC_UA_NO_GETTER_DEFINED -100097
120
122 #define BLC_UA_NO_SETTER_DEFINED -100098
123
124 #define BLC_UA_SET_VALUE_REJECTED -100099
125
129 #define BLC_UA_NOT_RESOLVABLE_TAG_FIRST -100100
130
131 #define BLC_UA_NOT_RESOLVABLE_TAG_MAX -100200
132
133 #define BLC_UA_NO_REQUEST_DATA -100201
134
135 #define BLC_UA_SERVICE_FRAME_ORDER -100202
136
138 #define BLC_UA_SERVICE_TIMEOUT_SEND -100203
139
141 #define BLC_UA_SERVICE_TIMEOUT_RESPONSE -100204
142
144 #define BLC_UA_SERVICE_TIMEOUT_FLOWCONTROL_SEND -100205
145
146 #define BLC_UA_SERVICE_FLOWCONTROL_INVALIDSTATE -100206
147
148 #define BLC_UA_SERVICE_FLOWCONTROL_WAITSTATES -100207
149
150 #define BLC_UA_SERVICE_FLOWCONTROL_OVERFLOW -100208
151
152 #define BLC_UA_SERVICE_TIMEOUT_FLOWCONTROL_RECEIVE -100209
153
154 #define BLC_UA_SERVICE_FRAME_PACKAGING_ERROR -100210
155
160 #define BLC_UA_REQUESTED_OBJECT_NOT_FOUND_FIRST -101100
161
162 #define BLC_UA_REQUESTED_OBJECT_NOT_FOUND_MAX -101200
163
164 //
165 // ADHOC PROTOCOL ERROR CODES
166 //
167 #define BLC_ADHOC_INVALID_HANDLE -1
168 #define BLC_ADHOC_EXECUTE_RUNNING -102000
169 #define BLC_ADHOC_MCR_OFFSET 71000
170
171 //
172 // LUA RUNTIME ERROR CODES
173 //
174 #define BLC_LUA_RUNTIME_ERROR -103000
175
176 //----------------------------------------------------------------------------------------
177 //----------------------------------------------------------------------------------------
178 //-------Return Values from BabyLIN Devices-----------------------------------------------
179 //----------------------------------------------------------------------------------------
180 //----------------------------------------------------------------------------------------
181
183 #define BL_ERR_SDF_HEADER 98
184
185 #define BL_ERR_DP_CORRUPT 101
186
187 #define BL_ERR_DP_SEQUENCE 102
188
189 #define BL_ERR_DP_MAPPING 103
190
191 #define BL_ERR_CHANNEL 104
192
193 #define BL_ERR_SECTION_TYPE 105
194
195 #define BL_ERR_NULLPOINTER 106
196
197 #define BL_ERR_SECTION_MAPPING 107
198
199 #define BL_ERR_DATAFLASH_INIT 108
200
201 #define BL_ERR_DATAFLASH_INDEX 109
202
203 #define BL_ERR_DATAFLASH_NOSPACE 110
204
205 #define BL_ERR_DATAFLASH 111
206
207 #define BL_ERR_LICENCE 112
208
209 #define BL_ERR_HEAP_EXHAUSTED 113
210
211 #define BL_ERR_SIG_REFERENCE 114
212
213 #define BL_ERR_FRAME_REFERENCE 115
214
215 #define BL_ERR_CFG_REFERENCE 116
216
217 #define BL_ERR_MACROSEL_REFERENCE 117
218
219 #define BL_ERR_EVENT_REFERENCE 118
220
221 #define BL_ERR_SIGFUNC_REFERENCE 119
222
223 #define BL_ERR_CRC 120
224
225 #define BL_ERR_NOT_INITIALIZED 121
226
227 #define BL_ERR_FRAMEID_LOOKUP_FAILED 122
228
229 #define BL_ERR_MACRO_REFERENCE 130
230
231 #define BL_ERR_PARAMVALUE 200
232
233 #define BL_ERR_CONDITION 210
234
235 #define BL_ERR_PARAMCOUNT 211
236
237 #define BL_ERR_SERVICEQUEUE_EXHAUSTED 300
238
240 #define BL_ERR_DP_PARSE 900
241
242 #define BL_ERR_DP_PARSE_TOP 980
243
244 #define BL_ERR_DP_ARRAY_SIZE 989
245
246 #define BL_ERR_DP_NONAME 990
247
248 #define BL_ERR_DP_NAME_TO_SHORT 991
249
251 #define BL_ERR_DP_NAME_TO_LONG 992
252
253 #define BL_CMD_NOT_SUPPORTED 997
254
255 #define BL_ERR_UNDEF 998
256
257 #define BL_ERR_UNKNOWN_CMD 999
258
259 #define BL_OPERATION_PENDING -1
260
261 #define BL_MACRO_STILL_RUNNING 150
262
263 #define BL_MACRO_SAME_RUNNING 151
264
265 #define BL_MACRO_OTHER_RUNNING 152
266
267 #define BL_MACRO_START_FAIL 153
268
269 #define BL_MACRO_NEVER_EXECUTED 154
270
271 #define BL_MACRO_ERRCODE_IN_RESULT 155
272
273 #define BL_MACRO_EXCEPTIONCODE_IN_RESULT 156
274
280 typedef enum {
282 BL_ANSWER_TYPE_INT,
284 BL_ANSWER_TYPE_STR,
286 BL_ANSWER_TYPE_BIN,
288 BL_ANSWER_TYPE_INT64,
290 BL_ANSWER_TYPE_FLOAT,
292 BL_ANSWER_TYPE_UNKNOWN,
293 } BL_ANSWER_TYPE;
294
300 typedef enum {
302 LD_COMPLETED = 0,
304 LD_FAILED,
306 LD_IN_PROGRESS,
307 } BL_DTL_STATUS;
308
309 #endif // BABYLINRETURNCODES_H
LD_COMPLETED
Definition: BabyLINReturncodes.h:302
BL_DTL_STATUS
BL_DTL_STATUS
DTL protocol status answers. Part of BLC_DTL data structure. Retrieve status of pending DTL actions u...
Definition: BabyLINReturncodes.h:300
BL_ANSWER_TYPE_STR
Definition: BabyLINReturncodes.h:284
LD_FAILED
Definition: BabyLINReturncodes.h:304
BL_ANSWER_TYPE_BIN
Definition: BabyLINReturncodes.h:286
BL_ANSWER_TYPE
BL_ANSWER_TYPE
type of an answer data token retrieve type using BLC_getAnswerTypeByName or BLC_getAnswerTypeByIndex ...
Definition: BabyLINReturncodes.h:280
BL_HANDLE
void * BL_HANDLE
Definition: BabyLINReturncodes.h:34
BL_ADHOC_HANDLE
int BL_ADHOC_HANDLE
Definition: BabyLINReturncodes.h:35
BL_ANSWER_TYPE_INT
Definition: BabyLINReturncodes.h:282
BL_ANSWER_TYPE_INT64
Definition: BabyLINReturncodes.h:288
CPCHAR
const char * CPCHAR
Definition: BabyLINReturncodes.h:36
LD_IN_PROGRESS
Definition: BabyLINReturncodes.h:306
BL_ANSWER_TYPE_FLOAT
Definition: BabyLINReturncodes.h:290
BL_ANSWER_TYPE_UNKNOWN
Definition: BabyLINReturncodes.h:292
Generated on Fri May 30 2025 17:16:13 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: C:/JenkinsWS/workspace/orks_v2_LinWorksv2_Windows_trunk/source/externals/BabyLIN/src/libraries/BabyLIN/publicHeaders/BabyLINSDF.h File Reference

  • externals
  • BabyLIN
  • src
  • libraries
  • BabyLIN
  • publicHeaders
Typedefs | Functions
BabyLINSDF.h File Reference
#include "BabyLINReturncodes.h"

Go to the source code of this file.

Typedefs

typedef void * | BL_HANDLE
typedef const char * | CPCHAR

Functions

int BL_DLLIMPORT | BL_SDF_getNodeNr (BL_HANDLE handle, const char *name)
int BL_DLLIMPORT | BL_SDF_getSignalNr (BL_HANDLE handle, const char *name)
int BL_DLLIMPORT | BL_SDF_getFrameNr (BL_HANDLE handle, const char *name)
int BL_DLLIMPORT | BL_SDF_getScheduleNr (BL_HANDLE handle, const char *name)
int BL_DLLIMPORT | BL_SDF_getNumSchedules (BL_HANDLE handle)
CPCHAR BL_DLLIMPORT | BL_SDF_getScheduleName (BL_HANDLE handle, int schedule_nr)
int BL_DLLIMPORT | BL_SDF_getMacroNr (BL_HANDLE handle, const char *name)

Typedef Documentation

typedef void* BL_HANDLE

Definition at line 8 of file BabyLINSDF.h.

typedef const char* CPCHAR

Definition at line 9 of file BabyLINSDF.h.

Generated on Fri May 30 2025 17:16:13 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: C:/JenkinsWS/workspace/orks_v2_LinWorksv2_Windows_trunk/source/externals/BabyLIN/src/libraries/BabyLIN/publicHeaders/BabyLINSDF.h Source File

  • externals
  • BabyLIN
  • src
  • libraries
  • BabyLIN
  • publicHeaders
BabyLINSDF.h
Go to the documentation of this file.
1 #ifndef BABYLINSDF_H
2 #define BABYLINSDF_H
3
4 #include "BabyLINReturncodes.h"
5
6 // ! @brief represents a connection to a BabyLIN-device ( for old BabyLINs ) or
7 // one of the channels on new BabyLIN-devices
8 typedef void* BL_HANDLE;
9 typedef const char* CPCHAR;
10
11 #if defined(__cplusplus)
12 extern "C" {
13 #endif
14
25 // ! Get the SDF's number for node by name.
32 int BL_DLLIMPORT BL_SDF_getNodeNr(BL_HANDLE handle, const char* name);
33
34 // ! Get the SDF's number for signal by name.
41 int BL_DLLIMPORT BL_SDF_getSignalNr(BL_HANDLE handle, const char* name);
42
43 // ! Get the SDF's number for frame by name.
50 int BL_DLLIMPORT BL_SDF_getFrameNr(BL_HANDLE handle, const char* name);
51
52 // ! Get the SDF's number for schedule by name.
59 int BL_DLLIMPORT BL_SDF_getScheduleNr(BL_HANDLE handle, const char* name);
60
61 // ! Get the number of schedule tables in the SDF.
66 int BL_DLLIMPORT BL_SDF_getNumSchedules(BL_HANDLE handle);
67
68 // ! Get the SDF's name of schedule by number.
75 CPCHAR BL_DLLIMPORT BL_SDF_getScheduleName(BL_HANDLE handle, int schedule_nr);
76
77 // ! Get the SDF's number for macro by name.
84 int BL_DLLIMPORT BL_SDF_getMacroNr(BL_HANDLE handle, const char* name);
85
88 #if defined(__cplusplus)
89 } // extern "C"
90 #endif
91
92 #endif // BABYLINSDF_H
CPCHAR
const char * CPCHAR
Definition: BabyLINSDF.h:9
BL_SDF_getFrameNr
int BL_DLLIMPORT BL_SDF_getFrameNr(BL_HANDLE handle, const char *name)
BL_SDF_getScheduleNr
int BL_DLLIMPORT BL_SDF_getScheduleNr(BL_HANDLE handle, const char *name)
BL_HANDLE
void * BL_HANDLE
Definition: BabyLINReturncodes.h:34
BL_SDF_getSignalNr
int BL_DLLIMPORT BL_SDF_getSignalNr(BL_HANDLE handle, const char *name)
BL_DLLIMPORT
#define BL_DLLIMPORT
Definition: BabyLINReturncodes.h:9
BL_SDF_getScheduleName
CPCHAR BL_DLLIMPORT BL_SDF_getScheduleName(BL_HANDLE handle, int schedule_nr)
BabyLINReturncodes.h
CPCHAR
const char * CPCHAR
Definition: BabyLINReturncodes.h:36
BL_SDF_getMacroNr
int BL_DLLIMPORT BL_SDF_getMacroNr(BL_HANDLE handle, const char *name)
BL_HANDLE
void * BL_HANDLE
Definition: BabyLINSDF.h:8
BL_SDF_getNumSchedules
int BL_DLLIMPORT BL_SDF_getNumSchedules(BL_HANDLE handle)
BL_SDF_getNodeNr
int BL_DLLIMPORT BL_SDF_getNodeNr(BL_HANDLE handle, const char *name)
Generated on Fri May 30 2025 17:16:13 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: markdowns/commands.md File Reference

markdowns/commands.md File Reference

Go to the source code of this file.

Generated on Fri May 30 2025 17:16:13 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: markdowns/commands.md Source File

markdowns/commands.md
Go to the documentation of this file.
1 # Available commands
2 @ingroup Commands Available commands
3
4 BabyLIN commands to use in BL_- and BLC_sendCommand Functions {#babylin_commands}
5 ========
6
7 This chapter gives a brief overview of the available BabyLIN commands to use in the sendCommand functions of the BabyLIN API. The table uses statements in the following syntax:
8
9 [TOC]
10
11 <div class="alignmiddle">
12 | Symbol | Description|
13 | :-----------: | :-----------|
14 | [ ... ] | Optional parameter |
15 | <[type:]name> | Parameter "name" of type "type". If omitted, type defaults to an integer value|
16 | \| | Exclusive "or" of parameters. The user may specify one parameter out of the list.|
17 | **bold text** | Reserved keyword. In the Response, these texts can be used as name parameter in calls to @ref BLC_getAnswerByName and @ref BLC_getAnswerTypeByName |
18 | (...) | A group of parameters, used together with the exclusive "or" for more complex message definitions. |
19 | {[min],[max]} | This indicates the repetition of the previous parameter or parameter group. min/max stands for the minimal/maximal amount of repetitions. If only one number is given it specified min and max value, thus the number of repetitions must match exactly. |
20 </div>
21
22 The first response parameter will be returned by @ref BLC_sendCommand or @ref BL_sendCommand. <br>
23 If in the column response is given OK/Err, this mean the first return value will indicates the operation result 0 = OK anything != 0 will typically be an error.
24 To access the remaining response parameters use the functions @ref BLC_getAnswerByIndex, @ref BLC_getAnswerTypeByIndex, @ref BLC_getAnswerByName or @ref BLC_getAnswerTypeByName.
25
26 # Generic Commands # {#babylin_commands_generic}
27
28
29 <div class="alignmiddle">
30 <table class="doxtable">
31 <tr>
32 <th width="320px">Command</th>
33 <th width="200px">Response</th>
34 <th> Description </th>
35 <th> Supported Channel</th>
36 </tr>
37 <tr>
38 <td align="left" style="vertical-align:top">
39 <b>version</b></td>
40 <td align="center" style="vertical-align:top">\<version\></td>
41 <td align="left">
42 Reads firmware version of Baby-LIN.<br/>
43 example of interpretation of "version":<br/>
44 &nbsp;&nbsp; decimal value 311 = V.3.11
45 </td>
46 <td align="center" style="vertical-align:top">DEVICE</td>
47 </tr>
48 <tr>
49 <td align="left" style="vertical-align:top">
50 <b>reset</b></td>
51 <td align="center" style="vertical-align:top">OK | Error</td>
52 <td align="left">
53 <ul>
54 <li> LIN: All loaded configurations are deleted, LIN bus operation stops immediately. </li>
55 <li> CAN: All loaded configurations are deleted, CAN controller is switched off. </li>
56 </ul>
57 </td>
58 <td align="center" style="vertical-align:top">DEVICE</td>
59 </tr>
60 <tr>
61 <td align="left" style="vertical-align:top">
62 <b>reboot</b></td>
63 <td align="center" style="vertical-align:top">OK | Error</td>
64 <td align="left">
65 Target will execute same operations as on Power-On Reset.
66 Commands following this command might timeout until the Device is ready for communication again.
67 The Devices internal states are changed and thus new devices might be in state in which they are emulating an old device for some time.
68 </td>
69 <td align="center" style="vertical-align:top">DEVICE</td>
70 </tr>
71 <tr>
72 <td align="left" style="vertical-align:top">
73 <b>silence</b> [\<time\>]</td>
74 <td align="center" style="vertical-align:top">OK | Err</td>
75 <td align="left">
76 Set BabyLIN to silence mode for specified time [ms]
77 <ul>
78 <li>no time BabyLIN will stop sending frame-/signal- reports</li>
79 <li>time = 0: BabyLIN will send frame-/signal- reports</li>
80 <li>time = 1...n: BabyLIN will stop sending for n milliseconds</li>
81 </ul>
82 </td>
83 <td align="center" style="vertical-align:top">DEVICE</td>
84 </tr>
85 <tr>
86 <td align="left" style="vertical-align:top">
87 <b>targetcfg_wr</b> \<idx\> \<value\></td>
88 <td align="center" style="vertical-align:top">OK | Err</td>
89 <td align="left">
90 Writes the target configuration variable with index idx with the given value. idx may range in [0;63]
91 </td>
92 <td align="center" style="vertical-align:top">DEVICE</td>
93 </tr>
94 <tr>
95 <td align="left" style="vertical-align:top">
96 <b>targetcfg_rd</b> \<idx\></td>
97 <td align="center" style="vertical-align:top">\<value\></td>
98 <td align="left">
99 Reads target configuration variable with index idx idx may range in [0;63]
100 The available target configuration variables are listed in appendix 12.4.
101 </td>
102 <td align="center" style="vertical-align:top">DEVICE</td>
103 </tr>
104 <tr>
105 <td align="left" style="vertical-align:top">
106 <b>targetid</b></td>
107 <td align="center" style="vertical-align:top">
108 OK | Error
109 <ul>
110 <li><b>hwtype</b> \<hwtype\></li>
111 <li><b>version</b> \<version\></li>
112 <li><b>build</b> \<build\></li>
113 <li><b>flags</b> \<flags\></li>
114 <li><b>snum</b> \<snum\></li>
115 <li><b>heap</b> \<heap\></li>
116 <li><b>spare</b> \<channelCount\></li>
117 <li><b>name</b> \<name\></li>
118 </ul>
119 </td>
120 <td align="left">
121 Request info about the BabyLIN device (target). Use the bold key words in calls to @ref BLC_getAnswerByName and @ref BLC_getAnswerTypeByName, or use @ref BLC_getTargetID function to read this information.<br>
122 The hwtype is the hardwaretype of the BabyLIN device. Might differ from the result of the <b>hwtype</b> command while a new device simulates an old one.<br>
123 The version is the firmware version of the BabyLIN device.<br>
124 The build is the firmware build number of the BabyLIN device.<br>
125 The flags is a bit map currently only consisting of bit 0, which when set indicates, that the loaded firmware is a test version.<br>
126 The snum is the serial number of the BabyLIN device.<br>
127 The heap is the maximum heap size of the BabyLIN device.<br>
128 The channelCount the number of channels available on the BabyLIN device.<br>
129 The name is the name of the BabyLIN device.<br>
130 </td>
131 <td align="center" style="vertical-align:top">DEVICE</td>
132 </tr>
133 <tr>
134 <td align="left" style="vertical-align:top">
135 <b>hwtype</b></td>
136 <td align="center" style="vertical-align:top">\<hwtype\></td>
137 <td align="left">
138 Request the hardwaretype of the BabyLIN device.
139 The hwtype is the true Hardwaretype of the BabyLIN device.
140 This command is wrapped in @ref BLC_getHWType.
141 </td>
142 <td align="center" style="vertical-align:top">DEVICE</td>
143 </tr>
144 <tr>
145 <td align="left" style="vertical-align:top">
146 <b>licrd</b>
147 </td>
148 <td align="center" style="vertical-align:top">
149 OK | Err
150 <ul>
151 <li>\<optioncount\></li>
152 <li>(\<optionnum\> \<flags\>){0, optioncount}</li>
153 </ul>
154 </td>
155 <td align="left">
156 Read status of activated BabyLIN options. Use @ref BLC_getAnswerByIndex to read through the response parameters.<br>
157 Response will carry \<optioncount\> pairs of option number and option flags.<br>
158 flags & 0x80 = 0x80 => option is disabled.
159 </td>
160 <td align="center" style="vertical-align:top">DEVICE</td>
161 </tr>
162 <tr>
163 <td align="left" style="vertical-align:top">
164 <b>licwr</b> \<string: code\>
165 </td>
166 <td align="center" style="vertical-align:top">
167 OK | Err
168 </td>
169 <td align="left">
170 Send an activation code for an option to the BabyLIN device.
171 </td>
172 <td align="center" style="vertical-align:top">DEVICE</td>
173 </tr>
174 <tr>
175 <td align="left" style="vertical-align:top">
176 <b>licoffon</b> \<number\> \<offon\>
177 </td>
178 <td align="center" style="vertical-align:top">
179 Ok | Err
180 </td>
181 <td align="left">
182 Enable or disable the installed licence with number \<number\>. <br>
183 If \<offon\> is 0, the licence will be disabled.<br>
184 If \<offon\> is 1, the licence will be enabled.
185 </td>
186 <td align="center" style="vertical-align:top">DEVICE</td>
187 </tr>
188 <tr>
189 <td align="left" style="vertical-align:top">
190 <b>tstampzero</b>
191 </td>
192 <td align="center" style="vertical-align:top">
193 OK | Err
194 </td>
195 <td align="left">
196 This command will reset the targets absolute 32 bit us timestamp to zero.<br>
197 Older target firmware version might not support this command.
198 </td>
199 <td align="center" style="vertical-align:top">DEVICE</td>
200 </tr>
201 <tr>
202 <td align="left" style="vertical-align:top">
203 <b>persistent_rd </b>\<number\>
204 </td>
205 <td align="center" style="vertical-align:top">
206 OK | Error
207 <ul>
208 <li>\<value of variable\></li>
209 </ul>
210 </td>
211 <td align="left">
212 Read the value of device global accessible and persistent variable \<number\>.
213 Use @ref BLC_getAnswerByIndex to read through the response parameters.
214 </td>
215 <td align="center" style="vertical-align:top">DEVICE</td>
216 </tr>
217 <tr>
218 <td align="left" style="vertical-align:top">
219 <b>persistent_wr</b> \<number\> [\<value\>]
220 </td>
221 <td align="center" style="vertical-align:top">
222 Ok | Err
223 </td>
224 <td align="left">
225 set the value of device global accessible and persistent variable \<number\> to value \<value\>.
226 If \<value\> is omitted, the variable will be unset.
227 </td>
228 <td align="center" style="vertical-align:top">DEVICE</td>
229 </tr>
230 <tr>
231 <td align="left" style="vertical-align:top">
232 <b>output</b> \<number\> \<onoff\>
233 </td>
234 <td align="center" style="vertical-align:top">
235 OK|Err
236 </td>
237 <td align="left">
238 Set digital output state of ouptut \<number\> to
239 <ul>
240 <li>onoff = 1 output state "on"</li>
241 <li>onoff = 0 output state "off"</li>
242 </ul>
243 </td>
244 <td align="center" style="vertical-align:top">DEVICE</td>
245 </tr>
246 <tr>
247 <td align="left" style="vertical-align:top">
248 <b>factoryreset</b>
249 </td>
250 <td align="center" style="vertical-align:top">
251 Ok | Err
252 </td>
253 <td align="left">
254 Reset the device to it's factory state (i.e. remove all installed licences).
255 This might also involve a Reset of the device.
256 </td>
257 <td align="center" style="vertical-align:top">DEVICE</td>
258 </tr>
259 <tr>
260 <td align="left" style="vertical-align:top">
261 <b>ascii</b> <timeout></td>
262 <td align="center" style="vertical-align:top">no response !</td>
263 <td align="left">
264 Switches Baby-LIN to ASCII command API. See chapter ASCII command mode.
265 The optional parameter timeout will cause the Baby-LIN unit to switch back to the DPMSG based API after the
266 given timeout period elapsed without any character reception from the PC. The timeout is given in msec.
267 </td>
268 <td align="center" style="vertical-align:top">DEVICE</td>
269 </tr>
270 <tr>
271 <td align="left" style="vertical-align:top">
272 <b>readspeed</b></td>
273 <td align="center" style="vertical-align:top"><speed></td>
274 <td align="left">
275 Read the actual used BUS speed. If this command is issued after a mon_init 0 command,
276 return speed=0 until Baby-LIN managed to detect the actual bus speed.
277 </td>
278 <td align="center" style="vertical-align:top">LIN/CAN</td>
279 </tr>
280 <tr>
281 <td align="left" style="vertical-align:top">
282 <b>writespeed</b> <speed></td>
283 <td align="center" style="vertical-align:top">OK | Err</td>
284 <td align="left">
285 Sets bus speed to given value (bits/second), the value is not checked!
286 On LIN buses The new speed is only applied after the next bus start command, and thus can only be used in SDF mode.
287 </td>
288 <td align="center" style="vertical-align:top">LIN/CAN</td>
289 </tr>
290 <tr>
291 <td align="left" style="vertical-align:top">
292 <b>inject</b> <flags> <frameid> [<datasize>] <bytearray:data> <delay> <count> [<b>fill</b> <fillbyte>]
293 </td>
294 <td align="center" style="vertical-align:top">
295 OK | Err
296 </td>
297 <td align="left">
298 Inject a frame into the currently running schedule or CAN-simulation.
299 <ul>
300 <li> flags: Bitmask
301 <ul>
302 <li>LIN: <ul>
303 <li>Bits[0,1] 0x3: Lin Checksum Version:<ul>
304 <li> 1 : Classic Checksum</li>
305 <li> 2 : Extended Checksum</li>
306 <li> 3 : Undefined Checksum</li>
307 </ul></li>
308 <li>Bit2 0x4: Read frame (Send only the header)</li>
309 <li>Bit3 0x8: Isolated Frame does not change data of SDF-Frames</li>
310 </ul></li>
311 <li>CAN: <ul>
312 <li>Bit0 0x1: Use a 29Bit frame Id</li>
313 <li>Bit1 0x2: CAN-FD frame format</li>
314 <li>Bit3 0x8: Isolated Frame does not change data of SDF-Frames</li>
315 <li>Bit4 0x10: Enable baudrate-switching, only apply together with CAN-FD frame format</li>
316 </ul></li>
317 </ul>
318 </li>
319 <li> frameid = Identifier of the frame</li>
320 <li> datasize = size of the frame to send, only required for read frames or if the frame length should diverge from the length of the length of the given <data> array. Readframes with empty datasize are not supported by CAN </li>
321 <li> data = Bytearray ( if LIN-Readframe leave empty and specify <i><datasize></i> )</li>
322 <li> delay = Slottime for injected frame in milliseconds [ms]. A slottime of 0 will automatically cumpute the minimal slottime.</li>
323 <li> count specifies the number of injected frames which have to be issued to the Baby-LIN, before the first injection will start. This parameter allows to issue multiple inject commands and to make sure that all frames will be injected consecutive.
324 In such a case the first inject command might have a count value of 8, the other will have a count value of 0.
325 The amount of Injects bufferable Is dependant on the device.</li>
326 <li> fillbyte is the padding byte value, that will be used if <datasize> is bigger then the length of <data>.</li>
327 </ul>
328 <i>Readframe-example: "inject 0x05 20 6 [] 1000 0;" - Inject frame with ID 20 as Readframe. Use slottime 1000ms and send immediately. Expect 6 bytes as frame data with classic checksum.</i>
329 <p><b>SDFV2 devices do not support read frames</b></p>
330 </td>
331 <td align="center" style="vertical-align:top">LIN/CAN</td>
332 </tr>
333 <tr>
334 <td align="left" style="vertical-align:top">
335 <b>pullup</b> <<b>master</b> | <b>slave</b> | <b>auto</b> >
336 </td>
337 <td align="center" style="vertical-align:top">OK | Err</td>
338 <td align="left">
339 Configures the LIN bus pull-up resistor of the Baby-LIN device:
340 <ul>
341 <li>master => pull-up set to 1.12kOhm</li>
342 <li>slave => pull-up set to 30kOhm</li>
343 <li>auto => pull-up automatically set by BabyLIN</li>
344 </ul>
345 If a SDF configuration is used, the pull-up selection will happen automatically, depending on the emulation data setup.
346 In case of such an automatic configuration the command pull-up will override the automatic selection.
347 When loading a SDF, or entering monitor mode using "mon_init", the BabyLIN will be reset to "pullup auto".
348 </td>
349 <td align="center" style="vertical-align:top">LIN</td>
350 </tr>
351 <tr>
352 <td align="left" style="vertical-align:top">
353 <b>forcechecksum</b> <mode>
354 </td>
355 <td align="center" style="vertical-align:top">
356 OK | Err
357 </td>
358 <td align="left">
359 forces the LIN checksum generator to use a specific model independant from SDF information.
360 <ul>
361 <li>mode = 0: use SDF information</li>
362 <li>mode = 1: use classic checksum</li>
363 <li>mode = 2: use enhanced checksum</li>
364 </ul>
365 </td>
366 <td align="center" style="vertical-align:top">LIN</td>
367 </tr>
368 <tr>
369 <td align="left" style="vertical-align:top"><b>hwstate</b></td>
370 <td align="center" style="vertical-align:top"><status></td>
371 <td align="left">
372 Returns state of LIN Bus Voltage
373 <ul>
374 <li>status = 0: Bus supply is off</li>
375 <li>status = 1: Bus supply is present</li>
376 </ul>
377 </td>
378 <td align="center" style="vertical-align:top">LIN</td>
379 </tr>
380 <tr>
381 <td align="left" style="vertical-align:top"><b>status</b></td>
382 <td align="center" style="vertical-align:top"><status></td>
383 <td align="left">
384 Read status of referred channel, actually supported for LIN channels only, other channels always return 0.
385 <ul>
386 <li>0 disconnected from bus</li>
387 <li>1 sleep mode</li>
388 <li>2 waking up</li>
389 <li>3 detecting bus speed</li>
390 <li>4 connecting to bus</li>
391 <li>5 connected to bus</li>
392 <li>6 disconnecting from bus</li>
393 <li>7 entering sleep mode</li>
394 </ul>
395 </td>
396 <td align="center" style="vertical-align:top">LIN</td>
397 </tr>
398 <tr>
399 <td align="left" style="vertical-align:top">
400 <b>wakeup</b> [<duration>]
401 </td>
402 <td align="center" style="vertical-align:top">
403 OK | Err
404 </td>
405 <td align="left">
406 Manually wake up BabyLIN from sleep.
407 <ul>
408 <li>duration => The duration of the wakeup pulse in us. If <duration> is omitted, the value will be 500us.</li>
409 </ul>
410 </td>
411 <td align="center" style="vertical-align:top">LIN</td>
412 </tr>
413
414 <tr>
415 <td align="left" style="vertical-align:top">
416 <b>rtcget</b>
417 </td>
418 <td align="center" style="vertical-align:top">
419 OK | Err
420 <ul>
421 <li>Year</li>
422 <li>Month</li>
423 <li>Day of month</li>
424 <li>Hour</li>
425 <li>Minute</li>
426 <li>Second</li>
427 <li>Day of week</li>
428 </ul>
429 </td>
430 <td align="left">
431 Return the RTC time of the device. Use @ref BLC_getAnswerByIndex to read through the response parameters.
432 </td>
433 <td align="center" style="vertical-align:top">DEVICE</td>
434 </tr>
435
436 <tr>
437 <td align="left" style="vertical-align:top">
438 <b>rtcset</b> <year> <month> <dayOfMonth> <hour> <minute> <second>
439 </td>
440 <td align="center" style="vertical-align:top">
441 OK | Err
442 </td>
443 <td align="left">
444 Set the RTC time of the device.
445 </td>
446 <td align="center" style="vertical-align:top">DEVICE</td>
447 </tr>
448
449 <tr>
450 <td align="left" style="vertical-align:top">
451 <b>tagwrite</b> <tag_id> <tag_value> [<write_secret>] [<read_secret>]
452 </td>
453 <td align="center" style="vertical-align:top">
454 <value> | Err
455 </td>
456 <td align="left">
457 Writes the specified value into a custom tag in the device.<br>
458 When the "read_secret" parameter is set, you need to set this secret every time you want to read the value using "tagread", or you will get an error.<br>
459 When you set the "write_secret" parameter, you can only overwrite the value by specifing this secret again in the next "tagwrite" command.<br>
460 To overwrite the current "write_secret" you need the use the string "OverwritePasswordWr=<current write secret>" as the "value" parameter and put the new "write_secret" into the "write_secret" parameter.<br>
461 </td>
462 <td align="center" style="vertical-align:top">ANY</td>
463 </tr>
464
465 <tr>
466 <td align="left" style="vertical-align:top">
467 <b>tagread</b> <tag_id> [<read_secret>]
468 </td>
469 <td align="center" style="vertical-align:top">
470 OK | Err
471 </td>
472 <td align="left">
473 Reads the value of a custom tag stored in the device.<br>
474 You might need to set the "read_secret" parameter, if the tag was written with a "read_secret" set.
475 </td>
476 <td align="center" style="vertical-align:top">ANY</td>
477 </tr>
478
479 </table>
480 </div>
481
482
483 # Monitor Commands # {#babylin_commands_monitor}
484 <div class="alignmiddle">
485 <table class="doxtable">
486 <tr>
487 <th width="320px">Command</th>
488 <th width="200px">Response</th>
489 <th> Description </th>
490 <th> Supported Channel</th>
491 </tr>
492 <tr>
493 <td align="left" style="vertical-align:top">
494 <b>mon_init</b> <baudrate> [<mastermode/sendack> [<data_baudrate>]]
495 </td>
496 <td align="center" style="vertical-align:top">
497 OK | Err
498 </td>
499 <td align="left">
500 This command enables the Baby-LIN for non-SDF based operation. Once given, the following monitor commands will be available.<br>
501 A previous loaded SDF configuration on this channel will be destroyed, configurations on other channels remain.
502 <ul>
503 <li> The baudrate parameter supplied is the baud rate for the bus. If this parameter is set to 0, the Baby-LIN will enter a hardware synchronisation mode, where it tries to auto-detect the speed of the bus. This will require active communication on the bus to work properly.</li>
504 <li>LIN:
505 <ul>
506 <li>If the optional parameter <mastermode> on LIN is given with a value of 1, the device will allow sending data in monitor mode.</li>
507 </ul>
508 </li>
509 <li>CAN:
510 <ul>
511 <li>For CAN, the optional <sendack> parameter set to 1 will send ACKs for every CAN-frame on the bus. </li>
512 <li>The optional <data_baudrate> is only valid for CAN channels which support CAN-FD communication. It can only be specified together with the <sendack> parameter. This baud rate will be used during the data phase of a frame with active "baudrate switch" flag.</li>
513 </ul>
514 </li>
515 </ul>
516 See also the mon_frame and inject commands, how to define the data for the frames sent in this mode.<br><br>
517 <b>Note: Baby-LIN-3-ECO/KS1</b><br>
518 When using the SDF-based operation mode, issuing a bus start command will automatically enable the generator if no external bus voltage has been detected.<br>
519 For this monitor mode, this is not done automatically.
520 If you do not supply the bus externally, you can enable the generator by sending the command 'sysvar_wr @@SYSCFG17 1' to the LIN channel.<br>
521 </td>
522 <td align="center" style="vertical-align:top">LIN/CAN</td>
523 </tr>
524 <tr>
525 <td align="left" style="vertical-align:top">
526 <b>mon_on</b> <frameid> <mode>
527 </td>
528 <td align="center" style="vertical-align:top">
529 OK | Err
530 </td>
531 <td align="left">
532 The parameter supplied specifies the frame ID of the frame which should be monitored by the Baby-LIN device. <br>
533 <ul>
534 <li>If ALL DEFINED frameIds should be monitored, bit 30 of the frameId should be set to 1 (i.e. frameId = 0x40000000 )</li>
535 <li>If ALL UNDEFINED frameIds should be monitored, bit 31 of the frameId should be set to 1 (i.e. frameId = 0x80000000 )</li>
536 <li>If ALL frameIds (defined and undefined) should be monitored, bit 31 and 30 of the frameId should be set to 1 (i.e. frameId = 0xC0000000 )</li>
537 <li>To denote a 29bit CAN-Frame-Id, set bit 29 ( mask 0x20000000 ).</li>
538 </ul>
539 Note: If all frames are monitored, it is not possible to use mon_off on single frame-ids. There is no "blacklisting" in "all-frame"-mode.
540 For LIN channels monitoring of all frames can also be activated by setting frameid to 255.
541 The optional mode parameter can have the following values:
542 <ul>
543 <li> mode = 0: same as mon_off (stop reporting) </li>
544 <li> mode = 1: report on every occurrence, this is the default </li>
545 <li> mode = 3: report only on change </li>
546 </ul>
547 </td>
548 <td align="center" style="vertical-align:top">LIN/CAN</td>
549 </tr>
550 <tr>
551 <td align="left" style="vertical-align:top">
552 <b>mon_off</b> <frameid>
553 </td>
554 <td align="center" style="vertical-align:top">
555 OK | Err
556 </td>
557 <td align="left">
558 Removes the given frame ID from the list of monitored frames,
559 <ul>
560 <li>If ALL DEFINED frameIds shouldn't be monitored, bit 30 of the frameId should be set to 1 (i.e. frameId = 0x40000000 )</li>
561 <li>If ALL UNDEFINED frameIds shouldn't be monitored, bit 31 of the frameId should be set to 1 (i.e. frameId = 0x80000000 )</li>
562 <li>If ALL frameIds (defined and undefined) shouldn't be monitored, bit 30 and 31 of the frameId should be set to 1 (i.e. frameId = 0xC0000000 )</li>
563 <li>To denote a 29bit CAN-Frame-Id, set bit 29 ( mask 0x20000000 ).</li>
564 </ul>
565 For LIN channels monitoring of all frames can also be disabled by setting frameid to 255.
566 </td>
567 <td align="center" style="vertical-align:top">LIN/CAN</td>
568 </tr>
569 <tr>
570 <td align="left" style="vertical-align:top">
571 <b>mon_frame</b> \<frameid\> \<flags\> \<datalength\> [\<data\> {\<datalength\>}]
572 </td>
573 <td align="center" style="vertical-align:top">
574 OK | Err
575 </td>
576 <td align="left">
577 This command is intended to replace the "mon_set" and the "mon_type" command by a single command.<br>
578 Its a complete frame definition including \<data\> bytes and attributes(\<flags\>) (LIN: checksum type, CAN: 11/29 Bit identifier).<br>
579 The \<data\> is the data of the frame, as a list of \<datalength\> bytes.<br>
580 In case the Baby-LIN is in monitor mastermode, it will send the frame, when the mon_xmit command with the correspondng frameid is received.
581 <ul>
582 <li> LIN: Bit[0] flags & 0x01 == 0 Classic checksum</li>
583 <li> LIN: Bit[0] flags & 0x01 == 1 Extended checksum</li>
584 <li> CAN: Bit[0] flags & 0x01 == 0 11 bit identifier</li>
585 <li> CAN: Bit[0] flags & 0x01 == 1 29 bit identifier</li>
586 <li> CAN: Bit[1,2] flags & 0x06 == 0 Regular CAN frame</li>
587 <li> CAN: Bit[1,2] flags & 0x06 == 2 CAN-FD frame</li>
588 <li> CAN: Bit[1,2] flags & 0x06 == 4 CAN-FD frame with bitrate switching</li>
589 </ul>
590 </td>
591 <td align="center" style="vertical-align:top">LIN/CAN</td>
592 </tr>
593 <tr>
594 <td align="left" style="vertical-align:top">
595 <b>mon_xmit</b> \<frameId\> [\<slottime\>]
596 </td>
597 <td align="center" style="vertical-align:top">
598 OK | Err
599 </td>
600 <td align="left">
601 Trigger frame transmit of Frame with id frameId.<br>
602 On LIN channels setting slottime has no effect.<br>
603 On CAN channels, slottime = 0 equals a single transmit, slottime > 0 equals cyclic transmission of frame.
604 <ul>
605 <li>To denote a 29bit CAN-Frame-Id, set bit 31 ( mask 0x80000000 ).</li>
606 <li>If a 29bit frame id has been introduced using mon_frame, the flag 29bit flag is not needed to trasmit a frame (if there is no 11bit frame with the same id)</li>
607 <li>slottime sets the time of a CAN frame and is currently unsupported for LIN bus</li>
608 <li>If more than one LIN frame is emitted with this command, a delay must be inserted manually</li>
609 </ul>
610 <b>Note: Baby-LIN-3-ECO/KS1</b><br>
611 When using the SDF-based operation mode, issuing a bus start command will automatically enable the generator if no external bus voltage has been detected.<br>
612 For this monitor mode, this is not done automatically.
613 If you do not supply the bus externally, you can enable the generator by sending the command 'sysvar_wr @@SYSCFG17 1' to the LIN channel.<br>
614 </td>
615 <td align="center" style="vertical-align:top">LIN/CAN</td>
616 </tr>
617 <tr>
618 <td align="left" style="vertical-align:top">
619 <b>mon_unset</b> \<id\>
620 </td>
621 <td align="center" style="vertical-align:top">
622 OK | Err
623 </td>
624 <td align="left">
625 Stops responding for frame \<id\>.
626 </td>
627 <td align="center" style="vertical-align:top">LIN/CAN</td>
628 </tr>
629 <tr>
630 <td align="left" style="vertical-align:top">
631 <b>mon_reset</b>
632 </td>
633 <td align="center" style="vertical-align:top">
634 OK | Err
635 </td>
636 <td align="left">
637 Removes all objects defined by mon_on and mon_set commands.<br>
638 Configurations made with mon_init are also deleted. The LIN bus speed setting remains valid.
639 </td>
640 <td align="center" style="vertical-align:top">LIN/CAN</td>
641 </tr>
642 <tr>
643 <td align="left" style="vertical-align:top">
644 <b>mon_set</b> \<id\> [\<data\>{0,1024}]
645 </td>
646 <td align="center" style="vertical-align:top">
647 OK | Err
648 </td>
649 <td align="left">
650 Sets ID and data bytes for a frame, which will be responded by Baby-LIN.<br>
651 <ul>
652 <li> Up to 1024 \<data\> values can be given.</li>
653 </ul>
654 <b>Deprecated! use mon_frame instead</b>
655 </td>
656 <td align="center" style="vertical-align:top">LIN</td>
657 </tr>
658 <tr>
659 <td align="left" style="vertical-align:top">
660 <b>mon_type</b> \<LINversion\>
661 </td>
662 <td align="center" style="vertical-align:top">
663 OK | Err
664 </td>
665 <td align="left">
666 Set LIN version (checksum calculation method) for frames defined by mon_set
667 <ul>
668 <li>LINversion = 1 LIN version V.1.2/1.3</li>
669 <li>LINversion = 2 LIN version V.2.0</li>
670 </ul>
671 <b>Deprecated! use mon_frame instead</b>
672 </td>
673 <td align="center" style="vertical-align:top">LIN</td>
674 </tr>
675 </table>
676 </div>
677
678
679 # SDF Related Commands # {#babylin_commands_sdf}
680 <div class="alignmiddle">
681 <table class="doxtable">
682 <tr><th width="320px">Command</th><th width="200px">Response </th><th> Description </th><th> Supported Channel</th></tr>
683 <tr>
684 <td align="left" style="vertical-align:top">
685 <b>start</b> [schedule \<schedule_nr\>]
686 </td>
687 <td align="center" style="vertical-align:top">
688 OK | Err
689 </td>
690 <td align="left">
691 Start BUS simulation. <br>
692 On LIN channels,
693 <ul>
694 <li>"start schedule <schedule_nr>" will start the schedule with number <i>schedule_nr</i>.</li>
695 <li>"start" equals "start schedule 0".</li>
696 <li>"start schedule -1" will start the currently selected schedule and the schedule queue.</li>
697 </ul>
698 All signal values will be reset to the initial values given in the LDF/DBC file.
699 </td>
700 <td align="center" style="vertical-align:top">LIN/CAN</td>
701 </tr>
702 <tr>
703 <td align="left" style="vertical-align:top">
704 <b>stop</b>
705 </td>
706 <td align="center" style="vertical-align:top">
707 OK | Err
708 </td>
709 <td align="left">
710 Stop BUS simulation.
711 </td>
712 <td align="center" style="vertical-align:top">LIN/CAN</td>
713 </tr>
714 <tr>
715 <td align="left" style="vertical-align:top">
716 <b>sleep</b>
717 </td>
718 <td align="center" style="vertical-align:top">
719 OK | Err
720 </td>
721 <td align="left">
722 Issue special Master Request frame ( LIN only ) and stop simulations
723 </td>
724 <td align="center" style="vertical-align:top">LIN</td>
725 </tr>
726 <tr>
727 <td align="left" style="vertical-align:top">
728 <b>schedule</b> \<schedule_number\> [\<int:mode\>]
729 </td>
730 <td align="center" style="vertical-align:top">
731 OK | Err
732 </td>
733 <td align="left">
734 Switch to schedule table specified by schedule_number.
735 (Detailed description is work in progress)
736 If a schedule is running, switching will be scheduled after the current frame's delay.<br>
737 The BabyLIN hast o be configured as master.
738 <ul>
739 <li>Mode = -1: Keep current mode</li>
740 <li>Mode = 0: Cyclic (Default)<br>
741 Schedule Table will be run continuously, switching to another table will happen immediately. (DefaultMode)</li>
742 <li>Mode = 1: SingleRun<br>
743 A table with this attribute will run one time after the "schdeule idx" command. Then the system will wait for another schedule command.
744 Up to 12 schedule commands can be issued without delays, as they will be queued.</li>
745 <li>Mode = 2: ExitOnComplete<br>
746 The schedule table with this attribute will run continuously, but if a switch to another schedule is requested, the switch will
747 always happens after processing the last entry of this table.</li>
748 </ul>
749 </td>
750 <td align="center" style="vertical-align:top">LIN</td>
751 </tr>
752 <tr>
753 <td align="left" style="vertical-align:top">
754 <b>schedmode</b> <schedule_number> <int:mode>
755 </td>
756 <td align="center" style="vertical-align:top">
757 OK | Err
758 </td>
759 <td align="left">
760 Sets the scheduling mode for the given schedule table, without selecting it.
761 <ul>
762 <li>Mode = 0: Cyclic (Default)<br>
763 Schedule Table will be run continuously, switching to another table will happen immediately. (DefaultMode)</li>
764 <li>Mode = 1: SingleRun<br>
765 A table with this attribute will run one time after the "schdeule idx" command. Then the system will wait for another schedule command.
766 Up to 12 schedule commands can be issued without delays, as they will be queued.</li>
767 <li>Mode = 2: ExitOnComplete<br>
768 The schedule table with this attribute will run continuously, but if a switch to another schedule is requested, the switch will
769 always happens after processing the last entry of this table.</li>
770 </ul>
771 </td>
772 <td align="center" style="vertical-align:top">LIN</td>
773 </tr>
774 <tr>
775 <td align="left" style="vertical-align:top">
776 <b>schedmode</b> <schedule_number>
777 </td>
778 <td align="center" style="vertical-align:top">
779 OK | Err
780 <ul>
781 <li><mode></li>
782 </ul>
783 </td>
784 <td align="left">
785 Get the scheduling mode for the given schedulde table. Use @ref BLC_getAnswerByIndex to read through the response parameters.
786 <ul>
787 <li>Mode = 0: Cyclic (Default)<br>
788 Schedule Table will be run continuously, switching to another table will happen immediately. (DefaultMode)</li>
789 <li>Mode = 1: SingleRun<br>
790 A table with this attribute will run one time after the "schdeule idx" command. Then the system will wait for another schedule command.
791 Up to 12 schedule commands can be issued without delays, as they will be queued.</li>
792 <li>Mode = 2: ExitOnComplete<br>
793 The schedule table with this attribute will run continuously, but if a switch to another schedule is requested, the switch will
794 always happens after processing the last entry of this table.</li>
795 </ul>
796 The mode is available using the BLC_getAnswer* functions
797 </td>
798 <td align="center" style="vertical-align:top">LIN</td>
799 </tr>
800 <tr>
801 <td align="left" style="vertical-align:top">
802 <b>schedstate</b>
803 </td>
804 <td align="center" style="vertical-align:top">
805 &gt;0 | Err
806 <ul>
807 <li><running></li>
808 <li><selected></li>
809 <li><queued>{0, 13}</li>
810 </ul>
811 </td>
812 <td align="left">
813 On SDFV3 devices this command returns the schedule execution state. The return value is either 0 for OK or !=0 for an error. Use @ref BLC_getAnswerByIndex to read through the response parameters.
814 <ul>
815 <li>running = 0: no schedule running; running = 1: schedules are running</li>
816 <li>selected: the currently running (if running = 1) - or next to run (if running = 0) - schedule</li>
817 <li>queued: a list of up to 13 schedule numbers queued. Queued schedules will run in their delivered order</li>
818 </ul>
819 On SDFV2 devices, this command returns the last or current schedule running as the return value (&gt;=0) or an error as a return value &lt;0
820 </td>
821 <td align="center" style="vertical-align:top">LIN</td>
822 </tr>
823 <tr>
824 <td align="left" style="vertical-align:top">
825 <b>setnodesimu</b> <node_nr> <onoff>
826 </td>
827 <td align="center" style="vertical-align:top">
828 OK | Err
829 </td>
830 <td align="left">
831 Switches node emulation on/off during run time
832 <ul>
833 <li>LIN: all frames published by the given node will be simulated or not</li>
834 <li>CAN: only frames with slottime != 0 will be simulated, if publishing node is turned on</li>
835 </ul>
836 The <node_nr> can be derived from the node definition in the LDF:
837 Example LDF:
838 <i>Nodes {
839 Master: MasterECU,1.0000 ms,0.1000 ms;
840 Slaves: Slave1Motor, Slave2Sensor;
841 }</i>
842 The master node always has the node number 0.
843 The 1st slave node (here Slave1Motor) has the Node_nr 1<br>
844 The 2nd slave node (here Slave2Sensor) has the node_nr 2<br>
845 etc...
846 </td>
847 <td align="center" style="vertical-align:top">LIN/CAN</td>
848 </tr>
849 <tr>
850 <td align="left" style="vertical-align:top">
851 <b>getnodesimu</b> <noder_nr>
852 </td>
853 <td align="center" style="vertical-align:top">
854 <emulationstate>
855 </td>
856 <td align="left">
857 returns emulationstate (0/1) for given node
858 <ul>
859 <li>emulationstate = 0 the requested node is not simulated by Baby-LIN, so it should be connected in real
860 <li>emulationstate = 1 the requested node is simulated by Baby-LIN, so it should not be connected in real
861 </ul>
862 </td>
863 <td align="center" style="vertical-align:top">LIN/CAN</td>
864 </tr>
865 <tr>
866 <td align="left" style="vertical-align:top">
867 <b>setsig</b> <signal_number> <int:value | bytearray:array>
868 </td>
869 <td align="center" style="vertical-align:top">
870 OK | Err
871 </td>
872 <td align="left">
873 Set a new signal value, the value can be an int (scalar signal) or a bytearray ( for byte array signal ). @ref BLC_setsig is defined as a wrapper for this command.
874 </td>
875 <td align="center" style="vertical-align:top">LIN/CAN</td>
876 </tr>
877 <tr>
878 <td align="left" style="vertical-align:top">
879 <b>getsig</b> <signal_number> <mode>
880 </td>
881 <td align="center" style="vertical-align:top">
882 OK | Err | Pending (-1)<br>
883 <int64 signalvalue>
884 </td>
885 <td align="left">
886 Allows direct access to current signal values as they are in the device.<br>
887 The signal is referenced by the signal_number, which is the SDF index of the related signal.<br>
888 There are some calling variants, which are controlled by option <mode> parameter.<br>
889 If the parameter mode is not present, mode = 0 is used as default mode.<br>
890 <ul>
891 <li><b>mode </b> = 0: Returns the last value written to the signal.</li>
892 <li><b>mode </b> = 1: Returns no value but resets fresh flag in device, which will be set on next appearance of the signal on bus.</li>
893 <li><b>mode </b> = 2: Return signal value as result, if fresh flag was set since last call with mode = 1,<br> otherwise returns RETCODE_OPERATION_PENDING (-1).</li>
894 </ul>
895 Mode 1 and 2 are used in combination and make sense for bus signals only.
896 The BLC_sendCommand (handle, "getsig....") is an alternative method to access a signal value.<br>
897 The other methods are BLC_getNextSignal (..) which fetches the signal value from a signal report queue and the BLC_getSignalValueX (...) variants, which return the latest signal value, which came into the signal report queue.<br>
898 The methods using the signal report queue need to activate the appropriate signal reporting with <b>dissignal</b> before they will work!
899 </td>
900 <td align="center" style="vertical-align:top">LIN/CAN</td>
901 </tr>
902 <tr>
903 <td align="left" style="vertical-align:top">
904 <b>addsig</b> <signal_number> <int32:value> [<int64/uint64:min_value>] [<int64/uint64:max_value>] [<wrap_around>]
905 </td>
906 <td align="center" style="vertical-align:top">
907 OK | Err
908 </td>
909 <td align="left">
910 Adds a signed value to the value of the given signal. <b>min_value</b> determines the lower limit for <b>value</b>. <b>max_value</b> determines the upper limit for <b>value</b>. <b>wrap_around</b> determine the overflow behaviour.
911 <ul>
912 <li> <b>wrap_around</b> = 0, disabled. </li>
913 <li> <b>wrap_around</b> = 1, enabled. </li>
914 </ul>
915 </td>
916 <td align="center" style="vertical-align:top">LIN/CAN</td>
917 </tr>
918 <tr>
919 <td align="left" style="vertical-align:top">
920 <b>freezesig</b> <mode>
921 </td>
922 <td align="center" style="vertical-align:top">
923 OK | Err
924 </td>
925 <td align="left">
926 <ul>
927 <li>mode = 1: deactivates signal update on setsig commands.</li>
928 <li>mode = 0: re-enables signal update, all signal values defined by previous setsig commands will be updated at the same time</li>
929 </ul>
930 </td>
931 <td align="center" style="vertical-align:top">LIn/CAN</td>
932 </tr>
933 <tr>
934 <td align="left">
935 <b>dissignal</b> <signal_number> <mode>
936 </td>
937 <td align="center" style="vertical-align:top">
938 OK | Err
939 </td>
940 <td align="left">
941 Enable signal reporting for the given signal. The given signal number is the signal index within the section.
942 <ul>
943 <li>mode=0 Switch off reporting.</li>
944 <li>mode=1 Send value every time signal it occurs on bus.</li>
945 <li>mode=3 Send value, only if change occurs.</li>
946 </ul>
947 </td>
948 <td align="center" style="vertical-align:top">LIN/CAN</td>
949 </tr>
950 <tr>
951 <td align="left">
952 <b>nodissignal</b> <signal_number>
953 </td>
954 <td align="center" style="vertical-align:top">
955 OK | Err
956 </td>
957 <td align="left">
958 Disable signal reporting for the given signal.
959 </td>
960 <td align="center" style="vertical-align:top">LIN/CAN</td>
961 </tr>
962 <tr>
963 <td align="left" style="vertical-align:top">
964 <b>disframe</b> <scope> <mode>
965 </td>
966 <td align="center" style="vertical-align:top">
967 OK | Err
968 </td>
969 <td align="left" style="vertical-align:top">
970 Enable frame reporting for the frames selected by the given <scope> parameter.<br>
971 The parameter <scope> selects specific frames defined in SDF bus description by SDF frame number, or by frame identifier<br> On LIN the frame identifier can be a 6 Bit value on CAN ist can be a 11 or 29 Bit identifier.<br>
972 Additional there are some scope variants which allow to select all knownFrames or unknown frames.<br>
973 <b>Known frames</b> are the frames given in the corresponding bus description(LDF, DBC or ARXML). <br><b>Unknown frames</b> are not includes in bus description, this might be frames created by injects or protocol commands <br>or in case of CAN, unknown frames might be sent by nodes not included in bus description <br><br>
974 Bits[31:30:29] define the meaning of Bits[28...0] of value <scope>.<br>
975 <ul>
976 <li><b>Bits[31:30:29] = 0:0:0</b> scope defined by bits [28...0] only</li>
977 <ul>
978 <li> Bits[28..0] = frame number (SDF index) of referenced frame</li>
979 <li> LIN special cases (legacy format)</li>
980 <ul>
981 <li> Bits[28..0] = 255 (0xff) all known frames will be in scope</li>
982 <li> Bits[28..0] >= 256 (0x100) the known frame with frameId = scope - 0x100 will be in scope</li>
983 </ul>
984 </ul>
985 <li><b>Bits[31:30:29] = 1:0:0</b> scope will include all unknown frames</li>
986 <ul>
987 <li> Bits[28..0] dont' care</li>
988 </ul>
989 <li><b>Bits[31:30:29] = 0:1:0</b> scope will include all known frames</li>
990 <ul>
991 <li> Bits[28..0] dont' care</li>
992 </ul>
993 <li><b>Bits[31:30:29] = 1:1:0</b> scope will include all known and all unknown frames</li>
994 <ul>
995 <li> Bits[28..0] dont' care</li>
996 </ul>
997 <li><b>Bits[31:30:29] = 0:0:1</b> scope defined by bits [31,28...0]</li>
998 <ul>
999 <li> Bits[31,28..0] = selects known frame with frameId = (scope & 0x9FFFFFFF)</li>
1000 <li> Bits[31] is used for CAN only and defines whether a standard/11Bit Id (=0) or extended/29Bit ID CAN frame is selected.</li>
1001 </ul>
1002 </ul>
1003 The \<mode\> parameter defines the frame reporting options to be applied to all frames in the given \<scope\>.<br>
1004 <ul>
1005 <li>mode=0: Switch off reporting for all frames in \<scope\>.</li>
1006 <li>mode=1: report frames everytime when they occur on bus.</li>
1007 <li>mode=3: report known frames on changes only. For unknown frames this will be converted mode = 1 automatically in device.</li>
1008 </ul>
1009 <b>Examples:</b>
1010 <ul>
1011 <li><i>disframe 15 1</i> selects frame with SDF index for reporting, every time it occurs on bus</li>
1012 <li><i>disframe 0xC0000000 1</i> selects all known and unknown frames for reporting if they occur on bus</li>
1013 <li><i>disframe 0x20000000 1</i> selects known frame with frame id 14 for reporting, every time it occurs on bus</li>
1014 <li><i>disframe 255 1</i> On LIN bus, this is legacy version of <i>disframe 0x4000000 1</i> and seletcs all known frames.</li>
1015 </ul>
1016 </td>
1017 <td align="center" style="vertical-align:top">LIN/CAN</td>
1018 </tr>
1019 <tr>
1020 <td align="left">
1021 <b>nodisframe</b> \<scope\>
1022 </td>
1023 <td align="center" style="vertical-align:top">
1024 OK | Err
1025 </td>
1026 <td align="left">
1027 Disable frame reporting for the frames in given \<scope\>.<br>
1028 Regarding the \<scope\> parameter refer to disframe command to see all special cases.
1029 The <i>disframe \<scope\> 0 </i> variant will do the same as the <i>nodisframe \<scope\></i> command.<br>
1030 So we recommend to use disframe in nre peroject as nodisframe is deprecated.
1031 </td>
1032 <td align="center" style="vertical-align:top">LIN/CAN</td>
1033 </tr>
1034 <tr>
1035 <td align="left" style="vertical-align:top">
1036 <b>macro_exec</b> \<macro_nr/macro_name\> [\<long:value\> {0, 10}]
1037 </td>
1038 <td align="center" style="vertical-align:top">
1039 OK | Err
1040 </td>
1041 <td align="left">
1042 Start execution of macro with given number \<macro_nr\>.<br>
1043 \<value\> the parameters of the macro to call.
1044 </td>
1045 <td align="center" style="vertical-align:top">LIN/CAN</td>
1046 </tr>
1047 <tr>
1048 <td align="left" style="vertical-align:top">
1049 <b>macro_result</b> \<macro_nr\>
1050 </td>
1051 <td align="center" style="vertical-align:top">
1052 \<state\>
1053 <ul>
1054 <li>\<macro_nr\></li>
1055 <li>\<high\></li>
1056 <li>\<low\></li>
1057 </ul>
1058 </td>
1059 <td align="left">
1060 Requests the result of the last execution of the macro with the given number \<macro_nr\>.<br>
1061 The \<high\> and \<low\> values form one 64 bit number, with \<high\> containing the upper part of the value.<br>
1062 If the \<state\> is 0 the value of the "__Return" signal is returned in the \<high\> and \<low\> values.<br>
1063 If the \<state\> is 155 the value of the "__Failure" signal is returned in the \<high\> and \<low\> values.<br>
1064 If the \<state\> is 156 the value of the exception, that terminated the macro execution, is returned in the \<high\> and \<low\> values.<br>
1065 For other \<state\> values consult the @ref BabyLINReturncodes.h.
1066 </td>
1067 <td align="center" style="vertical-align:top">LIN/CAN</td>
1068 </tr>
1069 <tr>
1070 <td align="left" style="vertical-align:top">
1071 <b>macro_rstr</b> \<macro_nr\>
1072 </td>
1073 <td align="center" style="vertical-align:top">
1074 OK | Err
1075 <ul>
1076 <li>\<macro_result_string\></li>
1077 </ul>
1078 </td>
1079 <td align="left">
1080 Requests the result string of the macro with the given number \<macro_nr\>.<br>
1081 Each macro can store one macro result string. It can be set using the print macro command.<br>
1082 The value of the macro result string will not be automatically reset, when a macro is started.<br>
1083 Therefor it may contain a value from a previous run.
1084 </td>
1085 <td align="center" style="vertical-align:top">LIN/CAN</td>
1086 </tr>
1087 <tr>
1088 <td align="left" style="vertical-align:top">
1089 <b>macro_abort</b> [\<macro_nr\>]
1090 </td>
1091 <td align="center" style="vertical-align:top">
1092 OK | Err
1093 </td>
1094 <td align="left">
1095 Stop execution of an active macro given by macro_nr. If macro_nr is omitted, abort all running macros.
1096 </td>
1097 <td align="center" style="vertical-align:top">LIN/CAN</td>
1098 </tr>
1099 <tr>
1100 <td align="left" style="vertical-align:top">
1101 <b>frameset</b> \<frame_number\> \<-1/0/1/2/n\>
1102 </td>
1103 <td align="center" style="vertical-align:top">
1104 OK | Err
1105 </td>
1106 <td align="left">
1107 frame_number is the SDF-index of the requested frame.<br>
1108 On a LIN-Channel, the second parameter is used to suspend or resume the transmission of this frame, when Baby-Lin is used as LIN bus master.
1109 <ul>
1110 <li>Frameset 0 0 will suspend the sending of the frame 0, the frame slot time remains intact</li>
1111 <li>Frameset 0 1 will resume the sending of this frame (if it is available form the active schedule table)</li>
1112 <li>Frameset 0 2 will suspend the sending of the frame 0, including frame slot time</li>
1113 </ul>
1114 On a CAN-Channel, the second parameter is used to suspend, single send or resume the transmission of this frame with a specific timeout.
1115 <ul>
1116 <li>Frameset 0 -1 will suspend the sending of the frame 0</li>
1117 <li>Frameset 0 0 will send the frame exactly one time </li>
1118 <li>Frameset 0 n will start sending the frame with n-milliseconds timeout</li>
1119 </ul>
1120 </td>
1121 <td align="center" style="vertical-align:top">LIN/CAN</td>
1122 </tr>
1123 <tr>
1124 <td align="left" style="vertical-align:top">
1125 <b>sigfuncmodify</b> \<sigfuncidx\>\<start\>\<end\>\<modify\>\<flags\>
1126 </td>
1127 <td align="center" style="vertical-align:top">
1128 OK | Err
1129 </td>
1130 <td align="left">
1131 This commands redefines the parameters of a signals function given in the SDF.<br>
1132 The command should only be used on signal functions of type counter.<br>
1133 The command is supported for LIN channels only.<br>
1134 <ul>
1135 <li>\<sigfuncidx\> identifies which signals function to change</li>
1136 <li>\<start\> counter start value</li>
1137 <li>\<end\> counnting end value</li>
1138 <li>\<modify\> increment of counter \<modify\> == 0 will stop counter</li>
1139 <li>\<flags\> 0x01 swap Bytes</li>
1140 </ul>
1141 </td>
1142 <td align="center" style="vertical-align:top">LIN/CAN</td>
1143 </tr>
1144 <tr>
1145 <td align="left" style="vertical-align:top">
1146 <b>auxout</b> \<outchannel\> \<outstate\>
1147 </td>
1148 <td align="center" style="vertical-align:top">
1149 OK | Err
1150 </td>
1151 <td align="left">
1152 Will set the given output of the device to given state, not supported on all devices.<br>
1153 Outchannels on Baby-LIN-RM/RM-II:<br>
1154 <ul>
1155 <li>0...3 OUT1...OUT4</li>
1156 <li>4 Led F1</li>
1157 <li>5 Led F2</li>
1158 </ul>
1159 Earlier target firmware version supported this command on LIN channel only later this command was moved to DEVCIE channel.
1160 </td>
1161 <td align="center" style="vertical-align:top">LIN/DEVICE</td>
1162 </tr>
1163 <tr>
1164 <td align="left" style="vertical-align:top">
1165 <b>dtlmode</b> \<mode\>
1166 </td>
1167 <td align="center" style="vertical-align:top">
1168 OK | Err
1169 </td>
1170 <td align="left">
1171 Sets mode of diagnistic support.<br>
1172 <ul>
1173 <li>0 = no DTL</li>
1174 <li>1 = DTL-Raw Mode</li>
1175 <li>2 = DTL-Cooked Mode</li>
1176 </ul>
1177 See also additional manual Baby-LIN API for Diagnostic Modes (UM_BabyLIN_DIAG_E.pdf)
1178 </td>
1179 <td align="center" style="vertical-align:top">LIN</td>
1180 </tr>
1181 <tr>
1182 <td align="left" style="vertical-align:top">
1183 <b>varwr</b> \<mode\> \<signal index\> [\<length\>] \<value\>
1184 </td>
1185 <td align="center" style="vertical-align:top">
1186 OK | Err
1187 </td>
1188 <td align="left">
1189 Writes \<value\> into the array, starting at \<signal index\>.
1190 \<mode\> defines, what kind of input for \<value\> is expected:
1191 <ul>
1192 <li><b>Mode 0:</b> \<value\> has to be a list of number in the format: '[ value1 value2 valueN ]'. \<length\> can not
1193 be used in this mode.<br>Example: 'varwr 0 23 [ 1 2 3 4]' would write "1..4" in the signals starting at index 23.
1194 </li>
1195 <li><b>Mode 1:</b> \<value\> has to be a string with escape sequences allowed. \<length\> can not be used in this mode.<br>Example:
1196 'varwr 1 23 "AB\03D"' would write the values 65, 66, 3, 67 (ASCII values of "AB[...]C" in the signals. "\03" is an escape sequence for the hex value 0x03.
1197 </li>
1198 <li><b>Mode 2:</b> requires the parameter \<length\>. \<value\> has to be a single number.
1199 <br>Example: 'varwr 2 23 10 40' would write the value "40" in all 10 signals, starting at index 23.
1200 </li>
1201 </ul>
1202 In every \<mode\>, the array will be filled, beginning from \<signal index\>,
1203 until either no more values are to be written, or no more signals are found in the SDF.
1204 In \<mode\> = 2, the command is done, when \<length\> signals were written.
1205 </td>
1206 <td align="center" style="vertical-align:top">LIN/CAN</td>
1207 </tr>
1208 <tr>
1209 <td align="left" style="vertical-align:top">
1210 <b>varrd</b> \<mode\> \<signal index\> \<length\>
1211 </td>
1212 <td align="center" style="vertical-align:top">
1213 OK | Err
1214 <ul>
1215 <li>\<array_data\></li>
1216 </ul>
1217 </td>
1218 <td align="left">
1219 Reads \<length\> values from the array, starting at \<signal index\>.
1220 \<mode\> defines, how the values will be returned:
1221 <ul>
1222 <li><b>Mode 0:</b> returns a list of decimal numbers<br>Example: 'varrd 0 23 3'
1223 would read 3 signals, starting at index 23 and returns a list where each entry
1224 contains the corresponding signals value.<br>Expected return code is 0.
1225 </li>
1226 <li><b>Mode 1:</b> returns a list of hexadecimal numbers. The numbers are encoded in a string for hexadecimal representation.<br>
1227 Example: 'varrd 1 23 3' would read 3 signals, starting at index 23 and returns a list where each entry contains the corresponding
1228 signals valueas string of hexadecimal numbers (Format: "FF").
1229 </li>
1230 <li><b>Mode 2:</b> returns all read values as single concatenated string. The string may contain escaped sequences for non-printable characters.
1231 <br>Example: 'varrd 2 23 3' would read 3 signals, starting at index 23 and returns a single answer as a string like "AB\03C".
1232 </li>
1233 <li><b>Mode 3:</b> returns all read values as single concatenated string. Non-printable characters are escaped as '.' .
1234 <br>Example: 'varrd 3 23 3' would read 3 signals, starting at index 23 and returns a single answer as a string like "AB.C".
1235 </li>
1236 </ul>
1237 In every \<mode\>, \<length\> = 0 can be used to read the array until a signal with value 0x00 is encountered.
1238 </td>
1239 <td align="center" style="vertical-align:top">LIN/CAN</td>
1240 </tr>
1241 <tr>
1242 <td align="left" style="vertical-align:top">
1243 <b>sysvar_rd</b> \<name\>
1244 </td>
1245 <td align="center" style="vertical-align:top">
1246 OK | Err
1247 <ul>
1248 <li>\<value\></li>
1249 </ul>
1250 </td>
1251 <td align="left">
1252 Reads the system variable with the name \<name\> and return it's current value.
1253 </td>
1254 <td align="center" style="vertical-align:top">DEVICE/LIN/CAN</td>
1255 </tr>
1256 <tr>
1257 <td align="left" style="vertical-align:top">
1258 <b>sysvar_wr</b> <name> <value>
1259 </td>
1260 <td align="center" style="vertical-align:top">
1261 OK | Err
1262 </td>
1263 <td align="left">
1264 Writes the system variable with the name <name> and sets it's new value to \<value\>.
1265 </td>
1266 <td align="center" style="vertical-align:top">DEVICE/LIN/CAN</td>
1267 </tr>
1268
1269 </table>
1270 </div>
BLC_getAnswerTypeByIndex
int BL_DLLIMPORT BLC_getAnswerTypeByIndex(BL_HANDLE handle, const unsigned int index, BL_ANSWER_TYPE *type, size_t *length)
Get type of a parameter of the last answer data from a BabyLIN.
BLC_sendCommand
int BL_DLLIMPORT BLC_sendCommand(BL_HANDLE handle, const char *command)
Send a command to the BabyLIN device.
BLC_getAnswerByName
int BL_DLLIMPORT BLC_getAnswerByName(BL_HANDLE handle, const char *name, void *buffer, size_t length)
Get the value of a parameter of the last answer data from a BabyLIN.
BLC_getHWType
int BL_DLLIMPORT BLC_getHWType(BL_HANDLE handle)
Returns the unique hardware type identifier for a device.
BL_sendCommand
int BL_DLLIMPORT BL_sendCommand(BL_HANDLE handle, const char *command)
BLC_getAnswerByIndex
int BL_DLLIMPORT BLC_getAnswerByIndex(BL_HANDLE handle, const unsigned int index, void *buffer, size_t length)
Get the value of a parameter of the last answer data from a BabyLIN.
BLC_getAnswerTypeByName
int BL_DLLIMPORT BLC_getAnswerTypeByName(BL_HANDLE handle, const char *name, BL_ANSWER_TYPE *type, size_t *length)
Get type of a parameter of the last answer data from a BabyLIN.
BLC_getTargetID
int BL_DLLIMPORT BLC_getTargetID(BL_HANDLE handle, BLC_TARGETID *targetID)
Requests the information about the target.
Generated on Fri May 30 2025 17:16:12 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: markdowns/UnifiedAccess/DateTimeFormat.md File Reference

markdowns/UnifiedAccess/DateTimeFormat.md File Reference

Go to the source code of this file.

Generated on Fri May 30 2025 17:16:13 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: markdowns/UnifiedAccess/DateTimeFormat.md Source File

markdowns/UnifiedAccess/DateTimeFormat.md
Go to the documentation of this file.
1 # Date and time format
2 @ingroup ua_datetimeformat
3
4 Certain strings can use data and time format specifiers.<br>The following list shows all format specifiers.
5
6 | __Format specifier__ | __Category__ | __Description__ |
7 | :--: | :--: | :-- |
8 | `%%Y` | Year | Writes year as a decimal number, e.g. 2017. |
9 | `%%Y` | Year | Writes year as a decimal number, e.g. 2017. |
10 | `%%y` | Year | Writes last 2 digits of year as a decimal number (range [00,99]). |
11 | `%%b` | Month | Writes abbreviated month name, e.g. Oct (locale dependent). |
12 | `%%B` | Month | Writes full month name, e.g. October (locale dependent). |
13 | `%%m` | Month | Writes month as a decimal number (range [01,12]). |
14 | `%%U` | Week | Writes week of the year as a decimal number (Sunday is the first day of the week) (range [00,53]). |
15 | `%%W` | Week | Writes week of the year as a decimal number (Monday is the first day of the week) (range [00,53]). |
16 | `%%j` | Day | Writes day of the year as a decimal number (range [001,366]). |
17 | `%%d` | Day | Writes day of the month as a decimal number (range [01,31]). |
18 | `%%a` | Day | Writes abbreviated weekday name, e.g. Fri (locale dependent). |
19 | `%%A` | Day | Writes full weekday name, e.g. Friday (locale dependent). |
20 | `%%w` | Day | Writes weekday as a decimal number, where Sunday is 0 (range [0-6]). |
21 | `%%H` | Hour | Writes hour as a decimal number, 24 hour clock (range [00-23]). |
22 | `%%I` | Hour | Writes hour as a decimal number, 12 hour clock (range [01,12]). |
23 | `%%M` | Minute | Writes minute as a decimal number (range [00,59]). |
24 | `%%S` | Second | Writes second as a decimal number (range [00,60]). |
25 | `%%%fm` | Fractional | Writes milliseconds as a decimal number (range [000,999]). |
26 | `%%%fu` | Fractional | Writes microseconds as a decimal number (range [000,999]). |
27 | `%%c` | Other | Writes standard date and time string, e.g. Sun Oct 17 04:41:13 2010 (locale dependent). |
28 | `%%x` | Other | Writes localized date representation (locale dependent). |
29 | `%%X` | Other | Writes localized time representation, e.g. 18:40:20 or 6:40:20 PM (locale dependent). |
30 | `%%p` | Other | Writes localized a.m. or p.m. (locale dependent). |
31 | `%%z` | Other | Writes offset from UTC in the ISO 8601 format (e.g. -0430), or no characters if the time zone information is not available. |
32 | `%%Z` | Other | Writes locale-dependent time zone name or abbreviation, or no characters if the time zone information is not available. |
33 | `%%` | Other | Writes literal %. |
Generated on Fri May 30 2025 17:16:12 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: Deprecated List

Deprecated List
Global BL_frame_t::status
no longer used
Class BL_signal_t
Global BLC_getErrorString (int error_code)
use BLC_getDetailedErrorString() instead
Global BLC_getLastError (BL_HANDLE handle, char *pErrorBuffer, int bufferLength)
use BLC_getDetailedErrorString() instead
Global BLC_getVersion (int *major, int *minor)
Use BLC_getExtendedVersion instead
Global BLC_open (unsigned int port)
use BLC_openPort() together with BLC_convertUrl() or BLC_getBabyLinPorts()
Global BLC_openNet (const char *ip, int port)
use BLC_openPort() together with BLC_convertUrl() or BLC_getBabyLinPorts()
Global BLC_openUSB (const char *device)
use BLC_openPort() together with BLC_convertUrl()
Global BLC_registerJumboFrameCallback (BL_HANDLE handle, BLC_jumboframe_callback_func *callback)
Use BLC_registerUserDataJumboFrameCallback instead
Generated on Fri May 30 2025 17:16:13 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: markdowns/UnifiedAccess/Device.md File Reference

markdowns/UnifiedAccess/Device.md File Reference

Go to the source code of this file.

Generated on Fri May 30 2025 17:16:13 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: markdowns/UnifiedAccess/Device.md Source File

markdowns/UnifiedAccess/Device.md
Go to the documentation of this file.
1 # The Device
2 @ingroup ua_device
3
4 You should first read through the @ref ua.<br/>
5 Here all available __Tags__ of a Device can be looked up.
6 Also all __Tags__ of the @ref ua_sdf loaded onto this device can be used.
7
8 #### Child __Tags__
9
10 | __Tag__ | __Type__ | __Description__ |
11 | :--: | :--: | :-- |
12 | `sdf` | Void | Gets the @ref ua_sdf loaded by this device. |
13 | `channel` | <span style="white-space: nowrap;">32bit Number</span><br>String | Find a @ref ua_channel by index or name. |
14 | `lin_channel` | <span style="white-space: nowrap;">32bit Number</span><br>String | Find a [LIN-Channel](@ref ua_channel) by index or name. |
15 | `can_channel` | <span style="white-space: nowrap;">32bit Number</span><br>String | Find a [CAN-Channel](@ref ua_channel) by index or name. |
16
17 #### Property __Tags__
18
19 | __Tag__ | Default Value | __Type__ | __Description__ |
20 | :--: | :--: | :--: | :-- |
21 | `name` | <> | String | The name, of the device. |
22 | `supported_sdf_version` | <> | 32bit Number | The maximal SDF version, that is supported by this device. |
23 | `channel_count` | <> | <span style="white-space: nowrap;">32bit Number</span> | The amount of available [Channels](@ref ua_channel) in this device. |
24 | `lin_channel_count` | <> | <span style="white-space: nowrap;">32bit Number</span> | The amount of available [LIN-Channels](@ref ua_channel) in this device. |
25 | `can_channel_count` | <> | <span style="white-space: nowrap;">32bit Number</span> | The amount of available [CAN-Channels](@ref ua_channel) in this device. |
Generated on Fri May 30 2025 17:16:12 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: C:/JenkinsWS/workspace/orks_v2_LinWorksv2_Windows_trunk/source/externals/BabyLIN/src/libraries Directory Reference

  • externals
  • BabyLIN
  • src
  • libraries
libraries Directory Reference
Generated on Fri May 30 2025 17:16:14 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: C:/JenkinsWS/workspace/orks_v2_LinWorksv2_Windows_trunk/source/externals Directory Reference

  • externals
externals Directory Reference
Generated on Fri May 30 2025 17:16:14 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: C:/JenkinsWS/workspace/orks_v2_LinWorksv2_Windows_trunk/source/externals/BabyLIN/src Directory Reference

  • externals
  • BabyLIN
  • src
src Directory Reference
Generated on Fri May 30 2025 17:16:14 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: C:/JenkinsWS/workspace/orks_v2_LinWorksv2_Windows_trunk/source/externals/BabyLIN Directory Reference

  • externals
  • BabyLIN
BabyLIN Directory Reference
Generated on Fri May 30 2025 17:16:14 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: C:/JenkinsWS/workspace/orks_v2_LinWorksv2_Windows_trunk/source/externals/BabyLIN/src/libraries/BabyLIN/privateHeaders Directory Reference

  • externals
  • BabyLIN
  • src
  • libraries
  • BabyLIN
  • privateHeaders
privateHeaders Directory Reference
Generated on Fri May 30 2025 17:16:14 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: C:/JenkinsWS/workspace/orks_v2_LinWorksv2_Windows_trunk/source/externals/BabyLIN/src/libraries/BabyLIN/publicHeaders Directory Reference

  • externals
  • BabyLIN
  • src
  • libraries
  • BabyLIN
  • publicHeaders
publicHeaders Directory Reference
Generated on Fri May 30 2025 17:16:14 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: C:/JenkinsWS/workspace/orks_v2_LinWorksv2_Windows_trunk/source/externals/BabyLIN/src/libraries/BabyLIN Directory Reference

  • externals
  • BabyLIN
  • src
  • libraries
  • BabyLIN
BabyLIN Directory Reference
Generated on Fri May 30 2025 17:16:14 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: markdowns/UnifiedAccess/SDF/EncodingType.md File Reference

markdowns/UnifiedAccess/SDF/EncodingType.md File Reference

Go to the source code of this file.

Generated on Fri May 30 2025 17:16:13 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: markdowns/UnifiedAccess/SDF/EncodingType.md Source File

markdowns/UnifiedAccess/SDF/EncodingType.md
Go to the documentation of this file.
1 # The Encoding Type
2 @ingroup ua_encoding_type
3
4 You should first read through the @ref ua.<br/>
5 Here all available __Tags__ of a Encoding Type can be looked up.
6
7 #### Child __Tags__
8
9 | __Tag__ | __Type__ | __Description__ |
10 | :--: | :--: | :-- |
11 | `encoding_value` | <span style="white-space: nowrap;">32bit Number</span><br> | find a @ref ua_encoding_value by index. |
12
13 #### Property __Tags__
14
15 | __Tag__ | Default Value | __Type__ | __Description__ |
16 | :--: | :--: | :--: | :-- |
17 | `name` | <> | String | The name, of the Encoding Type. |
18 | `encoding_value_count` | <> | <span style="white-space: nowrap;">32bit Number</span> | The amount of available [Encoding Values](@ref ua_encoding_value) for this Encoding Type. |
Generated on Fri May 30 2025 17:16:12 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: markdowns/UnifiedAccess/SDF/EncodingValue.md File Reference

markdowns/UnifiedAccess/SDF/EncodingValue.md File Reference

Go to the source code of this file.

Generated on Fri May 30 2025 17:16:13 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: markdowns/UnifiedAccess/SDF/EncodingValue.md Source File

markdowns/UnifiedAccess/SDF/EncodingValue.md
Go to the documentation of this file.
1 # The Encoding Value
2 @ingroup ua_encoding_value
3
4 You should first read through the @ref ua.<br/>
5 Here all available __Tags__ of an Encoding Value can be looked up.
6
7 Physical encodings are computed by multiplying the signal value with the scale followed by adding the offset.
8
9 #### Property __Tags__
10
11 | __Tag__ | Default Value | __Type__ | __Description__ |
12 | :--: | :--: | :--: | :-- |
13 | `type` | <> | <span style="white-space: nowrap;">32bit Number</span> | The Encoding Value value:<br>Logical := 0<br>Physical := 1<br>BCD := 3<br>ASCII := 4 |
14 | `alias` | <> | String | The Text that is used for this Encoding. Only valid for Logical encodings. |
15 | `unit` | <> | String | The Unit that is used for this Encoding. Only valid for Physical encodings. |
16 | `raw_min` | <> | <span style="white-space: nowrap;">64bit Number</span> | The minimal Signal Value, valid for this encoding. |
17 | `raw_max` | <> | <span style="white-space: nowrap;">64bit Number</span> | The maximal Signal Value, valid for this encoding. |
18 | `scale` | <> | String | The scale value for this encoding. Only valid for Physical encodings. |
19 | `offset` | <> | String | The offset value for this encoding. Only valid for Physical encodings. |
Generated on Fri May 30 2025 17:16:12 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: File List

File List
Here is a list of all files with brief descriptions:
[detail level 1234567]
\ - externals
  \ - BabyLIN
    \ - src
      \ - libraries
        \ - BabyLIN
          o - privateHeaders
          | \ * BabyLIN_Doxygen_Structure.h
          \ - publicHeaders
            o * BabyLIN.h
            o * BabyLIN_RP1210.h
            o * BabyLIN_UnifiedAccess.h
            o * BabyLINCAN.h
            o * BabyLINCAN_nostruct.h
            o * BabyLINCAN_types.h
            o * BabyLINCANSDF.h
            o * BabyLINReturncodes.h
            o * BabyLINSDF.h
            \ * SDF.h
Generated on Fri May 30 2025 17:16:15 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: markdowns/UnifiedAccess/SDF/Frame.md File Reference

markdowns/UnifiedAccess/SDF/Frame.md File Reference

Go to the source code of this file.

Generated on Fri May 30 2025 17:16:13 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: markdowns/UnifiedAccess/SDF/Frame.md Source File

markdowns/UnifiedAccess/SDF/Frame.md
Go to the documentation of this file.
1 # The SDF Frame
2 @ingroup ua_sdf_frame
3
4 You should first read through the @ref ua.<br/>
5 Here all available __Tags__ of a Frame can be looked up.
6
7 #### Child __Tags__
8
9 | __Tag__ | __Type__ | __Description__ |
10 | :--: | :--: | :-- |
11 | `mapping` | <span style="white-space: nowrap;">32bit Number</span> | return the associated @ref ua_sdf_mapping. |
12
13 #### Property __Tags__
14
15 | __Tag__ | Default Value | __Type__ | __Description__ |
16 | :--: | :--: | :--: | :-- |
17 | `name` | <> | String | The name, of the frame. |
18 | `index` | <> | <span style="white-space: nowrap;">32bit Number</span> | The frame's index in the @ref ua_section 's `frame` list. |
19 | `id` | <> | <span style="white-space: nowrap;">32bit Number</span> | The frame's ID, that is used on the bus. |
20 | `length` | <> | <span style="white-space: nowrap;">32bit Number</span> | The frame's length in bytes. |
21 | `emulated` | <> | Boolean | True if the frame is emulated. |
22 | `mapping_count` | <> | <span style="white-space: nowrap;">32bit Number</span> | The amount of available [Mappings](@ref ua_sdf_mapping) in this frame. |
Generated on Fri May 30 2025 17:16:12 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: markdowns/SdfScript/Function scope.md File Reference

markdowns/SdfScript/Function scope.md File Reference

Go to the source code of this file.

Generated on Fri May 30 2025 17:16:13 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: markdowns/SdfScript/Function scope.md Source File

markdowns/SdfScript/Function scope.md
Go to the documentation of this file.
1 @ingroup sdf_script_function
2
3 The function scope means any script statements <b>inside</b> of "function [...]" blocks.<br>
4 The function is always called with one parameter, the channel object. This object represents the device channel the section is loaded onto.<br>
5 Using this object, you can query some device or SDF data and manipulate other objects.<br>
6 <br>
7 The following functions/object/variables are available, please see their corresponding pages for detailed information:<br>
8
9 | Name | Type | Reference |
10 |---|---|---|
11 | @ref script_sdf_func_print | Function | Prints a string to the @ref BLC_registerLuaPrintCallback <br><b>See @ref script_sdf_func_print</b> |
12 | @ref script_sdf_func_sleep | Function | Sleeps for a given time in milliseconds.<br><b>See @ref script_sdf_func_sleep</b> |
13 | @ref script_sdf_obj_channel | Object | Represents a channel on the device.<br><b>See @ref script_sdf_obj_channel</b> |
Generated on Fri May 30 2025 17:16:12 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: Data Fields

  • Data Structure Index
  • All
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • p
  • r
  • s
  • t
  • u
  • v
  • x
Here is a list of all struct and union fields with links to the structures/unions they belong to:

- a -

  • accept_any_csize : ADHOC_PROTOCOL_FLAGS , ADHOC_SERVICE_FLAGS
  • active : BLC_ADHOC_PROTOCOL
  • array : BL_signal_t , BLC_SIGNAL
  • arrayLength : BL_signal_t , BLC_SIGNAL
  • associatedWithSectionNr : BLC_CHANNELINFO
Generated on Fri May 30 2025 17:16:15 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: Data Fields

  • Data Structure Index
  • All
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • p
  • r
  • s
  • t
  • u
  • v
  • x
Here is a list of all struct and union fields with links to the structures/unions they belong to:

- b -

  • breaklength : BL_frame_t
  • build : BL_targetid_t , BLC_TARGETID
  • busFlags : BLC_FRAME , BLC_JUMBO_FRAME
Generated on Fri May 30 2025 17:16:15 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: Data Fields

  • Data Structure Index
  • All
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • p
  • r
  • s
  • t
  • u
  • v
  • x
Here is a list of all struct and union fields with links to the structures/unions they belong to:

- c -

  • can : ADHOC_PROTOCOL_FLAGS , ADHOC_SERVICE_FLAGS
  • can_channel_count : BLC_RP1210_DEVICE
  • channel : BLC_LOG
  • channelid : BLC_MACROSTATE
  • checksum : BLC_FRAME , BLC_JUMBO_FRAME
  • checksum_rcv : ADHOC_SERVICE_FLAGS
  • checksum_txd : ADHOC_SERVICE_FLAGS
  • chId : BLC_FRAME , BLC_JUMBO_FRAME , BLC_SIGNAL
  • cmdnr : BLC_MACROSTATE
Generated on Fri May 30 2025 17:16:15 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: Data Fields

  • Data Structure Index
  • All
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • p
  • r
  • s
  • t
  • u
  • v
  • x
Here is a list of all struct and union fields with links to the structures/unions they belong to:

- d -

  • data : BL_dtl_t , BLC_DTL , BLC_EVENT
  • description : BLC_RP1210_DEVICE , SDF_SECTIONINFO
  • device : BL_portInfo_t , BLC_PORTINFO
Generated on Fri May 30 2025 17:16:15 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: Data Fields

  • Data Structure Index
  • All
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • p
  • r
  • s
  • t
  • u
  • v
  • x
Here is a list of all struct and union fields with links to the structures/unions they belong to:

- e -

  • event : BLC_EVENT
  • expect_can_11_29bit : ADHOC_PROTOCOL_FLAGS
  • expect_canfd_frame : ADHOC_PROTOCOL_FLAGS
  • expect_canfd_switch : ADHOC_PROTOCOL_FLAGS
  • expect_chksumtype : ADHOC_PROTOCOL_FLAGS
  • expect_shortenedlcf : ADHOC_PROTOCOL_FLAGS
  • expect_shortenedsf : ADHOC_PROTOCOL_FLAGS
  • extended : BL_frame_t
Generated on Fri May 30 2025 17:16:15 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: Data Fields

  • Data Structure Index
  • All
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • p
  • r
  • s
  • t
  • u
  • v
  • x
Here is a list of all struct and union fields with links to the structures/unions they belong to:

- f -

  • fdbaudswitch_rcv : ADHOC_SERVICE_FLAGS
  • fdbaudswitch_txd : ADHOC_SERVICE_FLAGS
  • fdframe_rcv : ADHOC_SERVICE_FLAGS
  • fdframe_txd : ADHOC_SERVICE_FLAGS
  • filename : BLC_SDFINFO
  • fill_byte : BLC_ADHOC_PROTOCOL
  • flags : BL_frame_t , BL_targetid_t , BLC_ADHOC_PROTOCOL , BLC_ADHOC_SERVICE , BLC_TARGETID
  • flow_control_block_size : BLC_ADHOC_EXECUTE
  • flow_control_st_min : BLC_ADHOC_EXECUTE
  • format_version : BLC_LOG
  • framedata : BL_frame_t
  • frameData : BLC_FRAME , BLC_JUMBO_FRAME
  • frameFlags : BLC_FRAME , BLC_JUMBO_FRAME
  • frameId : BLC_FRAME , BLC_JUMBO_FRAME
Generated on Fri May 30 2025 17:16:15 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: Data Fields

  • Data Structure Index
  • All
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • p
  • r
  • s
  • t
  • u
  • v
  • x
Here is a list of all struct and union fields with links to the structures/unions they belong to:

- g -

  • generic : ADHOC_PROTOCOL_FLAGS , ADHOC_SERVICE_FLAGS
  • group : BLC_LOG
Generated on Fri May 30 2025 17:16:15 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: Data Fields

  • Data Structure Index
  • All
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • p
  • r
  • s
  • t
  • u
  • v
  • x
Here is a list of all struct and union fields with links to the structures/unions they belong to:

- h -

  • hardware_type : BLC_RP1210_DEVICE
  • heapsize : BL_targetid_t , BLC_TARGETID
Generated on Fri May 30 2025 17:16:15 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: Data Fields

  • Data Structure Index
  • All
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • p
  • r
  • s
  • t
  • u
  • v
  • x
Here is a list of all struct and union fields with links to the structures/unions they belong to:

- i -

  • id : BLC_CHANNELINFO , BLC_LOG , BLC_RP1210_DEVICE
  • id_11_29_rcv : ADHOC_SERVICE_FLAGS
  • id_11_29_txd : ADHOC_SERVICE_FLAGS
  • index : BL_signal_t , BLC_SIGNAL
  • intime : BLC_FRAME , BLC_JUMBO_FRAME
  • isArray : BL_signal_t , BLC_SIGNAL
Generated on Fri May 30 2025 17:16:15 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: Data Fields

  • Data Structure Index
  • All
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • p
  • r
  • s
  • t
  • u
  • v
  • x
Here is a list of all struct and union fields with links to the structures/unions they belong to:

- l -

  • length : BL_dtl_t , BL_frame_t , BLC_DTL
  • lenOfData : BLC_FRAME , BLC_JUMBO_FRAME
  • lin : ADHOC_PROTOCOL_FLAGS , ADHOC_SERVICE_FLAGS
Generated on Fri May 30 2025 17:16:15 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: Data Fields

  • Data Structure Index
  • All
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • p
  • r
  • s
  • t
  • u
  • v
  • x
Here is a list of all struct and union fields with links to the structures/unions they belong to:

- m -

  • macronr : BLC_MACROSTATE
  • maxbaudrate : BLC_CHANNELINFO
Generated on Fri May 30 2025 17:16:15 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: Data Fields

  • Data Structure Index
  • All
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • p
  • r
  • s
  • t
  • u
  • v
  • x
Here is a list of all struct and union fields with links to the structures/unions they belong to:

- n -

  • nad : BL_dtl_t , BLC_ADHOC_EXECUTE , BLC_DTL
  • name : BL_portInfo_t , BL_targetid_t , BLC_ADHOC_PROTOCOL , BLC_ADHOC_SERVICE , BLC_CHANNELINFO , BLC_PORTINFO , BLC_RP1210_DEVICE , BLC_SECTIONINFO , BLC_TARGETID , SDF_SECTIONINFO
  • no_flowctrl_wait : ADHOC_SERVICE_FLAGS
  • nr : BLC_SECTIONINFO
  • Num0fParams : SCONFIG_LIST
  • NumOfBytes : SBYTEARRAY
  • numofchannels : BLC_TARGETID
Generated on Fri May 30 2025 17:16:15 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: Data Fields

  • Data Structure Index
  • All
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • p
  • r
  • s
  • t
  • u
  • v
  • x
Here is a list of all struct and union fields with links to the structures/unions they belong to:

- p -

  • p2_extended : BLC_ADHOC_EXECUTE
  • Parameter : SCONFIG
  • pBytes : SBYTEARRAY
  • pc_timestamp : BLC_EVENT
  • pConfig : SCONFIG_LIST
  • portNr : BL_portInfo_t , BLC_PORTINFO
  • protocoltype : ADHOC_PROTOCOL_FLAGS
Generated on Fri May 30 2025 17:16:15 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: Data Fields

  • Data Structure Index
  • All
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • p
  • r
  • s
  • t
  • u
  • v
  • x
Here is a list of all struct and union fields with links to the structures/unions they belong to:

- r -

  • req_container_size : BLC_ADHOC_SERVICE
  • req_frame_id : BLC_ADHOC_SERVICE
  • req_payload_size : BLC_ADHOC_SERVICE
  • req_slot_time : BLC_ADHOC_PROTOCOL , BLC_ADHOC_SERVICE
  • requestonly : ADHOC_SERVICE_FLAGS
  • reserved1 : BLC_CHANNELINFO
  • reserved2 : BLC_CHANNELINFO
  • reserved3 : BLC_CHANNELINFO
  • rsp_container_size : BLC_ADHOC_SERVICE
  • rsp_delay : BLC_ADHOC_PROTOCOL , BLC_ADHOC_SERVICE
  • rsp_frame_id : BLC_ADHOC_SERVICE
  • rsp_payload_size : BLC_ADHOC_SERVICE
  • rsp_slot_time : BLC_ADHOC_PROTOCOL , BLC_ADHOC_SERVICE
Generated on Fri May 30 2025 17:16:15 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: Data Fields

  • Data Structure Index
  • All
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • p
  • r
  • s
  • t
  • u
  • v
  • x
Here is a list of all struct and union fields with links to the structures/unions they belong to:

- s -

  • sectionCount : BLC_SDFINFO
  • sectionNr : SDF_SECTIONINFO
  • serial : BL_targetid_t , BLC_TARGETID
  • serial_number : BLC_RP1210_DEVICE
  • shortenlcf_rcv : ADHOC_SERVICE_FLAGS
  • shortenlcf_txd : ADHOC_SERVICE_FLAGS
  • shortensf_rcv : ADHOC_SERVICE_FLAGS
  • shortensf_txd : ADHOC_SERVICE_FLAGS
  • signal_index : BLC_LOG
  • slaveprotocol : ADHOC_PROTOCOL_FLAGS
  • source : BLC_LOG
  • source_type : BLC_LOG
  • spare : BL_targetid_t
  • state : BLC_MACROSTATE
  • status : BL_dtl_t , BL_error_t , BL_frame_t , BLC_DTL , BLC_ERROR
  • sub_index : BLC_LOG
  • synctime : BL_frame_t
Generated on Fri May 30 2025 17:16:15 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: Data Fields

  • Data Structure Index
  • All
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • p
  • r
  • s
  • t
  • u
  • v
  • x
Here is a list of all struct and union fields with links to the structures/unions they belong to:

- t -

  • time : BL_frame_t
  • timestamp : BL_error_t , BL_frame_t , BLC_ERROR , BLC_EVENT , BLC_FRAME , BLC_JUMBO_FRAME , BLC_MACROSTATE , BLC_SIGNAL
  • timestamp_unix : BLC_LOG
  • timestamp_usec : BLC_LOG
  • tx_shortenlcf : ADHOC_PROTOCOL_FLAGS
  • tx_shortensf : ADHOC_PROTOCOL_FLAGS
  • type : BL_error_t , BL_portInfo_t , BL_targetid_t , BLC_CHANNELINFO , BLC_ERROR , BLC_PORTINFO , BLC_SECTIONINFO , BLC_TARGETID , SDF_SECTIONINFO
Generated on Fri May 30 2025 17:16:15 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: Data Fields

  • Data Structure Index
  • All
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • p
  • r
  • s
  • t
  • u
  • v
  • x
Here is a list of all struct and union fields with links to the structures/unions they belong to:

- u -

  • unused_1 : ADHOC_PROTOCOL_FLAGS , ADHOC_SERVICE_FLAGS
  • unused_2 : ADHOC_PROTOCOL_FLAGS , ADHOC_SERVICE_FLAGS
  • unused_3 : ADHOC_PROTOCOL_FLAGS , ADHOC_SERVICE_FLAGS
  • unused_4 : ADHOC_SERVICE_FLAGS
  • unused_5 : ADHOC_SERVICE_FLAGS
  • use_std_negresp : ADHOC_PROTOCOL_FLAGS , ADHOC_SERVICE_FLAGS
  • use_std_posresp : ADHOC_PROTOCOL_FLAGS , ADHOC_SERVICE_FLAGS
Generated on Fri May 30 2025 17:16:15 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: Data Fields

  • Data Structure Index
  • All
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • p
  • r
  • s
  • t
  • u
  • v
  • x
Here is a list of all struct and union fields with links to the structures/unions they belong to:

- v -

  • value : BL_frame_t , BL_signal_t , BLC_SIGNAL
  • Value : SCONFIG
  • value_array_size : BLC_LOG
  • value_data : BLC_LOG
  • value_element_size : BLC_LOG
  • value_signed : BLC_LOG
  • version : BL_targetid_t , BLC_TARGETID
  • version_major : BLC_SDFINFO
  • version_minor : BLC_SDFINFO
Generated on Fri May 30 2025 17:16:15 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: Data Fields - Variables

  • Data Structure Index
  • All
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • p
  • r
  • s
  • t
  • u
  • v
  • x

- a -

  • accept_any_csize : ADHOC_PROTOCOL_FLAGS , ADHOC_SERVICE_FLAGS
  • active : BLC_ADHOC_PROTOCOL
  • array : BL_signal_t , BLC_SIGNAL
  • arrayLength : BL_signal_t , BLC_SIGNAL
  • associatedWithSectionNr : BLC_CHANNELINFO
Generated on Fri May 30 2025 17:16:15 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: Data Fields - Variables

  • Data Structure Index
  • All
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • p
  • r
  • s
  • t
  • u
  • v
  • x

- b -

  • breaklength : BL_frame_t
  • build : BL_targetid_t , BLC_TARGETID
  • busFlags : BLC_FRAME , BLC_JUMBO_FRAME
Generated on Fri May 30 2025 17:16:15 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: Data Fields - Variables

  • Data Structure Index
  • All
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • p
  • r
  • s
  • t
  • u
  • v
  • x

- c -

  • can : ADHOC_PROTOCOL_FLAGS , ADHOC_SERVICE_FLAGS
  • can_channel_count : BLC_RP1210_DEVICE
  • channel : BLC_LOG
  • channelid : BLC_MACROSTATE
  • checksum : BLC_FRAME , BLC_JUMBO_FRAME
  • checksum_rcv : ADHOC_SERVICE_FLAGS
  • checksum_txd : ADHOC_SERVICE_FLAGS
  • chId : BLC_FRAME , BLC_JUMBO_FRAME , BLC_SIGNAL
  • cmdnr : BLC_MACROSTATE
Generated on Fri May 30 2025 17:16:15 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: Data Fields - Variables

  • Data Structure Index
  • All
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • p
  • r
  • s
  • t
  • u
  • v
  • x

- d -

  • data : BL_dtl_t , BLC_DTL , BLC_EVENT
  • description : BLC_RP1210_DEVICE , SDF_SECTIONINFO
  • device : BL_portInfo_t , BLC_PORTINFO
Generated on Fri May 30 2025 17:16:15 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: Data Fields - Variables

  • Data Structure Index
  • All
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • p
  • r
  • s
  • t
  • u
  • v
  • x

- e -

  • event : BLC_EVENT
  • expect_can_11_29bit : ADHOC_PROTOCOL_FLAGS
  • expect_canfd_frame : ADHOC_PROTOCOL_FLAGS
  • expect_canfd_switch : ADHOC_PROTOCOL_FLAGS
  • expect_chksumtype : ADHOC_PROTOCOL_FLAGS
  • expect_shortenedlcf : ADHOC_PROTOCOL_FLAGS
  • expect_shortenedsf : ADHOC_PROTOCOL_FLAGS
  • extended : BL_frame_t
Generated on Fri May 30 2025 17:16:15 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: Data Fields - Variables

  • Data Structure Index
  • All
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • p
  • r
  • s
  • t
  • u
  • v
  • x

- f -

  • fdbaudswitch_rcv : ADHOC_SERVICE_FLAGS
  • fdbaudswitch_txd : ADHOC_SERVICE_FLAGS
  • fdframe_rcv : ADHOC_SERVICE_FLAGS
  • fdframe_txd : ADHOC_SERVICE_FLAGS
  • filename : BLC_SDFINFO
  • fill_byte : BLC_ADHOC_PROTOCOL
  • flags : BL_frame_t , BL_targetid_t , BLC_ADHOC_PROTOCOL , BLC_ADHOC_SERVICE , BLC_TARGETID
  • flow_control_block_size : BLC_ADHOC_EXECUTE
  • flow_control_st_min : BLC_ADHOC_EXECUTE
  • format_version : BLC_LOG
  • framedata : BL_frame_t
  • frameData : BLC_FRAME , BLC_JUMBO_FRAME
  • frameFlags : BLC_FRAME , BLC_JUMBO_FRAME
  • frameId : BLC_FRAME , BLC_JUMBO_FRAME
Generated on Fri May 30 2025 17:16:15 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: Data Fields - Variables

  • Data Structure Index
  • All
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • p
  • r
  • s
  • t
  • u
  • v
  • x

- g -

  • generic : ADHOC_PROTOCOL_FLAGS , ADHOC_SERVICE_FLAGS
  • group : BLC_LOG
Generated on Fri May 30 2025 17:16:15 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: Data Fields - Variables

  • Data Structure Index
  • All
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • p
  • r
  • s
  • t
  • u
  • v
  • x

- h -

  • hardware_type : BLC_RP1210_DEVICE
  • heapsize : BL_targetid_t , BLC_TARGETID
Generated on Fri May 30 2025 17:16:15 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: Data Fields - Variables

  • Data Structure Index
  • All
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • p
  • r
  • s
  • t
  • u
  • v
  • x

- i -

  • id : BLC_CHANNELINFO , BLC_LOG , BLC_RP1210_DEVICE
  • id_11_29_rcv : ADHOC_SERVICE_FLAGS
  • id_11_29_txd : ADHOC_SERVICE_FLAGS
  • index : BL_signal_t , BLC_SIGNAL
  • intime : BLC_FRAME , BLC_JUMBO_FRAME
  • isArray : BL_signal_t , BLC_SIGNAL
Generated on Fri May 30 2025 17:16:15 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: Data Fields - Variables

  • Data Structure Index
  • All
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • p
  • r
  • s
  • t
  • u
  • v
  • x

- l -

  • length : BL_dtl_t , BL_frame_t , BLC_DTL
  • lenOfData : BLC_FRAME , BLC_JUMBO_FRAME
  • lin : ADHOC_PROTOCOL_FLAGS , ADHOC_SERVICE_FLAGS
Generated on Fri May 30 2025 17:16:15 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: Data Fields - Variables

  • Data Structure Index
  • All
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • p
  • r
  • s
  • t
  • u
  • v
  • x

- m -

  • macronr : BLC_MACROSTATE
  • maxbaudrate : BLC_CHANNELINFO
Generated on Fri May 30 2025 17:16:15 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: Data Fields - Variables

  • Data Structure Index
  • All
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • p
  • r
  • s
  • t
  • u
  • v
  • x

- n -

  • nad : BL_dtl_t , BLC_ADHOC_EXECUTE , BLC_DTL
  • name : BL_portInfo_t , BL_targetid_t , BLC_ADHOC_PROTOCOL , BLC_ADHOC_SERVICE , BLC_CHANNELINFO , BLC_PORTINFO , BLC_RP1210_DEVICE , BLC_SECTIONINFO , BLC_TARGETID , SDF_SECTIONINFO
  • no_flowctrl_wait : ADHOC_SERVICE_FLAGS
  • nr : BLC_SECTIONINFO
  • Num0fParams : SCONFIG_LIST
  • NumOfBytes : SBYTEARRAY
  • numofchannels : BLC_TARGETID
Generated on Fri May 30 2025 17:16:15 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: Data Fields - Variables

  • Data Structure Index
  • All
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • p
  • r
  • s
  • t
  • u
  • v
  • x

- p -

  • p2_extended : BLC_ADHOC_EXECUTE
  • Parameter : SCONFIG
  • pBytes : SBYTEARRAY
  • pc_timestamp : BLC_EVENT
  • pConfig : SCONFIG_LIST
  • portNr : BL_portInfo_t , BLC_PORTINFO
  • protocoltype : ADHOC_PROTOCOL_FLAGS
Generated on Fri May 30 2025 17:16:15 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: Data Fields - Variables

  • Data Structure Index
  • All
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • p
  • r
  • s
  • t
  • u
  • v
  • x

- r -

  • req_container_size : BLC_ADHOC_SERVICE
  • req_frame_id : BLC_ADHOC_SERVICE
  • req_payload_size : BLC_ADHOC_SERVICE
  • req_slot_time : BLC_ADHOC_PROTOCOL , BLC_ADHOC_SERVICE
  • requestonly : ADHOC_SERVICE_FLAGS
  • reserved1 : BLC_CHANNELINFO
  • reserved2 : BLC_CHANNELINFO
  • reserved3 : BLC_CHANNELINFO
  • rsp_container_size : BLC_ADHOC_SERVICE
  • rsp_delay : BLC_ADHOC_PROTOCOL , BLC_ADHOC_SERVICE
  • rsp_frame_id : BLC_ADHOC_SERVICE
  • rsp_payload_size : BLC_ADHOC_SERVICE
  • rsp_slot_time : BLC_ADHOC_PROTOCOL , BLC_ADHOC_SERVICE
Generated on Fri May 30 2025 17:16:15 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: Data Fields - Variables

  • Data Structure Index
  • All
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • p
  • r
  • s
  • t
  • u
  • v
  • x

- s -

  • sectionCount : BLC_SDFINFO
  • sectionNr : SDF_SECTIONINFO
  • serial : BL_targetid_t , BLC_TARGETID
  • serial_number : BLC_RP1210_DEVICE
  • shortenlcf_rcv : ADHOC_SERVICE_FLAGS
  • shortenlcf_txd : ADHOC_SERVICE_FLAGS
  • shortensf_rcv : ADHOC_SERVICE_FLAGS
  • shortensf_txd : ADHOC_SERVICE_FLAGS
  • signal_index : BLC_LOG
  • slaveprotocol : ADHOC_PROTOCOL_FLAGS
  • source : BLC_LOG
  • source_type : BLC_LOG
  • spare : BL_targetid_t
  • state : BLC_MACROSTATE
  • status : BL_dtl_t , BL_error_t , BL_frame_t , BLC_DTL , BLC_ERROR
  • sub_index : BLC_LOG
  • synctime : BL_frame_t
Generated on Fri May 30 2025 17:16:15 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: Data Fields - Variables

  • Data Structure Index
  • All
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • p
  • r
  • s
  • t
  • u
  • v
  • x

- t -

  • time : BL_frame_t
  • timestamp : BL_error_t , BL_frame_t , BLC_ERROR , BLC_EVENT , BLC_FRAME , BLC_JUMBO_FRAME , BLC_MACROSTATE , BLC_SIGNAL
  • timestamp_unix : BLC_LOG
  • timestamp_usec : BLC_LOG
  • tx_shortenlcf : ADHOC_PROTOCOL_FLAGS
  • tx_shortensf : ADHOC_PROTOCOL_FLAGS
  • type : BL_error_t , BL_portInfo_t , BL_targetid_t , BLC_CHANNELINFO , BLC_ERROR , BLC_PORTINFO , BLC_SECTIONINFO , BLC_TARGETID , SDF_SECTIONINFO
Generated on Fri May 30 2025 17:16:15 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: Data Fields - Variables

  • Data Structure Index
  • All
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • p
  • r
  • s
  • t
  • u
  • v
  • x

- u -

  • unused_1 : ADHOC_PROTOCOL_FLAGS , ADHOC_SERVICE_FLAGS
  • unused_2 : ADHOC_PROTOCOL_FLAGS , ADHOC_SERVICE_FLAGS
  • unused_3 : ADHOC_PROTOCOL_FLAGS , ADHOC_SERVICE_FLAGS
  • unused_4 : ADHOC_SERVICE_FLAGS
  • unused_5 : ADHOC_SERVICE_FLAGS
  • use_std_negresp : ADHOC_PROTOCOL_FLAGS , ADHOC_SERVICE_FLAGS
  • use_std_posresp : ADHOC_PROTOCOL_FLAGS , ADHOC_SERVICE_FLAGS
Generated on Fri May 30 2025 17:16:15 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: Data Fields - Variables

  • Data Structure Index
  • All
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • p
  • r
  • s
  • t
  • u
  • v
  • x

- v -

  • value : BL_frame_t , BL_signal_t , BLC_SIGNAL
  • Value : SCONFIG
  • value_array_size : BLC_LOG
  • value_data : BLC_LOG
  • value_element_size : BLC_LOG
  • value_signed : BLC_LOG
  • version : BL_targetid_t , BLC_TARGETID
  • version_major : BLC_SDFINFO
  • version_minor : BLC_SDFINFO
Generated on Fri May 30 2025 17:16:15 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: Data Fields - Variables

  • Data Structure Index
  • All
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • p
  • r
  • s
  • t
  • u
  • v
  • x

- x -

  • xmit_can_11_29bit : ADHOC_PROTOCOL_FLAGS
  • xmit_canfd_frame : ADHOC_PROTOCOL_FLAGS
  • xmit_canfd_switch : ADHOC_PROTOCOL_FLAGS
  • xmit_chksumtype : ADHOC_PROTOCOL_FLAGS
  • xmit_no_flowctrl_wait : ADHOC_PROTOCOL_FLAGS
  • xmit_shortenflowctrl : ADHOC_PROTOCOL_FLAGS
  • xmit_shortenlcf : ADHOC_PROTOCOL_FLAGS
  • xmit_shortensf : ADHOC_PROTOCOL_FLAGS
Generated on Fri May 30 2025 17:16:15 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: Data Fields

  • Data Structure Index
  • All
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • p
  • r
  • s
  • t
  • u
  • v
  • x
Here is a list of all struct and union fields with links to the structures/unions they belong to:

- x -

  • xmit_can_11_29bit : ADHOC_PROTOCOL_FLAGS
  • xmit_canfd_frame : ADHOC_PROTOCOL_FLAGS
  • xmit_canfd_switch : ADHOC_PROTOCOL_FLAGS
  • xmit_chksumtype : ADHOC_PROTOCOL_FLAGS
  • xmit_no_flowctrl_wait : ADHOC_PROTOCOL_FLAGS
  • xmit_shortenflowctrl : ADHOC_PROTOCOL_FLAGS
  • xmit_shortenlcf : ADHOC_PROTOCOL_FLAGS
  • xmit_shortensf : ADHOC_PROTOCOL_FLAGS
Generated on Fri May 30 2025 17:16:15 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: markdowns/SdfScript/General.md File Reference

markdowns/SdfScript/General.md File Reference

Go to the source code of this file.

Generated on Fri May 30 2025 17:16:13 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: markdowns/SdfScript/General.md Source File

markdowns/SdfScript/General.md
Go to the documentation of this file.
1 @ingroup sdf_script
2
3 The DLL supports the execution of a SDF script file.
4 These are normal ".sdf" files which contain script code instead of the binary SDF data.
5 <br>
6 SDF scripts only work on PC and the MB-II but not in the standalone application mode of normal devices, as the device can't execute the scripts.
7
8 ## Use cases
9 Normally, a script SDF is coupled with a normal binary SDF and is used to execute script code when the normal SDF is loaded.<br>
10 This way, you can modify the data of the binary SDF, like setting signals or table values.<br>
11 This also allows to automatically start operation when a SDF is loaded.<br>
12 ![](structure.png)
13
14 ## Creating a script SDF
15 To create a script SDF, you only need to create a new file with the ".sdf" extension.<br>
16 You can now edit this file with any texteditor.<br>
17 <br>
18 Script SDFs require a certain header to work and be loadable by the DLL or the SimpeMenu.<br>
19 The first line of your script has to be:<br>
20 ~~~~~~~~~~~~~~~{.py}
21 -- [HEADER] SDFType=script ScriptVersion=100
22 ~~~~~~~~~~~~~~~
23 <br>
24 You can now specify a binary SDF to load if you need one:
25 ~~~~~~~~~~~~~~~{.py}
26 sdf_file = "YourBinarySDF.sdf"
27 ~~~~~~~~~~~~~~~
28 <br>
29 And you can specify functions that will be called <i>after</i> the DLL loaded the binary SDF and the script SDF.
30 ~~~~~~~~~~~~~~~{.py}
31 function OnDownloadSection_1(channel)
32
33 end
34 ~~~~~~~~~~~~~~~
35 <br>
36 You can modify the function names suffix of "1" to match the required channel.<br>
37 The channel numbering is the same as the number of the section of SDF as shown in the SessionConf.<br>
38 So the function in the example above will be loaded when (and *only when!) the SDFs section 1 is loaded onto a device.<br>
39 Especially on the BabyLIN-MB-II this might not always be the case, which will result in the function not being called.<br>
40 <br><b>See @ref script_sdf_obj_channel for further information about the "channel" argument of this function.</b>
41
42 ## Hello World!
43 Using the information from above, a simple, minimum script SDF could look like this:
44
45 ~~~~~~~~~~~~~~~{.py}
46 -- [HEADER] SDFType=script ScriptVersion=100
47 sdf_file = "YourBinarySDF.sdf"
48
49 function OnDownloadSection_1(channel)
50 print("Hello from a script SDF!")
51 end
52 ~~~~~~~~~~~~~~~
53
54 This example will print "Hello from a script SDF!" to a registered LUA callback and not modify the binary SDF.
55
56 ## DLL callbacks
57 You can register callbacks that will be run, if a script SDF print something using the "print" script function using the @ref BLC_registerLuaPrintCallback DLL function.<br>
58 You can also register the @ref BLC_registerLuaErrorCallback which will print error information when your script fails. This might be helpful to debug issues.<br>
59 <br>
Generated on Fri May 30 2025 17:16:12 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: markdowns/SdfScript/Global scope.md File Reference

markdowns/SdfScript/Global scope.md File Reference

Go to the source code of this file.

Generated on Fri May 30 2025 17:16:13 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: markdowns/SdfScript/Global scope.md Source File

markdowns/SdfScript/Global scope.md
Go to the documentation of this file.
1 @ingroup sdf_script_global
2
3 The global scope means any script statements <b>outside</b> of "function [...]" blocks.<br>
4 Currently there are only a few functions or variables to set from the global scope:<br>
5
6 | Name | Description |
7 |---|---|
8 | sdf_file | A variable containing the name of the SDF to load.<br><br><b>Default</b>: '' |
9 | sdf_force_download | If this variable is set to "false", the binary SDF pointed to by "sdf_file" might not be actually reloaded.<br>This is useful if you want to reexecute the script SDF but not change the current binary SDF state.<br><b>Warning</b>: If this value is 'false', reloading the script SDF does not change the binary SDFs state. So any running bus will keep running and all virtual signals etc. will keep their values and NOT be resetted to the default values.<br><br><b>Default</b>: true |
Generated on Fri May 30 2025 17:16:12 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: markdowns/limitations.md File Reference

markdowns/limitations.md File Reference

Go to the source code of this file.

Generated on Fri May 30 2025 17:16:13 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: markdowns/limitations.md Source File

markdowns/limitations.md
Go to the documentation of this file.
1 # Limitations
2 @ingroup limitations
3
4 In this chapter all known limitations of the BabyLIN library are listed.
5
6 #### Protocol Service Data Mapping
7
8 The services configurable via the @ref ua interface can not map more then 268435455 Bytes (~256 MB) in a single binary mapping.
9
10 #### UDS Services
11
12 The following UDS Services do not yet have named properties for data mappings:
13 @ref ua_uds_responseonevent, @ref ua_uds_readdatabyperiodicidentifier and @ref ua_uds_dynamicallydefinedataidentifier.
14 Mapping data from and to those services requires you to use free mappings as described in @ref ua_service_iso_tp
Generated on Fri May 30 2025 17:16:12 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: markdowns/UnifiedAccess/LogFile.md File Reference

markdowns/UnifiedAccess/LogFile.md File Reference

Go to the source code of this file.

Generated on Fri May 30 2025 17:16:13 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: markdowns/UnifiedAccess/LogFile.md Source File

markdowns/UnifiedAccess/LogFile.md
Go to the documentation of this file.
1 # The log file
2 @ingroup ua_logfile
3
4 You should first read through the @ref ua.<br/>
5
6 The BabyLIN library allows to log data of a Baby-LIN device.<br>
7 This log file can be configured in many ways, especially the data, that is logged, the file format and the mode, when data are written.<br>
8
9 Here all available __Tags__ of an log file can be looked up.
10
11 #### Property __Tags__
12
13 | __Tag__ | __Default Value__ | __Type__ | __Description__ |
14 | :--: | :--: | :--: | :-- |
15 | `config_name` | \"Log config\" | String | The name of the config. This name is optional and can be used to identify the log config. |
16 | `block_on_destruction` | false | Boolean | If true, the destruction of the log object blocks, until the writing of the file is finished.<br>If false, the file writing may be delayed until after the destruction.<br>This flag changes the behaviour of BLC_destroy().<br>\warning This property can not be set from within a SDF. |
17 | `flush_peridically` | false | Boolean | If true, the logfile will be flushed (written to disk) periodically.<br>If false, the file writing may be delayed until a close is called.<br>This flag may reduce the performance.<br>\warning This property can not be set from within a SDF. |
18 | `file_path` | Windows: C:\\Users\\<username>\\Documents\\Lipowsky Industrie-Elektronik GmbH\\Logs\\<br>Linux: /home/<username>/Documents/Lipowsky Industrie-Elektronik GmbH/Logs/ | String | This is the path, where the log files will be created. |
19 | `file_prefix` | \"Log_\" | String | This is a fixed prefix for all log files.<br>The maximum log size will be evaluated depending on this filename prefix. |
20 | `file_postfix` | \"%Y_%m_%d_%H_%M_%S\" | String | Adds a timestamp postfix to the filename.<br>The timestamp postfix is only added, if this format string is not empty.<br>See @ref ua_datetimeformat for supported date and time format specifiers. |
21 | `file_extension` | \"log\" | String | This is the extension of the log file.<br>A '.' will be added automatically between the filename and extension. |
22 | `max_filesize` | 10 MB | 64bit Number | This is the maximum file size for a log file.<br>If this file size is exceeded:<br>- the current log file will be closed<br>- a new log file will be created<br>- the logging will continue in the new file<br>\warning The final log size may be slightly larger than this value.<br>Please note, that the size of a report vary along different reports types and the memory size does not represent the final file size. |
23 | `log_format` | 1<br>(3rd party compatible ASCII log) | 32bit Number | This is the format of the log file:<br>0: Lipowsky binary log<br>1: 3rd party compatible ASCII log<br>4: CSV frame log<br>5: CSV signal log<br>6: Raw log |
24 | `enable_frames` | See table below. | Boolean | If true (1), frames will be logged. |
25 | `enable_signals` | See table below. | Boolean | If true (1), signals will be logged. |
26 | `enable_macrostates` | See table below. | Boolean | If true (1), macro state changes will be logged. |
27 | `enable_errors` | See table below. | Boolean | If true (1), errors will be logged. |
28 | `enable_events` | See table below. | Boolean | If true (1), events will be logged. |
29 | `enable_debug` | See table below. | Boolean | If true (1), debug messages will be logged. |
30 | `enable_comments` | See table below. | Boolean | If true (1), application comments will be logged. |
31 | `date_line_format` | \"%%a %%B %%d %%H:%%M:%%S %%Y\" | String | Adds a date line on top of the header.<br>The line starts with \"date \".<br>The lines are only added, if this text property is not empty.<br>See @ref ua_datetimeformat for supported date and time format specifiers. |
32 | `internal_events_line_enabled` | true | Boolean | Adds a line with the fixed text:<br>\"internal events logged\" |
33 | `format_version` | \"8.0.0\" | String | Adds a line with a version number.<br>Just add the version number, e.g. \"11.0.0\".<br>The line in the log file will then be: \"version 11.0.0\"<br>The lines are only added, if this text property is not empty. |
34 | `additional_header_text` | <> | String | Adds a custom header text.<br>This custom header text will be added without the comment prefix.<br>You may use \"\\n\" to add a new line.<br>The lines are only added, if this text property is not empty. |
35 | `additional_header_comment` | <> | String | Adds a custom header comment.<br>This custom header comment will be added with the comment prefix.<br>You may use \"\\n\" to add a new line.<br>The lines are only added, if this text property is not empty. |
36 | `trigger_block_enabled` | true | Boolean | Marks the complete log as the trigger block.<br>Before the regular logging, this text is added with a timestamp: \"Begin Triggerblock\".<br>After the regular logging, this text is added: \"End TriggerBlock\". |
37 | `start_entry` | \"Start of measurement\" | String | Adds this text, at the beginning of the regular logging.<br>The lines are only added, if this text property is not empty. |
38 | `timestamp_decimal_places` | 6 | 32bit Number | This is the number of decimal places used after the decimal point.<br>If the number of decimal places of the timestamp is lower, zeros will be added. |
39 | `timestamp_integer_places` | 4 | 32bit Number | This is the number of integer places used before the decimal point.<br>If the number of integer places of the timestamp is lower, space characters will be added. |
40 | `align_timestamp_enabled` | false | Boolean | Check to align the timestamp of comments and reports with the frame reports.<br>3 space characters will be added before the tiemstamp of a frame report. |
41 | `preceding_timestamp_format` | <> | String | Adds an absolute timestamp before each report.<br>The absolute timestamp is only added, if this format string is not empty.<br><br>See @ref ua_datetimeformat for supported date and time format specifiers. |
42 | `min_frame_id_chars` | 15 | 32bit Number | This is the number of characters the frame ID will at least use.<br>If the number of characters for the frame ID is lower, space characters will be added. If the frame ID requires more characters, the lines may no longer be justified. |
43 | `d_column_enabled` | false | Boolean | Check to enable a column with 'd' characters before the data length of frame reports. |
44 | `checksum_enabled` | true | Boolean | Check to enable the Checksum entry as decimal number at the end. |
45 | `frame_id_enabled` | true | Boolean | Check to enable the frame ID as decimal number at the end. |
46 | `channel_mapping` | \"Li\\nL2\\nL3\\nL4\\nL5\\nL6\\nC1\\nC2\\nC3\" | String | Choose the ID for a channel.<br>Each line represents a bus channel.<br>You can simply click the Baby-LIN device, that is used to record the log to get the default layout. |
47 | `is_extended` | false<br>Simple format | Boolean | false: Simple format<br>The simple format only stores necessary information.<br>Use it, if you have never used the extended format before.<br><br>true: Extended format<br>It adds certain columns for compatibility reasons.<br>Use it only, if you have used it before. |
48 | `integer_coding` | 1<br>Hexadecimal | 32bit Number | 0: Decimal<br>Integer values are encoded as decimal values.<br><br>1: Hexadecimal<br>Integer values are encoded as hexadecimal values. |
49
50 #### Method __Tags__
51
52 | __Tag__ | __Parameters__ | __Description__ |
53 | :--: | :--: | :-- |
54 | `assign_channel` | `mode`=32bit Number<br>`handle`=BL_HANDLE | Use this method to assign a channel to the log file or deassign a channel from the log file.<br>If assigned, the log files will register all necessary channel callbacks.<br>If unassigned, the log files will unregister all registered channel callbacks.<br>The assign method must be recalled, if a SDF file was loaded.<br>The mode is optional and can have the follwoing values:<br>0: Unassign<br>1: Assign (Default) |
55 | `write` | `filename`=String (Optional) | Writes the log data from memory to a file.<br>If no filename is passed, a log file name will be generated based on `file_path`, `file_prefix`, `file_postfix` and `file_extension`. |
56 | `start` | | Start storing the received reports in the memory. |
57 | `stop` | | Stop storing the received reports in the memory. |
58 | `add` | `comment`=String | Adds an application specific comment. |
59 | `load` | `config`=String | Loads a log configuration using the filename passed in `config`. |
60 | `save` | `config`=String<br>`overwrite`=Boolean | Saves the current log configuration using the filename passed in `config`.<br>If the file already exists, it will only overwritten, if `overwrite` is set. |
61
62 #### Report type support of log file formats
63
64 | | __Frames__ | __Signals__ | __Macro state__ | __Errors__ | __Events__ | __Debug messages__ | __Application comments__ | __DTL requests__ | __DTL responses__ |
65 | :-- | :--: | :--: | :--: | :--: | :--: | :--: | :--: | :--: | :--: |
66 | __Lipowsky binary log__ | Supported<br>Default: Enabled | | | | | | | | |
67 | __3rd party compatible ASCII log__ | Supported<br>Default: Enabled | Supported<br>Default: Disabled | Supported<br>Default: Disabled | Supported<br>Default: Enabled | Supported<br>Default: Enabled | Supported<br>Default: Enabled | Supported<br>Default: Enabled | Supported<br>Default: Disabled | Supported<br>Default: Disabled |
68 | __CSV frame log__ | Supported<br>Default: Enabled | | | | | | | | |
69 | __CSV signal log__ | | Supported<br>Default: Enabled | | | | | | | |
70
71 \warning Signals are only reported, if the BabyLIN device is using a SDF.<br>All signals defined as GUI elements in the SDF will be logged.<br>If the BabyLIN device is monitoring without a SDF, no signals can be logged.
72
73 #### Ignored properties
74
75 Not all properties of the log configuration are always used.
76 The following list shows an overview about the application and the ignored properties.
77
78 | __Devices__ | __Application__ | __Configuration source__ | __Target__ | __Ignored or special properties__ |
79 | :-- | :-- | :-- | :-- | :-- |
80 | All Baby-LIN devices | SimpleMenu | Log configuration dialog | Local PC storage | |
81 | All Baby-LIN devices | Custom application using<br>the Baby-LIN library | @ref ua interface of<br>the Baby-LIN library. | Local PC storage | |
82 | All Baby-LIN devices | SDF loaded by LINWorks<br>or custom application<br>using the Baby-LIN library | Print macro commands<br>within a SDF. | Local PC storage | `file_path`: Should be empty to use default path, that is availbale on all machines |
83 | Baby-LIN-MB-II | SDF logging<br>in PLC application<br>or stand alone mode | Print macro commands<br>within a SDF | Internal<br>Baby-LIN-MB-II<br>storage | `file_path`: Is a local path within the Baby-LIN-MB-II<br>`file_prefix`: Should not be 'Log_' to not collide with the genral logging |
84 | Baby-LIN-MB-II | Background logging<br>in PLC application<br>or stand alone mode | Log configuration file<br>uploaded via web interface | Internal<br>Baby-LIN-MB-II<br>storage | `file_path`: Is a local path within the Baby-LIN-MB-II<br>`file_prefix`, `file_postfix`, `file_extension`: Uses a fixed algorithm<br>`max_logsize`: Limited by the Baby-LIN-MB-II storage<br>`channel_mapping`: Contains the Baby-LIN-MB-II channels<br>`additional_header_comment`: Contains information about the Baby-LIN-MB-II |
85 | All Baby-LIN devices | External trigger | Log configuration dialog | Local PC storage | `file_path`: Should be empty to use default path, that is availbale on all machines |
86 | All Baby-LIN devices | Log file conversion<br>in LogViewer export | Log configuration dialog | Local PC storage | `file_path`, `file_prefix`, `file_postfix`, `file_extension`: The target filename is selected <br>`max_filesize`, `max_logsize`, `max_storage_time`: The target file size is not limited by the software |
Generated on Fri May 30 2025 17:16:12 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: markdowns/UnifiedAccess/SDF/Macro.md File Reference

markdowns/UnifiedAccess/SDF/Macro.md File Reference

Go to the source code of this file.

Generated on Fri May 30 2025 17:16:13 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: markdowns/UnifiedAccess/SDF/Macro.md Source File

markdowns/UnifiedAccess/SDF/Macro.md
Go to the documentation of this file.
1 # The Macro
2 @ingroup ua_sdf_macro
3
4 You should first read through the @ref ua.<br/>
5 Here all available __Tags__ of a Macro can be looked up.
6
7 #### Child __Tags__
8
9 | __Tag__ | __Type__ | __Description__ |
10 | :--: | :--: | :-- |
11 | `parameter` | <span style="white-space: nowrap;">32bit Number</span><br>String | find a @ref ua_macro_parameter by index or name. |
12
13 #### Property __Tags__
14
15 | __Tag__ | Default Value | __Type__ | __Description__ |
16 | :--: | :--: | :--: | :-- |
17 | `name` | <> | String | The name, of the Macro. |
18 | `index` | <> | <span style="white-space: nowrap;">32bit Number</span> | The Macro's index in the @ref ua_section 's `macro` list. |
19 | `parameter_count` | <> | <span style="white-space: nowrap;">32bit Number</span> | The number of @ref ua_macro_parameter of this macro. |
Generated on Fri May 30 2025 17:16:12 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: markdowns/UnifiedAccess/SDF/MacroParameters.md File Reference

markdowns/UnifiedAccess/SDF/MacroParameters.md File Reference

Go to the source code of this file.

Generated on Fri May 30 2025 17:16:13 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: markdowns/UnifiedAccess/SDF/MacroParameters.md Source File

markdowns/UnifiedAccess/SDF/MacroParameters.md
Go to the documentation of this file.
1 # The Macro Parameters
2 @ingroup ua_macro_parameter
3
4 You should first read through the @ref ua.<br/>
5 Here all available __Tags__ of a Macro Parameter can be looked up.
6
7 #### Property __Tags__
8
9 | __Tag__ | Default Value | __Type__ | __Description__ |
10 | :--: | :--: | :--: | :-- |
11 | `name` | <> | String | The name, of the Parameter. |
12 | `index` | <> | <span style="white-space: nowrap;">32bit Number</span> | The Parameter's index in the @ref ua_sdf_macro 's `parameter` list. |
Generated on Fri May 30 2025 17:16:12 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: markdowns/mainpage.md File Reference

markdowns/mainpage.md File Reference

Go to the source code of this file.

Generated on Fri May 30 2025 17:16:13 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: markdowns/mainpage.md Source File

markdowns/mainpage.md
Go to the documentation of this file.
1 BabyLINDLL Documentation {#mainpage}
2 ============
3
4 These documents describe the BabyLIN-DLL C Interface of BabyLIN devices with CAN support and therefore mainly address developers not using the LinWorks SimpleMenu application to run simulations.
5 Nevertheless, the [General Information](#general_information) chapters might be interesting for all BabyLIN users as they describe the essential changes in the BabyLIN infrastructure.
6
7 <hr>
8 The @ref return_values are the first chapter and can help with some of the issues.
9 <hr>
10 Information about the @ref BLC_sendCommand s command parameter can be found in the @ref Commands chapter.
11 <hr>
12 An Introduction to the @ref ua will help getting an over view over the internal data structures.
13 <hr>
14
15 [TOC]
16
17 # General Information {#general_information}
18
19 With the introduction of CAN support in BabyLIN devices, the changes in hardware cause basic changes in the LinWorks software as well as the BabyLIN-DLL structure.
20 Previous BabyLIN devices were restricted to one LIN bus. This setup made it possible to use the USB **connection** to the device for handling the LIN bus ( refer picture [Old BabyLIN structure](#babylin_structure_old.png) ).
21
22 ![Old BabyLIN structure](@ref babylin_structure_old.png "Old BabyLIN structure")
23 The CAN support introduces devices with multiple bus interfaces (LIN and CAN). To distinguish between the bus interfaces, the BabyLIN structure represents
24 each bus interface using a **channel** ( i.e. LIN-channel and CAN-channel ). Furthermore, the BabyLIN device itself provides a **DEVICE-channel** for configuration and status purposes. Picture [New BabyLIN structure](#babylin_structure_new.png) shows a USB
25 connection with a LIN, two CAN and one DEVICE channel. These devices are called **multi-channel-devices**.
26 ![New BabyLIN structure](@ref babylin_structure_new.png "New BabyLIN structure")
27 The channel-based design of the BabyLIN structure allows the user to use each channel in a similar way as in the old structure.
28
29 The introduction of channels leads to new specifications for all software components in the BabyLIN portfolio. First of all, the **Session Description File (SDF)** format has to provide configurations for different types of channels.
30 This issue is addressed by introducing **SDF-sections**. A section within an SDF stores the configuration of exactly one channel. A SDF can store multiple sections. The sections will be mapped to a matching channel in the device upon download.
31 The BabyLIN-DLL API has to provide an interface to the new structure and SDF format, as does the LinWorks software.
32
33 # BabyLIN DLL - New And Old API {#bldllapi_new_and_old_api}
34
35 In order to provide a convenient way to use multi-channel-devices and reduce the overhead in application development, the API is designed to support both, new and old (legacy) API calls.
36 All legacy API calls startet with the prefix **BL_**. These calls are deprecated but still work. The naming convention for new API calls provides the prefix **BLC_** ( Baby-Lin-Can ).
37 The following table shows how the devices and APIs may be combined:
38
39 <div class="alignmiddle">
40
41 | API | Old BabyLIN Device | Multi-Channel-Device |
42 | -----------: | :-----------: | :-----------: |
43 | Legacy | X | X |
44 | New | X | X |
45
46 </div>
47
48 \note It is possible to use legacy API-calls on multi-channel-devices, but in order to make use if the multi-channel-functionality, the new API functions have to be used.
49
50 This philosophy of API-calls allows the usage of multi-channel-devices with existing applications using the legacy API. In this case, the device will be used as an old, single-channel-device with only one LIN channel.
51 On the other hand, when using an old, single-channel-device with the new API, the device will be handled as a device with a virtual DEVICE- and LIN-channel.
52 Working on a channel representing a LIN- or CAN-BUS ( i.e. a BUS-channel ), is very similar to working with an old (single-channel) device connection.
53 The main difference between legacy- and new API usage is the setup of the device connection with and without channel awareness.
54
55 Comparison Of Basic API Flow {#bldllapi_comparison_flow}
56 ---
57 The following pictures show an example flow of how the legacy- and new API work
58
59 <div class="alignmiddle">
60
61 Old BabyLIN Device | Multi-Channel-Device
62 :-----------: | :-----------:
63 ![Old BabyLIN API flow](@ref babylin_api_flow_old.png "Old BabyLIN API flow") | ![New BabyLIN API flow](@ref babylin_api_flow_new.png "New BabyLIN API flow")
64
65 </div>
BLC_sendCommand
int BL_DLLIMPORT BLC_sendCommand(BL_HANDLE handle, const char *command)
Send a command to the BabyLIN device.
Generated on Fri May 30 2025 17:16:12 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: markdowns/UnifiedAccess/SDF/Node.md File Reference

markdowns/UnifiedAccess/SDF/Node.md File Reference

Go to the source code of this file.

Generated on Fri May 30 2025 17:16:13 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: markdowns/UnifiedAccess/SDF/Node.md Source File

markdowns/UnifiedAccess/SDF/Node.md
Go to the documentation of this file.
1 # The SDF Node
2 @ingroup ua_sdf_node
3
4 You should first read through the @ref ua.<br/>
5 Here all available __Tags__ of a Node can be looked up.
6
7 #### Child __Tags__
8
9 | __Tag__ | __Type__ | __Description__ |
10 | :--: | :--: | :-- |
11 | `frame` | <span style="white-space: nowrap;">32bit Number</span><br>String | return the associated @ref ua_sdf_frame. |
12
13 #### Property __Tags__
14
15 | __Tag__ | Default Value | __Type__ | __Description__ |
16 | :--: | :--: | :--: | :-- |
17 | `name` | <> | String | The name, of the node. |
18 | `index` | <> | <span style="white-space: nowrap;">32bit Number</span> | The node's index in the @ref ua_section 's `node` list. |
19 | `emulated` | <> | Boolean | True if the node is emulated. |
20 | `frame_count` | <> | <span style="white-space: nowrap;">32bit Number</span> | The amount of available [Frames](@ref ua_sdf_frame) for this node. |
21
Generated on Fri May 30 2025 17:16:12 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: markdowns/UnifiedAccess/NullHandle.md File Reference

markdowns/UnifiedAccess/NullHandle.md File Reference

Go to the source code of this file.

Generated on Fri May 30 2025 17:16:13 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: markdowns/UnifiedAccess/NullHandle.md Source File

markdowns/UnifiedAccess/NullHandle.md
Go to the documentation of this file.
1 # The DLL Handle
2 @ingroup ua_null_handle
3
4 You should first read through the @ref ua.<br>
5 Here all available __Tags__ of the DLL Handle can be looked up.<br>
6 The DLL Handle is a unique Handle, that can be retrieved by calling @ref BLC_createHandle with a handle value of 0 and an empty path.
7
8 ~~~.c
9 BL_HANDLE dll_handle;
10 BLC_createHandle(0, "", &dll_handle);
11 ~~~
12
13 #### Create Child __Tags__
14
15 | __Tag__ | __Child Tag__| __Description__ |
16 | :--: | :--: | :-- |
17 | `new_logfile` | `logfile`| creates a new @ref ua_logfile |
18
19 #### Property __Tags__
20
21 | __Tag__ | Default Value | __Type__ | __Description__ |
22 | :--: | :--: | :--: | :-- |
23 | `version` | <> | String | The Version of the library. |
24 | `utf8path` | false | Boolean | If set to 'true' the file paths will be interpreted as UTF-8 encoded Strings. Thus allowing to access SDF files with filenames/paths, that contain Characters, which can not be printed in the current locale. |
25 | `global_sdf_log_enabled` | true | Boolean | If true, logging from a SDF is enabled. The print commands are handled by the BabyLIN library and log files can be created. |
26 | `global_max_log_memory` | 100MB | 64Bit Nubmer | This is the maximum amount of RAM memory, that will be used by @ref ua_logfile. |
27 | `global_fixed_log_path` | \"\" | String | If set, all @ref ua_logfile will be redirected to this folder. |
BLC_createHandle
int32_t BL_DLLIMPORT BLC_createHandle(BL_HANDLE handle, const char *path, BL_HANDLE *result)
BLC_createHandle retrieves a handle to a loaded Object or creates a new Object.
BL_HANDLE
void * BL_HANDLE
Definition: BabyLINReturncodes.h:34
Generated on Fri May 30 2025 17:16:12 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: Related Pages

Related Pages
Here is a list of all related documentation pages:
Generated on Fri May 30 2025 17:16:15 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: markdowns/SdfScript/Print.md File Reference

markdowns/SdfScript/Print.md File Reference

Go to the source code of this file.

Generated on Fri May 30 2025 17:16:13 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: markdowns/SdfScript/Print.md Source File

markdowns/SdfScript/Print.md
Go to the documentation of this file.
1 @ingroup script_sdf_func_print
2
3 ## Description
4 Prints the given arguments as a string to the @ref BLC_registerLuaPrintCallback.<br>
5 It accepts variable number of arguments and will try to convert them from any type to a string.<br>
6 The function does not return anything.<br>
7 <br>
8 <b>Syntax</b>:
9 ~~~~~~~~~~~~~~~{.py}
10 print(str, [any ...])
11 ~~~~~~~~~~~~~~~
12
13 ## Examples
14 ~~~~~~~~~~~~~~~{.py}
15 print("SimpleString")
16 print('SingleQuotedString')
17 print('Concat'..' this'..' string')
18 print('Concat with a variable: '..var)
19 print('Concat with a variable: ', var1, var2, var3)
20 ~~~~~~~~~~~~~~~
BLC_registerLuaPrintCallback
int BL_DLLIMPORT BLC_registerLuaPrintCallback(BL_HANDLE handle, BLC_lua_print_func_ptr *func, void *userdata)
Registers a callback that will be called when the lua "print" function is called. ...
Generated on Fri May 30 2025 17:16:12 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: markdowns/UnifiedAccess/UDS/Protocol_FFCBO.md File Reference

markdowns/UnifiedAccess/UDS/Protocol_FFCBO.md File Reference

Go to the source code of this file.

Generated on Fri May 30 2025 17:16:13 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: markdowns/UnifiedAccess/UDS/Protocol_FFCBO.md Source File

markdowns/UnifiedAccess/UDS/Protocol_FFCBO.md
Go to the documentation of this file.
1 # The First Frame Callback Object
2 @ingroup ua_ffcbo
3
4 You should first read through the @ref ua.<br/>
5 Here all specific __Tags__ of the temporary First Frame Callback Object can be looked up.
6 The __Tags__ from @ref ua_protocol_iso_tp are also supported.<br/>
7 This Object is only extending the @ref ua_protocol_iso_tp Object for its `ff_callback` context.
8
9
10 #### Property __Tags__
11
12 | __Tag__ | __Default Value__ | __Type__ | __Description__ |
13 | :--: | :--: | :--: | :-- |
14 | `frame_id` | <> | <span style="white-space: nowrap;">32bit Number</span> | The frame ID of the First Frame Candidate. |
15 | `frame_data` | <> | Binary | The Frame Data as they were on the bus. |
16 | `nad` | <> | 8bit Number | The node address of the First Frame Candidate. If the Frame is definitely a ISO-TP frame without NAD, requesting this property will result in a @ref BLC_UA_GET_VALUE_REJECTED. |
17 | `payload_nad` | <> | Binary | The Protocol payload of the First Frame Candidate. Interpreting Byte 1 as PCI. |
18 | `payload_no_nad` | <> | Binary | The Protocol payload of the First Frame Candidate. Interpreting Byte 0 as PCI. |
BLC_UA_GET_VALUE_REJECTED
#define BLC_UA_GET_VALUE_REJECTED
Definition: BabyLINReturncodes.h:113
Generated on Fri May 30 2025 17:16:12 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: markdowns/UnifiedAccess/Protocol_ISO_TP.md File Reference

markdowns/UnifiedAccess/Protocol_ISO_TP.md File Reference

Go to the source code of this file.

Generated on Fri May 30 2025 17:16:13 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: markdowns/UnifiedAccess/Protocol_ISO_TP.md Source File

markdowns/UnifiedAccess/Protocol_ISO_TP.md
Go to the documentation of this file.
1 # The Base ISO-TP protocol
2 @ingroup ua_protocol_iso_tp
3
4 You should first read through the @ref ua.<br/>
5 Here all available __Tags__ of an ISO-TP Protocol can be looked up.
6
7 #### Child __Tags__
8
9 | __Tag__ | __Type__ | __Description__ |
10 | :--: | :--: | :-- |
11 | `service` | <span style="white-space: nowrap;">32bit Number</span><br>String | Finds a @ref ua_service_iso_tp by index or name. |
12
13 #### Create __Tags__
14
15 | __Tag__ | __Child Tag__ | __Description__ |
16 | :--: | :--: | :-- |
17 | `new_service` | `service` | Creates a new @ref ua_service_iso_tp of type @ref ua_service_iso_tp |
18 |--|--|--|
19 | `new_DiagnosticSessionControl` | `service` | Creates a new @ref ua_service_iso_tp of type @ref ua_uds_diagnosticsessioncontrol |
20 | `new_ECUReset` | `service` | Creates a new @ref ua_service_iso_tp of type @ref ua_uds_ecureset |
21 | `new_SecurityAccess` | `service` | Creates a new @ref ua_service_iso_tp of type @ref ua_uds_securityaccess |
22 | `new_CommunicationControl` | `service` | Creates a new @ref ua_service_iso_tp of type @ref ua_uds_communicationcontrol |
23 | `new_TesterPresent` | `service` | Creates a new @ref ua_service_iso_tp of type @ref ua_uds_testerpresent |
24 | `new_AccessTimingParameter` | `service` | Creates a new @ref ua_service_iso_tp of type @ref ua_uds_accesstimingparameter |
25 | `new_SecuredDataTransmission` | `service` | Creates a new @ref ua_service_iso_tp of type @ref ua_uds_secureddatatransmission |
26 | `new_ControlDTCSetting` | `service` | Creates a new @ref ua_service_iso_tp of type @ref ua_uds_controldtcsetting |
27 | `new_ResponseOnEvent` | `service` | Creates a new @ref ua_service_iso_tp of type @ref ua_uds_responseonevent |
28 | `new_LinkControl` | `service` | Creates a new @ref ua_service_iso_tp of type @ref ua_uds_linkcontrol |
29 |--|--|--|
30 | `new_ReadDataByIdentifier` | `service` | Creates a new @ref ua_service_iso_tp of type @ref ua_uds_readdatabyidentifier |
31 | `new_ReadMemoryByAddress` | `service` | Creates a new @ref ua_service_iso_tp of type @ref ua_uds_readmemorybyaddress |
32 | `new_ReadScalingDataByIdentifier` | `service` | Creates a new @ref ua_service_iso_tp of type @ref ua_uds_readscalingdatabyidentifier |
33 | `new_ReadDataByPeriodicIdentifier` | `service` | Creates a new @ref ua_service_iso_tp of type @ref ua_uds_readdatabyperiodicidentifier |
34 | `new_DynamicallyDefineDataIdentifier` | `service` | Creates a new @ref ua_service_iso_tp of type @ref ua_uds_dynamicallydefinedataidentifier |
35 | `new_WriteDataByIdentifier` | `service` | Creates a new @ref ua_service_iso_tp of type @ref ua_uds_writedatabyidentifier |
36 | `new_WriteMemoryByAddress` | `service` | Creates a new @ref ua_service_iso_tp of type @ref ua_uds_writememorybyaddress |
37 |--|--|--|
38 | `new_ClearDiagnosticInfromation` | `service` | Creates a new @ref ua_service_iso_tp of type @ref ua_uds_cleardiagnosticinformation |
39 | `new_ReadDTCInformation` | `service` | Creates a new @ref ua_service_iso_tp of type @ref ua_uds_readdtcinformation |
40 |--|--|--|
41 | `new_InputOutputControlByIdentifier` | `service` | Creates a new @ref ua_service_iso_tp of type @ref ua_uds_inputoutputcontrolbyidentifier |
42 |--|--|--|
43 | `new_RoutineControl` | `service` | Creates a new @ref ua_service_iso_tp of type @ref ua_uds_routinecontrol |
44 |--|--|--|
45 | `new_RequestDownload` | `service` | Creates a new @ref ua_service_iso_tp of type @ref ua_uds_requestdownload |
46 | `new_RequestUpload` | `service` | Creates a new @ref ua_service_iso_tp of type @ref ua_uds_requestupload |
47 | `new_TransferData` | `service` | Creates a new @ref ua_service_iso_tp of type @ref ua_uds_transferdata |
48 | `new_RequestTransferExit` | `service` | Creates a new @ref ua_service_iso_tp of type @ref ua_uds_requesttransferexit |
49 | `new_RequestFileTransfer` | `service` | Creates a new @ref ua_service_iso_tp of type @ref ua_uds_requestfiletransfer |
50
51 #### Property __Tags__
52
53 | __Tag__ | __Default Value__ | __Type__ | __Description__ |
54 | :--: | :--: | :--: | :-- |
55 | `name` | "" | String | The name, by which the @ref ua_protocol_iso_tp can be found |
56 | `index` | <> | <span style="white-space: nowrap;">32bit Number</span> | The Protocol's index in the @ref ua_channel 's `protocol` list. |
57 | `service_count` | <> | <span style="white-space: nowrap;">32bit Number</span> | The amount of [Services](@ref ua_service_iso_tp) in the protocol |
58 | `ff_callback` | <> | Callback | The Function to Call when a First Frame Candidate is detected. The obtained Handle will be a @ref ua_ffcbo. This function is also called for First Frame Candidates send by currently executed Services. |
59 |--|--|--|Default values for newly created [Services](@ref ua_service_iso_tp)|
60 | `node_address` | LIN: 0x7F<br>CAN:-1 | 16bit Number | The default node address used for newly created [Services](@ref ua_service_iso_tp). Set to -1 to deactivate NAD in the frames. |
61 | `req_frame_id` | LIN: 0x3C<br>CAN:1 | 32bit Number | The default frame id of request frames used for newly created [Services](@ref ua_service_iso_tp). |
62 | `rsp_frame_id` | LIN: 0x3D<br>CAN:2 | 32bit Number | The default frame id of response frames used for newly created [Services](@ref ua_service_iso_tp). |
63 | `slave_only` | LIN:0 (false) | Boolean | Indicates, that the device is configured as a LIN-Slave and can not actively schedule frames. It is required to set this value to true for protocol slave implementations. not applicable on CAN channels. |
64 | `lin_version` | LIN:1 | 2bit Number | The default checksum type (classic for 1, enhanced for 2, undefined otherwise) used for newly created [Services](@ref ua_service_iso_tp). |
65 | `extend_frameid` | CAN:0 (false) | Boolean | The default frame id length (11 Bits in case of false, 29 Bits other wise) used for newly created [Services](@ref ua_service_iso_tp). |
66 | `req_slottime` | 20 | 32bit Number | The default request frame slot time used for newly created [Services](@ref ua_service_iso_tp). This value is also send in flow control frames when simulating the response. |
67 | `rsp_slottime` | 20 | 32bit Number | The default response frame slot time used for newly created [Services](@ref ua_service_iso_tp). This value is also send in flow control frames when simulating the request. |
68 | `timeout_frame` | 50 | 32bit Number | The default timeout for send frames used for newly created [Services](@ref ua_service_iso_tp). |
69 | `timeout_response` | 1000 | 32bit Number | The default timeout for the response frames used for newly created [Services](@ref ua_service_iso_tp). |
70 | `padding` | LIN: 0xFF<br>CAN: 0xCC | 8bit Number | The default padding used for newly created [Services](@ref ua_service_iso_tp). |
71 | `blocksize` | CAN: 0 | 8bit Number | The default block size used in flow control frames for newly created [Services](@ref ua_service_iso_tp). |
72 | `optimize` | false | Boolean | If this is set to true the last frame of the request and response will be transmitted with just the required frame length. e.g. a request with NAD and 3 bytes payload will have only 5 bytes instead of 8. This is the default value used for newly created [Services](@ref ua_service_iso_tp). |
73 | `max_continue_count` | 10 | 32bit Number | For this may times the Response will be repeated when a negative response code of 0x78 (continue to send) is received. This is the default value used for newly created [Services](@ref ua_service_iso_tp). |
74 | `max_flow_wait` | 10 | 32bit Number | For this may times the flow state is allowed to be 1, before aborting the service execution. This is the default value used for newly created [Services](@ref ua_service_iso_tp). |
Generated on Fri May 30 2025 17:16:12 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: markdowns/UnifiedAccess/UDS/Protocol_UDS_AccessTimingParameter.md File Reference

markdowns/UnifiedAccess/UDS/Protocol_UDS_AccessTimingParameter.md File Reference

Go to the source code of this file.

Generated on Fri May 30 2025 17:16:13 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: markdowns/UnifiedAccess/UDS/Protocol_UDS_AccessTimingParameter.md Source File

markdowns/UnifiedAccess/UDS/Protocol_UDS_AccessTimingParameter.md
Go to the documentation of this file.
1 # The UDS AccessTimingParameter service
2 @ingroup ua_uds_accesstimingparameter
3
4 You should first read through the @ref ua.<br>
5 Here all specific __Tags__ of an UDS access timing parameter service can be looked up.
6 The __Tags__ from @ref ua_service_iso_tp are also supported.
7
8 #### Property __Tags__
9
10 | __Tag__ | __Default Value__ | __Type__ | __Description__ |
11 | :--: | :--: | :--: | :-- |
12 | `service_id` | 0x83 | <span style="white-space: nowrap;">16bit Number</span> | The Service ID or sid of the request. |
13 | `rsp_service_id` | 0xC3 | 16bit Number | The Response Service ID or rsid of the response. |
14 | `req_subfunction` | 3 | 8bit Number | The sub function or timing parameter access type of the request. |
15 | `req_TimingParameterRequestRecord` | <> | Binary | The timing parameter request record of the request. |
16 | `rsp_subfunction` | <> | 8bit Number | The sub function or timing parameter access type of the response. |
17 | `rsp_TimingParameterResponseRecord` | <> | Binary | The timing parameter response record of the response. |
Generated on Fri May 30 2025 17:16:12 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: markdowns/UnifiedAccess/UDS/Protocol_UDS_ClearDiagnosticInformation.md File Reference

markdowns/UnifiedAccess/UDS/Protocol_UDS_ClearDiagnosticInformation.md File Reference

Go to the source code of this file.

Generated on Fri May 30 2025 17:16:13 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: markdowns/UnifiedAccess/UDS/Protocol_UDS_ClearDiagnosticInformation.md Source File

markdowns/UnifiedAccess/UDS/Protocol_UDS_ClearDiagnosticInformation.md
Go to the documentation of this file.
1 # The UDS ClearDiagnosticInformation service
2 @ingroup ua_uds_cleardiagnosticinformation
3
4 You should first read through the @ref ua.<br>
5 Here all specific __Tags__ of an UDS clear diagnostic information service can be looked up.
6 The __Tags__ from @ref ua_service_iso_tp are also supported.
7
8 #### Property __Tags__
9
10 | __Tag__ | __Default Value__ | __Type__ | __Description__ |
11 | :--: | :--: | :--: | :-- |
12 | `service_id` | 0x14 | <span style="white-space: nowrap;">16bit Number</span> | The Service ID or sid of the request. |
13 | `rsp_service_id` | 0x54 | 16bit Number | The Response Service ID or rsid of the response. |
14 | `req_groupOfDTC` | <> | 24bit Number | The group of DTC of the request. |
Generated on Fri May 30 2025 17:16:12 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: markdowns/UnifiedAccess/UDS/Protocol_UDS_CommunicationControl.md File Reference

markdowns/UnifiedAccess/UDS/Protocol_UDS_CommunicationControl.md File Reference

Go to the source code of this file.

Generated on Fri May 30 2025 17:16:13 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: markdowns/UnifiedAccess/UDS/Protocol_UDS_CommunicationControl.md Source File

markdowns/UnifiedAccess/UDS/Protocol_UDS_CommunicationControl.md
Go to the documentation of this file.
1 # The UDS CommunicationControl service
2 @ingroup ua_uds_communicationcontrol
3
4 You should first read through the @ref ua.<br>
5 Here all specific __Tags__ of an UDS communication control service can be looked up.
6 The __Tags__ from @ref ua_service_iso_tp are also supported.
7
8 #### Property __Tags__
9
10 | __Tag__ | __Default Value__ | __Type__ | __Description__ |
11 | :--: | :--: | :--: | :-- |
12 | `service_id` | 0x28 | <span style="white-space: nowrap;">16bit Number</span> | The Service ID or sid of the request. |
13 | `rsp_service_id` | 0x68 | 16bit Number | The Response Service ID or rsid of the response. |
14 | `req_subfunction` | 0 | 8bit Number | The sub function or control type of the request. |
15 | `req_communicationType` | 1 | 8bit Number | The communication type of the request. |
16 | `req_nodeIdentificationNumber` | <> | 16bit Number | The node identification number of the request. |
17 | `rsp_subfunction` | <> | 8bit Number | The sub function or control type of the response. |
Generated on Fri May 30 2025 17:16:12 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: markdowns/UnifiedAccess/UDS/Protocol_UDS_ControlDTCSetting.md File Reference

markdowns/UnifiedAccess/UDS/Protocol_UDS_ControlDTCSetting.md File Reference

Go to the source code of this file.

Generated on Fri May 30 2025 17:16:13 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: markdowns/UnifiedAccess/UDS/Protocol_UDS_ControlDTCSetting.md Source File

markdowns/UnifiedAccess/UDS/Protocol_UDS_ControlDTCSetting.md
Go to the documentation of this file.
1 # The UDS ControlDTCSetting service
2 @ingroup ua_uds_controldtcsetting
3
4 You should first read through the @ref ua.<br>
5 Here all specific __Tags__ of an UDS control DTC setting service can be looked up.
6 The __Tags__ from @ref ua_service_iso_tp are also supported.
7
8 #### Property __Tags__
9
10 | __Tag__ | __Default Value__ | __Type__ | __Description__ |
11 | :--: | :--: | :--: | :-- |
12 | `service_id` | 0x85 | <span style="white-space: nowrap;">16bit Number</span> | The Service ID or sid of the request. |
13 | `rsp_service_id` | 0xC5 | 16bit Number | The Response Service ID or rsid of the response. |
14 | `req_subfunction` | 1 | 8bit Number | The sub function or DTC setting type of the request. |
15 | `req_DTCSettingControlOptionRecord` | <> | Binary | The DTC setting control option record of the request. |
16 | `rsp_subfunction` | <> | 8bit Number | The sub function or DTC setting type of the response. |
Generated on Fri May 30 2025 17:16:12 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: markdowns/UnifiedAccess/UDS/Protocol_UDS_DiagnosticSessionControl.md File Reference

markdowns/UnifiedAccess/UDS/Protocol_UDS_DiagnosticSessionControl.md File Reference

Go to the source code of this file.

Generated on Fri May 30 2025 17:16:13 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: markdowns/UnifiedAccess/UDS/Protocol_UDS_DiagnosticSessionControl.md Source File

markdowns/UnifiedAccess/UDS/Protocol_UDS_DiagnosticSessionControl.md
Go to the documentation of this file.
1 # The UDS DiagnosticSessionControl service
2 @ingroup ua_uds_diagnosticsessioncontrol
3
4 You should first read through the @ref ua.<br>
5 Here all specific __Tags__ of an UDS diagnostic session control service can be looked up.
6 The __Tags__ from @ref ua_service_iso_tp are also supported.
7
8 #### Property __Tags__
9
10 | __Tag__ | __Default Value__ | __Type__ | __Description__ |
11 | :--: | :--: | :--: | :-- |
12 | `service_id` | 0x10 | <span style="white-space: nowrap;">16bit Number</span> | The Service ID or sid of the request. |
13 | `rsp_service_id` | 0x50 | 16bit Number | The Response Service ID or rsid of the response. |
14 | `req_subfunction` | 1 | 8bit Number | The sub function or diagnostic session type of the request. |
15 | `rsp_subfunction` | <> | 8bit Number | The sub function or diagnostic session type of the response. |
16 | `rsp_sessionParameterRecord` | <> | Binary | The session parameter record of the response. |
17 | `rsp_P2` | <> | 16bit Number | The P2 server max timing value of the response. |
18 | `rsp_P2*` | <> | 16bit Number | The P2* server max enhanced timing value of the response. |
Generated on Fri May 30 2025 17:16:12 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: markdowns/UnifiedAccess/UDS/Protocol_UDS_DynamicallyDefineDataIdentifier.md File Reference

markdowns/UnifiedAccess/UDS/Protocol_UDS_DynamicallyDefineDataIdentifier.md File Reference

Go to the source code of this file.

Generated on Fri May 30 2025 17:16:13 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: markdowns/UnifiedAccess/UDS/Protocol_UDS_DynamicallyDefineDataIdentifier.md Source File

markdowns/UnifiedAccess/UDS/Protocol_UDS_DynamicallyDefineDataIdentifier.md
Go to the documentation of this file.
1 # The UDS DynamicallyDefineDataIdentifier service
2 @ingroup ua_uds_dynamicallydefinedataidentifier
3
4 You should first read through the @ref ua.<br>
5 Here all specific __Tags__ of an UDS dynamically define data identifier service can be looked up.
6 The __Tags__ from @ref ua_service_iso_tp are also supported.
7
8 #### Property __Tags__
9
10 | __Tag__ | __Default Value__ | __Type__ | __Description__ |
11 | :--: | :--: | :--: | :-- |
12 | `service_id` | 0x2C | <span style="white-space: nowrap;">16bit Number</span> | The Service ID or sid of the request. |
13 | `rsp_service_id` | 0x6C | 16bit Number | The Response Service ID or rsid of the response. |
Generated on Fri May 30 2025 17:16:12 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: markdowns/UnifiedAccess/UDS/Protocol_UDS_ECUReset.md File Reference

markdowns/UnifiedAccess/UDS/Protocol_UDS_ECUReset.md File Reference

Go to the source code of this file.

Generated on Fri May 30 2025 17:16:13 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: markdowns/UnifiedAccess/UDS/Protocol_UDS_ECUReset.md Source File

markdowns/UnifiedAccess/UDS/Protocol_UDS_ECUReset.md
Go to the documentation of this file.
1 # The UDS ECUReset service
2 @ingroup ua_uds_ecureset
3
4 You should first read through the @ref ua.<br>
5 Here all specific __Tags__ of an UDS ECU reset service can be looked up.
6 The __Tags__ from @ref ua_service_iso_tp are also supported.
7
8 #### Property __Tags__
9
10 | __Tag__ | __Default Value__ | __Type__ | __Description__ |
11 | :--: | :--: | :--: | :-- |
12 | `service_id` | 0x11 | <span style="white-space: nowrap;">16bit Number</span> | The Service ID or sid of the request. |
13 | `rsp_service_id` | 0x51 | 16bit Number | The Response Service ID or rsid of the response. |
14 | `req_subfunction` | 1 | 8bit Number | the reset type of the request. |
15 | `rsp_subfunction` | <> | 8bit Number | the reset type of the response. |
16 | `rsp_powerDownTime` | <> | 8bit Number | the power down time of the response. |
Generated on Fri May 30 2025 17:16:12 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: markdowns/UnifiedAccess/UDS/Protocol_UDS_InputOutputControlByIdentifier.md File Reference

markdowns/UnifiedAccess/UDS/Protocol_UDS_InputOutputControlByIdentifier.md File Reference

Go to the source code of this file.

Generated on Fri May 30 2025 17:16:13 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: markdowns/UnifiedAccess/UDS/Protocol_UDS_InputOutputControlByIdentifier.md Source File

markdowns/UnifiedAccess/UDS/Protocol_UDS_InputOutputControlByIdentifier.md
Go to the documentation of this file.
1 # The UDS InputOutputControlByIdentifier service
2 @ingroup ua_uds_inputoutputcontrolbyidentifier
3
4 You should first read through the @ref ua.<br>
5 Here all specific __Tags__ of an UDS input output control by identifier service can be looked up.
6 The __Tags__ from @ref ua_service_iso_tp are also supported.
7
8 #### Property __Tags__
9
10 | __Tag__ | __Default Value__ | __Type__ | __Description__ |
11 | :--: | :--: | :--: | :-- |
12 | `service_id` | 0x2F | <span style="white-space: nowrap;">16bit Number</span> | The Service ID or sid of the request. |
13 | `rsp_service_id` | 0x6F | 16bit Number | The Response Service ID or rsid of the response. |
14 | `req_dataIdentifier` | <> | 16bit Number | the data identifier of the request. |
15 | `req_controlOptionRecord` | <> | Binary | the control option record of the request, might also contain the controlEnableMaskRecord. |
16 | `rsp_dataIdentifier` | <> | 16bit Number | the data identifier of the response. |
17 | `rsp_controlStatusRecord` | <> | Binary | the control status record of the response. |
Generated on Fri May 30 2025 17:16:12 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: markdowns/UnifiedAccess/UDS/Protocol_UDS_LinkControl.md File Reference

markdowns/UnifiedAccess/UDS/Protocol_UDS_LinkControl.md File Reference

Go to the source code of this file.

Generated on Fri May 30 2025 17:16:13 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: markdowns/UnifiedAccess/UDS/Protocol_UDS_LinkControl.md Source File

markdowns/UnifiedAccess/UDS/Protocol_UDS_LinkControl.md
Go to the documentation of this file.
1 # The UDS LinkCotntrol service
2 @ingroup ua_uds_linkcontrol
3
4 You should first read through the @ref ua.<br>
5 Here all specific __Tags__ of an UDS link control service can be looked up.
6 The __Tags__ from @ref ua_service_iso_tp are also supported.
7
8 #### Property __Tags__
9
10 | __Tag__ | __Default Value__ | __Type__ | __Description__ |
11 | :--: | :--: | :--: | :-- |
12 | `service_id` | 0x87 | <span style="white-space: nowrap;">16bit Number</span> | The Service ID or sid of the request. |
13 | `rsp_service_id` | 0xC7 | 16bit Number | The Response Service ID or rsid of the response. |
14 | `req_subfunction` | <> | 8bit Number | The sub function or link control type of the request. Setting this value will update the requests message length appropriately. |
15 | `req_linkControlModeIdentifier` | <> | 8bit Number | The link control mode identifier of the request. |
16 | `req_linkRecord` | <> | 24bit Number | The link record of the request. |
17 | `rsp_subfunction` | <> | 8bit Number | The sub function or link control type of the response. |
Generated on Fri May 30 2025 17:16:12 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: markdowns/UnifiedAccess/UDS/Protocol_UDS_ReadDataByIdentifier.md File Reference

markdowns/UnifiedAccess/UDS/Protocol_UDS_ReadDataByIdentifier.md File Reference

Go to the source code of this file.

Generated on Fri May 30 2025 17:16:13 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: markdowns/UnifiedAccess/UDS/Protocol_UDS_ReadDataByIdentifier.md Source File

markdowns/UnifiedAccess/UDS/Protocol_UDS_ReadDataByIdentifier.md
Go to the documentation of this file.
1 # The UDS ReadByDataIdentifier service
2 @ingroup ua_uds_readdatabyidentifier
3
4 You should first read through the @ref ua.<br>
5 Here all specific __Tags__ of an UDS read data by identifier service can be looked up.
6 The __Tags__ from @ref ua_service_iso_tp are also supported.
7
8 #### Property __Tags__
9
10 | __Tag__ | __Default Value__ | __Type__ | __Description__ |
11 | :--: | :--: | :--: | :-- |
12 | `service_id` | 0x22 | <span style="white-space: nowrap;">16bit Number</span> | The Service ID or sid of the request. |
13 | `rsp_service_id` | 0x62 | 16bit Number | The Response Service ID or rsid of the response. |
14 | `req_dataIdentifier` | <> | 16bit Number | the data identifier from the request |
15 | `rsp_dataIdentifier` | <> | 16bit Number | the data identifier from the response |
16 | `rsp_dataRecord` | <> | Binary | the data record from the response |
Generated on Fri May 30 2025 17:16:12 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: markdowns/UnifiedAccess/UDS/Protocol_UDS_ReadDataByPeriodicIdentifier.md File Reference

markdowns/UnifiedAccess/UDS/Protocol_UDS_ReadDataByPeriodicIdentifier.md File Reference

Go to the source code of this file.

Generated on Fri May 30 2025 17:16:13 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: markdowns/UnifiedAccess/UDS/Protocol_UDS_ReadDataByPeriodicIdentifier.md Source File

markdowns/UnifiedAccess/UDS/Protocol_UDS_ReadDataByPeriodicIdentifier.md
Go to the documentation of this file.
1 # The UDS ReadDataByPeriodicIdentifier service
2 @ingroup ua_uds_readdatabyperiodicidentifier
3
4 You should first read through the @ref ua.<br>
5 Here all specific __Tags__ of an UDS read data by periodic identifier service can be looked up.
6 The __Tags__ from @ref ua_service_iso_tp are also supported.
7
8 #### Property __Tags__
9
10 | __Tag__ | __Default Value__ | __Type__ | __Description__ |
11 | :--: | :--: | :--: | :-- |
12 | `service_id` | 0x2A | <span style="white-space: nowrap;">16bit Number</span> | The Service ID or sid of the request. |
13 | `rsp_service_id` | 0x6A | 16bit Number | The Response Service ID or rsid of the response. |
Generated on Fri May 30 2025 17:16:12 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: markdowns/UnifiedAccess/UDS/Protocol_UDS_ReadDTCInformation.md File Reference

markdowns/UnifiedAccess/UDS/Protocol_UDS_ReadDTCInformation.md File Reference

Go to the source code of this file.

Generated on Fri May 30 2025 17:16:13 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: markdowns/UnifiedAccess/UDS/Protocol_UDS_ReadDTCInformation.md Source File

markdowns/UnifiedAccess/UDS/Protocol_UDS_ReadDTCInformation.md
Go to the documentation of this file.
1 # The UDS ReadDTCInformation service
2 @ingroup ua_uds_readdtcinformation
3
4 You should first read through the @ref ua.<br>
5 Here all specific __Tags__ of an UDS read DTC information service can be looked up.<br>
6 The __Tags__ from @ref ua_service_iso_tp are also supported.
7
8 #### Property __Tags__
9
10 | __Tag__ | __Default Value__ | __Type__ | __Description__ |
11 | :--: | :--: | :--: | :-- |
12 | `service_id` | 0x19 | <span style="white-space: nowrap;">16bit Number</span> | The Service ID or sid of the request. |
13 | `rsp_service_id` | 0x59 | 16bit Number | The Response Service ID or rsid of the response. |
14 | `req_subfunction` | <> | 8bit Number | The sub function or report type of the request. Setting this value will change the actual object type to that of the given sub function id. |
15 | `rsp_subfunction` | <> | 8bit Number | The sub function or report type of the response. Setting this value will change the actual object type to that of the given sub function id. |
Generated on Fri May 30 2025 17:16:12 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: markdowns/UnifiedAccess/UDS/Protocol_UDS_ReadMemoryByAddress.md File Reference

markdowns/UnifiedAccess/UDS/Protocol_UDS_ReadMemoryByAddress.md File Reference

Go to the source code of this file.

Generated on Fri May 30 2025 17:16:13 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: markdowns/UnifiedAccess/UDS/Protocol_UDS_ReadMemoryByAddress.md Source File

markdowns/UnifiedAccess/UDS/Protocol_UDS_ReadMemoryByAddress.md
Go to the documentation of this file.
1 # The UDS ReadMemoryByAddress service
2 @ingroup ua_uds_readmemorybyaddress
3
4 You should first read through the @ref ua.<br>
5 Here all specific __Tags__ of an UDS read memory by address service can be looked up.
6 The __Tags__ from @ref ua_service_iso_tp are also supported.
7
8 #### Property __Tags__
9
10 | __Tag__ | __Default Value__ | __Type__ | __Description__ |
11 | :--: | :--: | :--: | :-- |
12 | `service_id` | 0x23 | <span style="white-space: nowrap;">16bit Number</span> | The Service ID or sid of the request. |
13 | `rsp_service_id` | 0x63 | 16bit Number | The Response Service ID or rsid of the response. |
14 | `req_memoryAddress` | <> | 64bit Number<br>Binary | The memory address of the request. if set as a number only the required bytes are stored. |
15 | `req_memorySize` | <> | 64bit Number<br>Binary | The memory size of the request. if set as a number only the required bytes are stored. |
16 | `req_addressAndLengthFormatIdentifier` | <> | 8bit Number | The address length format identifier of the request. This value is updated when setting `req_memoryAddress` or `req_memorySize` properties. |
17 | `rsp_dataRecord` | <> | Binary | The data record of the response. |
Generated on Fri May 30 2025 17:16:12 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: markdowns/UnifiedAccess/UDS/Protocol_UDS_ReadScalingByIdentifier.md File Reference

markdowns/UnifiedAccess/UDS/Protocol_UDS_ReadScalingByIdentifier.md File Reference

Go to the source code of this file.

Generated on Fri May 30 2025 17:16:13 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: markdowns/UnifiedAccess/UDS/Protocol_UDS_ReadScalingByIdentifier.md Source File

markdowns/UnifiedAccess/UDS/Protocol_UDS_ReadScalingByIdentifier.md
Go to the documentation of this file.
1 # The UDS ReadScalingByIdentifier service
2 @ingroup ua_uds_readscalingdatabyidentifier
3
4 You should first read through the @ref ua.<br>
5 Here all specific __Tags__ of an UDS read scaling by identifier service can be looked up.
6 The __Tags__ from @ref ua_service_iso_tp are also supported.
7
8 #### Property __Tags__
9
10 | __Tag__ | __Default Value__ | __Type__ | __Description__ |
11 | :--: | :--: | :--: | :-- |
12 | `service_id` | 0x24 | <span style="white-space: nowrap;">16bit Number</span> | The Service ID or sid of the request. |
13 | `rsp_service_id` | 0x64 | 16bit Number | The Response Service ID or rsid of the response. |
14 | `req_dataIdentifier` | <> | 16bit Number | The data identifier of the request. |
15 | `rsp_dataIdentifier` | <> | 16bit Number | The data identifier of the response. |
16 | `rsp_scalingByte` | <> | 8bit Number | The scaling byte of the response. |
17 | `rsp_scalingByteExtension` | <> | Binary | The scaling byte extension of the response. |
Generated on Fri May 30 2025 17:16:12 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: markdowns/UnifiedAccess/UDS/Protocol_UDS_RequestDownload.md File Reference

markdowns/UnifiedAccess/UDS/Protocol_UDS_RequestDownload.md File Reference

Go to the source code of this file.

Generated on Fri May 30 2025 17:16:13 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: markdowns/UnifiedAccess/UDS/Protocol_UDS_RequestDownload.md Source File

markdowns/UnifiedAccess/UDS/Protocol_UDS_RequestDownload.md
Go to the documentation of this file.
1 # The UDS RequestDownload service
2 @ingroup ua_uds_requestdownload
3
4 You should first read through the @ref ua.<br>
5 Here all specific __Tags__ of an UDS request download service can be looked up.
6 The __Tags__ from @ref ua_service_iso_tp are also supported.
7
8 #### Property __Tags__
9
10 | __Tag__ | __Default Value__ | __Type__ | __Description__ |
11 | :--: | :--: | :--: | :-- |
12 | `service_id` | 0x34 | <span style="white-space: nowrap;">16bit Number</span> | The Service ID or sid of the request. |
13 | `rsp_service_id` | 0x74 | 16bit Number | The Response Service ID or rsid of the response. |
14 | `req_dataFormatIdentifier` | <> | 8bit Number | The data format identifier of the request. |
15 | `req_memoryAddress` | <> | 64bit Number<br>Binary | The memory address of the request. If set as a number only the required bytes are stored. |
16 | `req_memorySize` | <> | 64bit Number<br>Binary | The memory size of the request. If set as a number only the required bytes are stored. |
17 | `req_addressAndLengthFormatIdentifier` | <> | 8bit Number | The address length format identifier of the request. This value is updated by setting the requests address or size properties. |
18 | `rsp_maxNumberOfBlockLength` | <> | 64bit Number<br>Binary | The max number of blocks of the response. If set as a number only the required bytes are stored. |
19 | `rsp_lengthFormatIdentifier` | <> | 8bit Number | The length format identifier of the response. This value is updated by setting the responses max number of block length property. |
Generated on Fri May 30 2025 17:16:12 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: markdowns/UnifiedAccess/UDS/Protocol_UDS_RequestFileTransfer.md File Reference

markdowns/UnifiedAccess/UDS/Protocol_UDS_RequestFileTransfer.md File Reference

Go to the source code of this file.

Generated on Fri May 30 2025 17:16:13 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: markdowns/UnifiedAccess/UDS/Protocol_UDS_RequestFileTransfer.md Source File

markdowns/UnifiedAccess/UDS/Protocol_UDS_RequestFileTransfer.md
Go to the documentation of this file.
1 # The UDS RequestFileTransfer service
2 @ingroup ua_uds_requestfiletransfer
3
4 You should first read through the @ref ua.<br>
5 Here all specific __Tags__ of an UDS request file transfer service can be looked up.
6 The __Tags__ from @ref ua_service_iso_tp are also supported.
7
8 #### Property __Tags__
9
10 | __Tag__ | __Default Value__ | __Type__ | __Description__ |
11 | :--: | :--: | :--: | :-- |
12 | `service_id` | 0x38 | <span style="white-space: nowrap;">16bit Number</span> | The Service ID or sid of the request. |
13 | `rsp_service_id` | 0x78 | 16bit Number | The Response Service ID or rsid of the response. |
14 | `req_modeOfOperation` | <> | 8bit Number | The mode of operation of the request. Setting this value to 2 or 5 will remove the data format identifier and file length values. Setting this value to 4 will only remove the file length values. |
15 | `req_filePathAndName` | <> | Binary | The file path and name of the request. |
16 | `req_dataFormatIdentifier` | <> | 8bit Number | The data format identifier of the request. |
17 | `req_fileSizeUnCompressed` | <> | 64bit Number<br>Binary | The file size uncompressed of the request. If the given value is shorter then file size parameter length the value is prepends zeros to match the length. If the value is longer the file size parameter length is enlarged. If the value is set as number the file size parameter is tested to be narrowed to the minimal required value. |
18 | `req_fileSizeCompressed` | <> | 64bit Number<br>Binary | The file size uncompressed of the request. If the given value is shorter then file size parameter length the value is prepends zeros to match the length. If the value is longer the file size parameter length is enlarged. If the value is set as number the file size parameter is tested to be narrowed to the minimal required value. |
19 | `req_filePathAndNameLength` | <> | 16bit Number | The file path and name length of the request. This value is updated by setting the file path and name parameter. |
20 | `req_fileSizeParameterLength` | <> | 8bit Number | The file size parameter length of the request. Setting this value will update the file size uncompressed and file size compressed values. |
21 | `rsp_modeOfOperation` | <> | 8bit Number | The mode of operation of the response. |
22 | `rsp_maxNumberOfBlockLength` | <> | 64bit Number<br>Binary | The maximum number of block length of the response. Setting this value will update the length format identifier. |
23 | `rsp_dataFormatIdentifier` | <> | 8bit Number | The data format identifier of the response. |
24 | `rsp_fileSizeOrDirInfoParameterLength` | <> | 16bit Number | The file size or dir info parameter length of the response. Setting this value updates the length of file size uncompressed or dir info length and, if the mode of operation is not 5, also file size compressed. |
25 | `rsp_fileSizeCompressed` | <> | 64bit Number<br>Binary | The file size compressed of the response. Setting this value will update the file size or dir info parameter length. |
26 | `rsp_lengthFormatIdentifier` | <> | 8bit Number | The length format identifier of the response. Setting this value will update the max Number of blocks value. |
27 | `rsp_fileSizeUnCompressedOrDirInfoLength` | <> | 64bit Number<br>Binary | The file size uncompressed or dir info length of the response. Setting this value will update the file size or dir info parameter length. |
Generated on Fri May 30 2025 17:16:12 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: markdowns/UnifiedAccess/UDS/Protocol_UDS_RequestTransferExit.md File Reference

markdowns/UnifiedAccess/UDS/Protocol_UDS_RequestTransferExit.md File Reference

Go to the source code of this file.

Generated on Fri May 30 2025 17:16:13 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: markdowns/UnifiedAccess/UDS/Protocol_UDS_RequestTransferExit.md Source File

markdowns/UnifiedAccess/UDS/Protocol_UDS_RequestTransferExit.md
Go to the documentation of this file.
1 # The UDS RequestTransferExit service
2 @ingroup ua_uds_requesttransferexit
3
4 You should first read through the @ref ua.<br>
5 Here all specific __Tags__ of an UDS request transfer exit service can be looked up.
6 The __Tags__ from @ref ua_service_iso_tp are also supported.
7
8 #### Property __Tags__
9
10 | __Tag__ | __Default Value__ | __Type__ | __Description__ |
11 | :--: | :--: | :--: | :-- |
12 | `service_id` | 0x37 | <span style="white-space: nowrap;">16bit Number</span> | The Service ID or sid of the request. |
13 | `rsp_service_id` | 0x77 | 16bit Number | The Response Service ID or rsid of the response. |
14 | `req_transferRequestParameterRecord` | <> | Binary | The transfer parameter record of the request. |
15 | `rsp_transferResponseParameterRecord` | <> | Binary | The transfer parameter record of the response. |
Generated on Fri May 30 2025 17:16:12 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: markdowns/UnifiedAccess/UDS/Protocol_UDS_RequestUpload.md File Reference

markdowns/UnifiedAccess/UDS/Protocol_UDS_RequestUpload.md File Reference

Go to the source code of this file.

Generated on Fri May 30 2025 17:16:13 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: markdowns/UnifiedAccess/UDS/Protocol_UDS_RequestUpload.md Source File

markdowns/UnifiedAccess/UDS/Protocol_UDS_RequestUpload.md
Go to the documentation of this file.
1 # The UDS RequestUpload service
2 @ingroup ua_uds_requestupload
3
4 You should first read through the @ref ua.<br>
5 Here all specific __Tags__ of an UDS request upload service can be looked up.
6 The __Tags__ from @ref ua_service_iso_tp are also supported.
7
8 #### Property __Tags__
9
10 | __Tag__ | __Default Value__ | __Type__ | __Description__ |
11 | :--: | :--: | :--: | :-- |
12 | `service_id` | 0x35 | <span style="white-space: nowrap;">16bit Number</span> | The Service ID or sid of the request. |
13 | `rsp_service_id` | 0x75 | 16bit Number | The Response Service ID or rsid of the response. |
14 | `req_dataFormatIdentifier` | <> | 8bit Number | The data format identifier of the request. |
15 | `req_memoryAddress` | <> | 64bit Number<br>Binary | The memory address of the request. if set as a number only the required bytes are stored. |
16 | `req_memorySize` | <> | 64bit Number<br>Binary | The memory size of the request. if set as a number only the required bytes are stored. |
17 | `req_addressAndLengthFormatIdentifier` | <> | 8bit Number | The address length format identifier of the request. This value is updated by setting the requests address or size properties. |
18 | `rsp_maxNumberOfBlockLength` | <> | 64bit Number<br>Binary | The max number of blocks of the response. |
19 | `rsp_lengthFormatIdentifier` | <> | 8bit Number | The length format identifier of the response. This value is updated by setting the responses max number of block length property. |
Generated on Fri May 30 2025 17:16:12 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: markdowns/UnifiedAccess/UDS/Protocol_UDS_ResponseOnEvent.md File Reference

markdowns/UnifiedAccess/UDS/Protocol_UDS_ResponseOnEvent.md File Reference

Go to the source code of this file.

Generated on Fri May 30 2025 17:16:13 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: markdowns/UnifiedAccess/UDS/Protocol_UDS_ResponseOnEvent.md Source File

markdowns/UnifiedAccess/UDS/Protocol_UDS_ResponseOnEvent.md
Go to the documentation of this file.
1 # The UDS ResponseOnEvent service
2 @ingroup ua_uds_responseonevent
3
4 You should first read through the @ref ua.<br>
5 Here all specific __Tags__ of an UDS response on event service can be looked up.
6 The __Tags__ from @ref ua_service_iso_tp are also supported.
7
8 #### Property __Tags__
9
10 | __Tag__ | __Default Value__ | __Type__ | __Description__ |
11 | :--: | :--: | :--: | :-- |
12 | `service_id` | 0x86 | <span style="white-space: nowrap;">16bit Number</span> | The Service ID or sid of the request. |
13 | `rsp_service_id` | 0xC6 | 16bit Number | The Response Service ID or rsid of the response. |
Generated on Fri May 30 2025 17:16:12 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: markdowns/UnifiedAccess/UDS/Protocol_UDS_RoutineControl.md File Reference

markdowns/UnifiedAccess/UDS/Protocol_UDS_RoutineControl.md File Reference

Go to the source code of this file.

Generated on Fri May 30 2025 17:16:13 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: markdowns/UnifiedAccess/UDS/Protocol_UDS_RoutineControl.md Source File

markdowns/UnifiedAccess/UDS/Protocol_UDS_RoutineControl.md
Go to the documentation of this file.
1 # The UDS RoutineControl service
2 @ingroup ua_uds_routinecontrol
3
4 You should first read through the @ref ua.<br>
5 Here all specific __Tags__ of an UDS routine control service can be looked up.
6 The __Tags__ from @ref ua_service_iso_tp are also supported.
7
8 #### Property __Tags__
9
10 | __Tag__ | __Default Value__ | __Type__ | __Description__ |
11 | :--: | :--: | :--: | :-- |
12 | `service_id` | 0x31 | <span style="white-space: nowrap;">16bit Number</span> | The Service ID or sid of the request. |
13 | `rsp_service_id` | 0x71 | 16bit Number | The Response Service ID or rsid of the response. |
14 | `req_subfunction` | <> | 8bit Number | The sub function id or routine control type of the request. |
15 | `rsp_subfunction` | <> | 8bit Number | The sub function id or routine control type of the response. |
16 | `req_routineIdentifier` | <> | 16bit Number | The routine identifier of the request. |
17 | `req_routineControlOptionRecord` | <> | Binary | The control option record of the request. |
18 | `rsp_routineIdentifier` | <> | 16bit Number | The routine identifier of the response. |
19 | `rsp_routineInfo` | <> | 8bit Number | The routine information of the response. |
20 | `rsp_routineStatusRecord` | <> | Binary | The routine status record routine information of the response. |
Generated on Fri May 30 2025 17:16:12 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: markdowns/UnifiedAccess/UDS/Protocol_UDS_SecuredDataTransmission.md File Reference

markdowns/UnifiedAccess/UDS/Protocol_UDS_SecuredDataTransmission.md File Reference

Go to the source code of this file.

Generated on Fri May 30 2025 17:16:13 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: markdowns/UnifiedAccess/UDS/Protocol_UDS_SecuredDataTransmission.md Source File

markdowns/UnifiedAccess/UDS/Protocol_UDS_SecuredDataTransmission.md
Go to the documentation of this file.
1 # The UDS SecuredDataTransmission service
2 @ingroup ua_uds_secureddatatransmission
3
4 You should first read through the @ref ua.<br>
5 Here all specific __Tags__ of an UDS secured data transmission service can be looked up.
6 The __Tags__ from @ref ua_service_iso_tp are also supported.
7
8 #### Property __Tags__
9
10 | __Tag__ | __Default Value__ | __Type__ | __Description__ |
11 | :--: | :--: | :--: | :-- |
12 | `service_id` | 0x84 | <span style="white-space: nowrap;">16bit Number</span> | The Service ID or sid of the request. |
13 | `rsp_service_id` | 0xC4 | 16bit Number | The Response Service ID or rsid of the response. |
14 | `req_securityDataRequestRecord` | <> | Binary | The security data record of the request. |
15 | `rsp_securityDataResponseRecord` | <> | Binary | The security data record of the response. |
Generated on Fri May 30 2025 17:16:12 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: markdowns/UnifiedAccess/UDS/Protocol_UDS_SecuretyAccess.md File Reference

markdowns/UnifiedAccess/UDS/Protocol_UDS_SecuretyAccess.md File Reference

Go to the source code of this file.

Generated on Fri May 30 2025 17:16:13 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: markdowns/UnifiedAccess/UDS/Protocol_UDS_SecuretyAccess.md Source File

markdowns/UnifiedAccess/UDS/Protocol_UDS_SecuretyAccess.md
Go to the documentation of this file.
1 # The UDS SecurityAccess service
2 @ingroup ua_uds_securityaccess
3
4 You should first read through the @ref ua.<br>
5 Here all specific __Tags__ of an UDS security access service can be looked up.
6 The __Tags__ from @ref ua_service_iso_tp are also supported.
7
8 #### Property __Tags__
9
10 | __Tag__ | __Default Value__ | __Type__ | __Description__ |
11 | :--: | :--: | :--: | :-- |
12 | `service_id` | 0x27 | <span style="white-space: nowrap;">16bit Number</span> | The Service ID or sid of the request. |
13 | `rsp_service_id` | 0x67 | 16bit Number | The Response Service ID or rsid of the response. |
14 | `req_subfunction` | 1 | 8bit Number | The sub function id or access type of the request. The default configuration is request seed. |
15 | `rsp_subfunction` | <> | 8bit Number | The sub function id or access type of the response. |
16 | `req_securityKey` | <> | Binary | The security key of the request. |
17 | `rsp_securitySeed` | <> | Binary | The security seed of the response. |
18 | `req_securityAccessDataRecord` | <> | Binary | The security access data record of the request. This is an alias for the security access key. |
Generated on Fri May 30 2025 17:16:12 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: markdowns/UnifiedAccess/UDS/Protocol_UDS_TesterPresent.md File Reference

markdowns/UnifiedAccess/UDS/Protocol_UDS_TesterPresent.md File Reference

Go to the source code of this file.

Generated on Fri May 30 2025 17:16:13 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: markdowns/UnifiedAccess/UDS/Protocol_UDS_TesterPresent.md Source File

markdowns/UnifiedAccess/UDS/Protocol_UDS_TesterPresent.md
Go to the documentation of this file.
1 # The UDS TesterPresent service
2 @ingroup ua_uds_testerpresent
3
4 You should first read through the @ref ua.<br>
5 Here all specific __Tags__ of an UDS tester present service can be looked up.
6 The __Tags__ from @ref ua_service_iso_tp are also supported.
7
8 #### Property __Tags__
9
10 | __Tag__ | __Default Value__ | __Type__ | __Description__ |
11 | :--: | :--: | :--: | :-- |
12 | `service_id` | 0x3E | <span style="white-space: nowrap;">16bit Number</span> | The Service ID or sid of the request. |
13 | `rsp_service_id` | 0x7E | 16bit Number | The Response Service ID or rsid of the response. |
14 | `timeout_response` | 0 | 32bit Number | The time within the slave has to respond. the default value is : don't wait for a response. Change this value along with the `req_subfunction` property. |
15 | `cycle_time` | 0 | 32bit Number | The interval in milliseconds, after which the tester present Service has to be rescheduled. Setting this value to 0 will stop the sending thread. All other values will start the thread or, if the previous value was not null, update the interval after the next service execution. |
16 | `req_subfunction` | 0x80 | 8bit Number | The sub function id or zeroid of the request. The default configuration is do not respond. `timeout_response` should be updated too if this value is changed. |
17 | `rsp_subfunction` | <> | 8bit Number | The sub function id or zeroid of the response. |
Generated on Fri May 30 2025 17:16:12 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: markdowns/UnifiedAccess/UDS/Protocol_UDS_TransferData.md File Reference

markdowns/UnifiedAccess/UDS/Protocol_UDS_TransferData.md File Reference

Go to the source code of this file.

Generated on Fri May 30 2025 17:16:13 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: markdowns/UnifiedAccess/UDS/Protocol_UDS_TransferData.md Source File

markdowns/UnifiedAccess/UDS/Protocol_UDS_TransferData.md
Go to the documentation of this file.
1 # The UDS TransferData service
2 @ingroup ua_uds_transferdata
3
4 You should first read through the @ref ua.<br>
5 Here all specific __Tags__ of an UDS transfer data service can be looked up.
6 The __Tags__ from @ref ua_service_iso_tp are also supported.
7
8 #### Property __Tags__
9
10 | __Tag__ | __Default Value__ | __Type__ | __Description__ |
11 | :--: | :--: | :--: | :-- |
12 | `service_id` | 0x36 | <span style="white-space: nowrap;">16bit Number</span> | The Service ID or sid of the request. |
13 | `rsp_service_id` | 0x76 | 16bit Number | The Response Service ID or rsid of the response. |
14 | `req_blockSequenceCounter` | 0 | 8bit Number | The block sequence counter of the request. |
15 | `req_transferRequestParameterRecord` | <> | Binary | The transfer request parameter record of the request. |
16 | `rsp_blockSequenceCounter` | 0 | 8bit Number | The block sequence counter of the response. |
17 | `rsp_transferResponseParameterRecord` | <> | Binary | The transfer response parameter record of the response. |
Generated on Fri May 30 2025 17:16:12 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: markdowns/UnifiedAccess/UDS/Protocol_UDS_WriteByMemoryAddress.md File Reference

markdowns/UnifiedAccess/UDS/Protocol_UDS_WriteByMemoryAddress.md File Reference

Go to the source code of this file.

Generated on Fri May 30 2025 17:16:13 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: markdowns/UnifiedAccess/UDS/Protocol_UDS_WriteByMemoryAddress.md Source File

markdowns/UnifiedAccess/UDS/Protocol_UDS_WriteByMemoryAddress.md
Go to the documentation of this file.
1 # The UDS WriteByDataIdentifier service
2 @ingroup ua_uds_writememorybyaddress
3
4 You should first read through the @ref ua.<br>
5 Here all specific __Tags__ of an UDS write memory by address service can be looked up.
6 The __Tags__ from @ref ua_service_iso_tp are also supported.
7
8 #### Property __Tags__
9
10 | __Tag__ | __Default Value__ | __Type__ | __Description__ |
11 | :--: | :--: | :--: | :-- |
12 | `service_id` | 0x3D | <span style="white-space: nowrap;">16bit Number</span> | The Service ID or sid of the request. |
13 | `rsp_service_id` | 0x7D | 16bit Number | The Response Service ID or rsid of the response. |
14 | `req_memoryAddress` | <> | 64bit Number<br>Binary | The memory address of the request. if set as a number only the required bytes are stored. |
15 | `req_dataRecord` | <> | Binary | The data record of the request. Setting this will also set the memory size of the request. |
16 | `req_memorySize` | <> | 64bit Number<br>Binary | The memory size of the request. if set as a number only the required bytes are stored. |
17 | `req_addressAndLengthFormatIdentifier` | <> | 8bit Number | The address length format identifier of the request. This value is updated by setting the requests address, size or data properties. |
18 | `rsp_memoryAddress` | <> | 64bit Number<br>Binary | The memory address of the response. if set as a number only the required bytes are stored. |
19 | `rsp_memorySize` | <> | 64bit Number<br>Binary | The memory size of the response. if set as a number only the required bytes are stored. |
20 | `rsp_addressAndLengthFormatIdentifier` | <> | 8bit Number | The address length format identifier of the response. This value is updated by setting the responses address and size properties. |
Generated on Fri May 30 2025 17:16:12 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: markdowns/UnifiedAccess/UDS/Protocol_UDS_WriteDataByIdentifier.md File Reference

markdowns/UnifiedAccess/UDS/Protocol_UDS_WriteDataByIdentifier.md File Reference

Go to the source code of this file.

Generated on Fri May 30 2025 17:16:13 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: markdowns/UnifiedAccess/UDS/Protocol_UDS_WriteDataByIdentifier.md Source File

markdowns/UnifiedAccess/UDS/Protocol_UDS_WriteDataByIdentifier.md
Go to the documentation of this file.
1 # The UDS WriteByDataIdentifier service
2 @ingroup ua_uds_writedatabyidentifier
3
4 You should first read through the @ref ua.<br>
5 Here all specific __Tags__ of an UDS write data by identifier service can be looked up.
6 The __Tags__ from @ref ua_service_iso_tp are also supported.
7
8 #### Property __Tags__
9
10 | __Tag__ | __Default Value__ | __Type__ | __Description__ |
11 | :--: | :--: | :--: | :-- |
12 | `service_id` | 0x2E | <span style="white-space: nowrap;">16bit Number</span> | The Service ID or sid of the request. |
13 | `rsp_service_id` | 0x6E | 16bit Number | The Response Service ID or rsid of the response. |
14 | `req_dataIdentifier` | <> | 16bit Number | the data identifier of the request |
15 | `req_dataRecord` | <> | Binary | the data record of the request |
16 | `rsp_dataIdentifier` | <> | 16bit Number | the data identifier of the response |
Generated on Fri May 30 2025 17:16:12 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: markdowns/UnifiedAccess/ProtocolService_ISO_TP.md File Reference

markdowns/UnifiedAccess/ProtocolService_ISO_TP.md File Reference

Go to the source code of this file.

Generated on Fri May 30 2025 17:16:13 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: markdowns/UnifiedAccess/ProtocolService_ISO_TP.md Source File

markdowns/UnifiedAccess/ProtocolService_ISO_TP.md
Go to the documentation of this file.
1 # The Base ISO-TP protocol service
2 @ingroup ua_service_iso_tp
3
4 You should first read through the @ref ua.<br/>
5 Here all available __Tags__ of an ISO-TP Service can be looked up.
6
7 #### Child __Tags__
8
9 | __Tag__ | __Type__ | __Description__ |
10 | :--: | :--: | :-- |
11 | `mapping` | Void | [Free mappings](@ref free_mappings) can be realized by using this tag.<br>e.g. storing the value 0x1337 with 16 bits into the request with an offset of 8 bits:<br>`BLC_setSignedNumber(service_handle, "mapping offset=8 length=16 request", 0x1337);` |
12
13 #### Property __Tags__
14
15 | __Tag__ | __Default Value__ | __Type__ | __Description__ |
16 | :--: | :--: | :--: | :-- |
17 | `name` | "" | String | The name, by which the @ref ua_service_iso_tp can be found. |
18 | `index` | <> | <span style="white-space: nowrap;">32bit Number</span> | The Service's index in the @ref ua_protocol_iso_tp 's `service` list. |
19 | `state` | <> | 32bit Number | The Services current state of execution. |
20 | `req_complete` | <> | Callback | The function to call after the Request was completely send or received. The function is called by the thread that started the service execution. |
21 | `rsp_complete` | <> | Callback | The function to call after the Response was completely send or received, this will happen multiple times if the negative response code is 0x78 (continue to send) and `max_continue_count` is greater then 1. The function is called by the thread that started the service execution. |
22 | `receive_flow` | <> | Callback | The function to call after a flow control frame is received. The function is called by the thread that started the service execution. |
23 | `send_flow` | <> | Callback | The function to call before a flow control frame was send. The function is called by the thread that started the service execution. |
24 | -- | -- | -- | -- |
25 | `req_node_address` | <span style="white-space: nowrap;">from @ref ua_protocol_iso_tp</span> | <span style="white-space: nowrap;">16bit Number</span> | The NAD in the request frame(s). |
26 | `rsp_node_address` | from @ref ua_protocol_iso_tp | 16bit Number | The NAD in the response frame(s). |
27 | `req_frame_id` | from @ref ua_protocol_iso_tp | 32bit Number | The frame id of the request frame(s). |
28 | `rsp_frame_id` | from @ref ua_protocol_iso_tp | 32bit Number | The frame id of the response frame(s). |
29 | `req_slottime` | from @ref ua_protocol_iso_tp | 32bit Number | The slot time of the request frame(s). This value is also send in flow control frames when simulating the response. |
30 | `rsp_slottime` | from @ref ua_protocol_iso_tp | 32bit Number | The slot time of the response frame(s). This value is also send in flow control frames when simulating the request. |
31 | `timeout_frame` | from @ref ua_protocol_iso_tp | 32bit Number | If a send frame is not received within this time the service execution is aborted. |
32 | `timeout_response` | from @ref ua_protocol_iso_tp | 32bit Number | If the response (or a flow control frame) is not received within this timeout the service execution is aborted. |
33 | `slave_only` | from @ref ua_protocol_iso_tp | Boolean | Indicates, that the device is configured as a LIN-Slave and can not actively schedule frames. It is required to set this value to true for protocol slave implementations. not applicable on CAN channels. |
34 | `lin_version` | from @ref ua_protocol_iso_tp | 2bit Number | The LIN version of the checksum. not applicable on CAN channels. |
35 | `extend_frameid` | from @ref ua_protocol_iso_tp | Boolean | The frame id length (11 Bits in case of false, 29 Bits other wise) used for request and response frames. not applicable for LIN channels. |
36 | `req_data` | <> | Binary | The request payload. |
37 | `rsp_data` | <> | Binary | The response payload. |
38 | `service_id` | -1 | 16bit Number | The Service ID or sid of the request. If the value is between 0 and 255 the first byte of the simulated request will be set to this value when executing the service. |
39 | `rsp_service_id` | -1 | 16bit Number | The Response Service ID or rsid of the response. If the value is between 0 and 255 the first byte of the simulated response will be set to this value, after the request is completed in the service execution. |
40 | `negative_response_code` | 0 | 8bit Number | The negative response code or nrc from the last/current service execution. |
41 | `req_simulate` | true | Boolean | If true the request is send(simulated) by the application. |
42 | `rsp_simulate` | false | Boolean | If true the response is send(simulated) by the application. |
43 | `req_flowstate` | CAN:0 | 4bit Number | The status value of the last/next flow control frame received/send during the request. |
44 | `rsp_flowstate` | CAN:0 | 4bit Number | The status value of the last/next flow control frame received/send during the response. |
45 | `req_blocksize` | from @ref ua_protocol_iso_tp | 8bit Number | The block size value of the last/next flow control frame received/send during the request. |
46 | `rsp_blocksize` | from @ref ua_protocol_iso_tp | 8bit Number | The block size value of the last/next flow control frame received/send during the response. |
47 | `max_flow_wait` | from @ref ua_protocol_iso_tp | 32bit Number | For this may times the flow state is allowed to be 1, before aborting the service execution. |
48 | `max_continue_count` | from @ref ua_protocol_iso_tp | 32bit Number | For this may times the Response will be repeated when a negative response code of 0x78 (continue to send) is received. |
49 | `padding` | from @ref ua_protocol_iso_tp | 8bit Number | The value to fill the last frame with if not optimized. This value is also the default value for not mapped parts of the request and response payload. |
50 | `optimize` | from @ref ua_protocol_iso_tp | Boolean | If this is set to true the last frame of the request and response will be transmitted with just the required frame length. e.g. a request with NAD and 3 bytes payload will have only 5 bytes instead of 8. |
51
52 #### Method __Tags__
53
54 | __Tag__ | __Parameters__ | __Description__ |
55 | :--: | :--: | :-- |
56 | `execute` | -- | Executes the service.<br>Return values in the range of:<br> 0-255 = The `negative_response_code`<br> (-255)-(-1) = The result of an intermediate command, send by the Device multiplied by '-1', to distinguish it from `negative_response_code` values. |
57 | `wait_complete` | `timeout`=64bit Number | Stalls until the service stops executing or the timeout is reached. The timeout is given in milliseconds, its default value is 5,8*10^8 years. |
58 | `wait_start` | `timeout`=64bit Number | Stalls until the service starts executing or the timeout is reached. The timeout is given in milliseconds, its default value is 5,8*10^8 years. |
59
60
61 <hr>
62 # Free Mapping {#free_mappings}
63 <hr>
64
65 Your are free to extract arbitrary data from the request and response.
66 In opposition to other Objects in the tree, no handle can be generated for Free Mapping objects, so they can only be used in getters or setters.
67 In the following examples a short is written into the request, so that the request data is {0x10, 0x01}:
68 ~~~~.c
69 // first the 0x10 is written to request byte 0 then 0x01 to request byte 1
70 BLC_setUnsignedNumber(service_handle, "mapping offset=0 length=16 request", 0x0110);
71 ~~~~
72 To achieve the same with motorola byte order (MSB first (0x01)):
73 ~~~~.c
74 // first the 0x01 is written to request byte 1 then 0x10 to request byte 0
75 BLC_setUnsignedNumber(service_handle, "mapping offset=8 length=16 type=motorolasawtooth request", 0x1001);
76 ~~~~
77
78 #### Child __Tags__
79
80 | __Tag__ | __Default Value__ | __Type__ | __Description__ |
81 | :--: | :--: | :--: | :-- |
82 | `offset` | 0 | <span style="white-space: nowrap;">32bit Number</span> | The offset of the mapping in bits. the value always takes reference to bit0 of the value to map. |
83 | `length` | 0xFFFFFFFF | 32bit Number | The length of the mapping in bits. If the length is 0xFFFFFFFF the length is inferred from the specific getter or setter function. 64 for @ref BLC_getSignedNumber, @ref BLC_getUnsignedNumber, @ref BLC_setSignedNumber and @ref BLC_setUnsignedNumber, 64 bit length is also assumed if the length value was set to a value greater then 64. (8 * data length) for @ref BLC_getBinary and @ref BLC_setBinary. |
84 | `extend` | true | Boolean | If set to "true"(1) the request/response will be enlarged, so that the given data fits in. other wise the returned value might indicate, that no data was mapped. |
85 | `type` | 0/"intelsawtooth" | 2bit Number<br>String | The bit and byte order to apply. 0=="intelsawtooth", 1=="intelsequential", 2=="motorolasawtooth", 3=="motorolasequential" |
86
87 #### Property __Tags__
88
89 | __Tag__ | __Type__ | __Description__ |
90 | :--: | :--: | :-- |
91 | `request` | <span style="white-space: nowrap;">64bit Number</span><br> Binary | Apply the mapping to the request payload. |
92 | `response` | 64bit Number<br> Binary | Apply the mapping to the response payload. |
BLC_getSignedNumber
int32_t BL_DLLIMPORT BLC_getSignedNumber(BL_HANDLE handle, const char *path, int64_t *result)
BLC_getSignedNumber gets a signed value from the given handle.
BLC_setSignedNumber
int32_t BL_DLLIMPORT BLC_setSignedNumber(BL_HANDLE handle, const char *path, int64_t value)
BLC_setSignedNumber sets a signed value of the given handle.
BLC_getUnsignedNumber
int32_t BL_DLLIMPORT BLC_getUnsignedNumber(BL_HANDLE handle, const char *path, uint64_t *result)
BLC_getUnsignedNumber gets a unsigned value from the given handle.
BLC_setBinary
int32_t BL_DLLIMPORT BLC_setBinary(BL_HANDLE handle, const char *path, const uint8_t *value, uint32_t value_length)
BLC_setBinary sets a binary value of the given handle.
BLC_setUnsignedNumber
int32_t BL_DLLIMPORT BLC_setUnsignedNumber(BL_HANDLE handle, const char *path, uint64_t value)
BLC_setUnsignedNumber sets an unsigned value of the given handle.
BLC_getBinary
int32_t BL_DLLIMPORT BLC_getBinary(BL_HANDLE handle, const char *path, uint8_t *result, uint32_t *result_length)
BLC_getBinary gets a binary value from the given handle.
Generated on Fri May 30 2025 17:16:12 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: markdowns/UnifiedAccess/UDS/ReadDTCInformation_SubFunctions/ReportDTCBySeverityMaskRecord.md File Reference

markdowns/UnifiedAccess/UDS/ReadDTCInformation_SubFunctions/ReportDTCBySeverityMaskRecord.md File Reference

Go to the source code of this file.

Generated on Fri May 30 2025 17:16:13 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: markdowns/UnifiedAccess/UDS/ReadDTCInformation_SubFunctions/ReportDTCBySeverityMaskRecord.md Source File

markdowns/UnifiedAccess/UDS/ReadDTCInformation_SubFunctions/ReportDTCBySeverityMaskRecord.md
Go to the documentation of this file.
1 # The UDS ReadDTCInformation ReportDTCBySeverityMaskRecord Subfuction ID 0x08.
2 @ingroup ua_uds_reportDTCBySeverityMaskRecord
3
4 You should first read through the @ref ua.<br>
5 Here additional __Tags__ of this ReadDTCInformation Subfunction can be looked up.<br>
6 The __Tags__ from @ref ua_uds_readdtcinformation and @ref ua_service_iso_tp are also supported.
7
8 #### Property __Tags__
9
10 | __Tag__ | __Default Value__ | __Type__ | __Description__ |
11 | :--: | :--: | :--: | :-- |
12 | `req_subfunction` | 8 | <span style="white-space: nowrap;">8bit Number</span> | The sub function or report type of the request. Setting this value will change the actual object type to that of the given sub function id. |
13 | `rsp_subfunction` | 8 | <span style="white-space: nowrap;">8bit Number</span> | The sub function or report type of the response. Setting this value will change the actual object type to that of the given sub function id. |
14 | `req_dtcseveritymaskrecord` | <> | Binary | The DTC Severity Mask Record of the Request. |
15 | `rsp_dtcstatusavailabilitymask` | <> | <span style="white-space: nowrap;">8bit Number</span> | The DTC Status Availability Mask of the Response. |
16 | `rsp_dtcandseverityrecords` | <> | Binary | The DTC And Severity Records of the Response.<br>This is a List of 6 byte blocks. The first byte is the DTC Severity value. The second byte is the DTC Functional Unit. The third, fourth and fifth byte are the DTC value(MSB first). The sixth byte is the statusOfDTC value. |
Generated on Fri May 30 2025 17:16:12 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: markdowns/UnifiedAccess/UDS/ReadDTCInformation_SubFunctions/ReportDTCByStatusMask.md File Reference

markdowns/UnifiedAccess/UDS/ReadDTCInformation_SubFunctions/ReportDTCByStatusMask.md File Reference

Go to the source code of this file.

Generated on Fri May 30 2025 17:16:13 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: markdowns/UnifiedAccess/UDS/ReadDTCInformation_SubFunctions/ReportDTCByStatusMask.md Source File

markdowns/UnifiedAccess/UDS/ReadDTCInformation_SubFunctions/ReportDTCByStatusMask.md
Go to the documentation of this file.
1 # The UDS ReadDTCInformation ReportDTCByStatusMask Subfuction ID 0x02.
2 @ingroup ua_uds_reportDTCByStatusMask
3
4 You should first read through the @ref ua.<br>
5 Here additional __Tags__ of this ReadDTCInformation Subfunction can be looked up.<br>
6 The __Tags__ from @ref ua_uds_readdtcinformation and @ref ua_service_iso_tp are also supported.
7
8 #### Property __Tags__
9
10 | __Tag__ | __Default Value__ | __Type__ | __Description__ |
11 | :--: | :--: | :--: | :-- |
12 | `req_subfunction` | 2 | <span style="white-space: nowrap;">8bit Number</span> | The sub function or report type of the request. Setting this value will change the actual object type to that of the given sub function id. |
13 | `rsp_subfunction` | 2 | <span style="white-space: nowrap;">8bit Number</span> | The sub function or report type of the response. Setting this value will change the actual object type to that of the given sub function id. |
14 | `req_dtcstatusmask` | <> | <span style="white-space: nowrap;">8bit Number</span> | The DTC Status Mask of the Request. |
15 | `rsp_dtcstatusavailabilitymask` | <> | <span style="white-space: nowrap;">8bit Number</span> | The DTC Status Availability Mask of the Response. |
16 | `rsp_dtcandstatusrecords` | <> | Binary | The DTC And Status Records of the Response.<br>This is a List of 4 byte blocks. The first, second and third byte are the DTC value(MSB first). The fourth byte is the statusOfDTC value. |
Generated on Fri May 30 2025 17:16:12 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: markdowns/UnifiedAccess/UDS/ReadDTCInformation_SubFunctions/ReportDTCExtDataRecordByDTCNumber.md File Reference

markdowns/UnifiedAccess/UDS/ReadDTCInformation_SubFunctions/ReportDTCExtDataRecordByDTCNumber.md File Reference

Go to the source code of this file.

Generated on Fri May 30 2025 17:16:13 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: markdowns/UnifiedAccess/UDS/ReadDTCInformation_SubFunctions/ReportDTCExtDataRecordByDTCNumber.md Source File

markdowns/UnifiedAccess/UDS/ReadDTCInformation_SubFunctions/ReportDTCExtDataRecordByDTCNumber.md
Go to the documentation of this file.
1 # The UDS ReadDTCInformation ReportDTCExtDataRecordByDTCNumber Subfuction ID 0x06.
2 @ingroup ua_uds_reportDTCExtDataRecordByDTCNumber
3
4 You should first read through the @ref ua.<br>
5 Here additional __Tags__ of this ReadDTCInformation Subfunction can be looked up.<br>
6 The __Tags__ from @ref ua_uds_readdtcinformation and @ref ua_service_iso_tp are also supported.
7
8 #### Property __Tags__
9
10 | __Tag__ | __Default Value__ | __Type__ | __Description__ |
11 | :--: | :--: | :--: | :-- |
12 | `req_subfunction` | 6 | <span style="white-space: nowrap;">8bit Number</span> | The sub function or report type of the request. Setting this value will change the actual object type to that of the given sub function id. |
13 | `rsp_subfunction` | 6 | <span style="white-space: nowrap;">8bit Number</span> | The sub function or report type of the response. Setting this value will change the actual object type to that of the given sub function id. |
14 | `req_dtcmaskrecord` | <> | <span style="white-space: nowrap;">24bit Number</span><br>Binary | The DTC Mask Record of the Request. |
15 | `req_dtcextdatarecordnumber` | <> | <span style="white-space: nowrap;">8bit Number</span> | The DTC Ext Data Record Number of the Request. |
16 | `rsp_dtcandstatusrecord` | <> | <span style="white-space: nowrap;">32bit Number</span><br>Binary | The DTC And Status Record of the Response.<br>The first, second and third byte are the DTC value(MSB first). The fourth byte is the statusOfDTC value. When accessed as Number the LSB is the statusOfDTC. |
17 | `rsp_dtcextdatarecords` | <> | Binary | The DTC Extended Data Records of the Response.<br>This is a List consisting of DTCExtDataRecordNumber and DTCExtDataRecord. The first byte is the DTCExtDataRecordNumber. The DTCExtDataRecord has to be defined by the manufacturer and thus the position of the next DTCExtDataRecordNumber. |
Generated on Fri May 30 2025 17:16:12 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: markdowns/UnifiedAccess/UDS/ReadDTCInformation_SubFunctions/ReportDTCExtDataRecordByRecordNumber.md File Reference

markdowns/UnifiedAccess/UDS/ReadDTCInformation_SubFunctions/ReportDTCExtDataRecordByRecordNumber.md File Reference

Go to the source code of this file.

Generated on Fri May 30 2025 17:16:13 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: markdowns/UnifiedAccess/UDS/ReadDTCInformation_SubFunctions/ReportDTCExtDataRecordByRecordNumber.md Source File

markdowns/UnifiedAccess/UDS/ReadDTCInformation_SubFunctions/ReportDTCExtDataRecordByRecordNumber.md
Go to the documentation of this file.
1 # The UDS ReadDTCInformation ReportDTCExtDataRecordByRecordNumber Subfuction ID 0x16.
2 @ingroup ua_uds_reportDTCExtDataRecordByRecordNumber
3
4 You should first read through the @ref ua.<br>
5 Here additional __Tags__ of this ReadDTCInformation Subfunction can be looked up.<br>
6 The __Tags__ from @ref ua_uds_readdtcinformation and @ref ua_service_iso_tp are also supported.
7
8 #### Property __Tags__
9
10 | __Tag__ | __Default Value__ | __Type__ | __Description__ |
11 | :--: | :--: | :--: | :-- |
12 | `req_subfunction` | 0x16 | <span style="white-space: nowrap;">8bit Number</span> | The sub function or report type of the request. Setting this value will change the actual object type to that of the given sub function id. |
13 | `rsp_subfunction` | 0x16 | <span style="white-space: nowrap;">8bit Number</span> | The sub function or report type of the response. Setting this value will change the actual object type to that of the given sub function id. |
14 | `req_dtcextdatarecordnumber` | <> | <span style="white-space: nowrap;">8bit Number</span> | The DTC Extended Data Record Number of the Request. |
15 | `rsp_dtcextdatarecordnumber` | <> | <span style="white-space: nowrap;">8bit Number</span> | The DTC Extended Data Record Number of the Response. |
16 | `rsp_dtcextdatarecords` | <> | Binary | The DTC Extended Data Records of the Response.<br>This is a List of DTCAndStatusRecord and DTCExtDataRecord fields. The first, second and third byte are the DTC value(MSB first). The fourth byte is the statusOfDTC value. The manufacturer has to document the amount and format of the following bytes forming the DTCExtDataRecord and thus where the next Record begins. |
Generated on Fri May 30 2025 17:16:12 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: markdowns/UnifiedAccess/UDS/ReadDTCInformation_SubFunctions/ReportDTCFaultDetectionCounter.md File Reference

markdowns/UnifiedAccess/UDS/ReadDTCInformation_SubFunctions/ReportDTCFaultDetectionCounter.md File Reference

Go to the source code of this file.

Generated on Fri May 30 2025 17:16:13 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: markdowns/UnifiedAccess/UDS/ReadDTCInformation_SubFunctions/ReportDTCFaultDetectionCounter.md Source File

markdowns/UnifiedAccess/UDS/ReadDTCInformation_SubFunctions/ReportDTCFaultDetectionCounter.md
Go to the documentation of this file.
1 # The UDS ReadDTCInformation ReportDTCFaultDetectionCounter Subfuction ID 0x14.
2 @ingroup ua_uds_reportDTCFaultDetectionCounter
3
4 You should first read through the @ref ua.<br>
5 Here additional __Tags__ of this ReadDTCInformation Subfunction can be looked up.<br>
6 The __Tags__ from @ref ua_uds_readdtcinformation and @ref ua_service_iso_tp are also supported.
7
8 #### Property __Tags__
9
10 | __Tag__ | __Default Value__ | __Type__ | __Description__ |
11 | :--: | :--: | :--: | :-- |
12 | `req_subfunction` | 0x14 | <span style="white-space: nowrap;">8bit Number</span> | The sub function or report type of the request. Setting this value will change the actual object type to that of the given sub function id. |
13 | `rsp_subfunction` | 0x14 | <span style="white-space: nowrap;">8bit Number</span> | The sub function or report type of the response. Setting this value will change the actual object type to that of the given sub function id. |
14 | `rsp_dtcfaultdetectioncounterrecord` | <> | Binary | The DTC Fault Detection Counter Record of the Response.<br>This is a List of 4 byte blocks. The first, second and third byte are the DTC value(MSB first). The fourth byte is the DTC Fault Detection Counter value. |
Generated on Fri May 30 2025 17:16:13 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: markdowns/UnifiedAccess/UDS/ReadDTCInformation_SubFunctions/ReportDTCSnapshotIdentification.md File Reference

markdowns/UnifiedAccess/UDS/ReadDTCInformation_SubFunctions/ReportDTCSnapshotIdentification.md File Reference

Go to the source code of this file.

Generated on Fri May 30 2025 17:16:13 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: markdowns/UnifiedAccess/UDS/ReadDTCInformation_SubFunctions/ReportDTCSnapshotIdentification.md Source File

markdowns/UnifiedAccess/UDS/ReadDTCInformation_SubFunctions/ReportDTCSnapshotIdentification.md
Go to the documentation of this file.
1 # The UDS ReadDTCInformation ReportDTCSnapshotIdentification Subfuction ID 0x03.
2 @ingroup ua_uds_reportDTCSnapshotIdentification
3
4 You should first read through the @ref ua.<br>
5 Here additional __Tags__ of this ReadDTCInformation Subfunction can be looked up.<br>
6 The __Tags__ from @ref ua_uds_readdtcinformation and @ref ua_service_iso_tp are also supported.
7
8 #### Property __Tags__
9
10 | __Tag__ | __Default Value__ | __Type__ | __Description__ |
11 | :--: | :--: | :--: | :-- |
12 | `req_subfunction` | 3 | <span style="white-space: nowrap;">8bit Number</span> | The sub function or report type of the request. Setting this value will change the actual object type to that of the given sub function id. |
13 | `rsp_subfunction` | 3 | <span style="white-space: nowrap;">8bit Number</span> | The sub function or report type of the response. Setting this value will change the actual object type to that of the given sub function id. |
14 | `req_dtcmaskrecord` | <> | <span style="white-space: nowrap;">24bit Number</span><br>Binary | The DTC Mask Record of the Request. |
15 | `req_dtcsnapshotrecordnumber` | <> | <span style="white-space: nowrap;">8bit Number</span> | The DTC Snapshot Record Number of the Request. |
16 | `rsp_dtcrecords` | <> | Binary | The DTC Records of the Response.<br>This is a list of 4 byte blocks, containing DTCRecord and DTCSnapshotRecordNumber. The first, second and third bytes are the DTC value(MSB first). The fourth byte is the DTCSnapshotRecordNumber. |
Generated on Fri May 30 2025 17:16:13 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: markdowns/UnifiedAccess/UDS/ReadDTCInformation_SubFunctions/ReportDTCSnapshotRecordByDTCNumber.md File Reference

markdowns/UnifiedAccess/UDS/ReadDTCInformation_SubFunctions/ReportDTCSnapshotRecordByDTCNumber.md File Reference

Go to the source code of this file.

Generated on Fri May 30 2025 17:16:13 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: markdowns/UnifiedAccess/UDS/ReadDTCInformation_SubFunctions/ReportDTCSnapshotRecordByDTCNumber.md Source File

markdowns/UnifiedAccess/UDS/ReadDTCInformation_SubFunctions/ReportDTCSnapshotRecordByDTCNumber.md
Go to the documentation of this file.
1 # The UDS ReadDTCInformation ReportDTCSnapshotRecordByDTCNumber Subfuction ID 0x04.
2 @ingroup ua_uds_reportDTCSnapshotRecordByDTCNumber
3
4 You should first read through the @ref ua.<br>
5 Here additional __Tags__ of this ReadDTCInformation Subfunction can be looked up.<br>
6 The __Tags__ from @ref ua_uds_readdtcinformation and @ref ua_service_iso_tp are also supported.
7
8 #### Property __Tags__
9
10 | __Tag__ | __Default Value__ | __Type__ | __Description__ |
11 | :--: | :--: | :--: | :-- |
12 | `req_subfunction` | 4 | <span style="white-space: nowrap;">8bit Number</span> | The sub function or report type of the request. Setting this value will change the actual object type to that of the given sub function id. |
13 | `rsp_subfunction` | 4 | <span style="white-space: nowrap;">8bit Number</span> | The sub function or report type of the response. Setting this value will change the actual object type to that of the given sub function id. |
14 | `req_dtcmaskrecord` | <> | <span style="white-space: nowrap;">24bit Number</span><br>Binary | The DTC Mask Record of the Request. |
15 | `req_dtcsnapshotrecordnumber` | <> | <span style="white-space: nowrap;">8bit Number</span> | The DTC Snapshot Record Number of the Request. |
16 | `rsp_dtcandstatusrecord` | <> | <span style="white-space: nowrap;">32bit Number</span><br>Binary | The DTC And Status Record of the Response.<br>The first, second and third byte are the DTC value(MSB first). The fourth byte is the statusOfDTC value. When accessed as Number the LSB ist the statusOfDTC. |
17 | `rsp_dtcsnapshotrecords` | <> | Binary | The DTC Snapshot Records of the Response.<br> This is a list consisting of DTCSnapshotRecordNumber, DTCSnapshotRecordNumberOfIdentifiers and DTCSnapshotRecord. The first byte is the DTCSnapshotRecordNumber. The second byte is the DTCSnapshotRecordNumberOfIdentifiers, followed by the DTCSnapshotRecord.<br>The DTCSnapshotRecord is a List of DataIdentifers and the corresponding snapshotData. The first and second bytes are the DataIdentifier value(MSB first), followed by the snapshotData. The size of the snapshotData has to be defined by the manufacturer and thus the position of the next DataIdentifier and DTCSnapshotRecordNumber. |
Generated on Fri May 30 2025 17:16:13 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: markdowns/UnifiedAccess/UDS/ReadDTCInformation_SubFunctions/ReportDTCStoredDataByRecordNumber.md File Reference

markdowns/UnifiedAccess/UDS/ReadDTCInformation_SubFunctions/ReportDTCStoredDataByRecordNumber.md File Reference

Go to the source code of this file.

Generated on Fri May 30 2025 17:16:13 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: markdowns/UnifiedAccess/UDS/ReadDTCInformation_SubFunctions/ReportDTCStoredDataByRecordNumber.md Source File

markdowns/UnifiedAccess/UDS/ReadDTCInformation_SubFunctions/ReportDTCStoredDataByRecordNumber.md
Go to the documentation of this file.
1 # The UDS ReadDTCInformation ReportDTCStoredDataByRecordNumber Subfuction ID 0x05.
2 @ingroup ua_uds_reportDTCStoredDataByRecordNumber
3
4 You should first read through the @ref ua.<br>
5 Here additional __Tags__ of this ReadDTCInformation Subfunction can be looked up.<br>
6 The __Tags__ from @ref ua_uds_readdtcinformation and @ref ua_service_iso_tp are also supported.
7
8 #### Property __Tags__
9
10 | __Tag__ | __Default Value__ | __Type__ | __Description__ |
11 | :--: | :--: | :--: | :-- |
12 | `req_subfunction` | 5 | <span style="white-space: nowrap;">8bit Number</span> | The sub function or report type of the request. Setting this value will change the actual object type to that of the given sub function id. |
13 | `rsp_subfunction` | 5 | <span style="white-space: nowrap;">8bit Number</span> | The sub function or report type of the response. Setting this value will change the actual object type to that of the given sub function id. |
14 | `req_dtcstoreddatarecordnumber` | <> | <span style="white-space: nowrap;">8bit Number</span> | The DTC Stored Data Record Number of the Request. |
15 | `rsp_dtcstoreddatarecords` | <> | Binary | The DTC Stored Data Records of the Response.<br> This is a list consisting of DTCStoredDataRecordNumber, DTCAndStatusRecord, DTCStoredDataRecordNumberOfIdentifiers and DTCStoredDataRecord. The first byte is the DTCStoredDataRecordNumber. The second, third and fourth bytes are the DTC value(MSB first). The fifth byte id the statusOfDTC. The sixth byte is the DTCStoredDataRecordNumberOfIdentifiers, followed by the DTCStoredDataRecord.<br>The DTCStoredDataRecord is a List of DataIdentifers and the corresponding DTCStoredData. The first and second bytes are the DataIdentifier value(MSB first), followed by the DTCStoredData. The size of the DTCStoredData has to be defined by the manufacturer and thus the position of the next DataIdentifier and DTCStoredDataRecordNumber. |
Generated on Fri May 30 2025 17:16:13 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: markdowns/UnifiedAccess/UDS/ReadDTCInformation_SubFunctions/ReportDTCWithPermanentStatus.md File Reference

markdowns/UnifiedAccess/UDS/ReadDTCInformation_SubFunctions/ReportDTCWithPermanentStatus.md File Reference

Go to the source code of this file.

Generated on Fri May 30 2025 17:16:13 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: markdowns/UnifiedAccess/UDS/ReadDTCInformation_SubFunctions/ReportDTCWithPermanentStatus.md Source File

markdowns/UnifiedAccess/UDS/ReadDTCInformation_SubFunctions/ReportDTCWithPermanentStatus.md
Go to the documentation of this file.
1 # The UDS ReadDTCInformation ReportDTCWithPermanentStatus Subfuction ID 0x15.
2 @ingroup ua_uds_reportDTCWithPermanentStatus
3
4 You should first read through the @ref ua.<br>
5 Here additional __Tags__ of this ReadDTCInformation Subfunction can be looked up.<br>
6 The __Tags__ from @ref ua_uds_readdtcinformation and @ref ua_service_iso_tp are also supported.
7
8 #### Property __Tags__
9
10 | __Tag__ | __Default Value__ | __Type__ | __Description__ |
11 | :--: | :--: | :--: | :-- |
12 | `req_subfunction` | 0x15 | <span style="white-space: nowrap;">8bit Number</span> | The sub function or report type of the request. Setting this value will change the actual object type to that of the given sub function id. |
13 | `rsp_subfunction` | 0x15 | <span style="white-space: nowrap;">8bit Number</span> | The sub function or report type of the response. Setting this value will change the actual object type to that of the given sub function id. |
14 | `rsp_dtcstatusavailabilitymask` | <> | <span style="white-space: nowrap;">8bit Number</span> | The DTC Status Availability Mask of the Response. |
15 | `rsp_dtcandstatusrecords` | <> | Binary | The DTC And Status Records of the Response.<br>This is a List of 4 byte blocks. The first, second and third byte are the DTC value(MSB first). The fourth byte is the statusOfDTC value. |
Generated on Fri May 30 2025 17:16:13 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: markdowns/UnifiedAccess/UDS/ReadDTCInformation_SubFunctions/ReportEmissionsOBDDTCByStatusMask.md File Reference

markdowns/UnifiedAccess/UDS/ReadDTCInformation_SubFunctions/ReportEmissionsOBDDTCByStatusMask.md File Reference

Go to the source code of this file.

Generated on Fri May 30 2025 17:16:13 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: markdowns/UnifiedAccess/UDS/ReadDTCInformation_SubFunctions/ReportEmissionsOBDDTCByStatusMask.md Source File

markdowns/UnifiedAccess/UDS/ReadDTCInformation_SubFunctions/ReportEmissionsOBDDTCByStatusMask.md
Go to the documentation of this file.
1 # The UDS ReadDTCInformation ReportEmissionsOBDDTCByStatusMask Subfuction ID 0x13.
2 @ingroup ua_uds_reportEmissionsOBDDTCByStatusMask
3
4 You should first read through the @ref ua.<br>
5 Here additional __Tags__ of this ReadDTCInformation Subfunction can be looked up.<br>
6 The __Tags__ from @ref ua_uds_readdtcinformation and @ref ua_service_iso_tp are also supported.
7
8 #### Property __Tags__
9
10 | __Tag__ | __Default Value__ | __Type__ | __Description__ |
11 | :--: | :--: | :--: | :-- |
12 | `req_subfunction` | 0x13 | <span style="white-space: nowrap;">8bit Number</span> | The sub function or report type of the request. Setting this value will change the actual object type to that of the given sub function id. |
13 | `rsp_subfunction` | 0x13 | <span style="white-space: nowrap;">8bit Number</span> | The sub function or report type of the response. Setting this value will change the actual object type to that of the given sub function id. |
14 | `req_dtcstatusmask` | <> | <span style="white-space: nowrap;">8bit Number</span> | The DTC Status Mask of the Request. |
15 | `rsp_dtcstatusavailabilitymask` | <> | <span style="white-space: nowrap;">8bit Number</span> | The DTC Status Availability Mask of the Response. |
16 | `rsp_dtcandstatusrecords` | <> | Binary | The DTC And Status Records of the Response.<br>This is a List of 4 byte blocks. The first, second and third byte are the DTC value(MSB first). The fourth byte is the statusOfDTC value. |
Generated on Fri May 30 2025 17:16:13 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: markdowns/UnifiedAccess/UDS/ReadDTCInformation_SubFunctions/ReportFirstConfirmedDTC.md File Reference

markdowns/UnifiedAccess/UDS/ReadDTCInformation_SubFunctions/ReportFirstConfirmedDTC.md File Reference

Go to the source code of this file.

Generated on Fri May 30 2025 17:16:13 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: markdowns/UnifiedAccess/UDS/ReadDTCInformation_SubFunctions/ReportFirstConfirmedDTC.md Source File

markdowns/UnifiedAccess/UDS/ReadDTCInformation_SubFunctions/ReportFirstConfirmedDTC.md
Go to the documentation of this file.
1 # The UDS ReadDTCInformation ReportFirstConfirmedDTC Subfuction ID 0x0C.
2 @ingroup ua_uds_reportFirstConfirmedDTC
3
4 You should first read through the @ref ua.<br>
5 Here additional __Tags__ of this ReadDTCInformation Subfunction can be looked up.<br>
6 The __Tags__ from @ref ua_uds_readdtcinformation and @ref ua_service_iso_tp are also supported.
7
8 #### Property __Tags__
9
10 | __Tag__ | __Default Value__ | __Type__ | __Description__ |
11 | :--: | :--: | :--: | :-- |
12 | `req_subfunction` | 0x0C | 8bit Number | The sub function or report type of the request. Setting this value will change the actual object type to that of the given sub function id. |
13 | `rsp_subfunction` | 0x0C | 8bit Number | The sub function or report type of the response. Setting this value will change the actual object type to that of the given sub function id. |
14 | `rsp_dtcstatusavailabilitymask` | <> | 8bit Number | The DTC Status Availability Mask of the Response. |
15 | `rsp_dtcandstatusrecords` | <> | Binary | The DTC And Status Records of the Response.<br>This is a List of 4 byte blocks. The first, second and third byte are the DTC value(MSB first). The fourth byte is the statusOfDTC value. |
Generated on Fri May 30 2025 17:16:13 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: markdowns/UnifiedAccess/UDS/ReadDTCInformation_SubFunctions/ReportFirstTestFailedDTC.md File Reference

markdowns/UnifiedAccess/UDS/ReadDTCInformation_SubFunctions/ReportFirstTestFailedDTC.md File Reference

Go to the source code of this file.

Generated on Fri May 30 2025 17:16:13 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: markdowns/UnifiedAccess/UDS/ReadDTCInformation_SubFunctions/ReportFirstTestFailedDTC.md Source File

markdowns/UnifiedAccess/UDS/ReadDTCInformation_SubFunctions/ReportFirstTestFailedDTC.md
Go to the documentation of this file.
1 # The UDS ReadDTCInformation ReportFirstTestFailedDTC Subfuction ID 0x0B.
2 @ingroup ua_uds_reportFirstTestFailedDTC
3
4 You should first read through the @ref ua.<br>
5 Here additional __Tags__ of this ReadDTCInformation Subfunction can be looked up.<br>
6 The __Tags__ from @ref ua_uds_readdtcinformation and @ref ua_service_iso_tp are also supported.
7
8 #### Property __Tags__
9
10 | __Tag__ | __Default Value__ | __Type__ | __Description__ |
11 | :--: | :--: | :--: | :-- |
12 | `req_subfunction` | 0x0B | <span style="white-space: nowrap;">8bit Number</span> | The sub function or report type of the request. Setting this value will change the actual object type to that of the given sub function id. |
13 | `rsp_subfunction` | 0x0B | <span style="white-space: nowrap;">8bit Number</span> | The sub function or report type of the response. Setting this value will change the actual object type to that of the given sub function id. |
14 | `rsp_dtcstatusavailabilitymask` | <> | <span style="white-space: nowrap;">8bit Number</span> | The DTC Status Availability Mask of the Response. |
15 | `rsp_dtcandstatusrecords` | <> | Binary | The DTC And Status Records of the Response.<br>This is a List of 4 byte blocks. The first, second and third byte are the DTC value(MSB first). The fourth byte is the statusOfDTC value. |
Generated on Fri May 30 2025 17:16:13 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: markdowns/UnifiedAccess/UDS/ReadDTCInformation_SubFunctions/ReportMirrorMemoryDTCByStatusMask.md File Reference

markdowns/UnifiedAccess/UDS/ReadDTCInformation_SubFunctions/ReportMirrorMemoryDTCByStatusMask.md File Reference

Go to the source code of this file.

Generated on Fri May 30 2025 17:16:13 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: markdowns/UnifiedAccess/UDS/ReadDTCInformation_SubFunctions/ReportMirrorMemoryDTCByStatusMask.md Source File

markdowns/UnifiedAccess/UDS/ReadDTCInformation_SubFunctions/ReportMirrorMemoryDTCByStatusMask.md
Go to the documentation of this file.
1 # The UDS ReadDTCInformation ReportMirrorMemoryDTCByStatusMask Subfuction ID 0x0F.
2 @ingroup ua_uds_reportMirrorMemoryDTCByStatusMask
3
4 You should first read through the @ref ua.<br>
5 Here additional __Tags__ of this ReadDTCInformation Subfunction can be looked up.<br>
6 The __Tags__ from @ref ua_uds_readdtcinformation and @ref ua_service_iso_tp are also supported.
7
8 #### Property __Tags__
9
10 | __Tag__ | __Default Value__ | __Type__ | __Description__ |
11 | :--: | :--: | :--: | :-- |
12 | `req_subfunction` | 0x0F | <span style="white-space: nowrap;">8bit Number</span> | The sub function or report type of the request. Setting this value will change the actual object type to that of the given sub function id. |
13 | `rsp_subfunction` | 0x0F | <span style="white-space: nowrap;">8bit Number</span> | The sub function or report type of the response. Setting this value will change the actual object type to that of the given sub function id. |
14 | `req_dtcstatusmask` | <> | <span style="white-space: nowrap;">8bit Number</span> | The DTC Status Mask of the Request. |
15 | `rsp_dtcstatusavailabilitymask` | <> | <span style="white-space: nowrap;">8bit Number</span> | The DTC Status Availability Mask of the Response. |
16 | `rsp_dtcandstatusrecords` | <> | Binary | The DTC And Status Records of the Response.<br>This is a List of 4 byte blocks. The first, second and third byte are the DTC value(MSB first). The fourth byte is the statusOfDTC value. |
Generated on Fri May 30 2025 17:16:13 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: markdowns/UnifiedAccess/UDS/ReadDTCInformation_SubFunctions/ReportMirrorMemoryDTCExtDataRecordByDTCNumber.md File Reference

markdowns/UnifiedAccess/UDS/ReadDTCInformation_SubFunctions/ReportMirrorMemoryDTCExtDataRecordByDTCNumber.md File Reference

Go to the source code of this file.

Generated on Fri May 30 2025 17:16:13 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: markdowns/UnifiedAccess/UDS/ReadDTCInformation_SubFunctions/ReportMirrorMemoryDTCExtDataRecordByDTCNumber.md Source File

markdowns/UnifiedAccess/UDS/ReadDTCInformation_SubFunctions/ReportMirrorMemoryDTCExtDataRecordByDTCNumber.md
Go to the documentation of this file.
1 # The UDS ReadDTCInformation ReportMirrorMemoryDTCExtDataRecordByDTCNumber Subfuction ID 0x10.
2 @ingroup ua_uds_reportMirrorMemoryDTCExtDataRecordByDTCNumber
3
4 You should first read through the @ref ua.<br>
5 Here additional __Tags__ of this ReadDTCInformation Subfunction can be looked up.<br>
6 The __Tags__ from @ref ua_uds_readdtcinformation and @ref ua_service_iso_tp are also supported.
7
8 #### Property __Tags__
9
10 | __Tag__ | __Default Value__ | __Type__ | __Description__ |
11 | :--: | :--: | :--: | :-- |
12 | `req_subfunction` | 0x10 | <span style="white-space: nowrap;">8bit Number</span> | The sub function or report type of the request. Setting this value will change the actual object type to that of the given sub function id. |
13 | `rsp_subfunction` | 0x10 | <span style="white-space: nowrap;">8bit Number</span> | The sub function or report type of the response. Setting this value will change the actual object type to that of the given sub function id. |
14 | `req_dtcmaskrecord` | <> | <span style="white-space: nowrap;">24bit Number</span><br>Binary | The DTC Mask Record of the Request. |
15 | `req_dtcextdatarecordnumber` | <> | <span style="white-space: nowrap;">8bit Number</span> | The DTC Ext Data Record Number of the Request. |
16 | `rsp_dtcandstatusrecord` | <> | <span style="white-space: nowrap;">32bit Number</span><br>Binary | The DTC And Status Record of the Response.<br>The first, second and third byte are the DTC value(MSB first). The fourth byte is the statusOfDTC value. When accessed as Number the LSB is the statusOfDTC. |
17 | `rsp_dtcextdatarecords` | <> | Binary | The DTC Extended Data Records of the Response.<br>This is a List consisting of DTCExtDataRecordNumber and DTCExtDataRecord. The first byte is the DTCExtDataRecordNumber. The DTCExtDataRecord has to be defined by the manufacturer and thus the position of the next DTCExtDataRecordNumber. |
Generated on Fri May 30 2025 17:16:13 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: markdowns/UnifiedAccess/UDS/ReadDTCInformation_SubFunctions/ReportMostRecentConfirmedDTC.md File Reference

markdowns/UnifiedAccess/UDS/ReadDTCInformation_SubFunctions/ReportMostRecentConfirmedDTC.md File Reference

Go to the source code of this file.

Generated on Fri May 30 2025 17:16:13 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: markdowns/UnifiedAccess/UDS/ReadDTCInformation_SubFunctions/ReportMostRecentConfirmedDTC.md Source File

markdowns/UnifiedAccess/UDS/ReadDTCInformation_SubFunctions/ReportMostRecentConfirmedDTC.md
Go to the documentation of this file.
1 # The UDS ReadDTCInformation ReportMostRecentConfirmedDTC Subfuction ID 0x0E.
2 @ingroup ua_uds_reportMostRecentConfirmedDTC
3
4 You should first read through the @ref ua.<br>
5 Here additional __Tags__ of this ReadDTCInformation Subfunction can be looked up.<br>
6 The __Tags__ from @ref ua_uds_readdtcinformation and @ref ua_service_iso_tp are also supported.
7
8 #### Property __Tags__
9
10 | __Tag__ | __Default Value__ | __Type__ | __Description__ |
11 | :--: | :--: | :--: | :-- |
12 | `req_subfunction` | 0x0E | <span style="white-space: nowrap;">8bit Number</span> | The sub function or report type of the request. Setting this value will change the actual object type to that of the given sub function id. |
13 | `rsp_subfunction` | 0x0E | <span style="white-space: nowrap;">8bit Number</span> | The sub function or report type of the response. Setting this value will change the actual object type to that of the given sub function id. |
14 | `rsp_dtcstatusavailabilitymask` | <> | <span style="white-space: nowrap;">8bit Number</span> | The DTC Status Availability Mask of the Response. |
15 | `rsp_dtcandstatusrecords` | <> | Binary | The DTC And Status Records of the Response.<br>This is a List of 4 byte blocks. The first, second and third byte are the DTC value(MSB first). The fourth byte is the statusOfDTC value. |
Generated on Fri May 30 2025 17:16:13 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: markdowns/UnifiedAccess/UDS/ReadDTCInformation_SubFunctions/ReportMostRecentTestFailedDTC.md File Reference

markdowns/UnifiedAccess/UDS/ReadDTCInformation_SubFunctions/ReportMostRecentTestFailedDTC.md File Reference

Go to the source code of this file.

Generated on Fri May 30 2025 17:16:13 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: markdowns/UnifiedAccess/UDS/ReadDTCInformation_SubFunctions/ReportMostRecentTestFailedDTC.md Source File

markdowns/UnifiedAccess/UDS/ReadDTCInformation_SubFunctions/ReportMostRecentTestFailedDTC.md
Go to the documentation of this file.
1 # The UDS ReadDTCInformation ReportMostRecentTestFailedDTC Subfuction ID 0x0D.
2 @ingroup ua_uds_reportMostRecentTestFailedDTC
3
4 You should first read through the @ref ua.<br>
5 Here additional __Tags__ of this ReadDTCInformation Subfunction can be looked up.<br>
6 The __Tags__ from @ref ua_uds_readdtcinformation and @ref ua_service_iso_tp are also supported.
7
8 #### Property __Tags__
9
10 | __Tag__ | __Default Value__ | __Type__ | __Description__ |
11 | :--: | :--: | :--: | :-- |
12 | `req_subfunction` | 0x0D | <span style="white-space: nowrap;">8bit Number</span> | The sub function or report type of the request. Setting this value will change the actual object type to that of the given sub function id. |
13 | `rsp_subfunction` | 0x0D | <span style="white-space: nowrap;">8bit Number</span> | The sub function or report type of the response. Setting this value will change the actual object type to that of the given sub function id. |
14 | `rsp_dtcstatusavailabilitymask` | <> | <span style="white-space: nowrap;">8bit Number</span> | The DTC Status Availability Mask of the Response. |
15 | `rsp_dtcandstatusrecords` | <> | Binary | The DTC And Status Records of the Response.<br>This is a List of 4 byte blocks. The first, second and third byte are the DTC value(MSB first). The fourth byte is the statusOfDTC value. |
Generated on Fri May 30 2025 17:16:13 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: markdowns/UnifiedAccess/UDS/ReadDTCInformation_SubFunctions/ReportNumberOfDTCBySeverityMaskRecord.md File Reference

markdowns/UnifiedAccess/UDS/ReadDTCInformation_SubFunctions/ReportNumberOfDTCBySeverityMaskRecord.md File Reference

Go to the source code of this file.

Generated on Fri May 30 2025 17:16:13 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: markdowns/UnifiedAccess/UDS/ReadDTCInformation_SubFunctions/ReportNumberOfDTCBySeverityMaskRecord.md Source File

markdowns/UnifiedAccess/UDS/ReadDTCInformation_SubFunctions/ReportNumberOfDTCBySeverityMaskRecord.md
Go to the documentation of this file.
1 # The UDS ReadDTCInformation ReportNumberOfDTCBySeverityMaskRecord Subfuction ID 0x07.
2 @ingroup ua_uds_reportNumberOfDTCBySeverityMaskRecord
3
4 You should first read through the @ref ua.<br>
5 Here additional __Tags__ of this ReadDTCInformation Subfunction can be looked up.<br>
6 The __Tags__ from @ref ua_uds_readdtcinformation and @ref ua_service_iso_tp are also supported.
7
8 #### Property __Tags__
9
10 | __Tag__ | __Default Value__ | __Type__ | __Description__ |
11 | :--: | :--: | :--: | :-- |
12 | `req_subfunction` | 7 | <span style="white-space: nowrap;">8bit Number</span> | The sub function or report type of the request. Setting this value will change the actual object type to that of the given sub function id. |
13 | `rsp_subfunction` | 7 | <span style="white-space: nowrap;">8bit Number</span> | The sub function or report type of the response. Setting this value will change the actual object type to that of the given sub function id. |
14 | `req_dtcseveritymaskrecord` | <> | Binary | The DTC Severity Mask Record of the Request. |
15 | `rsp_dtcstatusavailabilitymask` | <> | <span style="white-space: nowrap;">8bit Number</span> | The DTC Status Availability Mask of the Response. |
16 | `rsp_dtcformatidentifier` | <> | <span style="white-space: nowrap;">8bit Number</span> | The DTC Format Identifier of the Response. |
17 | `rsp_dtccount` | <> | <span style="white-space: nowrap;">16bit Number</span> | The DTC Count of the Response. |
Generated on Fri May 30 2025 17:16:13 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: markdowns/UnifiedAccess/UDS/ReadDTCInformation_SubFunctions/ReportNumberOfDTCByStatusMask.md File Reference

markdowns/UnifiedAccess/UDS/ReadDTCInformation_SubFunctions/ReportNumberOfDTCByStatusMask.md File Reference

Go to the source code of this file.

Generated on Fri May 30 2025 17:16:13 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: markdowns/UnifiedAccess/UDS/ReadDTCInformation_SubFunctions/ReportNumberOfDTCByStatusMask.md Source File

markdowns/UnifiedAccess/UDS/ReadDTCInformation_SubFunctions/ReportNumberOfDTCByStatusMask.md
Go to the documentation of this file.
1 # The UDS ReadDTCInformation ReportNumberOfDTCByStatusMask Subfuction ID 0x01.
2 @ingroup ua_uds_reportNumberOfDTCByStatusMask
3
4 You should first read through the @ref ua.<br>
5 Here additional __Tags__ of this ReadDTCInformation Subfunction can be looked up.<br>
6 The __Tags__ from @ref ua_uds_readdtcinformation and @ref ua_service_iso_tp are also supported.
7
8 #### Property __Tags__
9
10 | __Tag__ | __Default Value__ | __Type__ | __Description__ |
11 | :--: | :--: | :--: | :-- |
12 | `req_subfunction` | 1 | <span style="white-space: nowrap;">8bit Number</span> | The sub function or report type of the request. Setting this value will change the actual object type to that of the given sub function id. |
13 | `rsp_subfunction` | 1 | <span style="white-space: nowrap;">8bit Number</span> | The sub function or report type of the response. Setting this value will change the actual object type to that of the given sub function id. |
14 | `req_dtcstatusmask` | <> | <span style="white-space: nowrap;">8bit Number</span> | The DTC Status Mask of the Request. |
15 | `rsp_dtcstatusavailabilitymask` | <> | <span style="white-space: nowrap;">8bit Number</span> | The DTC Status Availability Mask of the Response. |
16 | `rsp_dtcformatidentifier` | <> | <span style="white-space: nowrap;">8bit Number</span> | The DTC Format Identifier of the Response. |
17 | `rsp_dtccount` | <> | <span style="white-space: nowrap;">16bit Number</span> | The DTC Count of the Response. |
Generated on Fri May 30 2025 17:16:13 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: markdowns/UnifiedAccess/UDS/ReadDTCInformation_SubFunctions/ReportNumberOfEmissionsOBDDTCByStatusMask.md File Reference

markdowns/UnifiedAccess/UDS/ReadDTCInformation_SubFunctions/ReportNumberOfEmissionsOBDDTCByStatusMask.md File Reference

Go to the source code of this file.

Generated on Fri May 30 2025 17:16:13 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: markdowns/UnifiedAccess/UDS/ReadDTCInformation_SubFunctions/ReportNumberOfEmissionsOBDDTCByStatusMask.md Source File

markdowns/UnifiedAccess/UDS/ReadDTCInformation_SubFunctions/ReportNumberOfEmissionsOBDDTCByStatusMask.md
Go to the documentation of this file.
1 # The UDS ReadDTCInformation ReportNumberOfEmissionsOBDDTCByStatusMask Subfuction ID 0x12.
2 @ingroup ua_uds_reportNumberOfEmissionsOBDDTCByStatusMask
3
4 You should first read through the @ref ua.<br>
5 Here additional __Tags__ of this ReadDTCInformation Subfunction can be looked up.<br>
6 The __Tags__ from @ref ua_uds_readdtcinformation and @ref ua_service_iso_tp are also supported.
7
8 #### Property __Tags__
9
10 | __Tag__ | __Default Value__ | __Type__ | __Description__ |
11 | :--: | :--: | :--: | :-- |
12 | `req_subfunction` | 0x12 | <span style="white-space: nowrap;">8bit Number</span> | The sub function or report type of the request. Setting this value will change the actual object type to that of the given sub function id. |
13 | `rsp_subfunction` | 0x12 | <span style="white-space: nowrap;">8bit Number</span> | The sub function or report type of the response. Setting this value will change the actual object type to that of the given sub function id. |
14 | `req_dtcstatusmask` | <> | <span style="white-space: nowrap;">8bit Number</span> | The DTC Status Mask of the Request. |
15 | `rsp_dtcstatusavailabilitymask` | <> | <span style="white-space: nowrap;">8bit Number</span> | The DTC Status Availability Mask of the Response. |
16 | `rsp_dtcformatidentifier` | <> | <span style="white-space: nowrap;">8bit Number</span> | The DTC Format Identifier of the Response. |
17 | `rsp_dtccount` | <> | <span style="white-space: nowrap;">16bit Number</span> | The DTC Count of the Response. |
Generated on Fri May 30 2025 17:16:13 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: markdowns/UnifiedAccess/UDS/ReadDTCInformation_SubFunctions/ReportNumberOfMirrorMemoryDTCByStatusMask.md File Reference

markdowns/UnifiedAccess/UDS/ReadDTCInformation_SubFunctions/ReportNumberOfMirrorMemoryDTCByStatusMask.md File Reference

Go to the source code of this file.

Generated on Fri May 30 2025 17:16:13 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: markdowns/UnifiedAccess/UDS/ReadDTCInformation_SubFunctions/ReportNumberOfMirrorMemoryDTCByStatusMask.md Source File

markdowns/UnifiedAccess/UDS/ReadDTCInformation_SubFunctions/ReportNumberOfMirrorMemoryDTCByStatusMask.md
Go to the documentation of this file.
1 # The UDS ReadDTCInformation ReportNumberOfMirrorMemoryDTCByStatusMask Subfuction ID 0x11.
2 @ingroup ua_uds_reportNumberOfMirrorMemoryDTCByStatusMask
3
4 You should first read through the @ref ua.<br>
5 Here additional __Tags__ of this ReadDTCInformation Subfunction can be looked up.<br>
6 The __Tags__ from @ref ua_uds_readdtcinformation and @ref ua_service_iso_tp are also supported.
7
8 #### Property __Tags__
9
10 | __Tag__ | __Default Value__ | __Type__ | __Description__ |
11 | :--: | :--: | :--: | :-- |
12 | `req_subfunction` | 0x11 | <span style="white-space: nowrap;">8bit Number</span> | The sub function or report type of the request. Setting this value will change the actual object type to that of the given sub function id. |
13 | `rsp_subfunction` | 0x11 | <span style="white-space: nowrap;">8bit Number</span> | The sub function or report type of the response. Setting this value will change the actual object type to that of the given sub function id. |
14 | `req_dtcstatusmask` | <> | <span style="white-space: nowrap;">8bit Number</span> | The DTC Status Mask of the Request. |
15 | `rsp_dtcstatusavailabilitymask` | <> | <span style="white-space: nowrap;">8bit Number</span> | The DTC Status Availability Mask of the Response. |
16 | `rsp_dtcformatidentifier` | <> | <span style="white-space: nowrap;">8bit Number</span> | The DTC Format Identifier of the Response. |
17 | `rsp_dtccount` | <> | <span style="white-space: nowrap;">16bit Number</span> | The DTC Count of the Response. |
Generated on Fri May 30 2025 17:16:13 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: markdowns/UnifiedAccess/UDS/ReadDTCInformation_SubFunctions/ReportSeverityInformationOfDTC.md File Reference

markdowns/UnifiedAccess/UDS/ReadDTCInformation_SubFunctions/ReportSeverityInformationOfDTC.md File Reference

Go to the source code of this file.

Generated on Fri May 30 2025 17:16:13 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: markdowns/UnifiedAccess/UDS/ReadDTCInformation_SubFunctions/ReportSeverityInformationOfDTC.md Source File

markdowns/UnifiedAccess/UDS/ReadDTCInformation_SubFunctions/ReportSeverityInformationOfDTC.md
Go to the documentation of this file.
1 # The UDS ReadDTCInformation ReportDTCSeverityInformation Subfuction ID 0x09.
2 @ingroup ua_uds_reportSeverityInformationOfDTC
3
4 You should first read through the @ref ua.<br>
5 Here additional __Tags__ of this ReadDTCInformation Subfunction can be looked up.<br>
6 The __Tags__ from @ref ua_uds_readdtcinformation and @ref ua_service_iso_tp are also supported.
7
8 #### Property __Tags__
9
10 | __Tag__ | __Default Value__ | __Type__ | __Description__ |
11 | :--: | :--: | :--: | :-- |
12 | `req_subfunction` | 9 | <span style="white-space: nowrap;">8bit Number</span> | The sub function or report type of the request. Setting this value will change the actual object type to that of the given sub function id. |
13 | `rsp_subfunction` | 9 | <span style="white-space: nowrap;">8bit Number</span> | The sub function or report type of the response. Setting this value will change the actual object type to that of the given sub function id. |
14 | `req_dtcmaskrecord` | <> | <span style="white-space: nowrap;">24bit Number</span><br>Binary | The DTC Mask Record of the Request. |
15 | `rsp_dtcstatusavailabilitymask` | <> | <span style="white-space: nowrap;">8bit Number</span> | The DTC Status Availability Mask of the Response. |
16 | `rsp_dtcandseverityrecords` | <> | Binary | The DTC And Severity Records of the Response.<br>This is a List of 6 byte blocks. The first byte is the DTC Severity value. The second byte is the DTC Functional Unit. The third, fourth and fifth byte are the DTC value(MSB first). The sixth byte is the statusOfDTC value. |
Generated on Fri May 30 2025 17:16:13 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: markdowns/UnifiedAccess/UDS/ReadDTCInformation_SubFunctions/ReportSupportedDTC.md File Reference

markdowns/UnifiedAccess/UDS/ReadDTCInformation_SubFunctions/ReportSupportedDTC.md File Reference

Go to the source code of this file.

Generated on Fri May 30 2025 17:16:13 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: markdowns/UnifiedAccess/UDS/ReadDTCInformation_SubFunctions/ReportSupportedDTC.md Source File

markdowns/UnifiedAccess/UDS/ReadDTCInformation_SubFunctions/ReportSupportedDTC.md
Go to the documentation of this file.
1 # The UDS ReadDTCInformation ReportSupportedDTC Subfuction ID 0x0A.
2 @ingroup ua_uds_reportSupportedDTC
3
4 You should first read through the @ref ua.<br>
5 Here additional __Tags__ of this ReadDTCInformation Subfunction can be looked up.<br>
6 The __Tags__ from @ref ua_uds_readdtcinformation and @ref ua_service_iso_tp are also supported.
7
8 #### Property __Tags__
9
10 | __Tag__ | __Default Value__ | __Type__ | __Description__ |
11 | :--: | :--: | :--: | :-- |
12 | `req_subfunction` | 0xA | <span style="white-space: nowrap;">8bit Number</span> | The sub function or report type of the request. Setting this value will change the actual object type to that of the given sub function id. |
13 | `rsp_subfunction` | 0xA | <span style="white-space: nowrap;">8bit Number</span> | The sub function or report type of the response. Setting this value will change the actual object type to that of the given sub function id. |
14 | `rsp_dtcstatusavailabilitymask` | <> | <span style="white-space: nowrap;">8bit Number</span> | The DTC Status Availability Mask of the Response. |
15 | `rsp_dtcandstatusrecords` | <> | Binary | The DTC And Status Records of the Response.<br>This is a List of 4 byte blocks. The first, second and third byte are the DTC value(MSB first). The fourth byte is the statusOfDTC value. |
Generated on Fri May 30 2025 17:16:13 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: markdowns/UnifiedAccess/UDS/ReadDTCInformation_SubFunctions/ReportUserDefMemoryDTCByStatusMask.md File Reference

markdowns/UnifiedAccess/UDS/ReadDTCInformation_SubFunctions/ReportUserDefMemoryDTCByStatusMask.md File Reference

Go to the source code of this file.

Generated on Fri May 30 2025 17:16:13 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: markdowns/UnifiedAccess/UDS/ReadDTCInformation_SubFunctions/ReportUserDefMemoryDTCByStatusMask.md Source File

markdowns/UnifiedAccess/UDS/ReadDTCInformation_SubFunctions/ReportUserDefMemoryDTCByStatusMask.md
Go to the documentation of this file.
1 # The UDS ReadDTCInformation ReportUserDefMemoryDTCByStatusMask Subfuction ID 0x17.
2 @ingroup ua_uds_reportUserDefMemoryDTCByStatusMask
3
4 You should first read through the @ref ua.<br>
5 Here additional __Tags__ of this ReadDTCInformation Subfunction can be looked up.<br>
6 The __Tags__ from @ref ua_uds_readdtcinformation and @ref ua_service_iso_tp are also supported.
7
8 #### Property __Tags__
9
10 | __Tag__ | __Default Value__ | __Type__ | __Description__ |
11 | :--: | :--: | :--: | :-- |
12 | `req_subfunction` | 0x17 | <span style="white-space: nowrap;">8bit Number</span> | The sub function or report type of the request. Setting this value will change the actual object type to that of the given sub function id. |
13 | `rsp_subfunction` | 0x17 | <span style="white-space: nowrap;">8bit Number</span> | The sub function or report type of the response. Setting this value will change the actual object type to that of the given sub function id. |
14 | `req_dtcstatusmask` | <> | <span style="white-space: nowrap;">8bit Number</span> | The DTC Status Mask of the Request. |
15 | `req_memoryselection` | <> | <span style="white-space: nowrap;">8bit Number</span> | The Memory Selection of the Request. |
16 | `rsp_memoryselection` | <> | <span style="white-space: nowrap;">8bit Number</span> | The Memory Selection of the Response. |
17 | `rsp_dtcstatusavailabilitymask` | <> | <span style="white-space: nowrap;">8bit Number</span> | The DTC Status Availability Mask of the Response. |
18 | `rsp_dtcandstatusrecords` | <> | Binary | The DTC And Status Records of the Response.<br>This is a List of 4 byte blocks. The first, second and third byte are the DTC value(MSB first). The fourth byte is the statusOfDTC value. |
Generated on Fri May 30 2025 17:16:13 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: markdowns/UnifiedAccess/UDS/ReadDTCInformation_SubFunctions/ReportUserDefMemoryDTCExtDataRecordByDTCNumber.md File Reference

markdowns/UnifiedAccess/UDS/ReadDTCInformation_SubFunctions/ReportUserDefMemoryDTCExtDataRecordByDTCNumber.md File Reference

Go to the source code of this file.

Generated on Fri May 30 2025 17:16:13 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: markdowns/UnifiedAccess/UDS/ReadDTCInformation_SubFunctions/ReportUserDefMemoryDTCExtDataRecordByDTCNumber.md Source File

markdowns/UnifiedAccess/UDS/ReadDTCInformation_SubFunctions/ReportUserDefMemoryDTCExtDataRecordByDTCNumber.md
Go to the documentation of this file.
1 # The UDS ReadDTCInformation ReportUserDefMemoryDTCExtDataRecordByDTCNumber Subfuction ID 0x19.
2 @ingroup ua_uds_reportUserDefMemoryDTCExtDataRecordByDTCNumber
3
4 You should first read through the @ref ua.<br>
5 Here additional __Tags__ of this ReadDTCInformation Subfunction can be looked up.<br>
6 The __Tags__ from @ref ua_uds_readdtcinformation and @ref ua_service_iso_tp are also supported.
7
8 #### Property __Tags__
9
10 | __Tag__ | __Default Value__ | __Type__ | __Description__ |
11 | :--: | :--: | :--: | :-- |
12 | `req_subfunction` | 0x19 | <span style="white-space: nowrap;">8bit Number</span> | The sub function or report type of the request. Setting this value will change the actual object type to that of the given sub function id. |
13 | `rsp_subfunction` | 0x19 | <span style="white-space: nowrap;">8bit Number</span> | The sub function or report type of the response. Setting this value will change the actual object type to that of the given sub function id. |
14 | `req_dtcmaskrecord` | <> | <span style="white-space: nowrap;">24bit Number</span><br>Binary | The DTC Mask Record of the Request. |
15 | `req_dtcextdatarecordnumber` | <> | <span style="white-space: nowrap;">8bit Number</span> | The DTC Ext Data Record Number of the Request. |
16 | `req_memoryselection` | <> | <span style="white-space: nowrap;">8bit Number</span> | The Memory Selection of the Request. |
17 | `rsp_memoryselection` | <> | <span style="white-space: nowrap;">8bit Number</span> | The Memory Selection of the Response. |
18 | `rsp_dtcandstatusrecord` | <> | <span style="white-space: nowrap;">32bit Number</span><br>Binary | The DTC And Status Record of the Response.<br>The first, second and third byte are the DTC value(MSB first). The fourth byte is the statusOfDTC value. When accessed as Number the LSB is the statusOfDTC. |
19 | `rsp_dtcextdatarecords` | <> | Binary | The DTC Extended Data Records of the Response.<br>This is a list of DataRecords. In each Record, the first byte is the DTCExtDataRecordNumber, followed by the DTCExtDataRecord data. The length of each record has to be documented by the manufacturer. |
Generated on Fri May 30 2025 17:16:13 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: markdowns/UnifiedAccess/UDS/ReadDTCInformation_SubFunctions/ReportUserDefMemoryDTCSnapshotRecordByDTCNumber.md File Reference

markdowns/UnifiedAccess/UDS/ReadDTCInformation_SubFunctions/ReportUserDefMemoryDTCSnapshotRecordByDTCNumber.md File Reference

Go to the source code of this file.

Generated on Fri May 30 2025 17:16:13 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: markdowns/UnifiedAccess/UDS/ReadDTCInformation_SubFunctions/ReportUserDefMemoryDTCSnapshotRecordByDTCNumber.md Source File

markdowns/UnifiedAccess/UDS/ReadDTCInformation_SubFunctions/ReportUserDefMemoryDTCSnapshotRecordByDTCNumber.md
Go to the documentation of this file.
1 # The UDS ReadDTCInformation ReportUserDefMemoryDTCSnapshotRecordByDTCNumber Subfuction ID 0x18.
2 @ingroup ua_uds_reportUserDefMemoryDTCSnapshotRecordByDTCNumber
3
4 You should first read through the @ref ua.<br>
5 Here additional __Tags__ of this ReadDTCInformation Subfunction can be looked up.<br>
6 The __Tags__ from @ref ua_uds_readdtcinformation and @ref ua_service_iso_tp are also supported.
7
8 #### Property __Tags__
9
10 | __Tag__ | __Default Value__ | __Type__ | __Description__ |
11 | :--: | :--: | :--: | :-- |
12 | `req_subfunction` | 0x18 | <span style="white-space: nowrap;">8bit Number</span> | The sub function or report type of the request. Setting this value will change the actual object type to that of the given sub function id. |
13 | `rsp_subfunction` | 0x18 | <span style="white-space: nowrap;">8bit Number</span> | The sub function or report type of the response. Setting this value will change the actual object type to that of the given sub function id. |
14 | `req_dtcmaskrecord` | <> | <span style="white-space: nowrap;">24bit Number</span><br>Binary | The DTC Mask Record of the Request. |
15 | `req_dtcsnapshotrecordnumber` | <> | <span style="white-space: nowrap;">8bit Number</span> | The DTC Snapshot Record Number of the Request. |
16 | `req_memoryselection` | <> | <span style="white-space: nowrap;">8bit Number</span> | The Memory Selection of the Request. |
17 | `rsp_memoryselection` | <> | <span style="white-space: nowrap;">8bit Number</span> | The Memory Selection of the Response. |
18 | `rsp_dtcandstatusrecord` | <> | <span style="white-space: nowrap;">32bit Number</span><br>Binary | The DTC And Status Record of the Response.<br>The first, second and third byte are the DTC value(MSB first). The fourth byte is the statusOfDTC value. When accessed as Number the LSB is the statusOfDTC. |
19 | `rsp_dtcsnapshotrecords` | <> | Binary | The DTC Snapshot Records of the Response.<br>The first byte of a DTC Snapshot Record is the record index.<br>The second byte of a DTC Snapshot Record is the number of identifiers in the record.<br>The actual record data starts with the third byte and is a list of 2 Bytes dataIdentfiers (MSB first) followed by the values associated with the dataIdentifier, the length of these values has to be documented in the by the manufacturer of the Device you are communicating with. |
Generated on Fri May 30 2025 17:16:13 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: markdowns/UnifiedAccess/UDS/ReadDTCInformation_SubFunctions/ReportWWHOBDDTCByMaskRecord.md File Reference

markdowns/UnifiedAccess/UDS/ReadDTCInformation_SubFunctions/ReportWWHOBDDTCByMaskRecord.md File Reference

Go to the source code of this file.

Generated on Fri May 30 2025 17:16:13 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: markdowns/UnifiedAccess/UDS/ReadDTCInformation_SubFunctions/ReportWWHOBDDTCByMaskRecord.md Source File

markdowns/UnifiedAccess/UDS/ReadDTCInformation_SubFunctions/ReportWWHOBDDTCByMaskRecord.md
Go to the documentation of this file.
1 # The UDS ReadDTCInformation ReportWWHOBDDTCByMaskRecord Subfuction ID 0x42.
2 @ingroup ua_uds_reportWWHOBDDTCByMaskRecord
3
4 You should first read through the @ref ua.<br>
5 Here additional __Tags__ of this ReadDTCInformation Subfunction can be looked up.<br>
6 The __Tags__ from @ref ua_uds_readdtcinformation and @ref ua_service_iso_tp are also supported.
7
8 #### Property __Tags__
9
10 | __Tag__ | __Default Value__ | __Type__ | __Description__ |
11 | :--: | :--: | :--: | :-- |
12 | `req_subfunction` | 0x42 | <span style="white-space: nowrap;">8bit Number</span> | The sub function or report type of the request. Setting this value will change the actual object type to that of the given sub function id. |
13 | `rsp_subfunction` | 0x42 | <span style="white-space: nowrap;">8bit Number</span> | The sub function or report type of the response. Setting this value will change the actual object type to that of the given sub function id. |
14 | `req_functionalgroupidentifier` | <> | <span style="white-space: nowrap;">8bit Number</span> | The Functional Group Identifier of the Request. |
15 | `req_dtcseveritymaskrecord` | <> | Binary | The DTC Severity Mask Record of the Request. |
16 | `rsp_functionalgroupidentifier` | <> | <span style="white-space: nowrap;">8bit Number</span> | The Functional Group Identifier of the Response. |
17 | `rsp_dtcstatusavailabilitymask` | <> | <span style="white-space: nowrap;">8bit Number</span> | The DTC Status Availability Mask of the Response. |
18 | `rsp_dtcseverityavailabilitymask` | <> | <span style="white-space: nowrap;">8bit Number</span> | The DTC Severity Availability Mask of the Response. |
19 | `rsp_dtcformatidentifier` | <> | <span style="white-space: nowrap;">8bit Number</span> | The DTC Format Identifier of the Response. |
20 | `rsp_dtcandseverityrecords` | <> | Binary | The DTC And Severity Record of the Response.<br>This is a List of 5 byte blocks. The first byte is the DTC Severity. The second, third and fourth byte are the DTC value(MSB first). The fifth byte is the statusOfDTC value. |
Generated on Fri May 30 2025 17:16:13 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: markdowns/UnifiedAccess/UDS/ReadDTCInformation_SubFunctions/ReportWWHOBDDTCWithPermanentStatus.md File Reference

markdowns/UnifiedAccess/UDS/ReadDTCInformation_SubFunctions/ReportWWHOBDDTCWithPermanentStatus.md File Reference

Go to the source code of this file.

Generated on Fri May 30 2025 17:16:13 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: markdowns/UnifiedAccess/UDS/ReadDTCInformation_SubFunctions/ReportWWHOBDDTCWithPermanentStatus.md Source File

markdowns/UnifiedAccess/UDS/ReadDTCInformation_SubFunctions/ReportWWHOBDDTCWithPermanentStatus.md
Go to the documentation of this file.
1 # The UDS ReadDTCInformation ReportWWHOBDDTCWithPermanentStatus Subfuction ID 0x55.
2 @ingroup ua_uds_reportWWHOBDDTCWithPermanentStatus
3
4
5 You should first read through the @ref ua.<br>
6 Here additional __Tags__ of this ReadDTCInformation Subfunction can be looked up.<br>
7 The __Tags__ from @ref ua_uds_readdtcinformation and @ref ua_service_iso_tp are also supported.
8
9 #### Property __Tags__
10
11 | __Tag__ | __Default Value__ | __Type__ | __Description__ |
12 | :--: | :--: | :--: | :-- |
13 | `req_subfunction` | 0x55 | <span style="white-space: nowrap;">8bit Number</span> | The sub function or report type of the request. Setting this value will change the actual object type to that of the given sub function id. |
14 | `rsp_subfunction` | 0x55 | <span style="white-space: nowrap;">8bit Number</span> | The sub function or report type of the response. Setting this value will change the actual object type to that of the given sub function id. |
15 | `req_functionalgroupidentifier` | <> | <span style="white-space: nowrap;">8bit Number</span> | The Functional Group Identifier of the Request. |
16 | `rsp_functionalgroupidentifier` | <> | <span style="white-space: nowrap;">8bit Number</span> | The Functional Group Identifier of the Response. |
17 | `rsp_dtcstatusavailabilitymask` | <> | <span style="white-space: nowrap;">8bit Number</span> | The DTC Status Availability Mask of the Response. |
18 | `rsp_dtcformatidentifier` | <> | <span style="white-space: nowrap;">8bit Number</span> | The DTC Format Identifier of the Response. |
19 | `rsp_dtcandstatusrecords` | <> | Binary | The DTC And Status Records of the Response.<br>This is a List of 4 byte blocks. The first, second and third byte are the DTC value(MSB first). The fourth byte is the statusOfDTC value. |
Generated on Fri May 30 2025 17:16:13 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: C:/JenkinsWS/workspace/orks_v2_LinWorksv2_Windows_trunk/source/externals/BabyLIN/src/libraries/BabyLIN/publicHeaders/SDF.h File Reference

  • externals
  • BabyLIN
  • src
  • libraries
  • BabyLIN
  • publicHeaders
Data Structures | Macros | Typedefs | Functions
SDF.h File Reference
#include "BabyLINReturncodes.h"

Go to the source code of this file.

Data Structures

struct SDF_SECTIONINFO

Macros

#define | SDF_OK 0
#define | SDF_HANDLE_INVALID -100024
#define | SDF_IN_USE -100025

Typedefs

typedef void * SDF_HANDLE

Functions

SDF_HANDLE BL_DLLIMPORT | SDF_open (const char *filename)
Loads a SDFile to memory and returns a SDF_HANDLE. More...
SDF_HANDLE BL_DLLIMPORT | SDF_openLDF (const char *filename)
Loads a LDFFile to memory, creates a temporary SDF and returns a SDF_HANDLE. More...
int BL_DLLIMPORT | SDF_close (SDF_HANDLE handle)
Closes a SDFile opened using SDF_open. More...
int BL_DLLIMPORT | SDF_hasMacroCommandOverwriteEnabled (SDF_HANDLE sdfhandle)
Returns whether the command overwriting feature for macro names is enabled. More...
int BL_DLLIMPORT | SDF_downloadToDevice (SDF_HANDLE sdfhandle, BL_HANDLE blhandle, int mode)
Download a SDFile to a BabyLIN device. More...
int BL_DLLIMPORT | SDF_downloadSectionToChannel (SDF_HANDLE sectionhandle, BL_HANDLE channelhandle)
Download a SDFile to a BabyLIN device. More...
int BL_DLLIMPORT | SDF_getSectionCount (SDF_HANDLE sdfhandle)
Get number of sections in SDF. More...
SDF_HANDLE BL_DLLIMPORT | SDF_getSectionHandle (SDF_HANDLE handle, int sectionNr)
Get handle to a section of a sdf. More...
int BL_DLLIMPORT | SDF_getSectionInfo (SDF_HANDLE handle, SDF_SECTIONINFO *info)
Get information about a section. More...
Generated on Fri May 30 2025 17:16:13 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: C:/JenkinsWS/workspace/orks_v2_LinWorksv2_Windows_trunk/source/externals/BabyLIN/src/libraries/BabyLIN/publicHeaders/SDF.h Source File

  • externals
  • BabyLIN
  • src
  • libraries
  • BabyLIN
  • publicHeaders
SDF.h
Go to the documentation of this file.
1 #ifndef SDF_H
2 #define SDF_H
3
4 #include "BabyLINReturncodes.h"
5
6 typedef struct {
7 int sectionNr;
8 // ! Sectiontype (i.e. 0 = LIN, 1 = CAN, 99 = DEVICE)
9 int type;
10 char name[64];
11 char description[4096];
12 } SDF_SECTIONINFO;
13
14 #if defined(__cplusplus)
15 extern "C" {
16 #endif
17
31 #define SDF_OK 0
32 #define SDF_HANDLE_INVALID -100024
33 #define SDF_IN_USE -100025
34
35 typedef void* SDF_HANDLE;
36
44 SDF_HANDLE BL_DLLIMPORT SDF_open(const char* filename);
45
53 SDF_HANDLE BL_DLLIMPORT SDF_openLDF(const char* filename);
54
60 int BL_DLLIMPORT SDF_close(SDF_HANDLE handle);
61
70 int BL_DLLIMPORT SDF_hasMacroCommandOverwriteEnabled(SDF_HANDLE sdfhandle);
71
80 int BL_DLLIMPORT SDF_downloadToDevice(SDF_HANDLE sdfhandle, BL_HANDLE blhandle, int mode);
81
89 int BL_DLLIMPORT SDF_downloadSectionToChannel(SDF_HANDLE sectionhandle, BL_HANDLE channelhandle);
90
97 int BL_DLLIMPORT SDF_getSectionCount(SDF_HANDLE sdfhandle);
98
105 SDF_HANDLE BL_DLLIMPORT SDF_getSectionHandle(SDF_HANDLE handle, int sectionNr);
106
113 int BL_DLLIMPORT SDF_getSectionInfo(SDF_HANDLE handle, SDF_SECTIONINFO* info);
116 #if defined(__cplusplus)
117 } // extern "C"
118 #endif
119
120 #endif // SDF_H
SDF_downloadToDevice
int BL_DLLIMPORT SDF_downloadToDevice(SDF_HANDLE sdfhandle, BL_HANDLE blhandle, int mode)
Download a SDFile to a BabyLIN device.
SDF_getSectionInfo
int BL_DLLIMPORT SDF_getSectionInfo(SDF_HANDLE handle, SDF_SECTIONINFO *info)
Get information about a section.
SDF_SECTIONINFO::type
int type
Definition: SDF.h:9
SDF_SECTIONINFO
Definition: SDF.h:6
BL_HANDLE
void * BL_HANDLE
Definition: BabyLINReturncodes.h:34
SDF_openLDF
SDF_HANDLE BL_DLLIMPORT SDF_openLDF(const char *filename)
Loads a LDFFile to memory, creates a temporary SDF and returns a SDF_HANDLE.
SDF_getSectionCount
int BL_DLLIMPORT SDF_getSectionCount(SDF_HANDLE sdfhandle)
Get number of sections in SDF.
SDF_close
int BL_DLLIMPORT SDF_close(SDF_HANDLE handle)
Closes a SDFile opened using SDF_open.
SDF_open
SDF_HANDLE BL_DLLIMPORT SDF_open(const char *filename)
Loads a SDFile to memory and returns a SDF_HANDLE.
BL_DLLIMPORT
#define BL_DLLIMPORT
Definition: BabyLINReturncodes.h:9
BabyLINReturncodes.h
SDF_HANDLE
void * SDF_HANDLE
Definition: SDF.h:35
SDF_SECTIONINFO::sectionNr
int sectionNr
Definition: SDF.h:7
SDF_downloadSectionToChannel
int BL_DLLIMPORT SDF_downloadSectionToChannel(SDF_HANDLE sectionhandle, BL_HANDLE channelhandle)
Download a SDFile to a BabyLIN device.
SDF_getSectionHandle
SDF_HANDLE BL_DLLIMPORT SDF_getSectionHandle(SDF_HANDLE handle, int sectionNr)
Get handle to a section of a sdf.
SDF_hasMacroCommandOverwriteEnabled
int BL_DLLIMPORT SDF_hasMacroCommandOverwriteEnabled(SDF_HANDLE sdfhandle)
Returns whether the command overwriting feature for macro names is enabled.
Generated on Fri May 30 2025 17:16:13 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: markdowns/UnifiedAccess/SDF/SDF.md File Reference

markdowns/UnifiedAccess/SDF/SDF.md File Reference

Go to the source code of this file.

Generated on Fri May 30 2025 17:16:13 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: markdowns/UnifiedAccess/SDF/SDF.md Source File

markdowns/UnifiedAccess/SDF/SDF.md
Go to the documentation of this file.
1 # The Session Description File
2 @ingroup ua_sdf
3
4 You should first read through the @ref ua.<br/>
5 Here all available __Tags__ of a Session Description File can be looked up.
6
7 #### Child __Tags__
8
9 | __Tag__ | __Type__ | __Description__ |
10 | :--: | :--: | :-- |
11 | `section` | <span style="white-space: nowrap;">32bit Number</span><br>String | find a @ref ua_section by index or name. |
12
13 #### Property __Tags__
14
15 | __Tag__ | Default Value | __Type__ | __Description__ |
16 | :--: | :--: | :--: | :-- |
17 | `name` | <> | String | The name, of the SDF file. |
18 | `sdf_version` | <> | 32bit Number | The minimal SDF version, that is required by this SDF File. |
19 | `section_count` | <> | <span style="white-space: nowrap;">32bit Number</span> | The amount of available [Sections](@ref ua_section) in this Session Description File. |
Generated on Fri May 30 2025 17:16:12 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: markdowns/SdfBasedLogging.md File Reference

markdowns/SdfBasedLogging.md File Reference

Go to the source code of this file.

Generated on Fri May 30 2025 17:16:13 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: markdowns/SdfBasedLogging.md Source File

markdowns/SdfBasedLogging.md
Go to the documentation of this file.
1 # SDF based logging
2 @ingroup sdfbasedlogging
3
4 # Introduction
5
6 A lot of application have the requirement for the creation of log files.
7
8 Typical information included in these log files are:
9
10 * Bus communication
11 * Processed data, like e.g. serial numbers read using protocol services
12 * Application status information
13
14 The content, that needs to be logged, may also vary depending on the application status and progress.
15
16 Therefor the best way to create log files is by configuring and controlling them from within a SDF.
17
18 # Availability
19
20 The SDF based logging is available in the following setups:
21
22 <table class="doxtable">
23 <tr>
24 <th>Baby-LIN device</th>
25 <th>Mode</th>
26 <th>Baby-LIN library application</th>
27 <th>Target folder for log files</th>
28 </tr>
29 <tr>
30 <td colspan="2">Baby-LIN-II</td>
31 <td rowspan="5">SimpleMenu</td>
32 <td rowspan="5"><i>My documents</i> \\Lipowsky Industrie-Elektronik GmbH\\Logs\\ </td>
33 </tr>
34 <tr>
35 <td colspan="2">Baby-LIN-RC-II</td>
36 </tr>
37 <tr>
38 <td colspan="2">Baby-LIN-RM-II</td>
39 </tr>
40 <tr>
41 <td>HARP-4/5</td>
42 <td>PC mode</td>
43 </tr>
44 <tr>
45 <td>Baby-LIN-MB-II</td>
46 <td>SimpleMenu mode</td>
47 </tr>
48 <tr>
49 <td>Baby-LIN-MB-II</td>
50 <td>Stand-Alone mode</td>
51 <td>The Baby-LIN-MB-II firmware</td>
52 <td><i>SD card</i></td>
53 </tr>
54 </table>
55
56 # Control by print macro commands
57
58 To control the log mechanism, print macro commands are used.
59
60 They allow to define a formatted string and use signals as replacement.
61
62 All log commands must apply to these conditions:
63 * "Debug report" must be chosen as target.
64 * The print text must start with a "[LOG]" prefix.
65
66 # Feedback from log commands
67
68 The print commands create reports, that are parsed and processed by the BabyLIN library.
69
70 If a log command is not valid or can not be executed, an error report is created.
71
72 Therefor it is not possible, to verify within the SDF, if the log command was executed successfully.
73
74 If you want to implement the SDF based logging, please verify that no log commands triggers an error report by using the SimpleMenu for the development.
75
76 # Log configuration
77
78 The SDF based logging uses internally the same mechanisms as the @ref ua_logfile available using the UniversalAccess API.
79
80 All configuration properties available for the @ref ua_logfile, can also be used for the SDF based logging.
81
82 # Log commands
83
84 The following commands are available to control the log file creation, configuration, writing and so on.
85
86 <table class="doxtable">
87 <tr>
88 <th>Command with parameter</th>
89 <th>Description</th>
90 <th>Parameter description</th>
91 </tr>
92 <tr>
93 <td>create *[handle]*</td>
94 <td>
95 This command creates a new log file object.<br>
96 The new object has a default configuration.</td>
97 <td>
98 *handle* (Optional parameter)<br>
99 The handle is an integer identifying a log file object.<br>
100 Default: The source channel of the log command.</td>
101 </tr>
102 <tr>
103 <td>assign *[mode]* *[channel]* *[handle]*</td>
104 <td>
105 This command assigns a channel to or unassign a channel from the log file object.<br>
106 If assigned, the log file object will register all necessary channel callbacks.<br>
107 If unassigned, the log file object will unregister all registered channel callbacks.<br>
108 The assign method must be recalled, if a SDF file was loaded.</td>
109 <td>
110 *mode* (Optional parameter)<br>
111 Possible values: 0: Unassign, 1: Assign<br>
112 Default: Assign<br>
113 <br>
114 *channel* (Optional parameter)<br>
115 The parameter identifies a channel using the channel index.<br>
116 Default: The source channel of the log command.<br>
117 <br>
118 *handle* (Optional parameter)<br>
119 The handle is an integer identifying a log file object.<br>
120 Default: The source channel of the log command.</td>
121 </tr>
122 <tr>
123 <td>config *key* *value* *[handle]*</td>
124 <td>
125 This command sets a single configuration property.<br>
126 The configuration must be done, before a "start" or "write" command is send.</td>
127 <td>
128 *key* (Mandatory parameter)<br>
129 The key name of the property, e.g. "log_format".<br>
130 <br>
131 *value* (Mandatory parameter)<br>
132 The new value of the property.<br>
133 <br>
134 *handle* (Optional parameter)<br>
135 The handle is an integer identifying a log file object.<br>
136 Default: The source channel of the log command.</td>
137 </tr>
138 <tr>
139 <td>start *[handle]*</td>
140 <td>
141 This command starts the storing of the received reports in the memory.<br>
142 The stored reports are only written into a physical log file, if the write command is executed before the log file object is closed.</td>
143 <td>
144 *handle* (Optional parameter)<br>
145 The handle is an integer identifying a log file object.<br>
146 Default: The source channel of the log command.</td>
147 </tr>
148 <tr>
149 <td>stop *[handle]*</td>
150 <td>
151 This command stops the storing of the received reports in the memory.<br>
152 The stored reports are only written into a physical log file, if the write command is executed before the log file object is closed.</td>
153 <td>
154 *handle* (Optional parameter)<br>
155 The handle is an integer identifying a log file object.<br>
156 Default: The source channel of the log command.</td>
157 </tr>
158 <tr>
159 <td>write *[filename]* *[handle]*</td>
160 <td>
161 The write command triggers the creation of a physical log file.<br>
162 All stored reports in the memory will be written to the log file, even if the log file object is closed in the meantime.<br>
163 Without this command, no physical log file will be created.</td>
164 <td>
165 *filename* (Optional parameter)<br>
166 The explicit filename used for the physical log file.<br>
167 Default: The filename will be created automatically based on the configuration properties.<br>
168 <br>
169 *handle* (Optional parameter)<br>
170 The handle is an integer identifying a log file object.<br>
171 Default: The source channel of the log command.</td>
172 </tr>
173 <tr>
174 <td>close *[handle]*</td>
175 <td>
176 This command closes the log file object.<br>
177 If the writing has been triggered, all stored reports in memory will be written to the physical file.<br>
178 If no writing has been triggered, all stored reports will be discarded. No physical log file will be written.</td>
179 <td>
180 *handle* (Optional parameter)<br>
181 The handle is an integer identifying a log file object.<br>
182 Default: The source channel of the log command.</td>
183 </tr>
184 </table>
185
186 # Example
187
188
189 <table class="doxtable">
190 <tr>
191 <th>Print command content</th>
192 <th>Description</th>
193 </tr>
194 <tr>
195 <td>[LOG]create</td>
196 <td>
197 This command creates a log file object.<br>
198 Since no handle is passed, it is implicitly created with a channel specific handle.
199 </td>
200 </tr>
201 <tr>
202 <td>[LOG]assign 1</td>
203 <td>
204 This command assigns the the channel, which executes the section with this macro command to the log file.<br>
205 All reports, that are enabled, will be added to the log file, after the start command.
206 </td>
207 </tr>
208 <tr>
209 <td>[LOG]config enable_frames 1</td>
210 <td>Configure the log file object properties: Enable frame reports.</td>
211 </tr>
212 <tr>
213 <td>[LOG]config enable_errors 1</td>
214 <td>Configure the log file object properties: Enable error reports.</td>
215 </tr>
216 <tr>
217 <td>[LOG]config enable_events 1</td>
218 <td>Configure the log file object properties: Enable event reports.</td>
219 </tr>
220 <tr>
221 <td>[LOG]config enable_debug 1</td>
222 <td>Configure the log file object properties: Enable debug reports.</td>
223 </tr>
224 <tr>
225 <td>[LOG]start</td>
226 <td>
227 Start the saving of reports within the log file object.<br>
228 From now on, received reports will be saved, if the report type was enabled in the configuration.
229 </td>
230 </tr>
231 <tr>
232 <td>[LOG]write</td>
233 <td>
234 This commands triggers the writing of saved reports to a physical file.<br>
235 All reports saved until now will be written as well as all future reports.<br>
236 The name of the physical log file will be created using the configuration "file_prefix", "file_postfix" and "file_extension".</td>
237 </tr>
238 <tr>
239 <td>[LOG]stop</td>
240 <td>
241 Stop the saving of reports within the log file.<br>
242 From now on, no received reports will be saved, until a "start" command is send again.
243 </td>
244 </tr>
245 <tr>
246 <td>[LOG]close</td>
247 <td>
248 The log file object is closed<br>
249 If a "write" command was sent, all saved reports will be written.<br>
250 If no "write" command was sent, the saved reports will be discarded.
251 </td>
252 </tr>
253 </table>
Generated on Fri May 30 2025 17:16:12 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: markdowns/SdfScript/Channel.md File Reference

markdowns/SdfScript/Channel.md File Reference

Go to the source code of this file.

Generated on Fri May 30 2025 17:16:13 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: markdowns/SdfScript/Channel.md Source File

markdowns/SdfScript/Channel.md
Go to the documentation of this file.
1 @ingroup script_sdf_obj_channel
2
3 ## Description
4 An object represeting a channel on the device.<br>
5 This object is mainly used in the "OnDownloadSection_[...]" functions as argument.<br>
6 You can call several functions on this object to interact with the device or the binary SDF.<br>
7 <br>
8 All functions are callable like this:<br>
9 ~~~~~~~~~~~~~~~{.py}
10 function OnDownloadSection_1(channel)
11 -- 'channel' is the name of an object of the type 'Channel'
12 -- You call functions with the syntax 'variable_name:function_name'
13 local channel_id = channel:GetId()
14 end
15 ~~~~~~~~~~~~~~~
16
17 # Available Functions
18
19 ## Channel:GetId()
20 Returns the device index of the channel.<br>
21 Needs no arguments.<br>
22 The function returns a single number typed value for the index.<br>
23 <br>
24 <b>Syntax</b>:
25 ~~~~~~~~~~~~~~~{.py}
26 index = Channel:GetId()
27 ~~~~~~~~~~~~~~~
28 <br>
29 <b>Examples</b>:
30 ~~~~~~~~~~~~~~~{.py}
31 local channel_id = channel:GetId()
32 print('Channel ID: ', channel_id)
33 ~~~~~~~~~~~~~~~
34
35 ## Channel:GetHandle()
36 Returns the handle to the channel. This value is the same as a @ref BLC_openPort would return.<br>
37 <i>Note</i>: Each reload of the script SDF, as well as each call to @ref BLC_openPort may result in different values for the handle refering to this channel.<br>
38 During runtime, this value is garantueed to not change until the device is closed.<br>
39 Needs no arguments.<br>
40 The function returns a single number typed value for the index.<br>
41 <br>
42 <b>Syntax</b>:
43 ~~~~~~~~~~~~~~~{.py}
44 handle = Channel:GetHandle()
45 ~~~~~~~~~~~~~~~
46 <br>
47 <b>Examples</b>:
48 ~~~~~~~~~~~~~~~{.py}
49 local channel_handle = channel:GetHandle()
50 print('Channel handle: ', channel_handle)
51 ~~~~~~~~~~~~~~~
52
53 ## Channel:GetName()
54 Returns the name of the channel.<br>
55 Needs no arguments.<br>
56 The function returns a single string typed value for the name.<br>
57 <br>
58 <b>Syntax</b>:
59 ~~~~~~~~~~~~~~~{.py}
60 name = Channel:GetName()
61 ~~~~~~~~~~~~~~~
62 <br>
63 <b>Examples</b>:
64 ~~~~~~~~~~~~~~~{.py}
65 local channel_name = channel:GetName()
66 print('Channel name: ', channel_name)
67 ~~~~~~~~~~~~~~~
68
69 ## Channel:GetType()
70 Returns the type of the channel.<br>
71 Needs no arguments.<br>
72 The function returns a number typed value for the type.<br>
73 ChannelType is defined as: <br>
74 ~~~~~~~~~~~~~~~{.py}
75 ChannelType = {DEVICE = 0, LIN = 1, CAN_LS = 2, CAN_HS = 3, CAN_FD = 4}
76 ~~~~~~~~~~~~~~~
77 You can directly use these values, please do <b>not</b> use the number values directly!
78 <br>
79 <b>Syntax</b>:
80 ~~~~~~~~~~~~~~~{.py}
81 type = Channel:GetType()
82 ~~~~~~~~~~~~~~~
83 <br>
84 <b>Examples</b>:
85 ~~~~~~~~~~~~~~~{.py}
86 local channel_type = channel:GetType()
87 if(channel_type == ChannelType.CAN_LS) then
88 print("This is only printed if the channel is CAN lowspeed!")
89 end
90 ~~~~~~~~~~~~~~~
91
92 ## Channel:GetMaximumBaudrate()
93 Returns the maximum bus speed the channel supports.<br>
94 Needs no arguments.<br>
95 The function returns a single number typed value for the speed.<br>
96 <br>
97 <b>Syntax</b>:
98 ~~~~~~~~~~~~~~~{.py}
99 max_speed = Channel:GetMaximumBaudrate()
100 ~~~~~~~~~~~~~~~
101 <br>
102 <b>Examples</b>:
103 ~~~~~~~~~~~~~~~{.py}
104 local max_speed = channel:GetMaximumBaudrate()
105 print('Channel maximum speed: ', max_speed)
106 ~~~~~~~~~~~~~~~
107
108 ## Channel:IsDisabled()
109 Returns the activation state of the channel.<br>
110 <i>Note</i>: This value is <b>always</b> true when called on a channel object from a 'OnDownloadSection_[...]' function.
111 Needs no arguments.<br>
112 The function returns a single boolean typed value for the activation state.<br>
113 <br>
114 <b>Syntax</b>:
115 ~~~~~~~~~~~~~~~{.py}
116 is_disabled = Channel:IsDisabled()
117 ~~~~~~~~~~~~~~~
118 <br>
119 <b>Examples</b>:
120 ~~~~~~~~~~~~~~~{.py}
121 local channel_disabled = channel:IsDisabled()
122 print('Channel is disabled: ', channel_disabled)
123 ~~~~~~~~~~~~~~~
124
125 ## Channel:HasSDFv3Support()
126 Returns whether the channel supports version 3 SDFs.<br>
127 Needs no arguments.<br>
128 The function returns a single boolean typed value for the state.<br>
129 <br>
130 <b>Syntax</b>:
131 ~~~~~~~~~~~~~~~{.py}
132 supports_v3 = Channel:HasSDFv3Support()
133 ~~~~~~~~~~~~~~~
134 <br>
135 <b>Examples</b>:
136 ~~~~~~~~~~~~~~~{.py}
137 local channel_support_sdfv3 = channel:HasSDFv3Support()
138 print('Channel supports SDFv3: ', channel_support_sdfv3)
139 ~~~~~~~~~~~~~~~
140
141 ## Channel:ExecuteMacro()
142 Executes a macro on the device.<br>
143 Requires the macro identifier as argument.<br>
144 Optionally you can also set the timeout (in milliseconds) and macro parameters as arguments.<br>
145 <br>
146 The macro identifier can be a number value, representing a macro index, or a string value representing the macro name.<br>
147 <b>Note</b>: When using a string for the macro name, make sure the SDF macro names are unique. <br>The first found macro with a matching name will be executed if there are several identically named macros.
148 <br>
149 The macro parameters have to be a table value.<br>
150 The timeout has to be a number value.<br>
151 <br>
152 The function will return both the macro return code as a number value, as well as the macro result string as a string value.<br>
153 <br>
154 <b>Syntax</b>:
155 ~~~~~~~~~~~~~~~{.py}
156 macro_ret_code, macro_result_str = Channel:ExecuteMacro(macro, [arguments], [timeout])
157 ~~~~~~~~~~~~~~~
158 <br>
159 <b>Examples</b>:
160 ~~~~~~~~~~~~~~~{.py}
161 -- Executes the macro with id '0'
162 local macro_ret_code, macro_result_str = channel:ExecuteMacro(0)
163
164 -- Executes the first macro with the name 'ExampleMacro'
165 local macro_ret_code, macro_result_str = channel:ExecuteMacro('ExampleMacro')
166
167 -- Executes the macro with id '0' with a timeout of 500 milliseconds
168 local macro_ret_code, macro_result_str = channel:ExecuteMacro(0, 500)
169
170 -- Executes the macro with id '0' with a list of parameters
171 local macro_ret_code, macro_result_str = channel:ExecuteMacro(0, {1,2,3,4})
172
173 -- Executes the macro with id '0' with a list of parameters and a timeout of 500 milliseconds
174 local macro_ret_code, macro_result_str = channel:ExecuteMacro(0, {1,2,3,4}, 500)
175
176 -- The parameter list and the timeout can also be switched in place
177 local macro_ret_code, macro_result_str = channel:ExecuteMacro(0, 500, {1,2,3,4})
178 ~~~~~~~~~~~~~~~
179
180 ## Channel:GetTableCount()
181 Returns the number of Tables in the section that is loaded onto this channel.<br>
182 Needs no arguments.<br>
183 The function returns a single number typed value for the count.<br>
184 <br>
185 <b>Syntax</b>:
186 ~~~~~~~~~~~~~~~{.py}
187 table_count = Channel:GetTableCount()
188 ~~~~~~~~~~~~~~~
189 <br>
190 <b>Examples</b>:
191 ~~~~~~~~~~~~~~~{.py}
192 local table_count = channel:GetTableCount()
193 print("This SDF has "..table_count.. " tables.")
194 ~~~~~~~~~~~~~~~
195
196 ## Channel:GetTable()
197 Returns a table object for the index in this channel.<br>
198 Requires a number valued table index as argument. This value is the same as in the SDF.<br>
199 The function returns a single '@ref script_sdf_obj_table' typed object.<br>
200 <br>
201 See @ref script_sdf_obj_table to see what you can do with a '@ref script_sdf_obj_table' object.
202 <br>
203 <b>Syntax</b>:
204 ~~~~~~~~~~~~~~~{.py}
205 table = Channel:GetTable(index)
206 ~~~~~~~~~~~~~~~
207 <br>
208 <b>Examples</b>:
209 ~~~~~~~~~~~~~~~{.py}
210 -- 'tbl' is now an object referencing the SDF table with index 0.
211 local tbl = channel:GetTable(0)
212 ~~~~~~~~~~~~~~~
BLC_openPort
BL_HANDLE BL_DLLIMPORT BLC_openPort(BLC_PORTINFO portInfo)
Open a connection to a BabyLIN device using BLC_PORTINFO information.
Generated on Fri May 30 2025 17:16:12 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: markdowns/UnifiedAccess/SDF/Section.md File Reference

markdowns/UnifiedAccess/SDF/Section.md File Reference

Go to the source code of this file.

Generated on Fri May 30 2025 17:16:13 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: markdowns/UnifiedAccess/SDF/Section.md Source File

markdowns/UnifiedAccess/SDF/Section.md
Go to the documentation of this file.
1 # The Section
2 @ingroup ua_section
3
4 You should first read through the @ref ua.<br/>
5 Here all available __Tags__ of a Section can be looked up.
6
7 #### Child __Tags__
8
9 | __Tag__ | __Type__ | __Description__ |
10 | :--: | :--: | :-- |
11 | `signal` | <span style="white-space: nowrap;">32bit Number</span><br>String | find a @ref ua_sdf_signal by index or name. |
12 | `frame` | <span style="white-space: nowrap;">32bit Number</span><br>String | find a @ref ua_sdf_frame by index or name. |
13 | `node` | <span style="white-space: nowrap;">32bit Number</span><br>String | find a @ref ua_sdf_node by index or name. |
14 | `macro` | <span style="white-space: nowrap;">32bit Number</span><br>String | find a @ref ua_sdf_macro by index or name. |
15
16 #### Property __Tags__
17
18 | __Tag__ | Default Value | __Type__ | __Description__ |
19 | :--: | :--: | :--: | :-- |
20 | `name` | <> | String | The name, of the Section. |
21 | `index` | <> | <span style="white-space: nowrap;">32bit Number</span> | The Section's index in the @ref ua_sdf 's `section` list. |
22 | `type` | <> | <span style="white-space: nowrap;">32bit Number</span> | The Section type:<br>0 for LIN Sections<br>1 for CAN Sections<br>99 for Device Sections |
23 | `speed` | <> | <span style="white-space: nowrap;">32bit Number</span> | The bus speed configured in this Section. |
24 | `sdf_version` | <> | 32bit Number | The minimal SDF version, that is required by this section. |
25 | `max_baudrate_required` | <> | <span style="white-space: nowrap;">32bit Number</span>| The maximal baudrate a @ref ua_channel has to support to load this section. |
26 | `signal_count` | <> | <span style="white-space: nowrap;">32bit Number</span> | The amount of available [Signals](@ref ua_sdf_signal) in this Section. |
27 | `frame_count` | <> | <span style="white-space: nowrap;">32bit Number</span> | The amount of available [Frames](@ref ua_sdf_frame) in this Section. |
28 | `node_count` | <> | <span style="white-space: nowrap;">32bit Number</span> | The amount of available [Nodes](@ref ua_sdf_node) in this Section. |
29 | `macro_count` | <> | <span style="white-space: nowrap;">32bit Number</span> | The amount of available [Macros](@ref ua_sdf_macro) in this Section. |
Generated on Fri May 30 2025 17:16:12 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: markdowns/UnifiedAccess/SDF/Signal.md File Reference

markdowns/UnifiedAccess/SDF/Signal.md File Reference

Go to the source code of this file.

Generated on Fri May 30 2025 17:16:13 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: markdowns/UnifiedAccess/SDF/Signal.md Source File

markdowns/UnifiedAccess/SDF/Signal.md
Go to the documentation of this file.
1 # The SDF Signal
2 @ingroup ua_sdf_signal
3
4 You should first read through the @ref ua.<br/>
5 Here all available __Tags__ of a Signal can be looked up.
6
7 #### Child __Tags__
8
9 | __Tag__ | __Type__ | __Description__ |
10 | :--: | :--: | :-- |
11 | `encoding_type` | void | return the associated @ref ua_encoding_type. |
12 | `mapping` | <span style="white-space: nowrap;">32bit Number</span> | return the associated @ref ua_sdf_mapping. |
13
14 #### Property __Tags__
15
16 | __Tag__ | Default Value | __Type__ | __Description__ |
17 | :--: | :--: | :--: | :-- |
18 | `name` | <> | String | The name, of the Signal. |
19 | `index` | <> | <span style="white-space: nowrap;">32bit Number</span> | The signal's index in the @ref ua_section 's `signal` list. |
20 | `length` | <> | <span style="white-space: nowrap;">32bit Number</span> | The signal's length in bits. |
21 | `signed` | <> | Boolean | True if the signal is handled as a signed Number. |
22 | `initialvalue` | <> | <span style="white-space: nowrap;">64bit Number</span> | The signal's initial value. |
23 | `resetonbus` | <> | Boolean | True if the signal is reset to the `initialvalue` when a "Bus Start" is executed. |
24 | `emulated` | <> | Boolean | True if the signal is emulated. |
25 | `virtual` | <> | Boolean | True if the signal is a virtual signal. |
26 | `mapping_count` | <> | <span style="white-space: nowrap;">32bit Number</span> | The amount of available [Frame Mappings](@ref ua_sdf_mapping) for this signal. |
27
Generated on Fri May 30 2025 17:16:12 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: markdowns/SdfScript/Sleep.md File Reference

markdowns/SdfScript/Sleep.md File Reference

Go to the source code of this file.

Generated on Fri May 30 2025 17:16:13 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: markdowns/SdfScript/Sleep.md Source File

markdowns/SdfScript/Sleep.md
Go to the documentation of this file.
1 @ingroup script_sdf_func_sleep
2
3 ## Description
4 Stops the execution of the script for the given amount of time.<br>
5 It accepts a single number typed argument, which represents the time to sleep in milliseconds.<br>
6 The function does not return anything.<br>
7 <br>
8 <b>Syntax</b>:
9 ~~~~~~~~~~~~~~~{.py}
10 sleep(time_ms)
11 ~~~~~~~~~~~~~~~
12
13 ## Examples
14 ~~~~~~~~~~~~~~~{.py}
15 -- Sleep for 100ms
16 Sleep(100)
17
18 -- Sleep for 1 second
19 Sleep(10*100)
20
21 -- Sleep a variable time
22 Sleep(variable_name)
23 ~~~~~~~~~~~~~~~
Generated on Fri May 30 2025 17:16:12 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: BLC_RP1210_DEVICE Struct Reference

  • Data Structure Index
Data Fields
BLC_RP1210_DEVICE Struct Reference

#include <BabyLIN_RP1210.h>

Data Fields

uint32_t | serial_number
uint32_t | hardware_type
int32_t | can_channel_count
short | id
char | name [256]
char | description [256]

Detailed Description

Definition at line 320 of file BabyLIN_RP1210.h.

Field Documentation

int32_t BLC_RP1210_DEVICE::can_channel_count

Definition at line 326 of file BabyLIN_RP1210.h.

char BLC_RP1210_DEVICE::description[256]

Definition at line 333 of file BabyLIN_RP1210.h.

uint32_t BLC_RP1210_DEVICE::hardware_type

Definition at line 324 of file BabyLIN_RP1210.h.

short BLC_RP1210_DEVICE::id

Definition at line 329 of file BabyLIN_RP1210.h.

char BLC_RP1210_DEVICE::name[256]

Definition at line 331 of file BabyLIN_RP1210.h.

uint32_t BLC_RP1210_DEVICE::serial_number

Definition at line 322 of file BabyLIN_RP1210.h.

The documentation for this struct was generated from the following file:
  • C:/JenkinsWS/workspace/orks_v2_LinWorksv2_Windows_trunk/source/externals/BabyLIN/src/libraries/BabyLIN/publicHeaders/BabyLIN_RP1210.h
Generated on Fri May 30 2025 17:16:14 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: SBYTEARRAY Struct Reference

  • Data Structure Index
Data Fields
SBYTEARRAY Struct Reference

#include <BabyLIN_RP1210.h>

Data Fields

unsigned long | NumOfBytes
unsigned char * | pBytes

Detailed Description

Definition at line 261 of file BabyLIN_RP1210.h.

Field Documentation

unsigned long SBYTEARRAY::NumOfBytes

Definition at line 262 of file BabyLIN_RP1210.h.

unsigned char* SBYTEARRAY::pBytes

Definition at line 263 of file BabyLIN_RP1210.h.

The documentation for this struct was generated from the following file:
  • C:/JenkinsWS/workspace/orks_v2_LinWorksv2_Windows_trunk/source/externals/BabyLIN/src/libraries/BabyLIN/publicHeaders/BabyLIN_RP1210.h
Generated on Fri May 30 2025 17:16:14 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: SCONFIG Struct Reference

  • Data Structure Index
Data Fields
SCONFIG Struct Reference

#include <BabyLIN_RP1210.h>

Data Fields

unsigned long | Parameter
unsigned long | Value

Detailed Description

Definition at line 251 of file BabyLIN_RP1210.h.

Field Documentation

unsigned long SCONFIG::Parameter

Definition at line 252 of file BabyLIN_RP1210.h.

unsigned long SCONFIG::Value

Definition at line 253 of file BabyLIN_RP1210.h.

The documentation for this struct was generated from the following file:
  • C:/JenkinsWS/workspace/orks_v2_LinWorksv2_Windows_trunk/source/externals/BabyLIN/src/libraries/BabyLIN/publicHeaders/BabyLIN_RP1210.h
Generated on Fri May 30 2025 17:16:14 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: SCONFIG_LIST Struct Reference

  • Data Structure Index
Data Fields
SCONFIG_LIST Struct Reference

#include <BabyLIN_RP1210.h>

Data Fields

unsigned long Num0fParams
SCONFIG * pConfig

Detailed Description

Definition at line 256 of file BabyLIN_RP1210.h.

Field Documentation

unsigned long SCONFIG_LIST::Num0fParams

Definition at line 257 of file BabyLIN_RP1210.h.

SCONFIG* SCONFIG_LIST::pConfig

Definition at line 258 of file BabyLIN_RP1210.h.

The documentation for this struct was generated from the following file:
  • C:/JenkinsWS/workspace/orks_v2_LinWorksv2_Windows_trunk/source/externals/BabyLIN/src/libraries/BabyLIN/publicHeaders/BabyLIN_RP1210.h
Generated on Fri May 30 2025 17:16:14 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: SDF_SECTIONINFO Struct Reference

  • Data Structure Index
Data Fields
SDF_SECTIONINFO Struct Reference

#include <SDF.h>

Data Fields

int | sectionNr
int | type
char | name [64]
char | description [4096]

Detailed Description

Definition at line 6 of file SDF.h.

Field Documentation

char SDF_SECTIONINFO::description[4096]

Definition at line 11 of file SDF.h.

char SDF_SECTIONINFO::name[64]

Definition at line 10 of file SDF.h.

int SDF_SECTIONINFO::sectionNr

Definition at line 7 of file SDF.h.

int SDF_SECTIONINFO::type

Definition at line 9 of file SDF.h.

The documentation for this struct was generated from the following file:
  • C:/JenkinsWS/workspace/orks_v2_LinWorksv2_Windows_trunk/source/externals/BabyLIN/src/libraries/BabyLIN/publicHeaders/SDF.h
Generated on Fri May 30 2025 17:16:14 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: markdowns/SdfScript/Table.md File Reference

markdowns/SdfScript/Table.md File Reference

Go to the source code of this file.

Generated on Fri May 30 2025 17:16:13 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: markdowns/SdfScript/Table.md Source File

markdowns/SdfScript/Table.md
Go to the documentation of this file.
1 @ingroup script_sdf_obj_table
2
3 ## Description
4 An object represeting a table in the SDF.<br>
5 This object is used to read out or change table values.<br>
6 <br>
7 All functions are callable like this:<br>
8 ~~~~~~~~~~~~~~~{.py}
9 function OnDownloadSection_1(channel)
10 -- tbl may contain a reference to the table at index 0 in the SDF, if the SDF has such a table.
11 local tbl = channel:GetTable(0)
12
13 -- Call "GetId()" function on the table.
14 local tbl_id = tbl:GetId()
15 end
16 ~~~~~~~~~~~~~~~
17
18 # Available Functions
19
20 ## Table:GetId()
21 Returns the SDF index of the table.<br>
22 Needs no arguments.<br>
23 The function returns a single number typed value for the index.<br>
24 <br>
25 <b>Syntax</b>:
26 ~~~~~~~~~~~~~~~{.py}
27 sdf_index = Table:GetId()
28 ~~~~~~~~~~~~~~~
29 <br>
30 <b>Example</b>:
31 ~~~~~~~~~~~~~~~{.py}
32 local table_id = table:GetId()
33 print('Table ID: ', table_id)
34 ~~~~~~~~~~~~~~~
35
36 ## Table:GetRowCount()
37 Returns the number of rows in the table.<br>
38 Needs no arguments.<br>
39 The function returns a single number typed value for the row count.<br>
40 <br>
41 <b>Syntax</b>:
42 ~~~~~~~~~~~~~~~{.py}
43 row_count = Table:GetRowCount()
44 ~~~~~~~~~~~~~~~
45 <br>
46 <b>Examples</b>:
47 ~~~~~~~~~~~~~~~{.py}
48 local tbl_row_count = table:GetRowCount()
49 print('Table has this many rows: ', tbl_row_count)
50 ~~~~~~~~~~~~~~~
51
52 ## Table:GetColumnCount()
53 Returns the number of columns in the table.<br>
54 Needs no arguments.<br>
55 The function returns a single number typed value for the column count.<br>
56 <br>
57 <b>Syntax</b>:
58 ~~~~~~~~~~~~~~~{.py}
59 col_count = Table:GetColumnCount()
60 ~~~~~~~~~~~~~~~
61 <br>
62 <b>Examples</b>:
63 ~~~~~~~~~~~~~~~{.py}
64 local tbl_col_count = table:GetColumnCount()
65 print('Table has this many columns: ', tbl_col_count)
66 ~~~~~~~~~~~~~~~
67
68 ## Table:Read()
69 Returns the value of the given cell in the table.<br>
70 Requires a row and column index as number typed arguments.<br>
71 The function returns either a number or string typed value depending on the SDF column description for the value of the cell.<br>
72 <br>
73 <b>Syntax</b>:
74 ~~~~~~~~~~~~~~~{.py}
75 value = Table:Read(row, column)
76 ~~~~~~~~~~~~~~~
77 <br>
78 <b>Examples</b>:
79 ~~~~~~~~~~~~~~~{.py}
80 -- Reads out the value at row 0 column 1.
81 local value = table:Read(0, 1)
82 print('Table value at row 0 column 1: ', value)
83 ~~~~~~~~~~~~~~~
84
85 ## Table:Write()
86 Writes a value into a cell in the table.<br>
87 Requires a row and column index as number typed arguments, as well as a string or number typed value to write.<br>
88 <i>Note</i>: Writing a string value into a number cell and vise versa, will do nothing, the cell content is not changed in this case.<br>
89 The function does not return anything.<br>
90 <br>
91 <b>Syntax</b>:
92 ~~~~~~~~~~~~~~~{.py}
93 Table:Write(row, column, value)
94 ~~~~~~~~~~~~~~~
95 <br>
96 <b>Examples</b>:
97 ~~~~~~~~~~~~~~~{.py}
98 -- Write a number value of 1234 into row 0 column 1, assuming its a integer column:
99 local value = table:Read(0, 1, 1234)
100
101 -- Write a string value into row 0 column 2, assuming its a string column:
102 local value = table:Read(0, 2, "ExampleString")
103 ~~~~~~~~~~~~~~~
104
105 ## Table:Fill()
106 Fills all cells with a value.<br>
107 Requires a start cell as table type, a end cell as table type and optionally a number and a string type for the values to fill.<br>
108 If the optional value types are not passen, the cells will be filled with 0 or an empty string.<br>
109 The function does not return anything.<br>
110 <br>
111 <b>Syntax</b>:
112 ~~~~~~~~~~~~~~~{.py}
113 Table:Fill({start_row, start_column}, {end_row, end_column}, [number_value, string_value])
114 ~~~~~~~~~~~~~~~
115 <br>
116 <b>Examples</b>:
117 ~~~~~~~~~~~~~~~{.py}
118 -- Fills the cells from row 0 column 0 to row 4 colum 4 with an empty string or 0 depending on the columns type.
119 table:Fill({0, 0}, {4, 4})
120
121 -- Fills the cells from row 0 column 0 to row 4 colum 4 with an empty string or 0 depending on the columns type.
122 table:Fill({0, 0}, {4, 4}, 0, "")
123
124 -- Fills the cells from row 0 column 0 to row 4 colum 4 with the string 'ExampleString' or 1234 depending on the columns type.
125 table:Fill({0, 0}, {4, 4}, 1234, "ExampleString")
126 ~~~~~~~~~~~~~~~
127
128 ## Table:Clear()
129 Clears the table.<br>
130 Needs no arguments.<br>
131 The function does not return anything.<br>
132 <br>
133 This function is equivialent to:
134 ~~~~~~~~~~~~~~~{.py}
135 table:Fill({0, 0}, {table:GetRowCount() - 1, table:GetColumnCount() - 1})
136 ~~~~~~~~~~~~~~~
137 <br>
138 <b>Syntax</b>:
139 ~~~~~~~~~~~~~~~{.py}
140 Table:Clear()
141 ~~~~~~~~~~~~~~~
142 <br>
143 <b>Examples</b>:
144 ~~~~~~~~~~~~~~~{.py}
145 -- Clears the table. All cells will contain either an empty string or 0 depending on the columns type.
146 table:Clear()
147 ~~~~~~~~~~~~~~~
Generated on Fri May 30 2025 17:16:12 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: markdowns/UnifiedAccess/Channel.md File Reference

markdowns/UnifiedAccess/Channel.md File Reference

Go to the source code of this file.

Generated on Fri May 30 2025 17:16:13 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: markdowns/UnifiedAccess/Channel.md Source File

markdowns/UnifiedAccess/Channel.md
Go to the documentation of this file.
1 # The Channel
2 @ingroup ua_channel
3
4
5 You should first read through the @ref ua.<br/>
6 Here all available __Tags__ of a Channel can be looked up.
7 Also all __Tags__ of the @ref ua_section loaded onto this channel can be used.
8
9 #### Child __Tags__
10
11 | __Tag__ | __Type__ | __Description__ |
12 | :--: | :--: | :-- |
13 | `section` | Void | Gets the @ref ua_section loaded by this channel. |
14 | `protocol` | <span style="white-space: nowrap;">32bit Number</span><br>String | Find a @ref ua_protocol_iso_tp by index or name. |
15
16 #### Create Child __Tags__
17
18 | __Tag__ | __Child Tag__| __Description__ |
19 | :--: | :--: | :-- |
20 | `new_iso_tp_protocol` | `protocol`| creates a new @ref ua_protocol_iso_tp |
21
22 #### Property __Tags__
23
24 | __Tag__ | Default Value | __Type__ | __Description__ |
25 | :--: | :--: | :--: | :-- |
26 | `name` | <> | String | The name, by which this channel can be found. |
27 | `index` | <> | <span style="white-space: nowrap;">32bit Number</span> | The Channel's index in the @ref ua_device 's `channel` list. |
28 | `max_baudrate_supported` | <> | <span style="white-space: nowrap;">32bit Number</span> | The maximal Baudrate this Channel supports. |
29 | `protocol_count` | <> | <span style="white-space: nowrap;">32bit Number</span> | the amount of available [Protocols](@ref ua_protocol_iso_tp) in this channel |
Generated on Fri May 30 2025 17:16:12 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: markdowns/UnifiedAccess/UnifiedAccess.md File Reference

markdowns/UnifiedAccess/UnifiedAccess.md File Reference

Go to the source code of this file.

Generated on Fri May 30 2025 17:16:13 for BabyLIN Library by doxygen 1.8.6


BabyLIN Library: markdowns/UnifiedAccess/UnifiedAccess.md Source File

markdowns/UnifiedAccess/UnifiedAccess.md
Go to the documentation of this file.
1 # Unified Access
2 @ingroup ua
3
4 The tree currently exposed by the Unified Access interface:
5 ![Object Tree Structure](@ref UnifiedAccessTree.png "Object tree structure")
6
7 To use spaces in the value part of a __key value pair__ strings can be escaped by &quot; or ' for example __Tag__="some text" or __Tag__='some text'. Also for escaped sequences the space between __key value pairs__ is mandatory.
8
9 #### The Create __Tags__ Table
10
11 Most Objects have to be created before they can be used. Exceptions such as [Channels](@ref ua_channel) exist, they are created once the connection to the device is established.
12 The permitted __Tags__ are described for each Object in a table like this one:
13
14 | __Tag__ | __Child Tag__ | __Description__ |
15 | :--: | :--: | :-- |
16 | The exact tag for this child category | The child __Tag__ the newly created Object will be available in. | A description, stating what exact Object will be created. |
17
18 #### The Child __Tags__ Table
19
20 For every existing Object, a handle can be retrieved by using the respective child __Tag__ for the Objects type, on it's parent.
21 The permitted __Tags__ are described for each Object in a table like this one:
22
23 | __Tag__ | __Type__ | __Description__ |
24 | :--: | :--: | :-- |
25 | The exact tag for this child category | 32bit Number if the child can be selected by index<br>String if the child can be selected by name | A description of the child category. |
26
27 #### The Property __Tags__ Table
28
29 Every Object does have properties, to read and write. They can be read or modified by using the respective __Tag__ in a getter or setter.
30 The permitted __Tags__ are described for each Object in a table like this one:
31
32 | __Tag__ | __Default Value__ | __Type__ | __Description__ |
33 | :--: | :--: | :--: | :-- |
34 |The exact tag for this child category | A Number (e.g. 1)<br>A Boolean (e.g. false)<br>A String (e.g. "example")<br>A Binary (e.g. [1,2,3])<br>Uninitialized (<>) | \<n>bit Number if it can be accessed as a number.<br>Boolean is an alias for a 1bit Number, using 0 as false and 1 as true.<br>String it can be accessed as a text.<br>Binary if it can be accessed as an Array.<br>Callback if a callback can be set. | A description of what the property does. |
35
36 #### The Method __Tags__ Table
37
38 More complex operations are performed by the @ref BLC_execute function.
39 The permitted __Tags__ are described for each Object in a table like this one:
40
41 | __Tag__ | __Parameters__ | __Description__ |
42 | :--: | :--: | :-- |
43 |The exact tag for this child category | A tag for every parameter and its data type e.g. (timeout=64bit Number) | A description of what the method does. The returned values are also documented here. Returned values documented in the [BabyLINReturncodes.h](@ref return_values) are not explicitly listed. |
BLC_execute
int32_t BL_DLLIMPORT BLC_execute(BL_HANDLE handle, const char *path)
BLC_execute executes a method of the given handle.
Generated on Fri May 30 2025 17:16:13 for BabyLIN Library by doxygen 1.8.6